Bitcoin Forum
December 03, 2016, 04:50:08 AM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 [19] 20 »  All
  Print  
Author Topic: CGminer v3.8.5 on Broadcom based DD-WRT / OpenWRT  (Read 70394 times)
-ck
Moderator
Legendary
*
Offline Offline

Activity: 1988


Ruu \o/


View Profile WWW
December 09, 2013, 07:45:15 PM
 #361

Same error as last time. LIBUSB_ERROR_NOT_SUPPORTED  Angry
I know what this is likely to be. Fixed in git, version 3.8.5 cgminer, when it's out, should have it fixed.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
Pooled mine at kano.is, solo mine at solo.ckpool.org
-ck
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480740608
Hero Member
*
Offline Offline

Posts: 1480740608

View Profile Personal Message (Offline)

Ignore
1480740608
Reply with quote  #2

1480740608
Report to moderator
P_Shep
Legendary
*
Offline Offline

Activity: 924


View Profile WWW
December 09, 2013, 08:00:59 PM
 #362

Oh great, Thanks Con. Smiley
daurwid
Newbie
*
Offline Offline

Activity: 7

Just Another IT Guy!


View Profile WWW
December 10, 2013, 04:55:36 PM
 #363

Boo  Angry
Same error as last time. LIBUSB_ERROR_NOT_SUPPORTED  Angry
Back to 3.6.1 again.

I rolled back to 3.6.3 per P_Shep's suggestion.  I have had no problems since.  Hopefully ckolivas can figure out what's going on with the newer versions.  I tested 3.7.x & 3.8.x versions but could not get them to detect my BFL MiniRig SC.
OtaconEmmerich
Full Member
***
Offline Offline

Activity: 237



View Profile
December 10, 2013, 05:20:32 PM
 #364

Thanks for all the effort you do Con, and Thanks for compiling these Shep. Whenever you get to 3.8.5 I'll give it a go again.

Also I ment 3.6.3  in the last post, Which has been stable sense I upgraded my firmware and reinstalled Optware fresh and will stay that way I hope.
P_Shep
Legendary
*
Offline Offline

Activity: 924


View Profile WWW
December 10, 2013, 10:10:58 PM
 #365

OK, here it is:

https://www.dropbox.com/s/4oik0ecfezclq9u/cgminer_3.8.5_mipsel.ipk

Working for me right now.
OtaconEmmerich
Full Member
***
Offline Offline

Activity: 237



View Profile
December 10, 2013, 11:56:44 PM
 #366

Oh boy, Guess what?   Undecided
Code:
[2013-12-10 15:47:55] Started cgminer 3.8.5
 [2013-12-10 15:47:57] Probing for an alive pool
 [2013-12-10 15:47:58] Pool 0 difficulty changed to 2
 [2013-12-10 15:47:59] Network diff set to 908M
 [2013-12-10 15:49:18] AMU 5 SendWork usb write err:(-7) LIBUSB_ERROR_TIMEOUT   
 [2013-12-10 15:49:18] AMU 2 SendWork usb write err:(-7) LIBUSB_ERROR_TIMEOUT   
 [2013-12-10 15:49:18] AMU 4 SendWork usb write err:(-7) LIBUSB_ERROR_TIMEOUT   
 [2013-12-10 15:49:18] AMU 3 SendWork usb write err:(-7) LIBUSB_ERROR_TIMEOUT   
 [2013-12-10 15:50:45] AMU 5 attempted reset got err:(-5) LIBUSB_ERROR_NOT_FOUND
 [2013-12-10 15:50:45] AMU5: Comms error (werr=-5 amt=0)
 [2013-12-10 15:50:45] AMU 5 failure, disabling!
(5s):883.3M (avg):1.253Gh/s | A:0  R:0  HW:0  WU:0.0/m
It tries to mine, but 1 second after Network Diff shows up it all goes green(as in all the LED's on my BE's turn green)
It seems like at least it's TRYING to work but something hitches, Back to 3.6.3 and restarting every ~24 hours.
daurwid
Newbie
*
Offline Offline

Activity: 7

Just Another IT Guy!


View Profile WWW
December 11, 2013, 09:31:37 PM
 #367


Installed and seems to be running.  I'll report on it after 24 hours have passed.
miniminemo
Newbie
*
Offline Offline

Activity: 3


View Profile
December 12, 2013, 12:40:59 PM
 #368

I have an Asus RT N16 with ddwrt and a 5GH/s BFL miner.

I'm following the instructions posted at
http://pastebin.com/hwgm3kEe and
https://109.201.133.195/index.php?topic=76685.msg3911947

When starting cgminer I get:
  root@DD-WRT:/opt# cgminer
 [2013-12-12 05:41:53] Started cgminer 3.8.5                   
 [2013-12-12 05:41:53] Failed to sem_wait errno=89 cgsem=0x0x5061c8 in usbutils.c usb_resource_thread():3651

Not sure if I set up the usb libs properly, here is what I have
root@DD-WRT:/opt/lib# ls | grep libusb
libusb-0.1.so.4
libusb-0.1.so.4.4.4
libusb-1.0.so
libusb-1.0.so.0
libusb-1.0.so.0.1.0
libusb.so

root@DD-WRT:/opt/lib# ls -lR . | grep ^l
lrwxrwxrwx 1 root root      19 Dec 12 05:55 libusb-0.1.so.4 -> libusb-0.1.so.4.4.4
lrwxrwxrwx 1 root root      19 Dec 12 05:24 libusb-1.0.so -> libusb-1.0.so.0.1.0
lrwxrwxrwx 1 root root      19 Dec 12 04:31 libusb-1.0.so.0 -> libusb-1.0.so.0.1.0

Any ideas what could be the problem?
   
P_Shep
Legendary
*
Offline Offline

Activity: 924


View Profile WWW
December 12, 2013, 01:12:08 PM
 #369

I have an Asus RT N16 with ddwrt and a 5GH/s BFL miner.

I'm following the instructions posted at
http://pastebin.com/hwgm3kEe and
https://109.201.133.195/index.php?topic=76685.msg3911947

When starting cgminer I get:
  root@DD-WRT:/opt# cgminer
 [2013-12-12 05:41:53] Started cgminer 3.8.5                   
 [2013-12-12 05:41:53] Failed to sem_wait errno=89 cgsem=0x0x5061c8 in usbutils.c usb_resource_thread():3651

Not sure if I set up the usb libs properly, here is what I have
root@DD-WRT:/opt/lib# ls | grep libusb
libusb-0.1.so.4
libusb-0.1.so.4.4.4
libusb-1.0.so
libusb-1.0.so.0
libusb-1.0.so.0.1.0
libusb.so

root@DD-WRT:/opt/lib# ls -lR . | grep ^l
lrwxrwxrwx 1 root root      19 Dec 12 05:55 libusb-0.1.so.4 -> libusb-0.1.so.4.4.4
lrwxrwxrwx 1 root root      19 Dec 12 05:24 libusb-1.0.so -> libusb-1.0.so.0.1.0
lrwxrwxrwx 1 root root      19 Dec 12 04:31 libusb-1.0.so.0 -> libusb-1.0.so.0.1.0

Any ideas what could be the problem?
   

Well that should work OK. You don't need to worry about libusb though, cgminer is statically compiled.
To run straight from the cmd line, you may need to reset the library path:
unset LD_LIBRARY_PATH
unset LD_PRELOAD
daurwid
Newbie
*
Offline Offline

Activity: 7

Just Another IT Guy!


View Profile WWW
December 12, 2013, 03:15:37 PM
 #370

uptime on router 8 hrs, still running and uses very little resources. 3.8.5.
miniminemo
Newbie
*
Offline Offline

Activity: 3


View Profile
December 13, 2013, 02:15:18 AM
 #371

I have an Asus RT N16 with ddwrt and a 5GH/s BFL miner.

I'm following the instructions posted at
http://pastebin.com/hwgm3kEe and
https://109.201.133.195/index.php?topic=76685.msg3911947

When starting cgminer I get:
  root@DD-WRT:/opt# cgminer
 [2013-12-12 05:41:53] Started cgminer 3.8.5                   
 [2013-12-12 05:41:53] Failed to sem_wait errno=89 cgsem=0x0x5061c8 in usbutils.c usb_resource_thread():3651

Not sure if I set up the usb libs properly, here is what I have
root@DD-WRT:/opt/lib# ls | grep libusb
libusb-0.1.so.4
libusb-0.1.so.4.4.4
libusb-1.0.so
libusb-1.0.so.0
libusb-1.0.so.0.1.0
libusb.so

root@DD-WRT:/opt/lib# ls -lR . | grep ^l
lrwxrwxrwx 1 root root      19 Dec 12 05:55 libusb-0.1.so.4 -> libusb-0.1.so.4.4.4
lrwxrwxrwx 1 root root      19 Dec 12 05:24 libusb-1.0.so -> libusb-1.0.so.0.1.0
lrwxrwxrwx 1 root root      19 Dec 12 04:31 libusb-1.0.so.0 -> libusb-1.0.so.0.1.0

Any ideas what could be the problem?
   

Well that should work OK. You don't need to worry about libusb though, cgminer is statically compiled.
To run straight from the cmd line, you may need to reset the library path:
unset LD_LIBRARY_PATH
unset LD_PRELOAD

I tried unsetting the path and after running cgminer it prints out the semwait error then exits.
No difference when I run: service cgminer start.
This is what I get when listing the usb devices:

root@DD-WRT:~# ls -l /dev/usb/tts/
total 0
crw------- 1 root root 188, 0 Jan  1  1970 0

Any ideas about what's wrong?


 
OtaconEmmerich
Full Member
***
Offline Offline

Activity: 237



View Profile
December 13, 2013, 12:12:28 PM
 #372

uptime on router 8 hrs, still running and uses very little resources. 3.8.5.
What router model and what firmware if you wouldn't mind sharing.
P_Shep
Legendary
*
Offline Offline

Activity: 924


View Profile WWW
December 13, 2013, 03:18:33 PM
 #373


I tried unsetting the path and after running cgminer it prints out the semwait error then exits.
No difference when I run: service cgminer start.
This is what I get when listing the usb devices:

root@DD-WRT:~# ls -l /dev/usb/tts/
total 0
crw------- 1 root root 188, 0 Jan  1  1970 0

Any ideas about what's wrong?


 

No idea at all. That's the set up I have. My RT-N16 is running Kong mod build 21395M and OTRW2.

And tty won't list anything, the drivers aren't installed or used anymore. cgminer communicates directly with the device via libusb.
daurwid
Newbie
*
Offline Offline

Activity: 7

Just Another IT Guy!


View Profile WWW
December 13, 2013, 08:25:57 PM
 #374

uptime on router 8 hrs, still running and uses very little resources. 3.8.5.

Update.  Stability problems.  Log file shows this as error:

Quote
[2013-12-13 13:06:08] BAS0: GetResults failed no data returned  (err=0 amt=0)
 [2013-12-13 13:06:08] BAS0: RequestQueJobStatus failed no data returned  (err=0 amt=0)
 [2013-12-13 13:06:09] BAS 0 RequestResults usb write err:(-7) LIBUSB_ERROR_TIMEOUT
 [2013-12-13 13:06:09] BAS 0 attempted reset got err:(0) LIBUSB_SUCCESS / LIBUSB_TRANSFER_COMPLETED
 [2013-12-13 13:06:09] BAS0: RequestResults failed no data returned  (err=0 amt=0)
 [2013-12-13 13:06:09] BAS0: GetResults failed no data returned  (err=0 amt=0)
 [2013-12-13 13:06:10] BAS0: GetResults failed (err=-7 amt=0)
 [2013-12-13 13:06:10] BAS 0 RequestQueJob usb write err:(-7) LIBUSB_ERROR_TIMEOUT
 [2013-12-13 13:06:10] BAS 0 attempted reset got err:(0) LIBUSB_SUCCESS / LIBUSB_TRANSFER_COMPLETED
 [2013-12-13 13:06:10] BAS0: RequestQueJob failed no data returned  (err=0 amt=0)
 [2013-12-13 13:06:11] BAS0: GetResults failed no data returned  (err=0 amt=0)
 [2013-12-13 13:06:11] BAS0: GetResults failed (err=-7 amt=0)
 

Over time this would cause the router to reboot or force the service to restart.  Lots issues with router as well (attempting to use VPN was becoming a problem).

Rolled back to 3.6.3.

I'm running Kongmod 22200M + OTRW2.
P_Shep
Legendary
*
Offline Offline

Activity: 924


View Profile WWW
December 15, 2013, 09:27:22 PM
 #375

Running for just shy of 5 days now for me.

Getting a few 'BAS0: empty result...', but not too many.
daurwid
Newbie
*
Offline Offline

Activity: 7

Just Another IT Guy!


View Profile WWW
December 16, 2013, 04:19:33 PM
 #376

uptime on router 8 hrs, still running and uses very little resources. 3.8.5.
What router model and what firmware if you wouldn't mind sharing.

E3000 (WRT610Nv2 converted to E3000)+ KONGMOD 22200M + OTRW2

I also noticed that this optware was loading transmission_daemon which i had to disable the service as well as edit the /opt/etc/init.d/K90transmission and comment out line #129 which would run a gunzip process at 100% cpu at start.
Jaslynn
Member
**
Offline Offline

Activity: 73


View Profile
December 17, 2013, 12:38:51 PM
 #377

cgminer_3.8.5 running without a problem! Loving it
P_Shep
Legendary
*
Offline Offline

Activity: 924


View Profile WWW
December 19, 2013, 02:23:07 PM
 #378

Hmm, after 8 days or so without problem, suddenly bad things are happening.

Might have to go back to 3.6.3 also.
crazyates
Legendary
*
Offline Offline

Activity: 938



View Profile
December 22, 2013, 04:23:22 PM
 #379

Hmm, after 8 days or so without problem, suddenly bad things are happening.

Might have to go back to 3.6.3 also.

I picked up a WNDR3700v4 for $30 a few days ago, but didn't realize it's an Atheros mipseb SoC, not a Broadcom MIPSEL chip.

So then I got a WNR3500Lv2, which will be here in a few days. It's about the only broadcom MIPSEL I could find with 128MB RAM, 128MB Flash, and still only $30 on fleabay.

Maybe things will go smoother this time. Wink Should I start with your suggested 3.6.3, or go with the newest 3.8.5? It'll only be controlling SC Singles.

Tips? 1crazy8pMqgwJ7tX7ZPZmyPwFbc6xZKM9
Previous Trade History - Sale Thread
P_Shep
Legendary
*
Offline Offline

Activity: 924


View Profile WWW
December 22, 2013, 04:52:58 PM
 #380

Maybe stick with 3.6.3. Not sure there's much advantage with 3.8.5
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 [19] 20 »  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!