Bitcoin Forum
July 14, 2024, 05:30:39 PM *
News: Latest Bitcoin Core release: 27.0 [Torrent]
 
   Home   Help Search Login Register More  

Warning: Moderators do not remove likely scams. You must use your own brain: caveat emptor. Watch out for Ponzi schemes. Do not invest more than you can afford to lose.

Warning: One or more bitcointalk.org users have reported that they strongly believe that the creator of this topic is a scammer. (Login to see the detailed trust ratings.) While the bitcointalk.org administration does not verify such claims, you should proceed with extreme caution.
Pages: « 1 2 3 4 5 6 7 [8] 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 ... 65 »
  Print  
Author Topic: [BitFunder] Asset Exchange Marketplace + Rewritable Options Trading  (Read 129232 times)
Deprived
Hero Member
*****
Offline Offline

Activity: 532
Merit: 500


View Profile
January 29, 2013, 09:21:47 PM
 #141

Reserved amounts are now totally wrong.

It shows a reserved amount of  ฿0.5186460 for me on all assets - whether I have zero bids on them or a lot more than .5 BTC in bids.

This problem still exists.

It nows shows a reserved amount of ฿6.46497350 for me on all assets - whether or not I have any bids at all on them.

I'd guess that it's displaying the reserved amount I have on some security - whether or not it's the one I'm actually looking at.  It's entirely likely I DO have that exact amount in bids on some security.

Unfortunately it's also now rejecting bids at the server based on that amount.
Ukyo (OP)
Sr. Member
****
Offline Offline

Activity: 448
Merit: 250



View Profile
January 29, 2013, 10:48:38 PM
 #142

Reserved amounts are now totally wrong.

It shows a reserved amount of  ฿0.5186460 for me on all assets - whether I have zero bids on them or a lot more than .5 BTC in bids.

This problem still exists.

It nows shows a reserved amount of ฿6.46497350 for me on all assets - whether or not I have any bids at all on them.

I'd guess that it's displaying the reserved amount I have on some security - whether or not it's the one I'm actually looking at.  It's entirely likely I DO have that exact amount in bids on some security.

Unfortunately it's also now rejecting bids at the server based on that amount.

This is correct.
I had picked a few accounts to allow them to reserve on a per asset basis to test with, yours being one of them since you asked for the feature.
As stated in irc and another thread, I have decided against the per-asset reserve funding reserves.
It does not add any real liquidity to the system in my and many others opinions, it just offers a false pretense of that liquidity.

Once you bring your total reserve under your balance you will be able to place more orders on the books once again.
This goes for the other few users who are in the same situation.

There may be a reserves bug, and if someone notices the system adding/removing incorrect reserves based on their orders please let me know.
I have not been able to duplicate such thing on the sandbox which uses the exact same code at this time.
Ukyo (OP)
Sr. Member
****
Offline Offline

Activity: 448
Merit: 250



View Profile
January 30, 2013, 05:54:36 AM
 #143

Reserved amounts are now totally wrong.

It shows a reserved amount of  ฿0.5186460 for me on all assets - whether I have zero bids on them or a lot more than .5 BTC in bids.

This problem still exists.

It nows shows a reserved amount of ฿6.46497350 for me on all assets - whether or not I have any bids at all on them.

I'd guess that it's displaying the reserved amount I have on some security - whether or not it's the one I'm actually looking at.  It's entirely likely I DO have that exact amount in bids on some security.

Unfortunately it's also now rejecting bids at the server based on that amount.

This is correct.
I had picked a few accounts to allow them to reserve on a per asset basis to test with, yours being one of them since you asked for the feature.
As stated in irc and another thread, I have decided against the per-asset reserve funding reserves.
It does not add any real liquidity to the system in my and many others opinions, it just offers a false pretense of that liquidity.

Once you bring your total reserve under your balance you will be able to place more orders on the books once again.
This goes for the other few users who are in the same situation.

There may be a reserves bug, and if someone notices the system adding/removing incorrect reserves based on their orders please let me know.
I have not been able to duplicate such thing on the sandbox which uses the exact same code at this time.

I have cancelled all my buy orders, but it still says I have some reserved, I think this is a bug?

Ah hah! Let me take a look at the debug. Smiley
Ukyo (OP)
Sr. Member
****
Offline Offline

Activity: 448
Merit: 250



View Profile
January 30, 2013, 06:00:57 AM
 #144

You should be good now Peter.

I am going to be adding a full range of debugs on the 3 places in the code where reserves are handled tonight to track it down easier.

Thanks Smiley
Ukyo (OP)
Sr. Member
****
Offline Offline

Activity: 448
Merit: 250



View Profile
February 01, 2013, 08:56:23 PM
 #145

I cancelled some orders and the funds are stuck in reserve, help please.

This was corrected earlier. Smiley
EskimoBob
Legendary
*
Offline Offline

Activity: 910
Merit: 1000


Quality Printing Services by Federal Reserve Bank


View Profile
February 02, 2013, 09:43:52 PM
 #146


Any plans to clear up this mess? Smiley
How many "Price" can you have there?

I think that this is one of the most annoying "features" of bitfunder. This can be fixed by using "standard" terminology. You got about 3 "price" labels to many in that box.
 
After you have fixed that, can you please drop this cross eyed BS - having Buy and Sell boxes, above "wrong" columns - or to be more precise, you show Ask price in "buy" window above Bid column. Your Sell is above Ask column,  but uses prices form Bid column.
It looks and feels wrong and is counter intuitive - aka bad usability Smiley

While reading what I wrote, use the most friendliest and relaxing voice in your head.
BTW, Things in BTC bubble universes are getting ugly....
Peter Lambert
Hero Member
*****
Offline Offline

Activity: 756
Merit: 500

It's all fun and games until somebody loses an eye


View Profile
February 03, 2013, 12:24:23 PM
 #147

When placing an order, currently it says "Trade complete", even when no trade happens. When an order is put onto the book, it should say something like "Order placed successfully", I keep seeing that "trade complete" message and saying to myself "oh, crap, I didn't want to sell at the current prices, what did my fat fingers do?"

Use CoinBR to trade bitcoin stocks: CoinBR.com

The best place for betting with bitcoin: BitBet.us
Ukyo (OP)
Sr. Member
****
Offline Offline

Activity: 448
Merit: 250



View Profile
February 03, 2013, 08:36:56 PM
 #148

When placing an order, currently it says "Trade complete", even when no trade happens. When an order is put onto the book, it should say something like "Order placed successfully", I keep seeing that "trade complete" message and saying to myself "oh, crap, I didn't want to sell at the current prices, what did my fat fingers do?"

Ahh, actually this is my fault because I had fixed this. But for only one type of trade.
It should say "Trade completed and/or posted!". Which I have put up now.

In the future I will have it display a box that tells you What was immediately purchased/sold, and what was posted.

Thanks for letting me know! Smiley
Ukyo (OP)
Sr. Member
****
Offline Offline

Activity: 448
Merit: 250



View Profile
February 05, 2013, 03:36:46 AM
 #149

I am glad to say that thanks to Usagi's help the reserves issue has now been corrected.

Only 3 people have incorrect reserves balances at the moment, and they are the per-asset reserve testers.

To be able to place more orders again, they will need to cancel orders below their current balance.

If these users have not opted to cancel the bids on their own within 3 days, I will cancel them starting with the highest costs until the are at or below balance.
Ukyo (OP)
Sr. Member
****
Offline Offline

Activity: 448
Merit: 250



View Profile
February 06, 2013, 08:28:51 PM
 #150

Random suggestion:

Asset transfers currently only show up in the transaction history. I would like to see them in the My Assets -> Trade History section.
Could you create a yellow button for and place transfers into the Type column titled "transfer" and allow us to insert the Price Per ?

Wonderful idea, I will look into adding it in. Smiley
tulkos
Member
**
Offline Offline

Activity: 74
Merit: 10



View Profile
February 07, 2013, 05:00:30 AM
 #151

I can no longer connect using a secure connection, is it just me or the site?

🏰 TradeFortress 🏰
Bitcoin Veteran
VIP
Legendary
*
Offline Offline

Activity: 1316
Merit: 1043

👻


View Profile
February 07, 2013, 05:09:35 AM
 #152

I can no longer connect using a secure connection, is it just me or the site?
Same :/
Ukyo (OP)
Sr. Member
****
Offline Offline

Activity: 448
Merit: 250



View Profile
February 07, 2013, 05:10:26 AM
 #153

I can no longer connect using a secure connection, is it just me or the site?

One of our upstream providers thought it would be funny to block all port 443 traffic passing through their network.
I just de-peered the network and things should resume.

I have enabled people to use http://bitfunder.com for the meantime.

Only a few people who happened to be routing through them will be affected.
burnside
Legendary
*
Offline Offline

Activity: 1106
Merit: 1006


Lead Blockchain Developer


View Profile WWW
February 07, 2013, 07:08:47 AM
Last edit: February 07, 2013, 07:50:54 AM by burnside
 #154

I can no longer connect using a secure connection, is it just me or the site?

One of our upstream providers thought it would be funny to block all port 443 traffic passing through their network.
I just de-peered the network and things should resume.

I have enabled people to use http://bitfunder.com for the meantime.

Only a few people who happened to be routing through them will be affected.

Whoa, what provider?

Edit/add:

I don't know if this helps or not, but I'm seeing the issue over your nlayer peer:

  5    24 ms    24 ms    23 ms  cr2.la2ca.ip.att.net [12.123.30.250]
  6    21 ms    39 ms    23 ms  gar29.la2ca.ip.att.net [12.122.129.233]
  7    21 ms    38 ms    22 ms  ae-6.r05.lsanca03.us.bb.gin.ntt.net [129.250.9.5]
  8    34 ms    26 ms    47 ms  xe-3-0-1.ar1.lax2.us.nlayer.net [69.31.127.182]
  9    53 ms    19 ms    18 ms  ae1-80g.cr1.lax1.us.nlayer.net [69.31.127.129]
 10    32 ms    26 ms    22 ms  ae2-50g.ar1.lax1.us.nlayer.net [69.31.127.142]
 11    38 ms    34 ms    19 ms  as13335.xe-11-0-6.ar1.lax1.us.nlayer.net [69.31.125.106]
 12    27 ms    38 ms    44 ms  108.162.197.89

Cheers.
Ukyo (OP)
Sr. Member
****
Offline Offline

Activity: 448
Merit: 250



View Profile
February 07, 2013, 08:21:45 AM
 #155

The issue was originally routing through XO/Allegiance Telecom where they were blocking/breaking all HTTPS traffic.
I have a ticket open with one of the providers and they are working to isolate and correct it. HTTPS on BitFunder works fine.
A source in the middle is currently causing a connection refused.
romerun
Legendary
*
Offline Offline

Activity: 1078
Merit: 1002


Bitcoin is new, makes sense to hodl.


View Profile
February 07, 2013, 09:18:48 AM
 #156

so am I affected
Ukyo (OP)
Sr. Member
****
Offline Offline

Activity: 448
Merit: 250



View Profile
February 07, 2013, 09:23:00 AM
 #157

so am I affected

If you feel safe, you can use http://bitfunder.com

I just got word that the problem network has been identified, and that they are attempting to contact them to resolve it. It is not limited to just this one site.
My understanding is that if they do not get a resolution soon they will make routing changes.
romerun
Legendary
*
Offline Offline

Activity: 1078
Merit: 1002


Bitcoin is new, makes sense to hodl.


View Profile
February 07, 2013, 09:59:33 AM
 #158

nah, I rather wait, unless you can enable SSL on another port if the problem is to persist for a while
Ukyo (OP)
Sr. Member
****
Offline Offline

Activity: 448
Merit: 250



View Profile
February 07, 2013, 01:20:26 PM
 #159

nah, I rather wait, unless you can enable SSL on another port if the problem is to persist for a while

The problem should be fixed now.
SpaceJelly
Member
**
Offline Offline

Activity: 106
Merit: 10



View Profile
February 07, 2013, 01:26:55 PM
 #160

nah, I rather wait, unless you can enable SSL on another port if the problem is to persist for a while

The problem should be fixed now.

Yup, working again here Smiley

1Je11yL4Fqw5nvaP6KUs2JDABBp29vKeEU
1JeLLyv8o7YwooSg53qEdDSPXeAT3ShQoc
Pages: « 1 2 3 4 5 6 7 [8] 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 ... 65 »
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!