Bitcoin Forum
May 27, 2022, 06:55:33 PM *
News: Latest Bitcoin Core release: 23.0 [Torrent]
 
   Home   Help Search Login Register More  
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 [27] 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 »
  Print  
Author Topic: [ANN] lolMiner-mnx, Mining MinexCoin(MNX) New version: v0.4 (July 22)  (Read 30561 times)
rutra69
Newbie
*
Offline Offline

Activity: 6
Merit: 0


View Profile
March 14, 2018, 01:21:09 AM
 #521

 When i start 6x1070ti+1x1070 - My hashrate LOW... (7x110000sol) when i star only one CARD in rig - hash rate is good.(1x18000sol) why?? in benchmark mode too...
this devices automaticaly on platform 1, on the platform 0 i have INTEL HD. (Maybe this is somehow connected with this)
1653677733
Hero Member
*
Offline Offline

Posts: 1653677733

View Profile Personal Message (Offline)

Ignore
1653677733
Reply with quote  #2

1653677733
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1653677733
Hero Member
*
Offline Offline

Posts: 1653677733

View Profile Personal Message (Offline)

Ignore
1653677733
Reply with quote  #2

1653677733
Report to moderator
1653677733
Hero Member
*
Offline Offline

Posts: 1653677733

View Profile Personal Message (Offline)

Ignore
1653677733
Reply with quote  #2

1653677733
Report to moderator
1653677733
Hero Member
*
Offline Offline

Posts: 1653677733

View Profile Personal Message (Offline)

Ignore
1653677733
Reply with quote  #2

1653677733
Report to moderator
jezined
Newbie
*
Offline Offline

Activity: 23
Merit: 0


View Profile
March 14, 2018, 09:12:42 AM
 #522

When i start 6x1070ti+1x1070 - My hashrate LOW... (7x110000sol) when i star only one CARD in rig - hash rate is good.(1x18000sol) why?? in benchmark mode too...
this devices automaticaly on platform 1, on the platform 0 i have INTEL HD. (Maybe this is somehow connected with this)

what is the output from --list-devices ?

and are you starting it with the options --platform and --device set correctly?

Windows or Linux?

on my Linux box I run 3 separate instances of lolMiner, one for each device (2 x Nividia and 1 x Intel)
_gaf
Newbie
*
Offline Offline

Activity: 18
Merit: 0


View Profile
March 14, 2018, 09:30:20 AM
 #523

@Lolliedieb

Are you planning to add API status in your miner? I think that's very important part of tool.
rutra69
Newbie
*
Offline Offline

Activity: 6
Merit: 0


View Profile
March 14, 2018, 10:19:59 AM
 #524

When i start 6x1070ti+1x1070 - My hashrate LOW... (7x110000sol) when i star only one CARD in rig - hash rate is good.(1x18000sol) why?? in benchmark mode too...
this devices automaticaly on platform 1, on the platform 0 i have INTEL HD. (Maybe this is somehow connected with this)

what is the output from --list-devices ?

and are you starting it with the options --platform and --device set correctly?

Windows or Linux?

on my Linux box I run 3 separate instances of lolMiner, one for each device (2 x Nividia and 1 x Intel)

1. list device
Auto selecting platform with id 1: NVIDIA CUDA
Auto selecting all gpu in platform.
USING device with 0 (GeForce 1070 ti)
USING device with 1 (GeForce 1070 ti)
USING device with 2 (GeForce 1070)
USING device with 3 (GeForce 1070 ti)
USING device with 4 (GeForce 1070 ti)
USING device with 5 (GeForce 1070 ti)
USING device with 6 (GeForce 1070 ti)

platform and --device set AUTO, and i try :platform 1 , device 0,1,2,3,4,5,6,

Win 10
ninjam
Newbie
*
Offline Offline

Activity: 84
Merit: 0


View Profile
March 14, 2018, 10:50:16 AM
 #525

@Lolliedieb
With previous versions, did not had this kind of problem on nvidia rig, not even 0 sol error.
Tried exit-on-error option, and nothing changed, but when added option for timeout in the loop - it can be seen that actually miner was closing itself and starting indefinitely, cannot be seen when there is no timeout in the loop.
Last night miner again stuck in the middle of the night.
As workaround made some script to detect this stuck state and restart rig, as only this fixes problem, restarting miner does not help.

jezined
Newbie
*
Offline Offline

Activity: 23
Merit: 0


View Profile
March 14, 2018, 11:25:44 AM
 #526

When i start 6x1070ti+1x1070 - My hashrate LOW... (7x110000sol) when i star only one CARD in rig - hash rate is good.(1x18000sol) why?? in benchmark mode too...
this devices automaticaly on platform 1, on the platform 0 i have INTEL HD. (Maybe this is somehow connected with this)

what is the output from --list-devices ?

and are you starting it with the options --platform and --device set correctly?

Windows or Linux?

on my Linux box I run 3 separate instances of lolMiner, one for each device (2 x Nividia and 1 x Intel)

1. list device
Auto selecting platform with id 1: NVIDIA CUDA
Auto selecting all gpu in platform.
USING device with 0 (GeForce 1070 ti)
USING device with 1 (GeForce 1070 ti)
USING device with 2 (GeForce 1070)
USING device with 3 (GeForce 1070 ti)
USING device with 4 (GeForce 1070 ti)
USING device with 5 (GeForce 1070 ti)
USING device with 6 (GeForce 1070 ti)

platform and --device set AUTO, and i try :platform 1 , device 0,1,2,3,4,5,6,

Win 10

The output should looks more like this from my laptop which has an on-board Nvidia M1200 and external GTX 1060:

All available OpenCL platforms and devices:

Platform 0: NVIDIA CUDA
    Device 0: GeForce GTX 1060 3GB (GPU)
    Device 1: Quadro M1200 (GPU)
Platform 1: Intel(R) OpenCL
    Device 0: Intel(R) HD Graphics (GPU)
    Device 1: Intel(R) Core(TM) i7-7820HQ CPU @ 2.90GHz (CPU)


What you have copied looks to be from your attempt to start up lolMiner with no platform or devices set.

Try again, but this time run:
lolMiner-mnx.exe --list-devices




Lolliedieb
Member
**
Offline Offline

Activity: 432
Merit: 45


View Profile WWW
March 14, 2018, 11:46:14 AM
 #527

When i start 6x1070ti+1x1070 - My hashrate LOW... (7x110000sol) when i star only one CARD in rig - hash rate is good.(1x18000sol) why?? in benchmark mode too...
this devices automaticaly on platform 1, on the platform 0 i have INTEL HD. (Maybe this is somehow connected with this)

The latter is fine - for most Windows systems we have platform 1 when an Intel CPU is there.

Can you check on CPU load with all 7 cards? If the overall system load is >70% this may reduce speed because the Miner does not get enough attention by the operation system and thus the work is not scheduled fast enough.


this is photo when start miner 7 vegas with WB HIGH ,some GPUs are not start and 0 hash and miner crash. Huh Huh Huh
https://imgur.com/a/FBbw5

It can be that your system runs out of memory. The Windows AMD drivers (not sure about the Linux ones) require that at the creation time of the GPU buffers there is as well RAM or virtual system memory available as requested GPU device memory. So with HIGH this means that virtual memory file has to be about 7.5 GB per card!

This video gives a good hint, how to increase virtual memory size on your system (For lolMiner it should be more then the 16g in the video, but the way to set it is the same) :
https://www.youtube.com/watch?v=ZL0m7tVt_DU

You could also try running less cards or --set-work-batch 2G instead of --set-work-batch HIGH in the beginning. Would like to know if this changes your cards from not working to working Wink

Edit: Other reason indeed can be some driver issue - there is reason, that on Windows the default is 2G instead of AUTO or HIGH ... just because we had some trouble with AMD driver ...

Check out lolMiner 1.17, an efficient miner for Ethash, Beam and many Cuckoo-Cycle and Equihash variants for AMD cards at low fees.
Also inventor of Zombie Mode for Ethash, which allows you to mine on Eth with your 4G AMD GPUs above epoch 382.
dejan_p
Member
**
Offline Offline

Activity: 132
Merit: 11


View Profile
March 14, 2018, 01:42:56 PM
 #528

4x 1070 rig - ok, stable, increase in hashrate
4x 1080 rig - ok, stable,  increase in hashrate

however, 6x1060 rig, miner closes
work size 2g, auto, high, anything above 8, closes immediately after connecting to stratum
work size 2-4 works, hashrate ~10000 each but it goes to 0 after less than a minute
virtual memory increased to 50gb

don't know if it can be of any help
but after these crashes, if i want to open i.e. claymore eth miner, it can't create the dag anymore, or if it sometimes does, it's about 50% of the hash rate i usually get
NameTaken
Hero Member
*****
Offline Offline

Activity: 630
Merit: 502


View Profile
March 14, 2018, 02:29:46 PM
Last edit: March 14, 2018, 09:11:36 PM by NameTaken
 #529

Windows 10, R9 280X (from 2013/2014 Scrypt mining days), Blockchain driver can get 9KSol/s but unstable and miner crashes after a few minutes.
mikebzh44
Newbie
*
Offline Offline

Activity: 64
Merit: 0


View Profile
March 14, 2018, 05:06:12 PM
 #530

Nvidia

GTX 1070ti 15.2k sol/s 17.5k sol/s


Can someone tell me how it's possible to get 17.5 Ksol from a GTX1070Ti

I'm mining @ 16 KSol with those OC settings : MEM +400 / CLOCK +0 / POWER 110W

Thanks.
NameTaken
Hero Member
*****
Offline Offline

Activity: 630
Merit: 502


View Profile
March 14, 2018, 09:12:41 PM
 #531

Nvidia

GTX 1070ti 15.2k sol/s 17.5k sol/s


Can someone tell me how it's possible to get 17.5 Ksol from a GTX1070Ti

I'm mining @ 16 KSol with those OC settings : MEM +400 / CLOCK +0 / POWER 110W

Thanks.
18KSol/s with 120W, +200 core, +500 mem.
jurajo
Newbie
*
Offline Offline

Activity: 1
Merit: 0


View Profile
March 14, 2018, 09:52:11 PM
 #532

I have 5x Nvidia EVGA GTX1060 6GB, currently running with IOIminer-mnx_v03_Win64....after aprox 1 minute of running it crashes and I need to restart it manually...
where could be the problem ? In config I only changed my MNX address. Thank you
catfish78
Newbie
*
Offline Offline

Activity: 142
Merit: 0


View Profile
March 14, 2018, 11:38:46 PM
 #533

Lolliedieb, thank You, it's a nice upgrade:

(stable rigs results)

R9 270 (stock) - 4,6   (Ksols/s)
R9 270x (stock) - 5,1
R9 280x (stock) - 8,9
R9 280x(MSI,OC) - 9,6

Win 10, blockchain driver.

Power: + 7%
Temperature: + 5%

Tomorrow I put RX 570 cards to test - I really hope, that result will be much better then last time...

Cheers!
Whatqq
Newbie
*
Offline Offline

Activity: 6
Merit: 0


View Profile
March 15, 2018, 12:20:52 AM
Last edit: March 15, 2018, 12:33:04 AM by Whatqq
 #534

Hey Guys,

I noticed some of you are having issues or are wondering on what each card should be getting.

This is a tutorial and list for all the cards 10 series / rx 5xx / rx vega. *Please not this is ubuntu numbers beside vegas*

https://www.reddit.com/r/minexcoin/comments/8303j6/minexcoin_mining_observation_best_cards_overclock/

Please ask if you have any questions.

I do however have a question for you guys, how did you get your processor to hash in the miner? I wanted to test my coprocessor cards out.

Thanks

P.S. If you do find any information helpful please help me out as i am trying to recuperate my initial coins as they were lost in an EVGA psu lighting my ssd and backup drive literally on fire.

 
p.s. For anyone having issues with 0 sols hashing, try changing the risers, if this still has issues try with no overclock for stability, then lastly try different configuration with risers and make it your primary output display.

P.S. for those of you having miner crashes with new miner, force 2G as unless the card is a 1070ti+ there is very little hash difference from 2g to auto or high. this should solve your stability issue until this gets later fixed

P.S. My personal opinion is that Ubuntu is much better for NVIDIA based cards as they do appear to hash slightly better on Ubuntu. Radeon cards should be used through Windows as I find Ubuntu Radeon drivers a nightmare. Ubuntu can be used from a flash drive, so if you have a spare one lying around just set it up.
Good cat
Newbie
*
Offline Offline

Activity: 9
Merit: 0


View Profile
March 15, 2018, 11:06:54 AM
 #535

Hi, everybody!
The last days new version 0.3 works minutes 20-40 and speed falls on 0 sol and so indefinitely there is 0 sol 0sol......
How to fight against it also what to do?
The mine from 5 pieces 1060 3
Lolliedieb
Member
**
Offline Offline

Activity: 432
Merit: 45


View Profile WWW
March 15, 2018, 11:34:21 AM
Last edit: March 15, 2018, 01:01:32 PM by Lolliedieb
 #536

Time is running fast and coding never stops.

Although its only a small update, I would like to share lolMiner-mnx 0.31 with you

For those who do not want all the info whats new, here are just the download links:

Linux 64: Click me (v0.31)
Windows 64:   Click me (v0.31)

But why to download that without need? Well, this is new:

Fixed a bug in the Stratum Interface causing segfaults when receiving new jobs
This did not occur very often and most likely when the miner connected, but well - it happens from time to time and after some searching I found out why. But it seems I will have to do a new json interface for 0.4 - what fixes the segfault is rather a dirty fix and it only covers approx 80% of the possible reasons. Will try to come back with something better.

Introduced a new parameter "--optim"
This takes the two values OFF and STD (default). Setting the parameter to OFF will turn back some optimizations done for 0.3 that cause some lower end or older GPUs to run slower. So this kind of brings back the optimization level of 0.22 if you liked that more. Mid and high end cards will mine faster with this parameter not set (or the default STD), but also consume more energy. So the value OFF is also an option for those running into thermal problems.

If will extent the parameter in future for vendor specific optimizations. Lets see.

Introduced a new parameter "--use-compact-accept-msg"
This will replace the "Submitting Share / Share Accepted" message pair by * symbols attached to the 5 seconds statistics. This automatically activates --use-compact-short-stat, so we now have the following options for lolMiner-mnx to look like:

Default look--enable-time-print
Code:
[Device 0] Average speed (5s): 22714.3 sol/s
[Device 1] Average speed (5s): 22586.9 sol/s
Submitting share
Share accepted
[Device 0] Average speed (5s): 22544.1 sol/s
[Device 1] Average speed (5s): 22776.2 sol/s
Submitting share
Share accepted
Submitting share
Share accepted
Submitting share
Share accepted
[Device 0] Average speed (5s): 22045.2 sol/s
[Device 1] Average speed (5s): 22045 sol/s
Code:
12:15:12 [Device 0] Average speed (5s): 22660.5 sol/s
12:15:12 [Device 1] Average speed (5s): 22526.5 sol/s
Submitting share
Share accepted
12:15:17 [Device 0] Average speed (5s): 22494 sol/s
12:15:17 [Device 1] Average speed (5s): 22618.8 sol/s
Submitting share
Share accepted
12:15:22 [Device 0] Average speed (5s): 22020.2 sol/s
12:15:22 [Device 1] Average speed (5s): 22010.2 sol/s
Submitting share
Share accepted
12:15:27 [Device 0] Average speed (5s): 23222 sol/s
12:15:27 [Device 1] Average speed (5s): 23155.6 sol/s
--use-compact-short-stat--use-compact-short-stat --enable-time-print
Code:
Average speed (5s): 22643.7 sol/s | 22736.9 sol/s Total: 45380.5 sol/s
Submitting share
Share accepted
Average speed (5s): 22485.7 sol/s | 22536.9 sol/s Total: 45022.6 sol/s
Average speed (5s): 22606.5 sol/s | 22537.9 sol/s Total: 45144.4 sol/s
Submitting share
Share accepted
Submitting share
Share accepted
Average speed (5s): 22599.5 sol/s | 22529.1 sol/s Total: 45128.6 sol/s
Code:
12:21:43 Average speed (5s): 22705.1 sol/s | 22755 sol/s Total: 45460.1 sol/s
12:21:48 Average speed (5s): 22546.3 sol/s | 22667.3 sol/s Total: 45213.6 sol/s
Submitting share
Share accepted
12:21:53 Average speed (5s): 22578.1 sol/s | 22612.7 sol/s Total: 45190.8 sol/s
Submitting share
Share accepted
12:21:58 Average speed (5s): 22595.9 sol/s | 22635.1 sol/s Total: 45231 sol/s
Submitting share
Share accepted
--use-compact-accept-msg--use-compact-accept-msg --enable-time-print
Code:
Average speed (5s): 23167.9 sol/s | 23124 sol/s Total: 46291.9 sol/s **
Average speed (5s): 20888.2 sol/s | 22592.3 sol/s Total: 43480.5 sol/s
Average speed (5s): 20381.9 sol/s | 22738.9 sol/s Total: 43120.8 sol/s
Average speed (5s): 20863 sol/s | 22592.1 sol/s Total: 43455.1 sol/s
Average speed (5s): 20359.9 sol/s | 22602.3 sol/s Total: 42962.2 sol/s *
Code:
12:23:52 Average speed (5s): 21990.8 sol/s | 22753.8 sol/s Total: 44744.7 sol/s
12:23:57 Average speed (5s): 21497 sol/s | 22487.4 sol/s Total: 43984.4 sol/s *
12:24:02 Average speed (5s): 20862.4 sol/s | 23229.8 sol/s Total: 44092.2 sol/s
12:24:07 Average speed (5s): 20294.7 sol/s | 22661.5 sol/s Total: 42956.2 sol/s **
12:24:12 Average speed (5s): 20326.9 sol/s | 22620.1 sol/s Total: 42947 sol/s *

So, pick what you like most Cheesy
(Edit: you may see some speed differences between cards ... well the card 0 in this example running into heat problems rather soon and throttles - just that you know)



Hi, everybody!
The last days new version 0.3 works minutes 20-40 and speed falls on 0 sol and so indefinitely there is 0 sol 0sol......
How to fight against it also what to do?
The mine from 5 pieces 1060 3

Did you try the new --exit-on-zero parameter of 0.3? That should close the miner after at most two minutes after the first 0 sols was detected and the scripts provided with the miner (.bat file in Windows, .sh in Linux) should be able to restart it. Does this work for you? If you want a quicker restart you can set the long stats interval shorter.

Check out lolMiner 1.17, an efficient miner for Ethash, Beam and many Cuckoo-Cycle and Equihash variants for AMD cards at low fees.
Also inventor of Zombie Mode for Ethash, which allows you to mine on Eth with your 4G AMD GPUs above epoch 382.
skyluis2000
Newbie
*
Offline Offline

Activity: 2
Merit: 0


View Profile
March 15, 2018, 12:24:50 PM
 #537

Time is running fast and coding never stops.

Although its only a small update, I would like to share lolMiner-mnx 0.31 with you

For those who do not want all the info whats new, here are just the download links:

Linux 64: Click me (v0.31)
Windows 64:   Click me (v0.31)

But why to download that without need? Well, this is new:

Fixed a bug in the Stratum Interface causing segfaults when receiving new jobs
This did not occur very often and most likely when the miner connected, but well - it happens from time to time and after some searching I found out why. But it seems I will have to do a new json interface for 0.4 - what fixes the segfault is rather a dirty fix and it only covers approx 80% of the possible reasons. Will try to come back with something better.

Introduced a new parameter "--optim"
This takes the two values OFF and STD (default). Setting the parameter to OFF will turn back some optimizations done for 0.3 that cause some lower end or older GPUs to run slower. So this kind of brings back the optimization level of 0.22 if you liked that more. Mid and high end cards will mine faster with this parameter not set (or the default STD), but also consume more energy. So the value OFF is also an option for those running into thermal problems.

If will extent the parameter in future for vendor specific optimizations. Lets see.

Introduced a new parameter "--use-compact-accept-msg"
This will replace the "Submitting Share / Share Accepted" message pair by * symbols attached to the 5 seconds statistics. This automatically activates --use-compact-short-stat, so we now have the following options for lolMiner-mnx to look like:

Default look--enable-time-print
Code:
[Device 0] Average speed (5s): 22714.3 sol/s
[Device 1] Average speed (5s): 22586.9 sol/s
Submitting share
Share accepted
[Device 0] Average speed (5s): 22544.1 sol/s
[Device 1] Average speed (5s): 22776.2 sol/s
Submitting share
Share accepted
Submitting share
Share accepted
Submitting share
Share accepted
[Device 0] Average speed (5s): 22045.2 sol/s
[Device 1] Average speed (5s): 22045 sol/s
Code:
12:15:12 [Device 0] Average speed (5s): 22660.5 sol/s
12:15:12 [Device 1] Average speed (5s): 22526.5 sol/s
Submitting share
Share accepted
12:15:17 [Device 0] Average speed (5s): 22494 sol/s
12:15:17 [Device 1] Average speed (5s): 22618.8 sol/s
Submitting share
Share accepted
12:15:22 [Device 0] Average speed (5s): 22020.2 sol/s
12:15:22 [Device 1] Average speed (5s): 22010.2 sol/s
Submitting share
Share accepted
12:15:27 [Device 0] Average speed (5s): 23222 sol/s
12:15:27 [Device 1] Average speed (5s): 23155.6 sol/s
--use-compact-short-stat--use-compact-short-stat --enable-time-print
Code:
Average speed (5s): 22643.7 sol/s | 22736.9 sol/s Total: 45380.5 sol/s
Submitting share
Share accepted
Average speed (5s): 22485.7 sol/s | 22536.9 sol/s Total: 45022.6 sol/s
Average speed (5s): 22606.5 sol/s | 22537.9 sol/s Total: 45144.4 sol/s
Submitting share
Share accepted
Submitting share
Share accepted
Average speed (5s): 22599.5 sol/s | 22529.1 sol/s Total: 45128.6 sol/s
Code:
12:21:43 Average speed (5s): 22705.1 sol/s | 22755 sol/s Total: 45460.1 sol/s
12:21:48 Average speed (5s): 22546.3 sol/s | 22667.3 sol/s Total: 45213.6 sol/s
Submitting share
Share accepted
12:21:53 Average speed (5s): 22578.1 sol/s | 22612.7 sol/s Total: 45190.8 sol/s
Submitting share
Share accepted
12:21:58 Average speed (5s): 22595.9 sol/s | 22635.1 sol/s Total: 45231 sol/s
Submitting share
Share accepted
--use-compact-accept-msg--use-compact-accept-msg --enable-time-print
Code:
Average speed (5s): 23167.9 sol/s | 23124 sol/s Total: 46291.9 sol/s **
Average speed (5s): 20888.2 sol/s | 22592.3 sol/s Total: 43480.5 sol/s
Average speed (5s): 20381.9 sol/s | 22738.9 sol/s Total: 43120.8 sol/s
Average speed (5s): 20863 sol/s | 22592.1 sol/s Total: 43455.1 sol/s
Average speed (5s): 20359.9 sol/s | 22602.3 sol/s Total: 42962.2 sol/s *
Code:
12:23:52 Average speed (5s): 21990.8 sol/s | 22753.8 sol/s Total: 44744.7 sol/s
12:23:57 Average speed (5s): 21497 sol/s | 22487.4 sol/s Total: 43984.4 sol/s *
12:24:02 Average speed (5s): 20862.4 sol/s | 23229.8 sol/s Total: 44092.2 sol/s
12:24:07 Average speed (5s): 20294.7 sol/s | 22661.5 sol/s Total: 42956.2 sol/s **
12:24:12 Average speed (5s): 20326.9 sol/s | 22620.1 sol/s Total: 42947 sol/s *

So, pick what you like most Cheesy
(Edit: you may see some speed differences between cards ... well the card 0 in this example running into heat problems rather soon and throttles - just that you know)



Hi, everybody!
The last days new version 0.3 works minutes 20-40 and speed falls on 0 sol and so indefinitely there is 0 sol 0sol......
How to fight against it also what to do?
The mine from 5 pieces 1060 3

Did you try the new --exit-on-zero parameter of 0.3? That should close the miner after at most two minutes after the first 0 sols was detected and the scripts provided with the miner (.bat file in Windows, .sh in Linux) should be able to restart it. Does this work for you? If you want a quicker restart you can set the long stats interval shorter.

Hello. I really liked this version 0.3 and I just tested this version 0.31 but just like version 0.3 the older video card is not timed and still slow. in version 0.22 it makes 1700 soles. in this new version is making 900 sol / s even with the new parameter --optim OFF / STD. continues reading for gtx560 2GB. thank you
AAile
Newbie
*
Offline Offline

Activity: 44
Merit: 0


View Profile
March 15, 2018, 12:36:38 PM
 #538

...

Haven't reported to you for some time.
Ever since the second available version it crashes much less. I turned off Windows Error Reporting and put running it in queue so it works non stop right now. I had a problem only once with the program trying to connect to the pool - I see v0.31 will fix this.

Surprisingly, this v0.31 did wonder on my rx480 rig! Using the same .bat files and new version gives like 8700sol and more where previous version did only 6100sol!!! You must have gotten the right parameters for rx480 now.

So far, I'm running lolMIner on 8 rigs now. On 2 of them I have this issue with hashrate going down when you are not connected through TeamViewer or AnyDesk. Also, if you just keep the main youtube.com page open - the hashrate doesn't go down. You don't need to run a YT video, the preview is enough. Very weird. How could that happen? If you can't reproduce the issue, let me know and we'll see if we can give you access to a machine where this happens. On one of the rigs where this happens, it happens only if you run two particular cards in the same .exe. If you run separate .bats nothing slows down. The moment you run those two particular ones in the some .bat (doesn't matter if you run only these 2 or another 1,2,3,4,5,6,7) the hashrates go down.
Lolliedieb
Member
**
Offline Offline

Activity: 432
Merit: 45


View Profile WWW
March 15, 2018, 01:22:49 PM
 #539

Just updated the binary - had a small bug that --optim STD did not equal the default (when --optim is not set)

For next version I will try stabilizing the host part more - have an idea but must try how well this works Smiley

Check out lolMiner 1.17, an efficient miner for Ethash, Beam and many Cuckoo-Cycle and Equihash variants for AMD cards at low fees.
Also inventor of Zombie Mode for Ethash, which allows you to mine on Eth with your 4G AMD GPUs above epoch 382.
jezined
Newbie
*
Offline Offline

Activity: 23
Merit: 0


View Profile
March 15, 2018, 01:39:13 PM
 #540

Time is running fast and coding never stops.

Although its only a small update, I would like to share lolMiner-mnx 0.31 with you

For those who do not want all the info whats new, here are just the download links:

Linux 64: Click me (v0.31)
Windows 64:   Click me (v0.31)



Awesome work once again Mr Lollie!

However, with my little setup I have found that with my Nvidia GTX 1060 v0.31 with "--optim=OFF" works better/faster than v0.3 and v0.22
(I think since writing this you have made another fix, I will re-test)

For this card (slightly overclocked) the average speeds for each version are:
v0.22 - 11200 sol/s
v0.3 -  11300 sol/s
v0.31 - 12500 sol/s

And now with v0.31 if I try to run it against my Intel CPU I see one core get very busy but not much else (in benchmark mode):

 ./lolMiner-mnx_v031 --platform 1 --device 1 --optim OFF --use-alt-mine-thread
-------------------------------------------------
          Welcome to lolMiner-mnx v0.31

   This software is only meant for pool mining
    with the Equihash 96/5 algorithm (MARS)

For usage instructions add -h to the commandline.
   For support visit our bitcointalk thread.

          Made by Lolliedieb, March 2018
-------------------------------------------------
Using expert parameter "--use-alt-mine-thread". Be aware on possible consequences on CPU load and miner stability.
Multi GPU support will be deactivated.
No Argument given - Switching to Benchmark mode
Using device with id 1 (Intel(R) Core(TM) i7-7820HQ CPU @ 2.90GHz)
Selected work-batch for device 1: 42
^C



Also, the stdout from lolMiner (all versions) when piped into a file is regarded by my Linux host to be a data file, because I think of a control-@ null character...?

$ ./lolMiner-mnx_v031 --platform 0 --device 0 --optim OFF  > test.log 2>&1

$ file test.log
test.log: data

$ cat test.log
-------------------------------------------------
          Welcome to lolMiner-mnx v0.31

   This software is only meant for pool mining
    with the Equihash 96/5 algorithm (MARS)

For usage instructions add -h to the commandline.
   For support visit our bitcointalk thread.

          Made by Lolliedieb, March 2018
-------------------------------------------------
No Argument given - Switching to Benchmark mode
Using device with id 0 (GeForce GTX 1060 3GB)
Selected work-batch for device 0: 20
[Device 0] Average speed (5s): 12448.7 sol/s
[Device 0] Average speed (5s): 12457.9 sol/s
[Device 0] Average speed (5s): 12481.3 sol/s
[Device 0] Average speed (5s): 12427.7 sol/s
[Device 0] Average speed (5s): 12400 sol/s
[Device 0] Average speed (5s): 12393.1 sol/s
[Device 0] Average speed (5s): 12440.9 sol/s
[Device 0] Average speed (5s): 12393.3 sol/s
[Device 0] Average speed (5s): 12475.9 sol/s
[Device 0] Average speed (5s): 12541.1 sol/s
[Device 0] Average speed (5s): 12474.9 sol/s
---------------------------------------------
Average speed (60s): 12454.8 sol/s
---------------------------------------------

$ vi test.log
-------------------------------------------------
          Welcome to lolMiner-mnx v0.31

   This software is only meant for pool mining
    with the Equihash 96/5 algorithm (MARS)

For usage instructions add -h to the commandline.
   For support visit our bitcointalk thread.

          Made by Lolliedieb, March 2018
-------------------------------------------------
No Argument given - Switching to Benchmark mode
Using device with id 0 (GeForce GTX 1060 3GB^@)



This is only a bit annoying when wanting to use text search tools such as grep on the log files, which I can fixup using the strings util.

$ grep Average test.log
Binary file test.log matches

$ strings test.log | grep Average
[Device 0] Average speed (5s): 12448.7 sol/s
[Device 0] Average speed (5s): 12457.9 sol/s
[Device 0] Average speed (5s): 12481.3 sol/s
[Device 0] Average speed (5s): 12427.7 sol/s
[Device 0] Average speed (5s): 12400 sol/s
[Device 0] Average speed (5s): 12393.1 sol/s
[Device 0] Average speed (5s): 12440.9 sol/s
[Device 0] Average speed (5s): 12393.3 sol/s
[Device 0] Average speed (5s): 12475.9 sol/s
[Device 0] Average speed (5s): 12541.1 sol/s
[Device 0] Average speed (5s): 12474.9 sol/s
Average speed (60s): 12454.8 sol/s


Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 [27] 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 »
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!