Bitcoin Forum
January 21, 2017, 11:47:36 PM *
News: Latest stable version of Bitcoin Core: 0.13.2  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 [25] 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 »
  Print  
Author Topic: [ANN] ccminer 1.8.4 - opensource (tpruvot)  (Read 141689 times)
chrysophylax
Hero Member
*****
Offline Offline

Activity: 644


granite --- simple - solid - stable


View Profile WWW
February 02, 2016, 05:09:09 AM
 #481

which time the ccminer 1.7.1 will be compiled ?

thanks.
at 2:34 and 23 second (it will be available for 5 min ) don't miss it

is there something special happening with this version? ...

1.7.2 is already in git ...

or are you just joking djm34? ...

#crysx

1485042456
Hero Member
*
Offline Offline

Posts: 1485042456

View Profile Personal Message (Offline)

Ignore
1485042456
Reply with quote  #2

1485042456
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1485042456
Hero Member
*
Offline Offline

Posts: 1485042456

View Profile Personal Message (Offline)

Ignore
1485042456
Reply with quote  #2

1485042456
Report to moderator
1485042456
Hero Member
*
Offline Offline

Posts: 1485042456

View Profile Personal Message (Offline)

Ignore
1485042456
Reply with quote  #2

1485042456
Report to moderator
1485042456
Hero Member
*
Offline Offline

Posts: 1485042456

View Profile Personal Message (Offline)

Ignore
1485042456
Reply with quote  #2

1485042456
Report to moderator
joblo
Hero Member
*****
Online Online

Activity: 644


View Profile
February 02, 2016, 07:46:24 AM
 #482

I'm trying to run the miner in the background on Ubuntu, but I keep getting the error, :
Code:
Cuda error in func 'skeincoin_init' at line 711 : initialization error.
The function it references is in the cuda_skeincoin.cu file and it reads:

Code:
__host__
void skeincoin_init(int thr_id)
{
                 cuda_get_arch(thr_id);
                 CUDA_SAFE_CALL(cudaMalloc(&d_found[thr_id], 2 * sizeof(uint32_t)));
}

I tried deleting the function, I tried modifying it to follow the format of the groestlcoin file, but it never works in the background. When I run it in the foreground, the program and algo run fine.

Did you try other algos?

It's odd that it would work in the foreground but not in the background but that error sometimes means the
intensity is too high. Try modifying the -i arg, I have no idea what good for skein buut try number between
14 and 24.

Principal developer of cpuminer-opt, the optimized multi-algo CPU miner.
BTC donation address: 12tdvfF7KmAsihBXQXynT6E6th2c2pByTT
https://bitcointalk.org/index.php?topic=1326803.0
chrysophylax
Hero Member
*****
Offline Offline

Activity: 644


granite --- simple - solid - stable


View Profile WWW
February 02, 2016, 12:01:47 PM
 #483

I'm trying to run the miner in the background on Ubuntu, but I keep getting the error, :
Code:
Cuda error in func 'skeincoin_init' at line 711 : initialization error.
The function it references is in the cuda_skeincoin.cu file and it reads:

Code:
__host__
void skeincoin_init(int thr_id)
{
                 cuda_get_arch(thr_id);
                 CUDA_SAFE_CALL(cudaMalloc(&d_found[thr_id], 2 * sizeof(uint32_t)));
}

I tried deleting the function, I tried modifying it to follow the format of the groestlcoin file, but it never works in the background. When I run it in the foreground, the program and algo run fine.

Did you try other algos?

It's odd that it would work in the foreground but not in the background but that error sometimes means the
intensity is too high. Try modifying the -i arg, I have no idea what good for skein buut try number between
14 and 24.

that all depends on what he means by foreground and background ...

if by background he means '&' - then the majority of times it will not work ... dont ask me why - i dont know mate ...

and so if by foreground he means directly in console - then of course it will work ... especially if the gui is being used ...

so i just wanted to determine which way the 'background' method is ... as you would be on the nose with the '&' way with the intensities - as the card is using gpu memory for the gui and would crash accordingly when trying to access at a higher intensity ...

so i guess the question i SHOULD be asking is - what is your commandline parameters to run background? ...

#crysx

pallas
Legendary
*
Offline Offline

Activity: 1176


Black Belt Developer


View Profile
February 02, 2016, 12:18:00 PM
 #484

why do you even run it in background? just use byobu and hit F6 to exit.
it will go on as normal and you'll get back just by ssh-ing in again.
multiple windows and scrollback buffers as bonus ;-)

XCN M7 ccminer cuda8 pascal: https://bitcointalk.org/index.php?topic=1586383.0 -- Optimized GRS/DMD sgminer: https://bitcointalk.org/index.php?topic=779598.0
Espers: Reverse ICO, sidechains, new algo: https://bitcointalk.org/index.php?topic=1434700.0 -- BTC donations: 1H7qC5uHuGX2d5s9Kuw3k7Wm7xMQzL16SN
chrysophylax
Hero Member
*****
Offline Offline

Activity: 644


granite --- simple - solid - stable


View Profile WWW
February 02, 2016, 12:27:40 PM
 #485

why do you even run it in background? just use byobu and hit F6 to exit.
it will go on as normal and you'll get back just by ssh-ing in again.
multiple windows and scrollback buffers as bonus ;-)

i use screen ...

its easy to configure and runs from the command line with the same features you just mentioned ...

which is why i was trying to establish HOW he was doing the 'background' run ...

ill look into byobu - ive never heard of it ...

edit - hehehe ... and its in the fedora 23 repo ... nice ...

Code:
[root@horus ~]# dnf info byobu
Last metadata expiration check performed 21:41:36 ago on Tue Feb  2 01:17:05 2016.
Available Packages
Name        : byobu
Arch        : noarch
Epoch       : 0
Version     : 5.97
Release     : 1.fc23
Size        : 157 k
Repo        : updates
Summary     : Light-weight, configurable window manager built upon GNU screen
URL         : http://launchpad.net/byobu
License     : GPLv3
Description : Byobu is a Japanese term for decorative, multi-panel screens that serve
            : as folding room dividers. As an open source project, Byobu is an
            : elegant enhancement of the otherwise functional, plain,
            : practical GNU Screen. Byobu includes an enhanced profile
            : and configuration utilities for the GNU screen window manager,
            : such as toggle-able system status notifications.

and just for informations sake ...

Code:
[root@horus ~]# dnf info screen
Last metadata expiration check performed 21:44:09 ago on Tue Feb  2 01:17:05 2016.
Installed Packages
Name        : screen
Arch        : x86_64
Epoch       : 0
Version     : 4.3.1
Release     : 2.fc23
Size        : 938 k
Repo        : @System
From repo   : @commandline
Summary     : A screen manager that supports multiple logins on one terminal
URL         : http://www.gnu.org/software/screen
License     : GPLv2+
Description : The screen utility allows you to have multiple logins on just one
            : terminal. Screen is useful for users who telnet into a machine or are
            : connected via a dumb terminal, but want to use more than just one
            : login.
            :
            : Install the screen package if you need a screen manager that can
            : support multiple logins on one terminal.

tanx ...

#crysx

pallas
Legendary
*
Offline Offline

Activity: 1176


Black Belt Developer


View Profile
February 02, 2016, 12:33:35 PM
 #486

byobu is much more powerfull than screen and it is compatible.
it's like a textual windows manager.
it's one of those things you can't leave without, as soon as you pass the first 20 minutes of learning (YMMV) ;-)

https://help.ubuntu.com/community/Byobu

XCN M7 ccminer cuda8 pascal: https://bitcointalk.org/index.php?topic=1586383.0 -- Optimized GRS/DMD sgminer: https://bitcointalk.org/index.php?topic=779598.0
Espers: Reverse ICO, sidechains, new algo: https://bitcointalk.org/index.php?topic=1434700.0 -- BTC donations: 1H7qC5uHuGX2d5s9Kuw3k7Wm7xMQzL16SN
chrysophylax
Hero Member
*****
Offline Offline

Activity: 644


granite --- simple - solid - stable


View Profile WWW
February 02, 2016, 12:36:22 PM
 #487

byobu is much more powerfull than screen and it is compatible.
it's like a textual windows manager.
it's one of those things you can't leave without, as soon as you pass the first 20 minutes of learning (YMMV) ;-)

https://help.ubuntu.com/community/Byobu

im 'fiddling' ( ie - learning ) with it now ...

nice - and quite similar ... but it will take a little getting used to ...

seems i wont have to unlearn anything from screen either ...

tanx again pallas ...

#crysx

Epsylon3
Hero Member
*****
Offline Offline

Activity: 854


ccminer/cpuminer developer


View Profile WWW
February 04, 2016, 03:45:27 AM
 #488

yes, thanks, was using screen... but the lack of scrollback (or to find the right multiple key shortcuts) was a pain...

was about to switch to tmux... so i guess this one will help Wink

BTC: 1FhDPLPpw18X4srecguG3MxJYe4a1JsZnd - My Projects: ccminer - cpuminer-multi - yiimp - Forum threads : ccminer - cpuminer-multi
pallas
Legendary
*
Offline Offline

Activity: 1176


Black Belt Developer


View Profile
February 04, 2016, 10:33:26 AM
 #489

yes, thanks, was using screen... but the lack of scrollback (or to find the right multiple key shortcuts) was a pain...

was about to switch to tmux... so i guess this one will help Wink

byobu can use both tmux and screen as backends ;-)

XCN M7 ccminer cuda8 pascal: https://bitcointalk.org/index.php?topic=1586383.0 -- Optimized GRS/DMD sgminer: https://bitcointalk.org/index.php?topic=779598.0
Espers: Reverse ICO, sidechains, new algo: https://bitcointalk.org/index.php?topic=1434700.0 -- BTC donations: 1H7qC5uHuGX2d5s9Kuw3k7Wm7xMQzL16SN
ZeroFossilFuel
Full Member
***
Offline Offline

Activity: 230



View Profile WWW
February 06, 2016, 03:37:32 AM
 #490

which time the ccminer 1.7.1 will be compiled ?

thanks.
at 2:34 and 23 second (it will be available for 5 min ) don't miss it
LOL! That's some funny stuff right there.  Grin

I just successfully compiled 1.7.2 on a Xubuntu 14.04 miner with CUDA 7.5 on it and it runs beautifully! I mine the Quark algo. Period. Save the comments. Whereas sp_mod was running about 11% higher hashrate on my GTX 750 Ti's, it was only getting ~70% acceptance when I mined solo. tpruvot, while 11% lower hashrate, kicks ass at 100% acceptance! ~20% ahead of the game mining solo.

Question: I can't seem to compile on a Xubuntu 15.10 box with CUDA 7.5. Getting the "can't deal with >gcc4.9" error. I do seem to have gcc-4.8 installed but it's not being seen when I compile. How do I force it?

BTQ - 1HyTqd6phXRmYi2C8CCpXGV89qkLKgzPQN  Website  YouTube
joblo
Hero Member
*****
Online Online

Activity: 644


View Profile
February 06, 2016, 04:07:28 AM
 #491

which time the ccminer 1.7.1 will be compiled ?

thanks.
at 2:34 and 23 second (it will be available for 5 min ) don't miss it
LOL! That's some funny stuff right there.  Grin

I just successfully compiled 1.7.2 on a Xubuntu 14.04 miner with CUDA 7.5 on it and it runs beautifully! I mine the Quark algo. Period. Save the comments. Whereas sp_mod was running about 11% higher hashrate on my GTX 750 Ti's, it was only getting ~70% acceptance when I mined solo. tpruvot, while 11% lower hashrate, kicks ass at 100% acceptance! ~20% ahead of the game mining solo.

Question: I can't seem to compile on a Xubuntu 15.10 box with CUDA 7.5. Getting the "can't deal with >gcc4.9" error. I do seem to have gcc-4.8 installed but it's not being seen when I compile. How do I force it?

Did you install cuda from the distro repo or from nvidia? The distro is more likely to be compatible.

Principal developer of cpuminer-opt, the optimized multi-algo CPU miner.
BTC donation address: 12tdvfF7KmAsihBXQXynT6E6th2c2pByTT
https://bitcointalk.org/index.php?topic=1326803.0
ZeroFossilFuel
Full Member
***
Offline Offline

Activity: 230



View Profile WWW
February 06, 2016, 04:31:21 AM
 #492

On the 15.10 machine I installed CUDA 7.5 from the nVidia local .deb. On the 14.04 machine I installed CUDA 7.5 from .run. Or was it the other way around? Let me check...........

No, I had it right the first time. Either way, both from nVidia.

BTQ - 1HyTqd6phXRmYi2C8CCpXGV89qkLKgzPQN  Website  YouTube
pallas
Legendary
*
Offline Offline

Activity: 1176


Black Belt Developer


View Profile
February 06, 2016, 04:40:27 AM
 #493

To use a specific gcc version, find this line in Makefile.am and add the related option:

nvcc_ARCH += --compiler-bindir /usr/bin/gcc-4.7 -gencode=arch=compute_52,code=\"sm_52,compute_52\"

Remember to rerun autogen.sh, configure and then make.

XCN M7 ccminer cuda8 pascal: https://bitcointalk.org/index.php?topic=1586383.0 -- Optimized GRS/DMD sgminer: https://bitcointalk.org/index.php?topic=779598.0
Espers: Reverse ICO, sidechains, new algo: https://bitcointalk.org/index.php?topic=1434700.0 -- BTC donations: 1H7qC5uHuGX2d5s9Kuw3k7Wm7xMQzL16SN
ZeroFossilFuel
Full Member
***
Offline Offline

Activity: 230



View Profile WWW
February 06, 2016, 10:09:16 PM
 #494

Code:
gcc-4.8: error trying to exec 'cc1plus': execvp: No such file or directory
cc1plus is not in the repository. Even tried installing gcc-4.7. Same error. Also looked up the error message. Found some really old posts about adding build-essential and/or just g++. Both are installed.

BTQ - 1HyTqd6phXRmYi2C8CCpXGV89qkLKgzPQN  Website  YouTube
joblo
Hero Member
*****
Online Online

Activity: 644


View Profile
February 06, 2016, 10:51:59 PM
 #495

Code:
gcc-4.8: error trying to exec 'cc1plus': execvp: No such file or directory
cc1plus is not in the repository. Even tried installing gcc-4.7. Same error. Also looked up the error message. Found some really old posts about adding build-essential and/or just g++. Both are installed.

It seems you have two choices. Change cuda to match th OS or change the OS to match
cuda.

The latter seems preferable to me. If the xubuntu repo has cuda you can be pretty sure
it works.

Principal developer of cpuminer-opt, the optimized multi-algo CPU miner.
BTC donation address: 12tdvfF7KmAsihBXQXynT6E6th2c2pByTT
https://bitcointalk.org/index.php?topic=1326803.0
Epsylon3
Hero Member
*****
Offline Offline

Activity: 854


ccminer/cpuminer developer


View Profile WWW
February 06, 2016, 10:55:57 PM
 #496

its g++

and 4.7 is very old... Wink read the readme about fedora for the last gcc version problem (5+) but the problem is only with cuda 6.5 if i remember right

BTC: 1FhDPLPpw18X4srecguG3MxJYe4a1JsZnd - My Projects: ccminer - cpuminer-multi - yiimp - Forum threads : ccminer - cpuminer-multi
ZeroFossilFuel
Full Member
***
Offline Offline

Activity: 230



View Profile WWW
February 06, 2016, 11:16:07 PM
 #497

Code:
gcc-4.8: error trying to exec 'cc1plus': execvp: No such file or directory
cc1plus is not in the repository. Even tried installing gcc-4.7. Same error. Also looked up the error message. Found some really old posts about adding build-essential and/or just g++. Both are installed.

It seems you have two choices. Change cuda to match th OS or change the OS to match
cuda.

The latter seems preferable to me. If the xubuntu repo has cuda you can be pretty sure
it works.
Regressing CUDA to the native 6.5 found in the Xubuntu 15.10 repo is the preferable course for me since this is a multi-purpose machine that is only minting coins when I'm not sitting in front of it. I'm not too hopeful of it working though. It just makes no sense to me that CUDA 7.5 on a Xubuntu 14.04 machine works where the native CUDA version is 5.5 but won't work on a 15.10 machine where the native version is 6.5.  Will give that a try after dinner anyway and see if it makes a difference. Thanks for chiming in.

BTQ - 1HyTqd6phXRmYi2C8CCpXGV89qkLKgzPQN  Website  YouTube
ZeroFossilFuel
Full Member
***
Offline Offline

Activity: 230



View Profile WWW
February 07, 2016, 05:04:20 AM
 #498

Okay. I was almost ready to report success but not quite. I'm building with gcc-4.9 and I also had to install g++-4.9 separately. The compile looks like it's going to fly, gets all the way through the algos and then this
Code:
#error -- unsupported GNU version! gcc versions later than 4.9 are not supported!
Is there one more option I need to force?

BTQ - 1HyTqd6phXRmYi2C8CCpXGV89qkLKgzPQN  Website  YouTube
Epsylon3
Hero Member
*****
Offline Offline

Activity: 854


ccminer/cpuminer developer


View Profile WWW
February 07, 2016, 05:07:21 AM
 #499

I already answered

BTC: 1FhDPLPpw18X4srecguG3MxJYe4a1JsZnd - My Projects: ccminer - cpuminer-multi - yiimp - Forum threads : ccminer - cpuminer-multi
chrysophylax
Hero Member
*****
Offline Offline

Activity: 644


granite --- simple - solid - stable


View Profile WWW
February 07, 2016, 11:20:56 AM
 #500

epsylon3 ...

are you adding the decred kernel to the miner? ...

if so - when? ... and how would we set the commandline for optimal usage? ...

#crysx

Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 [25] 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!