Bitcoin Forum
August 18, 2017, 05:43:48 AM *
News: Latest stable version of Bitcoin Core: 0.14.2  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 [8] 9 10 11 12 13 14 15 16 17 18 19 »  All
  Print  
Author Topic: [ANN] sgminer with X11/X13/Nist5/Quark/Anime kernels compatible 14.6 amd drivers  (Read 88116 times)
aatila
Newbie
*
Offline Offline

Activity: 5


View Profile
June 22, 2014, 10:30:28 PM
#141

Hello

Sharing my x11 .bat for 5x R9 280X RoyalQueen Club3D.
4.45mh/s

Code:
setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1
sgminer.exe -k x11mod -o stratum+tcp://eu.wafflepool.com:3331 -u xxx -p 0.16 -I 18,18,17,18,18 -w 256 --thread-concurrency 8192 --lookup-gap 2 -g 2 --gpu-engine 1150,1150,1150,1150,1150 --gpu-memclock 1500,1500,1500,1500,1500 --auto-fan --gpu-fan 55-85 --temp-cutoff 80 --temp-overheat 76 --temp-target 73 --no-submit-stale --no-pool-disable --api-listen --api-allow W:127.0.0.1

Runs like a tank.

G3220 intel CPU
8GB Ram
64GB SSD
Asrock BTC H81
x R9 280X RoyalQueen Club3D.


The api-listen and api-allow localhost is implemented to work with http://cgminermonitor.com, so obsolete.
config setting pls
1503035028
Hero Member
*
Offline Offline

Posts: 1503035028

View Profile Personal Message (Offline)

Ignore
1503035028
Reply with quote  #2

1503035028
Report to moderator
1503035028
Hero Member
*
Offline Offline

Posts: 1503035028

View Profile Personal Message (Offline)

Ignore
1503035028
Reply with quote  #2

1503035028
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1503035028
Hero Member
*
Offline Offline

Posts: 1503035028

View Profile Personal Message (Offline)

Ignore
1503035028
Reply with quote  #2

1503035028
Report to moderator
wmr1988
Jr. Member
*
Offline Offline

Activity: 45


View Profile
June 23, 2014, 01:20:37 AM
#142

Has anyone gotten this to work for Windows now?

For some reason I'm getting only 1.5MH/s on HD 7850 @1050/1300 core/mem - which is very close to the previous lazybear x11 mod for sph

.bat as below
setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1
C:\sgminer\sgminer.exe -k x11mod  -o -p -u -I 15 -g 4 -w 128 --lookup-gap 2 --thread-concurrency 8192 --failover-only

loonb
Full Member
***
Offline Offline

Activity: 122


View Profile
June 23, 2014, 01:51:49 AM
#143

Has anyone gotten this to work for Windows now?

For some reason I'm getting only 1.5MH/s on HD 7850 @1050/1300 core/mem - which is very close to the previous lazybear x11 mod for sph

.bat as below
setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1
C:\sgminer\sgminer.exe -k x11mod  -o -p -u -I 15 -g 4 -w 128 --lookup-gap 2 --thread-concurrency 8192 --failover-only


-I 16 -g 2

Free Financial Future
Burst
wmr1988
Jr. Member
*
Offline Offline

Activity: 45


View Profile
June 23, 2014, 02:25:56 AM
#144

Has anyone gotten this to work for Windows now?

For some reason I'm getting only 1.5MH/s on HD 7850 @1050/1300 core/mem - which is very close to the previous lazybear x11 mod for sph

.bat as below
setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1
C:\sgminer\sgminer.exe -k x11mod  -o -p -u -I 15 -g 4 -w 128 --lookup-gap 2 --thread-concurrency 8192 --failover-only


-I 16 -g 2

Thanks but the increase is very miminal vs. the current setting. I'm just not getting that 20-30% performance increase that supposedly come with 14.4/14.6 driver.
bullus
Sr. Member
****
Offline Offline

Activity: 294


View Profile
June 23, 2014, 03:10:36 AM
#145

Has anyone gotten this to work for Windows now?

For some reason I'm getting only 1.5MH/s on HD 7850 @1050/1300 core/mem - which is very close to the previous lazybear x11 mod for sph

.bat as below
setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1
C:\sgminer\sgminer.exe -k x11mod  -o -p -u -I 15 -g 4 -w 128 --lookup-gap 2 --thread-concurrency 8192 --failover-only



try
sgminer.exe (so delete C:\sgminer\) maybe it was refering to another exe of sgminer.

btc 16LWhms487bzCxQWq5oeW8SMDPmU2rvQjf
wmr1988
Jr. Member
*
Offline Offline

Activity: 45


View Profile
June 23, 2014, 03:28:32 AM
#146

Has anyone gotten this to work for Windows now?

For some reason I'm getting only 1.5MH/s on HD 7850 @1050/1300 core/mem - which is very close to the previous lazybear x11 mod for sph

.bat as below
setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1
C:\sgminer\sgminer.exe -k x11mod  -o -p -u -I 15 -g 4 -w 128 --lookup-gap 2 --thread-concurrency 8192 --failover-only



try
sgminer.exe (so delete C:\sgminer\) maybe it was refering to another exe of sgminer.


My .bats were in another folder. But no even if i copy them over and removing the prefix doesn't have any difference...
smtn512
Jr. Member
*
Offline Offline

Activity: 34


View Profile
June 23, 2014, 04:26:57 AM
#147




I found the opencl files in AMD folder inside \Packages\Drivers\Display\WB6A_INF\B171094 (after decompressing the 14.6 driver package without installing it, or with 7zip)
I don't know which are needed, so I copied everything that had "opencl" or "amdocl" in the filename into the sgminer folder (8 files, dlls & exes).
Deleted all previous bins, and now it's even better (+3%) than using the bins from 14.6 (I have 14.4 drivers installed).

Did this... 14.4 drivers with 14.6 opencl files in sgminer folder. Msi 7790s up from 1.17mh to 1.62mh. Sapphire 270s up from 2mh to 2.72mh. If anyone is interested in my configs I'll post them upon request.

I use a 7790 (seven-seven-nine-zero, a bit weak I know, but only ~70W).
With 14.6 it went from 1.2MH/s to 1.8MH/s but with locked memory clock (core clock not locked).
I removed 14.6, kept the .bin files, reinstalled 14.4 and everything is fine.
If I recreate the .bin with 14.4 I get my old low hashrates again...



Yes these little things are great power savers, and they run so cool...wish I had bought more last December when they were .1btc each. I'm very curious to know whats in your 1.8mh config...

I have a gigabyte 7790 with 1Gb GDDR5. Core @1150 Mem @1200 (for less heat)
I'm getting 1.830 MH/s and 0.027 WU/m (currently at fractalcoin)
This is my conf. It's nothing special...

Code:
]
,
"xintensity" : "100",
"vectors" : "1",
"worksize" : "128",
"kernel" : "x11mod",
"thread-concurrency" : "8000",
"lookup-gap" : "2",
"gpu-threads" : "4",
"gpu-engine" : "1150",
"gpu-memclock" : "1200",
"queue" : "2",
"scan-time" : "4",
"expiry" : "8",
"no-pool-disable" : true,
"failover-only" : true
}

TC doesn't play such important role as in scrypt. I also use 8192 or 2048, without any significant change.
Memory clock also doesn't affect my rate much, so I keep it low to drop the temps.
You can also try more threads (6 or 8 ).
Q/S/E  based mostly on the coin and pool and my experience/hope/illusion/paranoia...

Update: After a full day of mining, the memory clock is again stuck at stock speed (1500).
I restarted the miner but its still stuck. I'm using djm34 version.
I switched to kozmos version (with bins from 14.6), and the clock is again working ok.
I think this is getting too confusing for me to follow...

From what I've read so far, it seems series 5xxx & 6xxx don't benefit as much by 14.6 or the new miners.

Update2:
If the 14.6 opencl files are in sgminer folder, when I run sgminer, mem clock gets stuck @ stock freq.
If I remove them (after I make the bins), then mem clock acts normal. Weird or not, it works.
I've tried this with both djm34 & kozmos versions for both x11 and x13...



Thanks for the follow up. The MSIs have never liked multiple GPU threads, on any algo... Tried it today with 2 threads and most of your settings and I did get into the 1.8mh range, but after a few hours a couple of cards just slumped down to 1.4mh for some reason. Clocks still the same, no proof of a driver crash but yet they slowed down, had to reboot to get full hashrate back...odd. I did change to Xi 100 and moved my clocks around some... Kept 1130/1400 1 thread per gpu which got them to 1.75mh each just fine holding 66C in a Texas garage with AC maintaining 30C (got tired of the rigs fighting my central air) each card pulling 65-70w total. Good enough for me!
samsss
Member
**
Offline Offline

Activity: 77


View Profile
June 23, 2014, 06:01:27 AM
#148

 Huh ???my other cards doing very good(low heat,high speed),but my r9 290 became very hot and not as fast as it should be,anybody know why?(with new sg miner and 14.6driver)
zaqco
Jr. Member
*
Offline Offline

Activity: 56


View Profile
June 23, 2014, 06:08:33 AM
#149

Does this have automatic x11 / x13 switching for MiningRigRentals and/or TradeMyBit?
Could someone please post an example for it if you have it.  Much appreciated.
fra55
Member
**
Offline Offline

Activity: 105


View Profile
June 23, 2014, 06:51:50 AM
#150

Hello

Sharing my x11 .bat for 5x R9 280X RoyalQueen Club3D.
4.45mh/s

Code:
setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1
sgminer.exe -k x11mod -o stratum+tcp://eu.wafflepool.com:3331 -u xxx -p 0.16 -I 18,18,17,18,18 -w 256 --thread-concurrency 8192 --lookup-gap 2 -g 2 --gpu-engine 1150,1150,1150,1150,1150 --gpu-memclock 1500,1500,1500,1500,1500 --auto-fan --gpu-fan 55-85 --temp-cutoff 80 --temp-overheat 76 --temp-target 73 --no-submit-stale --no-pool-disable --api-listen --api-allow W:127.0.0.1

Runs like a tank.

G3220 intel CPU
8GB Ram
64GB SSD
Asrock BTC H81
x R9 280X RoyalQueen Club3D.


The api-listen and api-allow localhost is implemented to work with http://cgminermonitor.com, so obsolete.
config setting pls


Just copy the values of the .bat file in the .conf file, I stands for Intensity, W for worksize, the other strings are quite straightforward
chengtangclnru4
Member
**
Offline Offline

Activity: 64


View Profile
June 23, 2014, 06:59:48 AM
#151

Hello

Sharing my x11 .bat for 5x R9 280X RoyalQueen Club3D.
4.45mh/s

Code:
setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1
sgminer.exe -k x11mod -o stratum+tcp://eu.wafflepool.com:3331 -u xxx -p 0.16 -I 18,18,17,18,18 -w 256 --thread-concurrency 8192 --lookup-gap 2 -g 2 --gpu-engine 1150,1150,1150,1150,1150 --gpu-memclock 1500,1500,1500,1500,1500 --auto-fan --gpu-fan 55-85 --temp-cutoff 80 --temp-overheat 76 --temp-target 73 --no-submit-stale --no-pool-disable --api-listen --api-allow W:127.0.0.1

Runs like a tank.

G3220 intel CPU
8GB Ram
64GB SSD
Asrock BTC H81
x R9 280X RoyalQueen Club3D.


The api-listen and api-allow localhost is implemented to work with http://cgminermonitor.com, so obsolete.
config setting pls

If we add to some list, I will keep voting.

QORA | 2ND GEN | NEW SOURCE CODE | QRkyfuZWFVXPps3Y4kh2seBCmjnQ34aY8Q
Get Free VpnCoin, Join BitNet ! your VhjaUt9Sd7PNVN5XLjYSzDYpVJD6Cr4SYp
CoinMin3r
Sr. Member
****
Offline Offline

Activity: 322


View Profile
June 23, 2014, 09:01:47 AM
#152

Tried this with my R9 290 with amd 14.4, but my hashrate got decreased than before.
I used to get 2.5+MH in x13 mode before but with this just 2.3 MH.
Any idea what went wrong.
Setting are all same before & now.

                                 
                  █████████████████████████████▒
               ▒███████████████████████████████▓░
             ▒████▓                         ░▓███▒░░
         ░▒▓████▓░                            ░▓███▓▓▒▒░░
▓▓▓▓▓████████▓▒               ░░░▒▒▒▒▒░         ░▒█████████▓▓▓▓▓
████████▓▒▒░              ░▒▓▓▓▒▒▒▒▒▒▒▓▓▓▓▒         ░░▒▒████████
▓██▓                   ░▒▓▓▓▒▒▒▒▒▒▒▒▒▒▒▒▒▓███▒░             ███▓
▒███                 ░▓█▓▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▓▓█████▒░         ▓▓█░
░█▓█░               ▓█▓▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▓▓▓▓▓▓█████▓██░     ▓███░
 ▓██▓             ▒██▒▒░▒▒▒▒▒▒▒░▒▒▒▒▒▒▒▒▒▒▒░▒▒░  ░▓█▓      ███▓
 ▒█▓█░           ▓█▓▒▒▒▒▒▒▒▒▒▒░▒░▒░░░░░▒▒░ ░▒░░▓███▓      ▒███▒
  █▓█▓          ▓█▓▒▓▒▒▒▒░░░░░░░░░░░░▒▓▒▒░░▒▒▓█████░      ███▓
  ▒█▓█░        ░██▓▓▒░░░░░░░░░▒▓▒░ ░░░ ░░▒▒▓▓▓▓▓█▒█░     ▓███▒
   ▓▓▓▓        ███▒░░░░░▒░░░▒▒▒▒▒░░░░░▒▒▒▒▒▒▒▒▒▓▓ █░    ▒███▒
   ░▓▓▓▓   ░▒▒ █▓▒▒▒▒▒▓▓▓▒░▒░░░░░░░▒▒▒▒▒▒▒▒▒░▒▒▓ ▒█    ░████▒
    ░▓▒▓▒ ░▓████▓▓▓▒▒▒▓▒░░░░░░░░░▒▒▒▒▒▒▒▒▒▒▒▒▒▒  ██   ░████▒
     ▒▓▓██  ▓████▓▒▒░░░░░░░░░▒▒▒▒▒▒▒▒▒▒▒░▒░▒▒░ ░██▒  ░████▒
      ▓████  ░██████▓▓▓▓▓▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒░░  ░███▓  ░████░
       ▒████   ▓█▓░█████▓▓▒▒▒▒▒▒▒▒▒▒░░░░░░▒▓████░  ▒████▒
        ░████▒  ▒░   ▒██████▓▓▓▒▒▒▒▒▒▒▓██████▓░   ▓████▒
          ████▓         ░▒▓██████████████▓░░    ░████▓
           ▒████▒                              ▓████░
             ▓████░                          ▒████▒
              ░████▓░                      ▒████▓
                ░████▓░                  ▒████▓░
                  ░████▓░              ▒████▓░
                     ░▓████▒          ▓████▒░
                       ░▒████▓░    ▒████▓▒
                          ░▓████▓▓████▓░
                             ▒█████▓░
                               ░▒▒░
✬✬✬✬✬

GhostPlayer
Legendary
*
Offline Offline

Activity: 924


View Profile
June 23, 2014, 09:08:13 AM
#153

WORKS !! AMD 13.12 - (opencl etc from 14.6 dropped in sgminer folder) - 4,15 mh/s from 280x (bios undervolted)

Well, it worked for me, but weird. When I first moved to x11, I used scrypt setting, and that was crap. So after much tweaking I found that
-I 19 -g 1 (pools) and -I 18 -g 1 (p2pool) gave me the best performance.

 Same happened here. With -g 2 -I 13 (max without driver crash) I get 3,1mh/s.

 Total hashrate (5x 280x) = 20,75 mh/s
 sgminer reports WU = 0.290,
 pool is going a bit bananas, but it also did that before. Reporting 32mh/s, but its only been up 5 minutes.
 
Try these!

Quote
-k x11mod -o stratum+tcp://xxx.xxx.org:3333 -u xxxx -p xxxxx --auto-fan --gpu-fan 25-85 --temp-cutoff 92 --temp-overheat 88 --temp-target 64 -I 19 -g 1 -w 256 --lookup-gap 2 --thread-concurrency 8192 --gpu-powertune 20 --gpu-engine 1100 --gpu-memclock 1500

 Thank you!!
atp1916
Legendary
*
Offline Offline

Activity: 854



View Profile
June 23, 2014, 09:45:45 AM
#154

I can also confirm that the openCL file copy method works on 14.4 / 13.12 with 290s and 270s.  Just deleted old bins and extra hash is there.

Here is a shot of the AMD openCL files i pulled:


Edit: I am noticing 13.12 rigs are slower than the 14.4 / 14.6 rigs (maybe).  May need minimum 14.4 to make this work.  Testing now...  No difference with 13.12 vs 14.4/14.6 with same settings.
Eastwind
Hero Member
*****
Offline Offline

Activity: 896



View Profile
June 23, 2014, 09:48:26 AM
#155

Can somebody post a .bin for X13 generated with 14.6?

Hopefully, with TC=8192, Worksize 128 or 256, gpu threads = 2.

Thanks in advance.

Edit: found it
https://bitcointalk.org/index.php?topic=658411.msg7429385#msg7429385
trankil
Hero Member
*****
Offline Offline

Activity: 504


View Profile WWW
June 23, 2014, 09:54:52 AM
#156

hello
i'm on linux with smos linux

i have updated successfully my AMD driver but i have a problem to compile your miner


when i use

CFLAGS="-O2 -Wall -march=native" ./configure

i have this result

Quote

------------------------------------------------------------------------
sgminer 4.1.0
------------------------------------------------------------------------


Configuration Options Summary:

  Use git version......: yes
  libcurl(GBT+getwork).: Enabled: -lcurl
  curses.TUI...........: FOUND: -lncurses
  OpenCL...............: FOUND. GPU mining support enabled
  ADL..................: SDK found, GPU monitoring support enabled

Compilation............: make (or gmake)
  CPPFLAGS.............:
  CFLAGS...............: -O2 -Wall -march=native
  LDFLAGS..............:  -lpthread
  LDADD................: -ldl -lcurl   compat/jansson-2.5/src/.libs/libjansson.a -lpthread -L/opt/AMDAPP/lib/x86 -lOpenCL    -lm -lrt

Installation...........: make install (as root if needed, with 'su' or 'sudo')
  prefix...............: /usr/local

root@smos-1:/opt/miners/sph-sgminer_x11mod# CFLAGS="-O2 -Wall -march=native" ./configure


but when i do the make   i have no ./sgminer created

do you have an idea what i miss?

Quote

root@smos-1:/opt/miners/sph-sgminer_x11mod# make
fatal: No names found, cannot describe anything.
make  all-recursive
fatal: No names found, cannot describe anything.
make[1]: Entering directory `/opt/miners/sph-sgminer_x11mod'
Making all in lib
make[2]: Entering directory `/opt/miners/sph-sgminer_x11mod/lib'
  GEN    signal.h
  GEN    string.h
make  all-recursive
make[3]: Entering directory `/opt/miners/sph-sgminer_x11mod/lib'
make[4]: Entering directory `/opt/miners/sph-sgminer_x11mod/lib'
make[4]: Nothing to be done for `all-am'.
make[4]: Leaving directory `/opt/miners/sph-sgminer_x11mod/lib'
make[3]: Leaving directory `/opt/miners/sph-sgminer_x11mod/lib'
make[2]: Leaving directory `/opt/miners/sph-sgminer_x11mod/lib'
Making all in compat
make[2]: Entering directory `/opt/miners/sph-sgminer_x11mod/compat'
Making all in jansson-2.5
make[3]: Entering directory `/opt/miners/sph-sgminer_x11mod/compat/jansson-2.5'
make  all-recursive
make[4]: Entering directory `/opt/miners/sph-sgminer_x11mod/compat/jansson-2.5'
Making all in src
make[5]: Entering directory `/opt/miners/sph-sgminer_x11mod/compat/jansson-2.5/src'
  CC     dump.lo
  CC     error.lo
  CC     hashtable.lo
  CC     load.lo
  CC     memory.lo
  CC     pack_unpack.lo
  CC     strbuffer.lo
  CC     strconv.lo
  CC     value.lo
  CCLD   libjansson.la
make[5]: Leaving directory `/opt/miners/sph-sgminer_x11mod/compat/jansson-2.5/src'
make[5]: Entering directory `/opt/miners/sph-sgminer_x11mod/compat/jansson-2.5'
make[5]: Leaving directory `/opt/miners/sph-sgminer_x11mod/compat/jansson-2.5'
make[4]: Leaving directory `/opt/miners/sph-sgminer_x11mod/compat/jansson-2.5'
make[3]: Leaving directory `/opt/miners/sph-sgminer_x11mod/compat/jansson-2.5'
make[3]: Entering directory `/opt/miners/sph-sgminer_x11mod/compat'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/opt/miners/sph-sgminer_x11mod/compat'
make[2]: Leaving directory `/opt/miners/sph-sgminer_x11mod/compat'
Making all in ccan
make[2]: Entering directory `/opt/miners/sph-sgminer_x11mod/ccan'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/opt/miners/sph-sgminer_x11mod/ccan'
Making all in sph
make[2]: Entering directory `/opt/miners/sph-sgminer_x11mod/sph'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/opt/miners/sph-sgminer_x11mod/sph'
fatal: No names found, cannot describe anything.
make[2]: Entering directory `/opt/miners/sph-sgminer_x11mod'
  CC     sgminer-sgminer.o
sgminer.c: In function ‚set_difficulty_multiplier‚:
sgminer.c:1091: warning: comparison of distinct pointer types lacks a cast
sgminer.c: In function ‚calc_diff‚:
sgminer.c:3041: warning: unused variable ‚uintdiff‚
sgminer.c: In function ‚app_restart‚:
sgminer.c:3246: warning: passing argument 2 of ‚execv‚ from incompatible pointer type
/usr/include/unistd.h:558: note: expected ‚char * const*‚ but argument is of type ‚const char * const*‚
sgminer.c: In function ‚rebuild_nonce‚:
sgminer.c:6182: warning: implicit declaration of function ‚qubitcoin_regenhash‚
sgminer.c:6185: warning: implicit declaration of function ‚quarkcoin_regenhash‚
sgminer.c:6188: warning: implicit declaration of function ‚myriadcoin_groestl_regenhash‚
sgminer.c:6191: warning: implicit declaration of function ‚fuguecoin_regenhash‚
sgminer.c:6194: warning: implicit declaration of function ‚inkcoin_regenhash‚
sgminer.c:6197: warning: implicit declaration of function ‚animecoin_regenhash‚
sgminer.c:6200: warning: implicit declaration of function ‚groestlcoin_regenhash‚
sgminer.c:6203: warning: implicit declaration of function ‚sifcoin_regenhash‚
sgminer.c:6206: warning: implicit declaration of function ‚twecoin_regenhash‚
sgminer.c:6214: warning: implicit declaration of function ‚marucoin_regenhash‚
  CC     sgminer-api.o
api.c: In function ‚api‚:
api.c:3740: warning: ‚isjoin‚ may be used uninitialized in this function
api.c:3732: warning: ‚cmdsbuf‚ may be used uninitialized in this function
  CC     sgminer-util.o
  CC     sgminer-sha2.o
  CC     sgminer-logging.o
  CC     sgminer-driver-opencl.o
driver-opencl.c: In function ‚queue_sph_kernel‚:
driver-opencl.c:1205: warning: unused variable ‚midstate‚
driver-opencl.c: In function ‚queue_x11mod_kernel‚:
driver-opencl.c:1226: warning: unused variable ‚num‚
driver-opencl.c:1224: warning: unused variable ‚midstate‚
driver-opencl.c: In function ‚queue_nist5_kernel‚:
driver-opencl.c:1269: warning: unused variable ‚num‚
driver-opencl.c:1267: warning: unused variable ‚midstate‚
driver-opencl.c: In function ‚queue_x13mod_kernel‚:
driver-opencl.c:1301: warning: unused variable ‚num‚
driver-opencl.c:1299: warning: unused variable ‚midstate‚
driver-opencl.c: In function ‚queue_x13modold_kernel‚:
driver-opencl.c:1348: warning: unused variable ‚num‚
driver-opencl.c:1346: warning: unused variable ‚midstate‚
  CC     sgminer-ocl.o
  CC     sgminer-findnonce.o
  CC     sgminer-adl.o
adl.c: In function ‚init_adl‚:
adl.c:329: warning: unused variable ‚iNumDisplays‚
adl.c: At top level:
adl.c:124: warning: ‚lpAdlDisplayInfo‚ defined but not used
  CC     sgminer-scrypt.o
  CC     sgminer-darkcoin.o
darkcoin.c: In function ‚darkcoin_regenhash‚:
darkcoin.c:174: warning: unused variable ‚scratchbuf‚
darkcoin.c: In function ‚scanhash_darkcoin‚:
darkcoin.c:189: warning: unused variable ‚scratchbuf‚
  CC     sgminer-qubitcoin.o
qubitcoin.c: In function ‚qubitcoin_regenhash‚:
qubitcoin.c:138: warning: unused variable ‚scratchbuf‚
qubitcoin.c: In function ‚scanhash_qubitcoin‚:
qubitcoin.c:153: warning: unused variable ‚scratchbuf‚
  CC     sgminer-quarkcoin.o
quarkcoin.c: In function ‚quarkcoin_regenhash‚:
quarkcoin.c:174: warning: unused variable ‚scratchbuf‚
quarkcoin.c: In function ‚scanhash_quarkcoin‚:
quarkcoin.c:189: warning: unused variable ‚scratchbuf‚
  CC     sgminer-myriadcoin-groestl.o
myriadcoin-groestl.c: In function ‚myriadcoin_groestl_regenhash‚:
myriadcoin-groestl.c:102: warning: unused variable ‚scratchbuf‚
myriadcoin-groestl.c: In function ‚scanhash_myriadcoin_groestl‚:
myriadcoin-groestl.c:117: warning: unused variable ‚scratchbuf‚
  CC     sgminer-fuguecoin.o
fuguecoin.c: In function ‚fuguecoin_regenhash‚:
fuguecoin.c:88: warning: unused variable ‚scratchbuf‚
fuguecoin.c: In function ‚scanhash_fuguecoin‚:
fuguecoin.c:103: warning: unused variable ‚scratchbuf‚
  CC     sgminer-inkcoin.o
inkcoin.c: In function ‚inkcoin_regenhash‚:
inkcoin.c:96: warning: unused variable ‚scratchbuf‚
inkcoin.c: In function ‚scanhash_inkcoin‚:
inkcoin.c:124: warning: implicit declaration of function ‚xhash‚
inkcoin.c:111: warning: unused variable ‚scratchbuf‚
  CC     sgminer-animecoin.o
animecoin.c: In function ‚animecoin_regenhash‚:
animecoin.c:174: warning: unused variable ‚scratchbuf‚
animecoin.c: In function ‚scanhash_animecoin‚:
animecoin.c:189: warning: unused variable ‚scratchbuf‚
  CC     sgminer-groestlcoin.o
groestlcoin.c: In function ‚groestlhash‚:
groestlcoin.c:57: warning: unused variable ‚ctx_sha2‚
groestlcoin.c: In function ‚groestlcoin_regenhash‚:
groestlcoin.c:102: warning: unused variable ‚scratchbuf‚
groestlcoin.c: In function ‚scanhash_groestlcoin‚:
groestlcoin.c:117: warning: unused variable ‚scratchbuf‚
  CC     sgminer-sifcoin.o
sifcoin.c: In function ‚sifcoin_regenhash‚:
sifcoin.c:129: warning: unused variable ‚scratchbuf‚
sifcoin.c: In function ‚scanhash_sifcoin‚:
sifcoin.c:144: warning: unused variable ‚scratchbuf‚
  CC     sgminer-twecoin.o
twecoin.c: In function ‚twecoin_regenhash‚:
twecoin.c:115: warning: unused variable ‚scratchbuf‚
twecoin.c: In function ‚scanhash_twecoin‚:
twecoin.c:130: warning: unused variable ‚scratchbuf‚
  CC     sgminer-marucoin.o
marucoin.c: In function ‚marucoin_regenhash‚:
marucoin.c:187: warning: unused variable ‚scratchbuf‚
marucoin.c: In function ‚scanhash_marucoin‚:
marucoin.c:202: warning: unused variable ‚scratchbuf‚
  CC     sgminer-nist5.o
nist5.c: In function ‚nist5_regenhash‚:
nist5.c:139: warning: unused variable ‚scratchbuf‚
nist5.c: In function ‚scanhash_nist5‚:
nist5.c:154: warning: unused variable ‚scratchbuf‚
  CCLD   sgminer
make[2]: Leaving directory `/opt/miners/sph-sgminer_x11mod'
make[1]: Leaving directory `/opt/miners/sph-sgminer_x11mod'
root@smos-1:/opt/miners/sph-sgminer_x11mod#


intotherain
Sr. Member
****
Offline Offline

Activity: 387


Blocklancer - Freelance on the Blockchain


View Profile
June 23, 2014, 09:57:50 AM
#157

got 4.400 my r9 280x toxic. thank you. Kiss

Is that on windows 32 or 64 ?  (Does it mater, using 32/64?)
windows 7 64bit

SolarFox
Member
**
Offline Offline

Activity: 103


View Profile
June 23, 2014, 10:15:57 AM
#158

@DJM34

Mining with x11modTahitiglg2tc8262w256l4.bin generated with this new miner is a little slower than with *.bin generated with "x11x13mod_03_06_2014" miner.

but check it... Maybe it`s only me.
DedRes
Newbie
*
Offline Offline

Activity: 11


View Profile
June 23, 2014, 10:22:56 AM
#159

Are you all here such a f* snobs?
Asked a question but nobody bothers to drop a word for it.
atp1916
Legendary
*
Offline Offline

Activity: 854



View Profile
June 23, 2014, 10:28:16 AM
#160

Hi, guys.
Hi
I'm a newbie in mining and I'd highly appreciate some help with the sgminer on win7
For some reason I'm unable to get connected to any pool (I tried several).
Drivers are 14.6

And here's how it runs:

D:\ISR\sgminer_14.6_fixed\kernel>setx GPU_MAX_ALLOC_PERCENT 100
SUCCESS: Specified value was saved.
D:\ISR\sgminer_14.6_fixed\kernel>setx GPU_USE_SYNC_OBJECTS 1
SUCCESS: Specified value was saved.
D:\ISR\sgminer_14.6_fixed\kernel>
D:\ISR\sgminer_14.6_fixed\kernel>..\sgminer.exe --kernel x11mod -g 1 -w 128 -I 18 -o stratum+tcp://west01.us.trademybit.com:4440 -u xxxxxx.1 -p x --no-submit-stale --verbose

--text-only
[13:54:16] Started sgminer 4.1.0
[13:54:17] CL Platform 0 vendor: Advanced Micro Devices, Inc.
[13:54:17] CL Platform 0 name: AMD Accelerated Parallel Processing
[13:54:17] CL Platform 0 version: OpenCL 1.2 AMD-APP (1526.3)
[13:54:17] Platform 0 devices: 1
[13:54:17]      0       Caicos
[13:54:17] Number of ADL devices: 1
[13:54:18] ATI ADL Overdrive5 API found.
[13:54:18] ATI ADL Overdrive6 API found.
[13:54:18] Found 4 ADL adapters
[13:54:18] ADL index 0, id 321458240 - BIOS partno.: BR41330.001, version: 013.0
09.000.010, date: 2011/07/20 06:08
[13:54:18] GPU 0 assigned: iAdapterIndex:0 iPresent:1 strUDID:PCI_VEN_1002&DEV_6760&SUBSYS_161E103C&REV_00_4&2179970E&0&0008A iBusNumber:1 iDeviceNumber:0 iFunctionNumber:0

iVendorID:1002 name:AMD Radeon HD 7400M Series
[13:54:18] ADL index 1, id 321458240 - BIOS partno.: BR41330.001, version: 013.0
09.000.010, date: 2011/07/20 06:08
[13:54:18] ADL index 2, id 321458240 - BIOS partno.: BR41330.001, version: 013.0
09.000.010, date: 2011/07/20 06:08
[13:54:18] ADL index 3, id 321458240 - BIOS partno.: BR41330.001, version: 013.0
09.000.010, date: 2011/07/20 06:08
[13:54:18] GPU 0 AMD Radeon HD 7400M Series hardware monitoring enabled
[13:54:18] ADL GPU 0 is Adapter index 0 and maps to adapter id 321458240
[13:54:18] GPU 0 BIOS partno.: BR41330.001, version: 013.009.000.010, date: 2011/07/20 06:08
[13:54:18] Failed to ADL_Overdrive5_FanSpeed_Get for default value
[13:54:18] Init GPU thread 0 GPU 0 virtual GPU 0
[13:54:18] CL Platform vendor: Advanced Micro Devices, Inc.
[13:54:18] CL Platform name: AMD Accelerated Parallel Processing
[13:54:18] CL Platform version: OpenCL 1.2 AMD-APP (1526.3)
[13:54:18] List of devices:
[13:54:18]      0       Caicos
[13:54:18] Selected 0: Caicos
[13:54:18] Kernel x11mod is experimental.
[13:55:15] Initialising kernel x11mod.cl with bitalign, 1 vectors and worksize 128
[13:55:15] initCl() finished. Found Caicos
[13:55:15] Probing for an alive pool
[13:55:15] Testing Pool 0
[13:55:25] Waiting for work to be available from pools.
[13:55:25] Setting GPUs to idle performance.
[13:55:58] Closing socket for stratum Pool 0
[13:56:15] No servers were found that could be used to get work from.

[13:56:15] Please check the details from the list below of the servers you have input
[13:56:15] Most likely you have input the wrong URL, forgotten to add a port, or  have not set up workers
[13:56:15] Pool: 0  URL: stratum+tcp://west01.us.trademybit.com:4440  User: xxxxxx.1  Password: x
[13:56:15] No servers could be used! Exiting.


Where am I wrong with that?
Thanks in advance


For posterity, here was the post that contained the question.

You did update to the "fixed" SGMiner that the OP updated to, right?  

It would appear that your miner is connecting just fine to the actual pool (as it is waiting for work to be available), and by extension your worker (maybe).. but dying because no work was found.  As such, i would rule out a config error wrt to the hardware.  You did do your workers on the pool(s) right, right?
Pages: « 1 2 3 4 5 6 7 [8] 9 10 11 12 13 14 15 16 17 18 19 »  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!