Bitcoin Forum
August 18, 2017, 05:43:57 AM *
News: Latest stable version of Bitcoin Core: 0.14.2  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 8 9 [10] 11 12 13 14 15 16 17 18 19 »  All
  Print  
Author Topic: [ANN] sgminer with X11/X13/Nist5/Quark/Anime kernels compatible 14.6 amd drivers  (Read 88119 times)
nwls31
Newbie
*
Offline Offline

Activity: 2


View Profile
June 23, 2014, 07:57:13 PM
 #181

Great job, my Powercolor 280x have gone from 3.4 Mh/s to 4.3 M/hs using this and just by moving those 8 files from the 14.6 directory, rather than the full driver update.

My config. is as follows if anyone is struggling :

Quote
"kernel" : "x11mod",
"intensity" : "20",
"vectors": "1",
"thread-concurrency" : "8193",
"worksize" : "256",
"lookup-gap" : "2",
"gpu-threads" : "2",
"gpu-engine" : "1150",
"gpu-fan" : "30-95",
"gpu-memclock" : "1550",
"gpu-memdiff" : "0,0,0,0",
"gpu-powertune" : "20",
"temp-cutoff" : "90",
"temp-overheat" : "85",
"temp-target" : "65",
"shaders" : "2048",
"api-allow" : "127.0.0.1,192.168.1/24",
"api-listen" : "true",
"api-mcast-port" : "4028",
"api-port" : "4028",
"auto-fan" : "true",
"expiry" : "1",
"nfactor": "11",
"failover-only" : "true",
"gpu-dyninterval" : "7",
"gpu-platform" : "1",
"log" : "5",
"log-dateformat" : "0",
"no-pool-disable" : true,
"no-submit-stale" : true,
"queue" : "0",
"scan-time" : "1",
"tcp-keepalive" : "30",
"temp-hysteresis" : "3",
"shares" : "0",
"kernel-path" : "/usr/local/bin"
}

http://i76.photobucket.com/albums/j36/hlxbravo/Noname.jpg



 Wink
1503035037
Hero Member
*
Offline Offline

Posts: 1503035037

View Profile Personal Message (Offline)

Ignore
1503035037
Reply with quote  #2

1503035037
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
DriverDan
Newbie
*
Offline Offline

Activity: 18


View Profile WWW
June 23, 2014, 09:27:26 PM
 #182

Has anyone checked if this increases utilization / increases power? Someone said temp went up so that would seem to indicate power draw is up.
jimlite
Legendary
*
Offline Offline

Activity: 1288


View Profile WWW
June 23, 2014, 09:37:43 PM
 #183

Anyone worried about the trojan hits on virustotal?

15-35% off anything on Amazon + .01 free BTC with Purse/Amazon https://t.co/ui0FEgypOX
Need to rent Big Hash https://www.nicehash.com/?refby=1393
NEED TO RENT A RIG? All algos at http://www.miningrigrentals.com/register?ref=627
TREZOR HARDWARE BTC SAFE WALLET http://tinyurl.com/olw2qe3
https://rawx.io Secure alt exchange that PAYS you interest!
BTC dice and FREE bitcoin faucet with only 1% edge https://t.co/blurpfa3Q4

  ✵ Super FAST block times      ✵ Block Explorer right in the wallet!     ✵ Stealth Addresses     ✵ PoW/PoS hybrid   
██
██
██
██
██
██
██
██
██
██
██
Ancient Money
for a New World
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
Join the conversation!
██
██
██
██
██
██
██
██
██
██
██

                 ▄████▄▄    ▄
██             ████████████▀
████▄         █████████████▀
▀████████▄▄   █████████████
▄▄█████████████████████████
██████████████████████████
  ▀██████████████████████
   █████████████████████
    ▀█████████████████▀
      ▄█████████████▀
▄▄███████████████▀
   ▀▀▀▀▀▀▀▀▀▀▀

TWITTER


jimlite
Legendary
*
Offline Offline

Activity: 1288


View Profile WWW
June 23, 2014, 09:44:28 PM
 #184

OP djm's mega link doesn't' work.
Kozmos link fails virustotal.
Can OP post link again?

15-35% off anything on Amazon + .01 free BTC with Purse/Amazon https://t.co/ui0FEgypOX
Need to rent Big Hash https://www.nicehash.com/?refby=1393
NEED TO RENT A RIG? All algos at http://www.miningrigrentals.com/register?ref=627
TREZOR HARDWARE BTC SAFE WALLET http://tinyurl.com/olw2qe3
https://rawx.io Secure alt exchange that PAYS you interest!
BTC dice and FREE bitcoin faucet with only 1% edge https://t.co/blurpfa3Q4

  ✵ Super FAST block times      ✵ Block Explorer right in the wallet!     ✵ Stealth Addresses     ✵ PoW/PoS hybrid   
██
██
██
██
██
██
██
██
██
██
██
Ancient Money
for a New World
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
Join the conversation!
██
██
██
██
██
██
██
██
██
██
██

                 ▄████▄▄    ▄
██             ████████████▀
████▄         █████████████▀
▀████████▄▄   █████████████
▄▄█████████████████████████
██████████████████████████
  ▀██████████████████████
   █████████████████████
    ▀█████████████████▀
      ▄█████████████▀
▄▄███████████████▀
   ▀▀▀▀▀▀▀▀▀▀▀

TWITTER


zing96
Sr. Member
****
Offline Offline

Activity: 266


View Profile
June 23, 2014, 11:27:25 PM
 #185

OP djm's mega link doesn't' work.
Kozmos link fails virustotal.
Can OP post link again?

OP's link does work...just not formatted correctly.

https://mega.co.nz/#!hZUAzQDQ!GrLynWXGP5wFIiDmFpXnTiXV-AI_bkXEFfQrJpbwF1o
jimlite
Legendary
*
Offline Offline

Activity: 1288


View Profile WWW
June 24, 2014, 01:32:18 AM
 #186

Oh, should have seen the different color in the link.
So I downloaded it, and virustotalled it.
DOESN'T THIS CONCERN ANYONE?

AntiVir    APPL/Bitcoinminer.Gen    20140623
Baidu-International    Hacktool.Win32.BitCoinMiner.BBF    20140623
DrWeb    Tool.BtcMine.141    20140623
ESET-NOD32    a variant of Win32/BitCoinMiner.BF    20140623
K7AntiVirus    Trojan ( 00494bd01 )    20140623           MAINLY THESE TROJANS, not the bitcoinminer!
K7GW    Trojan ( 00494bd01 )    20140623
Sophos    Generic PUA GF    20140623
Symantec    WS.Reputation.1    20140623
TrendMicro-HouseCall    Suspicious_GEN.F47V0620    20140623

15-35% off anything on Amazon + .01 free BTC with Purse/Amazon https://t.co/ui0FEgypOX
Need to rent Big Hash https://www.nicehash.com/?refby=1393
NEED TO RENT A RIG? All algos at http://www.miningrigrentals.com/register?ref=627
TREZOR HARDWARE BTC SAFE WALLET http://tinyurl.com/olw2qe3
https://rawx.io Secure alt exchange that PAYS you interest!
BTC dice and FREE bitcoin faucet with only 1% edge https://t.co/blurpfa3Q4

  ✵ Super FAST block times      ✵ Block Explorer right in the wallet!     ✵ Stealth Addresses     ✵ PoW/PoS hybrid   
██
██
██
██
██
██
██
██
██
██
██
Ancient Money
for a New World
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
██
Join the conversation!
██
██
██
██
██
██
██
██
██
██
██

                 ▄████▄▄    ▄
██             ████████████▀
████▄         █████████████▀
▀████████▄▄   █████████████
▄▄█████████████████████████
██████████████████████████
  ▀██████████████████████
   █████████████████████
    ▀█████████████████▀
      ▄█████████████▀
▄▄███████████████▀
   ▀▀▀▀▀▀▀▀▀▀▀

TWITTER


Bojcha
Hero Member
*****
Offline Offline

Activity: 741



View Profile
June 24, 2014, 02:04:33 AM
 #187

what about 5xxx/6xxx cards?

daeminium
Sr. Member
****
Offline Offline

Activity: 367



View Profile
June 24, 2014, 02:07:45 AM
 #188

Huh??

the_g00se
Newbie
*
Offline Offline

Activity: 3


View Profile
June 24, 2014, 05:02:17 AM
 #189

Thread explaining how to update to 14.6b and compile on BAMT can be found here:  http://www.reddit.com/r/BAMT/comments/28xu3i/add_amd_146_drivers_and_djm34s_optimized_sgminer/


Achieving 2.7mh/R9270 with this version!  16mh for the rig. Thank you djm34!!

planeswalker
Newbie
*
Offline Offline

Activity: 15


View Profile
June 24, 2014, 05:03:08 AM
 #190

If anyone had issues with "locked clock" speeds, I figured out what was causing mine.  One of my rigs has 4x 290x cards in it.  MSI afterburner recently expired, so I upgraded to the latest beta.  This upgrade didn't keep the "enable unofficial overclocking" setting to whatever you had it before.  I re-enabled it, bam, I can change core/mem clock speeds and not have my cards crash at the defaults.

BURST-FLGD-2KP4-X38S-6KSFY
DedRes
Newbie
*
Offline Offline

Activity: 11


View Profile
June 24, 2014, 05:06:51 AM
 #191


Then u need x13mod-old.

I tried it and got an Error (both x13mod and x13modold):
[08:01:59] Error -11: Building Program (clBuildProgram)
[08:01:59] "C:\Users\leonz\AppData\Local\Temp\OCL352T5.cl", line 1106: error: identifier
          "buf" is undefined
          INPUT_BIG;
          ^

"C:\Users\leonz\AppData\Local\Temp\OCL352T5.cl", line 1112: error: identifier          "buf" is undefined



Try to change -p xxx
just xxx instead what you have now.

try to use -o stratum+tcp://ca.p2pool.sk:7903 -u <whateverdarkcoinaddress> -p xxx

just to see if you get some work.


Tried. No change.


Furthermore.
Today @ morning my antivirus found a trojan in the fixed version. I see people already complained about that. So, I just confirm it.
Switching to NON-fixed version now..

Any suggestion of how to get this stuff to work?
Litejavichu
Hero Member
*****
Offline Offline

Activity: 675



View Profile
June 24, 2014, 05:48:46 AM
 #192

what about 5xxx/6xxx cards?

Run fine in 13.12 5850hd 
I18 TC6144
If you let the sgminer compile the default kernel (tc6016) gives problems. Edit a config to tc6144

Reinstall the drivers from the windows panel, not the whole process of catalyst
DedRes
Newbie
*
Offline Offline

Activity: 11


View Profile
June 24, 2014, 09:02:34 AM
 #193

Hmm
I suspect I may have some ports filtered out.
Does anybody know the X11 pool operating on port 80, 8080 or 443?

sesko
Sr. Member
****
Offline Offline

Activity: 392


View Profile
June 24, 2014, 09:34:27 AM
 #194

If this helps anybody:

2x r9 280x Vapor-x gains (using 14.6 fixed version of sgminer).

- Windows 8.1
- updated to 14.4 ATI drivers, did not gain anything.
- uninstalled drivers with DDU (highly recommended you use this to remove ATI drivers)
- Installed 14.6 ATI beta drivers (without HDMI audio drivers)

x11 data:
--- x11: 4,1Mh/s hashrate on both, it was not stable at first using old sgminer settings
   - bumped up just little GPU core, from 1060 to 1075 (at 1100 i got a lot of HW errors)
   - less undervoltage, before i was having 1,09V, now 1,11V
   - stable 48hours without HW errors
gains combined both gpu's:
   - before 6,2Mh/s......now 8,2Mh/s,   33% gain
   - electricity: before 295W..... now 315W,  7% more electric consumption.
BAT FILE BASIC SETTINGS: --thread-concurrency 8192,8191 -g 2,2 -I 18,18 -w 256,256 --auto-fan --gpu-memclock 1488,1488 --gpu-engine 1075,1075 --gpu-powertune -20,-20

x13 data:
--- x13: 3,1Mh/s on both
   - same settings and vboltage as x11
gains combined both gpu's:
   - before 5Mh/s .... now 6,2 Mh/s  20% gain
   -  electricity not measured yet
BAT FILE BASIC SETTINGS: --thread-concurrency 8192,8191 -g 2,2 -I 18,18 -w 128,128 --auto-fan --gpu-memclock 1488,1488 --gpu-engine 1075,1075 --gpu-powertune -20,-20

As you can see, only difference in settings between x11 and x13 is in worksize. Rest is the same. Trying to bumping up intensity, memclock, thread-concurrency and gpu powertune did not gave nothing more.
innergy
Hero Member
*****
Offline Offline

Activity: 588


View Profile
June 24, 2014, 09:42:26 AM
 #195

Got 4.85MH/s stable on 290
Win 7 x64, 14.6, 1000/1300 (every higher memclock causes SICK message sooner or later, due to the known 150-1350 variance.. I think)

Quote
sgminer -k x11mod -o stratum+tcp://drk.coinmine.pl:6090 -u ... -p ... -g 1 -w 128 --lookup-gap 2 --thread-concurrency 8192 --intensity 19 --gpu-engine 1000 --gpu-memclock 1300 --gpu-powertune 20 --auto-fan --temp-target 70
nfox
Sr. Member
****
Offline Offline

Activity: 434


View Profile WWW
June 24, 2014, 01:37:38 PM
 #196

Anyone tested with linux? what catalyst?
OPTiK
Full Member
***
Offline Offline

Activity: 122


View Profile
June 24, 2014, 03:09:41 PM
 #197

Any gains for r9 270? What are people hashing?
whocares
Full Member
***
Offline Offline

Activity: 160


View Profile
June 24, 2014, 03:41:26 PM
 #198

Diamond kernel doesn't work(creates ckolivas binary and throws many HW errors).
Should be great if it gets fixed cos groestlcoin kernel doesn't support DMD stratum.
litecoinbeast
Full Member
***
Offline Offline

Activity: 123


View Profile
June 24, 2014, 03:56:55 PM
 #199

Any gains for r9 270? What are people hashing?

x11 ~ 2.7
x13 ~ 2.0

The sweet part being still using 13.12 drivers with 14.6 opencl dropped in to folder. So didn't have to use "modded" drivers for Win7x64 to get the 5 270x "recognized".

Was getting ~2.0 and ~1.7 respectively before.

Took about 5 mins...didn't change a thing in bat or conf file.
kaltar
Full Member
***
Offline Offline

Activity: 205


View Profile
June 24, 2014, 03:58:36 PM
 #200

Well i;m posting my problem in case someone read this on a previous threads.

all my cards are hashing at the increased Hashrate, GREAT Job btw, you guys are coming up with great improvement before i can deploys the previous ones  Grin

so here is my problems, i have R9 280X and r9 270x running stable
but my Gigabyte R9 290x starts off at full speed, 5.5 mh/s on x11 but at an indeterminate time it will drop to about half speed, card restart doesn't fix this, i have to reboot.

it does this on sgminer416, and also on the sgminer5 and LSB version also. i read other people having this issue, but can't pinpoint the threads anymore.

anyone .?

thanks
Pages: « 1 2 3 4 5 6 7 8 9 [10] 11 12 13 14 15 16 17 18 19 »  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!