Bitcoin Forum
December 08, 2016, 06:28:19 AM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 ... 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 [119] 120 121 122 123 124 125 126 127 128 129 »
  Print  
Author Topic: Cairnsmore1 - Quad XC6SLX150 Board  (Read 251295 times)
ebereon
Sr. Member
****
Offline Offline

Activity: 407


View Profile
November 29, 2012, 05:33:36 PM
 #2361

the Icarus bitstreams from makomk have a watchdog for the dcm clock or how is it called. So if this hangs (Enterpoint CM1 Bug) the watchdog resets the clocks immediately (no idle fpga).

With the Hashvoodoo bitstream, this take care only on clock correction wich is happening every X shares/X seconds. So if you have "bad" boards, it can cost some Mhs as the reset is not immediately when a fpga(dcm clock) freezes.

I hope i have explained it in some correct way  Wink   (i'm not a pro in this!) Tongue

1481178499
Hero Member
*
Offline Offline

Posts: 1481178499

View Profile Personal Message (Offline)

Ignore
1481178499
Reply with quote  #2

1481178499
Report to moderator
1481178499
Hero Member
*
Offline Offline

Posts: 1481178499

View Profile Personal Message (Offline)

Ignore
1481178499
Reply with quote  #2

1481178499
Report to moderator
1481178499
Hero Member
*
Offline Offline

Posts: 1481178499

View Profile Personal Message (Offline)

Ignore
1481178499
Reply with quote  #2

1481178499
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481178499
Hero Member
*
Offline Offline

Posts: 1481178499

View Profile Personal Message (Offline)

Ignore
1481178499
Reply with quote  #2

1481178499
Report to moderator
Clearfly
Full Member
***
Offline Offline

Activity: 143



View Profile
December 01, 2012, 01:29:38 PM
 #2362

What Jtag cable do you guys recommend using on the CM1?
spiccioli
Legendary
*
Offline Offline

Activity: 1376

nec sine labore


View Profile
December 01, 2012, 02:30:13 PM
 #2363

What Jtag cable do you guys recommend using on the CM1?

BTW,

given a jtag cable tricone mining bitstream should work on CM1, did anyone with a jtag cable make any test?

spiccioli
Keninishna
Hero Member
*****
Offline Offline

Activity: 551



View Profile WWW
December 03, 2012, 12:45:05 PM
 #2364

What Jtag cable do you guys recommend using on the CM1?

BTW,

given a jtag cable tricone mining bitstream should work on CM1, did anyone with a jtag cable make any test?

spiccioli

Last I heard was from chrisp saying only 1 outta 4 cores will work as there is no dcm watchdog in tml. I tried to get ET to implement one but he claims the interface is proprietary, even though im pretty sure its not.
yohan
Sr. Member
****
Offline Offline

Activity: 448



View Profile
December 14, 2012, 08:55:44 PM
 #2365

The team at Enterpoint are having a break for Christmas and New Year and we will have a very minimal email support over the holiday period from 21st Dec to 7th Jan. After a year where the team have worked extremely hard they are having and deserve a big break from work. On behalf of all the team I would like to take this opportunity to wish you all a Merry Christmas and Happy New Year and particularly to thank all of you that purchased the many thousands of Cairnsmore1 we produced this year making the project a huge success.

We did some projections and believe that Cairnsmore1, as a Bitcoin mining board, will remain profitable for some time to come even though return has already halved and ASICs will further reduce profit if they actually appear. As with all these things we could be wrong and once we fire up Goliath we hope to put a little time into examining the viability of Litecoin mining on Cairnsmore1 as a possible alternative. That won't automatically mean that bitstream will be generated but that will be a consideration. It may be too expensive a task for us to justify doing it now so I don't want to promise it happening.

Yohan
mila
Sr. Member
****
Offline Offline

Activity: 462



View Profile
January 14, 2013, 11:24:02 PM
 #2366

happy new year everyone!

your ad here:
LazyOtto
Sr. Member
****
Offline Offline

Activity: 476


View Profile
January 15, 2013, 12:55:18 AM
 #2367

Welcome to the ignore list.
yohan
Sr. Member
****
Offline Offline

Activity: 448



View Profile
January 20, 2013, 12:16:03 PM
 #2368

Cairnsmore1 schematics are now available on http://www.enterpoint.co.uk/cairnsmore/CAIRNSMORE1_ISSUE_1_1.pdf for those of you that want to do other things with your board.

Yohan
Clearfly
Full Member
***
Offline Offline

Activity: 143



View Profile
January 20, 2013, 06:06:55 PM
 #2369

Thanks Yohan.

Any decisions yet regarding whether you guys plan to venture into an ASIC miner?
I live about 8 miles from Malvern so would prefer to buy from someone in the UK.
yohan
Sr. Member
****
Offline Offline

Activity: 448



View Profile
January 20, 2013, 07:04:43 PM
 #2370

Thanks Yohan.

Any decisions yet regarding whether you guys plan to venture into an ASIC miner?
I live about 8 miles from Malvern so would prefer to buy from someone in the UK.

For the moment we not releasing what we have. This is a background project for us and our time is mainly being spent elsewhere. Basically we don't want any pressure of releasing, building, shipping and supporting a product at this time. I think we will continue that way for a while with Goliath going into test at a pace that suits us.
Isokivi
Hero Member
*****
Offline Offline

Activity: 924


Items flashing here available at btctrinkets.com


View Profile WWW
January 20, 2013, 07:08:06 PM
 #2371

For the moment we not releasing what we have. This is a background project for us and our time is mainly being spent elsewhere. Basically we don't want any pressure of releasing, building, shipping and supporting a product at this time. I think we will continue that way for a while with Goliath going into test at a pace that suits us.

A ha! So you have something going on, consider the pressure to be on Smiley

Bitcoin trinkets now on my online store: btc trinkets.com <- Bitcoin Tiepins, cufflinks, lapel pins, keychains, card holders and challenge coins.
Beaflag VonRathburg
Sr. Member
****
Offline Offline

Activity: 472



View Profile
February 17, 2013, 10:10:29 PM
 #2372

I need a little help troubleshooting an issue with one of my CM1 boards. One of the unused fan headers managed to get some moisture on it and burnt out. The middle pin actually burnt through the board and has left that typical black mark everyone who's mined long enough is used to seeing on hardware. When it happened the board was still mining, but reporting 100% hardware errors, and stopped the rig from accepting shares. Resetting CGMiner caused the board not to be recognized, reporting COM errors. When, I plug in the USB cable the power light comes on, but the fan doesn't spin. I tried the fan on all of the remaining headers, but they don't work either. Instead, I used a molex adapter to get the fan to turn on and set switch 2 to off:



That still reports COM errors with CGMiner and it won't pickup the board. If anyone has any other ideas on things I could test let me know. Any help would be greatly appreciated.

LazyOtto
Sr. Member
****
Offline Offline

Activity: 476


View Profile
February 17, 2013, 10:24:33 PM
 #2373

That still reports COM errors with CGMiner
So, you're using Windows it looks like.

Have you looked to see if the OS detects the USB device? (System Properties | Device Manager)

If you don't get that far then the board is dead in the water.

I assume you cleaned up around the fried part to ensure no shorts still exist in that area.

Bottom line, if the OS won't even see it as a USB device, your next step will have to be if it can be recognized on a JTAG cable. If you can get a JTAG connection, from there see if the controller firmware / flash is corrupted or needs to be re-flashed.
Beaflag VonRathburg
Sr. Member
****
Offline Offline

Activity: 472



View Profile
March 15, 2013, 02:04:10 PM
 #2374

That still reports COM errors with CGMiner
So, you're using Windows it looks like.

Have you looked to see if the OS detects the USB device? (System Properties | Device Manager)

If you don't get that far then the board is dead in the water.

I assume you cleaned up around the fried part to ensure no shorts still exist in that area.

Bottom line, if the OS won't even see it as a USB device, your next step will have to be if it can be recognized on a JTAG cable. If you can get a JTAG connection, from there see if the controller firmware / flash is corrupted or needs to be re-flashed.

Took some time, but I have been working on this again lately. I cleaned the board off to give it another go at getting it to work. This is what it was doing when it decided to go crazy and stop working:



Still using the molex fan adapter I plug the board in and it gets detected as:


When both boards were working COMs 24-27 were what were used to get them mining. Without either board plugged in they are still there. The board is detected by USB and lights up fine, but I can't get CGMiner to detect it to start mining. How would I got about checking the controller firmware and flash storage?

LazyOtto
Sr. Member
****
Offline Offline

Activity: 476


View Profile
March 15, 2013, 02:20:19 PM
 #2375

How would I got about checking the controller firmware and flash storage?
Can only be done with a JTAG cable connection.

-- edit

But you might as well just try re-flashing it anyway, without bothering to check if the current image is corrupted.
ocminer
Legendary
*
Offline Offline

Activity: 1582



View Profile WWW
March 15, 2013, 03:58:50 PM
 #2376

A board of mine stopped working two days ago..

It is now only producing invalid shares.. It was running for months without a problem..

Temperatures seem ok, fan also, maybe some power issue.. All my other boards are running fine, tried a new power source and new usb cable, it only makes 1-2 valid shares, then only invalids.. very odd...

suprnova pools - reliable mining pools - #suprnova on freenet
https://www.suprnova.cc - FOLLOW us @ Twitter ! twitter.com/SuprnovaPools
Beaflag VonRathburg
Sr. Member
****
Offline Offline

Activity: 472



View Profile
March 15, 2013, 06:06:21 PM
 #2377

How would I got about checking the controller firmware and flash storage?
Can only be done with a JTAG cable connection.

-- edit

But you might as well just try re-flashing it anyway, without bothering to check if the current image is corrupted.

Something along the lines of? http://www.ebay.com/itm/USB-Blaster-Programmer-Cable-For-Mini-Altera-FPGA-CPLD-JTAG-Development-Board-/190789410429?pt=LH_DefaultDomain_0&hash=item2c6bef5e7d

A board of mine stopped working two days ago..

It is now only producing invalid shares.. It was running for months without a problem..

Temperatures seem ok, fan also, maybe some power issue.. All my other boards are running fine, tried a new power source and new usb cable, it only makes 1-2 valid shares, then only invalids.. very odd...

That's how I found out mine stopped working. It wouldn't allow the rig to submit any value shares.

LazyOtto
Sr. Member
****
Offline Offline

Activity: 476


View Profile
March 15, 2013, 06:29:35 PM
 #2378

Something along the lines of? ...
Yes, something along that line.

But I'm pretty sure that one will not work with these boards.

If you search through my postings you'll find where I found one which works for me. (I'm sure you can find one cheaper than I did if you go through eBay.)

However, I do suggest you just try flashing the firmware using your existing USB connection before you go through the hassle and expense of gearing up to use JTAG. (I'm a developer, so I had additional justifications for the tool / toy.)

Enterpoint has given complete instructions on how to update / flash the firmware on the CM1's. Search and ye shall find.
Keninishna
Hero Member
*****
Offline Offline

Activity: 551



View Profile WWW
March 15, 2013, 09:22:26 PM
 #2379

A board of mine stopped working two days ago..

It is now only producing invalid shares.. It was running for months without a problem..

Temperatures seem ok, fan also, maybe some power issue.. All my other boards are running fine, tried a new power source and new usb cable, it only makes 1-2 valid shares, then only invalids.. very odd...

A board of mine has stopped worked a few days ago as well :/ the thing will just endlessly power cycle. Power up for a minute hash some invalids then turn off then turn on. I also have another board with one fpga producing invalids. I wonder if enterpoints warranty is still valid? I may try makomk's bitstream on them just to see if it makes a difference.
Beaflag VonRathburg
Sr. Member
****
Offline Offline

Activity: 472



View Profile
March 15, 2013, 10:50:26 PM
 #2380

Newest Issue:



Switches set per Enterpoint recommendations SW1 = On,On,On,On / SW6 = On,Off,On,On , board is detected, driver installed, and trying to flash 1.5 controller. Nothing happens.

Pages: « 1 ... 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 [119] 120 121 122 123 124 125 126 127 128 129 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!