Bitcoin Forum
May 24, 2018, 06:06:46 PM *
News: Latest stable version of Bitcoin Core: 0.16.0  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: « 1 ... 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 [64] 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 ... 244 »
  Print  
Author Topic: █▓▒░-< [ZPOOL.CA][FlexFee™][SegWit] The miners multipool >-░▒▓█  (Read 193595 times)
This is a self-moderated topic. If you do not want to be moderated by the person who started this topic, create a new topic.
JaredKaragen
Legendary
*
Offline Offline

Activity: 966
Merit: 1009


★YoBit.Net★ 350+ Coins Exchange & Dice


View Profile
July 25, 2017, 09:10:45 PM
 #1261

note to all users mining skunk:

disable stats.  Do not add it to the password string.

I have been having miner crashes upon the pool asking for stats.

Not sure why its happening, but it does... and the miners don't crash when its not in the password string.

adding a pause to the end of the batch, let me see the final sting every time it crashed, and every single time it crashed;  its message was that the pool asked for stats.


At first It was only happening to my maxwell cards, but it seems to be happening to my pascal cards also... albeit takes much longer to crash on pascal cards than on maxwell cards.


I seriously doubt this would be a problem with the pool;  unless the pool sends something erroneous right after asking for stats.....  But you might want to look into it crackfoo if it's something that's added to stratum during the coin/algo setup process.

thanks will check with tpruvot

are you on windows10?

yup.

driver version is different between both machines too.

The machine with the 1070 is running 378.78

It looks like phillipma's test card also crashed;  I presume from the same problem.   I'm not sure if he runs 7 or 10.

happens both with the algo dev's version on the ANN thread, and the SP version.

Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1527185206
Hero Member
*
Offline Offline

Posts: 1527185206

View Profile Personal Message (Offline)

Ignore
1527185206
Reply with quote  #2

1527185206
Report to moderator
1527185206
Hero Member
*
Offline Offline

Posts: 1527185206

View Profile Personal Message (Offline)

Ignore
1527185206
Reply with quote  #2

1527185206
Report to moderator
crackfoo
Legendary
*
Offline Offline

Activity: 1610
Merit: 1105



View Profile WWW
July 26, 2017, 03:39:45 PM
 #1262

Your posts are deleted cause there is a thread for you all to talk about it. Move it or continue to be deleted.

ZPOOL - the miners multipool! Support | Paid 1150+ BTC(2016) - 1800+ BTC(2017)  | Mining LTC/LCC/BCA/DASH/KMD/ZCL | UNBELIEVER

▓▓▓ CLOUD MINING   ✔    HASH RENTAL ▓▓▓
Jaerin
Full Member
***
Offline Offline

Activity: 140
Merit: 100


View Profile
July 26, 2017, 04:00:35 PM
 #1263

I understand, I made no complaints about it.   It wasn't appropriate to discuss mining on other pools in this thread.  I apologize.
crackfoo
Legendary
*
Offline Offline

Activity: 1610
Merit: 1105



View Profile WWW
July 26, 2017, 04:32:03 PM
 #1264

I understand, I made no complaints about it.   It wasn't appropriate to discuss mining on other pools in this thread.  I apologize.

thnx

ya'all are free to mine where ever you want.

I understand their are oddities, the exchange mode is not supported or tested by the maintainer but it is all open source and regardless pays more than other multipool IMO. I'm not a dev. I welcome changes if there are better way to run the exchange mode: https://github.com/tpruvot/yiimp

or of course, you can run your own.

Cheers

ZPOOL - the miners multipool! Support | Paid 1150+ BTC(2016) - 1800+ BTC(2017)  | Mining LTC/LCC/BCA/DASH/KMD/ZCL | UNBELIEVER

▓▓▓ CLOUD MINING   ✔    HASH RENTAL ▓▓▓
cryptolelefla
Member
**
Offline Offline

Activity: 121
Merit: 10


View Profile
July 26, 2017, 04:51:54 PM
 #1265

trying to configure miner
-a skunk -o stratum+tcp://skunk.mine.zpool.ca:8433 -u my_btc_wallet -p c=SIGT -i 25
this is for be payed in btc


-a skunk -o stratum+tcp://skunk.mine.zpool.ca:8433 -u my_sight_wallet -p c=SIGT -i 25
this if SIGHT pay

is this correct?
also i got hash tap, but don't know what they are
crackfoo
Legendary
*
Offline Offline

Activity: 1610
Merit: 1105



View Profile WWW
July 26, 2017, 04:56:14 PM
 #1266

trying to configure miner
-a skunk -o stratum+tcp://skunk.mine.zpool.ca:8433 -u my_btc_wallet -p c=SIGT -i 25
this is for be payed in btc


-a skunk -o stratum+tcp://skunk.mine.zpool.ca:8433 -u my_sight_wallet -p c=SIGT -i 25
this if SIGHT pay

is this correct?
also i got hash tap, but don't know what they are

not quite right. the c= has to match what wallet you are using.


-a skunk -o stratum+tcp://skunk.mine.zpool.ca:8433 -u my_btc_wallet -p c=BTC -i 25
this is for be payed in btc


-a skunk -o stratum+tcp://skunk.mine.zpool.ca:8433 -u my_sigt_wallet -p c=SIGT -i 25
this if SIGT pay

ZPOOL - the miners multipool! Support | Paid 1150+ BTC(2016) - 1800+ BTC(2017)  | Mining LTC/LCC/BCA/DASH/KMD/ZCL | UNBELIEVER

▓▓▓ CLOUD MINING   ✔    HASH RENTAL ▓▓▓
cryptolelefla
Member
**
Offline Offline

Activity: 121
Merit: 10


View Profile
July 26, 2017, 05:42:44 PM
 #1267

trying to configure miner
-a skunk -o stratum+tcp://skunk.mine.zpool.ca:8433 -u my_btc_wallet -p c=SIGT -i 25
this is for be payed in btc


-a skunk -o stratum+tcp://skunk.mine.zpool.ca:8433 -u my_sight_wallet -p c=SIGT -i 25
this if SIGHT pay

is this correct?
also i got hash tap, but don't know what they are

not quite right. the c= has to match what wallet you are using.


-a skunk -o stratum+tcp://skunk.mine.zpool.ca:8433 -u my_btc_wallet -p c=BTC -i 25
this is for be payed in btc


-a skunk -o stratum+tcp://skunk.mine.zpool.ca:8433 -u my_sigt_wallet -p c=SIGT -i 25
this if SIGT pay
ty Sir
Jaerin
Full Member
***
Offline Offline

Activity: 140
Merit: 100


View Profile
July 26, 2017, 05:55:17 PM
 #1268

I understand, I made no complaints about it.   It wasn't appropriate to discuss mining on other pools in this thread.  I apologize.

thnx

ya'all are free to mine where ever you want.

I understand their are oddities, the exchange mode is not supported or tested by the maintainer but it is all open source and regardless pays more than other multipool IMO. I'm not a dev. I welcome changes if there are better way to run the exchange mode: https://github.com/tpruvot/yiimp

or of course, you can run your own.

Cheers

Thank you I appreciate you saying this.  Can you post what value you have YAAMP_FEES_EXCHANGE set to in your config?  Or better yet any of the relevant fees settings in the server config?  Perhaps there is a setting that should be .2 instead of 2 and that's causing the normal 2% to be 20%.

I'm looking over the Yiimp code and trying to determine if it is in fact a bug or some config that is set incorrectly.

As I mentioned before I don't think that anyone would protest to paying some fees for autoexchange as long as they were stated up front so someone could decide if the fee is worth the trouble or not.
olek82
Newbie
*
Offline Offline

Activity: 23
Merit: 0


View Profile
July 26, 2017, 06:13:05 PM
 #1269

hi,

i am mining blake2s on zpool. i would like to get paid out in verge coins, this is my .bat:

ccminer -a blake2s -o stratum+tcp://blake2s.mine.zpool.ca:5766 -u my_verge_wallet -p c=XVG-blake2s

is this right? when i check my wallet on zpool it shows me the values in Unobtanium(UNO) Huh. will i get paid in XVG in the end?

thx
Lercker
Sr. Member
****
Offline Offline

Activity: 322
Merit: 250


View Profile
July 26, 2017, 06:16:40 PM
 #1270

hi,

i am mining blake2s on zpool. i would like to get paid out in verge coins, this is my .bat:

ccminer -a blake2s -o stratum+tcp://blake2s.mine.zpool.ca:5766 -u my_verge_wallet -p c=XVG

is this right? when i check my wallet on zpool it shows me the values in Unobtanium(UNO) Huh. will i get paid in XVG in the end?

thx
Should look like that...
Jaerin
Full Member
***
Offline Offline

Activity: 140
Merit: 100


View Profile
July 26, 2017, 06:20:40 PM
 #1271

Just be aware that when you get paid out in other coins other than BTC it is not the same as though you are direct mining the coin.  As the price of the coin/BTC pair changes the amount of coins you get will change because you are credited the mBTC value of the coin and then converted not paid directly what coins you mine.   This is just a fact of how the auto exchange stuff working on Yiimp pools right now.
olek82
Newbie
*
Offline Offline

Activity: 23
Merit: 0


View Profile
July 26, 2017, 06:33:37 PM
 #1272

Quote
Should look like that...

thank you

Quote
Just be aware that when you get paid out in other coins other than BTC it is not the same as though you are direct mining the coin.  As the price of the coin/BTC pair changes the amount of coins you get will change because you are credited the mBTC value of the coin and then converted not paid directly what coins you mine.   This is just a fact of how the auto exchange stuff working on Yiimp pools right now.

ah okay have to keep an eye on that, thanks
Storx
Full Member
***
Offline Offline

Activity: 322
Merit: 132


View Profile
July 26, 2017, 07:13:36 PM
 #1273

I understand, I made no complaints about it.   It wasn't appropriate to discuss mining on other pools in this thread.  I apologize.

thnx

ya'all are free to mine where ever you want.

I understand their are oddities, the exchange mode is not supported or tested by the maintainer but it is all open source and regardless pays more than other multipool IMO. I'm not a dev. I welcome changes if there are better way to run the exchange mode: https://github.com/tpruvot/yiimp

or of course, you can run your own.

Cheers

crackfoo,

Is there a exchange fee charged to us from going from mined coin to btc outside of the 2% pool fee. I am trying to understand things a little more, after seeing what Jaerin said. I went back and checked my last 50 earnings when they were exchanged. Not knowing the transaction data... after comparing them all 93% of the payouts i received based on share % of coins i mined based on website stated numbers were all below not only the period mined lows, but 93% of payouts were at rates below the 24hr exchange lows.

I am not sure what is going on, but i think something needs to be looked into, either the website is reporting wrong or an internal script is paying out with to much fee added to it. I really would hate to leave the pool, because i have supported the pool, so if you can look into this more for me and possibly resolve it i would love to continue supporting the pool and move all my rigs back over, but SIGT payouts just were not making sense. I prefer your pool, because i typically use a multi-algo setup on your pool and dislike having to exchange things myself.

- GPUs Mining : 128 (Updated 3/7/18) // CPUs Mining : 19 (Updated 2/23/18)
crackfoo
Legendary
*
Offline Offline

Activity: 1610
Merit: 1105



View Profile WWW
July 26, 2017, 07:17:14 PM
 #1274


Thank you I appreciate you saying this.  Can you post what value you have YAAMP_FEES_EXCHANGE set to in your config?  Or better yet any of the relevant fees settings in the server config?  Perhaps there is a setting that should be .2 instead of 2 and that's causing the normal 2% to be 20%.

I'm looking over the Yiimp code and trying to determine if it is in fact a bug or some config that is set incorrectly.

As I mentioned before I don't think that anyone would protest to paying some fees for autoexchange as long as they were stated up front so someone could decide if the fee is worth the trouble or not.

YAAMP_FEES_EXCHANGE = 5

ZPOOL - the miners multipool! Support | Paid 1150+ BTC(2016) - 1800+ BTC(2017)  | Mining LTC/LCC/BCA/DASH/KMD/ZCL | UNBELIEVER

▓▓▓ CLOUD MINING   ✔    HASH RENTAL ▓▓▓
jmayniac
Jr. Member
*
Online Online

Activity: 68
Merit: 0


View Profile
July 26, 2017, 09:33:05 PM
 #1275

crackfoo,

Is there a exchange fee charged to us from going from mined coin to btc outside of the 2% pool fee. I am trying to understand things a little more, after seeing what Jaerin said. I went back and checked my last 50 earnings when they were exchanged. Not knowing the transaction data... after comparing them all 93% of the payouts i received based on share % of coins i mined based on website stated numbers were all below not only the period mined lows, but 93% of payouts were at rates below the 24hr exchange lows.

I am not sure what is going on, but i think something needs to be looked into, either the website is reporting wrong or an internal script is paying out with to much fee added to it. I really would hate to leave the pool, because i have supported the pool, so if you can look into this more for me and possibly resolve it i would love to continue supporting the pool and move all my rigs back over, but SIGT payouts just were not making sense. I prefer your pool, because i typically use a multi-algo setup on your pool and dislike having to exchange things myself.

I've been using the ZPool for a while now and I confirm your findings.  Something seems off somewhere in the exchange process.  I'd rather not move away either as I am doing ok here, but it's getting harder to justify staying.  Maybe Crackfoo can look into this and let us know for sure.
olek82
Newbie
*
Offline Offline

Activity: 23
Merit: 0


View Profile
July 27, 2017, 12:01:48 AM
 #1276

when using blake2s on zpool, is it possible to only mine verge or neva etc. ? thx
crackfoo
Legendary
*
Offline Offline

Activity: 1610
Merit: 1105



View Profile WWW
July 27, 2017, 12:16:05 AM
 #1277

when using blake2s on zpool, is it possible to only mine verge or neva etc. ? thx

Nope, it's a multipool. It'll mine whatever it deems appropriate.

ZPOOL - the miners multipool! Support | Paid 1150+ BTC(2016) - 1800+ BTC(2017)  | Mining LTC/LCC/BCA/DASH/KMD/ZCL | UNBELIEVER

▓▓▓ CLOUD MINING   ✔    HASH RENTAL ▓▓▓
Jaerin
Full Member
***
Offline Offline

Activity: 140
Merit: 100


View Profile
July 27, 2017, 12:21:19 AM
 #1278

I think I figured it out after looking at the Yiimp code.  The relevant function that I believe is causing the issues is as follows:

In web\yaamp\core\backend\markets.php on line 203

Code:
function AverageIncrement($value1, $value2)
{
$percent = 80;
$value = ($value1*(100-$percent) + $value2*$percent) / 100;

return $value;
}

This function is used for pretty much every price lookup from the markets.  The purpose of this function is to create a weighted value based upon 20% of value1 and 80% of value2.  The reason for doing it is to create a trailing average for price moves.  As an example in the price look up for any of the exchanges.

web\yaamp\core\exchange\bittrex.php on line 61-63

Code:
$price2 = ($m->Bid + $m->Ask)/2;
$market->price2 = AverageIncrement($market->price2, $price2);
$market->price = AverageIncrement($market->price, $m->Bid);


The purpose of this code is to first get the average of the Bid and Ask and put it in price2.
Next it sets the price2 value to the weighted value of the previous price2 and the current price2.  This would be a 20% weight of the old price + 80% value of the new price.
Finally it sets the price value to the weighted value of the previous price and the current bid.  This would be a 20% weight of the old bid + 80% value of the new bid.

On paper this seems reasonable because if the price fluctuates by a significant margin it will trail that value and essentially smooth the movement out.  

This is significant because if you look at the AverageIncrement function and consider that if the previous price being passed in value1 does not exist then the function returns 80% of the current price2 or Bid.  So I think what might be happening is somehow the object is falling out of scope or some other issue that is causing that value1 to get a 0 amount and therefore the values coming out are 80% of the value they should be.

As a workaround until it can be determined if the values are being passed incorrectly or falling out of scope a line to check if value1 is 0 and if it is return the value2 should work around the issue.  I'm going to likely try and setup a Yiimp instance on a test VM and see if I can get values out of it to determine for sure if this is the problem.

I'll let you know what I find.  Crackfoo if you want to perhaps add some debug logging like the following it may be quicker for you to see:

Code:
function AverageIncrement($value1, $value2)
{
$percent = 80;
$value = ($value1*(100-$percent) + $value2*$percent) / 100;

        debuglog("AverageIncrement: $value1, $value2");

return $value;
}

Or report it to Tpruvot and see if he can look at it.  I'm pretty sure this is what is causing the issues.



Storx
Full Member
***
Offline Offline

Activity: 322
Merit: 132


View Profile
July 27, 2017, 03:21:08 AM
 #1279

I think I figured it out after looking at the Yiimp code.  The relevant function that I believe is causing the issues is as follows:

In web\yaamp\core\backend\markets.php on line 203

Code:
function AverageIncrement($value1, $value2)
{
$percent = 80;
$value = ($value1*(100-$percent) + $value2*$percent) / 100;

return $value;
}

This function is used for pretty much every price lookup from the markets.  The purpose of this function is to create a weighted value based upon 20% of value1 and 80% of value2.  The reason for doing it is to create a trailing average for price moves.  As an example in the price look up for any of the exchanges.

web\yaamp\core\exchange\bittrex.php on line 61-63

Code:
$price2 = ($m->Bid + $m->Ask)/2;
$market->price2 = AverageIncrement($market->price2, $price2);
$market->price = AverageIncrement($market->price, $m->Bid);


The purpose of this code is to first get the average of the Bid and Ask and put it in price2.
Next it sets the price2 value to the weighted value of the previous price2 and the current price2.  This would be a 20% weight of the old price + 80% value of the new price.
Finally it sets the price value to the weighted value of the previous price and the current bid.  This would be a 20% weight of the old bid + 80% value of the new bid.

On paper this seems reasonable because if the price fluctuates by a significant margin it will trail that value and essentially smooth the movement out.  

This is significant because if you look at the AverageIncrement function and consider that if the previous price being passed in value1 does not exist then the function returns 80% of the current price2 or Bid.  So I think what might be happening is somehow the object is falling out of scope or some other issue that is causing that value1 to get a 0 amount and therefore the values coming out are 80% of the value they should be.

As a workaround until it can be determined if the values are being passed incorrectly or falling out of scope a line to check if value1 is 0 and if it is return the value2 should work around the issue.  I'm going to likely try and setup a Yiimp instance on a test VM and see if I can get values out of it to determine for sure if this is the problem.

I'll let you know what I find.  Crackfoo if you want to perhaps add some debug logging like the following it may be quicker for you to see:

Code:
function AverageIncrement($value1, $value2)
{
$percent = 80;
$value = ($value1*(100-$percent) + $value2*$percent) / 100;

        debuglog("AverageIncrement: $value1, $value2");

return $value;
}

Or report it to Tpruvot and see if he can look at it.  I'm pretty sure this is what is causing the issues.





Good work man, honestly i hope we can figure this stuff out and get back to normal payouts, i honestly want to stay on on this pool, because i am not a full time miner and need the mining operation to convert for me automatic when im busy working my normal 9to5 job... just hope crackfoo can get to the bottom of this....

- GPUs Mining : 128 (Updated 3/7/18) // CPUs Mining : 19 (Updated 2/23/18)
jmayniac
Jr. Member
*
Online Online

Activity: 68
Merit: 0


View Profile
July 27, 2017, 02:13:32 PM
 #1280

I think I figured it out after looking at the Yiimp code.  The relevant function that I believe is causing the issues is as follows:

In web\yaamp\core\backend\markets.php on line 203

Code:
function AverageIncrement($value1, $value2)
{
$percent = 80;
$value = ($value1*(100-$percent) + $value2*$percent) / 100;

return $value;
}

This function is used for pretty much every price lookup from the markets.  The purpose of this function is to create a weighted value based upon 20% of value1 and 80% of value2.  The reason for doing it is to create a trailing average for price moves.  As an example in the price look up for any of the exchanges.

web\yaamp\core\exchange\bittrex.php on line 61-63

Code:
$price2 = ($m->Bid + $m->Ask)/2;
$market->price2 = AverageIncrement($market->price2, $price2);
$market->price = AverageIncrement($market->price, $m->Bid);


The purpose of this code is to first get the average of the Bid and Ask and put it in price2.
Next it sets the price2 value to the weighted value of the previous price2 and the current price2.  This would be a 20% weight of the old price + 80% value of the new price.
Finally it sets the price value to the weighted value of the previous price and the current bid.  This would be a 20% weight of the old bid + 80% value of the new bid.

On paper this seems reasonable because if the price fluctuates by a significant margin it will trail that value and essentially smooth the movement out. 

This is significant because if you look at the AverageIncrement function and consider that if the previous price being passed in value1 does not exist then the function returns 80% of the current price2 or Bid.  So I think what might be happening is somehow the object is falling out of scope or some other issue that is causing that value1 to get a 0 amount and therefore the values coming out are 80% of the value they should be.

As a workaround until it can be determined if the values are being passed incorrectly or falling out of scope a line to check if value1 is 0 and if it is return the value2 should work around the issue.  I'm going to likely try and setup a Yiimp instance on a test VM and see if I can get values out of it to determine for sure if this is the problem.

I'll let you know what I find.  Crackfoo if you want to perhaps add some debug logging like the following it may be quicker for you to see:

Code:
function AverageIncrement($value1, $value2)
{
$percent = 80;
$value = ($value1*(100-$percent) + $value2*$percent) / 100;

        debuglog("AverageIncrement: $value1, $value2");

return $value;
}

Or report it to Tpruvot and see if he can look at it.  I'm pretty sure this is what is causing the issues.


I support this effort 100%.  If you need anything from me, let me know.

Jaerin,

Why don't you file an issue here: https://github.com/tpruvot/yiimp/issues

If that goes well, you can then submit a pull request.

Crackfoo,

Can you please look into this?  I would really like to know your thoughts.
Pages: « 1 ... 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 [64] 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 ... 244 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!