Bitcoin Forum
April 24, 2014, 10:59:59 AM *
News: Due to the OpenSSL heartbleed bug, changing your forum password is recommended.
 
   Home   Help Search Donate Login Register  
Pages: 1 2 3 4 5 6 7 [8] 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 ... 750
  Print  
Author Topic: CGMINER ASIC miner monitoring RPC linux/win/osx/mips/arm/r-pi 4.3.0  (Read 2662846 times)
This is a self-moderated topic. If you do not want to be moderated by the person who started this topic, create a new topic.
de4l
Member
**
Offline Offline

Activity: 81


View Profile

Ignore
July 16, 2011, 07:19:46 PM
 #141

You need to run aclocal before autogen.sh or ./configure. If you dont have it, install automake or autotool.

Thanks, I installed automake and got a bit further but now I get the error

Code:
configure.ac:125: error: possibly undefined macro: AC_MSG_ERROR
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
1398337199
Hero Member
*
Offline Offline

Posts: 1398337199

View Profile Personal Message (Offline)

Ignore
1398337199
Reply with quote  #2

1398337199
Report to moderator
1398337199
Hero Member
*
Offline Offline

Posts: 1398337199

View Profile Personal Message (Offline)

Ignore
1398337199
Reply with quote  #2

1398337199
Report to moderator
1398337199
Hero Member
*
Offline Offline

Posts: 1398337199

View Profile Personal Message (Offline)

Ignore
1398337199
Reply with quote  #2

1398337199
Report to moderator

Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1398337199
Hero Member
*
Offline Offline

Posts: 1398337199

View Profile Personal Message (Offline)

Ignore
1398337199
Reply with quote  #2

1398337199
Report to moderator
1398337199
Hero Member
*
Offline Offline

Posts: 1398337199

View Profile Personal Message (Offline)

Ignore
1398337199
Reply with quote  #2

1398337199
Report to moderator
1398337199
Hero Member
*
Offline Offline

Posts: 1398337199

View Profile Personal Message (Offline)

Ignore
1398337199
Reply with quote  #2

1398337199
Report to moderator
dikidera
Full Member
***
Offline Offline

Activity: 126


View Profile

Ignore
July 16, 2011, 08:28:44 PM
 #142

You need to run aclocal before autogen.sh or ./configure. If you dont have it, install automake or autotool.

Thanks, I installed automake and got a bit further but now I get the error

Code:
configure.ac:125: error: possibly undefined macro: AC_MSG_ERROR
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.

You know, i've also gotten this error, but not on cgminer. Try doing ./autogen.sh m4_pattern_allow or ./configure m4_pattern_allow or even "m4_pattern_allow ./autogen.sh" and so on.
ancow
Sr. Member
****
Offline Offline

Activity: 373


View Profile WWW

Ignore
July 16, 2011, 08:41:07 PM
 #143

Actually, just installing the right package should do the trick. My guess would be the autoconf-archive package.

BTC: 1GAHTMdBN4Yw3PU66sAmUBKSXy2qaq2SF4
ah42
Newbie
*
Offline Offline

Activity: 14


View Profile

Ignore
July 16, 2011, 09:08:58 PM
 #144

You need to run aclocal before autogen.sh or ./configure. If you dont have it, install automake or autotool.

Thanks, I installed automake and got a bit further but now I get the error

Code:
configure.ac:125: error: possibly undefined macro: AC_MSG_ERROR
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.

Do you have the needed build dependancies installed? You might get this error if autotools cannot find a definition for LIBCURL_CHECK_CONFIG (the only macro in configure.ac that actually  calls AC_MSG_ERROR)

Try:
Code:
sudo apt-get install libcurl4-openssl-dev

Was I helpful? 12Xqb8oETmUkGQ1WrcQ9GYK9CvDxXWb8fU
hi
Sr. Member
****
Offline Offline

Activity: 256


View Profile

Ignore
July 16, 2011, 09:12:38 PM
 #145

Hi

two problems:

1. 1.2.7 will not run on a HIS 5830, crashes to desktop, 1.2.6 runs fine

2.  LOTS OF STALES COMPARED TO OTHER GPU MINERS!!!!


Hi
dostortugas
Jr. Member
*
Offline Offline

Activity: 36


View Profile

Ignore
July 16, 2011, 09:43:17 PM
 #146

1. 1.2.7 will not run on a HIS 5830, crashes to desktop, 1.2.6 runs fine
2.  LOTS OF STALES COMPARED TO OTHER GPU MINERS!!!!

1. have you started it with any settings? executed in the source dir? what msgs do you get if any and have you entered verbose and or debugging flags?
2. I get about the same with any miner if I do compare on the same pool mining on the same pit... what differes are hashes/second and shares/minute
in terms of what the cgminer interface says I get 0 (NULL, zero, nada) stale shares and 73 rejected shares past 6h


19mX5f3YzMSWpDmEwznJNkPBnMSjcTGjPc
de4l
Member
**
Offline Offline

Activity: 81


View Profile

Ignore
July 16, 2011, 09:49:13 PM
 #147

You need to run aclocal before autogen.sh or ./configure. If you dont have it, install automake or autotool.

Thanks, I installed automake and got a bit further but now I get the error

Code:
configure.ac:125: error: possibly undefined macro: AC_MSG_ERROR
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.

You know, i've also gotten this error, but not on cgminer. Try doing ./autogen.sh m4_pattern_allow or ./configure m4_pattern_allow or even "m4_pattern_allow ./autogen.sh" and so on.

Thank you that fixed it! Sorry for all the problems but I really appreciate the help, now my opencl is not getting detected, but it's definitely in existence since I'd been running phoenix fine for months after setting up according to this tutorial http://forum.bitcoin.org/?topic=7514.0

I've also tried specifying the directories like this but still everything comes up as opencl not detected
Code:
CFLAGS="-O3 -Wall -march=native -I/opt/AMD-APP-SDK-v2.1-lnx64/include" LDFLAGS="-L/opt/ati-stream-sdk-v2.1-lnx64/lib/x86_64" ./configure
dikidera
Full Member
***
Offline Offline

Activity: 126


View Profile

Ignore
July 16, 2011, 09:58:34 PM
 #148

Well i see you have downloaded the 64bit version of the stream SDK. Are you on a 64 bit linux?
de4l
Member
**
Offline Offline

Activity: 81


View Profile

Ignore
July 16, 2011, 10:01:11 PM
 #149

Well i see you have downloaded the 64bit version of the stream SDK. Are you on a 64 bit linux?

yep, and it's been working just fine with phoenix+phatk for quite some time
dikidera
Full Member
***
Offline Offline

Activity: 126


View Profile

Ignore
July 16, 2011, 10:07:04 PM
 #150

Well, i'm not sure exactly where's the problem but try going in via a terminal into the app sdk and make; make install-ing it to the system directories and then just run CFLAGS="-O3 -Wall -march=native" ./configure to see if it helps.
dostortugas
Jr. Member
*
Offline Offline

Activity: 36


View Profile

Ignore
July 16, 2011, 10:08:09 PM
 #151

you need the opencl-headers (building needs headers and dev files not what you normaly use for running programs)
for ubuntu you can use just the debian ones (as there is no package in the repo...)
for other distros idk

19mX5f3YzMSWpDmEwznJNkPBnMSjcTGjPc
ckolivas
Moderator
Hero Member
*
Offline Offline

Activity: 1036



View Profile WWW

Ignore
July 16, 2011, 10:08:31 PM
 #152

You build from a release tarball. Then you can go straight to ./configure
Building from git you need to apt-get install autoconf automake
Then you can ./autogen.sh fine
Don't try to start building it any other way.

Prolonged outage is meant to be longer than that. There's some race there which is occasionally hit and does it very soon after. I'll work on that.

Lots of stales? Stale shares are harmless as they never get counted, it's just the app telling you it won't submit them.
Lots of rejects? You get paid according to accepted, so judge the effectiveness on the accepted. cgminer just happens to be brutally honest.

Still using POST? Yes we've been through this, check the discussion earlier on.

Primary developer/maintainer for cgminer: https://bitcointalk.org/index.php?topic=28402.0  148KkS2vgVi4VzUi4JcKzM2PMaMVPi3nnq
ONLY ignoring luke-jr
-ck
dikidera
Full Member
***
Offline Offline

Activity: 126


View Profile

Ignore
July 16, 2011, 10:09:18 PM
 #153

you need the opencl-headers (building needs headers and dev files not what you normaly use for running programs)
for ubuntu you can use just the debian ones (as there is no package in the repo...)
for other distros idk
Erm yeah, the app sdk IS the headers and those CFLAGS and LDFLAGS are exactly for specifying the paths to said headers and libraries.
dostortugas
Jr. Member
*
Offline Offline

Activity: 36


View Profile

Ignore
July 16, 2011, 10:11:52 PM
 #154

you need the opencl-headers (building needs headers and dev files not what you normaly use for running programs)
for ubuntu you can use just the debian ones (as there is no package in the repo...)
for other distros idk
Erm yeah, the app sdk IS the headers and those CFLAGS and LDFLAGS are exactly for specifying the paths to said headers and libraries.
that was what I was thinking at first
after I installed the headers it worked for me maybe it does for you

19mX5f3YzMSWpDmEwznJNkPBnMSjcTGjPc
dikidera
Full Member
***
Offline Offline

Activity: 126


View Profile

Ignore
July 16, 2011, 10:15:45 PM
 #155

you need the opencl-headers (building needs headers and dev files not what you normaly use for running programs)
for ubuntu you can use just the debian ones (as there is no package in the repo...)
for other distros idk
Erm yeah, the app sdk IS the headers and those CFLAGS and LDFLAGS are exactly for specifying the paths to said headers and libraries.
that was what I was thinking at first
after I installed the headers it worked for me maybe it does for you
Which is what i suggested above. For him(or her) to install them headers and .lib files in the system directories instead.
ckolivas
Moderator
Hero Member
*
Offline Offline

Activity: 1036



View Profile WWW

Ignore
July 16, 2011, 10:18:37 PM
 #156

There are instructions for the most convenient way of installing libs and includes in the README.

Primary developer/maintainer for cgminer: https://bitcointalk.org/index.php?topic=28402.0  148KkS2vgVi4VzUi4JcKzM2PMaMVPi3nnq
ONLY ignoring luke-jr
-ck
de4l
Member
**
Offline Offline

Activity: 81


View Profile

Ignore
July 16, 2011, 10:59:00 PM
 #157

There are instructions for the most convenient way of installing libs and includes in the README.

I already had them installed in /opt as the tutorial here does http://forum.bitcoin.org/?topic=7514.0 and I added the two symlinks and ran ldconfig according to your readme. Unfortunately I still get the opencl not detected error during the config.
dostortugas
Jr. Member
*
Offline Offline

Activity: 36


View Profile

Ignore
July 16, 2011, 11:04:01 PM
 #158

have you installed teh opencl-headers?

19mX5f3YzMSWpDmEwznJNkPBnMSjcTGjPc
dikidera
Full Member
***
Offline Offline

Activity: 126


View Profile

Ignore
July 16, 2011, 11:14:19 PM
 #159

have you installed teh opencl-headers?
Are you trolling? He already said he installed them.
ancow
Sr. Member
****
Offline Offline

Activity: 373


View Profile WWW

Ignore
July 17, 2011, 12:26:54 AM
 #160

Just tried version 1.2.7 on a rather up-to-date Mac, and OpenCL still isn't detected. For now I'm assuming the following bit in the configure file is to blame:
Code:
case $target in
  *-*-mingw*)
    have_x86_64=false
    have_win32=true
    PTHREAD_FLAGS=""
    ;;
  x86_64-*)
    have_x86_64=true
    ;;
  *-*-darwin*)
    have_x86_64=false
    OPENCL_FLAGS="-framework OpenCL"
        ;;
  *)
    have_x86_64=false
    ;;
esac
The Mac I have here is a 64bit machine and identifies itself as "x86_64-apple-darwin10.8.0", which means that the "*-*-darwin*" case is never reached.

Changing the case statement to the following enables OpenCL:
Code:
case $target in
  *-*-mingw*)
    have_x86_64=false
    have_win32=true
    PTHREAD_FLAGS=""
    ;;
  x86_64-*-darwin*)
    have_x86_64=true
    OPENCL_FLAGS="-framework OpenCL"
    ;;
  x86_64-*)
    have_x86_64=true
    ;;
  *-*-darwin*)
    have_x86_64=false
    OPENCL_FLAGS="-framework OpenCL"
        ;;
  *)
    have_x86_64=false
    ;;
esac

Unfortunately, I'm still getting the following error when makeing:
Code:
gcc -DHAVE_CONFIG_H -I. -pthread -fno-strict-aliasing -I./compat/jansson -I./lib -I./lib   -O3 -Wall -MT cgminer-main.o -MD -MP -MF .deps/cgminer-main.Tpo -c -o cgminer-main.o `test -f 'main.c' || echo './'`main.c
In file included from main.c:34:
compat.h:5: error: conflicting types for 'suseconds_t'
/usr/include/sys/types.h:250: error: previous declaration of 'suseconds_t' was here
make[2]: *** [cgminer-main.o] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

BTC: 1GAHTMdBN4Yw3PU66sAmUBKSXy2qaq2SF4
Pages: 1 2 3 4 5 6 7 [8] 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 ... 750
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!