Bitcoin Forum
December 09, 2016, 01:54:54 PM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 [41] 42 43 »
  Print  
Author Topic: Smartcoin Linux mining administration. [MULTI-MACHINE SUPPORT NOW IN!]  (Read 99685 times)
jondecker76
Full Member
***
Offline Offline

Activity: 238


View Profile
August 07, 2011, 11:09:20 AM
 #801

Update r647e now available
- Started writing the macro feature routines. All stubs now in place
- Huge optimizations on the multi-machine code.  12+ SQL queries per iteration per machine were eliminated (except for the localhost machine).


RollerBot Advanced Trading Platform
https://bitcointalk.org/index.php?topic=447727.0
BTC Donations for development: 1H36oTJsi3adFh68wwzz95tPP2xoAoTmhC
1481291694
Hero Member
*
Offline Offline

Posts: 1481291694

View Profile Personal Message (Offline)

Ignore
1481291694
Reply with quote  #2

1481291694
Report to moderator
1481291694
Hero Member
*
Offline Offline

Posts: 1481291694

View Profile Personal Message (Offline)

Ignore
1481291694
Reply with quote  #2

1481291694
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481291694
Hero Member
*
Offline Offline

Posts: 1481291694

View Profile Personal Message (Offline)

Ignore
1481291694
Reply with quote  #2

1481291694
Report to moderator
jondecker76
Full Member
***
Offline Offline

Activity: 238


View Profile
August 08, 2011, 11:27:58 AM
 #802

Update r652e now available!
- New macro system implementation complete (except for 'Edit Macro')


Here is some information about the macro system:
Macros are only useful if you are running multiple machines. The macro system allows you to change the profile on multiple machines at the same time all with one command (Think of a macro as a "macro-profile"). To use, go to Configure Macros->Add.
You can then build a macro and define which profile to switch to on which machines when the macro is executed. If a profile isn't assigned for a machine, then the profile will stay the same for the machine when the macro is executed.

An example of a useful macro would be to create a macro named "Fallover All", then assign the failover profile for each machine.  When you execute the "Failover All" macro, then the profile on each machine will change to failover.  Pretty simple!

Simply use the "Execute Macro" option to choose a defined macro to execute!


Sample Usage Case
Imagine that you are running a mining farm with 10 machines. You get news that your favorite pool has been cheating its users and you want to switch all of your machines to a different pool as soon as possible. Simply Execute one of your pre-built macros and all of your machines will redirect to the indicated profiles - all within seconds!


Known Issues: Edit Macro not yet implemented, though you can always delete a macro and add a new one to start over for now.  The edit macro functionality should be finished in the next day or two.

RollerBot Advanced Trading Platform
https://bitcointalk.org/index.php?topic=447727.0
BTC Donations for development: 1H36oTJsi3adFh68wwzz95tPP2xoAoTmhC
norulezapply
Sr. Member
****
Offline Offline

Activity: 475


View Profile
August 09, 2011, 06:44:54 PM
 #803

Hey getting some bizarre problems with my smartcoin Sad
Only seems to have started recently.
It's been mining fine for a while now.
But now on the status screen it shows <<IDLE>> for both my miners.
In the log it says they have locked up, but to be honest I doubt that both of my cards would lock up at the exact same time would they?
When trying to reload the miners, the miner screens just sit at the "Launching phoenix" screen and have no more output.
Then eventually I lose the ability to monitor my temperature (this occurs 10 minutes or so afterward, when i attempted to manually restart smartcoin).
And i get the message "No protocol specified" in the status window (a log from aticonfig maybe?)
The only solution is to restart Sad
Any ideas?

If my post helped, I'll happily accept a few bitmills!   15rGg6A1JFZV3b7TTbtpAaiYGdUD1e1oAm
jondecker76
Full Member
***
Offline Offline

Activity: 238


View Profile
August 10, 2011, 12:35:11 PM
 #804

This sounds exactly like a hardlock condition - and would make sense that they happen at the same time because most people overclock all their cards together (--adapter=all)

If it happens again, disconnect from smartcoin then type:
Code:
screen -r miner

Then you can look at all of the miner instances manually and see what is going on.

Another easy test would be to reduce clocks a little and see if the hardlock no longer happens.

Please post back what you find out!

RollerBot Advanced Trading Platform
https://bitcointalk.org/index.php?topic=447727.0
BTC Donations for development: 1H36oTJsi3adFh68wwzz95tPP2xoAoTmhC
sunny day
Jr. Member
*
Offline Offline

Activity: 32


View Profile
August 10, 2011, 06:02:21 PM
 #805

I can't get smartcoin to run the miners. on the localhost page all the miners say idle and occasionally a bunch of "aticonfig: no supported adapters are found" messages scroll by. on the log page i try to manually run the phoenix command but it gives me a kernel not found error.

when i run aticonfig manually it works but only when i sudo it.
i normally use cgminer and that works with my cards just fine.
AMDOverdrive also detects the cards fine.
any ideas jondecker?
norulezapply
Sr. Member
****
Offline Offline

Activity: 475


View Profile
August 10, 2011, 11:12:50 PM
 #806

@sunny day: try running smartcoin as root (sudo smartcoin)

@jondecker: Well I overclock my cards separately using atitweak because it's a 5770 and 5830 so they have different clocks.
The status screen shows <<DOWN>> for both cards.
It's just happened again now and I can still see the temperatures so aticonfig must still be working.
When I look at the miner screen instances all I see is
"Exporting: /opt/AMD-APP-SDK-v2.4-lnx64/lib/x86_64
LAUNCH: python /opt/miners/phoenix//phoenix.py -v -u http://btcrig:btcrig@localhost:8337/ device=0 worksize=256 vectors aggression=10 bfi_int fastloop=false -k phatk"

Also another thing I noticed is if phoenix fails to connect it will just stop trying after a couple of attempts:
e.g. "Exporting: /opt/AMD-APP-SDK-v2.4-lnx64/lib/x86_64
LAUNCH: python /opt/miners/phoenix//phoenix.py -v -u http://btcrig:btcrig@localhost:8337/ device=0 worksize=256 vectors aggression=10 bfi_int fastloop=false -k phatk
[10/08/2011 22:45:12] Phoenix r111 starting...
[10/08/2011 22:45:22] Failed to connect, retrying...
[10/08/2011 22:45:32] Failed to connect, retrying..."

Even though the server is up and running as I'm mining it on my other PC. It's been sat like that for 25 minutes without attempting to reconnect again now and smartcoin doesn't attempt to restart them either.

If I restart them manually they connect fine.

If my post helped, I'll happily accept a few bitmills!   15rGg6A1JFZV3b7TTbtpAaiYGdUD1e1oAm
jondecker76
Full Member
***
Offline Offline

Activity: 238


View Profile
August 11, 2011, 01:08:56 AM
 #807

I can't get smartcoin to run the miners. on the localhost page all the miners say idle and occasionally a bunch of "aticonfig: no supported adapters are found" messages scroll by. on the log page i try to manually run the phoenix command but it gives me a kernel not found error.

when i run aticonfig manually it works but only when i sudo it.
i normally use cgminer and that works with my cards just fine.
AMDOverdrive also detects the cards fine.
any ideas jondecker?

What linux distro are you running under? What install guide did you use?
You can run smartcoin as root, but that means you will also need to run the installer as root to set things up

RollerBot Advanced Trading Platform
https://bitcointalk.org/index.php?topic=447727.0
BTC Donations for development: 1H36oTJsi3adFh68wwzz95tPP2xoAoTmhC
jondecker76
Full Member
***
Offline Offline

Activity: 238


View Profile
August 11, 2011, 01:16:51 AM
 #808

@sunny day: try running smartcoin as root (sudo smartcoin)

@jondecker: Well I overclock my cards separately using atitweak because it's a 5770 and 5830 so they have different clocks.
The status screen shows <<DOWN>> for both cards.
It's just happened again now and I can still see the temperatures so aticonfig must still be working.
When I look at the miner screen instances all I see is
"Exporting: /opt/AMD-APP-SDK-v2.4-lnx64/lib/x86_64
LAUNCH: python /opt/miners/phoenix//phoenix.py -v -u http://btcrig:btcrig@localhost:8337/ device=0 worksize=256 vectors aggression=10 bfi_int fastloop=false -k phatk"

Also another thing I noticed is if phoenix fails to connect it will just stop trying after a couple of attempts:
e.g. "Exporting: /opt/AMD-APP-SDK-v2.4-lnx64/lib/x86_64
LAUNCH: python /opt/miners/phoenix//phoenix.py -v -u http://btcrig:btcrig@localhost:8337/ device=0 worksize=256 vectors aggression=10 bfi_int fastloop=false -k phatk
[10/08/2011 22:45:12] Phoenix r111 starting...
[10/08/2011 22:45:22] Failed to connect, retrying...
[10/08/2011 22:45:32] Failed to connect, retrying..."

Even though the server is up and running as I'm mining it on my other PC. It's been sat like that for 25 minutes without attempting to reconnect again now and smartcoin doesn't attempt to restart them either.

If I restart them manually they connect fine.

What distro are you running smartcoin on?  When the miner instance screen shows blank, is it like that when it starts, or after its already been running and then hangs? (Does smartcoin ever work properly, if even just for a little bit?  If/when it is working, do the miner instance screens look normal?)

Regarding phoenix connection issues, there isn't much I can do about phoenix issues, though it appears to me that lockup detection should happen in this instance.  Also, i have gotten reports of r 111 and r112  of phoenix having these types of problems (I run phoenix r107 and never have issues like you are describing, perhaps you could verify?)

RollerBot Advanced Trading Platform
https://bitcointalk.org/index.php?topic=447727.0
BTC Donations for development: 1H36oTJsi3adFh68wwzz95tPP2xoAoTmhC
Math Man
Full Member
***
Offline Offline

Activity: 150


View Profile
August 11, 2011, 08:47:34 AM
 #809

I am trying to get Smartcoin working on one of my rigs, which is running a persistent install of LinuxCoin 0.2b.  It has 3 HD 5970s in it, but I'm just trying to get the first GPU working.  I do have read/write permissions to the phoenix folder.  The Smartcoin host is running Debian Squeeze.

This below flashes across the screen a bunch of times when I switch to screen 2*$btc1.  Note: rylan is my user name on the Linuxcoin client and the Debian host.
Code:
Starting miner Miner.1!
Creating persistent ssh connection to machine 2
Bad port 'rylan'
Bad port 'rylan'
What does Bad port 'rylan' mean?  I have the ssh port set to 22.


Then the below screen shows up, where GPU[0] is idle.  There is a connection to btc1 though, because it's showing the correct temperature of GPU[0]
Code:
Smartcoin r652s 01:09:57
----------------------------------------
No screen session found. Host: btc1
GPU[0]: Temp: 56.00 load: 0%
CPU Load Avgs: 0.10 0.10 0.16

Profile: Automatic
--------Mainframe--------
GPU[0]: <<<IDLE>>>
Total : [0 MHash/sec] [0 Accepted] [0 Rejected] [0.00% Rejected]

Grand Total : [0 MHash/sec] [0 Accepted] [0 Rejected] [0.00% Rejected]


[ debian ][   0-$ control  1$ localhost  (2*$btc1)  3$ Log   ][ 08/11/11  1:10 ]

Below is my log
Code:
Starting SmartCoin at location: /home/rylan/smartcoin...
Running check
Starting main smartcoin screen session...


Creating persistent ssh connection to machine 2

Verifying integrity of general settings...
Verifying integrity of settings for machine 1...
Verifying integrity of settings for machine 2...
Creating tab for each machine...
Creating a logtail tab...
08/11/11 01:11:56       DEBUG: "screen -r miner -X hardstatus string '%{= kG}[ %{G}%H %{g}][%= %{= kw}%?%-Lw%?%{r}(%{W}%n*%f%t%?(%u)%?%{r})%{w}%?%+Lw%?%?%= %{g}][%{B} %m/%d/%y %{W}%c %{g}]'"

08/11/11 01:11:56       Starting miner Miner.1!

08/11/11 01:11:56       Launching miner with launch string: python /opt/miners/phoenix/phoenix.py -v -u http://MYUSERNAME:MYPASSWORD@mining.mainframe.nl:8343/ -k phatk -q 6 DEVICE=0 VECTORS BFI_INT FASTLOOP=false WORKSIZE=128 AGGRESSION=9

08/11/11 01:11:56       Creating persistent ssh connection to machine 2

08/11/11 01:11:56       DEBUG: "screen  -d -r miner -X screen -t Miner.1 /tmp/smartcoin_launcher.sh /opt/miners/phoenix/ 'python /opt/miners/phoenix/phoenix.py -v -u http://MYUSERNAME:MYPASSWORD@mining.mainframe.nl:8343/ -k phatk -q 6 DEVICE=0 VECTORS BFI_INT FASTLOOP=false WORKSIZE=128 AGGRESSION=9' "

08/11/11 01:11:56       Creating persistent ssh connection to machine 2

08/11/11 01:11:56       DEBUG: screen -r miner -p miner-dummy -X kill

Halp!   Cheesy
jondecker76
Full Member
***
Offline Offline

Activity: 238


View Profile
August 11, 2011, 06:13:59 PM
 #810

I am trying to get Smartcoin working on one of my rigs, which is running a persistent install of LinuxCoin 0.2b.  It has 3 HD 5970s in it, but I'm just trying to get the first GPU working.  I do have read/write permissions to the phoenix folder.  The Smartcoin host is running Debian Squeeze.

This below flashes across the screen a bunch of times when I switch to screen 2*$btc1.  Note: rylan is my user name on the Linuxcoin client and the Debian host.
Code:
Starting miner Miner.1!
Creating persistent ssh connection to machine 2
Bad port 'rylan'
Bad port 'rylan'
What does Bad port 'rylan' mean?  I have the ssh port set to 22.


Then the below screen shows up, where GPU[0] is idle.  There is a connection to btc1 though, because it's showing the correct temperature of GPU[0]
Code:
Smartcoin r652s 01:09:57
----------------------------------------
No screen session found. Host: btc1
GPU[0]: Temp: 56.00 load: 0%
CPU Load Avgs: 0.10 0.10 0.16

Profile: Automatic
--------Mainframe--------
GPU[0]: <<<IDLE>>>
Total : [0 MHash/sec] [0 Accepted] [0 Rejected] [0.00% Rejected]

Grand Total : [0 MHash/sec] [0 Accepted] [0 Rejected] [0.00% Rejected]


[ debian ][   0-$ control  1$ localhost  (2*$btc1)  3$ Log   ][ 08/11/11  1:10 ]

Below is my log
Code:
Starting SmartCoin at location: /home/rylan/smartcoin...
Running check
Starting main smartcoin screen session...


Creating persistent ssh connection to machine 2

Verifying integrity of general settings...
Verifying integrity of settings for machine 1...
Verifying integrity of settings for machine 2...
Creating tab for each machine...
Creating a logtail tab...
08/11/11 01:11:56       DEBUG: "screen -r miner -X hardstatus string '%{= kG}[ %{G}%H %{g}][%= %{= kw}%?%-Lw%?%{r}(%{W}%n*%f%t%?(%u)%?%{r})%{w}%?%+Lw%?%?%= %{g}][%{B} %m/%d/%y %{W}%c %{g}]'"

08/11/11 01:11:56       Starting miner Miner.1!

08/11/11 01:11:56       Launching miner with launch string: python /opt/miners/phoenix/phoenix.py -v -u http://MYUSERNAME:MYPASSWORD@mining.mainframe.nl:8343/ -k phatk -q 6 DEVICE=0 VECTORS BFI_INT FASTLOOP=false WORKSIZE=128 AGGRESSION=9

08/11/11 01:11:56       Creating persistent ssh connection to machine 2

08/11/11 01:11:56       DEBUG: "screen  -d -r miner -X screen -t Miner.1 /tmp/smartcoin_launcher.sh /opt/miners/phoenix/ 'python /opt/miners/phoenix/phoenix.py -v -u http://MYUSERNAME:MYPASSWORD@mining.mainframe.nl:8343/ -k phatk -q 6 DEVICE=0 VECTORS BFI_INT FASTLOOP=false WORKSIZE=128 AGGRESSION=9' "

08/11/11 01:11:56       Creating persistent ssh connection to machine 2

08/11/11 01:11:56       DEBUG: screen -r miner -p miner-dummy -X kill

Halp!   Cheesy

I am uploading an update right now that will fix your problem - there was a bug in a couple places where the user and the port were switched. It is now fixed.

Also,  I noticed that you are trying to remotely manage a Linuxcoin machine. See this from the multi-machine release note:
Quote
- If a remote machine normally runs smartcoin as root (with sudo - Linuxcoin would be an example of this), then when setting up a remote machine from Configure Machines, you must use the username 'root'.  This also means that the remote machine must have a root password for this to work.  To set up a root password, on the remote machine (before setting up the machine entry on the control screen):
Code:

Code:
sudo su

passwd

then enter a password twice.  You can now set up the remote machine in Smartcoin using the 'root' user


Here is what I would do in your situation to get things right again:
1) Delete the remote linuxcoin machine from Configure Machines->Delete
2) Update smartcoin to latest
3) Exit smartcoin
4) On your linuxcoin machine, make sure you have a root password set (per above instructions)
5) Fire smartcoin back up and add the linuxcoin machine again, and make sure you use the 'root' user.

This should get things working correctly again!  Thanks for the report!

RollerBot Advanced Trading Platform
https://bitcointalk.org/index.php?topic=447727.0
BTC Donations for development: 1H36oTJsi3adFh68wwzz95tPP2xoAoTmhC
jondecker76
Full Member
***
Offline Offline

Activity: 238


View Profile
August 11, 2011, 06:16:59 PM
 #811

Update 655e/655s now available:
- Fixed a remote machine bug where the port and username were switched around.
- Small change to donation system. Now only 1 worker per device will start up - this will be easier on resources.  I also switched to Eligius for the donation pool

RollerBot Advanced Trading Platform
https://bitcointalk.org/index.php?topic=447727.0
BTC Donations for development: 1H36oTJsi3adFh68wwzz95tPP2xoAoTmhC
jondecker76
Full Member
***
Offline Offline

Activity: 238


View Profile
August 11, 2011, 07:31:38 PM
 #812

Update r657e/657s now available
- There is a new tag supported in the launch string. The new tag is <#device+1#>.  This is useful if a miner always treats the CPU as device 0, which ends up offsetting the GPU devices.  This would cause the GPU load and temperatures to be out of sync on a few installs, as well as cause the CPU to be fired up as GPU[0] on some installs.  By using the <#device+1#> tag in the launch string, you can counteract this problem directly on a per-miner basis.  If your devices ever seemed out of order, or you ever had to manually change your devices to start with 1 - you may want to give this new tag a try.

RollerBot Advanced Trading Platform
https://bitcointalk.org/index.php?topic=447727.0
BTC Donations for development: 1H36oTJsi3adFh68wwzz95tPP2xoAoTmhC
sunny day
Jr. Member
*
Offline Offline

Activity: 32


View Profile
August 11, 2011, 08:11:56 PM
 #813

I can't get smartcoin to run the miners. on the localhost page all the miners say idle and occasionally a bunch of "aticonfig: no supported adapters are found" messages scroll by. on the log page i try to manually run the phoenix command but it gives me a kernel not found error.

when i run aticonfig manually it works but only when i sudo it.
i normally use cgminer and that works with my cards just fine.
AMDOverdrive also detects the cards fine.
any ideas jondecker?

What linux distro are you running under? What install guide did you use?
You can run smartcoin as root, but that means you will also need to run the installer as root to set things up
I'm running linuxcoin final. i uninstalled the the one that came with it cuz it was outdated and then installed it from the svn. i used the instructions on the wiki.
yeah running as root gives me a bunch of not found errors.
Math Man
Full Member
***
Offline Offline

Activity: 150


View Profile
August 12, 2011, 12:17:33 AM
 #814

I am uploading an update right now that will fix your problem - there was a bug in a couple places where the user and the port were switched. It is now fixed.

Also,  I noticed that you are trying to remotely manage a Linuxcoin machine. See this from the multi-machine release note:
Quote
- If a remote machine normally runs smartcoin as root (with sudo - Linuxcoin would be an example of this), then when setting up a remote machine from Configure Machines, you must use the username 'root'.  This also means that the remote machine must have a root password for this to work.  To set up a root password, on the remote machine (before setting up the machine entry on the control screen):
Code:

Code:
sudo su

passwd

then enter a password twice.  You can now set up the remote machine in Smartcoin using the 'root' user

Here is what I would do in your situation to get things right again:
1) Delete the remote linuxcoin machine from Configure Machines->Delete
2) Update smartcoin to latest
3) Exit smartcoin
4) On your linuxcoin machine, make sure you have a root password set (per above instructions)
5) Fire smartcoin back up and add the linuxcoin machine again, and make sure you use the 'root' user.

This should get things working correctly again!  Thanks for the report!


Thanks!  What you suggested worked for both of my remote machines. 

I sent you a donation.  This is a great piece of software.
jondecker76
Full Member
***
Offline Offline

Activity: 238


View Profile
August 12, 2011, 04:02:12 AM
 #815

I can't get smartcoin to run the miners. on the localhost page all the miners say idle and occasionally a bunch of "aticonfig: no supported adapters are found" messages scroll by. on the log page i try to manually run the phoenix command but it gives me a kernel not found error.

when i run aticonfig manually it works but only when i sudo it.
i normally use cgminer and that works with my cards just fine.
AMDOverdrive also detects the cards fine.
any ideas jondecker?

What linux distro are you running under? What install guide did you use?
You can run smartcoin as root, but that means you will also need to run the installer as root to set things up
I'm running linuxcoin final. i uninstalled the the one that came with it cuz it was outdated and then installed it from the svn. i used the instructions on the wiki.
yeah running as root gives me a bunch of not found errors.
Smartcoin has to run as root on top of Linuxcoin, as everything else is installed as root on linuxcoin.  You get not found errors because smartcoin has not yet been set up as root (Under linux, applications use hidden folders under the current user's path.  Since 'root' is a valid linux user, that means /root/.smartcoin must exist for it to run as root.  You can accomplish this by either
A) Re-running the installer as root (I.e. sudo smartcoin_install.sh)
or
B) copying the ~/.smartcoin directory from your user home to /root/.smartcoin

and of course, in this case after you have the hidden directory sorted, you'll want to run smartcoin as root (I.e. sudo smartcoin). 

Also,  if LinuxCoin ships with an out-of-date smartcoin,  you can just cd to the smartcoin directory (i think on LinuxCoin its /opt/miners/smartcoin), then run an 'svn update' before running the installer (as root of course).


I know its all a bit confusing, but this is the norm and compliant with Linux standards.

RollerBot Advanced Trading Platform
https://bitcointalk.org/index.php?topic=447727.0
BTC Donations for development: 1H36oTJsi3adFh68wwzz95tPP2xoAoTmhC
jondecker76
Full Member
***
Offline Offline

Activity: 238


View Profile
August 12, 2011, 04:08:05 AM
 #816

I am uploading an update right now that will fix your problem - there was a bug in a couple places where the user and the port were switched. It is now fixed.

Also,  I noticed that you are trying to remotely manage a Linuxcoin machine. See this from the multi-machine release note:
Quote
- If a remote machine normally runs smartcoin as root (with sudo - Linuxcoin would be an example of this), then when setting up a remote machine from Configure Machines, you must use the username 'root'.  This also means that the remote machine must have a root password for this to work.  To set up a root password, on the remote machine (before setting up the machine entry on the control screen):
Code:

Code:
sudo su

passwd

then enter a password twice.  You can now set up the remote machine in Smartcoin using the 'root' user

Here is what I would do in your situation to get things right again:
1) Delete the remote linuxcoin machine from Configure Machines->Delete
2) Update smartcoin to latest
3) Exit smartcoin
4) On your linuxcoin machine, make sure you have a root password set (per above instructions)
5) Fire smartcoin back up and add the linuxcoin machine again, and make sure you use the 'root' user.

This should get things working correctly again!  Thanks for the report!


Thanks!  What you suggested worked for both of my remote machines. 

I sent you a donation.  This is a great piece of software.

Glad to hear it worked well for you, and thanks for the donation!
Please post back if you find any further problems as multi-machine support is still very young and I want to make sure that it is stable and works as it should!

RollerBot Advanced Trading Platform
https://bitcointalk.org/index.php?topic=447727.0
BTC Donations for development: 1H36oTJsi3adFh68wwzz95tPP2xoAoTmhC
norulezapply
Sr. Member
****
Offline Offline

Activity: 475


View Profile
August 12, 2011, 05:14:52 PM
 #817

@sunny day: try running smartcoin as root (sudo smartcoin)

@jondecker: Well I overclock my cards separately using atitweak because it's a 5770 and 5830 so they have different clocks.
The status screen shows <<DOWN>> for both cards.
It's just happened again now and I can still see the temperatures so aticonfig must still be working.
When I look at the miner screen instances all I see is
"Exporting: /opt/AMD-APP-SDK-v2.4-lnx64/lib/x86_64
LAUNCH: python /opt/miners/phoenix//phoenix.py -v -u http://btcrig:btcrig@localhost:8337/ device=0 worksize=256 vectors aggression=10 bfi_int fastloop=false -k phatk"

Also another thing I noticed is if phoenix fails to connect it will just stop trying after a couple of attempts:
e.g. "Exporting: /opt/AMD-APP-SDK-v2.4-lnx64/lib/x86_64
LAUNCH: python /opt/miners/phoenix//phoenix.py -v -u http://btcrig:btcrig@localhost:8337/ device=0 worksize=256 vectors aggression=10 bfi_int fastloop=false -k phatk
[10/08/2011 22:45:12] Phoenix r111 starting...
[10/08/2011 22:45:22] Failed to connect, retrying...
[10/08/2011 22:45:32] Failed to connect, retrying..."

Even though the server is up and running as I'm mining it on my other PC. It's been sat like that for 25 minutes without attempting to reconnect again now and smartcoin doesn't attempt to restart them either.

If I restart them manually they connect fine.

What distro are you running smartcoin on?  When the miner instance screen shows blank, is it like that when it starts, or after its already been running and then hangs? (Does smartcoin ever work properly, if even just for a little bit?  If/when it is working, do the miner instance screens look normal?)

Regarding phoenix connection issues, there isn't much I can do about phoenix issues, though it appears to me that lockup detection should happen in this instance.  Also, i have gotten reports of r 111 and r112  of phoenix having these types of problems (I run phoenix r107 and never have issues like you are describing, perhaps you could verify?)

Linuxcoin 0.2-final.
I run it 16 hours a day and it only happens a couple of times a week.
It's always after a few hours or so.
When it works it looks normal.
I guess it's just locking up.
Do you recommend just setting the lockup script to restart the machine or set my clocks lower? Since it doesn't happen that often.
Ah, I'm using 1.5 but i'll try those, thanks.

If my post helped, I'll happily accept a few bitmills!   15rGg6A1JFZV3b7TTbtpAaiYGdUD1e1oAm
jondecker76
Full Member
***
Offline Offline

Activity: 238


View Profile
August 12, 2011, 05:21:07 PM
 #818

@sunny day: try running smartcoin as root (sudo smartcoin)

@jondecker: Well I overclock my cards separately using atitweak because it's a 5770 and 5830 so they have different clocks.
The status screen shows <<DOWN>> for both cards.
It's just happened again now and I can still see the temperatures so aticonfig must still be working.
When I look at the miner screen instances all I see is
"Exporting: /opt/AMD-APP-SDK-v2.4-lnx64/lib/x86_64
LAUNCH: python /opt/miners/phoenix//phoenix.py -v -u http://btcrig:btcrig@localhost:8337/ device=0 worksize=256 vectors aggression=10 bfi_int fastloop=false -k phatk"

Also another thing I noticed is if phoenix fails to connect it will just stop trying after a couple of attempts:
e.g. "Exporting: /opt/AMD-APP-SDK-v2.4-lnx64/lib/x86_64
LAUNCH: python /opt/miners/phoenix//phoenix.py -v -u http://btcrig:btcrig@localhost:8337/ device=0 worksize=256 vectors aggression=10 bfi_int fastloop=false -k phatk
[10/08/2011 22:45:12] Phoenix r111 starting...
[10/08/2011 22:45:22] Failed to connect, retrying...
[10/08/2011 22:45:32] Failed to connect, retrying..."

Even though the server is up and running as I'm mining it on my other PC. It's been sat like that for 25 minutes without attempting to reconnect again now and smartcoin doesn't attempt to restart them either.

If I restart them manually they connect fine.

What distro are you running smartcoin on?  When the miner instance screen shows blank, is it like that when it starts, or after its already been running and then hangs? (Does smartcoin ever work properly, if even just for a little bit?  If/when it is working, do the miner instance screens look normal?)

Regarding phoenix connection issues, there isn't much I can do about phoenix issues, though it appears to me that lockup detection should happen in this instance.  Also, i have gotten reports of r 111 and r112  of phoenix having these types of problems (I run phoenix r107 and never have issues like you are describing, perhaps you could verify?)

Linuxcoin 0.2-final.
I run it 16 hours a day and it only happens a couple of times a week.
It's always after a few hours or so.
When it works it looks normal.
I guess it's just locking up.
Do you recommend just setting the lockup script to restart the machine or set my clocks lower? Since it doesn't happen that often.
Ah, I'm using 1.5 but i'll try those, thanks.

I would recommend both actually - lower your clocks a little bit (2-3 mhz or so) and setup a nice lockup.sh script which reboots the machine and notifies you.

A good example is my own machine.  I kept backing off my overclock by 1mhz until it was stable. Just the other day, for the first time in 0ver 40 days it finally detected a lockup and rebooted.  Thats not enough of a concern for me to reduce clocks more, as I consider that pretty stable - but the lockup.sh script rebooting is a good thing, as otherwise I would have suffered some downtime until I checked on it (I'm known to not check on mine for several days at a time).

RollerBot Advanced Trading Platform
https://bitcointalk.org/index.php?topic=447727.0
BTC Donations for development: 1H36oTJsi3adFh68wwzz95tPP2xoAoTmhC
Math Man
Full Member
***
Offline Offline

Activity: 150


View Profile
August 14, 2011, 07:41:16 AM
 #819

Glad to hear it worked well for you, and thanks for the donation!
Please post back if you find any further problems as multi-machine support is still very young and I want to make sure that it is stable and works as it should!

The remote miner status screen has been freezing on me frequently.  The remote miners keep running though.  Below is my log screen.

Code:
08/14/11 00:20:09       Creating persistent ssh connection to machine 6

08/14/11 00:20:09       DEBUG: sleep 0.2

08/14/11 00:20:15       Creating persistent ssh connection to machine 6

08/14/11 00:20:15       DEBUG: grep 'hash' '/tmp/smartcoin-Miner.12' 2> /dev/null | tail -n 1

Normally, I only see the "DEBUG: sleep 0.2" message.  Tonight was the first time I've seen the "DEBUG: grep 'hash' '/tmp/smartcoin-Miner.12' 2> /dev/null | tail -n 1" message.

I haven't paid close enough attention to see if it's only one of the remote miner's status screen freezing or both freezing.

Killing Smartcoin and restarting it doesn't solve the problem.  Sometimes killing Smartcoin and then killing the screen on the remote miners that was frozen solves the problem, but the status screen sometimes stays frozen even after killing both things.

Edit1: I forgot to mention that I'm using r657s.

Edit2: It's both status screen that freeze on me, not just one of them.
jondecker76
Full Member
***
Offline Offline

Activity: 238


View Profile
August 15, 2011, 03:45:58 PM
 #820

Glad to hear it worked well for you, and thanks for the donation!
Please post back if you find any further problems as multi-machine support is still very young and I want to make sure that it is stable and works as it should!

The remote miner status screen has been freezing on me frequently.  The remote miners keep running though.  Below is my log screen.

Code:
08/14/11 00:20:09       Creating persistent ssh connection to machine 6

08/14/11 00:20:09       DEBUG: sleep 0.2

08/14/11 00:20:15       Creating persistent ssh connection to machine 6

08/14/11 00:20:15       DEBUG: grep 'hash' '/tmp/smartcoin-Miner.12' 2> /dev/null | tail -n 1

Normally, I only see the "DEBUG: sleep 0.2" message.  Tonight was the first time I've seen the "DEBUG: grep 'hash' '/tmp/smartcoin-Miner.12' 2> /dev/null | tail -n 1" message.

I haven't paid close enough attention to see if it's only one of the remote miner's status screen freezing or both freezing.

Killing Smartcoin and restarting it doesn't solve the problem.  Sometimes killing Smartcoin and then killing the screen on the remote miners that was frozen solves the problem, but the status screen sometimes stays frozen even after killing both things.

Edit1: I forgot to mention that I'm using r657s.

Edit2: It's both status screen that freeze on me, not just one of them.
Sorry it took so long to get back to you - i'm in the middle of a remodeling project so the last couple of days have been extremely busy

If you're constantly getting the log message that is creating the persistent ssh connection, that means that the SSH connection is dropping out for some reason (it should only have to create the connection once, and perhaps periodically you may see it.  Can you still manually ssh into the remote machine when t his happens?  Are all machines all on the same LAN? Are all connections hard-wired, or is WIFI involved?
At this point, I'm suspecting some problem at the network level(a flaky ethernet card even?). In the tests that I did here, I had no problem keeping a persistent ssh connection for weeks at a time without issues.  The fact that your connection goes down, and attempts to recreate the connection unsuccessfully points to a network problem as well.

You can check /var/log/syslog and /var/log/messages on the remote machines to see if there are any sshd errors, that should help give as a clue. Try running:
Code:
grep -rin ssh /var/log/*
And see if we can find the problem.  You can even run the above line on the machine running smartcoin as well. Please report back what you find out!

RollerBot Advanced Trading Platform
https://bitcointalk.org/index.php?topic=447727.0
BTC Donations for development: 1H36oTJsi3adFh68wwzz95tPP2xoAoTmhC
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 [41] 42 43 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!