Bitcoin Forum
February 25, 2017, 08:44:52 PM *
News: Latest stable version of Bitcoin Core: 0.13.2  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: « 1 [2] 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 ... 80 »
  Print  
Author Topic: BAMT version 0.5 - Easy USB based mining Linux with farm wide management tools  (Read 306124 times)
unicron
Newbie
*
Offline Offline

Activity: 25


View Profile
February 24, 2012, 09:32:55 AM
 #21

Here is a link to the current latest release.

Direct download: http://biomancer.net/bamt/bamt_v0.5a.zip

md5sum: 692d336de35fd3f3b4561ff39b109d08  bamt_v0.5a.zip
1488055492
Hero Member
*
Offline Offline

Posts: 1488055492

View Profile Personal Message (Offline)

Ignore
1488055492
Reply with quote  #2

1488055492
Report to moderator
1488055492
Hero Member
*
Offline Offline

Posts: 1488055492

View Profile Personal Message (Offline)

Ignore
1488055492
Reply with quote  #2

1488055492
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
cuz0882
Sr. Member
****
Offline Offline

Activity: 336



View Profile
February 24, 2012, 12:26:56 PM
 #22

I just tried this out for the first time tonight, the hash rate is really low though. Is there a guide to get cgminer running with it? I'm assuming the mining software is the reason for hash rate.. It's only giving 330 hash's per gpu. (5970's with 850 clocks)
gnar1ta$
Donator
Hero Member
*
Offline Offline

Activity: 756


View Profile
February 24, 2012, 03:32:05 PM
 #23

I just tried this out for the first time tonight, the hash rate is really low though. Is there a guide to get cgminer running with it? I'm assuming the mining software is the reason for hash rate.. It's only giving 330 hash's per gpu. (5970's with 850 clocks)

Like this in main settings:

Code:
# start cgminer?  set this to 1, and also set cgminer: 1 on each GPU you will manage with cgminer
  cgminer: 1
 
# options to cgminer (must have at least --api-listen for any bamt tools to work)
  cgminer_opts: --api-listen -0 http://<pool>:<port> -u <user> -p <pass> -I 8 --gpu-engine 850 --gpu-memclock 180 --auto-fan

Then the GPU section (add for each GPU 0,1,2....):

Code:
# GPU Configurtation
gpu0:
  disabled: 0
  # set to 1 if cgminer will manage this gpu.
  cgminer: 1
  # monitoring values, used by email alerts and gpumon
  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125

Mine lock with 850 on each core though, they run stable at 850,830 and 180 mem.

Losing hundreds of Bitcoins with the best scammers in the business - BFL, Avalon, KNC, HashFast.
BinaryMage
Hero Member
*****
Offline Offline

Activity: 546


Ad astra.


View Profile
February 24, 2012, 04:05:28 PM
 #24

File up on FTP. FTP to ftp://50.53.21.166:3141/, go to /bamt/0.5/bamt_v0.5a.zip. (For some reason a direct link to the file does not work; I'm not sure why.)


Foobared....

Code:
Connecting to 50.53.21.166:3141... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD (1) /bamt/0.5 ... done.
==> SIZE bamt_v0.5a.zip ... 529524325
==> PASV ... couldn't connect to 10.0.2.15 port 3144: Connection timed out

Like I said, you can't FTP to the file directly; I'm not sure why. I'm running vsftpd on Ubuntu Server 11.10 x64, if that helps.

-- BinaryMage -- | OTC | PGP
Isokivi
Hero Member
*****
Offline Offline

Activity: 924


Items flashing here available at btctrinkets.com


View Profile WWW
February 24, 2012, 07:35:05 PM
 #25

Trying to set this up on rig#1

Problems so far: I cant get any overclocking in with bamt.conf. I was able to do some overclocking with AMDOverdrive Ctrl, but Im nowhere near what this particular card can do, it wont let me push the core clock past 900Mhz. I have set up all (3)  the core_speeds at 970Mhz, tried only setting one dosent seem to make any difference.

Other than that everything looks fine.



Bitcoin trinkets now on my online store: btc trinkets.com <- Bitcoin Tiepins, cufflinks, lapel pins, keychains, card holders and challenge coins.
BitMinerN8
Hero Member
*****
Offline Offline

Activity: 626


Mining since May 2011.


View Profile
February 24, 2012, 08:08:00 PM
 #26

Trying to set this up on rig#1

Problems so far: I cant get any overclocking in with bamt.conf. I was able to do some overclocking with AMDOverdrive Ctrl, but Im nowhere near what this particular card can do, it wont let me push the core clock past 900Mhz. I have set up all (3)  the core_speeds at 970Mhz, tried only setting one dosent seem to make any difference.

Other than that everything looks fine.


I have been having issues too. What does it say on your http://YourMinerIP/ compared to what you set in bamt.conf? On my (3) 5850 GPU test rig that was doing 1120 Mhash/s under 0.4 is doing around 860 Mhash/s on 0.5 no matter what I put in for the 3 core_speed_X or mem_speed_X, it's like stock speeds only.

I'm going to try another single 5850 GPU rig now.
Isokivi
Hero Member
*****
Offline Offline

Activity: 924


Items flashing here available at btctrinkets.com


View Profile WWW
February 24, 2012, 08:17:04 PM
 #27

I found a workaround to the problem, but it's not pretty:
in root terminal: atitweak --set-core-voltage 1,16
(thats the card's stock voltage)
and: atitweak --set-engine-clock=970

Hashing away at normal rate now.

I'd still like to find out why I can only control the fanspeed from bamt.conf

Bitcoin trinkets now on my online store: btc trinkets.com <- Bitcoin Tiepins, cufflinks, lapel pins, keychains, card holders and challenge coins.
gnar1ta$
Donator
Hero Member
*
Offline Offline

Activity: 756


View Profile
February 24, 2012, 08:35:19 PM
 #28

Trying to set this up on rig#1

Problems so far: I cant get any overclocking in with bamt.conf. I was able to do some overclocking with AMDOverdrive Ctrl, but Im nowhere near what this particular card can do, it wont let me push the core clock past 900Mhz. I have set up all (3)  the core_speeds at 970Mhz, tried only setting one dosent seem to make any difference.

Other than that everything looks fine.


I have been having issues too. What does it say on your http://YourMinerIP/ compared to what you set in bamt.conf? On my (3) 5850 GPU test rig that was doing 1120 Mhash/s under 0.4 is doing around 860 Mhash/s on 0.5 no matter what I put in for the 3 core_speed_X or mem_speed_X, it's like stock speeds only.

I'm going to try another single 5850 GPU rig now.

Have you checked that oc hasn't been disabled by mother? Not running .5 yet but I'd think this would be included https://bitcointalk.org/index.php?topic=28967.msg755770#msg755770

Losing hundreds of Bitcoins with the best scammers in the business - BFL, Avalon, KNC, HashFast.
BitMinerN8
Hero Member
*****
Offline Offline

Activity: 626


Mining since May 2011.


View Profile
February 24, 2012, 08:41:01 PM
 #29

Trying to set this up on rig#1

Problems so far: I cant get any overclocking in with bamt.conf. I was able to do some overclocking with AMDOverdrive Ctrl, but Im nowhere near what this particular card can do, it wont let me push the core clock past 900Mhz. I have set up all (3)  the core_speeds at 970Mhz, tried only setting one dosent seem to make any difference.

Other than that everything looks fine.


I have been having issues too. What does it say on your http://YourMinerIP/ compared to what you set in bamt.conf? On my (3) 5850 GPU test rig that was doing 1120 Mhash/s under 0.4 is doing around 860 Mhash/s on 0.5 no matter what I put in for the 3 core_speed_X or mem_speed_X, it's like stock speeds only.

I'm going to try another single 5850 GPU rig now.

Have you checked that oc hasn't been disabled by mother? Not running .5 yet but I'd think this would be included https://bitcointalk.org/index.php?topic=28967.msg755770#msg755770

I confirmed the ACTIVE folder is empty.

On my single GPU 5850 on 0.5 i'm getting 305 Mhash/s.
On munin status page it shows Core 765 Mhz - Memory 1000 Mhz - Power 1.088v
Code:
gpu0:
  core_speed_0: 300
  core_speed_1: 800
  core_speed_2: 955
  
  mem_speed_0: 300
  mem_speed_1: 300
  mem_speed_2: 300

  core_voltage_0: 1.125
  core_voltage_1: 1.125
  core_voltage_2: 1.125000

On the same single GPU 5850 on 0.4 i'm getting 402 Mhash/s.
On munin status page it shows Core 970 Mhz - Memory 300 Mhz - Power 1.088v
Code:
gpu0:
  core_speed: 970
  mem_speed: 300
  fan_speed: 85
  kernel: phatk2
Isokivi
Hero Member
*****
Offline Offline

Activity: 924


Items flashing here available at btctrinkets.com


View Profile WWW
February 24, 2012, 08:41:54 PM
 #30

Trying to set this up on rig#1

Problems so far: I cant get any overclocking in with bamt.conf. I was able to do some overclocking with AMDOverdrive Ctrl, but Im nowhere near what this particular card can do, it wont let me push the core clock past 900Mhz. I have set up all (3)  the core_speeds at 970Mhz, tried only setting one dosent seem to make any difference.

Other than that everything looks fine.


I have been having issues too. What does it say on your http://YourMinerIP/ compared to what you set in bamt.conf? On my (3) 5850 GPU test rig that was doing 1120 Mhash/s under 0.4 is doing around 860 Mhash/s on 0.5 no matter what I put in for the 3 core_speed_X or mem_speed_X, it's like stock speeds only.

I'm going to try another single 5850 GPU rig now.

Have you checked that oc hasn't been disabled by mother? Not running .5 yet but I'd think this would be included https://bitcointalk.org/index.php?topic=28967.msg755770#msg755770
Nope the file mother creates is not there.

Bitcoin trinkets now on my online store: btc trinkets.com <- Bitcoin Tiepins, cufflinks, lapel pins, keychains, card holders and challenge coins.
Isokivi
Hero Member
*****
Offline Offline

Activity: 924


Items flashing here available at btctrinkets.com


View Profile WWW
February 24, 2012, 08:57:22 PM
 #31

And now it would appear that coldreboot killed my usb-stick.
edit: Rewriting bamt to the stick atm
edit2: manages to boot up, stick is not dead.

Bitcoin trinkets now on my online store: btc trinkets.com <- Bitcoin Tiepins, cufflinks, lapel pins, keychains, card holders and challenge coins.
BitMinerN8
Hero Member
*****
Offline Offline

Activity: 626


Mining since May 2011.


View Profile
February 24, 2012, 09:03:43 PM
 #32

And now it would appear that coldreboot killed my usb-stick.

Unplug and re-insert. See if that helps. I have that happen sometimes on a few rigs.
Isokivi
Hero Member
*****
Offline Offline

Activity: 924


Items flashing here available at btctrinkets.com


View Profile WWW
February 24, 2012, 09:09:16 PM
 #33

And now it would appear that coldreboot killed my usb-stick.

Unplug and re-insert. See if that helps. I have that happen sometimes on a few rigs.
Did that using a different usb port, that did not resolve it.

Bitcoin trinkets now on my online store: btc trinkets.com <- Bitcoin Tiepins, cufflinks, lapel pins, keychains, card holders and challenge coins.
BitMinerN8
Hero Member
*****
Offline Offline

Activity: 626


Mining since May 2011.


View Profile
February 24, 2012, 09:14:10 PM
 #34

And now it would appear that coldreboot killed my usb-stick.

Unplug and re-insert. See if that helps. I have that happen sometimes on a few rigs.
Did that using a different usb port, that did not resolve it.

I fixed one that would not come back by putting in a windows system, did a full format (not quick) and then restored the image on it again. It's been working for weeks after that. YMMV
Isokivi
Hero Member
*****
Offline Offline

Activity: 924


Items flashing here available at btctrinkets.com


View Profile WWW
February 24, 2012, 09:31:42 PM
 #35

Im back to square one: the usb-stick problem is gone.

bamt.conf wont apply overclocking, the values set are known stable clocks for this particular card. The card in question is a 5870, core voltage 1.16 core clock 970.
My workaround to this is to stop mining and run:
                                                                  atitweak --set-core-voltage=1.16
                                                                  atitweak --set engine-clock=970
And then restart mining.

Bitcoin trinkets now on my online store: btc trinkets.com <- Bitcoin Tiepins, cufflinks, lapel pins, keychains, card holders and challenge coins.
gnar1ta$
Donator
Hero Member
*
Offline Offline

Activity: 756


View Profile
February 24, 2012, 09:42:31 PM
 #36

Im back to square one: the usb-stick problem is gone.

bamt.conf wont apply overclocking, the values set are known stable clocks for this particular card. The card in question is a 5870, core voltage 1.16 core clock 970.
My workaround to this is to stop mining and run:
                                                                  atitweak --set-core-voltage=1.16
                                                                  atitweak --set engine-clock=970
And then restart mining.

If that works just add it to bamt.conf as a post oc command for the gpu and comment out the rest.
Code:
post_oc_cmd: /usr/local/bin/atitweak -e 970 -v 1.16 -A <#>
I never use the oc and fan commands just did it all that way. You can add -f <fan> and -m <memclock> also.  It will set all profile levels so make sure they are sane clocks.

Losing hundreds of Bitcoins with the best scammers in the business - BFL, Avalon, KNC, HashFast.
lodcrappo
Hero Member
*****
Offline Offline

Activity: 588


View Profile WWW
February 24, 2012, 09:49:19 PM
 #37

All the o/c settings in bamt.conf do is construct the atitweak command for you.  If it works with atitweak manually, it should work when bamt runs atitweak for you.
I will look into it.

If you want to support further development of BAMT (http://bamter.org/):  1PoRYaGS56ksQmK7XXLurW3B2zwCAE8PRc
lodcrappo
Hero Member
*****
Offline Offline

Activity: 588


View Profile WWW
February 24, 2012, 09:52:04 PM
 #38

I just tried this out for the first time tonight, the hash rate is really low though. Is there a guide to get cgminer running with it? I'm assuming the mining software is the reason for hash rate.. It's only giving 330 hash's per gpu. (5970's with 850 clocks)

Phoenix will give you at least the same and usually a better hashrate, better stales, and more shares accepted per minute (the only stat that actually matters) than cgminer.  Not to mention its much more stable.

The only reason to use cgminer is if you must have autofan or you must have it's pool management, and are willing to give up phoenix's advantages in return for those.

Soon, phoenix will have those things also,  either in phoenix 2 or from BAMT's own modifications in pcontrol.  We actually have autofan and autogpu implemented for phoenix, but I'm holding off to see where phoenix 2 will end up.   one way or the other, eventually phoenix will become the only miner needed in bamt.


As for your low rates, there may be a bug with overclocking.  I am looking into it.


If you want to support further development of BAMT (http://bamter.org/):  1PoRYaGS56ksQmK7XXLurW3B2zwCAE8PRc
lodcrappo
Hero Member
*****
Offline Offline

Activity: 588


View Profile WWW
February 24, 2012, 10:04:05 PM
 #39

Im back to square one: the usb-stick problem is gone.

bamt.conf wont apply overclocking, the values set are known stable clocks for this particular card. The card in question is a 5870, core voltage 1.16 core clock 970.
My workaround to this is to stop mining and run:
                                                                  atitweak --set-core-voltage=1.16
                                                                  atitweak --set engine-clock=970
And then restart mining.

Would you mind doing this to confirm bamt is understanding your config:

while mining, in a root shell or from ssh, type:

pcontrol

press d
press f
press enter

you will see a screen like this:



Make sure the O/C info (shaded purple in shot above, but won't be in real life)  matches what you set in bamt.conf

use up down arrow to check all your GPUs

let me know




If you want to support further development of BAMT (http://bamter.org/):  1PoRYaGS56ksQmK7XXLurW3B2zwCAE8PRc
BitMinerN8
Hero Member
*****
Offline Offline

Activity: 626


Mining since May 2011.


View Profile
February 24, 2012, 10:38:49 PM
 #40

Im back to square one: the usb-stick problem is gone.

bamt.conf wont apply overclocking, the values set are known stable clocks for this particular card. The card in question is a 5870, core voltage 1.16 core clock 970.
My workaround to this is to stop mining and run:
                                                                  atitweak --set-core-voltage=1.16
                                                                  atitweak --set engine-clock=970
And then restart mining.

Would you mind doing this to confirm bamt is understanding your config:

while mining, in a root shell or from ssh, type:

pcontrol

press d
press f
press enter

you will see a screen like this:



Make sure the O/C info (shaded purple in shot above, but won't be in real life)  matches what you set in bamt.conf

use up down arrow to check all your GPUs

let me know


On my test rig I run pcontrol, hit d and then f and it bombs out like this.
Code:
BAMT                                                                    miner1Exception in thread Thread-1:
 Display   GPUs   Pools   CoTraceback (most recent call last):
                                                                File "/usr/lib/python2.6/threading.py", linCurrent Pool: pit.deepbit.net
                                                          self.run()
  Hash: 305.334 Mh/s         Pools File: /etc/bamt/pools              File "/opt/bamt/pcontrolADLT.py", liPool Strategy: priority failover
   A/R: 98/0                     Kernel: phatk2f.scr.addstr(top + x,rt, ("%" + s   Rej: 0.00% "s") % " ") Kernel Params: BFI_INT VECTORS FASTLOOP=false AGG..
  Stat: got              error: addstr() returned ERR
   Que: 0/0
  Dlay: 164ms                                                            miner1
   Eff: 33.3%
Pages: « 1 [2] 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 ... 80 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!