Bitcoin Forum
December 04, 2016, 08:29:19 AM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 [5] 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 ... 80 »
  Print  
Author Topic: BAMT version 0.5 - Easy USB based mining Linux with farm wide management tools  (Read 302677 times)
TheHarbinger
Sr. Member
****
Offline Offline

Activity: 378


Why is it so damn hot in here?


View Profile
February 25, 2012, 03:28:07 PM
 #81


Thanks I must have had too many or few spaces.  It is working now.

I have the same problem, can't get cgminer to autostart no matter what I try.  Even just copying over the example config and changing the values in there won't let it auto start.  Sticking with 0.4 for now until I figure it out.  Can't really afford to take any of my 2.2GH/s rigs offline to play with it though, so I'm kind of stuck for now.

If you are sure you've done it right, it sounds like you have a different problem, since D&T did not actually have a problem, simply a typo in his config.


Yeah yeah, Phoenix is better...blah, blah, blah...  Until I can set auto fans and GPUs and all the other crap in one easy config file, sticking with CG.

That exactly what you will soon be able to do.  You'll get phoenix's stability and performance along with autofan, autogpu, and all the other fluffy stuff in cgminer Smiley


For sure it's a different problem.  Even copying the config files from a working/running 0.4 to a clean 0.5 doesn't help.  Just sits there with on the dreaded "No GPUs configured" background.  I think something is wrong with the way the config file is being read, because even changing the miner's name and/or location isn't showing up as changed.

12Um6jfDE7q6crm1s6tSksMvda8s1hZ3Vj
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
lodcrappo
Hero Member
*****
Offline Offline

Activity: 588


View Profile WWW
February 25, 2012, 03:30:13 PM
 #82


Thanks I must have had too many or few spaces.  It is working now.

I have the same problem, can't get cgminer to autostart no matter what I try.  Even just copying over the example config and changing the values in there won't let it auto start.  Sticking with 0.4 for now until I figure it out.  Can't really afford to take any of my 2.2GH/s rigs offline to play with it though, so I'm kind of stuck for now.

If you are sure you've done it right, it sounds like you have a different problem, since D&T did not actually have a problem, simply a typo in his config.


Yeah yeah, Phoenix is better...blah, blah, blah...  Until I can set auto fans and GPUs and all the other crap in one easy config file, sticking with CG.

That exactly what you will soon be able to do.  You'll get phoenix's stability and performance along with autofan, autogpu, and all the other fluffy stuff in cgminer Smiley


For sure it's a different problem.  Even copying the config files from a working/running 0.4 to a clean 0.5 doesn't help.  Just sits there with on the dreaded "No GPUs configured" background.  I think something is wrong with the way the config file is being read, because even changing the miner's name and/or location isn't showing up as changed.

If you are getting "no gpus configured", your config is b0rked.  Nothing is going to work.

you can run "mother -v" and she might tell you which line is messed up, but depending on what is wrong that isn't always possible.



If you want to support further development of BAMT (http://bamter.org/):  1PoRYaGS56ksQmK7XXLurW3B2zwCAE8PRc
TheHarbinger
Sr. Member
****
Offline Offline

Activity: 378


Why is it so damn hot in here?


View Profile
February 25, 2012, 03:36:51 PM
 #83


Thanks I must have had too many or few spaces.  It is working now.

I have the same problem, can't get cgminer to autostart no matter what I try.  Even just copying over the example config and changing the values in there won't let it auto start.  Sticking with 0.4 for now until I figure it out.  Can't really afford to take any of my 2.2GH/s rigs offline to play with it though, so I'm kind of stuck for now.

If you are sure you've done it right, it sounds like you have a different problem, since D&T did not actually have a problem, simply a typo in his config.


Yeah yeah, Phoenix is better...blah, blah, blah...  Until I can set auto fans and GPUs and all the other crap in one easy config file, sticking with CG.

That exactly what you will soon be able to do.  You'll get phoenix's stability and performance along with autofan, autogpu, and all the other fluffy stuff in cgminer Smiley


For sure it's a different problem.  Even copying the config files from a working/running 0.4 to a clean 0.5 doesn't help.  Just sits there with on the dreaded "No GPUs configured" background.  I think something is wrong with the way the config file is being read, because even changing the miner's name and/or location isn't showing up as changed.

If you are getting "no gpus configured", your config is b0rked.  Nothing is going to work.

you can run "mother -v" and she might tell you which line is messed up, but depending on what is wrong that isn't always possible.




That's what I don't understand, how can it be "b0rked"?  It's the same config as was running perfectly in 0.4.  The file was just copied from a 0.4 key to a clean 0.5 key.  It's the same file.  So now I must go beat my head against a wall.

12Um6jfDE7q6crm1s6tSksMvda8s1hZ3Vj
lodcrappo
Hero Member
*****
Offline Offline

Activity: 588


View Profile WWW
February 25, 2012, 03:38:43 PM
 #84


Thanks I must have had too many or few spaces.  It is working now.

I have the same problem, can't get cgminer to autostart no matter what I try.  Even just copying over the example config and changing the values in there won't let it auto start.  Sticking with 0.4 for now until I figure it out.  Can't really afford to take any of my 2.2GH/s rigs offline to play with it though, so I'm kind of stuck for now.

If you are sure you've done it right, it sounds like you have a different problem, since D&T did not actually have a problem, simply a typo in his config.


Yeah yeah, Phoenix is better...blah, blah, blah...  Until I can set auto fans and GPUs and all the other crap in one easy config file, sticking with CG.

That exactly what you will soon be able to do.  You'll get phoenix's stability and performance along with autofan, autogpu, and all the other fluffy stuff in cgminer Smiley


For sure it's a different problem.  Even copying the config files from a working/running 0.4 to a clean 0.5 doesn't help.  Just sits there with on the dreaded "No GPUs configured" background.  I think something is wrong with the way the config file is being read, because even changing the miner's name and/or location isn't showing up as changed.

If you are getting "no gpus configured", your config is b0rked.  Nothing is going to work.

you can run "mother -v" and she might tell you which line is messed up, but depending on what is wrong that isn't always possible.




That's what I don't understand, how can it be "b0rked"?  It's the same config as was running perfectly in 0.4.  The file was just copied from a 0.4 key to a clean 0.5 key.  It's the same file.  So now I must go beat my head against a wall.

you can run "mother -v" and she might tell you which line is messed up

If you want to support further development of BAMT (http://bamter.org/):  1PoRYaGS56ksQmK7XXLurW3B2zwCAE8PRc
cuz0882
Sr. Member
****
Offline Offline

Activity: 336



View Profile
February 25, 2012, 03:44:47 PM
 #85

I have been trying to overclock my cards all night. If I set my voltage to the stock setting it accepts the overclock. Not much of a solution though. Even in ati, it only lets the voltage raise to 1.049 which is stock on the 5970.
lodcrappo
Hero Member
*****
Offline Offline

Activity: 588


View Profile WWW
February 25, 2012, 03:50:06 PM
 #86

I have been trying to overclock my cards all night. If I set my voltage to the stock setting it accepts the overclock. Not much of a solution though. Even in ati, it only lets the voltage raise to 1.049 which is stock on the 5970.


I don't think Linux supports overvolting the 5970.  There is a tool called raedonvolt that supposedly can be hacked to sort of work, but it doesn't seem very robust or well supported.  it bypasses ATI's api and mucks around in the card directly.

for example..
http://allmybase.com/2012/01/25/overvolting-the-ati-radeon-5970-in-linux-with-radeonvolt/


If you want to support further development of BAMT (http://bamter.org/):  1PoRYaGS56ksQmK7XXLurW3B2zwCAE8PRc
cuz0882
Sr. Member
****
Offline Offline

Activity: 336



View Profile
February 25, 2012, 04:02:45 PM
 #87

I have been trying to overclock my cards all night. If I set my voltage to the stock setting it accepts the overclock. Not much of a solution though. Even in ati, it only lets the voltage raise to 1.049 which is stock on the 5970.


I don't think Linux supports overvolting the 5970.  There is a tool called raedonvolt that supposedly can be hacked to sort of work, but it doesn't seem very robust or well supported.  it bypasses ATI's api and mucks around in the card directly.

for example..
http://allmybase.com/2012/01/25/overvolting-the-ati-radeon-5970-in-linux-with-radeonvolt/


Hard to believe with all the people on the forum acting like everyone is crazy who uses windows on dedicated miners.
DeathAndTaxes
Donator
Legendary
*
Offline Offline

Activity: 1218


Gerald Davis


View Profile
February 25, 2012, 04:14:07 PM
 #88

I have been trying to overclock my cards all night. If I set my voltage to the stock setting it accepts the overclock. Not much of a solution though. Even in ati, it only lets the voltage raise to 1.049 which is stock on the 5970.


I don't think Linux supports overvolting the 5970.  There is a tool called raedonvolt that supposedly can be hacked to sort of work, but it doesn't seem very robust or well supported.  it bypasses ATI's api and mucks around in the card directly.

for example..
http://allmybase.com/2012/01/25/overvolting-the-ati-radeon-5970-in-linux-with-radeonvolt/


Hard to believe with all the people on the forum acting like everyone is crazy who uses windows on dedicated miners.

Due to exponential increase in power combined with heat load on a 3x5970 or 4x5970 rig most people don't overvolt 5970s.  Still this is one area where windows is superior.  You can always do a custom bios flash.
Isokivi
Hero Member
*****
Offline Offline

Activity: 924


Items flashing here available at btctrinkets.com


View Profile WWW
February 25, 2012, 04:59:48 PM
 #89

Im back to square one: the usb-stick problem is gone.

bamt.conf wont apply overclocking, the values set are known stable clocks for this particular card. The card in question is a 5870, core voltage 1.16 core clock 970.
My workaround to this is to stop mining and run:
                                                                  atitweak --set-core-voltage=1.16
                                                                  atitweak --set engine-clock=970
And then restart mining.

Would you mind doing this to confirm bamt is understanding your config:

while mining, in a root shell or from ssh, type:

pcontrol

press d
press f
press enter

you will see a screen like this:



Make sure the O/C info (shaded purple in shot above, but won't be in real life)  matches what you set in bamt.conf

use up down arrow to check all your GPUs

let me know


On my test rig I run pcontrol, hit d and then f and it bombs out like this.
Code:
BAMT                                                                    miner1Exception in thread Thread-1:
 Display   GPUs   Pools   CoTraceback (most recent call last):
                                                                File "/usr/lib/python2.6/threading.py", linCurrent Pool: pit.deepbit.net
                                                          self.run()
  Hash: 305.334 Mh/s         Pools File: /etc/bamt/pools              File "/opt/bamt/pcontrolADLT.py", liPool Strategy: priority failover
   A/R: 98/0                     Kernel: phatk2f.scr.addstr(top + x,rt, ("%" + s   Rej: 0.00% "s") % " ") Kernel Params: BFI_INT VECTORS FASTLOOP=false AGG..
  Stat: got              error: addstr() returned ERR
   Que: 0/0
  Dlay: 164ms                                                            miner1
   Eff: 33.3%

pcontrol is still very alpha, not intended for normal use at all. 

try making window bigger, sometimes it gets confused.

Sorry for the delayed reply, I was at work.
When I run /opt/bamt/fixer I get a message "One of the BAMT tools has suffered a fatal error. Not a GLOB reference at /usr/share/perl/5.10/IO/Zlib.pm line 559

Bitcoin trinkets now on my online store: btc trinkets.com <- Bitcoin Tiepins, cufflinks, lapel pins, keychains, card holders and challenge coins.
lodcrappo
Hero Member
*****
Offline Offline

Activity: 588


View Profile WWW
February 25, 2012, 05:01:10 PM
 #90


When I run /opt/bamt/fixer I get a message "One of the BAMT tools has suffered a fatal error. Not a GLOB reference at /usr/share/perl/5.10/IO/Zlib.pm line 559


https://bitcointalk.org/index.php?topic=65915.msg767818#msg767818

If you want to support further development of BAMT (http://bamter.org/):  1PoRYaGS56ksQmK7XXLurW3B2zwCAE8PRc
Isokivi
Hero Member
*****
Offline Offline

Activity: 924


Items flashing here available at btctrinkets.com


View Profile WWW
February 25, 2012, 05:02:46 PM
 #91


When I run /opt/bamt/fixer I get a message "One of the BAMT tools has suffered a fatal error. Not a GLOB reference at /usr/share/perl/5.10/IO/Zlib.pm line 559


https://bitcointalk.org/index.php?topic=65915.msg767818#msg767818

Just found it myslef, I really dislike the way this forum works Tongue

Bitcoin trinkets now on my online store: btc trinkets.com <- Bitcoin Tiepins, cufflinks, lapel pins, keychains, card holders and challenge coins.
lodcrappo
Hero Member
*****
Offline Offline

Activity: 588


View Profile WWW
February 25, 2012, 05:05:02 PM
 #92


When I run /opt/bamt/fixer I get a message "One of the BAMT tools has suffered a fatal error. Not a GLOB reference at /usr/share/perl/5.10/IO/Zlib.pm line 559


https://bitcointalk.org/index.php?topic=65915.msg767818#msg767818

Just found it myslef, I really dislike the way this forum works Tongue

yeah it kind of sucks.  well, not this forum anymore than every forum, afaict.

no real way to notify everybody: hey - here is the answer to that thing 50 of you are going to post about.

If you want to support further development of BAMT (http://bamter.org/):  1PoRYaGS56ksQmK7XXLurW3B2zwCAE8PRc
Isokivi
Hero Member
*****
Offline Offline

Activity: 924


Items flashing here available at btctrinkets.com


View Profile WWW
February 25, 2012, 05:07:03 PM
 #93

I can confirm that the workaround to apply the patch works and that the patch resolves the Oc issue.

Bitcoin trinkets now on my online store: btc trinkets.com <- Bitcoin Tiepins, cufflinks, lapel pins, keychains, card holders and challenge coins.
BitMinerN8
Hero Member
*****
Offline Offline

Activity: 626


Mining since May 2011.


View Profile
February 25, 2012, 08:16:27 PM
 #94

I can confirm that the workaround to apply the patch works and that the patch resolves the Oc issue.

If you don't mind saying, what flavor of card(s) are you running?
BitMinerN8
Hero Member
*****
Offline Offline

Activity: 626


Mining since May 2011.


View Profile
February 25, 2012, 11:18:14 PM
 #95



If you are speaking of the core_speed: 950 & mem_speed: 300 vs. core_speed_2: 950 & mem_speed_2: 300 it does not matter. My 0.4 USB stick for that rig is stock 0.4 bamt.conf, edited with what you see there, been running for weeks.

0.5 (even when testing the beta x64) seemed to have introduced the core_speed_X:, mem_speed_X:, etc (3 profiles) I have never been able to get the 5850s OC working in 0.5 any build (x86/x64).

No, the 3 profile, whatever_0 etc type settings have been in 0.4 for months.  Either style works fine in either version.  if you don't specify the number with _X, it just sets profile 2.  Always been that way.

interesting that you mention the x64 test build did not work either.  it was exactly the same code as 0.4!  only difference between x64 test and 0.4 was the 64bit kernel.  I shouldn't have called that "0.5" at all, that was a mistake.

I have even tried taking my working 0.4 bamt.conf over to 0.5 verbatim, does not work. Just an FYI as I mentioned before, this is not just one 5850, I have tested 4 separate rigs now with the same results. Some are Sapphire, one is Gigabyte. All different model MB, 3 ASUS, 1 Gigabyte. The only constant here is the 5850s, my 5830s are mining without issue, same exact setting going from 0.4 to 0.5. I will start in on testing 69xx after some sleep.

There is something weird going on, but it is not the "difference" between 0.4 and 0.5, since you saw this problem on x64, which was 0.4.   Time to look at other possibilities.


Here are the results of some further testing today with 3 more rigs:

miner-04 - running 0.5
GPU0: Sapphire 5830 - 314 Mhash/s - OC Working
GPU1: Diamond 6970 - 420 Mhash/s - OC Working
Same exact results in 0.4!  Cool

miner-06 - running 0.5
GPU0: Gigabyte 5870 - 406 Mhash/s - OC Working
GPU1: Sapphire 5830 - 313 Mhash/s - OC Working
Same exact results in 0.4!  Cool

miner-02 - running 0.5
GPU0: HIS 6950 - 341 Mhash/s - OC NOT Working
GPU1: Gigabyte 5850 - 306 Mhash/s - OC NOT Working
queue SadTrombone.com  Cry
And yes I am copying my exact settings from 0.4 to 0.5.

That same rig running 0.4
GPU0: HIS 6950 - 373 Mhash/s - OC Working
GPU1: Gigabyte 5850 - 387 Mhash/s - OC Working

Results of debug under 0.5:
Code:
root@miner-02:~# mine restart
Stopping mining processes...: mine..3481.gpu1..3448.gpu0..wrapper-1.pid..wrapper-0.pid...
Starting mining processes...: mine
(config sync: 'bamt.conf' in live dir is updated, copying to offline)
..munin..GPU 0..fan 0

--[ Debug info for O/C on GPU 0 ]------------------------------------------------

GPU is enabled, overclocking is enabled

OC command - profile 0: DISPLAY=:0.0 /usr/local/bin/atitweak -P 0 -A 0 -e 300 -m 300 -v 1.125

Results:
Setting performance level 0 on adapter 0: engine clock 300MHz, memory clock 300MHz, core voltage 1.125VDC
ADL_Overdrive5_ODPerformanceLevels_Set failed.

OC command - profile 1: DISPLAY=:0.0 /usr/local/bin/atitweak -P 1 -A 0 -e 800 -m 300 -v 1.125

Results:
Setting performance level 1 on adapter 0: engine clock 800MHz, memory clock 300MHz, core voltage 1.125VDC
ADL_Overdrive5_ODPerformanceLevels_Set failed.

OC command - profile 2: DISPLAY=:0.0 /usr/local/bin/atitweak -P 2 -A 0 -e 920 -m 300 -v 1.125000

Results:
Setting performance level 2 on adapter 0: engine clock 920MHz, memory clock 300MHz, core voltage 1.125VDC
ADL_Overdrive5_ODPerformanceLevels_Set failed.

-------------------------------------------------------------------------------

..GPU 1..fan 1

--[ Debug info for O/C on GPU 1 ]------------------------------------------------

GPU is enabled, overclocking is enabled

OC command - profile 0: DISPLAY=:0.0 /usr/local/bin/atitweak -P 0 -A 1 -e 300 -m 300 -v 1.125

Results:
Setting performance level 0 on adapter 1: engine clock 300MHz, memory clock 300MHz, core voltage 1.125VDC
ADL_Overdrive5_ODPerformanceLevels_Set failed.

OC command - profile 1: DISPLAY=:0.0 /usr/local/bin/atitweak -P 1 -A 1 -e 800 -m 300

Results:
Setting performance level 1 on adapter 1: engine clock 800MHz, memory clock 300MHz
ADL_Overdrive5_ODPerformanceLevels_Set failed.

OC command - profile 2: DISPLAY=:0.0 /usr/local/bin/atitweak -P 2 -A 1 -e 930 -m 300

Results:
Setting performance level 2 on adapter 1: engine clock 930MHz, memory clock 300MHz
ADL_Overdrive5_ODPerformanceLevels_Set failed.

-------------------------------------------------------------------------------

So as it sits, it looks as if this narrows it down to 5850's from Gigabyte/Sapphire and 6950 from HIS. (from the GPUs in my farm)
I can test a 5970 and some 6870s in a couple days, as they are remote and working without issue under 0.4 so I kind of want to leave them alone. I'm starting to get into my "if it works don't fix it mode". (but what fun is that right?)

I'm providing all of this as feedback, I know it will take time to research and fix. I just want other people to be aware in case they are have my specific issues with those GPUs. (if they actually page through the forum topic) For now I will stick with 0.4 on the rigs with the OC issues and 0.5 on the ones that don't.
lodcrappo
Hero Member
*****
Offline Offline

Activity: 588


View Profile WWW
February 25, 2012, 11:24:32 PM
 #96


Code:
--[ Debug info for O/C on GPU 0 ]------------------------------------------------

GPU is enabled, overclocking is enabled

OC command - profile 0: DISPLAY=:0.0 /usr/local/bin/atitweak -P 0 -A 0 -e 300 -m 300 -v 1.125

Results:
Setting performance level 0 on adapter 0: engine clock 300MHz, memory clock 300MHz, core voltage 1.125VDC
ADL_Overdrive5_ODPerformanceLevels_Set failed.

OC command - profile 1: DISPLAY=:0.0 /usr/local/bin/atitweak -P 1 -A 0 -e 800 -m 300 -v 1.125

Results:
Setting performance level 1 on adapter 0: engine clock 800MHz, memory clock 300MHz, core voltage 1.125VDC
ADL_Overdrive5_ODPerformanceLevels_Set failed.

OC command - profile 2: DISPLAY=:0.0 /usr/local/bin/atitweak -P 2 -A 0 -e 920 -m 300 -v 1.125000

Results:
Setting performance level 2 on adapter 0: engine clock 920MHz, memory clock 300MHz, core voltage 1.125VDC
ADL_Overdrive5_ODPerformanceLevels_Set failed.

-------------------------------------------------------------------------------

..GPU 1..fan 1

--[ Debug info for O/C on GPU 1 ]------------------------------------------------

GPU is enabled, overclocking is enabled

OC command - profile 0: DISPLAY=:0.0 /usr/local/bin/atitweak -P 0 -A 1 -e 300 -m 300 -v 1.125

Results:
Setting performance level 0 on adapter 1: engine clock 300MHz, memory clock 300MHz, core voltage 1.125VDC
ADL_Overdrive5_ODPerformanceLevels_Set failed.

OC command - profile 1: DISPLAY=:0.0 /usr/local/bin/atitweak -P 1 -A 1 -e 800 -m 300

Results:
Setting performance level 1 on adapter 1: engine clock 800MHz, memory clock 300MHz
ADL_Overdrive5_ODPerformanceLevels_Set failed.

OC command - profile 2: DISPLAY=:0.0 /usr/local/bin/atitweak -P 2 -A 1 -e 930 -m 300

Results:
Setting performance level 2 on adapter 1: engine clock 930MHz, memory clock 300MHz
ADL_Overdrive5_ODPerformanceLevels_Set failed.

-------------------------------------------------------------------------------



These results show the use of the three profile syntax.  Earlier you seemed to indicate your 0.4 config does not use the three profile syntax.   If this is ever going to be narrowed down, you must not change anything in the configuration between 0.4 and 0.5.  Nothing.  Copy the exact file from 0.4 to 0.5, don't type into it, don't edit it, just a 100% exact copy.   Otherwise, there is simply no guessing what these results are actually showing.



If you want to support further development of BAMT (http://bamter.org/):  1PoRYaGS56ksQmK7XXLurW3B2zwCAE8PRc
BitMinerN8
Hero Member
*****
Offline Offline

Activity: 626


Mining since May 2011.


View Profile
February 25, 2012, 11:47:39 PM
 #97


Code:
--[ Debug info for O/C on GPU 0 ]------------------------------------------------

GPU is enabled, overclocking is enabled

OC command - profile 0: DISPLAY=:0.0 /usr/local/bin/atitweak -P 0 -A 0 -e 300 -m 300 -v 1.125

Results:
Setting performance level 0 on adapter 0: engine clock 300MHz, memory clock 300MHz, core voltage 1.125VDC
ADL_Overdrive5_ODPerformanceLevels_Set failed.

OC command - profile 1: DISPLAY=:0.0 /usr/local/bin/atitweak -P 1 -A 0 -e 800 -m 300 -v 1.125

Results:
Setting performance level 1 on adapter 0: engine clock 800MHz, memory clock 300MHz, core voltage 1.125VDC
ADL_Overdrive5_ODPerformanceLevels_Set failed.

OC command - profile 2: DISPLAY=:0.0 /usr/local/bin/atitweak -P 2 -A 0 -e 920 -m 300 -v 1.125000

Results:
Setting performance level 2 on adapter 0: engine clock 920MHz, memory clock 300MHz, core voltage 1.125VDC
ADL_Overdrive5_ODPerformanceLevels_Set failed.

-------------------------------------------------------------------------------

..GPU 1..fan 1

--[ Debug info for O/C on GPU 1 ]------------------------------------------------

GPU is enabled, overclocking is enabled

OC command - profile 0: DISPLAY=:0.0 /usr/local/bin/atitweak -P 0 -A 1 -e 300 -m 300 -v 1.125

Results:
Setting performance level 0 on adapter 1: engine clock 300MHz, memory clock 300MHz, core voltage 1.125VDC
ADL_Overdrive5_ODPerformanceLevels_Set failed.

OC command - profile 1: DISPLAY=:0.0 /usr/local/bin/atitweak -P 1 -A 1 -e 800 -m 300

Results:
Setting performance level 1 on adapter 1: engine clock 800MHz, memory clock 300MHz
ADL_Overdrive5_ODPerformanceLevels_Set failed.

OC command - profile 2: DISPLAY=:0.0 /usr/local/bin/atitweak -P 2 -A 1 -e 930 -m 300

Results:
Setting performance level 2 on adapter 1: engine clock 930MHz, memory clock 300MHz
ADL_Overdrive5_ODPerformanceLevels_Set failed.

-------------------------------------------------------------------------------



These results show the use of the three profile syntax.  Earlier you seemed to indicate your 0.4 config does not use the three profile syntax.   If this is ever going to be narrowed down, you must not change anything in the configuration between 0.4 and 0.5.  Nothing.  Copy the exact file from 0.4 to 0.5, don't type into it, don't edit it, just a 100% exact copy.   Otherwise, there is simply no guessing what these results are actually showing.


I have never used the 3 profile settings in any of my 0.4 rigs. In 0.5 I moved the single 0.4 profile settings into the respective core_speed_2 or mem_speed_2, etc. (Like I did with all the other rigs that don't have a Gigabyte 5850 or HIS 6950 and are working fine.)

For the sake of argument I will copy the bamt.conf over from the 0.4 stick over to the 0.5 stick, but I will have to add the debug_oc to it.
BitMinerN8
Hero Member
*****
Offline Offline

Activity: 626


Mining since May 2011.


View Profile
February 26, 2012, 12:49:30 AM
 #98


Code:
--[ Debug info for O/C on GPU 0 ]------------------------------------------------

GPU is enabled, overclocking is enabled

OC command - profile 0: DISPLAY=:0.0 /usr/local/bin/atitweak -P 0 -A 0 -e 300 -m 300 -v 1.125

Results:
Setting performance level 0 on adapter 0: engine clock 300MHz, memory clock 300MHz, core voltage 1.125VDC
ADL_Overdrive5_ODPerformanceLevels_Set failed.

OC command - profile 1: DISPLAY=:0.0 /usr/local/bin/atitweak -P 1 -A 0 -e 800 -m 300 -v 1.125

Results:
Setting performance level 1 on adapter 0: engine clock 800MHz, memory clock 300MHz, core voltage 1.125VDC
ADL_Overdrive5_ODPerformanceLevels_Set failed.

OC command - profile 2: DISPLAY=:0.0 /usr/local/bin/atitweak -P 2 -A 0 -e 920 -m 300 -v 1.125000

Results:
Setting performance level 2 on adapter 0: engine clock 920MHz, memory clock 300MHz, core voltage 1.125VDC
ADL_Overdrive5_ODPerformanceLevels_Set failed.

-------------------------------------------------------------------------------

..GPU 1..fan 1

--[ Debug info for O/C on GPU 1 ]------------------------------------------------

GPU is enabled, overclocking is enabled

OC command - profile 0: DISPLAY=:0.0 /usr/local/bin/atitweak -P 0 -A 1 -e 300 -m 300 -v 1.125

Results:
Setting performance level 0 on adapter 1: engine clock 300MHz, memory clock 300MHz, core voltage 1.125VDC
ADL_Overdrive5_ODPerformanceLevels_Set failed.

OC command - profile 1: DISPLAY=:0.0 /usr/local/bin/atitweak -P 1 -A 1 -e 800 -m 300

Results:
Setting performance level 1 on adapter 1: engine clock 800MHz, memory clock 300MHz
ADL_Overdrive5_ODPerformanceLevels_Set failed.

OC command - profile 2: DISPLAY=:0.0 /usr/local/bin/atitweak -P 2 -A 1 -e 930 -m 300

Results:
Setting performance level 2 on adapter 1: engine clock 930MHz, memory clock 300MHz
ADL_Overdrive5_ODPerformanceLevels_Set failed.

-------------------------------------------------------------------------------


These results show the use of the three profile syntax.  Earlier you seemed to indicate your 0.4 config does not use the three profile syntax.   If this is ever going to be narrowed down, you must not change anything in the configuration between 0.4 and 0.5.  Nothing.  Copy the exact file from 0.4 to 0.5, don't type into it, don't edit it, just a 100% exact copy.   Otherwise, there is simply no guessing what these results are actually showing.


I have never used the 3 profile settings in any of my 0.4 rigs. In 0.5 I moved the single 0.4 profile settings into the respective core_speed_2 or mem_speed_2, etc. (Like I did with all the other rigs that don't have a Gigabyte 5850 or HIS 6950 and are working fine.)

For the sake of argument I will copy the bamt.conf over from the 0.4 stick over to the 0.5 stick, but I will have to add the debug_oc to it.

Here is the bamt.conf on 0.4 (working great, no issues, OC working) copied over to 0.5, the only change is adding the debug_oc: 1 to both gpu0: and gpu1: sections.
Code:
settings:
  miner_id: miner-02
  miner_loc: RACK-07 SHELF-03
  do_cgsnoop: 1
  do_bcast_status: 1
  do_monitor: 0
  do_manage_config: 0
  start_mining_init_delay: 20
  start_mining_miner_delay: 3
  show_config_at_boot: 0
  show_gpumon_at_boot: 0
gpu0:
  disabled: 0
  debug_oc: 1
  core_speed: 920
  mem_speed: 300
  fan_speed: 70
  kernel: phatk2
  kernel_params: BFI_INT VECTORS FASTLOOP=false AGGRESSION=9
  pool_file: /etc/bamt/pools
  pool_timeout: 180
  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_shares_lo: 1
gpu1:
  disabled: 0
  debug_oc: 1
  core_speed: 930
  mem_speed: 300
  fan_speed: 72
  kernel: phatk2
  kernel_params: BFI_INT VECTORS FASTLOOP=false AGGRESSION=11
  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 250
  monitor_shares_lo: 1
  pool_file: /etc/bamt/pools
  pool_timeout: 180

Here is the debug while under 0.5:
Code:
root@miner-02:/etc/bamt# mine restart
Stopping mining processes...: mine..5534.gpu1..5507.gpu0..wrapper-1.pid..wrapper-0.pid...
Starting mining processes...: mine..munin..GPU 0..fan 0

--[ Debug info for O/C on GPU 0 ]------------------------------------------------

GPU is enabled, overclocking is enabled

OC command - all profiles: DISPLAY=:0.0 /usr/local/bin/atitweak -P 2 -A 0 -f 70 -e 920 -m 300

Results:
Setting performance level 2 on adapter 0: engine clock 920MHz, memory clock 300MHz
ADL_Overdrive5_ODPerformanceLevels_Set failed.

-------------------------------------------------------------------------------

..GPU 1..fan 1

--[ Debug info for O/C on GPU 1 ]------------------------------------------------

GPU is enabled, overclocking is enabled

OC command - all profiles: DISPLAY=:0.0 /usr/local/bin/atitweak -P 2 -A 1 -f 72 -e 930 -m 300

Results:
Setting performance level 2 on adapter 1: engine clock 930MHz, memory clock 300MHz
ADL_Overdrive5_ODPerformanceLevels_Set failed.

-------------------------------------------------------------------------------
stoppots
Sr. Member
****
Offline Offline

Activity: 271


View Profile
February 26, 2012, 06:27:35 AM
 #99

I have a few small questions about my BAMT, one is about BAMT v0.4b

Is it OK to ask questions about the last version in heree, or are you trying to keep them seperate? or
max in montreal
Hero Member
*****
Offline Offline

Activity: 504


View Profile
February 26, 2012, 06:38:00 AM
 #100

seperate...
Pages: « 1 2 3 4 [5] 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 ... 80 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!