Bitcoin Forum
December 03, 2016, 02:42:41 AM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 [4] 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 »
  Print  
Author Topic: Bitminter client (Windows/Linux/Mac)  (Read 549344 times)
Fefox
Full Member
***
Offline Offline

Activity: 161



View Profile
October 22, 2011, 08:41:23 AM
 #61

Did something change on the back-end tonight?

Im constantly running out of work to do.. server is taking all the proofs of work no problem.
spare work units on hand would just keep dropping to zero.. now the funny thing is exactly at 3:30 -6GMT everything cleared up..
the instant I post a proof of work I get a new work unit and the buffer stays full.

no packet loss or high ping during the problem time either.

1480732961
Hero Member
*
Offline Offline

Posts: 1480732961

View Profile Personal Message (Offline)

Ignore
1480732961
Reply with quote  #2

1480732961
Report to moderator
1480732961
Hero Member
*
Offline Offline

Posts: 1480732961

View Profile Personal Message (Offline)

Ignore
1480732961
Reply with quote  #2

1480732961
Report to moderator
1480732961
Hero Member
*
Offline Offline

Posts: 1480732961

View Profile Personal Message (Offline)

Ignore
1480732961
Reply with quote  #2

1480732961
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480732961
Hero Member
*
Offline Offline

Posts: 1480732961

View Profile Personal Message (Offline)

Ignore
1480732961
Reply with quote  #2

1480732961
Report to moderator
1480732961
Hero Member
*
Offline Offline

Posts: 1480732961

View Profile Personal Message (Offline)

Ignore
1480732961
Reply with quote  #2

1480732961
Report to moderator
DrHaribo
Legendary
*
Offline Offline

Activity: 1960


Bitminter.com Operator


View Profile WWW
October 22, 2011, 09:21:07 AM
 #62

Did something change on the back-end tonight?

Nope, nothing changed.

Not sure what that was, but I also see "idling" messages intermittently in the log for 15 minutes. I wasn't watching as it happened, so I didn't get a chance to investigate. But if it was accepting proofs of work but was very slow with giving out new work, then perhaps it was a problem with bitcoind. Strangely, everything seems to have cleared up as suddenly as the problem appeared.

▶▶▶ Bitminter.com - Your trusted mining pool since 2011.
P4man
Hero Member
*****
Offline Offline

Activity: 504



View Profile
October 22, 2011, 09:44:19 AM
 #63

disclaimer: I dont know what Im talking about, but if the server was up and pinging showed no problem, could it be bitcoind having (had) trouble connecting to the bitcoin network? Is bitcoind using a different connection? If so, could this possibly be related to a DDoS attack?

Anyway, I dont seem to have lost any work, perhaps thats the advantage of using slower cards Cheesy.

Fefox
Full Member
***
Offline Offline

Activity: 161



View Profile
November 23, 2011, 08:22:28 PM
 #64

just tried the Catalyst 11.11 drivers under windows 7 64

bitminter client does not seem to like it much. 2 of the 3 6970's in the machine now have a hash rate of about 370 and one (the card varies) runs at 220..

tried crossfire on, off, off with bridges attached etc.. no difference..

anyone else try this version?

btw: Love the new website updates!
DrHaribo
Legendary
*
Offline Offline

Activity: 1960


Bitminter.com Operator


View Profile WWW
November 23, 2011, 08:57:20 PM
 #65

I just upgraded to Catalyst 11.11 too. Running 6990 + 5970 on Win7 64. Runs fine here, maybe even a little bit faster than the old drivers.

Not sure why you are having problems. One time I was switching between different driver versions to make sure the miner worked ok on them and something similar happened to me. I had to wipe the drivers completely and reinstall them to get things working properly again. Did you try another miner? If another miner has the same problem I'd bet it's something wrong with the driver install.

Glad you like the website update. Merged mining and website updates took a lot of time, but I'll have some updates for the miner again soon. Smiley

▶▶▶ Bitminter.com - Your trusted mining pool since 2011.
P4man
Hero Member
*****
Offline Offline

Activity: 504



View Profile
November 23, 2011, 09:08:53 PM
 #66

just tried the Catalyst 11.11 drivers under windows 7 64

bitminter client does not seem to like it much. 2 of the 3 6970's in the machine now have a hash rate of about 370 and one (the card varies) runs at 220..

Just tried it, no problems here. Also 11.11 win7 x64, using either bitminter or cgminer performance is fine. Only one card on this machine though.

Fefox
Full Member
***
Offline Offline

Activity: 161



View Profile
November 23, 2011, 10:47:49 PM
 #67

Well I removed the drivers again, used driver sweeper, reinstalled and same thing...

I rebooted the machine a couple times and had a single windows update install, and now its fine  Huh

damn windows!  Undecided

thanks for confirming that the new drivers did in fact work..

DrHaribo
Legendary
*
Offline Offline

Activity: 1960


Bitminter.com Operator


View Profile WWW
November 24, 2011, 05:04:43 PM
 #68

Good that you got it working Smiley

Getting AMD drivers working properly is like playing the lottery. And their OpenCL compiler is ridiculous. But.. they make some excellent hardware. Smiley

▶▶▶ Bitminter.com - Your trusted mining pool since 2011.
DrHaribo
Legendary
*
Offline Offline

Activity: 1960


Bitminter.com Operator


View Profile WWW
November 24, 2011, 10:10:46 PM
 #69

Quick update, just started working on the miner again.

  • Merged mining friendly, no more high NMC stales
  • Fixed bug that could say your GPU "prefers the work size to be a multiple of 3539913157759729696 for this work process."
  • Hopefully fixed unstable performance

It would be very useful with some feedback on performance. The previous beta had very unstable performance for some users. I saw this sometimes myself too. With this update it seems stable here.

Use the beta button to test it.

▶▶▶ Bitminter.com - Your trusted mining pool since 2011.
Fefox
Full Member
***
Offline Offline

Activity: 161



View Profile
November 25, 2011, 04:15:09 AM
 #70


It would be very useful with some feedback on performance. The previous beta had very unstable performance for some users. I saw this sometimes myself too. With this update it seems stable here.

Use the beta button to test it.


Running it now, right off on my 3x6970 machine with windows its down a bit @ 1278 Mhps from 1283

I start it up on the 6950's and the A8 and report back in the morning.
Fefox
Full Member
***
Offline Offline

Activity: 161



View Profile
November 25, 2011, 07:19:05 PM
 #71

all machines have identical hardware, numbers are: accepted / rejected

Bitminter Beta windows 7 64
BTC 30,346 / 51
NMC 7,284 / 2

cgminer linux
BTC 29,314 / 56
NMC 7,071 / 8

cgminer linux
BTC 29,232 / 59
NMC 7,073    / 12
 
Looks like bitminter wins  Grin
P4man
Hero Member
*****
Offline Offline

Activity: 504



View Profile
November 25, 2011, 07:45:50 PM
 #72

I did a 20 min test of the bitminter beta. No problems here, performance seems smooth and I was slightly surprised to see it outperform cgminer (even if marginally) on my 5850s.

Im still sticking to cgminer for manageability (easy ssh access, even from my android phone, pool failover, fan and temperature control etc) but impressive stuff nonetheless DrHaribo.

conspirosphere.tk
Legendary
*
Offline Offline

Activity: 1862


Revolution will be decentralized


View Profile WWW
November 26, 2011, 09:27:32 AM
 #73

With the 1.0 version I used to get about 420 Mhs with my 5870 at work intervals=15
With the new beta I am getting about 405 Mhs at work intervals=15
If I increase work intervals=20 I get about 412 Mhs with the new beta.
= I'm going back to 1.0 version

Turbor
Legendary
*
Offline Offline

Activity: 1008


BitMinter


View Profile WWW
November 26, 2011, 05:40:30 PM
 #74

Tried out the beta today but with 11.9 (win7 32) cgminer is the fastest for me if it comes to mh/s. Now i upgraded to 11.11 which gave me a small bump  Smiley.

DrHaribo
Legendary
*
Offline Offline

Activity: 1960


Bitminter.com Operator


View Profile WWW
November 27, 2011, 09:14:15 PM
 #75

Releasing another beta version for testing. Here are the changes:

  • Fixed bug that could say your GPU "prefers the work size to be a multiple of
      3539913157759729696 for this work process."
  • Index saved settings by MAC address of first network interface. This allows
      different settings on individual networked computers with the same files
      (homedir). Note: this means your settings will be reset to defaults when
      upgrading to this version, and also any time you switch network cards
      or change MAC address.
  • Bugfix: ignored new passwords from user after server responded with
      other HTTP response code than 200 or 401
  • Added options window under "Settings -> Options..." in the menu, with
      audio configuration
  • Remember more settings across restarts: device settings (Tune & Tweak),
      audio settings, hidden devices (individual close buttons),
      hide/show log
  • Make OpenCL buffer type selectable for user (Tune & Tweak)
  • Default to manual vectors off and BFI_INT off on non-AMD devices

The new options window (settings->options...) is where I will soon add automation options. There's only audio setup there for now. Finally device settings are saved, which is also a must before automating anything.

conspirosphere.tk, and anyone else getting better speed from regular (1.0.1) than beta version: I'd be very happy if you can try out this version and see if it helps. Please try the different types of buffers (new setting in "tune & tweak") if you are using Windows. I can't understand what else could be causing 1.0.1 to run faster. I hope I can figure out this issue before all the new features are done.

▶▶▶ Bitminter.com - Your trusted mining pool since 2011.
Fefox
Full Member
***
Offline Offline

Activity: 161



View Profile
November 27, 2011, 10:33:49 PM
 #76


Seems under windows its not saving ANY settings now.

on start-up I get get a warning/error message: Access to the persistent storage denied - cannot load or save settings

conspirosphere.tk
Legendary
*
Offline Offline

Activity: 1862


Revolution will be decentralized


View Profile WWW
November 28, 2011, 06:20:28 AM
 #77

conspirosphere.tk, and anyone else getting better speed from regular (1.0.1) than beta version: I'd be very happy if you can try out this version and see if it helps.

This seems ok: I am getting about the same performance of 1.0.1 version on my 5870 (about 420 Mhs using the same intervals=15), both with Buffer type= default and =Device accessible CPU mem (AMD only).
[edit]: still, I have the impression that newest beta is 2-5 Mhs slower than 1.0.1

DrHaribo
Legendary
*
Offline Offline

Activity: 1960


Bitminter.com Operator


View Profile WWW
November 28, 2011, 11:09:36 PM
 #78

Seems under windows its not saving ANY settings now.

on start-up I get get a warning/error message: Access to the persistent storage denied - cannot load or save settings

Oops - fixed! Strange bug, didn't happen when started from command line, only when started from browser.

This seems ok: I am getting about the same performance of 1.0.1 version on my 5870 (about 420 Mhs using the same intervals=15), both with Buffer type= default and =Device accessible CPU mem (AMD only).
[edit]: still, I have the impression that newest beta is 2-5 Mhs slower than 1.0.1

Glad it helped. But I'm at a loss as to what is causing that last bit of a performance hit for you. I can't see what else changed since 1.0.1 that would affect performance. I'll look over things again, though.

Small update today:
  • Fixed the loading and saving of settings (mentioned above)
  • Workaround for a bug in Java that would cause security errors talking about mixing signed and unsigned code

I can't really be sure the workaround for the second bug is working, since I would only see the bug about once a month. Very rare, but also annoying. Did any of you ever see it?

I'm calling this 1.1.0-beta4 now. Seems like an easier to understand naming scheme for the beta versions.

Thank you to all who are testing, the feedback from all of you is very valuable.

▶▶▶ Bitminter.com - Your trusted mining pool since 2011.
conspirosphere.tk
Legendary
*
Offline Offline

Activity: 1862


Revolution will be decentralized


View Profile WWW
November 29, 2011, 10:47:33 AM
 #79

Glad it helped. But I'm at a loss as to what is causing that last bit of a performance hit for you. I can't see what else changed since 1.0.1 that would affect performance. I'll look over things again, though.

No, maybe I had a wrong impression due to the fact that the speed counter is changing continuously. Now I think it is all right.

DrHaribo
Legendary
*
Offline Offline

Activity: 1960


Bitminter.com Operator


View Profile WWW
November 29, 2011, 01:25:56 PM
 #80

No, maybe I had a wrong impression due to the fact that the speed counter is changing continuously. Now I think it is all right.

Good stuff. Just lacking automation features and some more testing then, to finish version 1.1. Smiley

▶▶▶ Bitminter.com - Your trusted mining pool since 2011.
Pages: « 1 2 3 [4] 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!