Bitcoin Forum
February 23, 2019, 04:23:33 PM *
News: Latest Bitcoin Core release: 0.17.1 [Torrent]
 
   Home   Help Search Login Register More  
Pages: « 1 2 3 [4] 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 »
  Print  
Author Topic: lolMiner Equihash Miner, Update: Feb 7th: lolMiner 0.7 alpha 5  (Read 39043 times)
Hashnamer
Newbie
*
Offline Offline

Activity: 23
Merit: 0


View Profile
July 28, 2018, 12:45:11 AM
 #61

Why it is not work for me?

After run run_miner.bat, i have this:
https://i104.fastpic.ru/big/2018/0728/09/f0349bb62b7b0efcb3a27c15fffb5d09.jpg
(an endless attempt to run the mining.)

Windows 10 / Nvidia 398.36 / 1x1080ti

PS: ver 0.3 not working too.
1550939013
Hero Member
*
Offline Offline

Posts: 1550939013

View Profile Personal Message (Offline)

Ignore
1550939013
Reply with quote  #2

1550939013
Report to moderator
1550939013
Hero Member
*
Offline Offline

Posts: 1550939013

View Profile Personal Message (Offline)

Ignore
1550939013
Reply with quote  #2

1550939013
Report to moderator
1550939013
Hero Member
*
Offline Offline

Posts: 1550939013

View Profile Personal Message (Offline)

Ignore
1550939013
Reply with quote  #2

1550939013
Report to moderator
Your Bitcoin transactions
The Ultimate Bitcoin mixer
made truly anonymous.
with an advanced technology.
Mix coins
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1550939013
Hero Member
*
Offline Offline

Posts: 1550939013

View Profile Personal Message (Offline)

Ignore
1550939013
Reply with quote  #2

1550939013
Report to moderator
1550939013
Hero Member
*
Offline Offline

Posts: 1550939013

View Profile Personal Message (Offline)

Ignore
1550939013
Reply with quote  #2

1550939013
Report to moderator
1550939013
Hero Member
*
Offline Offline

Posts: 1550939013

View Profile Personal Message (Offline)

Ignore
1550939013
Reply with quote  #2

1550939013
Report to moderator
theboosted
Newbie
*
Offline Offline

Activity: 1
Merit: 0


View Profile
July 28, 2018, 08:34:57 AM
Last edit: July 28, 2018, 07:30:24 PM by theboosted
 #62

Very bad miner. Even in MNX on the old miner the speed was better. Not to mention the 144.5 EWBF's percentage of 30 more gives on BTG In general, this is a failure. Checked on the cards 1070.
CygnusMinor
Newbie
*
Offline Offline

Activity: 17
Merit: 0


View Profile
July 28, 2018, 02:21:55 PM
 #63

On a headless Ubuntu 18.04 server (updated to latest patch) using amdgpu-pro-18.20-606296 (had to hack it a bit by symlinking libamdoclsc64.so to libamdocl64.so and fixing some permissions - strace is a wonderful tool) using two stock MSI Vega 56's, it's working. Mostly.

I get:
Average speed (60s): 21.2 sol/s | 19.9 sol/s Total: 41.1 sol/s

Although one of the 56's locked up after about an hour or so and zombied the process. Had to hard reboot the system:
===============================================
Average speed (5s): 22.0 sol/s | 21.4 sol/s Total: 43.4 sol/s
New job received: <snip>
Submitting share
Share accepted
Average speed (5s): 18.2 sol/s | 19.2 sol/s Total: 37.4 sol/s
New job received: <snip>
Average speed (5s): 4.6 sol/s | 7.4 sol/s Total: 12.0 sol/s
---------------------------------------------
Average speed (60s): 17.2 sol/s | 18.6 sol/s Total: 35.9 sol/s
---------------------------------------------
Average speed (5s): 0.0 sol/s | 0.0 sol/s Total: 0.0 sol/s
Average speed (5s): 0.0 sol/s | 0.0 sol/s Total: 0.0 sol/s
Error: lolMiner detected that device 0 is stucked
Shutting down lolMiner
===============================================
akira128
Newbie
*
Offline Offline

Activity: 59
Merit: 0


View Profile
July 28, 2018, 09:48:23 PM
Last edit: July 28, 2018, 09:58:38 PM by akira128
 #64

running ubuntu 18.04.1 with 13 RX570 (8GB) cards.

There is something seriously wrong with the Equihash 96.5 (Minexcoin) algo on v0.4
If I use the WORKBATCH:  HIGH setting, the hashrate slows down to a crawl, also of note is that the power draw of each GPU is around 40 watts (it's normally 95 watts when mining). Something just isn't working right with the HIGH setting.
If I use WORKBATCH:  MEDIUM, the reported hashrate (on http://eu.minexpool.nl) is around 10-15% higher then with v.034
However, it goes through these long periods where very little crypto is actually paid out from the pool. I don't understand how the listed balance for this rig is consistently really low, but yet the hashrate is high.

Switched back to v.034 for now.
v.034 doesn't have issues with '--set-work-batch HIGH ' , and it gets paid more from the pool than with v.04
Lolliedieb
Member
**
Offline Offline

Activity: 289
Merit: 34


View Profile WWW
July 28, 2018, 09:49:02 PM
 #65

Why it is not work for me?

After run run_miner.bat, i have this:
https://i104.fastpic.ru/big/2018/0728/09/f0349bb62b7b0efcb3a27c15fffb5d09.jpg
(an endless attempt to run the mining.)

Windows 10 / Nvidia 398.36 / 1x1080ti

PS: ver 0.3 not working too.

This is strange. Have you tried to run clinfo.exe to see information about your OpenCL setup if its complete? That point of miner close is directly where it should try to detect the OpenCL drivers available.

On a headless Ubuntu 18.04 server (updated to latest patch) using amdgpu-pro-18.20-606296 (had to hack it a bit by symlinking libamdoclsc64.so to libamdocl64.so and fixing some permissions - strace is a wonderful tool) using two stock MSI Vega 56's, it's working. Mostly.

I 0 sol/s appear (usually) when writing to a non available memory address. There can be two reasons for this: a) either invalid program code / the program really tries to write to a non existing addr or b) some bits flipped so some calculation went inaccurate. The latter often happens with too much OC.
Plz try to run again and see if there is a systematics here / always after some time or always on same GPU. That may indicate slightly too high clocks. E.g. we had a 580 in testing with +10% mem running stable for hours, but at +15% ending up in 0 sol/s after less then 5 minutes and that reproducable.

Very bad miner. Even in MNX on the old miner the speed was better. Not to mention the 144.5 EWBF's percentage of 30 more gives on BTG In general, this is a failure. Checked on the cards 1070.

Old miner speed was better on 1070? Can someone confirm? On my 1080 I went from 16.4k to over 20.5k from 0.34 to 0.4. Wonder (on same code) if 1070 or 1080 scale differently here (I do not have such cards, but if that confirms I can provide the lagacy kernels for the new miner, so newer features can be used with older kernel code).

By the way: right now building up an complete new Windows build chain, switching from MingW64 cross build to Microsoft Visual Studio compilers and runtime libs. I hope this reduces the problems we face in Windows Smiley

Check out lolMiner Equihash miner for BEAM, BTG, AION, ZERO, MNX and many more for AMD & Nvidia
Stable branch: version 0.6
Alpha branch: version 0.7 alpha 5: Mining Beam on AMD
Lolliedieb
Member
**
Offline Offline

Activity: 289
Merit: 34


View Profile WWW
July 28, 2018, 09:59:54 PM
 #66

running ubuntu 18.04.1 with 13 RX570 (8GB) cards.

There is something seriously wrong with the Equihash 96.5 (Minexcoin) algo on v0.4
If I use the WORKBATCH:  HIGH setting, the hashrate slows down to a crawl, also of note is that the power draw of each GPU is around 40 watts (it's normally 85 watts when mining). Something just isn't working right with the HIGH setting.
If I use WORKBATCH:  MEDIUM, the reported hashrate (on http://eu.minexpool.nl) is around 10-15% higher then with v.034
However, it goes through these long periods where very little crypto is actually paid out from the pool. I don't understand how the listed balance for this rig is consistently really low, but yet the hashrate is high.

Switched back to v.034 for now.
v.034 doesn't have issues with '--set-work-batch HIGH ' , and it gets paid more from the pool than with v.04

Ok, so here HIGH slowes down the speed but also the power draw. Seems the GPUs are in fact running slower then. Can you tell me when starting up the 0.4 should report "Work Batch: <some number>" what these numbers are for MEDIUM and HIGH? It could be that the card has some sweet spot (e.g. preferes numbers divisible by 2,3,4 whatever) - that would be good to know Smiley

As for the pool you will always see a larger delay:
First you will see the "Shares" counter increase. That should happen lineary with your sol/s, so when pool says you got 10% higher sol/s it should climb up 10% quicker. Then after a while shares will be reset to 0. At that point a block was mined where the pool decided you now should be payed from that block. So the shares you collected before are then transfered to "Immature" and once the corresponding block has 100 confirmations it will be added up to your balance. The balance will then be payed out when reaching your current payment limit, I guess default at that pool is still 0.1 mnx.

That said: Between hashing and the actuall payment usually is more then half a day. Also luck of the pool and overall network hash plays a role, so to get a realistic estimate what advantage you have from one or other software version you must run both on identical hardware and same pool and start comparing incomming payouts more then a day after the experiment started. Usually when even pool detects that the hash is higher it should reward it higher. But also currently the network hashrate is over 30% higher then last week so that reduces payout / sol  :/

Check out lolMiner Equihash miner for BEAM, BTG, AION, ZERO, MNX and many more for AMD & Nvidia
Stable branch: version 0.6
Alpha branch: version 0.7 alpha 5: Mining Beam on AMD
akira128
Newbie
*
Offline Offline

Activity: 59
Merit: 0


View Profile
July 29, 2018, 01:50:31 AM
Last edit: July 29, 2018, 04:14:32 PM by akira128
 #67

>  Between hashing and the actuall payment usually is more then half a day.

The pool I'm using pays out in 0.1 MNX increments. I can clearly see the percentage that each rig has contributed toward the next 0.1 MNX payout.  I've been monitoring this daily for the last 7 months, so I'm familiar with how this works. All I'm saying is, there's something off with lolminer version 0.4 as it relates to my setup.
smitushka
Newbie
*
Offline Offline

Activity: 5
Merit: 0


View Profile
July 29, 2018, 06:00:03 AM
 #68

Dear Lolliedieb, Sir
Is there any chance for R9 380 2GB RAM to get involved?
Thank you
nighthawk96
Newbie
*
Offline Offline

Activity: 2
Merit: 0


View Profile
July 29, 2018, 06:46:49 AM
 #69

Hey guys, switched all of my rigs over from windows to SMOS a few months ago, have been using lolminer since version 0.2 i believe. This version has really stumped me. I tested on one rig with 4 1080ti's and 4 1070's and had about a 2-3% increase in hashrate. Following this i switched all 8 of my miners over. 4 are now currently off after receiving an overclocking error-

[4074005.214470] NVRM: Xid (PCI:0000:05:00): 13, Graphics SM Warp Exception on (GPC 2, TPC 4): Out Of Range Address
[4074005.228665] NVRM: Xid (PCI:0000:05:00): 13, Graphics SM Global Exception on (GPC 2, TPC 4): Physical Multiple Warp Errors
[4074005.244845] NVRM: Xid (PCI:0000:05:00): 13, Graphics Exception: ESR 0x516648=0x2000e 0x516650=0x24 0x516644=0xd3eff2 0x51664c=0x17f
[4074005.303301] NVRM: Xid (PCI:0000:05:00): 43, Ch 00000010, engmask 00000101
[4074005.316766] NVRM: Xid (PCI:0000:06:00): 43, Ch 00000010, engmask 00000101
Rig is rebooting due to system error. It could be caused by too much overclock/undervolt.
Average speed (5s): 85932.8 sol/s | 85165.3 sol/s | 85674.1 sol/s | 0.0 sol/s | 0.0 sol/s | 84946.2 sol/s | 85864.5 sol/s | 85239.7 sol/s Total: 512822.7 sol/s
Submitting share
Share accepted

I hadn't changed any settings between the switch of v0.34 and v0.4 and it ran for about an hour before receiving this error on all 4 machines, so i played around with on that is here, (the others are at remote locations). On a rig of 13 1060's the errors began to build up in between reboots and eventually lost fan control on half the rig before reinstalling the latest version of smos to a usb and starting again. Following the new usb it's running stable for about 30 minutes now but the hashrate is pretty much the same as v0.34 (11k sol/s)/(1060 6gb). I have a standard config perhaps i need to dig into the file and set some more parameters.. Any advice please let me know.

   -coin=MNX -pool=eu.minexpool.nl -port=9999 -user=XCgqjh3kCdbW8jD8wjmsHSuUx7Qd6o4xpV.Bigfella -p x

Standard config i've been using ^^^^
xiggga
Newbie
*
Offline Offline

Activity: 6
Merit: 0


View Profile
July 29, 2018, 09:24:28 AM
 #70

running ubuntu 18.04.1 with 13 RX570 (8GB) cards.

There is something seriously wrong with the Equihash 96.5 (Minexcoin) algo on v0.4
If I use the WORKBATCH:  HIGH setting, the hashrate slows down to a crawl, also of note is that the power draw of each GPU is around 40 watts (it's normally 95 watts when mining). Something just isn't working right with the HIGH setting.
If I use WORKBATCH:  MEDIUM, the reported hashrate (on http://eu.minexpool.nl) is around 10-15% higher then with v.034
However, it goes through these long periods where very little crypto is actually paid out from the pool. I don't understand how the listed balance for this rig is consistently really low, but yet the hashrate is high.

Switched back to v.034 for now.
v.034 doesn't have issues with '--set-work-batch HIGH ' , and it gets paid more from the pool than with v.04


the same thing Sad
CanErik
Hero Member
*****
Offline Offline

Activity: 756
Merit: 539



View Profile
July 29, 2018, 11:09:35 AM
 #71

Hi.

Is there any way to use IoIMiner without *.json file?

Kind regars
prichina
Newbie
*
Offline Offline

Activity: 79
Merit: 0


View Profile
July 30, 2018, 01:45:07 AM
 #72

How to set separate GPU for memory usage and how to set device id 0, 1 or 2.....i dont get it, there is not much instructions
Lolliedieb
Member
**
Offline Offline

Activity: 289
Merit: 34


View Profile WWW
July 30, 2018, 07:28:19 AM
 #73

Hi there,

I just updated the miner to version 0.41

Here are the download links:

[Lin 64] Click me (0.41 for Linux)
[Win 64]  Click me (0.41 for Windows)


And here are the changes (hope I get all):

Windows Version:
- Switched from a mingW64 to a visual studio based build. This should remove the majority of the Windows bugs / random crashed Cheesy

Coins:
- Added support for HeptaCoin (HEPTA)

Api:
- Added some new fields (total sol/s and pool information where the RIG is connected)
- Fixed the Windows API stability bug

Features:
- The miner now supports automatic user names. The parameter "RIGNAME" (in config file) or -rigname= (in command line) set a name for the Rig. When now for any pool connection data at the "USER" field no "." is found the RIGNAME will be appended to the user name automatically. Instead when a "." is found, RIGNAME will be ignored.

- Extended the "DEVICES" parameter and also enables control of devices in command line. Now the miner is fully functional to be controled over cmd. Especially the user now can select "DEVICES":"AMD" or "DEVICES" : "NVIDIA" to restrict to GPUs for one vendor (see manual for more details).

- Added the options "TIMEPRINT" and "SHORTACCEPT" to modify the console output. (See manual in section "Modify the Statistics Output")

- Added the options "CONNECTION_ATTEMPTS" and "RECONNECTION_TIMER" to modify the behavior of the failover support (See manual in section "Adjusting the Failover Pool Function")

- lolMiner can now change the kernel file search directory ("KERNELSDIR") and for the user_config.json (-usercfg= in command line). The paths can be absolute or relative to the current work directory. This allows to install the executable in some system search path and the other required stuff in a complete different location.


Known issues:
- Windows defender sometimes recognizes lolMiner.exe as virus. This is a false positive and Windows defender is the only search engine that I am aware of that does so (only one out of 67 virus search engines tested)

- Windows version may crash when hitting
  • - better stop the miner by task manager or ctrl + c.

- The current mining code for Nvidia & MNX seems only to work well (fast) on GTX1080 cards. Unfortunately the older one does not work directly in miner framework. I will now be on vacation for a week but will try to fix this ASAP.

- The API can not be displayed in Chrome. No idea why, but Firefox and Internet Explorer did well, on Windows, Linux and Android mobile.

Check out lolMiner Equihash miner for BEAM, BTG, AION, ZERO, MNX and many more for AMD & Nvidia
Stable branch: version 0.6
Alpha branch: version 0.7 alpha 5: Mining Beam on AMD
4ward
Member
**
Offline Offline

Activity: 424
Merit: 17


View Profile
July 30, 2018, 08:22:20 AM
 #74

- The API can not be displayed in Chrome. No idea why, but Firefox and Internet Explorer did well, on Windows, Linux and Android mobile.

Biggest issue (for me) is that it doesnt work from powershell.
both Invoke-WebRequest and Invoke-RESTMethod fail with "underlying connection was closed"

you can test using "Invoke-WebRequest http://localhost:8080"

Lolliedieb
Member
**
Offline Offline

Activity: 289
Merit: 34


View Profile WWW
July 30, 2018, 09:48:25 AM
 #75

- The API can not be displayed in Chrome. No idea why, but Firefox and Internet Explorer did well, on Windows, Linux and Android mobile.

Biggest issue (for me) is that it doesnt work from powershell.
both Invoke-WebRequest and Invoke-RESTMethod fail with "underlying connection was closed"

you can test using "Invoke-WebRequest http://localhost:8080"


Maybe because its not ouputing html but json code... I hope to add a html surface for it later, but first I have to tackle the speed issues Wink

Check out lolMiner Equihash miner for BEAM, BTG, AION, ZERO, MNX and many more for AMD & Nvidia
Stable branch: version 0.6
Alpha branch: version 0.7 alpha 5: Mining Beam on AMD
prichina
Newbie
*
Offline Offline

Activity: 79
Merit: 0


View Profile
July 30, 2018, 01:34:02 PM
 #76

It is not done yet, now the miner crashes , the moment the workbatch is loaded.
I've set it only with AMD gpus to work, i have mixed system...let me try with every cards. Maybe will not crash that way...

edit: Nope, it is the same, the miner crashes on start when the workbatch is loaded. Windows 10 x64, blockchain drivers and newest nvidia drivers.
4ward
Member
**
Offline Offline

Activity: 424
Merit: 17


View Profile
July 30, 2018, 04:06:55 PM
 #77

- The API can not be displayed in Chrome. No idea why, but Firefox and Internet Explorer did well, on Windows, Linux and Android mobile.

Biggest issue (for me) is that it doesnt work from powershell.
both Invoke-WebRequest and Invoke-RESTMethod fail with "underlying connection was closed"

you can test using "Invoke-WebRequest http://localhost:8080"


Maybe because its not ouputing html but json code... I hope to add a html surface for it later, but first I have to tackle the speed issues Wink

it can handle json well, but the problem is http server implementation
it fails with "System.Net.WebException: The underlying connection was closed: An unexpected error occurred
                        on a receive. ---> System.IO.IOException: Unable to read data from the transport connection:
                        An existing connection was forcibly closed by the remote host. --->
                        System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote
                        host"

Which also explains why Chrome doesn't work. Firefox also fails to display (although you can see the response in Dev Tools).

Simple "telnet localhost 8080" does return the info, which means its definitely not an http server )

miqaayil
Newbie
*
Offline Offline

Activity: 9
Merit: 0


View Profile
July 30, 2018, 05:03:28 PM
 #78

Hi there,

I just updated the miner to version 0.41

Here are the download links:

[Lin 64] Click me (0.41 for Linux)
[Win 64]  Click me (0.41 for Windows)


And here are the changes (hope I get all):

Windows Version:
- Switched from a mingW64 to a visual studio based build. This should remove the majority of the Windows bugs / random crashed Cheesy

Coins:
- Added support for HeptaCoin (HEPTA)

Api:
- Added some new fields (total sol/s and pool information where the RIG is connected)
- Fixed the Windows API stability bug

Features:
- The miner now supports automatic user names. The parameter "RIGNAME" (in config file) or -rigname= (in command line) set a name for the Rig. When now for any pool connection data at the "USER" field no "." is found the RIGNAME will be appended to the user name automatically. Instead when a "." is found, RIGNAME will be ignored.

- Extended the "DEVICES" parameter and also enables control of devices in command line. Now the miner is fully functional to be controled over cmd. Especially the user now can select "DEVICES":"AMD" or "DEVICES" : "NVIDIA" to restrict to GPUs for one vendor (see manual for more details).

- Added the options "TIMEPRINT" and "SHORTACCEPT" to modify the console output. (See manual in section "Modify the Statistics Output")

- Added the options "CONNECTION_ATTEMPTS" and "RECONNECTION_TIMER" to modify the behavior of the failover support (See manual in section "Adjusting the Failover Pool Function")

- lolMiner can now change the kernel file search directory ("KERNELSDIR") and for the user_config.json (-usercfg= in command line). The paths can be absolute or relative to the current work directory. This allows to install the executable in some system search path and the other required stuff in a complete different location.


Known issues:
- Windows defender sometimes recognizes lolMiner.exe as virus. This is a false positive and Windows defender is the only search engine that I am aware of that does so (only one out of 67 virus search engines tested)

- Windows version may crash when hitting
  • - better stop the miner by task manager or ctrl + c.

- The current mining code for Nvidia & MNX seems only to work well (fast) on GTX1080 cards. Unfortunately the older one does not work directly in miner framework. I will now be on vacation for a week but will try to fix this ASAP.

- The API can not be displayed in Chrome. No idea why, but Firefox and Internet Explorer did well, on Windows, Linux and Android mobile.

does this improve Sols for AMD Cards
andrei518
Newbie
*
Offline Offline

Activity: 5
Merit: 0


View Profile
July 30, 2018, 05:50:04 PM
 #79

at 2g amd does not work?
joeykolb
Newbie
*
Offline Offline

Activity: 48
Merit: 0


View Profile
July 30, 2018, 06:06:05 PM
 #80

how to change mining "short". between exemples 1,2,3 if u put at each examples ay coin to mine
Pages: « 1 2 3 [4] 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 »
  Print  
 
Jump to:  

Bitcointalk.org is not available or authorized for sale. Do not believe any fake listings.
Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!