Bitcoin Forum
November 21, 2017, 09:21:05 PM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 [25] 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 ... 287 »
  Print  
Author Topic: [OS] nvOC easy-to-use Linux Nvidia Mining v0019-1.4  (Read 327271 times)
LTCbusiness
Jr. Member
*
Offline Offline

Activity: 51


View Profile
June 10, 2017, 02:55:00 PM
 #481

Hey folks,

So I am new to mining.  Only cards I could get a couple of weeks ago was GTX1070 (as most of you know, AMD is nowhere to be found).

I have had a my first rig set up for about 10 days.  Windows 10, MSI Z270-A Plus mobo, 5x MSI GTX 1070 Gaming X 8G.  I mine ETH only, using Claymore.  I am averaging about 30.6 M/H per card with decent stability.  Rig power draw 830 watts for 5 cards.  Temp 59-61 degrees. Fan speed 60%

Currently using nvidia 382.05 driver.

So I am awaiting my last component today for a second rig same mobo, same cards (but a 6 card rig).

If I try Fullzero's nvOC what can I expect?  I have zero experience with Linux, but I am comfortable with command line interfaces.

A few questions:
Do you always boot from USB?  Or can you install on an ssd?  My rig that has windows 10, if I change the boot order in BIOS to USB and boot with nvOC is this a "dual partition"?
Will I be able to get better stability and increase M/H?

Thanks

nvOC is the best solution for nvidia card if you have no idea about Linux, it is like plug and play usb, you just need to change the modify onebash file, which is pretty easy task for anyone who can set up a mining rig. My 6 1080Ti card run smoothly for 5 days.


1511299265
Hero Member
*
Offline Offline

Posts: 1511299265

View Profile Personal Message (Offline)

Ignore
1511299265
Reply with quote  #2

1511299265
Report to moderator
1511299265
Hero Member
*
Offline Offline

Posts: 1511299265

View Profile Personal Message (Offline)

Ignore
1511299265
Reply with quote  #2

1511299265
Report to moderator
1511299265
Hero Member
*
Offline Offline

Posts: 1511299265

View Profile Personal Message (Offline)

Ignore
1511299265
Reply with quote  #2

1511299265
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1511299265
Hero Member
*
Offline Offline

Posts: 1511299265

View Profile Personal Message (Offline)

Ignore
1511299265
Reply with quote  #2

1511299265
Report to moderator
1511299265
Hero Member
*
Offline Offline

Posts: 1511299265

View Profile Personal Message (Offline)

Ignore
1511299265
Reply with quote  #2

1511299265
Report to moderator
min3333r
Newbie
*
Offline Offline

Activity: 11


View Profile
June 10, 2017, 04:33:18 PM
 #482

Hello,

nvOC works great out of the box, awesome project!

@zerofull would you be so kind and send me Z97x extreme4 mobo image, i'm trying to run 6x 1060 3G GPU per rig.

5x 1060 can boot, but when I add the last one getting debug error code 55 (Memory not installed).

The z97x doesn't have TOLUD or 4G, have disabled SDS, sound, serial port and putting PCIE2 and 5 to use Gen2. Nothing helped to boot the 6th GPU.

Thank you
sammybtc
Jr. Member
*
Offline Offline

Activity: 47


View Profile
June 10, 2017, 04:55:28 PM
 #483

It look very promissing however I keep booting on initramfs and Nothing else happend.
Does anybody had that issue before ?

thanks
citronick
Hero Member
*****
Offline Offline

Activity: 812


winter*juvia


View Profile
June 10, 2017, 05:06:05 PM
 #484

switched from Teamviewer to ssh...

removed the # from file as per onebash instructions

upon ssh to rig IP

user: root
password: miner1

Error message: Access denied

Anybody can help?


Citronick's Beer & Chicken Wings Fund : 32oo5tk1RfTbndrUjWvHJ9yT3bb2EyQYkq
fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
June 10, 2017, 05:11:59 PM
 #485

switched from Teamviewer to ssh...

removed the # from file as per onebash instructions

upon ssh to rig IP

user: root
password: miner1

Error message: Access denied

Anybody can help?



try as the user:

m1

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
June 10, 2017, 05:13:06 PM
 #486

Can I run some sort of update from withing the nvOS, or do I have to download a new version manually and make a new stick with it? Just thinking how would I go around managing updates for couple of rigs running nvOS...

I am working on the solution.  Wink

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
June 10, 2017, 05:21:43 PM
 #487

Hey folks,

So I am new to mining.  Only cards I could get a couple of weeks ago was GTX1070 (as most of you know, AMD is nowhere to be found).

I have had a my first rig set up for about 10 days.  Windows 10, MSI Z270-A Plus mobo, 5x MSI GTX 1070 Gaming X 8G.  I mine ETH only, using Claymore.  I am averaging about 30.6 M/H per card with decent stability.  Rig power draw 830 watts for 5 cards.  Temp 59-61 degrees. Fan speed 60%

Currently using nvidia 382.05 driver.

So I am awaiting my last component today for a second rig same mobo, same cards (but a 6 card rig).

If I try Fullzero's nvOC what can I expect?  I have zero experience with Linux, but I am comfortable with command line interfaces.

A few questions:
Do you always boot from USB?  Or can you install on an ssd?  My rig that has windows 10, if I change the boot order in BIOS to USB and boot with nvOC is this a "dual partition"?
Will I be able to get better stability and increase M/H?

Thanks

nvOC is the best solution for nvidia card if you have no idea about Linux, it is like plug and play usb, you just need to change the modify onebash file, which is pretty easy task for anyone who can set up a mining rig. My 6 1080Ti card run smoothly for 5 days.

Quote
A few questions:
Do you always boot from USB?  Or can you install on an ssd?

See:  https://bitcointalk.org/index.php?topic=1854250.msg19328385#msg19328385  and  https://bitcointalk.org/index.php?topic=1854250.msg19300078#msg19300078

Quote
My rig that has windows 10, if I change the boot order in BIOS to USB and boot with nvOC is this a "dual partition"?

I your planning on dual installing; I would recommend installing nvOC to a usb instead.  Then depending on your motherboard hold down the boot menu F key at boot: usually f10, f11, or f12 with the nvOC usb attached and select it from the bios boot selection menu.

Quote
Will I be able to get better stability and increase M/H?

Better stability for sure. 

For ETH I am not sure if you can push the cards harder while keeping them stable.  I will do a 1070 ETH test tonight and let you know how it goes.

creeksideguitar
Newbie
*
Offline Offline

Activity: 1


View Profile
June 10, 2017, 05:23:16 PM
 #488

I've been editing the bash file within Linux so I don't have to keep switching to Windows. I do notice that sometimes the changes to the settings don't take on the first logout. I sometimes have to logout twice to see the changes. Still tweaking the settings to optimize the rig.

I'm currently getting around 1100 sols (380 W at wall) on nanopool from a 2 card rig - 1 1080 ti & 1 1070 ITX. Adding a second 1080 ti tomorrow. Hopefully I can get it up to 1800 +. Would be great if I could hit 2000 Sols with this setup but I'm not sure that is possible. Trying to keep the GPU's under 70 degrees. Thanks for all this work Zero.
fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
June 10, 2017, 05:23:38 PM
 #489

It look very promissing however I keep booting on initramfs and Nothing else happend.
Does anybody had that issue before ?

thanks

Do you have an amd card on your rig / pc?

What mobo / CPU / ram / GPUs are you using?

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
June 10, 2017, 05:27:15 PM
 #490

Hello,

nvOC works great out of the box, awesome project!

@zerofull would you be so kind and send me Z97x extreme4 mobo image, i'm trying to run 6x 1060 3G GPU per rig.

5x 1060 can boot, but when I add the last one getting debug error code 55 (Memory not installed).

The z97x doesn't have TOLUD or 4G, have disabled SDS, sound, serial port and putting PCIE2 and 5 to use Gen2. Nothing helped to boot the 6th GPU.

Thank you

I don't have that specific motherboard; but I have other z97 mobos with similar 6 GPU difficulties.  I will get one out and see if I can find the problem tonight.

To help me find the problem:

press f12 to open the guake terminal

If cpuminer-opt is running rightclick over the guake terminal and select new tab or press ctrl + c to stop it.

then enter:

lspci | grep VGA

please tell me what this outputs


fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
June 10, 2017, 05:40:18 PM
 #491

I've been editing the bash file within Linux so I don't have to keep switching to Windows. I do notice that sometimes the changes to the settings don't take on the first logout. I sometimes have to logout twice to see the changes. Still tweaking the settings to optimize the rig.

I'm currently getting around 1100 sols (380 W at wall) on nanopool from a 2 card rig - 1 1080 ti & 1 1070 ITX. Adding a second 1080 ti tomorrow. Hopefully I can get it up to 1800 +. Would be great if I could hit 2000 Sols with this setup but I'm not sure that is possible. Trying to keep the GPU's under 70 degrees. Thanks for all this work Zero.

Expect is not meant to be used within bash.  This is generally the cause of some oneBash settings not implementing ( especially powerlimit).  This problem is highly dependent on the speed of the USB key you are using.

I am going to make another version using Maxximus007 suggestion to resolve this problem for slow USBs: see https://bitcointalk.org/index.php?topic=1854250.msg19468895#msg19468895

Right now you can always use manual cmd's with the guake terminal to ensure the execution, if your rig is not properly implementing them.

citronick
Hero Member
*****
Offline Offline

Activity: 812


winter*juvia


View Profile
June 10, 2017, 05:42:29 PM
 #492

switched from Teamviewer to ssh...

removed the # from file as per onebash instructions

upon ssh to rig IP

user: root
password: miner1

Error message: Access denied

Anybody can help?



try as the user:

m1

that works thanks!

Citronick's Beer & Chicken Wings Fund : 32oo5tk1RfTbndrUjWvHJ9yT3bb2EyQYkq
min3333r
Newbie
*
Offline Offline

Activity: 11


View Profile
June 10, 2017, 05:47:42 PM
 #493

I don't have that specific motherboard; but I have other z97 mobos with similar 6 GPU difficulties.  I will get one out and see if I can find the problem tonight.

To help me find the problem:

press f12 to open the guake terminal

If cpuminer-opt is running rightclick over the guake terminal and select new tab or press ctrl + c to stop it.

then enter:

lspci | grep VGA

please tell me what this outputs



00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1c02 (rev a1)
03:00.0 VGA compatible controller: NVIDIA Corporation Device 1c02 (rev a1)
06:00.0 VGA compatible controller: NVIDIA Corporation Device 1c02 (rev a1)
07:00.0 VGA compatible controller: NVIDIA Corporation Device 1c02 (rev a1)
09:00.0 VGA compatible controller: NVIDIA Corporation Device 1c02 (rev a1)

lspci doesn't see the GPU because the riser wasn't plugged in on boot. If it was plugged on power up and boot, would get error 55 and the system wouldn't even boot neither would get any video or interaction, hard reset is the only option there. The problem is not in the riser or GPU or slot because this is happening on all 5 rigs (z97x and 1060), replacing risers, GPU or power cables doesn't help.

I'll try now to leave it past the bios and then plug in the sixth riser on GRUB choose.
fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
June 10, 2017, 05:52:13 PM
 #494

switched from Teamviewer to ssh...

removed the # from file as per onebash instructions

upon ssh to rig IP

user: root
password: miner1

Error message: Access denied

Anybody can help?



try as the user:

m1

that works thanks!

Np mobaxterm ftw.


I don't have that specific motherboard; but I have other z97 mobos with similar 6 GPU difficulties.  I will get one out and see if I can find the problem tonight.

To help me find the problem:

press f12 to open the guake terminal

If cpuminer-opt is running rightclick over the guake terminal and select new tab or press ctrl + c to stop it.

then enter:

lspci | grep VGA

please tell me what this outputs



00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1c02 (rev a1)
03:00.0 VGA compatible controller: NVIDIA Corporation Device 1c02 (rev a1)
06:00.0 VGA compatible controller: NVIDIA Corporation Device 1c02 (rev a1)
07:00.0 VGA compatible controller: NVIDIA Corporation Device 1c02 (rev a1)
09:00.0 VGA compatible controller: NVIDIA Corporation Device 1c02 (rev a1)

lspci doesn't see the GPU because the riser wasn't plugged in on boot. If it was plugged on power up and boot, would get error 55 and the system wouldn't even boot neither would get any video or interaction, hard reset is the only option there. The problem is not in the riser or GPU or slot because this is happening on all 5 rigs (z97x and 1060), replacing risers, GPU or power cables doesn't help.

I'll try now to leave it past the bios and then plug in the sixth riser on GRUB choose.

What happens if you disable the onboard graphics?

UberDaemon
Jr. Member
*
Offline Offline

Activity: 42


View Profile
June 10, 2017, 05:54:50 PM
 #495

Is anyone else out there mining with Founders Edition 1070s?  What OC/power settings are you using?

I've been running ~3 hours stable with:

__CORE_OVERCLOCK=200
MEMORY_OVERCLOCK=900

-pl 105

How much further can/should I push this with only 105W power?  I'm stuck with 2 cards per PCI-E cable until next week when I get a shipment of new cables.


You can try upping the mc further; it depends on the specific card when it will start having problems.  When mining anything ethash I usually bump the memory up slowly until I have a crash then backoff to the previous setting.  If a crash happens again, I backoff again.

I bumped up the mc last night before going to bed.  It's been running stably since then. 

__CORE_OVERCLOCK=200
MEMORY_OVERCLOCK=1100

-pl 105

2 rigs • 14 1070 GPUs • 428mh/s ETH [►nvOC◄ Linux]
fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
June 10, 2017, 06:04:32 PM
 #496

Is anyone else out there mining with Founders Edition 1070s?  What OC/power settings are you using?

I've been running ~3 hours stable with:

__CORE_OVERCLOCK=200
MEMORY_OVERCLOCK=900

-pl 105

How much further can/should I push this with only 105W power?  I'm stuck with 2 cards per PCI-E cable until next week when I get a shipment of new cables.


You can try upping the mc further; it depends on the specific card when it will start having problems.  When mining anything ethash I usually bump the memory up slowly until I have a crash then backoff to the previous setting.  If a crash happens again, I backoff again.

I bumped up the mc last night before going to bed.  It's been running stably since then. 

__CORE_OVERCLOCK=200
MEMORY_OVERCLOCK=1100

-pl 105

Thanks again for hashes, very generous.   Smiley

If it is still stable; I would try:

__CORE_OVERCLOCK=200
MEMORY_OVERCLOCK=1200

and see how it goes.

mraug
Newbie
*
Offline Offline

Activity: 23


View Profile
June 10, 2017, 06:07:07 PM
 #497

Can I run some sort of update from withing the nvOS, or do I have to download a new version manually and make a new stick with it? Just thinking how would I go around managing updates for couple of rigs running nvOS...

I am working on the solution.  Wink

perfect
natminer
Jr. Member
*
Offline Offline

Activity: 30


View Profile
June 10, 2017, 06:09:37 PM
 #498

Does nvOC have any way to do automatic coin/algo/profit switching?

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
June 10, 2017, 06:16:53 PM
 #499

Does nvOC have any way to do automatic coin/algo/profit switching?

Not right now. 

I will add this to the list. 

Also when the nicehash linux Excavator client is done it should have this capability as well (I will add the Excavator client when it is released).

Although if I make a profit switching algorithm; it would most likely have different target parameters and coin switching conditions than those you are used to.


ext
Newbie
*
Offline Offline

Activity: 1


View Profile
June 10, 2017, 10:12:36 PM
 #500


https://timur.pw/storage/0.jpg

nvOS v0015
matherbord: "ASUS H87M-e" AND "asus h61m-k"
video: asus 1050 ti  4gb OC
https://timur.pw/storage/1.jpg

what can be done?
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 [25] 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 ... 287 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!