Bitcoin Forum
November 18, 2017, 09:09:18 AM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 ... 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 [68] 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 ... 284 »
  Print  
Author Topic: [OS] nvOC easy-to-use Linux Nvidia Mining v0019-1.4  (Read 322247 times)
fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
June 30, 2017, 07:43:00 AM
 #1341

All gfx cards are out of stock  Embarrassed

have heard AMD and Nvidia coming up with specialized minings cards

When can we expect it to hit stores?

No idea; I haven't been following this very closely.

1510996158
Hero Member
*
Offline Offline

Posts: 1510996158

View Profile Personal Message (Offline)

Ignore
1510996158
Reply with quote  #2

1510996158
Report to moderator
1510996158
Hero Member
*
Offline Offline

Posts: 1510996158

View Profile Personal Message (Offline)

Ignore
1510996158
Reply with quote  #2

1510996158
Report to moderator
Coinlancer is Disrupting the Freelance marketplace!
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
Coin++
Full Member
***
Online Online

Activity: 210



View Profile
June 30, 2017, 07:44:06 AM
 #1342

Perhaps can you put the version number of mOC in the thread title : like that it'll be more easier to see when it change for the reader.

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
June 30, 2017, 07:45:13 AM
 #1343

Nvidia cards for CUDA mode autoselect mode 2 
How i can change settings for mode 2 not 3 ?   or better use mode 3?
i get error  R/O attribute

My script

#!/bin/bash
#Включаем оверклокинг on GPU0 
#Enable PowerMizer (Auto) 2 - CUDA mode , most used for mining
nvidia-settings -a '[gpu:0]/GPUPowerMizerMode=3'
#Set GPU Clock offset -50Mhz -
nvidia-settings -a '[gpu:0]/GPUGraphicsClockOffset[3]=-50'
#Set GPU Memory offset +100Mhz -
nvidia-settings -a '[gpu:0]/GPUMemoryTransferRateOffset[3]=140'
#nvidia-settings -a [gpu:0]/GPUFanControlState=1
#nvidia-settings -a [fan:0]/GPUTargetFanSpeed=75

user@PC1 ~ $ ./nvidia-memclock-GPU0.sh

  Attribute 'GPUPowerMizerMode' (PC1:0[gpu:0]) assigned value 2.



ERROR: The attribute 'GPUGraphicsClockOffset' specified in assignment
       '[gpu:0]/GPUGraphicsClockOffset[2]=-50' cannot be assigned (it is a
       read-only attribute).



  Attribute 'GPUMemoryTransferRateOffset' (PC1:0[gpu:0]) assigned value 40.


It looks like you need to edit your xorg.conf before this will work.  You need to use 28 or 31 coolbits.

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
June 30, 2017, 07:49:03 AM
 #1344

My performance is lower than it is on ethOS or in Windows. I have two 1070s and 4 1060 6GB. On those with no overclock I get around 120MH/s in other OSes. Here with a +300 memory OC I am only getting 105MH/s dual mining eth and sia. I lowered the dcri value to the same number. I didn't set a power limit, maybe that will do it.  

If you scroll to the top of the mining process do you see OC messages for core and memory for each card?

If so:

try +200 core clock and +900 memory clock

if that hard or soft crashes, try:

try +100 core clock and +600 memory clock

also what model 1070s and 1060s?

EVGA superclocked 1070s and gigabyte gaming g1 1060s. Let me try the new settings

edit: looks like it crashed on the original settings with cannot get current temperatures

I may try individual clocks and see if one of the cards is the problem.

I need help with my 6x 1070 rig.. I keep getting the following error and then the miner crashes and restarts..
I didnt overclock it is on default settings..

NVML: cannot get current temperature, error 999 (an internal driver error occurred)
GPU 0, GpuMiner cu_k02 failed 30, unknown error
GPU 0, GpuMiner kx failed 1
GPU 3, GpuMiner kx failed 1
GPU 5, GpuMiner kx failed 1
GPU 4, GpuMiner cu_k02 failed 30, unknown error
GPU 4, GpuMiner kx failed 1
GPU 1, GpuMiner cu_k02 failed 30, unknown error
GPU 1, GpuMiner kx failed 1
NVML: cannot get current temperature, error 999 (an internal driver error occurred)


Any help would be appreciated.. Thanks

Hi,  I know this is an old post but I was wondering if anyone else has encountered this issue and has found a solution.  I have 6 x 1080tis running at stock (msi afterburner not running) and do not get this error anymore but would love to overclock.  As soon as I turn on afterburner, even if I don't overclock,  I get the above error message.  Sometime within 10 minutes, sometimes after days of running fine.  I've also tried overclocking on NVOC and after awhile I get the same error.  Any help would be greatly greatly appreciated and will send some ether for your assistance.  Thanks!!!

My guess is your GPUs are getting too hot.

Increase the manual fan speed

If your mining ETH use a negative core clock with a high memory clock:

try -100 core clock and +900 memory clock

Use a powerlimit of 200 watts. (maybe lower; I haven't really tested 1080tis with Ethash enough to know the opt powerlimit)


fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
June 30, 2017, 07:54:27 AM
 #1345

Fullzero thanks for detailed instruction of my idea and including it into nvOS v0017

here are some operations for image space releasing:

sudo apt update
sudo apt upgrade

sudo du -sh /var/cache/apt/archives
sudo apt-get clean

sudo apt-get autoremove
if after such operation we have such mistake as:
===
Errors were encountered while processing:
 linux-image-extra-4.4.0-65-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)
===
we need to delete all failes manually:
ls /var/lib/dpkg/info/ | grep linux-image | grep 4.4.0-65

exactly:
====
linux-image-4.4.0-65-generic.list
linux-image-4.4.0-65-generic.postrm
linux-image-extra-4.4.0-65-generic.list
linux-image-extra-4.4.0-65-generic.md5sums
linux-image-extra-4.4.0-65-generic.postinst
linux-image-extra-4.4.0-65-generic.postrm
====

cd /var/lib/dpkg/info/
sudo rm linux-image-4.4.0-65-generic.list
sudo rm linux-image-4.4.0-65-generic.postrm
sudo rm linux-image-extra-4.4.0-65-generic.list
sudo rm linux-image-extra-4.4.0-65-generic.md5sums
sudo rm linux-image-extra-4.4.0-65-generic.postinst
sudo rm linux-image-extra-4.4.0-65-generic.postrm

repeat the command:

sudo apt-get autoremove

have to delete non usable linux-image in system

dpkg --list | grep linux-image

sudo apt-get purge linux-image-4.4.0-{31,59,62,64,65,66,72,75,78,79}
sudo apt-get purge linux-image-extra-4.4.0-31-generic
sudo apt-get purge linux-image-extra-4.4.0-31-generic
sudo apt-get purge linux-image-extra-4.4.0-59-generic
sudo apt-get purge linux-image-extra-4.4.0-62-generic
sudo apt-get purge linux-image-extra-4.4.0-64-generic
sudo apt-get purge linux-image-extra-4.4.0-66-generic
sudo apt-get purge linux-image-extra-4.4.0-72-generic
sudo apt-get purge linux-image-extra-4.4.0-75-generic
sudo apt-get purge linux-image-extra-4.4.0-78-generic
sudo apt-get purge linux-image-extra-4.4.0-79-generic

then exsecute

sudo apt-get -f install
sudo dpkg --configure -a

it allows to desсrease size image on 2++Gb


PS:I would like to add monitoring system into your project.
Now, I'm choosing from zabbix, munin and cacti. What would you advice?


good ideas are always worth adding  Smiley

There are alot of excess files to enable portability; removing the unused system files should be fine if you need / want more space.

I am making my own custom monitoring solution; but I don't have a problem with adding more choices / options.


fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
June 30, 2017, 07:56:00 AM
 #1346

@Fullzero....

I now have OC control of the 1060 and 1070. My MoBo has 4 PCIe slots. 2 of them have the blue tabs on the back to hold cards down. THATS the 2 I ended up trying and now I can OC both cards. Of course when I add the other 2 cards I doubt I will be able to OC them. One of the cards is coming Saturday so I will try it then and let you know. BTW all my other cards are on eternal back order it seems lol.

Can you send me in either post or PM the original xorg.conf please. The changes I made have shrunk my TeamViewer so small I can barely see it.

Thanks again for your help

press f12 and enter:

Code:
sudo cp '/etc/X11/xorg.conf.backup' '/etc/X11/xorg.conf'

this should restore the original xorg.conf

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
June 30, 2017, 07:58:51 AM
 #1347

Fullzero thanks for detailed instruction of my idea and including it into nvOS v0017

here are some operations for image space releasing:

sudo apt update
sudo apt upgrade

sudo du -sh /var/cache/apt/archives
sudo apt-get clean

sudo apt-get autoremove
if after such operation we have such mistake as:
===
Errors were encountered while processing:
 linux-image-extra-4.4.0-65-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)
===
we need to delete all failes manually:
ls /var/lib/dpkg/info/ | grep linux-image | grep 4.4.0-65

exactly:
====
linux-image-4.4.0-65-generic.list
linux-image-4.4.0-65-generic.postrm
linux-image-extra-4.4.0-65-generic.list
linux-image-extra-4.4.0-65-generic.md5sums
linux-image-extra-4.4.0-65-generic.postinst
linux-image-extra-4.4.0-65-generic.postrm
====

cd /var/lib/dpkg/info/
sudo rm linux-image-4.4.0-65-generic.list
sudo rm linux-image-4.4.0-65-generic.postrm
sudo rm linux-image-extra-4.4.0-65-generic.list
sudo rm linux-image-extra-4.4.0-65-generic.md5sums
sudo rm linux-image-extra-4.4.0-65-generic.postinst
sudo rm linux-image-extra-4.4.0-65-generic.postrm

repeat the command:

sudo apt-get autoremove

have to delete non usable linux-image in system

dpkg --list | grep linux-image

sudo apt-get purge linux-image-4.4.0-{31,59,62,64,65,66,72,75,78,79}
sudo apt-get purge linux-image-extra-4.4.0-31-generic
sudo apt-get purge linux-image-extra-4.4.0-31-generic
sudo apt-get purge linux-image-extra-4.4.0-59-generic
sudo apt-get purge linux-image-extra-4.4.0-62-generic
sudo apt-get purge linux-image-extra-4.4.0-64-generic
sudo apt-get purge linux-image-extra-4.4.0-66-generic
sudo apt-get purge linux-image-extra-4.4.0-72-generic
sudo apt-get purge linux-image-extra-4.4.0-75-generic
sudo apt-get purge linux-image-extra-4.4.0-78-generic
sudo apt-get purge linux-image-extra-4.4.0-79-generic

then exsecute

sudo apt-get -f install
sudo dpkg --configure -a

it allows to desсrease size image on 2++Gb


PS:I would like to add monitoring system into your project.
Now, I'm choosing from zabbix, munin and cacti. What would you advice?

@_Parallax_

Code:
sudo apt-get purge $(dpkg -l linux-{image,headers}-"[0-9]*" | awk '/ii/{print $2}' | grep -ve "$(uname -r | sed -r 's/-[a-z]+//')"
will do all of that in a single line
or install byobu then you can run `sudo purge-old-kernels`

I use zabbix with grafana. Gives me telegram alerts and pretty graphs
 

sed and awk are great  Smiley

 zabbix with grafana looks very nice.  I like the graphs.

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
June 30, 2017, 08:01:08 AM
 #1348

I have zcash-cli installed on another partition (ubuntu17) my SSD Drive, and i'm running nvOC from a USB. 

While I'm in nvOC, is there a way i can run zcash-cli from that SSD? without installing it again for nvOC

mount the ssd; then you should be able to run the cli from the ssd once you install all its dependencies to nvOC.


fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
June 30, 2017, 08:12:39 AM
 #1349

Hey Im just getting started with your software and am having some troubles.

I have no problem using nanopool for ethereum but when using ethermine.org I get "READ RESPONSE FAILED: End of File" over and over forever.  Using genoil.

With nanopool my line setting for pool is eth-us-west1.nanopool.org:9999    =works perfect
With ethermine my line says us2.ethermine.org:4444  = i get that error...


I only change this line everything else remains constant. Perfect with nano, no good with ethermine. What am i missing?

Thanks



ethermine and some other pools use a . instead of a /

to fix this I added a switch:

change this line:

Code:
ETHERMINEdotORG="NO"

to:

Code:
ETHERMINEdotORG="YES"

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
June 30, 2017, 08:15:22 AM
 #1350

Perhaps can you put the version number of mOC in the thread title : like that it'll be more easier to see when it change for the reader.

that is a good idea; I'll add it now.

techo
Jr. Member
*
Offline Offline

Activity: 43


View Profile WWW
June 30, 2017, 08:19:59 AM
 #1351

Hi there. First af all thanks for this great os. I am new at mining and os systems but i am learning.

I have msi z270 sli plus, 4 asus strix 1060 and 2 zotac 1080 amp. When i try to boot system from usb it is so slow and almost take 2 or 3 minutes and some times system doesn't even boot and i can't figure out why. But when system is boot it is working like a charm. Could you please help me? What should i do?

Btw, sorry for my english.
S9k
Newbie
*
Offline Offline

Activity: 8


View Profile
June 30, 2017, 08:59:52 AM
 #1352

Hi,
I with great pleasure watch this community! All help each other.
NvOC - a magnificent platform for a mining. There isn't enough informative monitoring of a large number of rigs yet. I would like to pay your attention as it is realized at ethOS. On one page all information on all farms is available. I think it there has to be the first page.
Example: http://virosa.ethosdistro.com/
It would be desirable FAQ on the first page Wink. It is difficult to look for the necessary answers according to all pages Wink
Many thanks for your work and enthusiasm!
bmwM3
Newbie
*
Offline Offline

Activity: 10


View Profile
June 30, 2017, 12:49:38 PM
 #1353

Any way to remotely update from 0016 to 0017?
OverEasy
Sr. Member
****
Offline Offline

Activity: 246


View Profile
June 30, 2017, 12:58:37 PM
 #1354

@Fullzero....

I now have OC control of the 1060 and 1070. My MoBo has 4 PCIe slots. 2 of them have the blue tabs on the back to hold cards down. THATS the 2 I ended up trying and now I can OC both cards. Of course when I add the other 2 cards I doubt I will be able to OC them. One of the cards is coming Saturday so I will try it then and let you know. BTW all my other cards are on eternal back order it seems lol.

Can you send me in either post or PM the original xorg.conf please. The changes I made have shrunk my TeamViewer so small I can barely see it.

Thanks again for your help

press f12 and enter:

Code:
sudo cp '/etc/X11/xorg.conf.backup' '/etc/X11/xorg.conf'

this should restore the original xorg.conf


Darn, that didn't work. No problem I will just re-image the drive. Only takes about 15 mins Smiley
I'm gonna give you 24 hours of mining to your ETH address also. Thanks for making my life easier....
Sidhun
Newbie
*
Offline Offline

Activity: 3


View Profile
June 30, 2017, 01:58:26 PM
 #1355

Hey everyone - whats a good Clock setting for a MSI Z270-A Pro mobo and EVGA 1080ti cards?
- I have tried power limit of 235 with 0 clock and 0 mem = ran for 12 hours then crashed and had to reboot as the sols came down to 0 and power came down to 8w
- now i changed the power limit to NO and clock to -15.

Any suggestions?
fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
June 30, 2017, 02:13:04 PM
 #1356

Hi there. First af all thanks for this great os. I am new at mining and os systems but i am learning.

I have msi z270 sli plus, 4 asus strix 1060 and 2 zotac 1080 amp. When i try to boot system from usb it is so slow and almost take 2 or 3 minutes and some times system doesn't even boot and i can't figure out why. But when system is boot it is working like a charm. Could you please help me? What should i do?

Btw, sorry for my english.

I haven't tested this motherboard so, there may be one or more bios settings that would solve the sometimes not booting problem. 

2-3 minutes is normal; sometimes longer depending on the speed of the USB key used.  However, you shouldn't need to reboot often, if ever.

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
June 30, 2017, 02:54:29 PM
 #1357

Hi,
I with great pleasure watch this community! All help each other.
NvOC - a magnificent platform for a mining. There isn't enough informative monitoring of a large number of rigs yet. I would like to pay your attention as it is realized at ethOS. On one page all information on all farms is available. I think it there has to be the first page.
Example: http://virosa.ethosdistro.com/
It would be desirable FAQ on the first page Wink. It is difficult to look for the necessary answers according to all pages Wink
Many thanks for your work and enthusiasm!

At the bottom of the OP you can see monitoring has already been requested and I am working on it.

I will add making a FAQ section to the OP request list:

with any thread on Bitcointalk:

do a google search for the thread title + what you are looking for  Wink


fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
June 30, 2017, 03:01:58 PM
 #1358

Any way to remotely update from 0016 to 0017?

Not yet, working on updating.

 
@Fullzero....

I now have OC control of the 1060 and 1070. My MoBo has 4 PCIe slots. 2 of them have the blue tabs on the back to hold cards down. THATS the 2 I ended up trying and now I can OC both cards. Of course when I add the other 2 cards I doubt I will be able to OC them. One of the cards is coming Saturday so I will try it then and let you know. BTW all my other cards are on eternal back order it seems lol.

Can you send me in either post or PM the original xorg.conf please. The changes I made have shrunk my TeamViewer so small I can barely see it.

Thanks again for your help

press f12 and enter:

Code:
sudo cp '/etc/X11/xorg.conf.backup' '/etc/X11/xorg.conf'

this should restore the original xorg.conf


Darn, that didn't work. No problem I will just re-image the drive. Only takes about 15 mins Smiley
I'm gonna give you 24 hours of mining to your ETH address also. Thanks for making my life easier....

Thanks for hashes  Smiley


Hey everyone - whats a good Clock setting for a MSI Z270-A Pro mobo and EVGA 1080ti cards?
- I have tried power limit of 235 with 0 clock and 0 mem = ran for 12 hours then crashed and had to reboot as the sols came down to 0 and power came down to 8w
- now i changed the power limit to NO and clock to -15.

Any suggestions?

For ZEC and 1080tis I would try:
Code:
POWERLIMIT="YES"

POWERLIMIT_WATTS=225

__CORE_OVERCLOCK=100
MEMORY_OVERCLOCK=900

MANUAL_FAN="YES" 

FAN_SPEED=75  #or higher


CarlOrff
Sr. Member
****
Offline Offline

Activity: 406



View Profile
June 30, 2017, 03:04:07 PM
 #1359

Good, the version number in the topic title  Smiley

       ▄▄▀▀▀▀▀▀▀▀▀▄▄
    ▄█▀ ▄▄███████▄▄ ▀█▄
  ▄█▀ ▄█████████████▄ ▀▄▄
 ▄▀ ▄█████    ████████▄ ▀▄
▄█ ███████    ██████████ █▄
█ ▄█████▀▀   █▀    ▄████▄ █
█ ██████▄    ▀   ▄███████ █
█ ▀████         ▄███████▀ █
▀█ █████    █    ▀██████ █▀
 ▀▄ ▀██    ███    ▀███▀ ▄▀
  ▀█▄ ▀█████████████▀ ▄█▀
    ▀█▄ ▀▀███████▀▀ ▄█▀
       ▀▀▄▄▄▄▄▄▄▄▄▀▀
kickcity     ▄█▄           ▄█▄
▄███ ███ █████████ ███ ███▄
████▄ ▄█████████▄ ▄████
▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀

███████████████████████████
██                       ██
██      ███ ███ ███ ███  ██
██                       ██
██  ███ ███ ███ ███ ███  ██
██                       ██
██  ███ ███ ███ ███      ██
██                       ██
▀█████████████████████████▀
         ▀   ▀▄  ▄  ▄▀
   ▀    ▄   ▀  ▀▄ ▄▀  ▀
     ▀
█  ▀  ▀▀▄ ▄▀▀▀▀▀▀
  ▀▄  ▀    ▄▀▀▀   ▄   ▀
   ▀ ▀▀  ▀  ▀  ▄
▀▀▀▀  ▀▄  ▀   ▄▀  █ ▀  ▀
   █   ▀▄  ▀ █      ▀
 ▀   █ ▀  █  █  ▀
   ▀
        █
        ▀ 
           
           
           
WHITEPAPER
▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀
facebook   slack   VK   twitter   telegram
.
|
.
|
f00ch0w
Jr. Member
*
Offline Offline

Activity: 33


View Profile
June 30, 2017, 03:16:29 PM
 #1360

Anyone tried rigs with mixed cards? So far, 3x 1060 and 3x 1050ti are working stable while I'm having issues with 5x 1050ti and 1x 1070 (Miner constantly crashing with thread exit errors)

Solution, anyone?

Note: rig with 5x1050ti and 1x1070 worked stable for a short period of time once I bumped up the power limit (by 10) and then thread exited with errors and whole rig crashed.
Pages: « 1 ... 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 [68] 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 ... 284 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!