Bitcoin Forum
December 11, 2017, 02:19:13 PM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 [13] 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 »
  Print  
Author Topic: [ANN] Miner Control 1.6.1 - Auto profit switching miner controller  (Read 158588 times)
kalen37
Newbie
*
Offline Offline

Activity: 22


View Profile
October 20, 2014, 03:56:45 PM
 #241

howdy all, me again.

 Thanks to all of you who were helping me with my noobness.

 So far it looks like my issue wasn't with mining but nvlddmkm.sys issues. Didn't have them when I was using my 560TI but my 760 seems to have a problem with it. Still trying to fix it but I'm still trying to figure out if it's the card or 344.11 driver.
1513001953
Hero Member
*
Offline Offline

Posts: 1513001953

View Profile Personal Message (Offline)

Ignore
1513001953
Reply with quote  #2

1513001953
Report to moderator
1513001953
Hero Member
*
Offline Offline

Posts: 1513001953

View Profile Personal Message (Offline)

Ignore
1513001953
Reply with quote  #2

1513001953
Report to moderator
1513001953
Hero Member
*
Offline Offline

Posts: 1513001953

View Profile Personal Message (Offline)

Ignore
1513001953
Reply with quote  #2

1513001953
Report to moderator
FORTUNEJACK.COM[
                            
9 BTC WELCOME PACK FOR 1ST 5 DEPOSITS
FREE 1,000 mBTC daily for LuckyJack winners
[
          
]
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1513001953
Hero Member
*
Offline Offline

Posts: 1513001953

View Profile Personal Message (Offline)

Ignore
1513001953
Reply with quote  #2

1513001953
Report to moderator
1513001953
Hero Member
*
Offline Offline

Posts: 1513001953

View Profile Personal Message (Offline)

Ignore
1513001953
Reply with quote  #2

1513001953
Report to moderator
frazier34567
Member
**
Offline Offline

Activity: 95


View Profile
October 20, 2014, 05:15:30 PM
 #242

I tried to setup a scrypt only version to run my ASIC Zeus Blizzard 1.2 MHz.  

This is what I get when I try to start any pools:

[12:08:18] Starting TradeMyBit scrypt

Redirection is not supported.


Code:
"trademybit": {
        "apikey": "APIKey",
        "account": "account",
        "worker": "3",
"param1": "",
        "param2": "--scan-serial //./COM13  --zeus-chips 6 --zeus-clock 328 -o stratum+tcp://east01.us.trademybit.com",
        "algos": [
            { "algo": "scrypt", "folder": "C:\\Users\\Jim\\Desktop\\cpuminer\\cgminer4.3.5-zeus", "command": "cgminer.exe", "arguments": "--scrypt _PARAM2_:3330 -u _ACCOUNT_._WORKER_ -p x" }
        ]
    },

I assume it is something with cgminer, it normally opens another window to run cgminer after loading the conf file.  Is there a way to disable it?

This is on windows 7.1 Pro

EDIT: Figured it out need to use --text-only  in front of --scan-serial
StuffOfInterest
Sr. Member
****
Offline Offline

Activity: 379


View Profile
October 20, 2014, 06:08:41 PM
 #243

I tried to setup a scrypt only version to run my ASIC Zeus Blizzard 1.2 MHz.  

This is what I get when I try to start any pools:

[12:08:18] Starting TradeMyBit scrypt

Redirection is not supported.


Code:
"trademybit": {
        "apikey": "APIKey",
        "account": "account",
        "worker": "3",
"param1": "",
        "param2": "--scan-serial //./COM13  --zeus-chips 6 --zeus-clock 328 -o stratum+tcp://east01.us.trademybit.com",
        "algos": [
            { "algo": "scrypt", "folder": "C:\\Users\\Jim\\Desktop\\cpuminer\\cgminer4.3.5-zeus", "command": "cgminer.exe", "arguments": "--scrypt _PARAM2_:3330 -u _ACCOUNT_._WORKER_ -p x" }
        ]
    },

I assume it is something with cgminer, it normally opens another window to run cgminer after loading the conf file.  Is there a way to disable it?

This is on windows 7.1 Pro

EDIT: Figured it out need to use --text-only  in front of --scan-serial

Are you using Miner Control 1.4 or above?  I bet it was an issue with the cgminer output not being handled by the internal console in Miner Control.  If that was the case, another work around would have been to put '"usewindow": true' as an option in the scrypt algo line.  That would force the miner to launch in a separate window.  It is good that cgminer included an option to do text only output so it can run in the internal console.

Miner Control to get auto algorithm switching for multiple mining services. (please donate if you like)
Could Proof of Blockchain (PoBC) help secure a coin and avoid runaway ASIC mining?
StuffOfInterest
Sr. Member
****
Offline Offline

Activity: 379


View Profile
October 22, 2014, 01:29:34 AM
 #244

Just pushed out version 1.4.3.

Has a few tweeks for the LTCRabbit service and new substitution parameters at the algorithm level.  This can cut down on some redundancy in the config entries.  I'll try to get some more examples of how to use it in the first post tomorrow.

Miner Control to get auto algorithm switching for multiple mining services. (please donate if you like)
Could Proof of Blockchain (PoBC) help secure a coin and avoid runaway ASIC mining?
int3ractivodular
Sr. Member
****
Offline Offline

Activity: 280

TECHNOLOGY, BABY!


View Profile
October 22, 2014, 09:06:09 AM
 #245

Stoked that this is still getting updated, keep up the awesome work! Smiley
frazier34567
Member
**
Offline Offline

Activity: 95


View Profile
October 22, 2014, 08:36:34 PM
 #246

Here is my Script Mining Conf File for my Zeus Blizzard using cgminer 4.3.5 for Miner Control 1.4.3 Running on Windows 7.1 Pro

(I do not pay for power so please review the power settings under "general" and "algorithms" if you pay for it.)

Code:
{
    "general": {
        "power": 0.001,
        "exchange": 500,
  "currencycode": "USD",
        "mintime": 4,
        "maxtime": 240,
        "switchtime": 1,
        "deadtime": 10,
"logerrors": true,
        "logactivity": true,
        "gridsortmode": 1,
        "minerkillmode": 1,
        "traymode": 1,
"donationpercentage": 2,
        "donationfrequency": 240
    },
    "algorithms": [
        { "name": "scrypt", "hashrate": 1400, "power": 1, "aparam1": "cgminer.exe", "aparam2": "--scrypt" }
    ],
    "nicehash": {
        "account": "174xGU8o4axrax417kwMn7hygRR187zo4w",
        "worker": "3",
  "sparam1": "-o stratum+tcp://stratum.nicehash.com",
        "sparam2": "-p d=256 --text-only --scan-serial //./COM13  --zeus-chips 6 --zeus-clock 328",
        "algos": [
                       { "algo": "scrypt", "folder": "C:\\Users\\Jim\\Desktop\\cpuminer\\cgminer4.3.5-zeus", "command": "_APARAM1_", "arguments": "_APARAM2_ _SPARAM1_:3333 -u _ACCOUNT_._WORKER_ _SPARAM2_" }
]
    },
    "westhash": {
        "account": "174xGU8o4axrax417kwMn7hygRR187zo4w",
        "worker": "3",
  "weight": 0.99,
"sparam1": "-o stratum+tcp://stratum.westhash.com",
        "sparam2": "-p d=256 --text-only --scan-serial //./COM13  --zeus-chips 6 --zeus-clock 328",
        "algos": [
           
            { "algo": "scrypt", "folder": "C:\\Users\\Jim\\Desktop\\cpuminer\\cgminer4.3.5-zeus", "command": "_APARAM1_", "arguments": "_APARAM2_
_SPARAM1_:3333 -u _ACCOUNT_._WORKER_ _SPARAM2_" }
        ]
    },
    "trademybit": {
        "apikey": "931640e1eab78345ae4ea6121504fb5c55c9612b83574572c76f4bb9d0e0e11c",
        "account": "frazier345",
        "worker": "3",
"sparam1": "-o stratum+tcp://east01.us.trademybit.com",
        "sparam2": "-p x --text-only --scan-serial //./COM13  --zeus-chips 6 --zeus-clock 328",
        "algos": [
            { "algo": "scrypt", "folder": "C:\\Users\\Jim\\Desktop\\cpuminer\\cgminer4.3.5-zeus", "command": "_APARAM1_", "arguments": "_APARAM2_ _SPARAM1_:3330 -u _ACCOUNT_._WORKER_ _SPARAM2_" }
        ]
    },
    "yaamp": {
        "account": "174xGU8o4axrax417kwMn7hygRR187zo4w",
"worker": "3",
"sparam1": "-o stratum+tcp://yaamp.com",
        "sparam2": "--text-only --scan-serial //./COM13  --zeus-chips 6 --zeus-clock 328",
        "algos": [
            { "algo": "scrypt", "folder": "C:\\Users\\Jim\\Desktop\\cpuminer\\cgminer4.3.5-zeus", "command": "_APARAM1_", "arguments": "_APARAM2_ _SPARAM1_:3433 -u _ACCOUNT_ -p _WORKER_ _SPARAM2_" }
      ]
    },
    "wafflepool": {
        "account": "174xGU8o4axrax417kwMn7hygRR187zo4w",
        "worker":  "3",
"weight": 0.80,
        "sparam1": "--text-only --scan-serial //./COM13  --zeus-chips 6 --zeus-clock 328 -o stratum+tcp://useast.wafflepool.com",
        "sparam2": "-p x",
        "algos": [
            { "algo": "scrypt", "folder": "C:\\Users\\Jim\\Desktop\\cpuminer\\cgminer4.3.5-zeus", "command": "_APARAM1_", "arguments": "_APARAM2_ _SPARAM1_:3333 -u _ACCOUNT_._WORKER_ _PARAM2_" }
        ]
    },
    "ltcrabbit": {
        "apikey": "1e64305ea7d6d0e5a099233285f63d9dc95e8cea7ec5c674374140f029c15204",
        "account": "frazier345",
        "worker":  "3",
        "sparam1": "--text-only --scan-serial //./COM13  --zeus-chips 6 --zeus-clock 328",
        "sparam2": "-p x",
        "algos": [
            { "algo": "scrypt", "folder": "C:\\Users\\Jim\\Desktop\\cpuminer\\cgminer4.3.5-zeus", "command": "_APARAM1_", "arguments": "_APARAM2_ _SPARAM1_ -o stratum+tcp://scrypt.ltcrabbit.com:3333 -u _ACCOUNT_._WORKER_ _PARAM2_" }
        ]
    }
}

int3ractivodular
Sr. Member
****
Offline Offline

Activity: 280

TECHNOLOGY, BABY!


View Profile
October 22, 2014, 10:35:47 PM
 #247

So I got it all working properly on my Nvidia rigs and ccminer, but I'm running into some issues with my AMD rig with sgminer.

Here is the output I get whenever I try to launch (x15 in this example, using bitblock kernel):

Code:
[15:15:48] Starting NiceHash x15
[15:15:48] Set default algorithm to bitblock
[15:15:48] Global quota greatest common denominator set to 1
[15:15:48] Default Devices = all
[15:15:48] set_devices(all)
[15:15:48] Loading settings from default_profile for pool 0
[15:15:48] Pool 0 Algorithm set to "bitblock"
[15:15:48] Pool 0 devices set to "all"
[15:15:48] Pool 0 lookup gap set to "(null)"
[15:15:48] Pool 0 Intensity set to "19"
[15:15:48] Pool 0 XIntensity set to "(null)"
[15:15:48] Pool 0 Raw Intensity set to "(null)"
[15:15:48] Pool 0 Thread Concurrency set to "8192"
[15:15:48] Pool 0 GPU Clock set to "1100"
[15:15:48] Pool 0 GPU Memory clock set to "1250"
[15:15:48] Pool 0 GPU Threads set to "2"
[15:15:48] Pool 0 GPU Fan set to "(null)"
[15:15:48] Pool 0 GPU Powertune set to "(null)"
[15:15:48] Pool 0 GPU Vddc set to "(null)"
[15:15:48] Pool 0 Shaders set to "(null)"
[15:15:48] Pool 0 Worksize set to "256"

Redirection is not supported.

No clue what "Redirection is not supported." means. I'm also not entirely sure that everything is being passed correctly to sgminer, it seems like it is getting most of what I tell it but it's still not working properly.. Also I get the same set of errors regardless of which algo I attempt to use, except that the output changes respective to that algorithm and it's specific passed arguments.

Here's my Nicehash x15 config:

Code:
{ "algo": "x15", "folder": "", "command": "sgminer.exe", "arguments": " -k bitblock -o stratum+tcp://stratum.nicehash.com:3339 -u 1MyBTCAddresshere.worker -p x --thread-concurrency 8192 -I 19 -w 256 -g 2 --gpu-engine 1100 --gpu-memclock 1250" }

Any ideas as to what I might be doing wrong? I wasn't even able to get miners to fully start when I was using the SPARAMs etc so I just removed them and manually input the arguments, which seems to have worked for the most part, but obviously it's still not quite right or I'd be hashing away. Any help is greatly appreciated  Smiley

EDIT: Here is what appears in the error.log right after I attempt to launch it.

Code:
10/22/2014 3:47:48 PM
----------------------------------------------
Type: TargetInvocationException
Message: An exception occurred during the operation, making the result invalid.  Check InnerException for exception details.
Stack trace:    at System.ComponentModel.AsyncCompletedEventArgs.RaiseExceptionIfNecessary()
   at System.Net.DownloadStringCompletedEventArgs.get_Result()
   at MinerControl.Utility.WebUtil.DownloadJsonComplete(Object sender, DownloadStringCompletedEventArgs e)

10/22/2014 3:47:48 PM
----------------------------------------------
Type: WebException
Message: The underlying connection was closed: The connection was closed unexpectedly.
Stack trace:    at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
   at System.Net.WebClient.GetWebResponse(WebRequest request, IAsyncResult result)
   at System.Net.WebClient.DownloadBitsResponseCallback(IAsyncResult result)

10/22/2014 3:47:49 PM
----------------------------------------------
Type: TargetInvocationException
Message: An exception occurred during the operation, making the result invalid.  Check InnerException for exception details.
Stack trace:    at System.ComponentModel.AsyncCompletedEventArgs.RaiseExceptionIfNecessary()
   at System.Net.DownloadStringCompletedEventArgs.get_Result()
   at MinerControl.Utility.WebUtil.DownloadJsonComplete(Object sender, DownloadStringCompletedEventArgs e)

10/22/2014 3:47:49 PM
----------------------------------------------
Type: WebException
Message: The underlying connection was closed: The connection was closed unexpectedly.
Stack trace:    at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
   at System.Net.WebClient.GetWebResponse(WebRequest request, IAsyncResult result)
   at System.Net.WebClient.DownloadBitsResponseCallback(IAsyncResult result)
Travis9x
Full Member
***
Offline Offline

Activity: 170


View Profile WWW
October 22, 2014, 11:11:34 PM
 #248

So I got it all working properly on my Nvidia rigs and ccminer, but I'm running into some issues with my AMD rig with sgminer.

Here is the output I get whenever I try to launch (x15 in this example, using bitblock kernel):

Code:
[15:15:48] Starting NiceHash x15
[15:15:48] Set default algorithm to bitblock
[15:15:48] Global quota greatest common denominator set to 1
[15:15:48] Default Devices = all
[15:15:48] set_devices(all)
[15:15:48] Loading settings from default_profile for pool 0
[15:15:48] Pool 0 Algorithm set to "bitblock"
[15:15:48] Pool 0 devices set to "all"
[15:15:48] Pool 0 lookup gap set to "(null)"
[15:15:48] Pool 0 Intensity set to "19"
[15:15:48] Pool 0 XIntensity set to "(null)"
[15:15:48] Pool 0 Raw Intensity set to "(null)"
[15:15:48] Pool 0 Thread Concurrency set to "8192"
[15:15:48] Pool 0 GPU Clock set to "1100"
[15:15:48] Pool 0 GPU Memory clock set to "1250"
[15:15:48] Pool 0 GPU Threads set to "2"
[15:15:48] Pool 0 GPU Fan set to "(null)"
[15:15:48] Pool 0 GPU Powertune set to "(null)"
[15:15:48] Pool 0 GPU Vddc set to "(null)"
[15:15:48] Pool 0 Shaders set to "(null)"
[15:15:48] Pool 0 Worksize set to "256"

Redirection is not supported.

No clue what "Redirection is not supported." means. I'm also not entirely sure that everything is being passed correctly to sgminer, it seems like it is getting most of what I tell it but it's still not working properly.. Also I get the same set of errors regardless of which algo I attempt to use, except that the output changes respective to that algorithm and it's specific passed arguments.

Here's my Nicehash x15 config:

Code:
{ "algo": "x15", "folder": "", "command": "sgminer.exe", "arguments": " -k bitblock -o stratum+tcp://stratum.nicehash.com:3339 -u 1MyBTCAddresshere.worker -p x --thread-concurrency 8192 -I 19 -w 256 -g 2 --gpu-engine 1100 --gpu-memclock 1250" }

Any ideas as to what I might be doing wrong? I wasn't even able to get miners to fully start when I was using the SPARAMs etc so I just removed them and manually input the arguments, which seems to have worked for the most part, but obviously it's still not quite right or I'd be hashing away. Any help is greatly appreciated  Smiley

EDIT: Here is what appears in the error.log right after I attempt to launch it.

Code:
10/22/2014 3:47:48 PM
----------------------------------------------
Type: TargetInvocationException
Message: An exception occurred during the operation, making the result invalid.  Check InnerException for exception details.
Stack trace:    at System.ComponentModel.AsyncCompletedEventArgs.RaiseExceptionIfNecessary()
   at System.Net.DownloadStringCompletedEventArgs.get_Result()
   at MinerControl.Utility.WebUtil.DownloadJsonComplete(Object sender, DownloadStringCompletedEventArgs e)

10/22/2014 3:47:48 PM
----------------------------------------------
Type: WebException
Message: The underlying connection was closed: The connection was closed unexpectedly.
Stack trace:    at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
   at System.Net.WebClient.GetWebResponse(WebRequest request, IAsyncResult result)
   at System.Net.WebClient.DownloadBitsResponseCallback(IAsyncResult result)

10/22/2014 3:47:49 PM
----------------------------------------------
Type: TargetInvocationException
Message: An exception occurred during the operation, making the result invalid.  Check InnerException for exception details.
Stack trace:    at System.ComponentModel.AsyncCompletedEventArgs.RaiseExceptionIfNecessary()
   at System.Net.DownloadStringCompletedEventArgs.get_Result()
   at MinerControl.Utility.WebUtil.DownloadJsonComplete(Object sender, DownloadStringCompletedEventArgs e)

10/22/2014 3:47:49 PM
----------------------------------------------
Type: WebException
Message: The underlying connection was closed: The connection was closed unexpectedly.
Stack trace:    at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
   at System.Net.WebClient.GetWebResponse(WebRequest request, IAsyncResult result)
   at System.Net.WebClient.DownloadBitsResponseCallback(IAsyncResult result)
From what I understand (I don't have any AMD cards, so I don't use sgminer), sgminer output is not compatible with the Miner Control console.  So, you need to either set sgminer to text-only output, or tell Miner Control to launch sgminer in a separate window.

int3ractivodular
Sr. Member
****
Offline Offline

Activity: 280

TECHNOLOGY, BABY!


View Profile
October 22, 2014, 11:14:09 PM
 #249

That's basically what I was thinking was happening but I wasn't sure. Alright, I'll try that.

I was trying to get the miners to launch in a separate window with  the "usewindow" command but I guess I am still not doing it right.
int3ractivodular
Sr. Member
****
Offline Offline

Activity: 280

TECHNOLOGY, BABY!


View Profile
October 22, 2014, 11:25:00 PM
 #250

Well, seems like I got it working via using both text only output and the "usewindow" command and all is well. Smiley

On a semi-related note, I haven't been keeping up with GPU mining super closely recently, what are the expected speeds for a 280X on each algo nowadays?

Are their newly released modded kernels? Did people figure out the settings/clocks better? What settings/software are you guys mining with/could you redirect me to a better resource?
Travis9x
Full Member
***
Offline Offline

Activity: 170


View Profile WWW
October 22, 2014, 11:30:51 PM
 #251

Well, seems like I got it working via using both text only output and the "usewindow" command and all is well. Smiley

On a semi-related note, I haven't been keeping up with GPU mining super closely recently, what are the expected speeds for a 280X on each algo nowadays?

Are their newly released modded kernels? Did people figure out the settings/clocks better? What settings/software are you guys mining with/could you redirect me to a better resource?
I don't know a lot about AMD cards, so perhaps someone else here could help you more with that.  But I do know that NVIDIA cards seem to be the best for any of the X## algorithms, and AMD cards are best for some others.

int3ractivodular
Sr. Member
****
Offline Offline

Activity: 280

TECHNOLOGY, BABY!


View Profile
October 22, 2014, 11:31:56 PM
 #252

Well, seems like I got it working via using both text only output and the "usewindow" command and all is well. Smiley

On a semi-related note, I haven't been keeping up with GPU mining super closely recently, what are the expected speeds for a 280X on each algo nowadays?

Are their newly released modded kernels? Did people figure out the settings/clocks better? What settings/software are you guys mining with/could you redirect me to a better resource?
I don't know a lot about AMD cards, so perhaps someone else here could help you more with that.  But I do know that NVIDIA cards seem to be the best for any of the X## algorithms, and AMD cards are best for some others.

Okay, thanks for your help Smiley
xIIImaL
Legendary
*
Offline Offline

Activity: 1050


View Profile
October 24, 2014, 02:25:24 AM
 #253

please add support for the new algos from yaamp pool. x14, etc.

StuffOfInterest
Sr. Member
****
Offline Offline

Activity: 379


View Profile
October 24, 2014, 10:09:30 AM
 #254

please add support for the new algos from yaamp pool. x14, etc.

Already handled.  Just add an algorithms line for "x14" (or the other new algos supported by yaamp) and then a new algos line under yaamp.

Miner Control to get auto algorithm switching for multiple mining services. (please donate if you like)
Could Proof of Blockchain (PoBC) help secure a coin and avoid runaway ASIC mining?
frazier34567
Member
**
Offline Offline

Activity: 95


View Profile
October 24, 2014, 02:51:20 PM
 #255

YAAMP not updating for me.  Anyone else having issues?  I get this in the error log.  last update was at 8:00 Central time.

Code:
10/24/2014 9:48:22 AM
----------------------------------------------
Type: ArgumentException
Message: Invalid JSON primitive: scrypt.
Stack trace:    at System.Web.Script.Serialization.JavaScriptObjectDeserializer.DeserializePrimitiveObject()
at System.Web.Script.Serialization.JavaScriptObjectDeserializer.DeserializeInternal(Int32 depth)
at System.Web.Script.Serialization.JavaScriptObjectDeserializer.DeserializeDictionary(Int32 depth)
at System.Web.Script.Serialization.JavaScriptObjectDeserializer.DeserializeInternal(Int32 depth)
at System.Web.Script.Serialization.JavaScriptObjectDeserializer.DeserializeDictionary(Int32 depth)
at System.Web.Script.Serialization.JavaScriptObjectDeserializer.DeserializeInternal(Int32 depth)
at System.Web.Script.Serialization.JavaScriptObjectDeserializer.BasicDeserialize(String input, Int32 depthLimit, JavaScriptSerializer serializer)
at System.Web.Script.Serialization.JavaScriptSerializer.Deserialize(JavaScriptSerializer serializer, String input, Type type, Int32 depthLimit)
at System.Web.Script.Serialization.JavaScriptSerializer.DeserializeObject(String input)
at MinerControl.Utility.WebUtil.DownloadJsonComplete(Object sender, DownloadStringCompletedEventArgs e)

My guess is that they changed or screwed up the JSON output from the site.
StuffOfInterest
Sr. Member
****
Offline Offline

Activity: 379


View Profile
October 24, 2014, 03:04:46 PM
 #256

YAAMP not updating for me.  Anyone else having issues?  I get this in the error log.  last update was at 8:00 Central time.

Code:
10/24/2014 9:48:22 AM
----------------------------------------------
Type: ArgumentException
Message: Invalid JSON primitive: scrypt.
Stack trace:    at System.Web.Script.Serialization.JavaScriptObjectDeserializer.DeserializePrimitiveObject()
at System.Web.Script.Serialization.JavaScriptObjectDeserializer.DeserializeInternal(Int32 depth)
at System.Web.Script.Serialization.JavaScriptObjectDeserializer.DeserializeDictionary(Int32 depth)
at System.Web.Script.Serialization.JavaScriptObjectDeserializer.DeserializeInternal(Int32 depth)
at System.Web.Script.Serialization.JavaScriptObjectDeserializer.DeserializeDictionary(Int32 depth)
at System.Web.Script.Serialization.JavaScriptObjectDeserializer.DeserializeInternal(Int32 depth)
at System.Web.Script.Serialization.JavaScriptObjectDeserializer.BasicDeserialize(String input, Int32 depthLimit, JavaScriptSerializer serializer)
at System.Web.Script.Serialization.JavaScriptSerializer.Deserialize(JavaScriptSerializer serializer, String input, Type type, Int32 depthLimit)
at System.Web.Script.Serialization.JavaScriptSerializer.DeserializeObject(String input)
at MinerControl.Utility.WebUtil.DownloadJsonComplete(Object sender, DownloadStringCompletedEventArgs e)

My guess is that they changed or screwed up the JSON output from the site.

Definitely fouled up, output won't pass JSONLint now.

Code:
http://yaamp.com/api/status

Code:
arse error on line 74:
...h",        "port": -,        "coins":
----------------------^
Expecting 'STRING', 'NUMBER', 'NULL', 'TRUE', 'FALSE', '{', '['

Miner Control to get auto algorithm switching for multiple mining services. (please donate if you like)
Could Proof of Blockchain (PoBC) help secure a coin and avoid runaway ASIC mining?
ghotiphry
Newbie
*
Offline Offline

Activity: 28


View Profile
October 24, 2014, 03:09:38 PM
 #257

Yeah, YAAMP screwed with their API.  They've got a new field for starters.  I tweeted to them a couple change requests.  They've fixed one problem, still breaking where "port": -,
frazier34567
Member
**
Offline Offline

Activity: 95


View Profile
October 24, 2014, 03:17:49 PM
 #258

ah I see it now, for fresh and neoscrypt.
ghotiphry
Newbie
*
Offline Offline

Activity: 28


View Profile
October 24, 2014, 03:18:20 PM
 #259

Recommendation for next version: if retrieval of API from one site fails, allow the rest to continue as normal rather than failing to run?
StuffOfInterest
Sr. Member
****
Offline Offline

Activity: 379


View Profile
October 24, 2014, 03:23:22 PM
 #260

Recommendation for next version: if retrieval of API from one site fails, allow the rest to continue as normal rather than failing to run?

Already does that for api calls.  You would just see all of the YAAMP prices stay at zero.  

If the app is crashing out then I do need to know as there is another issue.  Also, related to that, I'd prefer to see the reports in the thread rather than as PMs.

Miner Control to get auto algorithm switching for multiple mining services. (please donate if you like)
Could Proof of Blockchain (PoBC) help secure a coin and avoid runaway ASIC mining?
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 [13] 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!