Bitcoin Forum
March 23, 2017, 06:22:50 AM *
News: Latest stable version of Bitcoin Core: 0.14.0  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 [32] 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 »
  Print  
Author Topic: [ANN] sph-sgminer: multi-coin multi-algorithm GPU miner | added MaruCoin  (Read 452304 times)
restless
Hero Member
*****
Online Online

Activity: 882


View Profile
March 26, 2014, 07:27:31 AM
 #621

are there some "benchmarks" about performance in Myr-groestl and groestl ?
1490250170
Hero Member
*
Offline Offline

Posts: 1490250170

View Profile Personal Message (Offline)

Ignore
1490250170
Reply with quote  #2

1490250170
Report to moderator
1490250170
Hero Member
*
Offline Offline

Posts: 1490250170

View Profile Personal Message (Offline)

Ignore
1490250170
Reply with quote  #2

1490250170
Report to moderator
The forum was founded in 2009 by Satoshi and Sirius. It replaced a SourceForge forum.
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1490250170
Hero Member
*
Offline Offline

Posts: 1490250170

View Profile Personal Message (Offline)

Ignore
1490250170
Reply with quote  #2

1490250170
Report to moderator
1490250170
Hero Member
*
Offline Offline

Posts: 1490250170

View Profile Personal Message (Offline)

Ignore
1490250170
Reply with quote  #2

1490250170
Report to moderator
1490250170
Hero Member
*
Offline Offline

Posts: 1490250170

View Profile Personal Message (Offline)

Ignore
1490250170
Reply with quote  #2

1490250170
Report to moderator
j4r3k
Jr. Member
*
Offline Offline

Activity: 32


View Profile
March 26, 2014, 08:02:56 AM
 #622

not really sure what the problem is but you could probably get it mining with --no-adl

nope, same result.
Maybe clean amd drivers with some tool and reinstall?
david123
Hero Member
*****
Offline Offline

Activity: 658


View Profile
March 26, 2014, 08:53:04 AM
 #623

Hi, can someone tell me what fine tuning makes a difference for darkcoin (and maybe the other algos)?
Is it just core freq or also mem freq or the right ratio (as with scrypt)? Thanks

DJstone
Jr. Member
*
Offline Offline

Activity: 37


View Profile
March 26, 2014, 12:10:01 PM
 #624

Can I get any help with this?



http://s18.postimg.org/em5dc9lxl/Clipboard01.png

Windows 8.1. cgminer, sgminer, vertminer run on the same machine with no problems. Don't know what is wrong.

GPU is detected.

Code:
D:\Aplikacje\sph-sgminer>sgminer -n
[04:14:30] CL Platform 0 vendor: Intel(R) Corporation
[04:14:30] CL Platform 0 name: Intel(R) OpenCL
[04:14:30] CL Platform 0 version: OpenCL 1.2
[04:14:30] Error -1: Getting Device IDs (num)
[04:14:30] CL Platform 1 vendor: Advanced Micro Devices, Inc.
[04:14:30] CL Platform 1 name: AMD Accelerated Parallel Processing
[04:14:30] CL Platform 1 version: OpenCL 1.2 AMD-APP (1348.5)
[04:14:30] Platform 1 devices: 1
[04:14:30]      0       Tahiti
[04:14:30] Number of ADL devices: 1
[04:14:30] ATI ADL Overdrive5 API found.
[04:14:30] ATI ADL Overdrive6 API found.
[04:14:30] Found 9 ADL adapters
[04:14:30] ADL index 0, id 1195520 - BIOS partno.: 113-1E249100-S42, version: 015.040.000.001, date: 2014/01/08 16:11
[04:14:30] GPU 0 assigned: iAdapterIndex:0 iPresent:1 strUDID:PCI_VEN_1002&DEV_679A&SUBSYS_E249174B&REV_00_4&15001D53&0&0008A iBusNumber:1 iDeviceNumber:0 iFunctionNumber:0 iVendorID:1002 Name:AMD Radeon HD 7900 Series
[04:14:30] ADL index 1, id 1195520 - BIOS partno.: 113-1E249100-S42, version: 015.040.000.001, date: 2014/01/08 16:11
[04:14:30] ADL index 2, id 1195520 - BIOS partno.: 113-1E249100-S42, version: 015.040.000.001, date: 2014/01/08 16:11
[04:14:30] ADL index 3, id 1195520 - BIOS partno.: 113-1E249100-S42, version: 015.040.000.001, date: 2014/01/08 16:11
[04:14:30] ADL index 4, id 1195520 - BIOS partno.: 113-1E249100-S42, version: 015.040.000.001, date: 2014/01/08 16:11
[04:14:30] ADL index 5, id 1195520 - BIOS partno.: 113-1E249100-S42, version: 015.040.000.001, date: 2014/01/08 16:11
[04:14:30] ADL index 6, id 1195520 - FAILED to get BIOS info
[04:14:30] Failed to ADL_Adapter_ID_Get. Error -1
[04:14:30] ADL index 7, id 1195520 - FAILED to get BIOS info
[04:14:30] Failed to ADL_Adapter_ID_Get. Error -1
[04:14:30] ADL index 8, id 1195520 - FAILED to get BIOS info
[04:14:30] Failed to ADL_Adapter_ID_Get. Error -1
[04:14:30] GPU 0 AMD Radeon HD 7900 Series hardware monitoring enabled
[04:14:30] ADL GPU 0 is Adapter index 0 and maps to adapter id 1195520
[04:14:30] GPU 0 BIOS partno.: 113-1E249100-S42, version: 015.040.000.001, date: 2014/01/08 16:11

[04:14:30] 1 GPU devices max detected


I don't know if it is really what im describing now but:

Did u Install the AMD APP SDK and the AMD OpenCL SDK?


Now to something different.

I would like you all to test my new version of sph-sgminer with support for latest nFactor Scrypt and al the normal sph Stuff from the last Version PHM commited.

Sourcecode on GIT : https://github.com/DJstone/sph-sgminer
Binaryfiles on Uploaded : http://ul.to/81oex4n2

I'd set up a complete merge with the current sgminer from veox (1f7b7ef26e) with phm's latest code.

All Kernels should be working.
I do have tested:

QRK
ANI
FC
DRK
Q2C
Scrpty (nFactor Scrypt)


already and they are working.


Thx

DRK: Xs55P4YP5nbfxv9hV2FEdyBYjcadmj1FBz
1976
Member
**
Offline Offline

Activity: 82


View Profile
March 26, 2014, 12:16:17 PM
 #625

DRK:
R9 270X   1.2M/s
thanks!
Amph
Legendary
*
Online Online

Activity: 1456



View Profile
March 26, 2014, 01:04:12 PM
 #626

Can I get any help with this?



http://s18.postimg.org/em5dc9lxl/Clipboard01.png

Windows 8.1. cgminer, sgminer, vertminer run on the same machine with no problems. Don't know what is wrong.

GPU is detected.

Code:
D:\Aplikacje\sph-sgminer>sgminer -n
[04:14:30] CL Platform 0 vendor: Intel(R) Corporation
[04:14:30] CL Platform 0 name: Intel(R) OpenCL
[04:14:30] CL Platform 0 version: OpenCL 1.2
[04:14:30] Error -1: Getting Device IDs (num)
[04:14:30] CL Platform 1 vendor: Advanced Micro Devices, Inc.
[04:14:30] CL Platform 1 name: AMD Accelerated Parallel Processing
[04:14:30] CL Platform 1 version: OpenCL 1.2 AMD-APP (1348.5)
[04:14:30] Platform 1 devices: 1
[04:14:30]      0       Tahiti
[04:14:30] Number of ADL devices: 1
[04:14:30] ATI ADL Overdrive5 API found.
[04:14:30] ATI ADL Overdrive6 API found.
[04:14:30] Found 9 ADL adapters
[04:14:30] ADL index 0, id 1195520 - BIOS partno.: 113-1E249100-S42, version: 015.040.000.001, date: 2014/01/08 16:11
[04:14:30] GPU 0 assigned: iAdapterIndex:0 iPresent:1 strUDID:PCI_VEN_1002&DEV_679A&SUBSYS_E249174B&REV_00_4&15001D53&0&0008A iBusNumber:1 iDeviceNumber:0 iFunctionNumber:0 iVendorID:1002 Name:AMD Radeon HD 7900 Series
[04:14:30] ADL index 1, id 1195520 - BIOS partno.: 113-1E249100-S42, version: 015.040.000.001, date: 2014/01/08 16:11
[04:14:30] ADL index 2, id 1195520 - BIOS partno.: 113-1E249100-S42, version: 015.040.000.001, date: 2014/01/08 16:11
[04:14:30] ADL index 3, id 1195520 - BIOS partno.: 113-1E249100-S42, version: 015.040.000.001, date: 2014/01/08 16:11
[04:14:30] ADL index 4, id 1195520 - BIOS partno.: 113-1E249100-S42, version: 015.040.000.001, date: 2014/01/08 16:11
[04:14:30] ADL index 5, id 1195520 - BIOS partno.: 113-1E249100-S42, version: 015.040.000.001, date: 2014/01/08 16:11
[04:14:30] ADL index 6, id 1195520 - FAILED to get BIOS info
[04:14:30] Failed to ADL_Adapter_ID_Get. Error -1
[04:14:30] ADL index 7, id 1195520 - FAILED to get BIOS info
[04:14:30] Failed to ADL_Adapter_ID_Get. Error -1
[04:14:30] ADL index 8, id 1195520 - FAILED to get BIOS info
[04:14:30] Failed to ADL_Adapter_ID_Get. Error -1
[04:14:30] GPU 0 AMD Radeon HD 7900 Series hardware monitoring enabled
[04:14:30] ADL GPU 0 is Adapter index 0 and maps to adapter id 1195520
[04:14:30] GPU 0 BIOS partno.: 113-1E249100-S42, version: 015.040.000.001, date: 2014/01/08 16:11

[04:14:30] 1 GPU devices max detected


I don't know if it is really what im describing now but:

Did u Install the AMD APP SDK and the AMD OpenCL SDK?


Now to something different.

I would like you all to test my new version of sph-sgminer with support for latest nFactor Scrypt and al the normal sph Stuff from the last Version PHM commited.

Sourcecode on GIT : https://github.com/DJstone/sph-sgminer
Binaryfiles on Uploaded : http://ul.to/81oex4n2

I'd set up a complete merge with the current sgminer from veox (1f7b7ef26e) with phm's latest code.

All Kernels should be working.
I do have tested:

QRK
ANI
FC
DRK
Q2C
Scrpty (nFactor Scrypt)


already and they are working.


Thx


kernel command for n-scrypt is the same like in vertminer? --nscrypt?

also heavycoin algo is missed

DJstone
Jr. Member
*
Offline Offline

Activity: 37


View Profile
March 26, 2014, 01:17:13 PM
 #627

Can I get any help with this?



http://s18.postimg.org/em5dc9lxl/Clipboard01.png

Windows 8.1. cgminer, sgminer, vertminer run on the same machine with no problems. Don't know what is wrong.

GPU is detected.

Code:
D:\Aplikacje\sph-sgminer>sgminer -n
[04:14:30] CL Platform 0 vendor: Intel(R) Corporation
[04:14:30] CL Platform 0 name: Intel(R) OpenCL
[04:14:30] CL Platform 0 version: OpenCL 1.2
[04:14:30] Error -1: Getting Device IDs (num)
[04:14:30] CL Platform 1 vendor: Advanced Micro Devices, Inc.
[04:14:30] CL Platform 1 name: AMD Accelerated Parallel Processing
[04:14:30] CL Platform 1 version: OpenCL 1.2 AMD-APP (1348.5)
[04:14:30] Platform 1 devices: 1
[04:14:30]      0       Tahiti
[04:14:30] Number of ADL devices: 1
[04:14:30] ATI ADL Overdrive5 API found.
[04:14:30] ATI ADL Overdrive6 API found.
[04:14:30] Found 9 ADL adapters
[04:14:30] ADL index 0, id 1195520 - BIOS partno.: 113-1E249100-S42, version: 015.040.000.001, date: 2014/01/08 16:11
[04:14:30] GPU 0 assigned: iAdapterIndex:0 iPresent:1 strUDID:PCI_VEN_1002&DEV_679A&SUBSYS_E249174B&REV_00_4&15001D53&0&0008A iBusNumber:1 iDeviceNumber:0 iFunctionNumber:0 iVendorID:1002 Name:AMD Radeon HD 7900 Series
[04:14:30] ADL index 1, id 1195520 - BIOS partno.: 113-1E249100-S42, version: 015.040.000.001, date: 2014/01/08 16:11
[04:14:30] ADL index 2, id 1195520 - BIOS partno.: 113-1E249100-S42, version: 015.040.000.001, date: 2014/01/08 16:11
[04:14:30] ADL index 3, id 1195520 - BIOS partno.: 113-1E249100-S42, version: 015.040.000.001, date: 2014/01/08 16:11
[04:14:30] ADL index 4, id 1195520 - BIOS partno.: 113-1E249100-S42, version: 015.040.000.001, date: 2014/01/08 16:11
[04:14:30] ADL index 5, id 1195520 - BIOS partno.: 113-1E249100-S42, version: 015.040.000.001, date: 2014/01/08 16:11
[04:14:30] ADL index 6, id 1195520 - FAILED to get BIOS info
[04:14:30] Failed to ADL_Adapter_ID_Get. Error -1
[04:14:30] ADL index 7, id 1195520 - FAILED to get BIOS info
[04:14:30] Failed to ADL_Adapter_ID_Get. Error -1
[04:14:30] ADL index 8, id 1195520 - FAILED to get BIOS info
[04:14:30] Failed to ADL_Adapter_ID_Get. Error -1
[04:14:30] GPU 0 AMD Radeon HD 7900 Series hardware monitoring enabled
[04:14:30] ADL GPU 0 is Adapter index 0 and maps to adapter id 1195520
[04:14:30] GPU 0 BIOS partno.: 113-1E249100-S42, version: 015.040.000.001, date: 2014/01/08 16:11

[04:14:30] 1 GPU devices max detected


I don't know if it is really what im describing now but:

Did u Install the AMD APP SDK and the AMD OpenCL SDK?


Now to something different.

I would like you all to test my new version of sph-sgminer with support for latest nFactor Scrypt and al the normal sph Stuff from the last Version PHM commited.

Sourcecode on GIT : https://github.com/DJstone/sph-sgminer
Binaryfiles on Uploaded : http://ul.to/81oex4n2

I'd set up a complete merge with the current sgminer from veox (1f7b7ef26e) with phm's latest code.

All Kernels should be working.
I do have tested:

QRK
ANI
FC
DRK
Q2C
Scrpty (nFactor Scrypt)


already and they are working.


Thx


kernel command for n-scrypt is the ame like in vertminer? --nscrypt?

also heavycoin algo is missed

Yes, the command for n-scrypt should be the same like in vertminer!
You can add following to your config file to add nFactor
"algorithm" : "nscrypt",

The Heavycoin kernel has not been build for -sph-sgminer yet.



DRK: Xs55P4YP5nbfxv9hV2FEdyBYjcadmj1FBz
Amph
Legendary
*
Online Online

Activity: 1456



View Profile
March 26, 2014, 01:36:24 PM
 #628

pretty cool then to have all in one, i can delete now all the other cgminer clone lol

apparently it is not the same, --nscrypt don't work, same for -k vertcoin

DJstone
Jr. Member
*
Offline Offline

Activity: 37


View Profile
March 26, 2014, 01:55:36 PM
 #629

pretty cool then to have all in one, i can delete now all the other cgminer clone lol

apparently it is not the same, --nscrypt don't work, same for -k vertcoin

OK than maybe --nscrypt doesn't work.

But the "algorithm" : "nscrypt", works fine for me!
I'm doing all my settings over the config files. So that would be my way to enable "nscrypt" for "scrypt-kernels"


Vertcoin is not yet implemented in sph-sgminer.

I'm going to do further updates.
Maybe PHM is faster Smiley. It is his thread, to be mentioned!!

DRK: Xs55P4YP5nbfxv9hV2FEdyBYjcadmj1FBz
badman74
Hero Member
*****
Offline Offline

Activity: 532


View Profile
March 26, 2014, 02:20:28 PM
 #630

pretty cool then to have all in one, i can delete now all the other cgminer clone lol

apparently it is not the same, --nscrypt don't work, same for -k vertcoin

OK than maybe --nscrypt doesn't work.

But the "algorithm" : "nscrypt", works fine for me!
I'm doing all my settings over the config files. So that would be my way to enable "nscrypt" for "scrypt-kernels"


Vertcoin is not yet implemented in sph-sgminer.

I'm going to do further updates.
Maybe PHM is faster Smiley. It is his thread, to be mentioned!!
it should be --algorithm nscrypt
--nscrypt is to manually set nfactor i.e. --nfactor 12

voffka05
Jr. Member
*
Offline Offline

Activity: 47



View Profile
March 26, 2014, 03:26:58 PM
 #631

somebody attach the 7950  bin file darkcoinTahiti.....bin from miner folder
DJstone
Jr. Member
*
Offline Offline

Activity: 37


View Profile
March 26, 2014, 03:46:29 PM
 #632

pretty cool then to have all in one, i can delete now all the other cgminer clone lol

apparently it is not the same, --nscrypt don't work, same for -k vertcoin

OK than maybe --nscrypt doesn't work.

But the "algorithm" : "nscrypt", works fine for me!
I'm doing all my settings over the config files. So that would be my way to enable "nscrypt" for "scrypt-kernels"


Vertcoin is not yet implemented in sph-sgminer.

I'm going to do further updates.
Maybe PHM is faster Smiley. It is his thread, to be mentioned!!
it should be --algorithm nscrypt
--nscrypt is to manually set nfactor i.e. --nfactor 12

Thx Smiley

DRK: Xs55P4YP5nbfxv9hV2FEdyBYjcadmj1FBz
DJstone
Jr. Member
*
Offline Offline

Activity: 37


View Profile
March 26, 2014, 03:51:32 PM
 #633

somebody attach the 7950  bin file darkcoinTahiti.....bin from miner folder

http://ul.to/kg58je3l

There u go.

DRK: Xs55P4YP5nbfxv9hV2FEdyBYjcadmj1FBz
badman74
Hero Member
*****
Offline Offline

Activity: 532


View Profile
March 26, 2014, 06:18:17 PM
 #634


Now to something different.

I would like you all to test my new version of sph-sgminer with support for latest nFactor Scrypt and al the normal sph Stuff from the last Version PHM commited.

Sourcecode on GIT : https://github.com/DJstone/sph-sgminer
Binaryfiles on Uploaded : http://ul.to/81oex4n2

I'd set up a complete merge with the current sgminer from veox (1f7b7ef26e) with phm's latest code.

All Kernels should be working.
I do have tested:

QRK
ANI
FC
DRK
Q2C
Scrpty (nFactor Scrypt)


already and they are working.


Thx
i cant get scrypt to work....
it just closes sgminer

kache
Full Member
***
Offline Offline

Activity: 140

Bored


View Profile
March 26, 2014, 06:35:09 PM
 #635

Are you still getting this kind of result with Hiro?  I'm mining on Suprnova pool at the same hash but achieving only 0.0038btc equiv per 24hours. I'll try another pool, but with Suchpool holding such a large portion of the network, I wonder if the poor performance is related to that. It shouldn't though..
Sorry, haven't been mining Hiro these last days, busy with new coin launches. Gonna get back on it tomorrow. Wink

Rig: http://www.betarigs.com/rig/257
BTC: 15rBivhPYhVnQsgVHucNXHy5b66bUn6njM
Doge: DSdsJdTrmXSAZCdNi1iQ7zEo8nH1iBWGQv
Gazza1
Full Member
***
Offline Offline

Activity: 238


View Profile
March 26, 2014, 06:40:35 PM
 #636

Why do I get these errors

./sgminer: --gpu-engine: unrecognized option
./sgminer: --gpu-memclock: unrecognized option

also if i remove those commands it works, but fan speed and temps are blank

Impossible is a word found only in the dictionary of fools.
MinerP
Full Member
***
Offline Offline

Activity: 182


View Profile
March 26, 2014, 06:53:40 PM
 #637

first time x11 mining hirocoin...  I am getting 2.4mhs with r9 290 is this correct? difficulty is 0.000 and accepted shares go up very slowly... only 2 accepted shares showing in total but lots have been accepted
mfqrs3
Sr. Member
****
Offline Offline

Activity: 300


View Profile
March 26, 2014, 07:00:37 PM
 #638

On latest build I have problem with qubit, it won't accept shares and very low WU level, almost nothing come to pool. Older versions works fine.
badman74
Hero Member
*****
Offline Offline

Activity: 532


View Profile
March 26, 2014, 07:15:33 PM
 #639

On latest build I have problem with qubit, it won't accept shares and very low WU level, almost nothing come to pool. Older versions works fine.
you may be on a pool that has patched for the old version

badman74
Hero Member
*****
Offline Offline

Activity: 532


View Profile
March 26, 2014, 07:18:16 PM
 #640

Why do I get these errors

./sgminer: --gpu-engine: unrecognized option
./sgminer: --gpu-memclock: unrecognized option

Also how do I make sgminer load the sgminer.conf file in linux? (i am linux noob)

also if i remove those commands it works, but fan speed and temps are blank

it looks like you built it without adl
to load a .conf its -c whatever.conf

Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 [32] 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!