Bitcoin Forum
June 28, 2017, 04:01:42 AM *
News: Latest stable version of Bitcoin Core: 0.14.2  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 [36] 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 »
  Print  
Author Topic: [ANN] sph-sgminer: multi-coin multi-algorithm GPU miner | added MaruCoin  (Read 472794 times)
boubou
Full Member
***
Offline Offline

Activity: 196


View Profile
March 29, 2014, 11:33:56 AM
 #701

I have the drop also on 290s TRI-X.


Hum, it's probably not a temp issue then, neither a bios issue I assume since the bios are very different.

Some people have the same issue on a windows7 system, so on a hard drive, it should put the USB aside.

BEHNZiP6UZunp41vurNaQi4r2hvgG57yzi : BdG
1498622502
Hero Member
*
Offline Offline

Posts: 1498622502

View Profile Personal Message (Offline)

Ignore
1498622502
Reply with quote  #2

1498622502
Report to moderator
1498622502
Hero Member
*
Offline Offline

Posts: 1498622502

View Profile Personal Message (Offline)

Ignore
1498622502
Reply with quote  #2

1498622502
Report to moderator
1498622502
Hero Member
*
Offline Offline

Posts: 1498622502

View Profile Personal Message (Offline)

Ignore
1498622502
Reply with quote  #2

1498622502
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
boubou
Full Member
***
Offline Offline

Activity: 196


View Profile
March 29, 2014, 12:17:06 PM
 #702

Yes, Darkcoin only (hum, I did not use the SpH miner to mine scrypt, but with other miners, no problem), R9 290 only.
Does it make any difference if you set GPU_MAX_ALLOC_PERCENT=100?
Can I put that in a command line?

Since you are on bampt (e.g. Linux) you could do this:

 nano /etc/profile

    Add the following to the bottom of the file:

export DISPLAY=:0
export GPU_MAX_ALLOC_PERCENT=100
export GPU_USE_SYNC_OBJECTS=1

Save file, reboot.

should do the work.
Thanks, I give it a try.

The drop still happened.

BEHNZiP6UZunp41vurNaQi4r2hvgG57yzi : BdG
aigeezer
Legendary
*
Offline Offline

Activity: 1363


Cryptanalyst castrated by his government, 1952


View Profile
March 29, 2014, 12:29:18 PM
 #703

Where were you looking ? lol

The clean up utility can easily be found here. Smiley

http://sites.amd.com/us/game/downloads/Pages/downloads.aspx

Interesting - I had never seen that one. I usually go here for AMD stuff: http://support.amd.com/en-us/download
flipme
Hero Member
*****
Offline Offline

Activity: 547


View Profile
March 29, 2014, 12:34:30 PM
 #704

Yeah, changed nothing for me too.

Could swapping/buffering be a driver issue then?
Loading/unloading something for the chained algos?
I've looked thru changed files on the system and was astonished how much I/O fglrx actually does.

A peaceful place, or so it looks from space.
A closer look reveals the human race.
-John Barlow
flipme
Hero Member
*****
Offline Offline

Activity: 547


View Profile
March 29, 2014, 01:54:19 PM
 #705

I just started again with a fresh copy of BAMT 1.6.
It comes with an sgminer for X11, but it crashed.
But it showed temp and fanspeed.
Who made that version? Bit confusing already.

Now I installed yours and the one from badman and it runs but doesn't show temp/fanspeed... and has the 10% drop of course.
Gonna try BAMT 2 later on, with 64bit ubuntu.

A peaceful place, or so it looks from space.
A closer look reveals the human race.
-John Barlow
badman74
Hero Member
*****
Offline Offline

Activity: 532


View Profile
March 29, 2014, 02:07:34 PM
 #706

I just started again with a fresh copy of BAMT 1.6.
It comes with an sgminer for X11, but it crashed.
But it showed temp and fanspeed.
Who made that version? Bit confusing already.

Now I installed yours and the one from badman and it runs but doesn't show temp/fanspeed... and has the 10% drop of course.
Gonna try BAMT 2 later on, with 64bit ubuntu.
you need to put the adl drivers in /sgminer/ADL_SDK/
there is a readme in the folder telling you where to get them

flipme
Hero Member
*****
Offline Offline

Activity: 547


View Profile
March 29, 2014, 05:26:49 PM
 #707

I just started again with a fresh copy of BAMT 1.6.
It comes with an sgminer for X11, but it crashed.
But it showed temp and fanspeed.
Who made that version? Bit confusing already.

Now I installed yours and the one from badman and it runs but doesn't show temp/fanspeed... and has the 10% drop of course.
Gonna try BAMT 2 later on, with 64bit ubuntu.
you need to put the adl drivers in /sgminer/ADL_SDK/
there is a readme in the folder telling you where to get them

Thanks, it's even included in the BAMT 1.6 distro.
I recompiled and ran, and now it's crashing again after a minute!

A build without those headers runs stable.

A peaceful place, or so it looks from space.
A closer look reveals the human race.
-John Barlow
badman74
Hero Member
*****
Offline Offline

Activity: 532


View Profile
March 29, 2014, 05:39:07 PM
 #708

I just started again with a fresh copy of BAMT 1.6.
It comes with an sgminer for X11, but it crashed.
But it showed temp and fanspeed.
Who made that version? Bit confusing already.

Now I installed yours and the one from badman and it runs but doesn't show temp/fanspeed... and has the 10% drop of course.
Gonna try BAMT 2 later on, with 64bit ubuntu.
you need to put the adl drivers in /sgminer/ADL_SDK/
there is a readme in the folder telling you where to get them

Thanks, it's even included in the BAMT 1.6 distro.
I recompiled and ran, and now it's crashing again after a minute!

maybe your clocks or intensity is too high

n00bnoxious
Sr. Member
****
Offline Offline

Activity: 280

Bitnation Development Team Member


View Profile
March 29, 2014, 07:30:09 PM
 #709

I have this issue with ALL my 290x BAMT 1.6 rigs too.   They drop 200k+ after a few mins.   So, max I can get it to is 2.41 Mh/s.   Do you have any fixes or workaround for this yet that you have discovered?


Could I have opinion of specialist about my Problem? I suspect a bug of the programm because that'is the only thing I had not check, someone can tell me if it's possible?

I offer on the other topic 30 Darkcoin Bounty to solve that problem, a nobody has a clue, but I get in touch with other that had the same problem.

Here is the facts:
I have 3 different R9 290, other people has 6 290 of other brand, after 10 minutes, the cards looses 10% of Hash.
That probelm happend only on R9 290 cars.
I'm on Bamt 1.6 from Bajawa, He is on windows 7, same problem.
All 290 on the same rig experiment the loss in the exact same second
if you put another card in the rigg that is not a 290, all the 290 had a loss, but not the other card
The cards are cold.
The problem happenedonly with sph-darkcoin miner, if I mine Litecoin, I'm stable.
I split the cards with 2 PSU, does not change a thing, cards crashed at the same time, no matter what psu they are plugged.
I change motherboard, does not change a thing.
I run 4 different sgminer, each one with one card activated: even I did launch them with a delay of 3 minutes, 10 minutes later, all the instance with a 290 had a 10% lossat the same time
I launched sgminer without a .conf: only intensity in the parameters: happened with I:18 and I:21 (0% rejected, cards should worked with high intensity)
Once I got the loss only a cold reboot can recover the missing hash. If I mine restart only the miner, it restart but is capped to 90% of max hashrate.

I'm getting out of hints. If the problem is in the programm, I shoud stop wasting my time. If it is not, I will keep investigate, even if I think I already get pretty far.
PS: as usual, english is not my first languagae, so if I offensed any-one, it was not intended. Wink


I've not been following your problem since the start so can you confirm what intensity you're on? I noticed on my R9 280X cards that if I put I up too high, first of all I'd get an extra boost of power right at the start, but my stale shares went up hugely and then the speed dropped down to its previous level.

My suggestion is to run it on I13, and make sure that's stable for the entire time, then move up 1 at a time until you find the magical balance between speed and stability.

Let me know if this helps :-)
CryptoGretzky
Sr. Member
****
Offline Offline

Activity: 322



View Profile
March 29, 2014, 11:03:24 PM
 #710

So... this is on my Asus R9 290x Elphida flashed with the Stilt Bios running on PiMP 1.1 beta (64 bit BAMT)...  Motherboard is a Gigabyte GA-EP45-UD3P.

Don't know if it's coincidence or what yet, I will test it on another rig, but using PiMP, but so far, it hasn't dropped after many hours running on it....   getting around 2.78 Mh/s



Oh... forgot to mention that I already tested this version of sgminer 4.1.0-96-g983e on BAMT 1.6 running on Asrock H81 Pro BTC with, but that dropped after a few mins still.   Will post again after I test PiMP on another rig.


maniacmusic
Jr. Member
*
Offline Offline

Activity: 52


View Profile
March 29, 2014, 11:04:42 PM
 #711

I tried to use sph sgminer to mine Offerings (Cthulhu).... what value should I give to the -k option?? I tried -k quark, -k  quarkcoin and even --kernel-path kernel --kernel quarkcoin but sgminer won't start
Thanks..

EnTiTy77
Jr. Member
*
Offline Offline

Activity: 50


View Profile
March 29, 2014, 11:06:28 PM
 #712

I have this issue with ALL my 290x BAMT 1.6 rigs too.   They drop 200k+ after a few mins.   So, max I can get it to is 2.41 Mh/s.   Do you have any fixes or workaround for this yet that you have discovered?


Could I have opinion of specialist about my Problem? I suspect a bug of the programm because that'is the only thing I had not check, someone can tell me if it's possible?

I offer on the other topic 30 Darkcoin Bounty to solve that problem, a nobody has a clue, but I get in touch with other that had the same problem.

Here is the facts:
I have 3 different R9 290, other people has 6 290 of other brand, after 10 minutes, the cards looses 10% of Hash.
That probelm happend only on R9 290 cars.
I'm on Bamt 1.6 from Bajawa, He is on windows 7, same problem.
All 290 on the same rig experiment the loss in the exact same second
if you put another card in the rigg that is not a 290, all the 290 had a loss, but not the other card
The cards are cold.
The problem happenedonly with sph-darkcoin miner, if I mine Litecoin, I'm stable.
I split the cards with 2 PSU, does not change a thing, cards crashed at the same time, no matter what psu they are plugged.
I change motherboard, does not change a thing.
I run 4 different sgminer, each one with one card activated: even I did launch them with a delay of 3 minutes, 10 minutes later, all the instance with a 290 had a 10% lossat the same time
I launched sgminer without a .conf: only intensity in the parameters: happened with I:18 and I:21 (0% rejected, cards should worked with high intensity)
Once I got the loss only a cold reboot can recover the missing hash. If I mine restart only the miner, it restart but is capped to 90% of max hashrate.

I'm getting out of hints. If the problem is in the programm, I shoud stop wasting my time. If it is not, I will keep investigate, even if I think I already get pretty far.
PS: as usual, english is not my first languagae, so if I offensed any-one, it was not intended. Wink


I've not been following your problem since the start so can you confirm what intensity you're on? I noticed on my R9 280X cards that if I put I up too high, first of all I'd get an extra boost of power right at the start, but my stale shares went up hugely and then the speed dropped down to its previous level.

My suggestion is to run it on I13, and make sure that's stable for the entire time, then move up 1 at a time until you find the magical balance between speed and stability.

Let me know if this helps :-)

I did exactly what n00bnoxious did but with xintensity just to see what would happen. Using SPH-SGminer on Darkcoin with 3 R9 290.

Went all the way to 620 and they hash was good there although I was getting 400k/h swings up and down which isn't real stable and the computer would stop responding after 10-20 min which I have never seen before.Ended up on 410, swings were tighter but still there and for some reason the 3rd gpu would sit 200k/h below the other cards.


Decided to play with the GPU threads as on scrypt running 2 instead of 1 gets me an extra 20-30k/h per card. Started at 4 per card , went to 8 - no real change, went to 12 - WOW! Swinging gone! Cards stabilized on hashrate and no drop.

Give it a go.

boubou you can send the 30 darkcoin bounty to Xpw1MPT1Fuv2xcod9F7DcNo6jhnBHEQht9  Wink
boubou
Full Member
***
Offline Offline

Activity: 196


View Profile
March 29, 2014, 11:21:36 PM
 #713

I have this issue with ALL my 290x BAMT 1.6 rigs too.   They drop 200k+ after a few mins.   So, max I can get it to is 2.41 Mh/s.   Do you have any fixes or workaround for this yet that you have discovered?


Could I have opinion of specialist about my Problem? I suspect a bug of the programm because that'is the only thing I had not check, someone can tell me if it's possible?

I offer on the other topic 30 Darkcoin Bounty to solve that problem, a nobody has a clue, but I get in touch with other that had the same problem.

Here is the facts:
I have 3 different R9 290, other people has 6 290 of other brand, after 10 minutes, the cards looses 10% of Hash.
That probelm happend only on R9 290 cars.
I'm on Bamt 1.6 from Bajawa, He is on windows 7, same problem.
All 290 on the same rig experiment the loss in the exact same second
if you put another card in the rigg that is not a 290, all the 290 had a loss, but not the other card
The cards are cold.
The problem happenedonly with sph-darkcoin miner, if I mine Litecoin, I'm stable.
I split the cards with 2 PSU, does not change a thing, cards crashed at the same time, no matter what psu they are plugged.
I change motherboard, does not change a thing.
I run 4 different sgminer, each one with one card activated: even I did launch them with a delay of 3 minutes, 10 minutes later, all the instance with a 290 had a 10% lossat the same time
I launched sgminer without a .conf: only intensity in the parameters: happened with I:18 and I:21 (0% rejected, cards should worked with high intensity)
Once I got the loss only a cold reboot can recover the missing hash. If I mine restart only the miner, it restart but is capped to 90% of max hashrate.

I'm getting out of hints. If the problem is in the programm, I shoud stop wasting my time. If it is not, I will keep investigate, even if I think I already get pretty far.
PS: as usual, english is not my first languagae, so if I offensed any-one, it was not intended. Wink


I've not been following your problem since the start so can you confirm what intensity you're on? I noticed on my R9 280X cards that if I put I up too high, first of all I'd get an extra boost of power right at the start, but my stale shares went up hugely and then the speed dropped down to its previous level.

My suggestion is to run it on I13, and make sure that's stable for the entire time, then move up 1 at a time until you find the magical balance between speed and stability.

Let me know if this helps :-)

I did exactly what n00bnoxious did but with xintensity just to see what would happen. Using SPH-SGminer on Darkcoin with 3 R9 290.

Went all the way to 620 and they hash was good there although I was getting 400k/h swings up and down which isn't real stable and the computer would stop responding after 10-20 min which I have never seen before.Ended up on 410, swings were tighter but still there and for some reason the 3rd gpu would sit 200k/h below the other cards.


Decided to play with the GPU threads as on scrypt running 2 instead of 1 gets me an extra 20-30k/h per card. Started at 4 per card , went to 8 - no real change, went to 12 - WOW! Swinging gone! Cards stabilized on hashrate and no drop.

Give it a go.

boubou you can send the 30 darkcoin bounty to Xpw1MPT1Fuv2xcod9F7DcNo6jhnBHEQht9  Wink

I just went back home...

Are you serious?

I planned to go to bed but I have to try that before. Smiley
So gpu-thread 12 same intensity (21)?
I check that right now.

EDIT: the line should be "gpu-thread": "12",
It does not seems to work, i don't seemore threads.

BEHNZiP6UZunp41vurNaQi4r2hvgG57yzi : BdG
boubou
Full Member
***
Offline Offline

Activity: 196


View Profile
March 29, 2014, 11:23:54 PM
 #714

So... this is on my Asus R9 290x Elphida flashed with the Stilt Bios running on PiMP 1.1 beta (64 bit BAMT)...  Motherboard is a Gigabyte GA-EP45-UD3P.

Don't know if it's coincidence or what yet, I will test it on another rig, but using PiMP, but so far, it hasn't dropped after many hours running on it....   getting around 2.78 Mh/s



Oh... forgot to mention that I already tested this version of sgminer 4.1.0-96-g983e on BAMT 1.6 running on Asrock H81 Pro BTC with, but that dropped after a few mins still.   Will post again after I test PiMP on another rig.


Have you got a link to your bamt image that you are using?

BEHNZiP6UZunp41vurNaQi4r2hvgG57yzi : BdG
CryptoGretzky
Sr. Member
****
Offline Offline

Activity: 322



View Profile
March 29, 2014, 11:27:56 PM
 #715

So... this is on my Asus R9 290x Elphida flashed with the Stilt Bios running on PiMP 1.1 beta (64 bit BAMT)...  Motherboard is a Gigabyte GA-EP45-UD3P.

Don't know if it's coincidence or what yet, I will test it on another rig, but using PiMP, but so far, it hasn't dropped after many hours running on it....   getting around 2.78 Mh/s



Oh... forgot to mention that I already tested this version of sgminer 4.1.0-96-g983e on BAMT 1.6 running on Asrock H81 Pro BTC with, but that dropped after a few mins still.   Will post again after I test PiMP on another rig.


Have you got a link to your bamt image that you are using?

http://getpimp.org/   

It's by the same guys (Bee) that made the older 1.3-1.5 Bamt https://litecointalk.org/index.php?topic=2924.0

EnTiTy77
Jr. Member
*
Offline Offline

Activity: 50


View Profile
March 29, 2014, 11:31:59 PM
 #716


I just went back home...

Are you serious?

I planned to go to bed but I have to try that before. Smiley
So gpu-thread 12 same intensity (21)?
I check that right now.

Intensity doesn't seem to make any difference after 20 when you have high gpu threads for some reason.

But yeah same intensity, higher threads.
CryptoGretzky
Sr. Member
****
Offline Offline

Activity: 322



View Profile
March 29, 2014, 11:36:42 PM
 #717


I just went back home...

Are you serious?

I planned to go to bed but I have to try that before. Smiley
So gpu-thread 12 same intensity (21)?
I check that right now.

Intensity doesn't seem to make any difference after 20 when you have high gpu threads for some reason.

But yeah same intensity, higher threads.

Can you please post your full conf file?

EnTiTy77
Jr. Member
*
Offline Offline

Activity: 50


View Profile
March 29, 2014, 11:41:09 PM
 #718

]
,
"intensity" : "0,0,0",
"xintensity" : "410,410,410",
"rawintensity" : "0,0,0",
"worksize" : "128,128,128",
"kernel" : "darkcoin,darkcoin,darkcoin",
"lookup-gap" : "2,2,2",
"thread-concurrency" : "25601,25601,25601",
"shaders" : "0,0,0",
"gpu-threads" : "12,12,12",
"gpu-engine" : "900-1000,900-1040,900-1000",
"gpu-fan" : "0-85,0-85,0-85",
"gpu-memclock" : "1375,1500,1375",
"gpu-memdiff" : "0,0,0",
"gpu-powertune" : "20,20,20",
"gpu-vddc" : "0.000,0.000,0.000",
"temp-cutoff" : "95,95,95",
"temp-overheat" : "85,85,85",
"temp-target" : "75,75,75",
"api-mcast-port" : "4028",
"api-port" : "4028",
"auto-fan" : true,
"auto-gpu" : true,
"expiry" : "28",
"failover-switch-delay" : "60",
"gpu-dyninterval" : "7",
"gpu-platform" : "1",
"cl-filename" : "scryptR9290,scryptR9290,scryptR9290",
"log" : "5",
"no-pool-disable" : true,
"queue" : "1",
"scan-time" : "7",
"tcp-keepalive" : "30",
"temp-hysteresis" : "3",
"shares" : "0",
"kernel-path" : "/usr/local/bin",
"no-submit-stale" : true
}
HooDude
Jr. Member
*
Offline Offline

Activity: 55


View Profile
March 29, 2014, 11:48:36 PM
 #719

I have this issue with ALL my 290x BAMT 1.6 rigs too.   They drop 200k+ after a few mins.   So, max I can get it to is 2.41 Mh/s.   Do you have any fixes or workaround for this yet that you have discovered?


Could I have opinion of specialist about my Problem? I suspect a bug of the programm because that'is the only thing I had not check, someone can tell me if it's possible?

I offer on the other topic 30 Darkcoin Bounty to solve that problem, a nobody has a clue, but I get in touch with other that had the same problem.

Here is the facts:
I have 3 different R9 290, other people has 6 290 of other brand, after 10 minutes, the cards looses 10% of Hash.
That probelm happend only on R9 290 cars.
I'm on Bamt 1.6 from Bajawa, He is on windows 7, same problem.
All 290 on the same rig experiment the loss in the exact same second
if you put another card in the rigg that is not a 290, all the 290 had a loss, but not the other card
The cards are cold.
The problem happenedonly with sph-darkcoin miner, if I mine Litecoin, I'm stable.
I split the cards with 2 PSU, does not change a thing, cards crashed at the same time, no matter what psu they are plugged.
I change motherboard, does not change a thing.
I run 4 different sgminer, each one with one card activated: even I did launch them with a delay of 3 minutes, 10 minutes later, all the instance with a 290 had a 10% lossat the same time
I launched sgminer without a .conf: only intensity in the parameters: happened with I:18 and I:21 (0% rejected, cards should worked with high intensity)
Once I got the loss only a cold reboot can recover the missing hash. If I mine restart only the miner, it restart but is capped to 90% of max hashrate.

I'm getting out of hints. If the problem is in the programm, I shoud stop wasting my time. If it is not, I will keep investigate, even if I think I already get pretty far.
PS: as usual, english is not my first languagae, so if I offensed any-one, it was not intended. Wink


I've not been following your problem since the start so can you confirm what intensity you're on? I noticed on my R9 280X cards that if I put I up too high, first of all I'd get an extra boost of power right at the start, but my stale shares went up hugely and then the speed dropped down to its previous level.

My suggestion is to run it on I13, and make sure that's stable for the entire time, then move up 1 at a time until you find the magical balance between speed and stability.

Let me know if this helps :-)

I did exactly what n00bnoxious did but with xintensity just to see what would happen. Using SPH-SGminer on Darkcoin with 3 R9 290.

Went all the way to 620 and they hash was good there although I was getting 400k/h swings up and down which isn't real stable and the computer would stop responding after 10-20 min which I have never seen before.Ended up on 410, swings were tighter but still there and for some reason the 3rd gpu would sit 200k/h below the other cards.


Decided to play with the GPU threads as on scrypt running 2 instead of 1 gets me an extra 20-30k/h per card. Started at 4 per card , went to 8 - no real change, went to 12 - WOW! Swinging gone! Cards stabilized on hashrate and no drop.

Give it a go.

boubou you can send the 30 darkcoin bounty to Xpw1MPT1Fuv2xcod9F7DcNo6jhnBHEQht9  Wink

This worked wonders for me. I can't get --gpu-threads 12,12 in my .bat to work (SGminer says its an invalid argument) but when I used --gpu-threads 8,8 it brought my hashrate up significantly on my R9 290x Tri-X's. The hashrate still fluctuates a fair bit, but on average it is much higher.

Darkcoin. Private - Secure - Innovative. See what the other coins have been talking about:  http://www.darkcoin.io/
badman74
Hero Member
*****
Offline Offline

Activity: 532


View Profile
March 29, 2014, 11:56:10 PM
 #720

I have this issue with ALL my 290x BAMT 1.6 rigs too.   They drop 200k+ after a few mins.   So, max I can get it to is 2.41 Mh/s.   Do you have any fixes or workaround for this yet that you have discovered?


Could I have opinion of specialist about my Problem? I suspect a bug of the programm because that'is the only thing I had not check, someone can tell me if it's possible?

I offer on the other topic 30 Darkcoin Bounty to solve that problem, a nobody has a clue, but I get in touch with other that had the same problem.

Here is the facts:
I have 3 different R9 290, other people has 6 290 of other brand, after 10 minutes, the cards looses 10% of Hash.
That probelm happend only on R9 290 cars.
I'm on Bamt 1.6 from Bajawa, He is on windows 7, same problem.
All 290 on the same rig experiment the loss in the exact same second
if you put another card in the rigg that is not a 290, all the 290 had a loss, but not the other card
The cards are cold.
The problem happenedonly with sph-darkcoin miner, if I mine Litecoin, I'm stable.
I split the cards with 2 PSU, does not change a thing, cards crashed at the same time, no matter what psu they are plugged.
I change motherboard, does not change a thing.
I run 4 different sgminer, each one with one card activated: even I did launch them with a delay of 3 minutes, 10 minutes later, all the instance with a 290 had a 10% lossat the same time
I launched sgminer without a .conf: only intensity in the parameters: happened with I:18 and I:21 (0% rejected, cards should worked with high intensity)
Once I got the loss only a cold reboot can recover the missing hash. If I mine restart only the miner, it restart but is capped to 90% of max hashrate.

I'm getting out of hints. If the problem is in the programm, I shoud stop wasting my time. If it is not, I will keep investigate, even if I think I already get pretty far.
PS: as usual, english is not my first languagae, so if I offensed any-one, it was not intended. Wink


I've not been following your problem since the start so can you confirm what intensity you're on? I noticed on my R9 280X cards that if I put I up too high, first of all I'd get an extra boost of power right at the start, but my stale shares went up hugely and then the speed dropped down to its previous level.

My suggestion is to run it on I13, and make sure that's stable for the entire time, then move up 1 at a time until you find the magical balance between speed and stability.

Let me know if this helps :-)

I did exactly what n00bnoxious did but with xintensity just to see what would happen. Using SPH-SGminer on Darkcoin with 3 R9 290.

Went all the way to 620 and they hash was good there although I was getting 400k/h swings up and down which isn't real stable and the computer would stop responding after 10-20 min which I have never seen before.Ended up on 410, swings were tighter but still there and for some reason the 3rd gpu would sit 200k/h below the other cards.


Decided to play with the GPU threads as on scrypt running 2 instead of 1 gets me an extra 20-30k/h per card. Started at 4 per card , went to 8 - no real change, went to 12 - WOW! Swinging gone! Cards stabilized on hashrate and no drop.

Give it a go.

boubou you can send the 30 darkcoin bounty to Xpw1MPT1Fuv2xcod9F7DcNo6jhnBHEQht9  Wink

This worked wonders for me. I can't get --gpu-threads 12,12 in my .bat to work (SGminer says its an invalid argument) but when I used --gpu-threads 8,8 it brought my hashrate up significantly on my R9 290x Tri-X's. The hashrate still fluctuates a fair bit, but on average it is much higher.
max threads is set at 10

Code:
char *set_gpu_threads(char *arg)
{
int i, val = 1, device = 0;
char *nextptr;

nextptr = strtok(arg, ",");
if (nextptr == NULL)
return "Invalid parameters for set_gpu_threads";
val = atoi(nextptr);
if (val < 1 || val > 10)
return "Invalid value passed to set_gpu_threads";

gpus[device++].threads = val;

while ((nextptr = strtok(NULL, ",")) != NULL) {
val = atoi(nextptr);
if (val < 1 || val > 10)
return "Invalid value passed to set_gpu_threads";

gpus[device++].threads = val;
}
if (device == 1) {
for (i = device; i < MAX_GPUDEVICES; i++)
gpus[i].threads = gpus[0].threads;
}

return NULL;
}
in driver-opencl.c

Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 [36] 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!