Bitcoin Forum
June 29, 2017, 12:40:51 AM *
News: Latest stable version of Bitcoin Core: 0.14.2  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 [37] 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 »
  Print  
Author Topic: [ANN] sph-sgminer: multi-coin multi-algorithm GPU miner | added MaruCoin  (Read 473030 times)
CryptoGretzky
Sr. Member
****
Offline Offline

Activity: 322



View Profile
March 29, 2014, 11:58:37 PM
 #721

Ok, on my other rig, I got PiMP running and this is the result after a few mins (all are Sapphire Tri-X 290x on  Asrock H81 Pro BTC):



GPU 0, 1, 2 are from a newer batch.   GPU 3 is an older one where I couldn't get it stable until I flashed it with the bios that I ripped from the newer GPU.

Noticed the first 2 that the temp/fan speed can be read dropped after a few mins back to 2.4 Mh?

GPU 2,3 temp couldn't be read for some reason and they stayed up at 2.78-2.8 Mh.

So... I am thinking that auto-gpu is throttling it back.   Temperature is quite low though...  my temp-target is 75.  Let me test temp-target with 80.

1498696851
Hero Member
*
Offline Offline

Posts: 1498696851

View Profile Personal Message (Offline)

Ignore
1498696851
Reply with quote  #2

1498696851
Report to moderator
Join the Crowdfunding Revolution ►► FundYourselfNow.com ◄◄ Crowdsale with
attractive rewards
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1498696851
Hero Member
*
Offline Offline

Posts: 1498696851

View Profile Personal Message (Offline)

Ignore
1498696851
Reply with quote  #2

1498696851
Report to moderator
1498696851
Hero Member
*
Offline Offline

Posts: 1498696851

View Profile Personal Message (Offline)

Ignore
1498696851
Reply with quote  #2

1498696851
Report to moderator
cinnamon_carter
Legendary
*
Offline Offline

Activity: 1106


It's about time


View Profile WWW
March 30, 2014, 12:03:23 AM
 #722

First I want to say I think this project has been well done adding support for many coins.

I noticed you have support for Quark.

Is it possible future development could add support for Simple Inflation Coin which is the father of Quark, secure and all similar clones

Simple Inflation Coin is slightly different in that it has just the 6 algo's rounds thus the quark miner will not just work out of the box for obvious reasons.

Here is the original launch thread of SIF  https://bitcointalk.org/index.php?PHPSESSID=fhfogsq68mludm4ip82ar2c8c0&topic=240894.0;all

ocminer has another thread here he put up for his pool and cloud mining https://bitcointalk.org/index.php?topic=404215.0


A little harder to follow since I don't speak/read Russian is the original launch thread of the coin here

https://bitcointalk.org/index.php?topic=240884.0


The english thread was not well 'organized' and originally did not contain the source code which is here

http://sourceforge.net/p/sifcoin/code/ci/master/tree/

and on github here https://github.com/sifcoin/sifcoin

Finally here is the source code to the most efficient cpu miner currently available to my knowledge

https://github.com/ig0tik3d/sifcoin-miner


SIC is not traded on any exchanges yet it has been running since last summer and everytime I check it there are always lots of nodes availalbe.

Difficulty goes up and down a little peaking most last October when there was a rumor it was to be added to BTCE for trading

and an even larger peak in difficulty a few months back when the optimized miner became available.

I hope you will consider it.

I hope others in the 'small' community of supporters of the coin would join me in a donation to you for your efforts if you ever have time.

Regards.....




Check out my coin Photon
Merge Mine 5 other Blake 256 coins - 6x your hash power  https://www.blakecoin.org/

The obvious choice is not always the best choice.

LOOK DEEPER - Look into the Blake 256 Family -- CC
EnTiTy77
Jr. Member
*
Offline Offline

Activity: 50


View Profile
March 30, 2014, 12:09:03 AM
 #723

I know 12 threads aren't being engaged.

But it is stabilizing the hashrate  Smiley
Gezellig4Geld
Newbie
*
Offline Offline

Activity: 13


View Profile
March 30, 2014, 12:11:55 AM
 #724


I figured it out for those who may have the same issue.. I was using 13.1 drivers because I have 6 cards, well I modded the 13.12 drivers to allow 6 cards, and now the Sgminer works fine with the new drivers..

PM me if somebody wants the modded INF file.


I could use that modded INF files as I am having the same issues with 6 x GPU (7950) on a WIN 8.1 system.  The 13.12 work fine for 5 GPU's but the 6th card does not and I have the error in device manager (code 43).  Only the tech Power Up 13.1 drivers will work for 6 GPU's but not for X11 coins.  I get HW errors and no accepted shares.  Right now I am using the 13.12 drivers with the 5GPU's and can mine Scrypt, Scrypt-N or X11 without any errors.  Sent you a PM in case you do not see this message.  I could definitely use a modded INF file to get the 6th card working with the latest 13.12 drivers.
CryptoGretzky
Sr. Member
****
Offline Offline

Activity: 322



View Profile
March 30, 2014, 12:18:10 AM
 #725

I know 12 threads aren't being engaged.

But it is stabilizing the hashrate  Smiley


The code shows that your thread is actually back to 1 if you set it to an invalid  gpu-thread count.  So, if you set your thread back to 1, you will have exactly the same result.

CryptoGretzky
Sr. Member
****
Offline Offline

Activity: 322



View Profile
March 30, 2014, 01:03:32 AM
 #726

Ok, on my other rig, I got PiMP running and this is the result after a few mins (all are Sapphire Tri-X 290x on  Asrock H81 Pro BTC):



GPU 0, 1, 2 are from a newer batch.   GPU 3 is an older one where I couldn't get it stable until I flashed it with the bios that I ripped from the newer GPU.

Noticed the first 2 that the temp/fan speed can be read dropped after a few mins back to 2.4 Mh?

GPU 2,3 temp couldn't be read for some reason and they stayed up at 2.78-2.8 Mh.

So... I am thinking that auto-gpu is throttling it back.   Temperature is quite low though...  my temp-target is 75.  Let me test temp-target with 80.



After I did a sudo aticonfig --adapter=all --initial -f,  it recogznied all 4 adapters.

I also changed auto-gpu to false and temp-target to 80.   On reboot, it started out at 2.6 Mh/s.

Once it hit temp-target, it dropped ALL GPU down to 2.38 Mh...   I don't know what else I can do to get it to hold at that initial hash.   Anyone have any ideas?

mfqrs3
Sr. Member
****
Offline Offline

Activity: 386


View Profile
March 30, 2014, 01:32:07 AM
 #727

I know 12 threads aren't being engaged.

But it is stabilizing the hashrate  Smiley


I have tyed that, and hashrate went from 2.4 to almost 3, BUT avg/max hashrate doesn't change, also pool is not registering more hashes.
EnTiTy77
Jr. Member
*
Offline Offline

Activity: 50


View Profile
March 30, 2014, 01:39:13 AM
 #728

I know 12 threads aren't being engaged.

But it is stabilizing the hashrate  Smiley


The code shows that your thread is actually back to 1 if you set it to an invalid  gpu-thread count.  So, if you set your thread back to 1, you will have exactly the same result.

Yup, your right  Tongue

Best I leave the advising to the professionals lol

Still... stops the drop on my rig and with the low memory usage the engine clock seems to have a bit more room for tweaking. At 1060 on the core 290's. Couldn't even get to 1000 on scrypt.
badman74
Hero Member
*****
Offline Offline

Activity: 532


View Profile
March 30, 2014, 02:00:26 AM
 #729

Ok, on my other rig, I got PiMP running and this is the result after a few mins (all are Sapphire Tri-X 290x on  Asrock H81 Pro BTC):



GPU 0, 1, 2 are from a newer batch.   GPU 3 is an older one where I couldn't get it stable until I flashed it with the bios that I ripped from the newer GPU.

Noticed the first 2 that the temp/fan speed can be read dropped after a few mins back to 2.4 Mh?

GPU 2,3 temp couldn't be read for some reason and they stayed up at 2.78-2.8 Mh.

So... I am thinking that auto-gpu is throttling it back.   Temperature is quite low though...  my temp-target is 75.  Let me test temp-target with 80.



After I did a sudo aticonfig --adapter=all --initial -f,  it recogznied all 4 adapters.

I also changed auto-gpu to false and temp-target to 80.   On reboot, it started out at 2.6 Mh/s.

Once it hit temp-target, it dropped ALL GPU down to 2.38 Mh...   I don't know what else I can do to get it to hold at that initial hash.   Anyone have any ideas?

try auto-fan
if that don't work try setting your fanspeed so it doesn't reach the temp target
for some reason it seems like disabling auto-gpu doesn't work right

CryptoGretzky
Sr. Member
****
Offline Offline

Activity: 322



View Profile
March 30, 2014, 02:03:17 AM
 #730

try auto-fan
if that don't work try setting your fanspeed so it doesn't reach the temp target
for some reason it seems like disabling auto-gpu doesn't work right

I already have my auto-fan as true.   Do you mean set it to false?

This is what I have as my conf already:

"api-allow" : "W:127.0.0.1,W:192.168.1.2",
"api-listen" : true,
"failover-only" : true,
"log" : "5",
"no-submit-stale": false,
"queue" : "0",
"scan-time" : "1",
"expiry" : "12",
"auto-fan" : true,
"auto-gpu" : false,
"gpu-threads" : "1",
"gpu-engine" : "1025,1025,1025,1025,1025",
"gpu-fan" : "35-100",
"gpu-memclock" : "1400,1400,1400,1400,1400",
"gpu-powertune" : "20",
"gpu-vddc" : "1.20",
"intensity" : "22",
"temp-target" : "80",
"temp-overheat" : "89",
"temp-cutoff" : "94",
"vectors" : "1",
"worksize" : "256",
"lookup-gap" : "2",
"shaders" : "2816",
"thread-concurrency" : "27000",

EnTiTy77
Jr. Member
*
Offline Offline

Activity: 50


View Profile
March 30, 2014, 02:39:36 AM
 #731

Could be your vddc. try setting it to 0.000
and see if that makes a difference.
HooDude
Jr. Member
*
Offline Offline

Activity: 55


View Profile
March 30, 2014, 02:49:16 AM
 #732

Im finding now that if I have the threads up at 10,10 or even 8,8 on my pair of R9 290x I get a ton of stale shares. Anyone else having this?

Darkcoin. Private - Secure - Innovative. See what the other coins have been talking about:  http://www.darkcoin.io/
badman74
Hero Member
*****
Offline Offline

Activity: 532


View Profile
March 30, 2014, 02:59:03 AM
 #733

try auto-fan
if that don't work try setting your fanspeed so it doesn't reach the temp target
for some reason it seems like disabling auto-gpu doesn't work right

I already have my auto-fan as true.   Do you mean set it to false?

This is what I have as my conf already:

"api-allow" : "W:127.0.0.1,W:192.168.1.2",
"api-listen" : true,
"failover-only" : true,
"log" : "5",
"no-submit-stale": false,
"queue" : "0",
"scan-time" : "1",
"expiry" : "12",
"auto-fan" : true,
"auto-gpu" : false,
"gpu-threads" : "1",
"gpu-engine" : "1025,1025,1025,1025,1025",
"gpu-fan" : "35-100",
"gpu-memclock" : "1400,1400,1400,1400,1400",
"gpu-powertune" : "20",
"gpu-vddc" : "1.20",
"intensity" : "22",
"temp-target" : "80",
"temp-overheat" : "89",
"temp-cutoff" : "94",
"vectors" : "1",
"worksize" : "256",
"lookup-gap" : "2",
"shaders" : "2816",
"thread-concurrency" : "27000",
maybe try "gpu-fan" : "50-100",
or higher...
just to keep from hitting temp-target

DemetriusAstroBlack
Sr. Member
****
Offline Offline

Activity: 320


View Profile
March 30, 2014, 03:06:41 AM
 #734

I had weird issues with sgh sgminer and temps/fans as well.  I had to set fan range at 20-85 auto-gpu true, and change the temp target to 62.  My cofig file is as follows:

{
"pools" : [
   {
      "url" : "stratum+tcp://stratum1.suchpool.pw:3335",
      "user" : "EDITED",
      "pass" : "x"
   },
   {
      "url" : "stratum+tcp://stratum2.suchpool.pw:3335",
      "user" : "EDITED",
      "pass" : "x"
   },
   {
      "url" : "stratum+tcp://stratum.forkpool.com:6347",
      "user" : "EDITED",
      "pass" : "x"
   }
]
,
"intensity" : "13,13,18",
"worksize" : "256,256,256",
"gpu-threads" : "2,2,1",
"thread-concurrency" : "8192,8192,15232",
"kernel" : "darkcoin,darkcoin,darkcoin",
"gpu-engine" : "500-1075,500-1075,500-1150",
"gpu-fan" : "20-85,20-85,20-85",
"gpu-memclock" : "1450,1450,1500",
"auto-gpu" : true,
"auto-fan" : true,
"temp-cutoff" : "85,85,85",
"temp-overheat" : "80,80,80",
"temp-target" : "62,62,62",

"kernel-path" : "/usr/local/bin"
}

Tip me BTC: 1MQ3JmX3xsnQqwEu7MB75GwxMtzKxJm4ha
CryptoGretzky
Sr. Member
****
Offline Offline

Activity: 322



View Profile
March 30, 2014, 03:19:15 AM
 #735

try auto-fan
if that don't work try setting your fanspeed so it doesn't reach the temp target
for some reason it seems like disabling auto-gpu doesn't work right

I already have my auto-fan as true.   Do you mean set it to false?

This is what I have as my conf already:

"api-allow" : "W:127.0.0.1,W:192.168.1.2",
"api-listen" : true,
"failover-only" : true,
"log" : "5",
"no-submit-stale": false,
"queue" : "0",
"scan-time" : "1",
"expiry" : "12",
"auto-fan" : true,
"auto-gpu" : false,
"gpu-threads" : "1",
"gpu-engine" : "1025,1025,1025,1025,1025",
"gpu-fan" : "35-100",
"gpu-memclock" : "1400,1400,1400,1400,1400",
"gpu-powertune" : "20",
"gpu-vddc" : "1.20",
"intensity" : "22",
"temp-target" : "80",
"temp-overheat" : "89",
"temp-cutoff" : "94",
"vectors" : "1",
"worksize" : "256",
"lookup-gap" : "2",
"shaders" : "2816",
"thread-concurrency" : "27000",
maybe try "gpu-fan" : "50-100",
or higher...
just to keep from hitting temp-target


I set auto-fan to false, gpu-fan to 80-100.   It never hit the temp-target, but it STILL dropped in hash after a few mins.  argh.   The only way to make it not drop was when my gpu wasn't detected...   this is insanity....

badman74
Hero Member
*****
Offline Offline

Activity: 532


View Profile
March 30, 2014, 03:42:09 AM
 #736

try auto-fan
if that don't work try setting your fanspeed so it doesn't reach the temp target
for some reason it seems like disabling auto-gpu doesn't work right

I already have my auto-fan as true.   Do you mean set it to false?

This is what I have as my conf already:

"api-allow" : "W:127.0.0.1,W:192.168.1.2",
"api-listen" : true,
"failover-only" : true,
"log" : "5",
"no-submit-stale": false,
"queue" : "0",
"scan-time" : "1",
"expiry" : "12",
"auto-fan" : true,
"auto-gpu" : false,
"gpu-threads" : "1",
"gpu-engine" : "1025,1025,1025,1025,1025",
"gpu-fan" : "35-100",
"gpu-memclock" : "1400,1400,1400,1400,1400",
"gpu-powertune" : "20",
"gpu-vddc" : "1.20",
"intensity" : "22",
"temp-target" : "80",
"temp-overheat" : "89",
"temp-cutoff" : "94",
"vectors" : "1",
"worksize" : "256",
"lookup-gap" : "2",
"shaders" : "2816",
"thread-concurrency" : "27000",
maybe try "gpu-fan" : "50-100",
or higher...
just to keep from hitting temp-target


I set auto-fan to false, gpu-fan to 80-100.   It never hit the temp-target, but it STILL dropped in hash after a few mins.  argh.   The only way to make it not drop was when my gpu wasn't detected...   this is insanity....
well... you could try setting your clocks with sapphire trixx or the equivalent then running with --no-adl
you can also start it normally top set the clock then restart it with --no-adl

CryptoGretzky
Sr. Member
****
Offline Offline

Activity: 322



View Profile
March 30, 2014, 04:03:38 AM
 #737

try auto-fan
if that don't work try setting your fanspeed so it doesn't reach the temp target
for some reason it seems like disabling auto-gpu doesn't work right

I already have my auto-fan as true.   Do you mean set it to false?

This is what I have as my conf already:

"api-allow" : "W:127.0.0.1,W:192.168.1.2",
"api-listen" : true,
"failover-only" : true,
"log" : "5",
"no-submit-stale": false,
"queue" : "0",
"scan-time" : "1",
"expiry" : "12",
"auto-fan" : true,
"auto-gpu" : false,
"gpu-threads" : "1",
"gpu-engine" : "1025,1025,1025,1025,1025",
"gpu-fan" : "35-100",
"gpu-memclock" : "1400,1400,1400,1400,1400",
"gpu-powertune" : "20",
"gpu-vddc" : "1.20",
"intensity" : "22",
"temp-target" : "80",
"temp-overheat" : "89",
"temp-cutoff" : "94",
"vectors" : "1",
"worksize" : "256",
"lookup-gap" : "2",
"shaders" : "2816",
"thread-concurrency" : "27000",
maybe try "gpu-fan" : "50-100",
or higher...
just to keep from hitting temp-target


I set auto-fan to false, gpu-fan to 80-100.   It never hit the temp-target, but it STILL dropped in hash after a few mins.  argh.   The only way to make it not drop was when my gpu wasn't detected...   this is insanity....
well... you could try setting your clocks with sapphire trixx or the equivalent then running with --no-adl
you can also start it normally top set the clock then restart it with --no-adl

How do I set the clock outside of sgminer in Linux?  Or, did you mean run sgminer, let it set the OC, then stop it, and restart with --no-adl.   I did that, now none of the temp and fan are showing.   But, even I did that, after a few mins, all the GPU still dropped from 2.6 back down to 2.3...  argh...

badman74
Hero Member
*****
Offline Offline

Activity: 532


View Profile
March 30, 2014, 04:15:03 AM
 #738

try auto-fan
if that don't work try setting your fanspeed so it doesn't reach the temp target
for some reason it seems like disabling auto-gpu doesn't work right

I already have my auto-fan as true.   Do you mean set it to false?

This is what I have as my conf already:

"api-allow" : "W:127.0.0.1,W:192.168.1.2",
"api-listen" : true,
"failover-only" : true,
"log" : "5",
"no-submit-stale": false,
"queue" : "0",
"scan-time" : "1",
"expiry" : "12",
"auto-fan" : true,
"auto-gpu" : false,
"gpu-threads" : "1",
"gpu-engine" : "1025,1025,1025,1025,1025",
"gpu-fan" : "35-100",
"gpu-memclock" : "1400,1400,1400,1400,1400",
"gpu-powertune" : "20",
"gpu-vddc" : "1.20",
"intensity" : "22",
"temp-target" : "80",
"temp-overheat" : "89",
"temp-cutoff" : "94",
"vectors" : "1",
"worksize" : "256",
"lookup-gap" : "2",
"shaders" : "2816",
"thread-concurrency" : "27000",
maybe try "gpu-fan" : "50-100",
or higher...
just to keep from hitting temp-target


I set auto-fan to false, gpu-fan to 80-100.   It never hit the temp-target, but it STILL dropped in hash after a few mins.  argh.   The only way to make it not drop was when my gpu wasn't detected...   this is insanity....
well... you could try setting your clocks with sapphire trixx or the equivalent then running with --no-adl
you can also start it normally top set the clock then restart it with --no-adl

How do I set the clock outside of sgminer in Linux?  Or, did you mean run sgminer, let it set the OC, then stop it, and restart with --no-adl.   I did that, now none of the temp and fan are showing.   But, even I did that, after a few mins, all the GPU still dropped from 2.6 back down to 2.3...  argh...
i am pretty much out of ideas now....

CryptoGretzky
Sr. Member
****
Offline Offline

Activity: 322



View Profile
March 30, 2014, 04:36:52 AM
 #739


How do I set the clock outside of sgminer in Linux?  Or, did you mean run sgminer, let it set the OC, then stop it, and restart with --no-adl.   I did that, now none of the temp and fan are showing.   But, even I did that, after a few mins, all the GPU still dropped from 2.6 back down to 2.3...  argh...
i am pretty much out of ideas now....

One interesting note is that for that earlier config where it couldn't detect temperature, but could detect fan, the setting in the xorg.conf had this following section (only 3 GPU detected):

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[1]-0"
        Driver      "fglrx"
        BusID       "PCI:2:0:0"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[2]-0"
        Driver      "fglrx"
        BusID       "PCI:7:0:0"
EndSection

Well, my cards weren't plugged into the PCI:7:0:0.   They were plugged into the 1, 2, 5, 6.   So, somehow when it detected it as PCI:7:0:0, it gave me fan detection, but not temp, but it could hash at 2.8 Mh/s without issue and without dropping.

janos666
Hero Member
*****
Offline Offline

Activity: 560


View Profile
March 30, 2014, 06:22:57 AM
 #740

I have the same problem with my 290(X)s and DarkCoin: unstable hashrate with a dropping average.

I tried to set gpu-threads from 1 to 8 and it's doesn't actually help. The 1s average seems to be significantly higher, but the real average remains the same and WU seems to drop!
Also, starting with 10 threads causes instant system-wide crash (no reboot via ssh, I have to manually flip the power switch in the garage).
And 4 or 2 threads doesn't make any real (measurable/significant) difference compared to 1 (it never did for my 290(X)s with any miner/algo/bios/clocks/etc, may be caused a slightly lower WU).

Setting lookup-gap to 1 from 2 doesn't cause any significant difference (it almost halves my hashrate with scrypt).

Setting thread-concurrency to 0.5x or 2x (the latter requires lookup-gap >=2) of my default 20480 doesn't help either.



By the way. I saw many people using worksize 512 even though it's actually maxed at 256 in every cgminer variants I know.
May be somebody should actually make that usable.
If it's as simple as changing the limit in the source then could you please point to the right file and the line number?
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 [37] 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!