Bitcoin Forum
June 27, 2019, 03:28:12 AM *
News: Latest Bitcoin Core release: 0.18.0 [Torrent] (New!)
 
   Home   Help Search Login Register More  
Pages: « 1 2 3 4 5 6 7 8 9 10 [11] 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 »
  Print  
Author Topic: [UPDATE] RX480 (Ref) 31+Mh, Custom Rom - VDDC OFFSET + Custom timing  (Read 229989 times)
citronick
Legendary
*
Offline Offline

Activity: 1344
Merit: 1043


---- winter*juvia -----


View Profile
August 29, 2016, 04:17:04 AM
 #201

thanks for the pointers Eliovp and jmumich -- will put this in the checklist.

Btw, Eliovp, your rom zip links seems bad, is there a folder in yoru website to download ROM files?

If I provided you good and useful info or just bring a smile to your day, consider sending me merit points to further validate this Bitcointalk account ~ useful for future account recovery...
1561606092
Hero Member
*
Offline Offline

Posts: 1561606092

View Profile Personal Message (Offline)

Ignore
1561606092
Reply with quote  #2

1561606092
Report to moderator
1561606092
Hero Member
*
Offline Offline

Posts: 1561606092

View Profile Personal Message (Offline)

Ignore
1561606092
Reply with quote  #2

1561606092
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1561606092
Hero Member
*
Offline Offline

Posts: 1561606092

View Profile Personal Message (Offline)

Ignore
1561606092
Reply with quote  #2

1561606092
Report to moderator
1561606092
Hero Member
*
Offline Offline

Posts: 1561606092

View Profile Personal Message (Offline)

Ignore
1561606092
Reply with quote  #2

1561606092
Report to moderator
Eliovp
Legendary
*
Offline Offline

Activity: 1020
Merit: 1245

Huh?


View Profile
August 29, 2016, 07:12:49 AM
 #202

thanks for the pointers Eliovp and jmumich -- will put this in the checklist.

Btw, Eliovp, your rom zip links seems bad, is there a folder in yoru website to download ROM files?

Link edited, should work now.

brizio71
Sr. Member
****
Offline Offline

Activity: 456
Merit: 250


Blockchain Just Entered The Real World


View Profile
August 29, 2016, 10:07:09 AM
 #203

Hi Guys need your help.

I finally got some time to get this mod on my Sapphire RX480s 8GB.

Reading this thread from the beginning and looking for that stuff that I would need to put on a thumbdrive is really challenging because there are so many variations of the mod type, scenarios...

I am not being lazy to go dig the necessary files but need to do the new mods fast because the power bill is killing me.

Can help me with links to the following?

1. LOW POWER MOD - I think Heliox final mod got this to about 29 MHs.
2. Latest "atiflash" - I believe Heliox mentioned that he used this latest util
3. Bypassing the windows 10 signature checks. My RX480s are on Win 7 and Win10.
4. Did I miss any other file or steps?

Thanks guys - appreciate it.

Citronick,


1. Here
2. Atiflash Polaris
3. I believe i posted it somewhere, a step by step that works perfectly, i however am at this moment to lazy to go and find it :p
4. Nope, that should do it Smiley

Greetings!

does this steps userfull for RX470 4GB too ?

thx




   ▄▄███████▄▄       ▐█     █▌         ██          ▐██████▄▄       ▐██████▄          ██         ▐█▄        █▌    ███████▌
 ▄███▀▀   ▀▀███▄     ▐█     █▌        █▌▐█         ▐█   ▀▀██▄     ▐█   ▀█▌        █▌▐█        ▐███▄      █▌       █▌   
▐██▌        ▐██▌    ▐█     █▌       ██  ██        ▐█      ▐█▌    ▐█   ▄█▌       ██  ██       ▐█ ▀██▄    █▌       █▌   
███          ███    ▐█     █▌      ██   ██       ▐█       ██    ▐██████▀       ██   ██      ▐█   ▀██▄   █▌       █▌   
▐██▌   ██▄   ▐██▌    ▐█     █▌     ██████████      ▐█      ▐█▌    ▐█▀██▄        ██████████     ▐█    ▀██▄ █▌       █▌   
 ▀███▄▄ ▀██▄ ▀█▀     ▐█▄   ▄█▌    ██       ██     ▐█   ▄▄██▀     ▐█  ▀██▄     ██       ██    ▐█      ▀███▌       █▌   
   ▀▀█████▀██▄        ▀██████▀    ██         ██    ▐██████▀▀       ▐█   ▀█▌   ██         ██   ▐█        ▀█▌       █▌   
           ▀▀▀

A Blueprint for Mapping Decentralized Data


Telegram             Twitter             Medium             LinkedIn
██
██
██
██
██
   
Data Stamping
Constellation Creation
Enriched data and services
██
██
██
██
██
   
With Quadrant, any form of

Data can be Authenticated.
Cryptozillah
Hero Member
*****
Offline Offline

Activity: 679
Merit: 500


View Profile
August 29, 2016, 10:46:16 AM
 #204

Just started to flash my cards, all reference 8Gb cards.

I have one card in a rig now flashed with the "RX480-30MhOTBLowEnergy" bios

I have followed this guide:

1) this is my personal step...remove all cards but 1
2) boot into windows
3) reset card in wattman and reboot
4) flash card with desired rom, load up atiwinflash with admin
5) click save, and backup your current ROM
6) close the pop up once done
7) Click load and select new BIOS
Cool click program
9) wait...screen will hang for about 30-40 secs dont panic.
10) on confirmation box close
11) close app
12) in device manager right click g-card and uninstall. don't tick.
13) reboot
14) card should be redetect but now you are in vga mode as it will fail to load driver.
15) hit windows button and power then holding shift click restart, select troubleshoot, adv, restart options, click restart
16) hit 4 on option screen
17) now in safe mode replace the ati file you need into c:\windows\system32\drivers (overwrite).
18) hit windows button and power then holding shift click restart, select troubleshoot, adv, restart options, click restart
19) select option 7
20) you should now boot up with mod driver and mod bios all working...if not you did some thing wrong. go back to step 12

But i end up like this:


I was running the 16.7.2 driver before starting the guide.
I am running Win 10.
Anyone know what i am doing wrong ?
Benchman
Full Member
***
Offline Offline

Activity: 219
Merit: 100



View Profile
August 29, 2016, 10:48:49 AM
 #205

Don't try on rx470, it's not the same card, and memory is deffierent.
blue1984
Member
**
Offline Offline

Activity: 75
Merit: 10


View Profile
August 30, 2016, 07:00:44 AM
 #206

Hello,
have someone undervolate the 480?
how can i set a offset in the Bios?

lg blue
citronick
Legendary
*
Offline Offline

Activity: 1344
Merit: 1043


---- winter*juvia -----


View Profile
August 30, 2016, 01:20:41 PM
Last edit: August 30, 2016, 04:04:53 PM by citronick
 #207

thanks for the pointers Eliovp and jmumich -- will put this in the checklist.

Btw, Eliovp, your rom zip links seems bad, is there a folder in yoru website to download ROM files?

These are my notes on flashing 6 x RX480 Sapphires.

It was a success!

Many thanks to Heliox, jmumich and others for your pointers.

No guarantee it will work for you but the checklist below will be useful to find all the files needed to get started.

OBJECTIVES
--------------
My rig is 6 x Sapphire 480 8Gb Reference cards. Win 10, ASrock H81 mobo, Celeron 1840, 8GB RAM, 120GB SSD and powered USB3 risers x 6. EVGA-G2-Gold-1300w.

My goal is to flash the cards with Heliox “low power” RX480 rom mod and save power consumption and bring the hash rate to as close to 30MHs per GPU. Previously its running at stock 22-23Mhs per card. Power draw just under 1100watts. I will do some power comparisons and fine tuning tomorrow when I get my hands on a kill-o-watt adapter.


DOWNLOADS
---------------
Before your begin, download some of the necessary files you need to do the flash.

Download the special “atikmdag.sys” from  "http://www.win-raid.com/t892f16-AMD-and-Nvidia-GOP-update-No-requests-DIY-19.html#msg30028”. You need to register yourself  on this site so that you can download the file.

Download the Low Power 480 ROM Mod from Heliox’s website. Download link here - http://www.mininghwcomparison.com480lowenergyok.zip/

Download the latest atiflash utility at https://www.techpowerup.com/downloads/2728/atiflash-2-74


FLASHING
-------------
Open cmd.exe with Admin rights and find the atiflash command line file. There is a windows version but I didn’t use this.

Type "atiflash -i” to list all the GPUs in your system

I will do the flashing for every card one card at a time, all in one go. So let’s flash the 1st card by using the commands below:

To flash first card, type "atiflash -p -f 0 480lowenergyOK.rom”

To flash the 2nd card, type "atiflash -p -f 1 480lowenergyOK.rom”  

Modify the "- f" switch accordingly depending how many cards you have

After you done flashing. Reboot PC.


SIGNING THE DEVICE THING & MINING
------------------------------------------------
After booting into windows… install the latest Crimson drivers. You can find the latest 16.7.3 driver package for 480 series in AMD website.

Next, goto Device Manager and find Display…. you GPUs should be listed there - for my case I can see all 6 cards but it has an error mark on it.

Right button click each of them and disable all GPUs.

Next reboot to safe mode by pressing Shift key and reboot.

Ensure that you select Safe Mode with Networking so that you can download 1 more utility to solve this device signing issue.

Before you download that file, you need to replace the atikmdag.sys file in c:\windows\system32\drivers folder with the special atikmdag.sys file you download earlier.

Download the device signing utility from  "http://www.ngohq.com/?page=dseo”. After downloading dseo file, Open it and sign the atikmdag.sys file in the windows folder.

Next, open a cmd.exe window with Admin rights and type “bcdedit.exe -set loadoptions  TESTSIGNING”

Reboot as per normal.

Goto Device manager and enable your GPUs again.

Reboot for good measure

You are ready to launch your miner - in my case is Claymore Dual Miner…. I am doing only ETH btw. You should see 29MHs per card.


If I provided you good and useful info or just bring a smile to your day, consider sending me merit points to further validate this Bitcointalk account ~ useful for future account recovery...
zcrewsmok
Newbie
*
Offline Offline

Activity: 7
Merit: 0


View Profile
August 30, 2016, 01:27:24 PM
 #208


Next run (still modded): 30.5 - 31Mh : Lowered core to 1192 and raised memory to the (for now) max of 2250.

https://s10.postimg.org/wg35868nt/mem_Edit_Testrun_Final.png

Larger image: Here

Maybe the reason downvolt?

https://bitcointalk.org/index.php?topic=1601238.0
Longsnowsm
Hero Member
*****
Offline Offline

Activity: 868
Merit: 517


View Profile
August 30, 2016, 01:44:20 PM
 #209

This is great stuff, I hope we get ROMS like this for the custom cards.  My first 480's arrive today, but they are the custom cards.
BTCBusinessConsult
Sr. Member
****
Offline Offline

Activity: 532
Merit: 250


View Profile
August 30, 2016, 01:50:33 PM
 #210

so is it the undervolting that is killing the cards?

I remember I ran my 290x (single card, just as a hobby) almost 24/7 at 80 C for months and month with no issues. But 100% STOCK.
PovertyByte
Sr. Member
****
Offline Offline

Activity: 420
Merit: 250


View Profile
August 30, 2016, 02:27:45 PM
 #211

so is it the undervolting that is killing the cards?

I remember I ran my 290x (single card, just as a hobby) almost 24/7 at 80 C for months and month with no issues. But 100% STOCK.

Damage from undervolting is not normal. It's safer on the hardware but it loses stability when pushing it which can cause the driver to get buggy until a reboot. Overvolting is more damaging on the hardware end.
d57heinz
Legendary
*
Offline Offline

Activity: 1415
Merit: 1008



View Profile WWW
August 30, 2016, 02:53:42 PM
 #212

so is it the undervolting that is killing the cards?

I remember I ran my 290x (single card, just as a hobby) almost 24/7 at 80 C for months and month with no issues. But 100% STOCK.

prolly a combination of Overclock and undervolt causing to many amps to run thru the cards.    Just a guess  If your looking for longterm Overclock is not your friend

Best Regards
d57heinz

As in nature, all is ebb and tide, all is wave motion, so it seems that in all branches of industry, alternating currents - electric wave motion - will have the sway. ~Nikola Tesla~
BTCBusinessConsult
Sr. Member
****
Offline Offline

Activity: 532
Merit: 250


View Profile
August 30, 2016, 04:26:59 PM
 #213

so is it the undervolting that is killing the cards?

I remember I ran my 290x (single card, just as a hobby) almost 24/7 at 80 C for months and month with no issues. But 100% STOCK.

prolly a combination of Overclock and undervolt causing to many amps to run thru the cards.    Just a guess  If your looking for longterm Overclock is not your friend

Best Regards
d57heinz

This is pretty new to me so I am trying to learn. So overclocking and undervolting can damage your card it seems.

I have read alot how people are undervolting their cards with Wattman and having the same if not better performance and using less power.

If overclocking can damage the card, does undervolting make it run cooler and with less intensity so therefore giving the card more life without affecting performance?

I have 2 XFX reference 480s, can anybody give me a good starting place for undervolting? Thanks
zcrewsmok
Newbie
*
Offline Offline

Activity: 7
Merit: 0


View Profile
August 30, 2016, 05:02:23 PM
 #214

prolly a combination of Overclock and undervolt causing to many amps to run thru the cards.   

There are 30 more cards with the same settings , work for a month.
Cryptozillah
Hero Member
*****
Offline Offline

Activity: 679
Merit: 500


View Profile
August 30, 2016, 05:17:46 PM
 #215

I messed around like a fool for twelwe hours yesterday to get my two rigs flashed and running.
I started out struggeling like a maniac on the 16.7.2 driver, that was my first misstake. Dont even try that, i wasted many hours on that crap driver.

When i went with the 16.8.2 driver things started to work better.
I flashed one card with Boyises 31.25 bios and also got it up and running for a few minutes before i started to flash the rest of my cards.

When i had all cards flashed and rigs ready i moved them back to their mining location and fired them up. After five minute i had serious problems. Both rigs mined perfectly at 31.5Mhs per gpu för a couple of minutes before one or two cards went to 0 before the driver crashed and systems rebooted. At that point i was ready to shoot my rigs and then myself. I just shut everything down after some attempts to sort it out.

Today i started the day with rebuilding one of the rigs, fresh installation of win 10 and then flashed one card back to original bios. This time i used the "RX480-30MhOTBLowEnergy" bios. After getting the rig ready for mining with that single card i let it run for like one hour and it was rock solid @ 30.5Mhs.

I flashed the rest of the gpus and did the same to my other rig. They are now up and running really solid.

This is how i did it on my systems:

Setup:
Asrock H81 BTC Pro
Celeron G1820
8Gb ram
64Gb SSD with Windows 10
Corsair RM 850
4 x RX 480 8Gb reference cards (MSI/Sapphire)
Powered USB risers (One riser per SATA line, dont use more because the connector get HOT. I have melted one myself while running two risers on the same line)

DETAILED Installation for noobs like myself ! Smiley
Leave one card with original bios, flash all other cards one by one with the custom bios.
For flashing i used Winflash 2.74. that version supports Polaris.

In Windows:
Place the winflash files in a folder named "winflash" in C: root.
Place the bios in the same folder and name it bios.rom

When that is done, right click on the windows menu and click on "Command Prompt (Admin)
Back up to C: root using the command "cd.. + enter" several times.
When you are at "C:\>" go to winflash folder: "cd winflash"
When you see this: "C:\Winflash>" you are at the right place.

Be sure to have removed all other cards or unplug the risers/power cables except för the card you want to flash.

Start flashing it with the command: atiwinflash -f -p 0 bios.rom
Note that i had my card in slot "p 0" that is the pcie slot number.

Now it should be flashing and it will take around 20-30 seconds.
After it is finished, reboot your system to see that it aint dead "black picture"
If it works flash the rest of you gpu:s except the one that you keep as original.

When all other cards are flashed, leave theme at side and put your card with original bios in the system. Be sure to clean any old drivers.

Install the 16.8.2 driver, only driver and utility.

When the driver is installed and rebooted you can flash this card with the custom bios also.
When the card is flashed you can start adding the rest of the cards one by one until all cards are detected by windows. Note that they will not be supported by the driver at this point.

When all cards are detected you are almost ready to go.
Now you need to reboot your system with holding your left Shift key when pressing reboot.

You will see a menu now and you will pick Troubleshoot + advanced + startup settings + restart.
In the menu at boot you choose option 4 to get in safe mode.

In safe mode navigate to: C:\Windows\System32\drivers
Replace the file atikmdag.sys with the modified one.

After that, reboot again with left shift pressed down.
Again choose: Troubleshoot + advanced + startup settings + restart

In the menu at boot choose option 7

You should now boot into windows and all your cards should be accepted by the driver and ready to start mining.

Any custom bios should work but try one out on one card first and see that it is stable before flashing the rest of you gpu:s. Also remember to backup your original bios, i used GPU-Z tp pull out my original bios.

Links:
Winflash 2.74: https://www.techpowerup.com/downloads/2728/atiflash-2-74
Bios: There are many around, i used one called "RX480-30MhOTBLowEnergy"

Modded atikmdag.sys file : http://www.win-raid.com/t892f16-AMD-and-Nvidia-GOP-update-No-requests-DIY-19.html#msg30028
Eliovp
Legendary
*
Offline Offline

Activity: 1020
Merit: 1245

Huh?


View Profile
August 30, 2016, 05:33:44 PM
 #216

Glad everything is working for basically everyone :p

BTCBusinessConsult
Sr. Member
****
Offline Offline

Activity: 532
Merit: 250


View Profile
August 30, 2016, 06:01:57 PM
 #217

Omg that sounds like its way above my technical skill level... seems like alot of effort for an extra ~5.5 mh/s.


Ill give it a go this weekend  Cool
d57heinz
Legendary
*
Offline Offline

Activity: 1415
Merit: 1008



View Profile WWW
August 30, 2016, 08:12:30 PM
 #218

@eliovp

Can you explain to me what in the gpu is needed to mine. Is it the stream processors or the compute units.  Looking at the new card vs say a 390x were looking at 2800+ stream proc vs 480 at 2300+. And it's the same ram if I'm not mistaken.  So they are running the ram and gpu at screaming speeds vs the 390x and also overclocking the chip way higher then I Can with 390x. I'm just wondering how long these cards will last 460-480 with them being oc so high.  I can easily get 32 mhs with 44 compute units or 2816 stream processors with 390x   Now 460 is comparable to 7970 or 280x. 32 compute with 2048 stream and performance is right about same.  So these to me are being pushed to the limit   I'm waiting for a 490x with same amount of compute and streams.

As in nature, all is ebb and tide, all is wave motion, so it seems that in all branches of industry, alternating currents - electric wave motion - will have the sway. ~Nikola Tesla~
maxmad_x
Sr. Member
****
Offline Offline

Activity: 546
Merit: 250


It takes a lot to build but not much to lose


View Profile
August 30, 2016, 11:43:36 PM
 #219

Glad everything is working for basically everyone :p

Thumbs up Sir.. you are great.
Btw if you can make/edit post at the beginning with links to all roms, sys file and the singing file that will be great.
Once again, you are amazing and thank you soooo much
-Max
ps_jb
Hero Member
*****
Offline Offline

Activity: 742
Merit: 500


View Profile
August 31, 2016, 12:05:43 AM
 #220

Question - I bought a card which looks like a reference (6 pins power, 1288MHz, design)

Is any way to know is it reference or not?
Pages: « 1 2 3 4 5 6 7 8 9 10 [11] 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!