Bitcoin Forum
July 21, 2018, 09:42:32 PM *
News: Latest stable version of Bitcoin Core: 0.16.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 [35] 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 ... 142 »
  Print  
Author Topic: [Cast XMR] high speed XMR/CryptoNight miner for RX Vega GPUs (2 KHash/s)  (Read 166816 times)
erittainvarma
Newbie
*
Offline Offline

Activity: 1
Merit: 0


View Profile
November 29, 2017, 10:52:29 AM
 #681

Any plans to include support for Fiji or Hawaii cards?
1532209352
Hero Member
*
Offline Offline

Posts: 1532209352

View Profile Personal Message (Offline)

Ignore
1532209352
Reply with quote  #2

1532209352
Report to moderator
1532209352
Hero Member
*
Offline Offline

Posts: 1532209352

View Profile Personal Message (Offline)

Ignore
1532209352
Reply with quote  #2

1532209352
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
oxzhor
Newbie
*
Offline Offline

Activity: 28
Merit: 0


View Profile
November 29, 2017, 11:27:04 AM
 #682

Hi,

I have a new problem whem i start Cast XMR it says:

Code:
Selected OpenCL device index 1 doesn't exist. 

If i look into regedit i see:
Code:
0000 Internal gpu
0001 Radeon RX Vega
0002 Radeon RX Vega
0003 Radeon RX Vega
0004-Radeon RX Vega

run.bat
Code:
cast_xmr-vega -G 1,2,3,4 -S pool.supportxmr.com:7777 -u wallet-address %*

How i can fix this issue?

try these values for the -G value: -G 0,1,2,3 don't worry it won't use the iGPU for mining...

I get the follow error message:
Code:
[12:19:30] Initializing GPU, loading kernel ...
[12:19:31] Selected OpenCL device index 1 doesn't exist.
glph3k
Member
**
Offline Offline

Activity: 75
Merit: 23


View Profile WWW
November 29, 2017, 12:08:37 PM
 #683

Hi,

a new cast XMR version is available:

Cast XMR Version 0.7 (2017/11/29)

  - network and job status added to current statistics
  - remote access to get current status at http://127.0.0.1:7777 in JSON format (enable with --remoteaccess)
  - command line option to specify number of reconnects to pool (default 100) before giving up (set with --reconnects n)
  - fix for nicehash to support upto 8 GPUs (before only 4 were possible)

Download Cast XMR 0.7 for Windows (64bit)

Happy mining!
oxzhor
Newbie
*
Offline Offline

Activity: 28
Merit: 0


View Profile
November 29, 2017, 12:13:48 PM
 #684

Hi,

a new cast XMR version is available:

Cast XMR Version 0.7 (2017/11/29)

  - network and job status added to current statistics
  - remote access to get current status at http://127.0.0.1:7777 in JSON format (enable with --remoteaccess)
  - command line option to specify number of reconnects to pool (default 100) before giving up (set with --reconnects n)
  - fix for nicehash to support upto 8 GPUs (before only 4 were possible)

Download Cast XMR 0.7 for Windows (64bit)

Happy mining!

Still the same error  Huh

Code:
[13:11:20] Initializing GPU, loading kernel ...
[13:11:20] Selected OpenCL device index 1 doesn't exist.

run.bat
Code:
cast_xmr-vega -G 0,1,2,3 -S pool.supportxmr.com:7777 -u 47BPxtKATViEjCy4TMTDHbAq6QqjFRMgsXhe2PmqfNKE41QBa2AhxgHP19huMV7et4X2YiAhVbgUgAoCAtDbmeuW1tcrgXN.miner1 %*

Njeroe
Jr. Member
*
Offline Offline

Activity: 47
Merit: 0


View Profile
November 29, 2017, 12:20:05 PM
 #685

Hi,

a new cast XMR version is available:

Cast XMR Version 0.7 (2017/11/29)

  - network and job status added to current statistics
  - remote access to get current status at http://127.0.0.1:7777 in JSON format (enable with --remoteaccess)
  - command line option to specify number of reconnects to pool (default 100) before giving up (set with --reconnects n)
  - fix for nicehash to support upto 8 GPUs (before only 4 were possible)

Download Cast XMR 0.7 for Windows (64bit)

Happy mining!

Still the same error  Huh

Code:
[13:11:20] Initializing GPU, loading kernel ...
[13:11:20] Selected OpenCL device index 1 doesn't exist.

run.bat
Code:
cast_xmr-vega -G 0,1,2,3 -S pool.supportxmr.com:7777 -u 47BPxtKATViEjCy4TMTDHbAq6QqjFRMgsXhe2PmqfNKE41QBa2AhxgHP19huMV7et4X2YiAhVbgUgAoCAtDbmeuW1tcrgXN.miner1 %*



try to add in the run.bat file --opencl 0 -G 0,1,2,3 if its not working try different number, like --opencl 1
oxzhor
Newbie
*
Offline Offline

Activity: 28
Merit: 0


View Profile
November 29, 2017, 12:27:42 PM
 #686

Hi,

a new cast XMR version is available:

Cast XMR Version 0.7 (2017/11/29)

  - network and job status added to current statistics
  - remote access to get current status at http://127.0.0.1:7777 in JSON format (enable with --remoteaccess)
  - command line option to specify number of reconnects to pool (default 100) before giving up (set with --reconnects n)
  - fix for nicehash to support upto 8 GPUs (before only 4 were possible)

Download Cast XMR 0.7 for Windows (64bit)

Happy mining!

Still the same error  Huh

Code:
[13:11:20] Initializing GPU, loading kernel ...
[13:11:20] Selected OpenCL device index 1 doesn't exist.

run.bat
Code:
cast_xmr-vega -G 0,1,2,3 -S pool.supportxmr.com:7777 -u 47BPxtKATViEjCy4TMTDHbAq6QqjFRMgsXhe2PmqfNKE41QBa2AhxgHP19huMV7et4X2YiAhVbgUgAoCAtDbmeuW1tcrgXN.miner1 %*



try to add in the run.bat file --opencl 0 -G 0,1,2,3 if its not working try different number, like --opencl 1

Still the same error  Huh
MATHReX
Sr. Member
****
Offline Offline

Activity: 364
Merit: 254



View Profile
November 29, 2017, 12:33:57 PM
 #687

Still the same error  Huh

Add this to the bat file:

Code:
--opencl 1 -G 0,1,2,..,N

for a N+1 number of Vega GPUs.

            ▄▄████▄▄
        ▄▄██████████████▄▄
      ███████████████████████▄▄
      ▀▀█████████████████████████
██▄▄       ▀▀█████████████████████
██████▄▄        ▀█████████████████
███████████▄▄       ▀▀████████████
███████████████▄▄        ▀████████
████████████████████▄▄       ▀▀███
 ▀▀██████████████████████▄▄
     ▀▀██████████████████████▄▄
▄▄        ▀██████████████████████▄
████▄▄        ▀▀██████████████████
█████████▄▄        ▀▀█████████████
█████████████▄▄        ▀▀█████████
██████████████████▄▄        ▀▀████
▀██████████████████████▄▄
  ▀▀████████████████████████
      ▀▀█████████████████▀▀
           ▀▀███████▀▀



.SEMUX
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
  Semux uses 100% original codebase
  Superfast with 30 seconds instant finality
  Tested 5000 tx per block on open network
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
█ █
oxzhor
Newbie
*
Offline Offline

Activity: 28
Merit: 0


View Profile
November 29, 2017, 12:42:14 PM
 #688

Still the same error  Huh

Add this to the bat file:

Code:
--opencl 1 -G 0,1,2,..,N

for a N+1 number of Vega GPUs.

Ok it starts with cast_xmr-vega --opencl 1 -G 0,1,2,3,N -S

Now i get the follow error

Code:
[13:51:27] Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.
Njeroe
Jr. Member
*
Offline Offline

Activity: 47
Merit: 0


View Profile
November 29, 2017, 12:53:27 PM
 #689



Still the same error  Huh

Code:
[13:11:20] Initializing GPU, loading kernel ...
[13:11:20] Selected OpenCL device index 1 doesn't exist.

run.bat
Code:
cast_xmr-vega -G 0,1,2,3 -S pool.supportxmr.com:7777 -u 47BPxtKATViEjCy4TMTDHbAq6QqjFRMgsXhe2PmqfNKE41QBa2AhxgHP19huMV7et4X2YiAhVbgUgAoCAtDbmeuW1tcrgXN.miner1 %*



try to add in the run.bat file --opencl 0 -G 0,1,2,3 if its not working try different number, like --opencl 1

Still the same error  Huh

[/quote]

did you have other GPUs on your system before? because it looks like you have driver issue.. if yes you should remove the old ones with DDU...
Kaezar
Jr. Member
*
Offline Offline

Activity: 59
Merit: 0


View Profile
November 29, 2017, 12:56:33 PM
 #690

Still the same error  Huh

Add this to the bat file:

Code:
--opencl 1 -G 0,1,2,..,N

for a N+1 number of Vega GPUs.

Ok it starts with cast_xmr-vega --opencl 1 -G 0,1,2,3,N -S

Now i get the follow error

Code:
[13:51:27] Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.
Just try with one card:
Code:
  cast_xmr-vega --opencl 1 -G 0 -S pool.supportxmr.com:7777 -u 47BPxtKATViEjCy4TMTDHbAq6QqjFRMgsXhe2PmqfNKE41QBa2AhxgHP19huMV7et4X2YiAhVbgUgAoCAtDbmeuW1tcrgXN.miner1
or
Code:
  cast_xmr-vega --opencl 0 -G 0 -S pool.supportxmr.com:7777 -u 47BPxtKATViEjCy4TMTDHbAq6QqjFRMgsXhe2PmqfNKE41QBa2AhxgHP19huMV7et4X2YiAhVbgUgAoCAtDbmeuW1tcrgXN.miner1
oxzhor
Newbie
*
Offline Offline

Activity: 28
Merit: 0


View Profile
November 29, 2017, 12:57:04 PM
 #691

Nop, already i run ddu in safe mode to reinstall the blockchain drivers.

Now it running but i get the follow error see my post above.
oxzhor
Newbie
*
Offline Offline

Activity: 28
Merit: 0


View Profile
November 29, 2017, 01:04:43 PM
 #692

Still the same error  Huh

Add this to the bat file:

Code:
--opencl 1 -G 0,1,2,..,N

for a N+1 number of Vega GPUs.

Ok it starts with cast_xmr-vega --opencl 1 -G 0,1,2,3,N -S

Now i get the follow error

Code:
[13:51:27] Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.
Just try with one card:
Code:
  cast_xmr-vega --opencl 1 -G 0 -S pool.supportxmr.com:7777 -u 47BPxtKATViEjCy4TMTDHbAq6QqjFRMgsXhe2PmqfNKE41QBa2AhxgHP19huMV7et4X2YiAhVbgUgAoCAtDbmeuW1tcrgXN.miner1
or
Code:
  cast_xmr-vega --opencl 0 -G 0 -S pool.supportxmr.com:7777 -u 47BPxtKATViEjCy4TMTDHbAq6QqjFRMgsXhe2PmqfNKE41QBa2AhxgHP19huMV7et4X2YiAhVbgUgAoCAtDbmeuW1tcrgXN.miner1


Ok 1 start without any error, with cast_xmr-vega --opencl 1 -G 0,1 it also start without error but when i added cast_xmr-vega --opencl 1 -G 0,1,2 i get
Code:
Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.
Kaezar
Jr. Member
*
Offline Offline

Activity: 59
Merit: 0


View Profile
November 29, 2017, 01:09:31 PM
 #693

Quote
Just try with one card:
Code:
  cast_xmr-vega --opencl 1 -G 0 -S pool.supportxmr.com:7777 -u 47BPxtKATViEjCy4TMTDHbAq6QqjFRMgsXhe2PmqfNKE41QBa2AhxgHP19huMV7et4X2YiAhVbgUgAoCAtDbmeuW1tcrgXN.miner1
or
Code:
  cast_xmr-vega --opencl 0 -G 0 -S pool.supportxmr.com:7777 -u 47BPxtKATViEjCy4TMTDHbAq6QqjFRMgsXhe2PmqfNKE41QBa2AhxgHP19huMV7et4X2YiAhVbgUgAoCAtDbmeuW1tcrgXN.miner1



Ok 1 start without any error, with cast_xmr-vega --opencl 1 -G 0,1 it also start without error but when i added cast_xmr-vega --opencl 1 -G 0,1,2 i get
Code:
Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.

Ok. Check device manager. You see all 3 cards without any problems with 22.19.659.0 drivers version?
oxzhor
Newbie
*
Offline Offline

Activity: 28
Merit: 0


View Profile
November 29, 2017, 01:15:35 PM
 #694

Quote
Just try with one card:
Code:
 cast_xmr-vega --opencl 1 -G 0 -S pool.supportxmr.com:7777 -u 47BPxtKATViEjCy4TMTDHbAq6QqjFRMgsXhe2PmqfNKE41QBa2AhxgHP19huMV7et4X2YiAhVbgUgAoCAtDbmeuW1tcrgXN.miner1
or
Code:
 cast_xmr-vega --opencl 0 -G 0 -S pool.supportxmr.com:7777 -u 47BPxtKATViEjCy4TMTDHbAq6QqjFRMgsXhe2PmqfNKE41QBa2AhxgHP19huMV7et4X2YiAhVbgUgAoCAtDbmeuW1tcrgXN.miner1



Ok 1 start without any error, with cast_xmr-vega --opencl 1 -G 0,1 it also start without error but when i added cast_xmr-vega --opencl 1 -G 0,1,2 i get
Code:
Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.

Ok. Check device manager. You see all 3 cards without any problems with 22.19.659.0 drivers version?

Yes all four Vega 56 have driver version 22.19.659.0

https://www.mupload.nl/img/lvcd7jlrzptjv.png
Kaezar
Jr. Member
*
Offline Offline

Activity: 59
Merit: 0


View Profile
November 29, 2017, 01:21:34 PM
 #695

Quote
Just try with one card:
Code:
  cast_xmr-vega --opencl 1 -G 0 -S pool.supportxmr.com:7777 -u 47BPxtKATViEjCy4TMTDHbAq6QqjFRMgsXhe2PmqfNKE41QBa2AhxgHP19huMV7et4X2YiAhVbgUgAoCAtDbmeuW1tcrgXN.miner1
or
Code:
  cast_xmr-vega --opencl 0 -G 0 -S pool.supportxmr.com:7777 -u 47BPxtKATViEjCy4TMTDHbAq6QqjFRMgsXhe2PmqfNKE41QBa2AhxgHP19huMV7et4X2YiAhVbgUgAoCAtDbmeuW1tcrgXN.miner1



Ok 1 start without any error, with cast_xmr-vega --opencl 1 -G 0,1 it also start without error but when i added cast_xmr-vega --opencl 1 -G 0,1,2 i get
Code:
Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.

Ok. Check device manager. You see all 3 cards without any problems with 22.19.659.0 drivers version?

Yes all four Vega 56 have driver version 22.19.659.0
Okaj... very interesting...
4 vega?
ok. just test all cards separatly.. with 0 and 1 we have no problems? start with 2..
Code:
cast_xmr-vega --opencl 1 -G 2
next
Code:
cast_xmr-vega --opencl 1 -G 3
Errors?
Njeroe
Jr. Member
*
Offline Offline

Activity: 47
Merit: 0


View Profile
November 29, 2017, 01:28:07 PM
 #696

Quote
Just try with one card:
Code:
  cast_xmr-vega --opencl 1 -G 0 -S pool.supportxmr.com:7777 -u 47BPxtKATViEjCy4TMTDHbAq6QqjFRMgsXhe2PmqfNKE41QBa2AhxgHP19huMV7et4X2YiAhVbgUgAoCAtDbmeuW1tcrgXN.miner1
or
Code:
  cast_xmr-vega --opencl 0 -G 0 -S pool.supportxmr.com:7777 -u 47BPxtKATViEjCy4TMTDHbAq6QqjFRMgsXhe2PmqfNKE41QBa2AhxgHP19huMV7et4X2YiAhVbgUgAoCAtDbmeuW1tcrgXN.miner1



Ok 1 start without any error, with cast_xmr-vega --opencl 1 -G 0,1 it also start without error but when i added cast_xmr-vega --opencl 1 -G 0,1,2 i get
Code:
Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.

Ok. Check device manager. You see all 3 cards without any problems with 22.19.659.0 drivers version?

Yes all four Vega 56 have driver version 22.19.659.0
Okaj... very interesting...
4 vega?
ok. just test all cards separatly.. with 0 and 1 we have no problems? start with 2..
Code:
cast_xmr-vega --opencl 1 -G 2
next
Code:
cast_xmr-vega --opencl 1 -G 3
Errors?

also did you increase the amount of virtual memory?
oxzhor
Newbie
*
Offline Offline

Activity: 28
Merit: 0


View Profile
November 29, 2017, 01:39:50 PM
 #697

virtual memory is set on 70000 min and max 80000.

Oke test all cards separately

Code:
cast_xmr-vega --opencl 1 -G 0
Test successful working

Code:
cast_xmr-vega --opencl 1 -G 1
Test successful working

Code:
cast_xmr-vega --opencl 1 -G 2
Test successful working

Code:
cast_xmr-vega --opencl 1 -G 3
Test successful working

4 not exist so i think Cast XMR will not count the internal GPU.

Code:
cast_xmr-vega --opencl 1 -G 0,1,2,3
Test FAIL
Error message:
Code:
Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.
oxzhor
Newbie
*
Offline Offline

Activity: 28
Merit: 0


View Profile
November 29, 2017, 01:56:50 PM
 #698

Ok it starts but spamming the error

[Pool: 'pool.supportxmr.com:7777' | Connected: 2017-11-29 15:07:59]
  0:00:16 (100%) Online
  0:00:00 (  0%) Offline

[Job: #1 | Difficulty: 25000 | Running: 16.0 sec]

[Hash Rate Avg: 8534.6 H/s]
  2389.8 H/s GPU0
  1351.8 H/s GPU1
  2395.6 H/s GPU2
  2397.5 H/s GPU3

[Shares Found: 4 | Avg Search Time: 4.0 sec]
   4 (100%) Accepted
   0 (  0%) Rejected by pool
   0 (  0%) Invalid result computation failed
   0 (  0%) Could not be submit because of network error
   0 (  0%) Outdated because of job change

[15:08:17] Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.
[15:08:17] Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.
Kaezar
Jr. Member
*
Offline Offline

Activity: 59
Merit: 0


View Profile
November 29, 2017, 02:31:54 PM
 #699

Ok it starts but spamming the error

[Pool: 'pool.supportxmr.com:7777' | Connected: 2017-11-29 15:07:59]
  0:00:16 (100%) Online
  0:00:00 (  0%) Offline

[Job: #1 | Difficulty: 25000 | Running: 16.0 sec]

[Hash Rate Avg: 8534.6 H/s]
  2389.8 H/s GPU0
  1351.8 H/s GPU1
  2395.6 H/s GPU2
  2397.5 H/s GPU3

[Shares Found: 4 | Avg Search Time: 4.0 sec]
   4 (100%) Accepted
   0 (  0%) Rejected by pool
   0 (  0%) Invalid result computation failed
   0 (  0%) Could not be submit because of network error
   0 (  0%) Outdated because of job change

[15:08:17] Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.
[15:08:17] Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.
hmm.. may be try "run as Administrator" ? just for test.
oxzhor
Newbie
*
Offline Offline

Activity: 28
Merit: 0


View Profile
November 29, 2017, 03:20:39 PM
 #700

Ok it starts but spamming the error

[Pool: 'pool.supportxmr.com:7777' | Connected: 2017-11-29 15:07:59]
  0:00:16 (100%) Online
  0:00:00 (  0%) Offline

[Job: #1 | Difficulty: 25000 | Running: 16.0 sec]

[Hash Rate Avg: 8534.6 H/s]
  2389.8 H/s GPU0
  1351.8 H/s GPU1
  2395.6 H/s GPU2
  2397.5 H/s GPU3

[Shares Found: 4 | Avg Search Time: 4.0 sec]
   4 (100%) Accepted
   0 (  0%) Rejected by pool
   0 (  0%) Invalid result computation failed
   0 (  0%) Could not be submit because of network error
   0 (  0%) Outdated because of job change

[15:08:17] Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.
[15:08:17] Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.
hmm.. may be try "run as Administrator" ? just for test.

The run.bat not open if i right click and open as admin, it pops op and close.
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 [35] 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 ... 142 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!