Bitcoin Forum
May 26, 2018, 02:55:30 PM *
News: Latest stable version of Bitcoin Core: 0.16.0  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 [49] 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 ... 129 »
  Print  
Author Topic: [Cast XMR] high speed XMR/CryptoNight miner for RX Vega GPUs (2 KHash/s)  (Read 155943 times)
pbfarmer
Jr. Member
*
Offline Offline

Activity: 34
Merit: 0


View Profile
December 10, 2017, 09:50:35 PM
 #961

Hello,

i got the following issue:

initially i got average around 1900h/s and after some time, it can be minutes or hours, i drops to 1500-1600h/s

Anyone having such issue and eventually a solution ?

Sounds like your memory is overheating.  I've noticed similar behavior around 70 deg (HBM, not gpu/core,) - rock steady at 67-68 deg.  Weird thing is that frequency was never throttled - Wattman graphs showed a constant 1100 MHz.  I'm guessing Vega maybe loosens timings at 70 deg, and those timings remain 'permanent' until load is removed (i.e. miner is stopped.)

Try increasing cooling (higher fan, better airflow,) and/or reduce your power consumption (lower voltages or reduce power limit - 1% lower PL can mean 1-3 deg.)
1527346530
Hero Member
*
Offline Offline

Posts: 1527346530

View Profile Personal Message (Offline)

Ignore
1527346530
Reply with quote  #2

1527346530
Report to moderator
1527346530
Hero Member
*
Offline Offline

Posts: 1527346530

View Profile Personal Message (Offline)

Ignore
1527346530
Reply with quote  #2

1527346530
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1527346530
Hero Member
*
Offline Offline

Posts: 1527346530

View Profile Personal Message (Offline)

Ignore
1527346530
Reply with quote  #2

1527346530
Report to moderator
pbfarmer
Jr. Member
*
Offline Offline

Activity: 34
Merit: 0


View Profile
December 10, 2017, 09:56:46 PM
 #962

Hі, guys,  Cаst XMR  mаx wоrk wіth 4 Vеgа's?  Аrе thеrе lіmіtаtіоns ?  Thаnks
I think it can work with up to 8 or more,afaik? It also depends on the AMD drivers.

how do i solve the falling hash rate problem? Seems like the hashrate keeps going down after mining for a while.
do you use a iGPU? If so, connect a headless HDMI ghost so your computer thinks there is a monitor connected all the time.

I enabled the iGPU (the integrated GPU of your mobo or Intel processor) in the bios settings as the main graphics device and the Vega never drop a single hash the entire time.

Also, I am not using AMD Wattman (only the Blockchain august drivers) but these settings, in a bat, that launch with Windows -so does Cast XMR- with OverdriveNTool work fine for me (stable 1970H/s+):


[Profile_0]
Name=Vega56
GPU_P0=852;900
GPU_P1=991;900
GPU_P2=1084;900
GPU_P3=1138;900
GPU_P4=1150;900
GPU_P5=1202;900
GPU_P6=1212;905
GPU_P7=1407;950
Mem_P0=167;900
Mem_P1=500;900
Mem_P2=800;900
Mem_P3=950;900
Fan_Min=3000
Fan_Max=4900
Fan_Target=75
Fan_Acoustic=2400
Power_Temp=85
Power_Target=0


You should be able to get 1407 MHz core w/ 905-915 mV.  950 should be enough for at least 1457.  Also guessing you could drop your power target quite a bit - anywhere from 5-20%.
penetrak
Full Member
***
Offline Offline

Activity: 135
Merit: 100


View Profile
December 10, 2017, 10:03:03 PM
 #963

I want to download this program from OP Download Cast XMR 0.7 for Windows (64bit), but ESET antivirus blocks my access to the page. I want to try it. Can you put it on mega.nz or google? I'll be glad, thank you.
P00P135
Full Member
***
Offline Offline

Activity: 308
Merit: 110


View Profile
December 10, 2017, 10:34:59 PM
 #964

I want to download this program from OP Download Cast XMR 0.7 for Windows (64bit), but ESET antivirus blocks my access to the page. I want to try it. Can you put it on mega.nz or google? I'll be glad, thank you.

Put an exception rule for the website in your antivirus?
dagarair
Sr. Member
****
Offline Offline

Activity: 569
Merit: 256


View Profile
December 10, 2017, 10:50:29 PM
 #965

7 Card VEGA up and running.  So far I have stopped jacking with it today but there are settings

7 VEGA
-10 FQ
945 MHZ
-10 power (yes needs to go lower but was having issues)
50GB Virtual Disk - Crashed at 45



penetrak
Full Member
***
Offline Offline

Activity: 135
Merit: 100


View Profile
December 10, 2017, 10:51:32 PM
 #966

I want to download this program from OP Download Cast XMR 0.7 for Windows (64bit), but ESET antivirus blocks my access to the page. I want to try it. Can you put it on mega.nz or google? I'll be glad, thank you.

Put an exception rule for the website in your antivirus?
All right. I can try to make an exception in ESET antivirus. I downloaded the file checked through the virustotal and writes this.
https://www.virustotal.com/#/file/d399de45051a0e9885decef3f4ae35ec4fca1371d8f788ffc7b7796704884c3a/detection
But when I check it through ESET, it's OK.
ronnieb
Jr. Member
*
Offline Offline

Activity: 37
Merit: 0


View Profile
December 11, 2017, 12:05:00 AM
 #967

7 Card VEGA up and running.  So far I have stopped jacking with it today but there are settings

7 VEGA
-10 FQ
945 MHZ
-10 power (yes needs to go lower but was having issues)
50GB Virtual Disk - Crashed at 45





setup in the garage?
ManeBjorn
Legendary
*
Offline Offline

Activity: 1218
Merit: 1002



View Profile
December 11, 2017, 02:18:57 AM
 #968

Looks good. How are the temps?

7 Card VEGA up and running.  So far I have stopped jacking with it today but there are settings

7 VEGA
-10 FQ
945 MHZ
-10 power (yes needs to go lower but was having issues)
50GB Virtual Disk - Crashed at 45





xeridea
Sr. Member
****
Offline Offline

Activity: 419
Merit: 251


View Profile WWW
December 11, 2017, 04:38:33 AM
 #969

On a sidenote... Has anyone managed to set failover pools using Cast? Or is there no other option but to wait for glph3k to release a new version that supports failovers? Those ETN pools really aren't the most reliable...

Miner closes after x amount (default 100) failed pool connections.  Change number of failed attempts (see OP), then change batch file to like

cast_xmr.exe pool1 ....
cast_xmr.exe pool2 ....
cast_xmr.exe pool3 ....
cast_xmr.exe pool1 ....
cast_xmr.exe pool2 ....
cast_xmr.exe pool3 ....
cast_xmr.exe pool1 ....
cast_xmr.exe pool2 ....
cast_xmr.exe pool3 ....
cast_xmr.exe pool1 ....
cast_xmr.exe pool2 ....
cast_xmr.exe pool3 ....
cast_xmr.exe pool1 ....
cast_xmr.exe pool2 ....
cast_xmr.exe pool3 ....


A bit of a hack but it would work.

Profitability over time charts for many GPUs - http://xeridea.us/charts

BTC:  16wzGLYLh1ximotu3Ln7htKnbUUcwWvQUv   LTC:  LdPvSJoAwgH87TXSMBuxDefBvp2bweXApY   Eth:  0xb508131ca5d983ebe72f8af61ecfb7d1b61f6d18
errata
Jr. Member
*
Offline Offline

Activity: 59
Merit: 0


View Profile
December 11, 2017, 11:21:08 AM
 #970

Hi all! What could be the reason for 1 of my 5 cards is always calculating wrong nonce? I constantly see this:

Code:
[10:19:15] GPU4 Found Nonce, submitting...
[10:19:15] !Rejected, Nonce Invalid!
[10:19:15] Shares: 34 Accepted, 7 Errors | Hash Rate Avg: 9815.7 H/s | Avg Search Time: 23.9 sec

and occasionally (but very rare):

Code:
[10:29:46] New job received. Avg Job Time: 43.5 sec
[10:29:46] Difficulty changed. Now: 230021.
[10:29:46] GPU4 Found Nonce, job already changed -> outdated.
[10:29:46] Shares: 54 Accepted, 14 Errors | Hash Rate Avg: 9814.6 H/s | Avg Search Time: 24.8 sec

Both 64s (I have 2x Vega 65 and 3x Vega 56) have same settings applied and this is happening on 1 of them. If something is wrong with settings, I assume that the other 64 would calculate it wrongly too, isn't it so?

I tried to change the riser for this card and then it worked briefly. After next reboot I started to see "Rejected" message again. I tried to switch the position for both 64s but still the same card was reporting the error (this time it was GPU3).

Thanks for any tips!
ninjam
Jr. Member
*
Offline Offline

Activity: 72
Merit: 0


View Profile
December 11, 2017, 11:38:51 AM
 #971

Too much overclock for that card. Press 's' to see reason for rejected shares.
Omg9500
Jr. Member
*
Offline Offline

Activity: 80
Merit: 0


View Profile
December 11, 2017, 11:49:23 AM
 #972

I am having a problem with cast-xmr klatest version ) which mines at only 3100 h/s whereas claymore reaches 7400 h/s on the same system....

Win10 64 uptodate
6 Sapphire RX580 cards with modified BIOS
4 MSI RX580 cards with modified BIOS
AMD driver 17.11.2 (Blockchain beta drivers not working for me because only upto 8 cards supported)

Any ideas?
I'll give you a hint.
Your answer is in the title of this thread.
It's a bit hidden, I'll admit, but it's one very specific word you're looking for.

I'll help.
It's located between the words RX and GPUs.

It supports 580's just fine.  You should be able to get 700-1k h/s on each depending on how well you can memstrap and OC it.
Just fine is meh. Why use cast on rx570/580 if it's not optimised for these cards? I get over 800 on my rx570's using Claymore. 1k I'd seriously love to see that. No freely distributed miner can achieve that with these cards... that I know of anyway.

I get over 800 per card with claymore and amdxmr miner (https://www.amdxmrminer.com/) but cards get quite hot. Not the sapphires, they stay at around 66 deg celsius but the MSI cards go upto 75 which is quite warm. So I reduced voltage, power limit, GPU and MEM freq. on the MSI cards. And with h regards to your hint I have obviously seen the word but if you have a look at the OP you will see that it clearly says thst RX480/RX580 are supported.
Souran
Jr. Member
*
Offline Offline

Activity: 46
Merit: 2


View Profile
December 11, 2017, 12:04:01 PM
 #973

I am having a problem with cast-xmr klatest version ) which mines at only 3100 h/s whereas claymore reaches 7400 h/s on the same system....

Win10 64 uptodate
6 Sapphire RX580 cards with modified BIOS
4 MSI RX580 cards with modified BIOS
AMD driver 17.11.2 (Blockchain beta drivers not working for me because only upto 8 cards supported)

Any ideas?
I'll give you a hint.
Your answer is in the title of this thread.
It's a bit hidden, I'll admit, but it's one very specific word you're looking for.

I'll help.
It's located between the words RX and GPUs.

It supports 580's just fine.  You should be able to get 700-1k h/s on each depending on how well you can memstrap and OC it.
Just fine is meh. Why use cast on rx570/580 if it's not optimised for these cards? I get over 800 on my rx570's using Claymore. 1k I'd seriously love to see that. No freely distributed miner can achieve that with these cards... that I know of anyway.

RX580, samsung memory, using blockchain drivers:
1050h on cast xmr
1010h on claymore

same card, 17.11.2 drivers
680h on cast xmr
1010h on claymore

So your argument is invalid, the miner works fine with RX 5XX/4XX cards, even better than the other "optimized" miners; just not optimized for the drivers.
errata
Jr. Member
*
Offline Offline

Activity: 59
Merit: 0


View Profile
December 11, 2017, 12:05:18 PM
 #974

Too much overclock for that card. Press 's' to see reason for rejected shares.

Hm, could overclock really be the reason? How comes that other 64 with the same settings works fine? I'll try to play around with numbers to see if it will help, thanks for the answer!

Also, my stats:

Code:
[Shares Found: 495 | Avg Search Time: 27.6 sec]
 383 ( 77%) Accepted
   0 (  0%) Rejected by pool
  88 ( 18%) Invalid result computation failed
   0 (  0%) Could not be submit because of network error
  24 (  5%) Outdated because of job change
ninjam
Jr. Member
*
Offline Offline

Activity: 72
Merit: 0


View Profile
December 11, 2017, 12:35:48 PM
 #975

If you have number greater than zero under "Invalid result computation failed" - reason is that you overclocked that card too much.
Not every card is the same, some cards can be oced more, some less. I have 1 of 5 vega 56 cards that not want to accept voltage under 1V although 4 other cards work with voltage under 0.9 using the same settings.
errata
Jr. Member
*
Offline Offline

Activity: 59
Merit: 0


View Profile
December 11, 2017, 01:38:51 PM
 #976

If you have number greater than zero under "Invalid result computation failed" - reason is that you overclocked that card too much.
Not every card is the same, some cards can be oced more, some less. I have 1 of 5 vega 56 cards that not want to accept voltage under 1V although 4 other cards work with voltage under 0.9 using the same settings.

Right, ok, thanks for the answer, I'll try to change my settings and hope for the best :)
dagarair
Sr. Member
****
Offline Offline

Activity: 569
Merit: 256


View Profile
December 11, 2017, 01:57:40 PM
 #977

7 Card VEGA up and running.  So far I have stopped jacking with it today but there are settings

7 VEGA
-10 FQ
945 MHZ
-10 power (yes needs to go lower but was having issues)
50GB Virtual Disk - Crashed at 45





setup in the garage?

Yeah but not really.  I have a 2 ton AC just for that garagae, an insulated door, 240V power the whole smash.
alexandervba
Newbie
*
Offline Offline

Activity: 2
Merit: 0


View Profile
December 11, 2017, 02:58:58 PM
 #978

Hi,

Im running this command:

cast_xmr-vega -S xmr-eu1.nanopool.org:14444 -u XMRAdress %* --opencl 0 -G 0,1,2,3,4,5

But im getting a massive ammount of errors and cant seem to find the answer in the replies...
ive also tried opencl 1, 2 and 3, but these wont start at all.

Code:
[15:55:06] Initializing GPU, loading kernel ...
[Suspicious link removed]pute Driver detected.
GPU0: Ellesmere | 36 Compute Units
GPU1: Ellesmere | 36 Compute Units
GPU2: Ellesmere | 36 Compute Units
GPU3: Ellesmere | 36 Compute Units
GPU4: Ellesmere | 36 Compute Units
GPU5: Ellesmere | 36 Compute Units
[15:55:08] Connecting to xmr-eu1.nanopool.org:14444 ...
[15:55:09] Connected to pool.
[15:55:09] New job received.
[15:55:09] Difficulty changed. Now: 120001.
[15:55:09] Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.
[15:55:09] Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.
[15:55:09] Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.
errata
Jr. Member
*
Offline Offline

Activity: 59
Merit: 0


View Profile
December 11, 2017, 03:14:06 PM
 #979

Hi,

Im running this command:

cast_xmr-vega -S xmr-eu1.nanopool.org:14444 -u XMRAdress %* --opencl 0 -G 0,1,2,3,4,5

But im getting a massive ammount of errors and cant seem to find the answer in the replies...
ive also tried opencl 1, 2 and 3, but these wont start at all.

Code:
[15:55:06] Initializing GPU, loading kernel ...
[Suspicious link removed]pute Driver detected.
GPU0: Ellesmere | 36 Compute Units
GPU1: Ellesmere | 36 Compute Units
GPU2: Ellesmere | 36 Compute Units
GPU3: Ellesmere | 36 Compute Units
GPU4: Ellesmere | 36 Compute Units
GPU5: Ellesmere | 36 Compute Units
[15:55:08] Connecting to xmr-eu1.nanopool.org:14444 ...
[15:55:09] Connected to pool.
[15:55:09] New job received.
[15:55:09] Difficulty changed. Now: 120001.
[15:55:09] Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.
[15:55:09] Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.
[15:55:09] Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.

Code:
GPU0: Ellesmere | 36 Compute Units
Are those AMD Vega cards you have or something else?
alexandervba
Newbie
*
Offline Offline

Activity: 2
Merit: 0


View Profile
December 11, 2017, 03:16:13 PM
 #980

Hi,

Im running this command:

cast_xmr-vega -S xmr-eu1.nanopool.org:14444 -u XMRAdress %* --opencl 0 -G 0,1,2,3,4,5

But im getting a massive ammount of errors and cant seem to find the answer in the replies...
ive also tried opencl 1, 2 and 3, but these wont start at all.

Code:
[15:55:06] Initializing GPU, loading kernel ...
[Suspicious link removed]pute Driver detected.
GPU0: Ellesmere | 36 Compute Units
GPU1: Ellesmere | 36 Compute Units
GPU2: Ellesmere | 36 Compute Units
GPU3: Ellesmere | 36 Compute Units
GPU4: Ellesmere | 36 Compute Units
GPU5: Ellesmere | 36 Compute Units
[15:55:08] Connecting to xmr-eu1.nanopool.org:14444 ...
[15:55:09] Connected to pool.
[15:55:09] New job received.
[15:55:09] Difficulty changed. Now: 120001.
[15:55:09] Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.
[15:55:09] Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.
[15:55:09] Error CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0.

Code:
GPU0: Ellesmere | 36 Compute Units
Are those AMD Vega cards you have or something else?

Hi,

Oh right, these are Radeon RX580 cards, they wont work?
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 [49] 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 ... 129 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!