Bitcoin Forum
May 26, 2018, 02:55:50 PM *
News: Latest stable version of Bitcoin Core: 0.16.0  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 [43] 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 ... 129 »
  Print  
Author Topic: [Cast XMR] high speed XMR/CryptoNight miner for RX Vega GPUs (2 KHash/s)  (Read 155943 times)
wolverine5pl
Sr. Member
****
Offline Offline

Activity: 405
Merit: 250


View Profile
December 05, 2017, 10:56:15 PM
 #841

my cast xmr fast (1950 h/s) but i see very slow on the pool site (1200-1600 h/s) Why?

This is a general thing in mining. The miner counts the hashes (the speed you are searching) while the pool only knows how many valid shares you've sent (so it counts the results).

The two are equivalent only when averaging on a very large time interval
plug it into nicehash. nicehash has nice graphs with average hashrate on longer periods. i woudnt worry about it too much. its not easy tho. we all would love to see highest hashrate on pools all the time

               ,,╓▄▄▄▄▄▄▄▄▄µ,.               
           ,╔▄▓▓██████████████▓▄▄,           
        ╓╗▓▓██████████████████████▓▄µ       
      ╔▄████████████████████████████▓▓╦     
    ╔╣▓████████▀` ▀███████▀` ╙█████████▌m   
   ╔▓████████▌`     ▀██▓▀      ▐████████▓N   
  ╔▓██████████▓▄      └      ,███████████▓N 
 ╔▓█████▓▀▀█████▓▄         ╓██████▓`▓█████▓H
 ╫█████╨   `█████▀         ▓████▀     ▀████▒
,╫████▄      `▓▀             ▀▀      ,▓████▌H
:╣██████▄           ,▓██           ╓███████▓H
 ╫████████K        ▓█████Ñ        ╫████████▌`
 ╠▓█████▀`          ╙██▓           `▀██████Ñ
 `╫███▀`      ▄▄            ,▄▄       ▀███▌`
  `╣██▓▄    ▄████▄        ,▓████▄    ,▄██▌` 
   `╨███▓▄▓████████▌    ╓█████████▄▄▄███▀`   
     ╙▀██████████████▌▄███████████████▀╨     
       ╙▀██████████████████████████▓▀╨`     
         `╨▀▓███████████████████▓▀╨`         
            ``╨▀▀▀█████████▀▀▀╨``           
                   ```````
AdultChain
   ██   
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
   ██   
Discord
ANN
       ████▓▄▄▐████╒▄▄▓███▌
       `██████▐████▐█████▀
          ╙▀▀▀▐████`▀▀▀`
              ▐████
        ▄▓████▐████▐███▓▄
       ▓██████▐████▐██████▄
       ████    ▀▓▀┘   ▓████
       ████    ███    ▓████
       ████   ▐███▄   ▓████
       ████  ║█████M  ▓████
       ████  ▐M███▌   ▓████
       ████  ▄████    ▓████
       ████  ████▓    ▓████     
       ████  ▓█ ▀█▌   ▓████
       ████  ▓█  ╙█∩  ▓████
       ████  █▌   ▀█  ▓████
       ████  ▀⌐    ▀▄ ▓████
       ████  ║▌    ╓█ ▓████
       ███████████████████▀
        ▀▓██████████████▀
   ██   
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
█  ██  █
1527346550
Hero Member
*
Offline Offline

Posts: 1527346550

View Profile Personal Message (Offline)

Ignore
1527346550
Reply with quote  #2

1527346550
Report to moderator
1527346550
Hero Member
*
Offline Offline

Posts: 1527346550

View Profile Personal Message (Offline)

Ignore
1527346550
Reply with quote  #2

1527346550
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1527346550
Hero Member
*
Offline Offline

Posts: 1527346550

View Profile Personal Message (Offline)

Ignore
1527346550
Reply with quote  #2

1527346550
Report to moderator
uDwcHYO
Full Member
***
Offline Offline

Activity: 333
Merit: 100


View Profile
December 06, 2017, 01:04:18 AM
 #842

I've already seen similar questions about null hashes, but I did not find an answer

Code:
[05:59:47] GPU0 | 47°C | Fan 1327 RPM | 924.4 H/s
[05:59:47] GPU1 | 46°C | Fan 1348 RPM | 925.7 H/s
[05:59:47] GPU2 | 46°C | Fan 1318 RPM | 900.6 H/s
[05:59:47] GPU3 | 45°C | Fan 1288 RPM | 0.0 H/s
[05:59:49] GPU0 | 46°C | Fan 1326 RPM | 924.0 H/s
[05:59:50] GPU1 | 46°C | Fan 1347 RPM | 925.3 H/s
[05:59:50] GPU2 | 46°C | Fan 1314 RPM | 899.3 H/s
[05:59:50] GPU3 | 46°C | Fan 1285 RPM | 0.0 H/s
[05:59:50] GPU0 | 46°C | Fan 1326 RPM | 0.0 H/s
[05:59:50] GPU1 | 47°C | Fan 1350 RPM | 0.0 H/s
[05:59:50] GPU2 | 45°C | Fan 1313 RPM | 0.0 H/s
[05:59:50] GPU3 | 45°C | Fan 1285 RPM | 235.3 H/s
[05:59:53] GPU0 | 46°C | Fan 1327 RPM | 921.3 H/s
[05:59:53] GPU1 | 46°C | Fan 1344 RPM | 923.7 H/s
[05:59:53] GPU2 | 46°C | Fan 1317 RPM | 896.8 H/s
[05:59:53] GPU3 | 45°C | Fan 1286 RPM | 0.0 H/s
[05:59:55] New job received. Avg Job Time: 31.0 sec
[05:59:55] GPU0 | 47°C | Fan 1329 RPM | 921.7 H/s
[05:59:55] GPU1 | 46°C | Fan 1343 RPM | 921.7 H/s
[05:59:55] GPU2 | 46°C | Fan 1318 RPM | 895.9 H/s
[05:59:55] GPU3 | 46°C | Fan 1288 RPM | 0.0 H/s

can I  do something with this problem? it can be with 1 card or 2 or 3. With the same settings, alternative miners work stably but give 7-9% less

   SEMUX   -   An innovative high-performance blockchain platform   
▬▬▬▬▬      Powered by Semux BFT consensus algorithm      ▬▬▬▬▬
Github    -    Discord    -    Twitter    -    Telegram    -    Airdrop to BTC holders
hozerdev
Jr. Member
*
Offline Offline

Activity: 44
Merit: 0


View Profile
December 06, 2017, 01:18:11 AM
 #843

Trying to run this miner on RX 580 rigs.
Getting "Error CL_DEVICE_NOT_FOUND calling clGetDeviceIDs for number of devices", tried different options like --opencl 0 /1. In device manager no integrated graphics, only rx 580s. Happens on all my rigs.
Any advise please?
uDwcHYO
Full Member
***
Offline Offline

Activity: 333
Merit: 100


View Profile
December 06, 2017, 01:31:01 AM
 #844

try using this data in command line  -G 0,1,2,3 -O 1 , where -G num id cards , it helped me, had the same problem

   SEMUX   -   An innovative high-performance blockchain platform   
▬▬▬▬▬      Powered by Semux BFT consensus algorithm      ▬▬▬▬▬
Github    -    Discord    -    Twitter    -    Telegram    -    Airdrop to BTC holders
hozerdev
Jr. Member
*
Offline Offline

Activity: 44
Merit: 0


View Profile
December 06, 2017, 01:57:29 AM
 #845

try using this data in command line  -G 0,1,2,3 -O 1 , where -G num id cards , it helped me, had the same problem
Thanks, it worked. Apparently --opencl doesn't work in 0.7. Getting just 60h/s more then claymore's miner. Overall 920 h/s per card.
duyquang06
Jr. Member
*
Offline Offline

Activity: 104
Merit: 0


View Profile
December 06, 2017, 03:06:22 AM
 #846

Can someone post complete list of configuration options, please  : (

I pull --help in bat file but nothing happens....Sadly

Really need readme.txt file Sad(

Thanks u guys.
MickDaster
Full Member
***
Offline Offline

Activity: 167
Merit: 100


View Profile WWW
December 06, 2017, 03:06:34 AM
 #847

try using this data in command line  -G 0,1,2,3 -O 1 , where -G num id cards , it helped me, had the same problem
Thanks, it worked. Apparently --opencl doesn't work in 0.7. Getting just 60h/s more then claymore's miner. Overall 920 h/s per card.

that is not that bad, which card is it again??

and what driver?

★ ★ ★ ★ ★   DeepOnion  ✔  Anonymous and Untraceable Cryptocurrency  ✔  TOR INTEGRATED & SECURED   ★ ★ ★ ★ ★
› › › › ›  JOIN THE NEW AIRDROP ✈️    ★    ✔ VERIFIED WITH DEEPVAULT  ‹ ‹ ‹ ‹ ‹
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬   ANN  WHITEPAPER  FACEBOOK  TWITTER  YOUTUBE  FORUM   ▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
gregzinho
Newbie
*
Offline Offline

Activity: 2
Merit: 0


View Profile
December 06, 2017, 03:17:39 AM
 #848

Error CL_MEM_OBJECT_ALLOCATION_FAILURE

How i solve this issue?
xeridea
Sr. Member
****
Offline Offline

Activity: 419
Merit: 251


View Profile WWW
December 06, 2017, 04:12:20 AM
 #849

Error CL_MEM_OBJECT_ALLOCATION_FAILURE

How i solve this issue?
Make your pagefile huge

Profitability over time charts for many GPUs - http://xeridea.us/charts

BTC:  16wzGLYLh1ximotu3Ln7htKnbUUcwWvQUv   LTC:  LdPvSJoAwgH87TXSMBuxDefBvp2bweXApY   Eth:  0xb508131ca5d983ebe72f8af61ecfb7d1b61f6d18
hozerdev
Jr. Member
*
Offline Offline

Activity: 44
Merit: 0


View Profile
December 06, 2017, 04:28:41 AM
 #850

that is not that bad, which card is it again??
and what driver?
Blockchain driver, Sapphire Rx580 Nitro SE, they hold 1200/2250 with 850v on core and memory.

I've already seen similar questions about null hashes, but I did not find an answer
Code:
...
[05:59:50] GPU3 | 46°C | Fan 1285 RPM | 0.0 H/s
[05:59:50] GPU0 | 46°C | Fan 1326 RPM | 0.0 H/s
[05:59:50] GPU1 | 47°C | Fan 1350 RPM | 0.0 H/s
[05:59:50] GPU2 | 45°C | Fan 1313 RPM | 0.0 H/s
...

can I  do something with this problem? it can be with 1 card or 2 or 3. With the same settings, alternative miners work stably but give 7-9% less
I have it too, v0.7. It doesn't seem cause any problem apart that it spams into a console.
eafindme
Newbie
*
Offline Offline

Activity: 10
Merit: 0


View Profile
December 06, 2017, 06:34:22 AM
 #851

Error CL_MEM_OBJECT_ALLOCATION_FAILURE

How i solve this issue?
Make your pagefile huge

Make your virtual memory multiples of your GPU's VRAM, eg, 5 pcs RX570 4G will need 5*4 = 20GB virtual memory on hard disk.
eafindme
Newbie
*
Offline Offline

Activity: 10
Merit: 0


View Profile
December 06, 2017, 06:49:08 AM
 #852

that is not that bad, which card is it again??
and what driver?
Blockchain driver, Sapphire Rx580 Nitro SE, they hold 1200/2250 with 850v on core and memory.

I've already seen similar questions about null hashes, but I did not find an answer
Code:
...
[05:59:50] GPU3 | 46°C | Fan 1285 RPM | 0.0 H/s
[05:59:50] GPU0 | 46°C | Fan 1326 RPM | 0.0 H/s
[05:59:50] GPU1 | 47°C | Fan 1350 RPM | 0.0 H/s
[05:59:50] GPU2 | 45°C | Fan 1313 RPM | 0.0 H/s
...

can I  do something with this problem? it can be with 1 card or 2 or 3. With the same settings, alternative miners work stably but give 7-9% less
I have it too, v0.7. It doesn't seem cause any problem apart that it spams into a console.

Yeah, it keeps spamming the console even though the statistics show that the GPU still running...

Code:
...
[Hash Rate Avg: 3147.9 H/s]
  717.4 H/s GPU0
  827.7 H/s GPU1
  805.1 H/s GPU2
  797.8 H/s GPU3

[Shares Found: 4 | Avg Search Time: 65.0 sec]
   4 (100%) Accepted
   0 (  0%) Rejected by pool
   0 (  0%) Invalid result computation failed
   0 (  0%) Could not be submit because of network error
   0 (  0%) Outdated because of job change

[14:44:04] GPU0 | 48°C | Fan 1639 RPM | 0.0 H/s
[14:44:04] GPU1 | 54°C | Fan 1879 RPM | 827.1 H/s
[14:44:04] GPU2 | 59°C | Fan 2070 RPM | 803.3 H/s
[14:44:04] GPU3 | 54°C | Fan 2025 RPM | 793.4 H/s
...
errata
Jr. Member
*
Offline Offline

Activity: 59
Merit: 0


View Profile
December 06, 2017, 10:28:41 AM
 #853

Hi all!

I wonder how does Cast XMR enumerate GPUs? Does it have any relation with OverdriveNTool? For example, OverdriveNTool reports cards in my system in this way:

Code:
0: iGPU
1: Nvidia
2: Vega 64
3: Vega 64
4: Vega 56
5: Vega 56
6: Vega 56

and I'm running Cast XMR like this:

Code:
cast_xmr-vega.exe --remoteaccess -S pool:7777 -u address -p pass --opencl 2 -G 0,1,2,3,4

Once CAST XMR starts, I can see the list of cards:

Code:
GPU0: gfx901 | 64 Compute Units
GPU1: gfx901 | 64 Compute Units
GPU2: gfx901 | 64 Compute Units
GPU3: gfx901 | 64 Compute Units
GPU4: gfx901 | 64 Compute Units

but how can I tell exactly which GPUs are Vega 64s and which ones are 56s?
otidar
Newbie
*
Offline Offline

Activity: 3
Merit: 0


View Profile
December 06, 2017, 10:36:00 AM
 #854

Hello,

i got the following issue:

initially i got average around 1900h/s and after some time, it can be minutes or hours, i drops to 1500-1600h/s

Anyone having such issue and eventually a solution ?
huntingthesnark
Member
**
Offline Offline

Activity: 119
Merit: 11


View Profile
December 06, 2017, 10:59:54 AM
 #855

Quick idiot question - how do you set failover pools? Thanks in advance!
Permonik
Member
**
Offline Offline

Activity: 163
Merit: 10


View Profile
December 06, 2017, 11:40:50 AM
 #856

Hi all!

I wonder how does Cast XMR enumerate GPUs? Does it have any relation with OverdriveNTool? For example, OverdriveNTool reports cards in my system in this way:

Code:
0: iGPU
1: Nvidia
2: Vega 64
3: Vega 64
4: Vega 56
5: Vega 56
6: Vega 56

and I'm running Cast XMR like this:

Code:
cast_xmr-vega.exe --remoteaccess -S pool:7777 -u address -p pass --opencl 2 -G 0,1,2,3,4

Once CAST XMR starts, I can see the list of cards:

Code:
GPU0: gfx901 | 64 Compute Units
GPU1: gfx901 | 64 Compute Units
GPU2: gfx901 | 64 Compute Units
GPU3: gfx901 | 64 Compute Units
GPU4: gfx901 | 64 Compute Units

but how can I tell exactly which GPUs are Vega 64s and which ones are 56s?
It is easy, just setup different rpm of fan for each gpu and you will see it.
errata
Jr. Member
*
Offline Offline

Activity: 59
Merit: 0


View Profile
December 06, 2017, 12:39:19 PM
 #857

Hi all!

I wonder how does Cast XMR enumerate GPUs? Does it have any relation with OverdriveNTool? For example, OverdriveNTool reports cards in my system in this way:

Code:
0: iGPU
1: Nvidia
2: Vega 64
3: Vega 64
4: Vega 56
5: Vega 56
6: Vega 56

and I'm running Cast XMR like this:

Code:
cast_xmr-vega.exe --remoteaccess -S pool:7777 -u address -p pass --opencl 2 -G 0,1,2,3,4

Once CAST XMR starts, I can see the list of cards:

Code:
GPU0: gfx901 | 64 Compute Units
GPU1: gfx901 | 64 Compute Units
GPU2: gfx901 | 64 Compute Units
GPU3: gfx901 | 64 Compute Units
GPU4: gfx901 | 64 Compute Units

but how can I tell exactly which GPUs are Vega 64s and which ones are 56s?
It is easy, just setup different rpm of fan for each gpu and you will see it.

So, there's no other way except being close to the card and observing it?
s3r9i0
Newbie
*
Online Online

Activity: 17
Merit: 0


View Profile
December 06, 2017, 02:45:05 PM
 #858

Have 7 RX580 GPUs, 8gb RAM

With 1 cards works good, but when us all 7 (-G 0,1,2,3,4,5,6) I see this error message:

CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0

* increasing the Virtual Memory up to 41Gb makes no sense
Peglar
Newbie
*
Offline Offline

Activity: 7
Merit: 0


View Profile
December 06, 2017, 02:57:18 PM
 #859

Have 7 RX580 GPUs, 8gb RAM

With 1 cards works good, but when us all 7 (-G 0,1,2,3,4,5,6) I see this error message:

CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0

* increasing the Virtual Memory up to 41Gb makes no sense

yet increasing the virtual memory will fix it. i have it set at 60gb on my vega rigs
th00ber
Hero Member
*****
Offline Offline

Activity: 726
Merit: 500


View Profile
December 06, 2017, 03:26:09 PM
 #860

Have 7 RX580 GPUs, 8gb RAM

With 1 cards works good, but when us all 7 (-G 0,1,2,3,4,5,6) I see this error message:

CL_MEM_OBJECT_ALLOCATION_FAILURE calling clEnqueueNDRangeKernel for kernel 0

* increasing the Virtual Memory up to 41Gb makes no sense

Who care about Gb lost on a rig ??
Mine is 60Gb and 5 Vega are running well.
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 [43] 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 ... 129 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!