Bitcoin Forum
November 18, 2017, 09:09:49 AM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 ... 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 [111] 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 ... 284 »
  Print  
Author Topic: [OS] nvOC easy-to-use Linux Nvidia Mining v0019-1.4  (Read 322268 times)
car1999
Full Member
***
Offline Offline

Activity: 168


View Profile
July 25, 2017, 07:26:08 AM
 #2201

Hello fullzero,
After a bunch of research and try, I built ccminer 2.2 successfully on nvOC 0018.

The previous build break is due to the openssl version,

Code:
m1@m1-desktop:~$ openssl version
OpenSSL 1.1.1-dev  xx XXX xxxx

You used a dev build of openssl in nvOC, ccminer doesn't support it. I download source code of openssl v1.0.2l from openssl.org, build the code, create a few soft links to replace the v1.1.1, it finally works. Not sure if this change breaks other things.

I also built alexis78 fork, https://github.com/alexis78/ccminer, it requires one more step, replace cuda-7.5 to cuda-8.0 in configure.sh.

I'm looking forward these miners in nvOC 0019.

Using linux requires some technical backgrounds, fortunately I was a windows developer Grin
1510996189
Hero Member
*
Offline Offline

Posts: 1510996189

View Profile Personal Message (Offline)

Ignore
1510996189
Reply with quote  #2

1510996189
Report to moderator
1510996189
Hero Member
*
Offline Offline

Posts: 1510996189

View Profile Personal Message (Offline)

Ignore
1510996189
Reply with quote  #2

1510996189
Report to moderator
1510996189
Hero Member
*
Offline Offline

Posts: 1510996189

View Profile Personal Message (Offline)

Ignore
1510996189
Reply with quote  #2

1510996189
Report to moderator
The Bitcoin network protocol was designed to be extremely flexible. It can be used to create timed transactions, escrow transactions, multi-signature transactions, etc. The current features of the client only hint at what will be possible in the future.
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1510996189
Hero Member
*
Offline Offline

Posts: 1510996189

View Profile Personal Message (Offline)

Ignore
1510996189
Reply with quote  #2

1510996189
Report to moderator
1510996189
Hero Member
*
Offline Offline

Posts: 1510996189

View Profile Personal Message (Offline)

Ignore
1510996189
Reply with quote  #2

1510996189
Report to moderator
akokkon
Newbie
*
Offline Offline

Activity: 5


View Profile
July 25, 2017, 07:33:16 AM
 #2202

I use nvoc for dual mining: DUAL_ETC_PASC

for ETC I can use only etc.nanopool.org or etc.ethermine.org servers, in all other ETC POOL servers I receive the message:

ETH: Authorization failed
: {"id":2,"jsonrpc":"2.0","result":null,"error":{"code":-1,"message":"Invalidlogin"}}
Stratum - reading socket failed, disconnect
ETH: Job timeout, disconnect, retry in 20 sec...

Please help me to find a solution.

Bibi187
Full Member
***
Offline Offline

Activity: 140


https://steemit.com/@bibi187


View Profile WWW
July 25, 2017, 09:53:15 AM
 #2203

I have NV 1060. How I can change Performance Level from 2 to 3 in Nvidia X server settings?


in 1bash set:

Code:
GPUPowerMizerMode_Adjust="YES"

GPUPowerMizerMode=3


or open a new guake tab and enter:

Code:
sudo nvidia-settings -a [gpu:0]/GPUPowerMizerMode=3

changing the number in (gpu:0) for the GPU you are adjusting.

Hi fullzero, any fix issue about this ?

Mode on GPUPowerMizer 0-1-2-3
Ubuntu dont detect the 3 one.
Screen as evidence Wink

http://imgur.com/a/wp7kx

Thanks for all your hardwork, to the other hard contributor to Wink

EDIT : how can i grab some log when i soft crash ? I would like to check this.

EDIT2 : My main GPU0, with display attached, got some mh/s drop like -3mh/s on max on period. That from the display ? Working on "REMOTE" + ssh fix the issue ?

Hey I have the same issue but my assumption is that the Nvidia GUI is showing level 1/2/3 BUT the Nvidia command line tool is showing 0/1/2 and (I am guessing) that 0=1, 1=2 and 2=3.

This is very possible.

No Sad
Nvidia GUI is showing 4lines level 0/1/2/3
And, when 1bash starting, level 3 is showing for short time

From the GUI nvidia we have 0 to 3, linux have only 3 setup for PowerMizer 0 to 2.
I assume the "3" state in only for windows ?
I put negativ oc on core & clock, + full power (150W), same deal "3" is not a valid value.

▀     DeepOnion  |  TOR Integrated & Secured  [ Facebook  Telegram  Bitcointalk  Twitter  Youtube  Reddit ]     ▀
Your Anonymity Guaranteed  ★  Your Assets Secured by TOR  ★  Guard Your Privacy!   ❱❱❱ JOIN AIRDROP NOW!
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬  File Authenticity Guaranteed by DeepVault  ▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
ivoldemar
Newbie
*
Offline Offline

Activity: 23


View Profile
July 25, 2017, 01:31:10 PM
 #2204

Good afternoon!
===
I'll start with the configuration of my equipment:
GPU - 13 Colorful P106-100 Mining (without video outputs) Edition or 12 + 1 MSI 1060/6 (with video output)
Motherboard H110 Pro BTC
===
Downloaded and installed nvoc 18 version.
Starting with the first run, the system immediately began to issue an error and go into reboot. (Screenshot attached) http://prntscr.com/fzo8uv http://prntscr.com/fzobub

If you quickly close this window with an error and try to start the miner - the system starts and mining.

But, the system does not respond to overclocking. Increasing the memory, setting the speed of the coolers, powerlimit - nothing is applied and the system can only run in the stock.

It did not work out, I tried to connect via integrated video graphics, also through a card with a video output. I suspect this is because of the error that pops up at the very beginning, related to xorg.

One error message also appears on one MSI 1060/6 card.

I tried to run the data on the motherboard H81 Pro BTC + net install Ubuntu + version of the drivers Nvidia 384.47 and everything was fine.

Tell me how to solve this problem?
For earlier I express my gratitude!

I ask for prognosis for the possibly incorrect text, tk. I used an interpreter.

nvOC doesn't support integrated graphics.  If you connect a monitor to the integrated graphics you will enter an infinite loop where the system xorg get corrupted then 1bash restores the xorg and reboots.

If you have connected a monitor to integrated graphics previously; after switching to using the primary GPU (the one connected to the 16x slot) you will need to allow the system to reboot once, then on the second boot after changing it should work.



WTF?

http://prntscr.com/g02inr
http://prntscr.com/g02iuz
http://prntscr.com/g02j15


UPDATE:

The system finally started. But, overclocking is applied only to the card in which the monitor is inserted. The remaining P106 cards do not overclock. Screenshots I enclose.
http://prntscr.com/g03joa
http://prntscr.com/g03jt8
http://prntscr.com/g03jyl
It's unclear what else, manual control of the cooler is turned on, set to 100%. But still the system adjusts them automatically.
dittie
Jr. Member
*
Offline Offline

Activity: 41


View Profile
July 25, 2017, 02:58:33 PM
 #2205

Hello fullzero,
After a bunch of research and try, I built ccminer 2.2 successfully on nvOC 0018.

The previous build break is due to the openssl version,

Code:
m1@m1-desktop:~$ openssl version
OpenSSL 1.1.1-dev  xx XXX xxxx

You used a dev build of openssl in nvOC, ccminer doesn't support it. I download source code of openssl v1.0.2l from openssl.org, build the code, create a few soft links to replace the v1.1.1, it finally works. Not sure if this change breaks other things.

I also built alexis78 fork, https://github.com/alexis78/ccminer, it requires one more step, replace cuda-7.5 to cuda-8.0 in configure.sh.

I'm looking forward these miners in nvOC 0019.

Using linux requires some technical backgrounds, fortunately I was a windows developer Grin

Is it worth to upgrade?

Get Free ONION https://deeponion.org/apply TOR Integrated Crypto
argonaute
Jr. Member
*
Offline Offline

Activity: 48


View Profile
July 25, 2017, 03:01:51 PM
 #2206

Hi Fullzero

I want to share with you a GPU failed that the watchdog is not able to detect

wdog screen:

GPU UTILIZATION:  Unable to determine the device handle for GPU 0000:09:00.0: GPU is lost. Reboot the system to recover this GPU

/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: Unable: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: to: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: determine: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: the: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: device: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: handle: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: for: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: GPU: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: 0000:09:00.0:: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: GPU: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: is: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: lost.: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: Reboot: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: the: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: system: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: to: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: recover: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: this: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: GPU: integer expression expected
Tue Jul 25 16:57:01 CEST 2017 - All good! Will check again in 60 seconds


GPU UTILIZATION:  Unable to determine the device handle for GPU 0000:09:00.0: GPU is lost. Reboot the system to recover this GPU

/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: Unable: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: to: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: determine: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: the: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: device: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: handle: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: for: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: GPU: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: 0000:09:00.0:: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: GPU: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: is: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: lost.: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: Reboot: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: the: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: system: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: to: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: recover: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: this: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: GPU: integer expression expected
Tue Jul 25 16:58:01 CEST 2017 - All good! Will check again in 60 seconds


the miner show/detect only 6 GPU over 7

nvidia-smi doesn't work
$ nvidia-smi
Unable to determine the device handle for GPU 0000:09:00.0: GPU is lost.  Reboot the system to recover this GPU

temp screen:
Provided power limit 75.00 W is not a valid power limit which should be between 115.00 W and 291.00 W for GPU 00000000:0A:00.0
Terminating early due to previous errors.
Tue Jul 25 17:01:07 CEST 2017 - All good, will check again soon

GPU 0, Target temp: 61, Current: 60, Diff: 1, Fan: 75, Power: 123.46

GPU 1, Target temp: 61, Current: 60, Diff: 1, Fan: 63, Power: 124.62

GPU 2, Target temp: 61, Current: 59, Diff: 2, Fan: 77, Power: 119.23

GPU 3, Target temp: 61, Current: 60, Diff: 1, Fan: 68, Power: 120.72

GPU 4, Target temp: 61, Current: 59, Diff: 2, Fan: 57, Power: 124.26

GPU 5, Target temp: 61, Current: Unable, Diff: 61, Fan: to, Power: determine

/home/m1/Maxximus007_AUTO_TEMPERATURE_CONTROL: line 125: [: Unable: integer expression expected
/home/m1/Maxximus007_AUTO_TEMPERATURE_CONTROL: line 158: [: the: integer expression expected
/home/m1/Maxximus007_AUTO_TEMPERATURE_CONTROL: line 171: [: to: integer expression expected
GPU 6, Target temp: 61, Current: 55, Diff: 6, Fan: 50, Power: 126.76

Tue Jul 25 17:01:37 CEST 2017 - Restoring Power limit for gpu:6. Old limit: 125 New limit: 75 Fan speed: 50

Provided power limit 75.00 W is not a valid power limit which should be between 115.00 W and 291.00 W for GPU 00000000:0A:00.0
Terminating early due to previous errors.
Tue Jul 25 17:01:37 CEST 2017 - All good, will check again soon

muxufe
Newbie
*
Offline Offline

Activity: 1


View Profile
July 25, 2017, 04:12:03 PM
 #2207

I have NV 1060. How I can change Performance Level from 2 to 3 in Nvidia X server settings?


in 1bash set:

Code:
GPUPowerMizerMode_Adjust="YES"

GPUPowerMizerMode=3


or open a new guake tab and enter:

Code:
sudo nvidia-settings -a [gpu:0]/GPUPowerMizerMode=3

changing the number in (gpu:0) for the GPU you are adjusting.

Hi fullzero, any fix issue about this ?

Mode on GPUPowerMizer 0-1-2-3
Ubuntu dont detect the 3 one.
Screen as evidence Wink

http://imgur.com/a/wp7kx

Thanks for all your hardwork, to the other hard contributor to Wink

EDIT : how can i grab some log when i soft crash ? I would like to check this.

EDIT2 : My main GPU0, with display attached, got some mh/s drop like -3mh/s on max on period. That from the display ? Working on "REMOTE" + ssh fix the issue ?

Hey I have the same issue but my assumption is that the Nvidia GUI is showing level 1/2/3 BUT the Nvidia command line tool is showing 0/1/2 and (I am guessing) that 0=1, 1=2 and 2=3.

This is very possible.

No Sad
Nvidia GUI is showing 4lines level 0/1/2/3
And, when 1bash starting, level 3 is showing for short time

From the GUI nvidia we have 0 to 3, linux have only 3 setup for PowerMizer 0 to 2.
I assume the "3" state in only for windows ?
I put negativ oc on core & clock, + full power (150W), same deal "3" is not a valid value.


There is a difference between performance mode and performance levels. Performance mode  0 is "prefere maximum performance" mode 1 is "adaptive" and 2 is "auto". Performance level is the thing with the clock speeds(adaptive clocking)1 to 4, witch you can see in the gui. It looks like a by design "feature" from the nvidia driver. Wink Everytime you start the miner software the performance level goes to 3 and the card clock will go down. Overclocking settings will also effect the clock speed on a lower perfomance level.
Example : level 1   200mhz  and 400mhz
                  level 2   400mhz and 100mhz
                  level 3   1200mhz and 3000mhz
                  level 4    1700mhz and 4000mhz
After overclocking gpu +100 memory +1000 it will look like this:
                  level 1   300mhz  and 1400mhz
                  level 2   500mhz and 1100mhz
                  level 3   1300mhz and 4000mhz
                  level 4   1800mhz and 5000mhz
The only thing you do with overclocking, is making your card clocks speed as fast as it should be.
It would be super if someone has a solution for that. Wink
Btw nvidia-smi -ac 5000,1800 won’t work in my case.(application clocking)

There is also a post at the nvidia devforum with the same problems.
gyoztes
Newbie
*
Offline Offline

Activity: 16


View Profile
July 25, 2017, 04:50:19 PM
 #2208


Hi guys,

While I use v18, I get this error.

http://www.ballai.hu/image1.jpg

The vga params are the same as in v17 (7x1070, power limit 100, proc: -200, mem: +1100). In v17 it was stable as rock for weeks.
The problems:
- I use watchdog param but it is not restarting
- once restart after 8 hours
- ctrl+c does not work
- in the first 10 minutes I can reboot from console
- I can not use teamviewer

Please help me to find a solution.

Thank you ind advance!
mikespax
Member
**
Offline Offline

Activity: 98


View Profile WWW
July 25, 2017, 08:22:55 PM
 #2209

Hi guys! Guys with 1080Ti mining LBC, how did you set up 1bash to mine this coin? I still can't beat an issue with worker autentification. What should I paste in 1bash? Please advice. Thank you!

I responded to your pm; let me know if you get it to work.

could I also get this answer? just having the same stupid issues with any pools that require workers. if you prefilled the bash with your own working worker info and stuff it might help idiots like me get started. I did notice that I got an authentication stratum error when just trying to run with your prefilled LBC information
fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
July 25, 2017, 11:02:19 PM
 #2210

THANK YOU FOR YOUR PROMPT AND CONSIDERATE REPLY--

I appreciate it, and notice that you are replying to all the bloggers here.  Really a healthy approach to development!  I hope you get enough sleep each day!

I will follow your blog until the nvOC operating system makes sense to me.  I really want to use it in my 1050ti rig when it goes together.

Thanks again for your efforts!       --scryptr

I am not very good at sleeping; I will try to get a good schedule soon.

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
July 25, 2017, 11:02:55 PM
 #2211

Unzipping nvOC_v0018.zip (hash verified) on MacOSX using default Unarchiver or unzip resulted in corrupted file (I noticed this issue has been reported by several users). Because I don't have PC where to extract it, I found that Keka (http://www.kekaosx.com/en/) works perfectly. Keka is free unarchiver for Mac based on p7zip (7-zip port) and it extracted file without issues. Maybe it can be added to instructions for mac to avoid frustration for mac users.

I will add a link to this with a note on the OP.

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
July 25, 2017, 11:09:47 PM
 #2212

Overvolting ...is it possible with nvOC? Seems like there is literature on it for Linux with Nvidia:

https://devtalk.nvidia.com/default/topic/902932/linux/overvolting-/

But I have not found a way to do it yet. It would be helpful for a number of algorithms ...overvolt a bit and lower wattage. I do it in Windows with Equihash with very nice results on my 1060 cards.



This reference is in regard to Maxwell and older series GPUs.  I am not sure if Over / undervolting is possible via api in Linux for 1000 series;  I will look into this later: I believe it is already on the list.

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
July 25, 2017, 11:16:50 PM
 #2213

my rigs keep restarting after few minutes. Some after 5 mins some after 30. Im not sure why this keeps happening.

im using all 1070's with core 100 / 1050 also i tried 150-200 / 1100-1600. No luck

what is your power limit on them? for 1070s I would push around 120-125 with a moderate/heavy OC. Anything less can cause stability problems.

my power limits are all at 125

in the home directory there is a file named:

Code:
4_restartlog

open it with gedit and tell me what is there


It says utilization is too low. Reviving did not work so restarting machine


Are you sure the client is connecting correctly to the pool?  If you disable the watchdog:

Code:
IAmNotAJeep_and_Maxximus007_WATCHDOG="NO"

What happens when you try to mine?

Also what COIN are you mining?

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
July 25, 2017, 11:33:50 PM
 #2214

Hi Fullzero! Great job!! Thank you.
New coin is out there  SIGT signatum. Can you add it please?

I see an awful lot of requests for Fullzero to add coins. Jeez people just add them yourself! He doesn't know or probably even care what coin your mining.
It's REALLY REALLY REALLY REALLY easy to add or even remove coins from 1bash.
I think of 1bash as a template that I can tailor to my own needs.

LOL just my opinion....

I will add it to the list.  

Anyone who uses a COIN they added themselves please post the code and save me time adding it in the future.  

Also if you want a COIN selection added please research and find a pool you want to use with that COIN; to save me the time doing that as well.

It is easy to add a coin to nvOC IF it uses the same algorithm as an existing coin.

To anyone who doesn't know how to add a coin.  First find out what algorithm it uses.  If it uses the equihash algo for example, find the following code about 2/3 to the end of 1bash and copy it and past it, then change all of the "ZEC" in the new code to the coin you want to mine (excluding HCD='/home/m1/zec/miner'-leave that alone):

if [ $COIN == "ZEC" ]
then
HCD='/home/m1/zec/miner'
ZECADDR="$ZEC_ADDRESS.$ZEC_WORKER"
until $HCD --eexit 3 --fee $EWBF_PERCENT --pec --server $ZEC_POOL --user $ZECADDR --pass z --port $ZEC_PORT;
   do
   echo "FAILURE; reinit in 5" >&2
   sleep 5
done
fi

So it would look like:

if [ $COIN == "NEWCOIN" ]
then
HCD='/home/m1/zec/miner'
NEWCOINADDR="$NEWCOIN_ADDRESS.$NEWCOIN_WORKER"
until $HCD --eexit 3 --fee $EWBF_PERCENT --pec --server $NEWCOIN_POOL --user $NEWCOINADDR --pass z --port $NEWCOIN_PORT;
   do
   echo "FAILURE; reinit in 5" >&2
   sleep 5
done
fi

Do the same for the address and pool area towards the beginning of 1bash.

However, I haven't figured out how to add a new algorithm to the mix.  I also wanted to try out this SIGT.  I downloaded the new version of ccminer 2.2 that others are using and followed their guide on adding the .bat file, but couldn't get it to run. 

Maybe a guide on adding new miner software would save you some time in the future.  This is a great mining OS.  The downside is that it attracts many newer miners like myself.  Smiley

Thanks for your help.

The problem with making a generic guide is that pool and mining client syntax vary.  I don't really have a good solution to this.

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
July 25, 2017, 11:35:16 PM
 #2215

I have NV 1060. How I can change Performance Level from 2 to 3 in Nvidia X server settings?


in 1bash set:

Code:
GPUPowerMizerMode_Adjust="YES"

GPUPowerMizerMode=3


or open a new guake tab and enter:

Code:
sudo nvidia-settings -a [gpu:0]/GPUPowerMizerMode=3

changing the number in (gpu:0) for the GPU you are adjusting.

Hi fullzero, any fix issue about this ?

Mode on GPUPowerMizer 0-1-2-3
Ubuntu dont detect the 3 one.
Screen as evidence Wink

http://imgur.com/a/wp7kx

Thanks for all your hardwork, to the other hard contributor to Wink

EDIT : how can i grab some log when i soft crash ? I would like to check this.

EDIT2 : My main GPU0, with display attached, got some mh/s drop like -3mh/s on max on period. That from the display ? Working on "REMOTE" + ssh fix the issue ?

Hey I have the same issue but my assumption is that the Nvidia GUI is showing level 1/2/3 BUT the Nvidia command line tool is showing 0/1/2 and (I am guessing) that 0=1, 1=2 and 2=3.

This is very possible.

No Sad
Nvidia GUI is showing 4lines level 0/1/2/3
And, when 1bash starting, level 3 is showing for short time

From the GUI nvidia we have 0 to 3, linux have only 3 setup for PowerMizer 0 to 2.
I assume the "3" state in only for windows ?
I put negativ oc on core & clock, + full power (150W), same deal "3" is not a valid value.

If it is possible to use lvl 3 it most likely require Higher not lower OC; and perhaps a positive powerlimit.

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
July 25, 2017, 11:40:55 PM
 #2216

Hello fullzero,
After a bunch of research and try, I built ccminer 2.2 successfully on nvOC 0018.

The previous build break is due to the openssl version,

Code:
m1@m1-desktop:~$ openssl version
OpenSSL 1.1.1-dev  xx XXX xxxx

You used a dev build of openssl in nvOC, ccminer doesn't support it. I download source code of openssl v1.0.2l from openssl.org, build the code, create a few soft links to replace the v1.1.1, it finally works. Not sure if this change breaks other things.

I also built alexis78 fork, https://github.com/alexis78/ccminer, it requires one more step, replace cuda-7.5 to cuda-8.0 in configure.sh.

I'm looking forward these miners in nvOC 0019.

Using linux requires some technical backgrounds, fortunately I was a windows developer Grin

Thanks car1999;

this was helpful.

the problem with tp2.2 on nvOC was a file in the openssl: bn.h.  I swapped it with the version it was looking for and this resolved all the related errors.

Also the cuda version does need to be changed in configure.sh as you described, but also for 1000 series GPUs Makefile.am must be altered with the correct Arch flag, 61 for the 1000 series.

I compiled both alexis78 and Tpuvot 2.2 ccminer clients and added at download link to them on the OP.  I will include them in v0019 of course.

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
July 26, 2017, 01:37:04 AM
 #2217

I use nvoc for dual mining: DUAL_ETC_PASC

for ETC I can use only etc.nanopool.org or etc.ethermine.org servers, in all other ETC POOL servers I receive the message:

ETH: Authorization failed
: {"id":2,"jsonrpc":"2.0","result":null,"error":{"code":-1,"message":"Invalidlogin"}}
Stratum - reading socket failed, disconnect
ETH: Job timeout, disconnect, retry in 20 sec...

Please help me to find a solution.

You might be using a pool that requires you to create a worker beforehand then only accepts those pre-made workers.

What pool are you using?

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
July 26, 2017, 01:40:46 AM
 #2218

Good afternoon!
===
I'll start with the configuration of my equipment:
GPU - 13 Colorful P106-100 Mining (without video outputs) Edition or 12 + 1 MSI 1060/6 (with video output)
Motherboard H110 Pro BTC
===
Downloaded and installed nvoc 18 version.
Starting with the first run, the system immediately began to issue an error and go into reboot. (Screenshot attached) http://prntscr.com/fzo8uv http://prntscr.com/fzobub

If you quickly close this window with an error and try to start the miner - the system starts and mining.

But, the system does not respond to overclocking. Increasing the memory, setting the speed of the coolers, powerlimit - nothing is applied and the system can only run in the stock.

It did not work out, I tried to connect via integrated video graphics, also through a card with a video output. I suspect this is because of the error that pops up at the very beginning, related to xorg.

One error message also appears on one MSI 1060/6 card.

I tried to run the data on the motherboard H81 Pro BTC + net install Ubuntu + version of the drivers Nvidia 384.47 and everything was fine.

Tell me how to solve this problem?
For earlier I express my gratitude!

I ask for prognosis for the possibly incorrect text, tk. I used an interpreter.

nvOC doesn't support integrated graphics.  If you connect a monitor to the integrated graphics you will enter an infinite loop where the system xorg get corrupted then 1bash restores the xorg and reboots.

If you have connected a monitor to integrated graphics previously; after switching to using the primary GPU (the one connected to the 16x slot) you will need to allow the system to reboot once, then on the second boot after changing it should work.



WTF?

http://prntscr.com/g02inr
http://prntscr.com/g02iuz
http://prntscr.com/g02j15


UPDATE:

The system finally started. But, overclocking is applied only to the card in which the monitor is inserted. The remaining P106 cards do not overclock. Screenshots I enclose.
http://prntscr.com/g03joa
http://prntscr.com/g03jt8
http://prntscr.com/g03jyl
It's unclear what else, manual control of the cooler is turned on, set to 100%. But still the system adjusts them automatically.


If you want all the fans set to 100% ensure:

Code:
Maxximus007_AUTO_TEMPERATURE_CONTROL="NO"

Also I changed 1bash to hopefully better support the p106 GPUs in the bux fix version linked at the top of the OP.  I don't have any of these, so these changes were based on what other members have reported.

Looking at your screenshots; it looks like there is a problem either with the image on the ssd or with the ssd itself.  I would try reimaging and using the bug fix 1bash and files.

BTW this rig looks good; I want to make one of these myself.

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
July 26, 2017, 01:43:02 AM
 #2219

Hello fullzero,
After a bunch of research and try, I built ccminer 2.2 successfully on nvOC 0018.

The previous build break is due to the openssl version,

Code:
m1@m1-desktop:~$ openssl version
OpenSSL 1.1.1-dev  xx XXX xxxx

You used a dev build of openssl in nvOC, ccminer doesn't support it. I download source code of openssl v1.0.2l from openssl.org, build the code, create a few soft links to replace the v1.1.1, it finally works. Not sure if this change breaks other things.

I also built alexis78 fork, https://github.com/alexis78/ccminer, it requires one more step, replace cuda-7.5 to cuda-8.0 in configure.sh.

I'm looking forward these miners in nvOC 0019.

Using linux requires some technical backgrounds, fortunately I was a windows developer Grin

Is it worth to upgrade?

Yes, it makse a difference with some coins; ESP when using alexis78 for DGB:

I compiled both alexis78 and Tpuvot 2.2 ccminer clients and added at download link to them on the OP.  I will include them in v0019 of course.

car1999 saved me a bunch of time with this  Smiley.


fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
July 26, 2017, 01:44:45 AM
 #2220

Hi Fullzero

I want to share with you a GPU failed that the watchdog is not able to detect

wdog screen:

GPU UTILIZATION:  Unable to determine the device handle for GPU 0000:09:00.0: GPU is lost. Reboot the system to recover this GPU

/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: Unable: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: to: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: determine: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: the: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: device: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: handle: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: for: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: GPU: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: 0000:09:00.0:: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: GPU: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: is: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: lost.: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: Reboot: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: the: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: system: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: to: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: recover: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: this: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: GPU: integer expression expected
Tue Jul 25 16:57:01 CEST 2017 - All good! Will check again in 60 seconds


GPU UTILIZATION:  Unable to determine the device handle for GPU 0000:09:00.0: GPU is lost. Reboot the system to recover this GPU

/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: Unable: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: to: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: determine: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: the: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: device: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: handle: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: for: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: GPU: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: 0000:09:00.0:: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: GPU: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: is: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: lost.: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: Reboot: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: the: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: system: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: to: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: recover: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: this: integer expression expected
/home/m1/IAmNotAJeep_and_Maxximus007_WATCHDOG: line 44: [: GPU: integer expression expected
Tue Jul 25 16:58:01 CEST 2017 - All good! Will check again in 60 seconds


the miner show/detect only 6 GPU over 7

nvidia-smi doesn't work
$ nvidia-smi
Unable to determine the device handle for GPU 0000:09:00.0: GPU is lost.  Reboot the system to recover this GPU

temp screen:
Provided power limit 75.00 W is not a valid power limit which should be between 115.00 W and 291.00 W for GPU 00000000:0A:00.0
Terminating early due to previous errors.
Tue Jul 25 17:01:07 CEST 2017 - All good, will check again soon

GPU 0, Target temp: 61, Current: 60, Diff: 1, Fan: 75, Power: 123.46

GPU 1, Target temp: 61, Current: 60, Diff: 1, Fan: 63, Power: 124.62

GPU 2, Target temp: 61, Current: 59, Diff: 2, Fan: 77, Power: 119.23

GPU 3, Target temp: 61, Current: 60, Diff: 1, Fan: 68, Power: 120.72

GPU 4, Target temp: 61, Current: 59, Diff: 2, Fan: 57, Power: 124.26

GPU 5, Target temp: 61, Current: Unable, Diff: 61, Fan: to, Power: determine

/home/m1/Maxximus007_AUTO_TEMPERATURE_CONTROL: line 125: [: Unable: integer expression expected
/home/m1/Maxximus007_AUTO_TEMPERATURE_CONTROL: line 158: [: the: integer expression expected
/home/m1/Maxximus007_AUTO_TEMPERATURE_CONTROL: line 171: [: to: integer expression expected
GPU 6, Target temp: 61, Current: 55, Diff: 6, Fan: 50, Power: 126.76

Tue Jul 25 17:01:37 CEST 2017 - Restoring Power limit for gpu:6. Old limit: 125 New limit: 75 Fan speed: 50

Provided power limit 75.00 W is not a valid power limit which should be between 115.00 W and 291.00 W for GPU 00000000:0A:00.0
Terminating early due to previous errors.
Tue Jul 25 17:01:37 CEST 2017 - All good, will check again soon


I believe this is the exact problem that Maxximus007 recently made a new code block to resolve.

Pages: « 1 ... 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 [111] 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 ... 284 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!