Bitcoin Forum
August 17, 2022, 01:07:23 PM *
News: Latest Bitcoin Core release: 23.0 [Torrent]
 
   Home   Help Search Login Register More  
Pages: « 1 ... 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 [112] 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 ... 500 »
  Print  
Author Topic: PhoenixMiner 6.2c: fastest Ethereum/Ethash miner with lowest devfee (Win/Linux)  (Read 770954 times)
haliy-2017
Newbie
*
Offline Offline

Activity: 66
Merit: 0


View Profile
July 17, 2018, 11:23:03 AM
 #2221

...
FATAL ERROR: Debugger Detected

i tried with and without the -amd
Hello
I needed to install the drivers new. I use -amd. I use RX480, blockchain driver and 3.0c. Stopped working last friday.
Quote
FATAL ERROR: Debugger detected
What can I do? Claymore is working.
Thx for helping
   We have made some changes in anti-debug code in PhoenixMiner 3.1, which should solve (hopefully) most of these problems.

Dr. Phoenix,
Thanks for the great product.  I've found it faster and more reliable than the competition.

My .bat file points to an alternative config file.  Instead of specifying pools in my config.txt is there a way I can point to the epool.txt file?

Thank you.
   If you put the epools.txt file in the same folder as the miner (or in the same folder as the config.txt file), the miner will find it and read it without any additional options. We will add options to specify alternative names for the config and epools files in the next version.

Thanks. I have 39 amd 570 (3 rigs à 13 gpu).
Raised total speed from 1208 to 1213 with phoenix with autotune. Havent tried manually adjusting yet.

The speed was more stable with claymore (1208 mh/s). With phoenix it is from 1210-1213.
And the speed is different from each time the miner restarts due to auto-tune. Maybe it is better to write down the best settings and set the tune manually.
   Yes, this is the preferred way because even with all measures to make the auto-tuning reliable, if Windows starts messing with the GPUs during the auto-tune process, the results may be sub-optimal. Just don't forget to re-run auto-tune if you upgrade the drivers, or the miner itself, or if you change your OC settings, or mod the BIOS.


Hashrate is very stabel in 2.9e and in 3.0c. But "Average Hashrate for last 6 hours" in nanopool statistics page (https://eth.nanopool.org/account/0x...) for 3.0 typically show values less then reported hashrate and "Calculator" tab on this page shows about 0.36 ETH per month, but with 2.9e I have typically "Average Hashrate for last 6 hours" bigger then reported hashrate and calculator shows nubers bigger on 0.1 ETH per month. So if 3.0 shows 0.3x ETH per month, 2.9 shows 4.x ETH per month.

My command line for 2.9 and for 3.0 is:

set miner_params=-nvidia -cdm 2 -cdmport 3333 -cdmpass 12345 -minRigSpeed 188 -rmode 2 -tstop 65 -tstart 40 -logsmaxsize 0 -nvf 2
   Well, while ultimately the pool-side hashrate is all that matters, we only use the reported (local) hashrate when we working on the kernels because the former can be very unstable and prone to random ups and downs due to good/bad luck hitting the shares. Our test rigs are running more than 700 MH/s in total and even so, we have a few perecents ups or downs on pool-side hashrate in the matter of week or so, without any changes from our side, so there is that.


Loving Phoenix - 3 rigs, combination of XFX RX570's and RX580's.   Definitely more stable than claymore with fine tuning.

Question regarding -fanmin and -fanmax?

I used to run and set everything with Afterburner and claymore, including manual fan setting.
I set everything on one rig using Afterburner to 65% fan
Then, I stopped afternburner, started up Phoenix with command line addition of "-fanmin 75."
The speed still stays at 65 on all cards in the rig
Any thoughts?

DEVFEE and open source:

Also, any thoughts about making this public domain open source?
I would think that even at 0.65%, your Devfee should have more than paid for itself at this point.
How long do you want to keep it private and collect fee?

If it were me, I'd make it open source, make -devfee an option, and if we love it, have no problem setting a fee.   Certainly, I'd pay the fee (especially if I can control it)
Seems like if it were open source, people would be happier to compile it, and trust it as trustworthy.
It would help with adoption of the Phoenix Miner for the masses.
   Thank you for using our miner, we will continue to improve it!
   First, the OC settings of Phoenix doesn't work reliably on drivers older than 18.x.x. If you are using 18.x.x drivers, also note that the minimum and maximum fan speeds are subject to limitations from the GPU BIOS.
   Second, we don't plan to go open-source until some time after we stop working on improvements (which won't any time soon). Two of us are in the process of winding down their day jobs to in order to focus working on the miner and they wouldn't do this if the income is unstable and they can't support their families with it. While we appreciate that a lot of miners will continue to pay the devfee if it is optional, some of us has no so good experince with such "donationware", which ultimately fails to generate any meaningful revenue.

Does the miner create a new logfile when it is closed and starts again?
  Yes, unless you have specified explicit log file name with the -logfile command-line option. See the documentation for this option in the first post of this thread for more information.

Hi.
phoniex miner crashes just after starting load gpu log file doesnt give too much info.here is the log:

Code:
2018.07.04:11:54:56.713: main Phoenix Miner 3.0c Windows/msvc - Release
2018.07.04:11:54:56.713: main Cmd line: -pool etc.arsmine.net:8008 -wal 0x1c9cfc8a55dc86cee1c07a354593428d8894ad30 -worker Robert -pass x -coin etc -rmode 1 -wdog 1 -log 2 -ftimeout 200
2018.07.04:11:55:10.755: main Available GPUs for mining:
2018.07.04:11:55:10.755: main GPU1: Radeon RX 570 Series (pcie 1), OpenCL 2.0, 4 GB VRAM, 32 CUs
2018.07.04:11:55:10.756: main GPU2: Radeon RX 580 Series (pcie 2), OpenCL 2.0, 8 GB VRAM, 36 CUs
2018.07.04:11:55:10.756: main GPU3: Radeon RX 570 Series (pcie 6), OpenCL 2.0, 4 GB VRAM, 32 CUs
2018.07.04:11:55:10.756: main GPU4: Radeon RX 570 Series (pcie 7), OpenCL 2.0, 4 GB VRAM, 32 CUs
2018.07.04:11:55:10.756: main GPU5: Radeon RX 570 Series (pcie Cool, OpenCL 2.0, 8 GB VRAM, 32 CUs
2018.07.04:11:55:10.756: main GPU6: Radeon RX 570 Series (pcie 9), OpenCL 2.0, 4 GB VRAM, 32 CUs
2018.07.04:11:55:10.756: main GPU7: Radeon RX 570 Series (pcie 10), OpenCL 2.0, 4 GB VRAM, 32 CUs
2018.07.04:11:55:10.756: main GPU8: GeForce GTX 1070 (pcie 11), CUDA cap. 6.1, 8 GB VRAM, 15 CUs
2018.07.04:11:55:10.756: main GPU9: GeForce GTX 1050 Ti (pcie 12), CUDA cap. 6.1, 4 GB VRAM, 6 CUs
2018.07.04:11:55:10.756: main GPU10: Radeon RX 580 Series (pcie 13), OpenCL 2.0, 4 GB VRAM, 36 CUs
2018.07.04:11:55:11.338: main ADL library initialized
2018.07.04:11:55:11.375: main NVML library initialized
2018.07.04:11:55:12.143: main Listening for CDM remote manager at port 3333 in read-only mode
2018.07.04:11:55:12.143: main Eth: the pool list contains 1 pool
2018.07.04:11:55:12.143: main Eth: primary pool: etc.arsmine.net:8008
2018.07.04:11:55:12.143: main Starting GPU mining
2018.07.04:11:55:12.143: main Matched GPU1 to ADL adapter index 32 (method 1)
2018.07.04:11:55:12.425: main GPU1: Created ADL monitor for adapter 32; overdrive version: 7
2018.07.04:11:55:12.426: main GPU1: using AMD driver ver 18.6.1
2018.07.04:11:55:12.426: main Matched GPU2 to ADL adapter index 80 (method 1)
2018.07.04:11:55:12.855: main GPU2: Created ADL monitor for adapter 80; overdrive version: 7
2018.07.04:11:55:12.855: main GPU2: using AMD driver ver 18.6.1
2018.07.04:11:55:12.855: main Matched GPU3 to ADL adapter index 64 (method 1)
2018.07.04:11:55:13.369: main GPU3: Created ADL monitor for adapter 64; overdrive version: 7
2018.07.04:11:55:13.369: main GPU3: using AMD driver ver 18.6.1
2018.07.04:11:55:13.370: main Matched GPU4 to ADL adapter index 96 (method 1)
2018.07.04:11:55:13.752: main GPU4: Created ADL monitor for adapter 96; overdrive version: 7
2018.07.04:11:55:13.752: main GPU4: using AMD driver ver 18.6.1
2018.07.04:11:55:13.753: main Matched GPU5 to ADL adapter index 112 (method 1)
2018.07.04:11:55:14.328: main GPU5: Created ADL monitor for adapter 112; overdrive version: 7
2018.07.04:11:55:14.329: main GPU5: using AMD driver ver 18.6.1
2018.07.04:11:55:14.329: main Matched GPU6 to ADL adapter index 48 (method 1)
2018.07.04:11:55:14.627: main GPU6: Created ADL monitor for adapter 48; overdrive version: 7
2018.07.04:11:55:14.627: main GPU6: using AMD driver ver 18.6.1
2018.07.04:11:55:14.627: main Matched GPU7 to ADL adapter index 16 (method 1)

--------------------------------------------------------
Any help? 2.9d works with out any problem.
Many thx in advance
   Please try the following:
   - increase the page file size to 32 GB (10 x 2.6 GB per DAG plus a few GBs for Windows)
   - try using -amd option to see if the rig starts without the Nvidia cards
   - try using the -lidag command-line option and/or the -gser command-line option to decrease the intensity during or serialize the DAG generation

When is next version due??
    It is already late because of the Linux support. Ideally we would like to release 3.1 for both Windows and Linux (at least in alpha form for Linux) but if the delay becomes too big, will release the Windows version first.

I don't know why but I have tried many times: with 800-850Mhs, I mine solo CLO at altpool.pro, if I use Phoenix or Bminer, I find 0 - 1 block/24h, if I use Claymore, I find 3 - 5 blocks/24h. Is Phoenix not optimized for solo-mining?
   There is nothing much to optimize for solo mining (it's just a different network protocol). Such a big difference is certainly quite strange and most probably attributable to huge swings with the CLO difficulty. We don't follow CLO closely, but bear in mind that the smaller coins with volatile price could have huge difficulty swings in small time thanks to services like nicehash, which throw huge hashrate when the price increases and thus increase the difficulty.

for me power limitation doesn t work. I tried adding -powlim -20 or -li or -gpow but
in my stats alwais at 100% the utlization. It makes my pc lag. I have a 1050 ti and w7 64 bit

What i have to write in the config? Sad
   Sorry, the OC options (including the power limit) doesn't work on Nvidia cards yet. We will implement them in the future.

Lately I am getting a clEnqueueNDRange(-4) error on GPU 12. I only have 12 Sapphire RX570 GPUs attached to my rig.

My rig has been humming without any errors for many months. This just happened lately like since 2 weeks back. Any ideas how to solve this?

My virtual memory is already set to min 24000 and max 36000
   You have to increase the page file size more as the DAG size continues to increase with each new DAG epoch. With 12 GPUs and DAG size about 2.6 GB, you better set the min size to 36 GB (or set both min and max to 40 GB).

which 18.x driver is best for phoenix?
Just tried 18.6.1 on 3-card pc, and all cards started to mine with 16MH - both with Claymore and Phoenix...
  Generally all drivers in the 18.x.x branch give almost identical performance. You may also try -clkernel 2 (if you are using AMD cards) because some cards give more stable and/or higher hashrate with these kernels instead of the default kernels.

2% stale shares.
Maybw its devfee kicking in.
   It's not the devfee, it is less than 0.01 GH/s in your case. The stale shares also dosn't explain this. Your effective hashrate shouldn't be less than 1.15 GH/s at the worst. Most possibly this is bad luck. Check the effective hashrate reported by the miner and compare it with the effective hashrate shown by the pool.


win7 ...
It seems there is no way to enable compute mode under Win7 and later (18.x) drivers.
Tried everything (registry, compute-switch tool) - FB usage stays at 65-68%
   There are some "doctored" drivers that can be found online but we don't recommend using drivers with unknown origin, unless the machine is very well isolated from anything important and is used only for mining. The other option with Win7 is to use the blockchain beta drivers.

Quote
Hey dude, I figured it out on my rig. I uninstalled the drivers for the iGPU. Once I did that, I got video output from one of the graphics cards and it let me start mining just fine.

https://www.reddit.com/r/EtherMining/comments/8p71di/claymore_and_phoenix_both_will_not_start_details/e0a65nc/

Putting this link here just incase anyone else having issue starting PhoenixMiner (or Claymore) after the recent Windows update.
   Frankly, there is no reason to keep Windows Update working on a dedicated mining rig. Just disable the Windows Update service in the Services control panel and forget about the stupid Windows updates. Of course, if this isn't a dedicated mining rig, this is not such a great idea.

Version 3.0c. Fan control seems not to be working properly.
Environment:
Clean installation Windows 10 (1709), no updates.
Drivers - latest (18.6.1)
Card: single Asus ROG Strix RX580 O8G (stock bios, only timings modified)
No any additional software than can interfere with fan control is installed (like Afterburner etc.)

-fanmin 50
-fanmax 100
-tt 55

When miner starts - fans are initially stopped. When temperature rises to 50 and above - fans start working on max speed (maybe not max but high enough). In a few seconds temperature drops below 50 and fans begin to slowdown and finally stop. In a few seconds the sequence repeats.

Tried setting -tt -50 to force constant fan speed - not working.

At the same time it works on Asus Strix RX570 more or less properly. At least asjusts fan speed to keep temperature set by -tt.
I have compared bios bios fan settings for these two cards - they are identical.
It is incompatibility with this particular card or I am missing something?
   Thank you for reporting this. We have ASUS Strix RX480 and the fan control works fine on them. Try to set only -fanmax and -tt (without -fanmin).

I just flipped over my 200+ gfx cards to Phoenix miner from Claymore and experienced more stability, less stale shares AND 1.5-2% increase in profits.

Please keep up the good work and i will continue to use your miner.

My farm has about 50% nVidia cards which just a few are 1080Ti.

With OhGodAnETHlargementPill injecting tighter memory timings the 1080Ti whent from 37MH to 54MH.

https://github.com/OhGodACompany/OhGodAnETHlargementPill

To inject new tighter memory timings in to nVidia cards result in a dramatic increase of HashPower in most 10xx serise cards

For example a 1070 can do up to 44MH and 1060 pushes over 30MH (depending on memory type and manufacturer of course)

My suggestion is to reverse engineer the OhGodAnETHlargementPill to find out how it's done and add it to the Phoenix miner.

Adding nVidia memory injection to cover 1050/1060/1070 would make Phoenix miner totally unstoppable.
   Thanks for the nice words!
   Wow, does it work on 1070/1060 too?! We were under the impression that the pill works only on GDDRX5 memory (1080Ti and 1080). We are running it on a mixed Nvidia rig with 1070,1070Ti, and 1080Ti and while the effect on 1080Ti is dramatic, the 1070/1070Ti doesn't seem to be affected at all.

@ PhoenixMiner

I second the request to reverse engineer OhGodACompany's Ethlargment Pill.... If you follow Kristy, she's stated that the software was card locked for the 1080 & 1080ti but works with the 1060 and 1070.

From what I've put together if someone figures out how to remove the card lock it would detect the 10 series card and set mem timings appropriately (this maybe incorrect info) but regardless it would show how to inject mem timings without flashing the cards with a SPI programmer & pomona clip.

She's under a NDA agreement for the software and from my understanding, cant release it for the 1060 and 1070 until someone else reverse engineers and releases it with or without dev fee. No matter how you look at it it would give you more hashrate on your dev fee and help us compete with what ever  FPGA's are out there on ETH and the E3 that's about to ship.

Wolf0 aka OhGodAPet already penetrated your miner to take a look earlier in this thread when Claymore accused you of stealing his kernels, so I think its only fair you open it up to take a look if you haven't already...
   We were definitely thinking about this back when the pill was first released but since it works with PhoenixMiner too we decided against this. We will get back to this at some point but as it alters the timings rather aggressively, so we hesitate to do this lest there is some kind of long-term degradation on the GPU itself (there is very low probability that this is the case but we can't be cavalier with the equipment of our clients).

please release linux version Smiley !
  That's what is causing the delay of 3.1 Smiley  Embarrassed


Hello Phoenix team,

Any update? I seem version 3.0C have some problem, a lot of PP rollback 2.9e

Looks like 3.0c have a lot of problem, I can't get it working for more than two days. 2.9e works perfect for me 🙄
   There are a lot of messages like this but on the other hand we are running 3.0c for more than a month without any problems. Granted, our rigs are more conservatively clocked and with too much power capacity but still we are trying to understand what is going on with these cases. The fact that nothing is logged in the log doesn't help much.

OP are you still out there? Haven’t heard from you in a while.
   Reading regularly but no time to answer too often as we try to push 3.1 out of the doors, and frankly the technical support is the least favorite part of the job for any programmer Wink

This miner is good but unfortunately it crashes while using EthEnlargement pill on GTX 1080. The gain is about 10 MH per card with Claymore. It will be good if you include the option to overclock memory on GTX1080 cards in your next release.
   We are using the pill with GTX1080Ti without any problems (54 MH/s). Try to decrease the memory overclock a little to avoid crashes.
Which is better to use the driver for 3.0c by 1060 6g Gaming X&?
1660741643
Hero Member
*
Offline Offline

Posts: 1660741643

View Profile Personal Message (Offline)

Ignore
1660741643
Reply with quote  #2

1660741643
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1660741643
Hero Member
*
Offline Offline

Posts: 1660741643

View Profile Personal Message (Offline)

Ignore
1660741643
Reply with quote  #2

1660741643
Report to moderator
1660741643
Hero Member
*
Offline Offline

Posts: 1660741643

View Profile Personal Message (Offline)

Ignore
1660741643
Reply with quote  #2

1660741643
Report to moderator
MrClean636
Newbie
*
Offline Offline

Activity: 14
Merit: 0


View Profile
July 17, 2018, 08:05:15 PM
 #2222

Bug report for version 3.0c using '-coin' flag.
Defining " -coin etc " results in miner failing to start, stating unable to resolve what looks like a blank pool entry.
Removing the -coin flag allows proper operation but DAG must regenerate for devfee and after (thinks coin is ETZ).

Phoenix Miner 3.0c Windows/msvc - Release
-----------------------------------------

Available GPUs for mining:
GPU1: GeForce GTX 1070 Ti (pcie 1), CUDA cap. 6.1, 8 GB VRAM, 19 CUs
GPU2: GeForce GTX 1070 (pcie 3), CUDA cap. 6.1, 8 GB VRAM, 15 CUs
GPU3: GeForce GTX 1070 Ti (pcie 5), CUDA cap. 6.1, 8 GB VRAM, 19 CUs
GPU4: GeForce GTX 1070 (pcie 6), CUDA cap. 6.1, 8 GB VRAM, 15 CUs
GPU5: GeForce GTX 1070 (pcie 7), CUDA cap. 6.1, 8 GB VRAM, 15 CUs
GPU6: GeForce GTX 1070 (pcie 8 ), CUDA cap. 6.1, 8 GB VRAM, 15 CUs
Listening for CDM remote manager at port 4028 in full mode
Eth: the pool list contains 2 pools
Eth: primary pool:
Starting GPU mining
Eth: Connecting to ethash pool  (proto: EthProxy)
Eth: Can't resolve host  - No such host is known
Eth: Reconnecting in 20 seconds...
GPU1: 55C 70%, GPU2: 57C 70%, GPU3: 47C 70%, GPU4: 61C 70%, GPU5: 54C 70%, GPU6: 55C 70%

human75
Newbie
*
Offline Offline

Activity: 51
Merit: 0


View Profile
July 17, 2018, 09:37:02 PM
Last edit: July 18, 2018, 05:49:02 PM by human75
 #2223

...


Hi.
phoniex miner crashes just after starting load gpu log file doesnt give too much info.here is the log:

Code:
2018.07.04:11:54:56.713: main Phoenix Miner 3.0c Windows/msvc - Release
2018.07.04:11:54:56.713: main Cmd line: -pool etc.arsmine.net:8008 -wal 0x1c9cfc8a55dc86cee1c07a354593428d8894ad30 -worker Robert -pass x -coin etc -rmode 1 -wdog 1 -log 2 -ftimeout 200
2018.07.04:11:55:10.755: main Available GPUs for mining:
2018.07.04:11:55:10.755: main GPU1: Radeon RX 570 Series (pcie 1), OpenCL 2.0, 4 GB VRAM, 32 CUs
2018.07.04:11:55:10.756: main GPU2: Radeon RX 580 Series (pcie 2), OpenCL 2.0, 8 GB VRAM, 36 CUs
2018.07.04:11:55:10.756: main GPU3: Radeon RX 570 Series (pcie 6), OpenCL 2.0, 4 GB VRAM, 32 CUs
2018.07.04:11:55:10.756: main GPU4: Radeon RX 570 Series (pcie 7), OpenCL 2.0, 4 GB VRAM, 32 CUs
2018.07.04:11:55:10.756: main GPU5: Radeon RX 570 Series (pcie Cool, OpenCL 2.0, 8 GB VRAM, 32 CUs
2018.07.04:11:55:10.756: main GPU6: Radeon RX 570 Series (pcie 9), OpenCL 2.0, 4 GB VRAM, 32 CUs
2018.07.04:11:55:10.756: main GPU7: Radeon RX 570 Series (pcie 10), OpenCL 2.0, 4 GB VRAM, 32 CUs
2018.07.04:11:55:10.756: main GPU8: GeForce GTX 1070 (pcie 11), CUDA cap. 6.1, 8 GB VRAM, 15 CUs
2018.07.04:11:55:10.756: main GPU9: GeForce GTX 1050 Ti (pcie 12), CUDA cap. 6.1, 4 GB VRAM, 6 CUs
2018.07.04:11:55:10.756: main GPU10: Radeon RX 580 Series (pcie 13), OpenCL 2.0, 4 GB VRAM, 36 CUs
2018.07.04:11:55:11.338: main ADL library initialized
2018.07.04:11:55:11.375: main NVML library initialized
2018.07.04:11:55:12.143: main Listening for CDM remote manager at port 3333 in read-only mode
2018.07.04:11:55:12.143: main Eth: the pool list contains 1 pool
2018.07.04:11:55:12.143: main Eth: primary pool: etc.arsmine.net:8008
2018.07.04:11:55:12.143: main Starting GPU mining
2018.07.04:11:55:12.143: main Matched GPU1 to ADL adapter index 32 (method 1)
2018.07.04:11:55:12.425: main GPU1: Created ADL monitor for adapter 32; overdrive version: 7
2018.07.04:11:55:12.426: main GPU1: using AMD driver ver 18.6.1
2018.07.04:11:55:12.426: main Matched GPU2 to ADL adapter index 80 (method 1)
2018.07.04:11:55:12.855: main GPU2: Created ADL monitor for adapter 80; overdrive version: 7
2018.07.04:11:55:12.855: main GPU2: using AMD driver ver 18.6.1
2018.07.04:11:55:12.855: main Matched GPU3 to ADL adapter index 64 (method 1)
2018.07.04:11:55:13.369: main GPU3: Created ADL monitor for adapter 64; overdrive version: 7
2018.07.04:11:55:13.369: main GPU3: using AMD driver ver 18.6.1
2018.07.04:11:55:13.370: main Matched GPU4 to ADL adapter index 96 (method 1)
2018.07.04:11:55:13.752: main GPU4: Created ADL monitor for adapter 96; overdrive version: 7
2018.07.04:11:55:13.752: main GPU4: using AMD driver ver 18.6.1
2018.07.04:11:55:13.753: main Matched GPU5 to ADL adapter index 112 (method 1)
2018.07.04:11:55:14.328: main GPU5: Created ADL monitor for adapter 112; overdrive version: 7
2018.07.04:11:55:14.329: main GPU5: using AMD driver ver 18.6.1
2018.07.04:11:55:14.329: main Matched GPU6 to ADL adapter index 48 (method 1)
2018.07.04:11:55:14.627: main GPU6: Created ADL monitor for adapter 48; overdrive version: 7
2018.07.04:11:55:14.627: main GPU6: using AMD driver ver 18.6.1
2018.07.04:11:55:14.627: main Matched GPU7 to ADL adapter index 16 (method 1)

--------------------------------------------------------
Any help? 2.9d works with out any problem.
Many thx in advance
  Please try the following:
   - increase the page file size to 32 GB (10 x 2.6 GB per DAG plus a few GBs for Windows)
   - try using -amd option to see if the rig starts without the Nvidia cards
   - try using the -lidag command-line option and/or the -gser command-line option to decrease the intensity during or serialize the DAG generation

 when i add -amd yes version 3.0c starts without crashing.
   pagefile is already 60gb. -lidag and - gser didnt make any diffrence.
So now what is your advise to make it work version 3 with amd and nvidia together?many thx
DXInfinity
Newbie
*
Offline Offline

Activity: 4
Merit: 0


View Profile
July 18, 2018, 07:58:59 AM
 #2224

After playing with settings a lot seems that setting fanmin 30, fanmax 100, tt 50 did the trick. Still not obvious and unpredictable though. At least fixed fan speed still not working.
This is for ROG cards with 0db function. Non-ROG Strix RX470, Strix RX570, RX480 work as expected.
Update: trick did not work. Maybe I'm doing something wrong? I want to keep coolers running at minimal set speed (30% for example) even if GPU is colder than -tt specified. How should I set it up?

To be honest - I tried claymore and it handles these cards even worse - coolers always start running at 100% when -tt condition is matched.
asbator
Member
**
Offline Offline

Activity: 68
Merit: 10


View Profile
July 18, 2018, 12:31:09 PM
 #2225

I have problem with older Windows 7 rig. It has 2 RX 480 and 2 RX 580, all 8GB versions. They all mine just 14MH, on both Claymore and Phoenix miner.
Equihash mining is OK though. When i mined Ethash before it was about 25MH if i remember correctly. Cards are not flashed, slightly underclocked and undervolted.
I reinstalled drivers, ended up installing newest beta. Trying to figure it out for couple of days, probably going to reinstall Windows.
Any suggestions?
damba_
Jr. Member
*
Offline Offline

Activity: 151
Merit: 3


View Profile
July 18, 2018, 04:25:19 PM
 #2226

I have problem with older Windows 7 rig. It has 2 RX 480 and 2 RX 580, all 8GB versions. They all mine just 14MH, on both Claymore and Phoenix miner.
Equihash mining is OK though. When i mined Ethash before it was about 25MH if i remember correctly. Cards are not flashed, slightly underclocked and undervolted.
I reinstalled drivers, ended up installing newest beta. Trying to figure it out for couple of days, probably going to reinstall Windows.
Any suggestions?

Have you switched GPU workload from Graphics to Compute in your drivers?
It could be the problem.
Or try installing Beta blockchain drivers https://support.amd.com/en-us/kb-articles/Pages/Radeon-Software-Crimson-ReLive-Edition-Beta-for-Blockchain-Compute-Release-Notes.aspx
Elder III
Sr. Member
****
Offline Offline

Activity: 1246
Merit: 274


View Profile
July 19, 2018, 03:41:30 AM
 #2227


I just flipped over my 200+ gfx cards to Phoenix miner from Claymore and experienced more stability, less stale shares AND 1.5-2% increase in profits.

Please keep up the good work and i will continue to use your miner.

My farm has about 50% nVidia cards which just a few are 1080Ti.

With OhGodAnETHlargementPill injecting tighter memory timings the 1080Ti whent from 37MH to 54MH.

https://github.com/OhGodACompany/OhGodAnETHlargementPill

To inject new tighter memory timings in to nVidia cards result in a dramatic increase of HashPower in most 10xx serise cards

For example a 1070 can do up to 44MH and 1060 pushes over 30MH (depending on memory type and manufacturer of course)

My suggestion is to reverse engineer the OhGodAnETHlargementPill to find out how it's done and add it to the Phoenix miner.

Adding nVidia memory injection to cover 1050/1060/1070 would make Phoenix miner totally unstoppable.
  Thanks for the nice words!
   Wow, does it work on 1070/1060 too?! We were under the impression that the pill works only on GDDRX5 memory (1080Ti and 1080). We are running it on a mixed Nvidia rig with 1070,1070Ti, and 1080Ti and while the effect on 1080Ti is dramatic, the 1070/1070Ti doesn't seem to be affected at all.

The FREE version of OhGodAnETHlargementPill only does 1080 and 1080Ti.

They actually sell OhGodAnETHlargementPill for larger farmers that can do 1050/1060/1070 but do so under NDA.

OhGodAGirl "one of its creators" said in an interview because they are under NDA they can not release OhGodAnETHlargementPill 1050/1060/1070.

Basically she is waiting for some one to reverse engineer the OhGodAnETHlargementPill, as soon as some one reverse engineer it they will be free of the NDA.

Check out BitBeTrippin interview with OhGodAGirl at time 1:10:10, i enclosed like with time stamp

https://www.youtube.com/watch?v=Dddc9r-xyN4&feature=youtu.be&t=4210

PLEASE! reverse engineer the OhGodAnETHlargementPill and include the nVidia memory timing injection function for 1050/1060/1070 in to PhoenixMiner and you will be the No1 miner totally wiping out all other competing nVidia miners out there.




The Eth Pill will be included in the SQRL Miner that will launch shortly before shipment of Acorns (mini FPGA-like GPU accelerators) sometime around the end of August.  According to the live stream on Monday the Pill will work on all GPUs (I assume all NVIDIA ones) within the SQRL Miner.
Kostyaon
Newbie
*
Offline Offline

Activity: 7
Merit: 0


View Profile
July 19, 2018, 07:58:29 AM
 #2228

Any new releases? need more coin support without DAG switching for DevFee.
Germini
Newbie
*
Offline Offline

Activity: 20
Merit: 1


View Profile
July 19, 2018, 11:13:10 AM
 #2229

how to get jsonrpc with curl for this miner?
I'm trying this and it's not working

curl -X POST -H "Content-Type: application/json" -d '{"id":0,"jsonrpc":"2.0","method":"miner_getstat1"}' http://IP:3333
MrTDHP
Newbie
*
Offline Offline

Activity: 64
Merit: 0


View Profile
July 19, 2018, 12:31:21 PM
 #2230

Anybody else having the same issue with me?

It has been numerous times lately that the pool reports to me that I'm not submitting anymore shares and when I tried to remotely connect to my rig I'm unable to (meaning the rig is freezing and needs a hard reboot). Checking the log the last entry would be somethign like Allocating DAG... or DAG xx% which isn't very helpful in determining what is going on wrong with the rig/miner.
sxemini
Member
**
Offline Offline

Activity: 1348
Merit: 42


View Profile
July 19, 2018, 03:29:17 PM
 #2231

if I add -coin "xxx" or -proto "x" phönixminer will not start anymore. Does anyone have an idea why?
Phönixminer says:
can't resolve host - No such host is known

i have this problem with etz, exp, ubiq and so on.

Donations ETH/ETC/TOKENS 0x3586fE59934c1Af2eE40d8376D1d1AF3BbA61708
Binance Bonus -> https://www.binance.com/de/register?ref=XTP9URDX
Zergpool Refcode for only 0,3% Poolfee -> d4ab238c239d44e974809a8c22d03525
MrClean636
Newbie
*
Offline Offline

Activity: 14
Merit: 0


View Profile
July 19, 2018, 10:46:05 PM
 #2232

if I add -coin "xxx" or -proto "x" phönixminer will not start anymore. Does anyone have an idea why?
Phönixminer says:
can't resolve host - No such host is known

i have this problem with etz, exp, ubiq and so on.

I posted a few days ago, same issue when doing -coin etc
Keeps thinking I'm mining etz so has to regenerate the dag for devfee EVERY TIME
Germini
Newbie
*
Offline Offline

Activity: 20
Merit: 1


View Profile
July 20, 2018, 03:28:47 AM
 #2233

how to get jsonrpc with curl for this miner?
I'm trying this and it's not working

curl -X POST -H "Content-Type: application/json" -d '{"id":0,"jsonrpc":"2.0","method":"miner_getstat1"}' http://IP:3333

I didn't make it with curl but I made it with python I had to add a newline character \n at the end of the request.
like this {"id":0,"jsonrpc":"2.0","method":"miner_getstat1"}\n
NicoxDJ
Newbie
*
Offline Offline

Activity: 4
Merit: 0


View Profile
July 20, 2018, 08:09:29 AM
 #2234

how to get jsonrpc with curl for this miner?
I'm trying this and it's not working

curl -X POST -H "Content-Type: application/json" -d '{"id":0,"jsonrpc":"2.0","method":"miner_getstat1"}' http://IP:3333

I didn't make it with curl but I made it with python I had to add a newline character \n at the end of the request.
like this {"id":0,"jsonrpc":"2.0","method":"miner_getstat1"}\n


Hey Germini,
Can you post your code please?
I found one python code somewhere here, but neither with \n it does not working :/
Soliqesh
Newbie
*
Offline Offline

Activity: 48
Merit: 0


View Profile WWW
July 20, 2018, 08:14:06 AM
Last edit: July 20, 2018, 02:02:28 PM by Soliqesh
 #2235

HI ANYBODY help me >this my erro 1050ti 4G. how can i fix them ? thanks
GPU8 CUDA error in CudaProgram.cu:329 : unspecified launch failure (719)
2018.07.09:08:38:32.876: GPU1 CUDA error in CudaProgram.cu:329 : unspecified launch failure (719)
2018.07.09:08:38:32.878: GPU1 GPU1 search error: unspecified launch failure
2018.07.09:08:38:32.879: GPU8 GPU8 search error: unspecified launch failure
2018.07.09:08:38:32.888: GPU4 CUDA error in CudaProgram.cu:329 : unspecified launch failure (719)
2018.07.09:08:38:32.888: GPU4 GPU4 search error: unspecified launch failure
2018.07.09:08:38:32.889: GPU5 CUDA error in CudaProgram.cu:329 : unspecified launch failure (719)
2018.07.09:08:38:32.889: GPU3 CUDA error in CudaProgram.cu:329 : unspecified launch failure (719)
2018.07.09:08:38:32.889: GPU3 GPU3 search error: unspecified launch failure
2018.07.09:08:38:32.889: GPU5 GPU5 search error: unspecified launch failure
2018.07.09:08:38:32.889: GPU7 CUDA error in CudaProgram.cu:329 : unspecified launch failure (719)
2018.07.09:08:38:32.889: GPU7 GPU7 search error: unspecified launch failure
2018.07.09:08:38:32.890: GPU6 CUDA error in CudaProgram.cu:329 : unspecified launch failure (719)
2018.07.09:08:38:32.890: GPU6 GPU6 search error: unspecified launch failure
2018.07.09:08:38:32.953: GPU2 CUDA error in CudaProgram.cu:329 : unspecified launch failure (719)
2018.07.09:08:38:32.953: GPU2 GPU2 search error: unspecified launch failure
2018.07.09:08:38:33.234: wdog Thread(s) not responding. Restarting.
Yes, after 198 epoch my rig with 1050ti have error 719 PM 3.0c  Huh  Huh
coldiecoldie
Newbie
*
Offline Offline

Activity: 23
Merit: 0


View Profile
July 20, 2018, 12:30:53 PM
 #2236

From https://bitcointalk.org/index.php?topic=4547448.0

...

I got some screenshots here showing the randomness of this weird problem.
In the first Screenshot i am on stock bios and Only 2 gpus generate dag and hash, while on the next 2 screenshots i am on modded bios for mining, here all 6 gpus generate dag and hash.
Thing is it is random, it can happen in reverse aswell, or other times only 3 gpus don't hash or only 1.It has no specfic rule.It is random.

Here it is the first screenshot on stock bios with 4 gpus not generating DAG and hashing with 0.All 6 GPUS are starting up but only 2 generate DAG, so 4 GPUS will hash with 0.

https://imgur.com/a/YBVqiRC

Second pair of screenshots.This is after restart and switching to moded bios.All 6 Gpus start up and all generate dag successfully.

https://imgur.com/a/fUIUHfv

Halp please !
VasilyS
Member
**
Offline Offline

Activity: 610
Merit: 21


View Profile WWW
July 20, 2018, 06:06:24 PM
 #2237

Good miner, but I have problems to launch it with R9 290. Miner is always crashing. If compare with Claymore this miner has increase of  speed about 1% and less fee. But Claymore, in my opinion is more stable.

                             ❱  CRYPTOPROFI  ❱
fynxer
Newbie
*
Offline Offline

Activity: 9
Merit: 0


View Profile
July 20, 2018, 08:36:24 PM
 #2238


The Eth Pill will be included in the SQRL Miner that will launch shortly before shipment of Acorns (mini FPGA-like GPU accelerators) sometime around the end of August.  According to the live stream on Monday the Pill will work on all GPUs (I assume all NVIDIA ones) within the SQRL Miner.

Thanks a bunch, weird i did not find this spending crazy time searing EthPill.

Will be interesting to see results.

Now PhoenixMiner must add its version of EthPill, always good with alternatives and competition
Germini
Newbie
*
Offline Offline

Activity: 20
Merit: 1


View Profile
July 21, 2018, 07:46:54 AM
Last edit: July 21, 2018, 08:21:13 PM by Germini
 #2239

how to get jsonrpc with curl for this miner?
I'm trying this and it's not working

curl -X POST -H "Content-Type: application/json" -d '{"id":0,"jsonrpc":"2.0","method":"miner_getstat1"}' http://IP:3333

I didn't make it with curl but I made it with python I had to add a newline character \n at the end of the request.
like this {"id":0,"jsonrpc":"2.0","method":"miner_getstat1"}\n


Hey Germini,
Can you post your code please?
I found one python code somewhere here, but neither with \n it does not working :/

Hi, no problem with this code you can get all the data from a claymore or phoenixminer with no problem using python. thanks to (https://github.com/pistonov/RedTools-Rig-Light)

Code:
import socket
import json

def get_data(ip, port):
    sock = socket.socket(socket.AF_INET, socket.SOCK_STREAM)
    server_address = (ip, int(port))
    try:
        sock.connect(server_address)
    except Exception as e:
        return []
    request = '{\"id\":0,\"jsonrpc\":\"2.0\",\"method\":\"miner_getstat1\"}\n'
    request = request.encode()
    try:
        sock.sendall(request)
    except Exception as e:
        return []
    try:
        data = sock.recv(512)
    except Exception as e:
        return []
    message = json.loads(data)
    sock.close()
    return message

def get_data_claymore(miner_ip, miner_port):
    hashrate_total = []
    hashrate = []
    accepted_shares = []
    invalid_shares = []
    miner_uptime = []

    data = get_data(miner_ip, miner_port)

    try:
        all = data['result'][6].split(';')
        gpu_temp = all[::2]
        gpu_fans = all[1::2]
        hashrate_total = int(data['result'][2].split(';')[0])
        hashrate = data['result'][3].split(';')
        accepted_shares = int(data['result'][2].split(';')[1])
        invalid_shares = int(data['result'][2].split(';')[2])
        miner_uptime = data['result'][1]
        return gpu_temp, gpu_fans, hashrate_total, hashrate, accepted_shares, invalid_shares, miner_uptime

    except Exception as e:
        return []

data = get_data_claymore("192.168.1.13", 3333)
print(data)

Enjoy my friend!
MasterPeace
Newbie
*
Offline Offline

Activity: 2
Merit: 0


View Profile
July 21, 2018, 09:55:27 AM
 #2240

parametr -mi dont work
Pages: « 1 ... 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 [112] 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 ... 500 »
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!