Bitcoin Forum
October 19, 2017, 07:00:57 PM *
News: Latest stable version of Bitcoin Core: 0.15.0.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 [27] 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 »
  Print  
Author Topic: Qt Bitcoin Trader [Open Source secure trading client for Mac/Windows/Linux]  (Read 348590 times)
EABEAB
Jr. Member
*
Offline Offline

Activity: 35


View Profile
December 11, 2013, 03:19:36 AM
 #521

v1.07.96 Beta Released!

Added rules groups.
Fixed sleep mode crash.
Fixed crash on internet reconnect.
Fixed Buy All In amount for all exchanges.
Fixed BTC China last trades and improved performance.
Added context menus.
Ability to fill rule from buy and sell panels.
Improved last trades for Bitstamp and BTC China.
Added Volume movement arrow to order book.
Added Total column to own history and last trades.
Added confirmation dialogs switcher.
Added Fee Calculator single window mode.
Added Bulgarian translation.
And many small fixes.
Improved performance and stability.

Night theme and other exchanges support is coming.


All features working now,

Thanks Chief
1508439657
Hero Member
*
Offline Offline

Posts: 1508439657

View Profile Personal Message (Offline)

Ignore
1508439657
Reply with quote  #2

1508439657
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1508439657
Hero Member
*
Offline Offline

Posts: 1508439657

View Profile Personal Message (Offline)

Ignore
1508439657
Reply with quote  #2

1508439657
Report to moderator
1508439657
Hero Member
*
Offline Offline

Posts: 1508439657

View Profile Personal Message (Offline)

Ignore
1508439657
Reply with quote  #2

1508439657
Report to moderator
1508439657
Hero Member
*
Offline Offline

Posts: 1508439657

View Profile Personal Message (Offline)

Ignore
1508439657
Reply with quote  #2

1508439657
Report to moderator
JasperDX7
Jr. Member
*
Offline Offline

Activity: 37


View Profile
December 11, 2013, 03:42:36 AM
 #522

v1.07.96 Beta Released!

Added rules groups.
Fixed sleep mode crash.
Fixed crash on internet reconnect.
Fixed Buy All In amount for all exchanges.
Fixed BTC China last trades and improved performance.
Added context menus.
Ability to fill rule from buy and sell panels.
Improved last trades for Bitstamp and BTC China.
Added Volume movement arrow to order book.
Added Total column to own history and last trades.
Added confirmation dialogs switcher.
Added Fee Calculator single window mode.
Added Bulgarian translation.
And many small fixes.
Improved performance and stability.

Night theme and other exchanges support is coming.

So far it seems to be working well. I love the groups! I still wish the rules where flexible though (ie. If Current buy price < 30% of last buy price...etc).

When can we expect indicator support like EMA, RSI...etc? Making this fully automated would be awesome and I'm sure a lot of people would be willing to donate. I know I will once EMA 7/21 support is added.
Squeaker
Sr. Member
****
Offline Offline

Activity: 450


View Profile WWW
December 11, 2013, 05:28:05 AM
 #523


Anything obvious jumping out at anyone?

Comment this lines:
Code:
#ifdef  Q_OS_WIN
if(!isActiveWindow())
{
FLASHWINFO flashInfo;
flashInfo.cbSize=sizeof(FLASHWINFO);
flashInfo.hwnd=this->winId();
flashInfo.dwFlags=FLASHW_ALL;
flashInfo.uCount=20;
flashInfo.dwTimeout=400;
::FlashWindowEx(&flashInfo);
}
#endif//ToDo: make this feature works on Mac OS X
Welp... I have to admit... I asked for obvious, I got obvious. XD

Thanks. Smiley

Squeaker
Sr. Member
****
Offline Offline

Activity: 450


View Profile WWW
December 11, 2013, 06:25:47 AM
 #524

Alright, very humbling how out of touch I am with coding, when I'm looking at this latest error, and I don't have a clue where to begin to fix this one...

Code:
c:\usr\dev\Qt\4.8.5\bin\rcc.exe -name QtResource ..\src\QtResource.qrc -o release\qrc_QtResource.cpp
g++ -c -pipe -O2 -w -frtti -fexceptions -mthreads -DUNICODE -DQT_DLL -DQT_NO_DEBUG -DQT_MULTIMEDIA_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_HAVE_MMX -DQT_HAVE_3DNOW -DQT_HAVE_SSE -DQT_HAVE_MMXEXT -DQT_HAVE_SSE2 -DQT_THREAD_SUPPORT -DQT_NEEDS_QMAIN -I"..\..\..\usr\dev\Qt\4.8.5\include\QtCore" -I"..\..\..\usr\dev\Qt\4.8.5\include\QtNetwork" -I"..\..\..\usr\dev\Qt\4.8.5\include\QtGui" -I"..\..\..\usr\dev\Qt\4.8.5\include\QtMultimedia" -I"..\..\..\usr\dev\Qt\4.8.5\include" -I"..\src" -I"..\..\..\usr\dev\Qt\4.8.5\src\3rdparty\zlib" -I"..\..\..\usr\dev\OpenSSL-Win32\include" -I"..\..\..\usr\dev\Qt\4.8.5\include\ActiveQt" -I"release" -I"." -I"." -I"..\..\..\usr\dev\Qt\4.8.5\mkspecs\win32-g++" -o release\qrc_QtResource.o release\qrc_QtResource.cpp
windres -i ..\src\WinResource.rc -o release\WinResource_res.o --include-dir=./../src -DUNICODE -DQT_DLL -DQT_NO_DEBUG -DQT_MULTIMEDIA_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_HAVE_MMX -DQT_HAVE_3DNOW -DQT_HAVE_SSE -DQT_HAVE_MMXEXT -DQT_HAVE_SSE2 -DQT_THREAD_SUPPORT -DQT_NEEDS_QMAIN
windres: ..\\src\\WinResource.rc:32: syntax error
mingw32-make[1]: *** [release/WinResource_res.o] Error 1
mingw32-make[1]: Leaving directory `C:/{{GIT REPO]}/Squeaker-QtBitcoinTrader/build-QtBitcoinTrader-Qt_4_8_5_4_8_5-Release'
mingw32-make: *** [release] Error 2
01:11:25: The process "C:\usr\dev\MinGW-gcc-4.4.0-2\mingw\bin\mingw32-make.exe" exited with code 2.
Error while building/deploying project QtBitcoinTrader (kit: Qt 4.8.5 (4.8.5))
When executing step 'Make'
01:11:25: Elapsed time: 01:41.

elbandi
Hero Member
*****
Offline Offline

Activity: 481


View Profile
December 11, 2013, 09:25:57 AM
 #525

hi,

feature request: i have some favorite exchange pairs, like btc/usd, ltc/usd, nvc/usd, ltc/btc... i dont care the others. could you make allow to customize the top-left list? i want to see only my favs or the favs are the first. like:
--- Favorites ---
btc/usd
ltc/usd
-- Other ---
ppc/usd
eur/usd
...

Elbandi
Squeaker
Sr. Member
****
Offline Offline

Activity: 450


View Profile WWW
December 11, 2013, 10:54:25 AM
 #526

hi,

feature request: i have some favorite exchange pairs, like btc/usd, ltc/usd, nvc/usd, ltc/btc... i dont care the others. could you make allow to customize the top-left list? i want to see only my favs or the favs are the first. like:
--- Favorites ---
btc/usd
ltc/usd
-- Other ---
ppc/usd
eur/usd
...

Elbandi
And, while you're at it, user-defineable pairs as well? So when an exchange adds/removes a pair, we don't have to wait for a program update to use it, we can just go into the config for that exchange, and add/remove the pair ourselves? (with the associated fee and trading limits, valid decimal places, etc... like BTCe's BTC/USD pair that has a minimum 0.001 unit in pricing)

IGHOR
Hero Member
*****
Offline Offline

Activity: 899



View Profile WWW
December 11, 2013, 01:18:20 PM
 #527

hi,

feature request: i have some favorite exchange pairs, like btc/usd, ltc/usd, nvc/usd, ltc/btc... i dont care the others. could you make allow to customize the top-left list? i want to see only my favs or the favs are the first. like:
--- Favorites ---
btc/usd
ltc/usd
-- Other ---
ppc/usd
eur/usd
...

Elbandi

I'll think how to implement it.

And, while you're at it, user-defineable pairs as well? So when an exchange adds/removes a pair, we don't have to wait for a program update to use it, we can just go into the config for that exchange, and add/remove the pair ourselves? (with the associated fee and trading limits, valid decimal places, etc... like BTCe's BTC/USD pair that has a minimum 0.001 unit in pricing)

I'll add real time synchronization of BTC-e pairs, and if some changed or deleted, or new one, program will use it.

Qt Bitcoin Trader, JL Script
Centrabit AG | Check out digital signature of every app you have download and use only official download sources.
Squeaker
Sr. Member
****
Offline Offline

Activity: 450


View Profile WWW
December 11, 2013, 01:47:25 PM
 #528

And, while you're at it, user-defineable pairs as well? So when an exchange adds/removes a pair, we don't have to wait for a program update to use it, we can just go into the config for that exchange, and add/remove the pair ourselves? (with the associated fee and trading limits, valid decimal places, etc... like BTCe's BTC/USD pair that has a minimum 0.001 unit in pricing)
I'll add real time synchronization of BTC-e pairs, and if some changed or deleted, or new one, program will use it.
That'll work, thanky.

IGHOR
Hero Member
*****
Offline Offline

Activity: 899



View Profile WWW
December 11, 2013, 02:12:05 PM
 #529

The mac version is crashing on startup for me as well... do I really have to uninstall Qt SDK? I need it for my PyQt projects :/

What about running the win version via wine? has anyone tested this?

You also can remove frameworks from "Qt Bitcoin Trader.app" folder.

Qt Bitcoin Trader, JL Script
Centrabit AG | Check out digital signature of every app you have download and use only official download sources.
maz
Full Member
***
Offline Offline

Activity: 168


View Profile
December 11, 2013, 02:51:21 PM
 #530

Is there a way to auto-update in linux without going through a re-installation?
IGHOR
Hero Member
*****
Offline Offline

Activity: 899



View Profile WWW
December 11, 2013, 04:13:38 PM
 #531

Is there a way to auto-update in linux without going through a re-installation?

No. But in feature it vary possible.

Qt Bitcoin Trader, JL Script
Centrabit AG | Check out digital signature of every app you have download and use only official download sources.
toothpick
Newbie
*
Offline Offline

Activity: 15


View Profile
December 11, 2013, 06:06:42 PM
 #532

Im getting constant crashes and closing on Windows 8 with this new version. Anyone else? Im using Bitstamp. Also, when placing a buy order at "All In" it never places and never shows a message why. But if I lower the price by one click, it posts. LOVE this app tho!!! Thanks so much!!!
IGHOR
Hero Member
*****
Offline Offline

Activity: 899



View Profile WWW
December 11, 2013, 06:28:04 PM
 #533

Im getting constant crashes and closing on Windows 8 with this new version. Anyone else? Im using Bitstamp. Also, when placing a buy order at "All In" it never places and never shows a message why. But if I lower the price by one click, it posts. LOVE this app tho!!! Thanks so much!!!

Try to remove %localappdata%\QtBitcoinTrader folder and re-create API keys.
I'm using Windows 8.1 and no crashes.
If this will not solved, please contact me via email or PM and we will debug it.

Qt Bitcoin Trader, JL Script
Centrabit AG | Check out digital signature of every app you have download and use only official download sources.
Squeaker
Sr. Member
****
Offline Offline

Activity: 450


View Profile WWW
December 11, 2013, 06:34:51 PM
 #534

Still at a loss why I'm getting:

windres -i ..\src\WinResource.rc -o release\WinResource_res.o --include-dir=./../src -DUNICODE -DQT_DLL -DQT_NO_DEBUG -DQT_MULTIMEDIA_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_HAVE_MMX -DQT_HAVE_3DNOW -DQT_HAVE_SSE -DQT_HAVE_MMXEXT -DQT_HAVE_SSE2 -DQT_THREAD_SUPPORT -DQT_NEEDS_QMAIN
windres: ..\\src\\WinResource.rc:32: syntax error

I've never had to deal with the compilers themselves before, every project I've been a part of already had all of that set up.

At this point, I'm just trying to compile the trader client as is, without any edits, so I know I have everything set up properly.

Anyone else already compiling this on Win7?

IGHOR
Hero Member
*****
Offline Offline

Activity: 899



View Profile WWW
December 11, 2013, 06:39:38 PM
 #535

Still at a loss why I'm getting:

windres -i ..\src\WinResource.rc -o release\WinResource_res.o --include-dir=./../src -DUNICODE -DQT_DLL -DQT_NO_DEBUG -DQT_MULTIMEDIA_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_HAVE_MMX -DQT_HAVE_3DNOW -DQT_HAVE_SSE -DQT_HAVE_MMXEXT -DQT_HAVE_SSE2 -DQT_THREAD_SUPPORT -DQT_NEEDS_QMAIN
windres: ..\\src\\WinResource.rc:32: syntax error

I've never had to deal with the compilers themselves before, every project I've been a part of already had all of that set up.

At this point, I'm just trying to compile the trader client as is, without any edits, so I know I have everything set up properly.

Anyone else already compiling this on Win7?


I use Visual Studio for compiling instead of mingw Qt Creator.
You can remove WinResource.rc from QtBitcoinTrader_Desktop.pro
So I have not tested it on Windows using Qt Creator.

Qt Bitcoin Trader, JL Script
Centrabit AG | Check out digital signature of every app you have download and use only official download sources.
patriotek
Newbie
*
Offline Offline

Activity: 19


View Profile
December 11, 2013, 07:05:00 PM
 #536

IGHOR:

Thanx so much for the update!

Is there a chance of adding support for Cryptsy, and again, CEX.io?  It'd be so much easier to use this than their non-optimal sites...

As well, if / when CEX is supported, there are already 3rd party scripts that handle such things as auto-reinvestment, so some of the rule suggestions I'd have would quite closely follow what's being done there...

Here's the one that I'm currently using, in particular:  https://github.com/Eloque/CexControl

It is quite effective.  Even goes so far as to determine, on each run, whether you'll get more bang for the buck: 1. Trading NMC for BTC then BTC for GHS, 2. Trading BTC for NMC then NMC for GHS, or 3. Trading either NMC or BTC directly for GHS.  It then, of course, places orders accordingly.

If either/or is not intended to be supported officially, any hints on how I might hack up support on my own?  I'm no programmer, but I'm willing to make the attempt...
Squeaker
Sr. Member
****
Offline Offline

Activity: 450


View Profile WWW
December 11, 2013, 07:23:15 PM
 #537

I use Visual Studio for compiling instead of mingw Qt Creator.
You can remove WinResource.rc from QtBitcoinTrader_Desktop.pro
So I have not tested it on Windows using Qt Creator.
yeah, I use vs2005 express on the other computer, but it is still running win2k. figured I'd set up this computer as closely as the dev's environment was when he's making this.

I _thought_ it would simplify things Tongue

I'll give your suggestion a try when I get up tonight. o/

ewibit
Legendary
*
Offline Offline

Activity: 2072


View Profile
December 11, 2013, 07:42:12 PM
 #538

Commands for Debian, Ubuntu etc..
Code:
qmake-qt4 QtBitcoinTrader_Mobility.pro
make
sudo make install

on Ubuntu 13.10:
Code:
g++ -c -m64 -pipe -O2 -w -D_REENTRANT -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++-64 -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtOpenGL -I/usr/include/qt4 -I/usr/include/QtMultimediaKit -I. -I/usr/src/3rdparty/zlib -I/usr/include/QtMobility -I/usr/include -I/usr/include/QtMobility -I/usr/X11R6/include -I.moc -I.ui -o .obj/feecalculator.o feecalculator.cpp
feecalculator.cpp: In constructor ‘FeeCalculator::FeeCalculator()’:
feecalculator.cpp:42:5: error: ‘class Ui::FeeCalculator’ has no member named ‘singleInstance’
  ui.singleInstance->setChecked(mainWindow.feeCalculatorSingleInstance);
     ^
make: *** [.obj/feecalculator.o] Fehler 1
IGHOR
Hero Member
*****
Offline Offline

Activity: 899



View Profile WWW
December 11, 2013, 07:49:53 PM
 #539

Commands for Debian, Ubuntu etc..
Code:
qmake-qt4 QtBitcoinTrader_Mobility.pro
make
sudo make install

on Ubuntu 13.10:
Code:
g++ -c -m64 -pipe -O2 -w -D_REENTRANT -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++-64 -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtOpenGL -I/usr/include/qt4 -I/usr/include/QtMultimediaKit -I. -I/usr/src/3rdparty/zlib -I/usr/include/QtMobility -I/usr/include -I/usr/include/QtMobility -I/usr/X11R6/include -I.moc -I.ui -o .obj/feecalculator.o feecalculator.cpp
feecalculator.cpp: In constructor ‘FeeCalculator::FeeCalculator()’:
feecalculator.cpp:42:5: error: ‘class Ui::FeeCalculator’ has no member named ‘singleInstance’
  ui.singleInstance->setChecked(mainWindow.feeCalculatorSingleInstance);
     ^
make: *** [.obj/feecalculator.o] Fehler 1

Try remove project and download it from Github again.
Maybe some old files left.

Qt Bitcoin Trader, JL Script
Centrabit AG | Check out digital signature of every app you have download and use only official download sources.
IGHOR
Hero Member
*****
Offline Offline

Activity: 899



View Profile WWW
December 11, 2013, 07:55:42 PM
 #540

IGHOR:

Thanx so much for the update!

Is there a chance of adding support for Cryptsy, and again, CEX.io?  It'd be so much easier to use this than their non-optimal sites...

As well, if / when CEX is supported, there are already 3rd party scripts that handle such things as auto-reinvestment, so some of the rule suggestions I'd have would quite closely follow what's being done there...

Here's the one that I'm currently using, in particular:  https://github.com/Eloque/CexControl

It is quite effective.  Even goes so far as to determine, on each run, whether you'll get more bang for the buck: 1. Trading NMC for BTC then BTC for GHS, 2. Trading BTC for NMC then NMC for GHS, or 3. Trading either NMC or BTC directly for GHS.  It then, of course, places orders accordingly.

If either/or is not intended to be supported officially, any hints on how I might hack up support on my own?  I'm no programmer, but I'm willing to make the attempt...

I think I'll add Cryptsy and Bitfines in v1.07.96
This features you tell is planted to Qt Open Trader
And currently multi exchange and multi currencies monitoring is not supported.

Qt Bitcoin Trader, JL Script
Centrabit AG | Check out digital signature of every app you have download and use only official download sources.
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 [27] 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!