Bitcoin Forum
November 21, 2017, 09:20:53 PM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 ... 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 [153] 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 ... 287 »
  Print  
Author Topic: [OS] nvOC easy-to-use Linux Nvidia Mining v0019-1.4  (Read 327269 times)
fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
August 30, 2017, 03:25:41 AM
 #3041

For equihash / Zec

What are the best settings, current just at +100 core

Cards run in a 70-90f environment

I think this depends on the card/model.  If you use sufficient power (in my experience) increasing memory clock offset also increases performance while < 1000.


Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
August 30, 2017, 03:28:52 AM
 #3042

Dont know if its been asked/suggested or not
I thought it would be good to implement some thing similar to nicehash oc settings for manual mine too
So when we change coin, 1bash automatically switch oc profile

Looking for something similar, maybe we can narrow down it to based on algo which is going to be used!?

Yes, I need to do this; maybe someone will do it for me?  There are lots of members capable of this.  I can as of v0019 modify the 3main / 2unix / watchdog update pastes and then users can pull those updates by running 4update.

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
August 30, 2017, 03:37:49 AM
 #3043

Its definitely full install I guess, but fullzero said he will update OP with full instructions, lets wait for them.
If v0019 is Ubuntu 16.04 too , it shouldn't need full install.
Unless it has big changes in distro and softwares.
Hopefully it doesnt need full.

The size of the primary partition has been drastically reduced; it is most likely faster to download the v0019 image than implement changes.  I also resolved a number of system conflicts. 

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
August 30, 2017, 03:57:24 AM
 #3044

Hi, after 60h of stable running the hash drops by 50%, but program dose not restart. Is there or can you add an option in 1bash filr " if hash under x Restart" ?

Tnx
Hash drops usually for 2 reasons
1- GPU not fully utilize, which Iamnotajeep watchdog will be aware and restart the miner
2- GPU get hot and Maxximus cant get it to temp limit  with 100% fan and it will lower the power usuage.


Yes but i am using pure P106-100 rig so both of those are disabled.
I would like to know if what i asked can be coded so i dont have to manually restart everytime

I can't properly confirm this as I don't have a p106-100 rig myself; but I suspect that most of the time x is running in pure P106-100 remote mode.  If this is correct; you should be able to use the watchdog.

Please test this out and let me know.

Also in v0019; I added a variable in 1bash for a pure P106-100 mode.  If a member can let me know if this works as intended as well it would be helpful thanks.

gs777
Jr. Member
*
Offline Offline

Activity: 52


View Profile
August 30, 2017, 04:23:52 AM
 #3045

My 10xGTX1070 nvOC v0019 running stable for 6 h!
Pl130 cc150 mc350
THANK YOU Fullzero and everyone who has made it happen!!!
 Grin

Hope to see soon some guidance how
to setup telegram alerts
This new feature looks promising
fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
August 30, 2017, 04:27:45 AM
 #3046

Hi all miners,
Excellent work fullzero! You're the king ;-) Many thanks for sharing with us.

I'm newer in mining, so I try use Windows, but found nvOS now and use it. But I've a small question, I must disconnect M.2 disc before nvOS run or not (for sure don't lost data)?

Thanks for any advice :-)

As there were so many problems with v0018 zeroing the first partition; v0019 does not zeroize.  If you use a USB key it will copy and then remove the 1bash from the windows partition.  If you use an ssd: it will not copy or remove the 1bash from the windows partition and you will need to manually replace the 1bash in the home directory.  This is most likely due to my failure to change a setting in the fstab properly when I configured it.

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
August 30, 2017, 04:36:24 AM
 #3047

Dont know if its been asked/suggested or not
I thought it would be good to implement some thing similar to nicehash oc settings for manual mine too
So when we change coin, 1bash automatically switch oc profile

Looking for something similar, maybe we can narrow down it to based on algo which is going to be used!?

not to elegant but for now I do this(v0018):
Code:
INDIVIDUAL_CLOCKS="YES"         # YES NO

if [ $COIN == "ETH" -o $COIN == "ETC" ]
then
    if [ $INDIVIDUAL_CLOCKS == "NO" ]
    then
        __CORE_OVERCLOCK=0
        MEMORY_OVERCLOCK=1210
    elif [ $INDIVIDUAL_CLOCKS == "YES" ]
    then
        __CORE_OVERCLOCK_0=0
        MEMORY_OVERCLOCK_0=1300
        __CORE_OVERCLOCK_1=0
        MEMORY_OVERCLOCK_1=1300
        __CORE_OVERCLOCK_2=0       
        MEMORY_OVERCLOCK_2=1200
        __CORE_OVERCLOCK_3=0
        MEMORY_OVERCLOCK_3=1200
        __CORE_OVERCLOCK_4=0
        MEMORY_OVERCLOCK_4=1600
        __CORE_OVERCLOCK_5=0
        MEMORY_OVERCLOCK_5=1200
        __CORE_OVERCLOCK_6=0       
        MEMORY_OVERCLOCK_6=1200
    fi
elif [ $COIN == "DUAL_ETH_SC" ]
then
    __CORE_OVERCLOCK=110
    MEMORY_OVERCLOCK=1100
elif [ $COIN == "ZEC" ]
then
    if [ $INDIVIDUAL_CLOCKS == "NO" ]
    then
        __CORE_OVERCLOCK=105   
        MEMORY_OVERCLOCK=1200
    elif [ $INDIVIDUAL_CLOCKS == "YES" ]
    then
        __CORE_OVERCLOCK_0=104
        MEMORY_OVERCLOCK_0=1230
        __CORE_OVERCLOCK_1=104
        MEMORY_OVERCLOCK_1=1225
        __CORE_OVERCLOCK_2=120
        MEMORY_OVERCLOCK_2=1300
        __CORE_OVERCLOCK_3=104
        MEMORY_OVERCLOCK_3=1225
        __CORE_OVERCLOCK_4=105
        MEMORY_OVERCLOCK_4=1300
        __CORE_OVERCLOCK_5=105
        MEMORY_OVERCLOCK_5=1235
        __CORE_OVERCLOCK_6=104
        MEMORY_OVERCLOCK_6=1235
    fi
fi
 
# Set individual clocks here if INDIVIDUAL_CLOCKS="YES"
#__CORE_OVERCLOCK_0=100
#MEMORY_OVERCLOCK_0=1230
#__CORE_OVERCLOCK_1=100
#MEMORY_OVERCLOCK_1=1230
#__CORE_OVERCLOCK_2=100
#MEMORY_OVERCLOCK_2=1230
#__CORE_OVERCLOCK_3=100
#MEMORY_OVERCLOCK_3=1230
#__CORE_OVERCLOCK_4=130
#MEMORY_OVERCLOCK_4=1310
#__CORE_OVERCLOCK_5=100
#MEMORY_OVERCLOCK_5=1220
#__CORE_OVERCLOCK_6=100
#MEMORY_OVERCLOCK_6=1215
...etc

we need to modularise 1bash, 1 settings file for each coin(or a settings db) would be nice, don't have to much time on my hands right now but when I do I'll think of something and ask my man fullzero to include it if he likes it.

I use a similar kind, but based on algo/script, because there are number of coins based on algos for eg; ethash has 6 coins (ETH,ETC,EXP,UBQ,MUSIC,SOIL) which use mostly same OC settings (I believe). We need something similar modularised kind of thing going forward (I kinda like your idea actually, may try the way you've used and see how it goes) Smiley

I like this idea but I think it would be easier to implement if there was a ALGO variable that was the subject of the if conditional like so:

if [ $COIN == "ETH" -o $COIN == "ETC" ... ( all the ETHASH) ]
then
ALGO="ETHASH"
fi

like wise for EQUIHASH ect; then:

if [ $ALGO == "ETHASH" ]
then
(your nests)

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
August 30, 2017, 04:44:49 AM
 #3048

Please share Monero GPU mining app.

I'm not sure if it's optimal for the purpose, but I've been running this one for a few weeks now:

https://github.com/KlausT/ccminer-cryptonight

Building from source is fairly straightforward:

Code:
mkdir -p /home/m1/KTccminer-cryptonight
cd ~
git clone https://github.com/KlausT/ccminer-cryptonight KTccminer-cryptonight
cd KTccminer-cryptonight
./configure --with-cuda=/usr/local/cuda-8.0
make

I failed to add this ccminer fork which apparently results in this;

I'm getting this issue (straight from nvOC 19) when I select 'SALFTER_MPH_PROFIT_SWITCHING' as COIN, anyone had this issue?? I've tested URL on RIG's browser, it is working as expected.

Code:
Traceback (most recent call last):
  File "/home/m1/mph_switch", line 37, in <module>
    data=json.loads(fetch("http://miningpoolhub.com/?page=api&action=getminingandprofitsstatistics"))["return"]
  File "/home/m1/mph_switch", line 32, in fetch
    return urllib2.build_opener().open(r).read()
  File "/usr/lib/python2.7/urllib2.py", line 435, in open
    response = meth(req, response)
  File "/usr/lib/python2.7/urllib2.py", line 548, in http_response
    'http', request, response, code, msg, hdrs)
  File "/usr/lib/python2.7/urllib2.py", line 473, in error
    return self._call_chain(*args)
  File "/usr/lib/python2.7/urllib2.py", line 407, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.7/urllib2.py", line 556, in http_error_default
    raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
urllib2.HTTPError: HTTP Error 500: Internal Server Error
[WARN] Unable to load the library libutempter !
[WARN] The <wall> command will not work in guake !
[WARN] libutempter.so.0: cannot open shared object file: No such file or directory


[WARN] Unable to load the library libutempter !
[WARN] The <wall> command will not work in guake !
[WARN] libutempter.so.0: cannot open shared object file: No such file or directory

BTW, thank you so much for all the updates with this release, awesome work fullzero as ever, the best mining OS and the best community ever Smiley

Have you tried to install libutempter0 ?
Code:
sudo apt install libutempter0

Thanks for the reply, it seems the error has gone using the above install; but mining is not started in guake as expected!

Code:
All done.

  Attribute 'GPUGraphicsClockOffset' (m1-desktop:0[gpu:7]) assigned value 150.


  Attribute 'GPUGraphicsClockOffset' (m1-desktop:0[gpu:7]) assigned value 150.


  Attribute 'GPUMemoryTransferRateOffset' (m1-desktop:0[gpu:7]) assigned value -300.


  Attribute 'GPUMemoryTransferRateOffset' (m1-desktop:0[gpu:7]) assigned value -300.


  Attribute 'GPUFanControlState' (m1-desktop:0[gpu:7]) assigned value 0.


monero (Cryptonight): 0.00108000 BTC/day (4.64 USD/day)
zclassic (Equihash): 0.00100364 BTC/day (4.31 USD/day)
zcash (Equihash): 0.00098478 BTC/day (4.23 USD/day)
ethereum (Ethash): 0.00098032 BTC/day (4.21 USD/day)
ethereum-classic (Ethash): 0.00094537 BTC/day (4.06 USD/day)
groestlcoin (Groestl): 0.00092318 BTC/day (3.96 USD/day)
maxcoin (Keccak): 0.00079139 BTC/day (3.40 USD/day)
expanse (Ethash): 0.00073189 BTC/day (3.14 USD/day)
musicoin (Ethash): 0.00068310 BTC/day (2.93 USD/day)
vertcoin (Lyra2RE2): 0.00060242 BTC/day (2.59 USD/day)
myriadcoin-groestl (Myriad-Groestl): 0.00060066 BTC/day (2.58 USD/day)
digibyte-groestl (Myriad-Groestl): 0.00037603 BTC/day (1.61 USD/day)
feathercoin (NeoScrypt): 0.00026042 BTC/day (1.12 USD/day)
myriadcoin-skein (Skein): 0.00007466 BTC/day (0.32 USD/day)
siacoin (Sia): -0.00000641 BTC/day (-0.03 USD/day)
digibyte-skein (Skein): -0.00014849 BTC/day (-0.64 USD/day)
digibyte-qubit (Qubit): -0.00023583 BTC/day (-1.01 USD/day)
geocoin (Qubit): -0.00028547 BTC/day (-1.23 USD/day)
dash (X11): -0.00032753 BTC/day (-1.41 USD/day)
startcoin (X11): -0.00034090 BTC/day (-1.46 USD/day)
verge-scrypt (Scrypt): -0.00040643 BTC/day (-1.74 USD/day)
adzcoin (X11): -0.00040828 BTC/day (-1.75 USD/day)
litecoin (Scrypt): -0.00041916 BTC/day (-1.80 USD/day)
gamecredits (Scrypt): -0.00042298 BTC/day (-1.82 USD/day)
sexcoin (Scrypt): -0.00045059 BTC/day (-1.93 USD/day)

No others errors found!

Will investigate more into it and update; Thanks  Smiley

Well, I think I've figured it why it has failed even after installation of 'libutempter0', the profitable coin according to MPH is XMR and with the XMR the path provided in the 'mph_config.json' is invalid.

Code:
/home/m1/KTccminer-cryptonight/ccminer -a cryptonight

valid one

Code:
/home/m1/KXccminer/ccminer -a cryptonight


Scott have you tried the stak client?  Does does the KlausT client have equivalent performance?

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
August 30, 2017, 04:46:25 AM
 #3049

Hi all,

Hopefully this is not too off-topic, but in trying to get the latest ethminer working in nvOC (at the speeds expected for my GTX 1060 6gb cards), I had also been posting on their Github page. I am trying to figure out a few things, and would love to hear what you all have to say:

  • Someone on that thread suggested that with Linux-based mining, the overclock settings for memory people throw around (which, most things I read are for Windows) need to be doubled. As in, people usually say Samsung memory can get around an 850 memory OC, so they were saying for Ubuntu I would go with 1700? This felt wrong given the 1bash defaults, but I'd love verification
  • Is there any way anyone knows, without doing a Windows install, to learn what kind of memory my cards have? I'd rather not install Windows, and I have 26 cards I'd like to verify without changing their order or disconnecting if possible. I have not been successful in finding a Linux utility, but feel I may benefit from indvidual clock tuning
  • Has anyone gotten the 24-25 Mh/s the latest ethminer supposedly gets while using in nvOC? If so, what settings are you using?

I appreciate the input, as well as the fact that this build even exists, so any help here would be amazing.

Hi JudoFlash,

  • You are totally right for memory in linux, cause in linux u dont OC MemClock technically you OC MemoryTransferRate. MemClock = MemoryTransferRate % 2
  • Unfortunately on linux we don't have software that allow you to get memory brand version, easy way to do this is to boot your rig on a single windows card per card Wink
  • For this last one i dont have 1060, but i bet with nice OC u can grab this one. Remember to negative your CoreClock when u mine ETH Wink

Don't hesitate to ask more Wink

Thank you kindly. Wow, ok, so I will try ratcheting up the memory overclock some more. i have been underclocking the core by 200, but I appreciate the tip.

Too bad about the utility to read the memory type. Since instability takes a while to crash things sometimes, I bet I'll be tuning things for a LONG time. Especially since I have already had instability issues with my two ASRock H110 BTC+ Pro boards.

I will try some memory tuning and see where that brings me, though I'd love to hear if anyone else running 1060's has had success, and at what settings.

Thanks!

What CPU are you using with your unstable H110 rigs?

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
August 30, 2017, 04:51:40 AM
 #3050

Did anyone successfully set up teamviewer with custom resolutions without monitor(or dummy plug) on a headless rig?

Try


Interesting; have you confirmed this works helpme85?

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
August 30, 2017, 04:54:54 AM
 #3051

So, v019 is more stable than 018. Thank a lot.
However, I still have a problem with a screen

Moreover to many times a detected all cards (12th cards is detected after 1-2min after 1st one and watchdog become said about low utilisation).
Also, in terminal, screen is not working and in best way if it will show in guake(f12) after writing "screen -r", but sometimes it also wrote that "there is no screen to be resumed".


A screen can only be attached once.  So if it is attached to the guake terminal (as in your screenshot) then it cannot be attached to the gnome-terminal (which is why it displays that message)

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
August 30, 2017, 04:59:32 AM
 #3052

Is it normal that every time upPASTE reload config it start a new instance of 1bash ?

Code:
m1@m1-desktop-102:~$ ps aux | grep 1bash
m1        2201  0.0  0.0  13320  3876 pts/16   S+   11:43   0:00 bash /home/m1/1bash
m1        4482  0.0  0.0  13328  3840 pts/23   S+   12:14   0:00 bash /home/m1/1bash
m1       18432  0.0  0.0  13328  3836 pts/24   S+   16:18   0:00 bash /home/m1/1bash

Code:
m1@m1-desktop-101:~$ ps aux | grep 1bash
m1       13545  0.0  0.0  13324  3888 pts/17   S+   16:23   0:00 bash /home/m1/1bash
m1       13546  0.0  0.0  13332  3820 pts/23   S+   16:23   0:00 bash /home/m1/1bash
m1       13547  0.0  0.0  13328  3892 pts/21   S+   16:23   0:00 bash /home/m1/1bash


Problem is some times it create multiple miners :

Code:
m1@m1-desktop-101:~$ screen -r  miner
There are several suitable screens on:
14358.miner (08/29/17 16:23:44) (Detached)
14348.miner (08/29/17 16:23:44) (Detached)
Type "screen [-d] -r [pid.]tty.host" to resume one of them.

and multiple temp too

Code:
m1@m1-desktop-101:~$ screen -r temp
There are several suitable screens on:
13837.temp (08/29/17 16:23:36) (Detached)
13830.temp (08/29/17 16:23:36) (Detached)
13823.temp (08/29/17 16:23:36) (Detached)
Type "screen [-d] -r [pid.]tty.host" to resume one of them.

The multiple miners only happens on one of my rigs, the other one dont have this issue.
Both has multiple 1bash running but one make multiple miners.

When upPASTE see modification between your 1bash and 1bash, he trigger a reboot of the process.
So are u sure u put right address of your upPASTE ?
That prolly from some weird permissions u cant kill your miner running. I got this trouble with multi launching miner. A new install fixed this Smiley

If using the original v0018 versions; I think this was one of the bugs.  I modified 2unix and 1bash to have additional process killing in the bugfix 1bash for v0018.  This was passed on to v0019.  Of course I expect there are lots of bugs in v0019 as well; as it was not properly tested.  Today I am fairly sure I noticed something off with stak not being killed by the watchdog; but I need to look into it more.  There is also something going wrong in general with guake.

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
August 30, 2017, 05:09:16 AM
 #3053

Interesting. Thank you - I will try that.

I guess I will need to learn how to SSH.

Also increase your powerlimit; 75 is very low for a 1060.  I recommend moving it up to 100; then you can bump it down if it is stable without issue.  Will probably be stable until around 85-90 watts or lower.

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
August 30, 2017, 05:12:25 AM
 #3054

So far nvOC0019 seems working good, i notice something weird, i actually lost 4 mh/s on my 8 x 1070 Asus compared to nvOC0018 on skunk algo, i use same miner as u input inside i assume, ccminer2.2 by tpruvot.

have you checked intensity??

Yeap i use -i 25 as usual i am between 29.5-30 before i was on 30-30.5

I updated the TP fork to the newest commit (I assumed it was better) for v0019; I still have the older 2.2 beta download link up on the OP; can you download and copy over the TP exe and tell me if your hashrate improves?  If it does, I will add the 2.2 beta back for the next version.

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
August 30, 2017, 05:21:45 AM
 #3055

What is the process of remoting in w/ nvoc19

I will make a v0019 demo video and go over this tomorrow.

fullzero
Legendary
*
Offline Offline

Activity: 1092



View Profile
August 30, 2017, 05:27:23 AM
 #3056

My 10xGTX1070 nvOC v0019 running stable for 6 h!
Pl130 cc150 mc350
THANK YOU Fullzero and everyone who has made it happen!!!
 Grin

Hope to see soon some guidance how
to setup telegram alerts
This new feature looks promising

My test bot has been getting a lot of telegrams from members; If this isn't covered soon by BaliMiner, I will make a guide. Hopefully BaliMiner will cover this.  Wink

TeslaCh
Newbie
*
Offline Offline

Activity: 2


View Profile
August 30, 2017, 05:28:35 AM
 #3057

 I have some problem with my rigs based on 0019. motherboard H110 BTC around 11 GTX 1050, 1060 1gtx and 1 video card with a GTX 970. Sometimes the error is displayed with squares instead of letters, the disappearing interface, and miner stops without errors. Also the rig often crashes with the error "nvml can't get current temperature 15" и " big dag buffer or cannot allocate big dag buffer".Processor celeron 3900 4gb ram. Second rig, with 13 1050 have probem with power usage: 4 cards use 57-60 watts, 11 cards uses 67-68 watts in ZEC miner. And I have Tp link adapter and wifi connection often disconnected. Sorry for my bad english, im from russia. Cheesy Cheesy
papampi
Full Member
***
Offline Offline

Activity: 140


Linux FOREVER! Resistance is futile!!!


View Profile
August 30, 2017, 05:36:54 AM
 #3058

Its definitely full install I guess, but fullzero said he will update OP with full instructions, lets wait for them.
If v0019 is Ubuntu 16.04 too , it shouldn't need full install.
Unless it has big changes in distro and softwares.
Hopefully it doesnt need full.

The size of the primary partition has been drastically reduced; it is most likely faster to download the v0019 image than implement changes.  I also resolved a number of system conflicts.  

OK, then I have to go for a reinstall of v0019
But please try to find a way for next versions to have an upgrade too so we dont have to reinstall whole system,
I have my rigs in remote location, remote as 1000 Km away.
I think so many others are like me.
I make them ready and send them to their new home Smiley
hard to reinstall whole system for every update.
kingsleylow
Newbie
*
Offline Offline

Activity: 13


View Profile
August 30, 2017, 06:04:35 AM
 #3059

hi guys..

may I know why i cannot connect to ethermine.org pool for ETH but its running fine for nanopool.org

it will show error like ETH: Share rejected !
Socket was closed remotely by pools.

this is my pool setting.
asia1.ethermine.org:4444

papampi
Full Member
***
Offline Offline

Activity: 140


Linux FOREVER! Resistance is futile!!!


View Profile
August 30, 2017, 06:22:57 AM
 #3060

hi guys..

may I know why i cannot connect to ethermine.org pool for ETH but its running fine for nanopool.org

it will show error like ETH: Share rejected !
Socket was closed remotely by pools.

this is my pool setting.
asia1.ethermine.org:4444


Did you set this :
Code:
ETHERMINEdotORG="YES"
Pages: « 1 ... 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 [153] 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 ... 287 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!