Bitcoin Forum
November 19, 2017, 12:03:39 PM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 ... 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 [203] 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 »
  Print  
Author Topic: Avalon ASIC users thread  (Read 432417 times)
haaggus
Newbie
*
Offline Offline

Activity: 29


View Profile WWW
March 21, 2014, 11:54:52 PM
 #4041

I don't understand why I can't just plug the Avalon 2 (single modular) into my laptop and connect to it with BFGminer like I do with my BFlabs Jalapeno... why do I have to go through all this bullshit with Raspberry Pi and WR703 ?

https://bitcoin-trader.biz/?ref=dcmining
1511093019
Hero Member
*
Offline Offline

Posts: 1511093019

View Profile Personal Message (Offline)

Ignore
1511093019
Reply with quote  #2

1511093019
Report to moderator
1511093019
Hero Member
*
Offline Offline

Posts: 1511093019

View Profile Personal Message (Offline)

Ignore
1511093019
Reply with quote  #2

1511093019
Report to moderator
Join ICO Now Coinlancer is Disrupting the Freelance marketplace!
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1511093019
Hero Member
*
Offline Offline

Posts: 1511093019

View Profile Personal Message (Offline)

Ignore
1511093019
Reply with quote  #2

1511093019
Report to moderator
1511093019
Hero Member
*
Offline Offline

Posts: 1511093019

View Profile Personal Message (Offline)

Ignore
1511093019
Reply with quote  #2

1511093019
Report to moderator
1511093019
Hero Member
*
Offline Offline

Posts: 1511093019

View Profile Personal Message (Offline)

Ignore
1511093019
Reply with quote  #2

1511093019
Report to moderator
gjpminingco
Sr. Member
****
Offline Offline

Activity: 350


Co-Owner Of DCMCo-Op Mining Farm at 3.5 th/s


View Profile WWW
March 22, 2014, 12:27:34 AM
 #4042

cgminer -S/dev/ttyUSB0 --avalon2-fan 100 --avalon2-freq 1500 --avalon2-voltage 10000 -o stratum+tcp://poolinfohere:3333 -O workerinfohere.worker1:x -o stratum+tcp://poolinfohere:3333 -O workerinfohere.worker1:x --api-allow W:127.0.0.1 --api-listen --real-quiet -Q 13 -s 11 -E 10 --no-submit-stale --hotplug 20 -l 5

Carlton Banks
Legendary
*
Offline Offline

Activity: 1820



View Profile
March 22, 2014, 02:30:24 AM
 #4043

I don't understand why I can't just plug the Avalon 2 (single modular) into my laptop and connect to it with BFGminer like I do with my BFlabs Jalapeno... why do I have to go through all this bullshit with Raspberry Pi and WR703 ?

I'm pretty sure MinePeon is kept up to date with the latest cgminer, so gjpminingco's parameters for the launch command (in above post) should work. OpenWRT isn't a desktop OS, it's made for routers. Routers don't have monitors (or video output sockets...), so you use a web interface to configure the options, or you suck up some courage and configure it using a remote command line.

Not sure about Avalon mk.2, but if they interface to their controller using USB, then you should just be able to use your laptop + mining software.

Vires in numeris
haaggus
Newbie
*
Offline Offline

Activity: 29


View Profile WWW
March 22, 2014, 04:08:44 AM
 #4044

Right, so what do I do with the above code? Save it into the Raspberry Pi Config file?

The config file contains settings for HDMI output. That should make the Raspi output some video signal to my monitor, I thought?

The OpenWRT .bin files on my SD card contain no version of CGminer or any other miner for that matter. I've looked through them all.

https://bitcoin-trader.biz/?ref=dcmining
mc1225
Member
**
Offline Offline

Activity: 110


View Profile WWW
March 22, 2014, 09:42:33 AM
 #4045

Hi All,

My China clone Avalon 200G all in a sudden stops working.  I tried to restart cgminer but only saw the followings.

Sat Mar 22 01:22:44 2014 daemon.info sysinit: ntpd: resolved peer 3.openwrt.pool.ntp.org to 138.236.128.112
Sat Mar 22 01:22:44 2014 daemon.info sysinit: ntpd: sent query to 138.236.128.112
Sat Mar 22 01:22:44 2014 daemon.info sysinit: ntpd: resolved peer 2.openwrt.pool.ntp.org to 59.148.184.7
Sat Mar 22 01:22:44 2014 daemon.info sysinit: ntpd: sent query to 59.148.184.7
Sat Mar 22 01:22:44 2014 daemon.info sysinit: ntpd: resolved peer 1.openwrt.pool.ntp.org to 218.189.210.10
Sat Mar 22 01:22:44 2014 daemon.info sysinit: ntpd: sent query to 218.189.210.10
Sat Mar 22 01:22:44 2014 daemon.info sysinit: ntpd: resolved peer 0.openwrt.pool.ntp.org to 59.148.184.7
Sat Mar 22 01:22:44 2014 daemon.info sysinit: ntpd: sent query to 59.148.184.7
Sat Mar 22 01:22:54 2014 daemon.info sysinit: Alarm clock
Sat Mar 22 01:22:54 2014 daemon.info sysinit: ntpd: resolved peer 3.openwrt.pool.ntp.org to 66.7.96.2
Sat Mar 22 01:22:54 2014 daemon.info sysinit: ntpd: sent query to 66.7.96.2
Sat Mar 22 01:22:54 2014 daemon.info sysinit: ntpd: resolved peer 2.openwrt.pool.ntp.org to 137.189.4.10
Sat Mar 22 01:22:54 2014 daemon.info sysinit: ntpd: sent query to 137.189.4.10
Sat Mar 22 01:22:54 2014 daemon.info sysinit: ntpd: resolved peer 1.openwrt.pool.ntp.org to 103.5.12.41
Sat Mar 22 01:22:54 2014 daemon.info sysinit: ntpd: sent query to 103.5.12.41
Sat Mar 22 01:22:54 2014 daemon.info sysinit: ntpd: resolved peer 0.openwrt.pool.ntp.org to 137.189.4.10
Sat Mar 22 01:22:54 2014 daemon.info sysinit: ntpd: sent query to 137.189.4.10
Sat Mar 22 01:23:04 2014 daemon.info sysinit: Alarm clock
Sat Mar 22 01:23:04 2014 daemon.info sysinit: ntpd: resolved peer 3.openwrt.pool.ntp.org to 138.236.128.112
Sat Mar 22 01:23:04 2014 daemon.info sysinit: ntpd: sent query to 138.236.128.112
Sat Mar 22 01:23:04 2014 daemon.info sysinit: ntpd: resolved peer 2.openwrt.pool.ntp.org to 59.148.184.7
Sat Mar 22 01:23:04 2014 daemon.info sysinit: ntpd: sent query to 59.148.184.7
Sat Mar 22 01:23:04 2014 daemon.info sysinit: ntpd: resolved peer 1.openwrt.pool.ntp.org to 218.189.210.10
Sat Mar 22 01:23:04 2014 daemon.info sysinit: ntpd: sent query to 218.189.210.10
Sat Mar 22 01:23:04 2014 daemon.info sysinit: ntpd: resolved peer 0.openwrt.pool.ntp.org to 59.148.184.7
Sat Mar 22 01:23:04 2014 daemon.info sysinit: ntpd: sent query to 59.148.184.7

Anyone can help to advise?  Thank you so much

Problem solved by comment out the lines checking ntp (administrator apply FW rules blocking it)

Carlton Banks
Legendary
*
Offline Offline

Activity: 1820



View Profile
March 22, 2014, 06:29:45 PM
 #4046

Right, so what do I do with the above code? Save it into the Raspberry Pi Config file?

The config file contains settings for HDMI output. That should make the Raspi output some video signal to my monitor, I thought?

The OpenWRT .bin files on my SD card contain no version of CGminer or any other miner for that matter. I've looked through them all.

Sounds like you're using "OpenWRT for raspi" vanilla, i.e. not a version adapted for mining? That will never work as is. The firmware on Avalon 2 wiki implies there are OpenWRT firmware builds for raspi, that should be what you're after.

If not, MinePeon is probably the quickest & easiest route. I'm not familiar with day-day usage of MinePeon, but there should be a text box labelled "parameters" or "config" or "arguments". Stick only the parameters from gjpminingco's solution into that textbox (basically discard the "cgminer" part), save/apply, restart mining. That's assuming he's got it right of course, but it can't be far wrong even if there was some mistake in it. Use

Vires in numeris
gjpminingco
Sr. Member
****
Offline Offline

Activity: 350


Co-Owner Of DCMCo-Op Mining Farm at 3.5 th/s


View Profile WWW
March 22, 2014, 06:37:36 PM
 #4047

Actually i am checking on seeing what the best overclock setting for the avalon2 single module is that runs the best settings

haaggus
Newbie
*
Offline Offline

Activity: 29


View Profile WWW
March 22, 2014, 08:55:03 PM
 #4048

https://bitcointalk.org/index.php?topic=526617.msg5845620#msg5845620

https://www.youtube.com/watch?v=cHnEN1AV9wM

There's a new thread I made with a bounty of 0.1BTC for each contributor who helps me get the miner hashing.
And a video of the problem.

https://bitcoin-trader.biz/?ref=dcmining
gjpminingco
Sr. Member
****
Offline Offline

Activity: 350


Co-Owner Of DCMCo-Op Mining Farm at 3.5 th/s


View Profile WWW
March 22, 2014, 09:07:22 PM
 #4049

https://bitcointalk.org/index.php?topic=526617.msg5845620#msg5845620

https://www.youtube.com/watch?v=cHnEN1AV9wM

There's a new thread I made with a bounty of 0.1BTC for each contributor who helps me get the miner hashing.
And a video of the problem.

If you have teamviewer i can help you with this issue

-ck
Moderator
Legendary
*
Offline Offline

Activity: 2338


Ruu \o/


View Profile WWW
March 25, 2014, 05:05:37 AM
 #4050

cgminer 4.2.1 based firmware:
http://ck.kolivas.org/apps/cgminer/avalon/20140324/

Primary developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org 1% Fee Solo mining at solo.ckpool.org
-ck
gjpminingco
Sr. Member
****
Offline Offline

Activity: 350


Co-Owner Of DCMCo-Op Mining Farm at 3.5 th/s


View Profile WWW
March 25, 2014, 01:15:57 PM
 #4051

is that avalon1 or avalon2 firmware

Coinagect
Newbie
*
Offline Offline

Activity: 12


View Profile
March 25, 2014, 02:26:32 PM
 #4052

Things were humming along, then rig stopped working with the:
[Firmware Version] => 20140324
cgminer: 698d677
cgminer-openwrt-packages: aadd747+
luci: 346e3e7+
Socket connect failed: Connection refused

Errors, after reboot connects for a moment but never hashing all discarded.  Then error returns and cgminer process ends.

Tried diff IPs, updating firmware (currently on 20140324), diff pools, etc.  Ping/tracrt/nslookup all working.

Where to go from here?  If you get it running again, I'll point to your acct for the rest of the day.
holders
Newbie
*
Offline Offline

Activity: 9


View Profile
March 25, 2014, 05:56:05 PM
 #4053

to: Coinagect - Return old software, and reinstall new.


to: ckolivas - Thank you! All good!

 
Coinagect
Newbie
*
Offline Offline

Activity: 12


View Profile
March 25, 2014, 07:37:21 PM
 #4054

to: Coinagect - Return old software, and reinstall new.


to: ckolivas - Thank you! All good!

 

No change in status by going back 20131229 and then coming to current.

**Update**
PS needed replacement
andrewboy44
Sr. Member
****
Offline Offline

Activity: 252



View Profile
March 27, 2014, 02:21:32 AM
 #4055

anyone know how to factory restore avalon mini?
gjpminingco
Sr. Member
****
Offline Offline

Activity: 350


Co-Owner Of DCMCo-Op Mining Farm at 3.5 th/s


View Profile WWW
March 27, 2014, 02:55:41 AM
 #4056

I can Help you fix the Unit if you would like

kano
Legendary
*
Offline Offline

Activity: 2268


Linux since 1997 RedHat 4


View Profile
March 27, 2014, 09:38:27 PM
 #4057

cgminer -S/dev/ttyUSB0 --avalon2-fan 100 --avalon2-freq 1500 --avalon2-voltage 10000 -o stratum+tcp://poolinfohere:3333 -O workerinfohere.worker1:x -o stratum+tcp://poolinfohere:3333 -O workerinfohere.worker1:x --api-allow W:0/0 --api-listen --real-quiet -Q 13 -s 11 -E 10 --no-submit-stale --hotplug 20 -l 5
--api-allow W:0/0 ... right ... give the whole world write access to your cgminer ... sigh why do people keep doing this (even KnC did it in all of their miners)

Pool: https://kano.is Here on Bitcointalk: Forum BTC: 1KanoPb8cKYqNrswjaA8cRDk4FAS9eDMLU
FreeNode IRC: irc.freenode.net channel #kano.is Majority developer of the ckpool code
Help keep Bitcoin secure by mining on pools with full block verification on all blocks - and NO empty blocks!
gjpminingco
Sr. Member
****
Offline Offline

Activity: 350


Co-Owner Of DCMCo-Op Mining Farm at 3.5 th/s


View Profile WWW
March 28, 2014, 12:02:33 AM
 #4058

no one can access it since it is behind a firewall that is just so i can use and test several different control apps

pepo
Member
**
Offline Offline

Activity: 86


View Profile
March 28, 2014, 06:33:43 AM
 #4059

Things were humming along, then rig stopped working with the:
[Firmware Version] => 20140324
cgminer: 698d677
cgminer-openwrt-packages: aadd747+
luci: 346e3e7+
Socket connect failed: Connection refused

Errors, after reboot connects for a moment but never hashing all discarded.  Then error returns and cgminer process ends.

Tried diff IPs, updating firmware (currently on 20140324), diff pools, etc.  Ping/tracrt/nslookup all working.

Where to go from here?  If you get it running again, I'll point to your acct for the rest of the day.

Hello , i had the same problem , it says 0.0mhs . It is the power supply , you got to trust me and change it, the fans dont work right?
scorpy
Newbie
*
Offline Offline

Activity: 2


View Profile
April 03, 2014, 04:20:58 PM
 #4060

Things were humming along, then rig stopped working with the:
[Firmware Version] => 20140324
cgminer: 698d677
cgminer-openwrt-packages: aadd747+
luci: 346e3e7+
Socket connect failed: Connection refused

Errors, after reboot connects for a moment but never hashing all discarded.  Then error returns and cgminer process ends.

Tried diff IPs, updating firmware (currently on 20140324), diff pools, etc.  Ping/tracrt/nslookup all working.

Where to go from here?  If you get it running again, I'll point to your acct for the rest of the day.

I have similar problem after update

Code:
[Firmware Version] => 20140320
cgminer: d73ac70
cgminer-openwrt-packages: b8e0918
luci: c06eb57
Socket connect failed: Connection refused

Both PSU are OK and working.
Pages: « 1 ... 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 [203] 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!