Bitcoin Forum
November 18, 2017, 09:13:26 AM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 ... 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 [185] 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 ... 284 »
  Print  
Author Topic: [OS] nvOC easy-to-use Linux Nvidia Mining v0019-1.4  (Read 322294 times)
Doftorul
Newbie
*
Offline Offline

Activity: 10


View Profile
September 16, 2017, 09:09:27 PM
 #3681

There are NO such limitations; nvOC is designed to max of 13 cards without any modification of 1bash & 3main (can add more by modifying these two files). Try to verify the risers (swap them around with the working ones).

Hash rates dropped with your 8 cards??
OK, I think same - no limitations...

I've rate ~6400 Sol/s with 8 cards.

After connection next 3 cards, rate dropped to ~5100 Sol/s only. nvOS didn't detect more than 8 cards, as you can saw on nvidia-smi.

Well, risers maybe problem - I'm novice in mining, so I ordered more types. I using version v006C and v008S. On cards plugged on v006C blinking LEDs below power connectors on card. I've ordered 13 pcs of v008S (these: www.aliexpress.com/item/TISHRIC-2018-Hot-VER008S-Molex-4PIN-15PIN-SATA-6PIN-3-in-1-PCIE-PCI-Express-Riser/32830747032.html). I hope that will works well.

Many thanks :-)

What is your CPU ?
I had the exact same issue with AsRock and 12 Ti's and it all went smooth when i switched the CPU's from the rig with my own. For me it worked putting a i5 7400 on the motherboard. Maybe it works with a less expensive CPU but it was the only one i had around.
1510996406
Hero Member
*
Offline Offline

Posts: 1510996406

View Profile Personal Message (Offline)

Ignore
1510996406
Reply with quote  #2

1510996406
Report to moderator
Coinlancer is Disrupting the Freelance marketplace!
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
Bibi187
Full Member
***
Offline Offline

Activity: 140


https://steemit.com/@bibi187


View Profile WWW
September 16, 2017, 09:09:47 PM
 #3682

hi need help is there any way i can schedule miner to run like only from 6pm-11am ?


U have multiple solution, depend what u want exactly.

PC have to be turned off or only mining process ?

If u need to pc be turned off, you probably can buy a power timer.

If u let PC run and just turn off miner, u can do a crontab Wink

Code:
crontab -e 0 11 * * * miner1 pkill -e screen && pkill -f 3main
contrab -e 0 18 * * * miner1 bash /home/m1/3main &

First line will kill your process every day at 11am
Second line will launch miner process every day at 6pm (18)

▀     DeepOnion  |  TOR Integrated & Secured  [ Facebook  Telegram  Bitcointalk  Twitter  Youtube  Reddit ]     ▀
Your Anonymity Guaranteed  ★  Your Assets Secured by TOR  ★  Guard Your Privacy!   ❱❱❱ JOIN AIRDROP NOW!
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬  File Authenticity Guaranteed by DeepVault  ▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
especial
Newbie
*
Offline Offline

Activity: 12


View Profile
September 16, 2017, 09:21:01 PM
 #3683

hi i get strange error when trying nicehash or mph with json:

LAUNCHING:  SALFTER_MPH_PROFIT_SWITCHING

Traceback (most recent call last):
  File "/home/m1/mph_switch", line 14, in <module>
    cfg=json.loads(open(sys.argv[1]).read())
  File "/usr/lib/python2.7/json/__init__.py", line 339, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python2.7/json/decoder.py", line 364, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python2.7/json/decoder.py", line 382, in raw_decode
    raise ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded


[url=https://deeponion.org
Doftorul
Newbie
*
Offline Offline

Activity: 10


View Profile
September 16, 2017, 09:28:42 PM
 #3684

Guys what is SRR option?

also when i set minimum temp=25 or lower, it wont go lower than 30

(using v0019 with updating)

SRR = Simple Rig Resetter
it's a little board that connects to your power/reset pins on the motherboard, it then listens for heartbeats from specific rigs, when the heartbeat stops, it means the rig froze, it hard re-sets the specific rig.

https://simplemining.net/download/SRR/PDF/SRR-manual-2017-02-10.pdf

I've been using one for a few months, saved me lots of time at the beginning.
Does Linux ever hard freeze?
Been using ubuntu since 2006,
Got lucky and have never experienced it.

I'm running my own 176 cards and hosting another 388 for friends and family and turning this into a hosting business.

After trying basically all the setups possible (with 6,7,8,9, 13 cards) i've settled on 3 cards per rig. Never looking back.

If you're using second hand HP Compaq DC7800 or DC7900 (you get it for 40 usd in my country with 4 G RAM, 3 pciex slots) and a dual core duo CPU you get the vPro awesomeness of full remote power on and off and Intel AMT out of band remote management included. Nobody can't beat that. Upgrade the firmware on the motherboards and BAM! you have a remote KVM built in. You can see your screen and do whatever you want from anywhere in the world.

If i am running 1080 cards and above, i buy a 750 W server PSU for another 50 USD and i can have a full rig up and running with the total cost of 90 USD per rig. If i am running 1060 cards, i simply upgrade for 10 usd the PSU in the SFF desktop to a 500 W one...

All the rigs are beautiful, no cabling nightmare, whenever a rig crashes i scripted a full power cycle using a raspberry pi as a watchdog.
SRR's are expensive when you have a lot of rigs.
damNmad
Full Member
***
Offline Offline

Activity: 168



View Profile
September 16, 2017, 09:44:14 PM
 #3685

hi i get strange error when trying nicehash or mph with json:

LAUNCHING:  SALFTER_MPH_PROFIT_SWITCHING

Traceback (most recent call last):
  File "/home/m1/mph_switch", line 14, in <module>
    cfg=json.loads(open(sys.argv[1]).read())
  File "/usr/lib/python2.7/json/__init__.py", line 339, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python2.7/json/decoder.py", line 364, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python2.7/json/decoder.py", line 382, in raw_decode
    raise ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded



I've seen this too; mostly a restart should fix or try to fire those url's (mph, coinbase, nicehash) in RIG's browser, see whether you can browse through.

▀     DeepOnion  |  TOR Integrated & Secured  [ Facebook  Telegram  Bitcointalk  Twitter  Youtube  Reddit ]     ▀
Your Anonymity Guaranteed  ★  Your Assets Secured by TOR  ★  Guard Your Privacy!   ❱❱❱ JOIN AIRDROP NOW!
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬  File Authenticity Guaranteed by DeepVault  ▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
lards
Jr. Member
*
Offline Offline

Activity: 47


View Profile
September 16, 2017, 09:47:34 PM
 #3686

Hi guys,

I have recently built a new rig with 13 P106-100 ASUS cards on nv0019 running -200cc 1550mc and PL90. I have a weird problem that after some time the hashrate on all cards drop by 50% or more and doesn't go back up, the miner doesn't restart and it just keeps running with lower hashrate.  This time it did this after 7 hours , with 7 cards running it was up for over 12hours and no problems. Has anyone experienced this before and maybe you know where the problem is?

I am obviously running headless and using SSH to monitor the rig and adjust the settings.

PS. The miner or the OS doesn't restart the miner or reboot the system, just the hashrate drops pretty badly from 328 to 140 MH/s.

Thanks in advance to everyone who can help and also thanks to fullzero for the new version!

dbolivar
Member
**
Offline Offline

Activity: 61


View Profile
September 16, 2017, 09:54:33 PM
 #3687

I have recently built a new rig with 13 P106-100 ASUS cards on nv0019 running -200cc 1550mc and PL90. I have a weird problem that after some time the hashrate on all cards drop by 50% or more and doesn't go back up, the miner doesn't restart and it just keeps running with lower hashrate.  This time it did this after 7 hours , with 7 cards running it was up for over 12hours and no problems. Has anyone experienced this before and maybe you know where the problem is?

How is the temperature of your cards? Have you configured nvOC to use auto temp control? If you have, it may be the case that you set the temp too low for what can be reached with 100% fan speed. In this case, auto temp control will smartly reduce the power limit to cool the cards, but of course this reduces the hash rate. Just a guess...
lards
Jr. Member
*
Offline Offline

Activity: 47


View Profile
September 16, 2017, 09:56:46 PM
 #3688

I have recently built a new rig with 13 P106-100 ASUS cards on nv0019 running -200cc 1550mc and PL90. I have a weird problem that after some time the hashrate on all cards drop by 50% or more and doesn't go back up, the miner doesn't restart and it just keeps running with lower hashrate.  This time it did this after 7 hours , with 7 cards running it was up for over 12hours and no problems. Has anyone experienced this before and maybe you know where the problem is?

How is the temperature of your cards? Have you configured nvOC to use auto temp control? If you have, it may be the case that you set the temp too low for what can be reached with 100% fan speed. In this case, auto temp control will smartly reduce the power limit to cool the cards, but of course this reduces the hash rate. Just a guess...


The highest temp I have on these cards is 61 degrees and fans are running no more than 67% so I doubt that these causes the problem. Unfortunately in P106-100 headless mode neither watchdog nor tempcontrol works so I do not use those.
IAmNotAJeep
Jr. Member
*
Offline Offline

Activity: 44


View Profile
September 16, 2017, 10:22:16 PM
 #3689

Guys what is SRR option?

also when i set minimum temp=25 or lower, it wont go lower than 30

(using v0019 with updating)

SRR = Simple Rig Resetter
it's a little board that connects to your power/reset pins on the motherboard, it then listens for heartbeats from specific rigs, when the heartbeat stops, it means the rig froze, it hard re-sets the specific rig.

https://simplemining.net/download/SRR/PDF/SRR-manual-2017-02-10.pdf

I've been using one for a few months, saved me lots of time at the beginning.
Does Linux ever hard freeze?
Been using ubuntu since 2006,
Got lucky and have never experienced it.

I'm running my own 176 cards and hosting another 388 for friends and family and turning this into a hosting business.

After trying basically all the setups possible (with 6,7,8,9, 13 cards) i've settled on 3 cards per rig. Never looking back.

If you're using second hand HP Compaq DC7800 or DC7900 (you get it for 40 usd in my country with 4 G RAM, 3 pciex slots) and a dual core duo CPU you get the vPro awesomeness of full remote power on and off and Intel AMT out of band remote management included. Nobody can't beat that. Upgrade the firmware on the motherboards and BAM! you have a remote KVM built in. You can see your screen and do whatever you want from anywhere in the world.

If i am running 1080 cards and above, i buy a 750 W server PSU for another 50 USD and i can have a full rig up and running with the total cost of 90 USD per rig. If i am running 1060 cards, i simply upgrade for 10 usd the PSU in the SFF desktop to a 500 W one...

All the rigs are beautiful, no cabling nightmare, whenever a rig crashes i scripted a full power cycle using a raspberry pi as a watchdog.
SRR's are expensive when you have a lot of rigs.


That's 188 mini rigs if my math is correct, and you have to add cabling/switches/power for all the cabling so 5x48 ports switches can handle that but then you still have a ton of cables (and time to manage it all) and if you go second hand for the switches, one switch dies and brings down 48 rigs, anyway you slice it you need cabling and can have many cards go down depending on the nature of your failure.
Then there is heat.
Of course the above can be great in the right circumstances.

FYI - 1 SRR controls 8 rigs, there should be a daughterboard available eventually to add 32 for a total of 40 rigs for 1 SRR.
I'm very happy with it.
CryptAtomeTrader44
Member
**
Offline Offline

Activity: 61

It is easier to break an atom than partialities AE


View Profile
September 16, 2017, 10:49:35 PM
 #3690

Seems like there is a problem with Klaust and Neoscrypt in linux
There is an open ticket for that
https://github.com/KlausT/ccminer/issues/49


I can not install KTccminer on NVOCv019.

I looked at your post on their incident ticket page and I find that 4 days ago you were able to compile it correctly on your machine.
Unfortunately, I have not managed to do the same with my Biostar TB250-BTC PRO (Socket 1151) and my 2 x ASUS GTX1070 DUAL.

I use the script (s) of Scott ALlfter (alias Salfter) and I went on his page here: https://gitlab.com/salfter/mph_switch/tree/master. This page explains how to add the Cryptonight and Sia miners but I was unable to compile by following the command lines given by Salfter.

./autoreconf.sh does not exist in the KTccminer directory
and
./configure --with-cuda- / usr / local / cuda-8.0 also returns errors after executing the file: autogen.sh

here is what the configuration command gives me before the command make:

user @ hostname $ / KTccminer-cryptonight $ ./configure --with-cuda / usr / local / cuda
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type: / usr / local / cuda
checking build system type ... / usr / local / cuda
configure: error: invalid value of canonical build

It seems to me to have found by re-reading the bash-history that it tries to mine with the CPUminer which mine at the same time as ETH and the others algo.
is it possible to mining with CPUs and GPUs with two different software simultaneously without it posing bp?
That is, I use Scott's mining profit switching script and I have activated the plusCPU function of fullZERO in the 1bash

1 / How to install KTccminer correctly?
2 / Is it possible to mine monero with the CPUs in addition to the GPUs ?

@Scott Alfter

The use of your script delighted me, but I hesitated for a long time because of the lack of documentation. I did not know too much or I was going. and I still do not really know where all the files you are using.

Maybe you have some documentation about these scripts?

NB: I used google translation to write this message

BIOSTAR TB250-BTC PRO (12x gpu) + 2x ASUS 1070
fattoad
Newbie
*
Offline Offline

Activity: 3


View Profile
September 17, 2017, 01:17:35 AM
 #3691

Greetings, i am in the process of setting up a 13 card rig to see what the world of mining is like. So i have run into an issue that seems odd. I have looked around and have not seen it. So here it is.

My miner keeps telling me it failed to connect to the host and i am not sure why. I am trying to use suprnova.cc pool

I set coin to ZEN
I then changed my worker name to my pool worker name
i have set the address to stratum+tcp://zen.suprnova.cc
i have set the port to 3618
and i have put my wallet address in.

So what am i missing? On my Windows rig i have to put worker name and password info in but i do not see any place to enter that. then when i start it up it just keeps failing to connect to host.
papampi
Full Member
***
Offline Offline

Activity: 140


Linux FOREVER! Resistance is futile!!!


View Profile
September 17, 2017, 05:24:52 AM
 #3692

Seems like there is a problem with Klaust and Neoscrypt in linux
There is an open ticket for that
https://github.com/KlausT/ccminer/issues/49


I can not install KTccminer on NVOCv019.

I looked at your post on their incident ticket page and I find that 4 days ago you were able to compile it correctly on your machine.
Unfortunately, I have not managed to do the same with my Biostar TB250-BTC PRO (Socket 1151) and my 2 x ASUS GTX1070 DUAL.

I use the script (s) of Scott ALlfter (alias Salfter) and I went on his page here: https://gitlab.com/salfter/mph_switch/tree/master. This page explains how to add the Cryptonight and Sia miners but I was unable to compile by following the command lines given by Salfter.

./autoreconf.sh does not exist in the KTccminer directory
and
./configure --with-cuda- / usr / local / cuda-8.0 also returns errors after executing the file: autogen.sh

here is what the configuration command gives me before the command make:

user @ hostname $ / KTccminer-cryptonight $ ./configure --with-cuda / usr / local / cuda
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type: / usr / local / cuda
checking build system type ... / usr / local / cuda
configure: error: invalid value of canonical build

It seems to me to have found by re-reading the bash-history that it tries to mine with the CPUminer which mine at the same time as ETH and the others algo.
is it possible to mining with CPUs and GPUs with two different software simultaneously without it posing bp?
That is, I use Scott's mining profit switching script and I have activated the plusCPU function of fullZERO in the 1bash

1 / How to install KTccminer correctly?
2 / Is it possible to mine monero with the CPUs in addition to the GPUs ?

@Scott Alfter

The use of your script delighted me, but I hesitated for a long time because of the lack of documentation. I did not know too much or I was going. and I still do not really know where all the files you are using.

Maybe you have some documentation about these scripts?

NB: I used google translation to write this message

If you just want KTccminer-cryptonight salfter has compiled one :

I finally got around to upgrading to v19 from v17.  I'd had some trouble with v18 and went back to v17, but v19's being much better behaved.  I put my config in (configured to use my MiningPoolHub switcher and Maxximus007's fan-control code) and let her rip.

There is one issue I ran across: no Cryptonight miner.  I noticed it when my mining rig's fans all slowed down.  To get things running again in a hurry, I copied the mining software from my v17 setup.  It's in this tarball:

https://alfter.us/wp/wp-content/uploads/2017/09/KTccminer-cryptonight.tar.xz

Unpack to ~m1. It'll unpack to a Git repo into which you can pull updates (I last updated it just a few days ago) that has already been configured and built.  I might've built it for Pascal (GeForce 10-series) GPUs only; I don't recall for sure if I did, so if you're using older GPUs and it doesn't work for you, you might need to rebuild it.

There was also an upstream change in this miner that requires a change in 3main.  The "-a cryptonight" option is no longer accepted, so load 3main into the editor of your choice, search for "KTccminer-cryptonight" (it's near the beginning of the heredoc that gets written to mph_conf.json), and delete "-a cryptonight" from that line.

Beyond that, the only other changes I made were to set the hostname equal to the worker name (changes in /etc/hostname and /etc/hosts), change the timezone from Eastern to Pacific, and to revise the speed and power figures in the mph_conf.json heredoc with my current configuration (up from 3 GPUs to 4).  As I write this, I'm imaging my v19 setup so I can copy it over to the (physically smaller) stick with v17.

I could compile KTccminer on nv0019, but not on my other ubuntu
gave me some errors
just download the source
and run the commands with no args
Code:
./autogen.sh
./configure.sh
./build.sh
it should be ok
papampi
Full Member
***
Offline Offline

Activity: 140


Linux FOREVER! Resistance is futile!!!


View Profile
September 17, 2017, 05:27:37 AM
 #3693

Greetings, i am in the process of setting up a 13 card rig to see what the world of mining is like. So i have run into an issue that seems odd. I have looked around and have not seen it. So here it is.

My miner keeps telling me it failed to connect to the host and i am not sure why. I am trying to use suprnova.cc pool

I set coin to ZEN
I then changed my worker name to my pool worker name
i have set the address to stratum+tcp://zen.suprnova.cc
i have set the port to 3618
and i have put my wallet address in.

So what am i missing? On my Windows rig i have to put worker name and password info in but i do not see any place to enter that. then when i start it up it just keeps failing to connect to host.

Exactly what is your zen supernava 1bash lines (copy / paste it )\
it should be like this :
Code:
ZEN_WORKER="$WORKERNAME"
ZEN_ADDRESS="username"
ZEN_POOL="zen.suprnova.cc"
ZEN_PORT="3618"
You make new or update your worker name in suprnova worker page ?
and post output of
Code:
ps ax | grep miner
papampi
Full Member
***
Offline Offline

Activity: 140


Linux FOREVER! Resistance is futile!!!


View Profile
September 17, 2017, 06:10:28 AM
 #3694

@fullzero
What do you think about integrating dropbox like pastebin too
I think It has so much more benefits than pastebin.
It can be either as a dropbox file link or a dropbox folder to check the files inside it.
papampi
Full Member
***
Offline Offline

Activity: 140


Linux FOREVER! Resistance is futile!!!


View Profile
September 17, 2017, 07:19:17 AM
 #3695

Anyone successfully mined sib x11ghost with Alexis?
I know Alexis should be able to handle it, but it gives me error :

Code:
/home/m1/ASccminer/ccminer -a sib -o stratum+tcp://sib.suprnova.cc:3458 -u papampi.nv101 -p x -i 24
*** ccminer alexis-1.0 for nVidia GPUs from alexis78@github ***
*** Built with the nVidia CUDA Toolkit 8.0 (Not recommended prefer 7.5)

*** Based on tpruvot@github ccminer
*** Originally based on Christian Buchner and Christian H. project
*** Include some of the work of djm34, sp, tsiv and klausT.

[2017-09-17 11:44:49] Starting on stratum+tcp://sib.suprnova.cc:3458
[2017-09-17 11:44:49] NVML GPU monitoring enabled.
[2017-09-17 11:44:49] 6 miner threads started, using 'sib' algorithm.
[2017-09-17 11:44:51] Stratum difficulty set to 0.00390625
[2017-09-17 11:44:51] sib block 474316, diff 680.280
[2017-09-17 11:44:51] GPU#0:Intensity set to 24, 16777216 cuda threads
[2017-09-17 11:44:51] GPU#4:Intensity set to 24, 16777216 cuda threads
[2017-09-17 11:44:51] GPU#2:Intensity set to 24, 16777216 cuda threads
[2017-09-17 11:44:51] GPU#1:Intensity set to 24, 16777216 cuda threads
[2017-09-17 11:44:51] GPU#5:Intensity set to 24, 16777216 cuda threads
[2017-09-17 11:44:51] GPU#3:Intensity set to 24, 16777216 cuda threads
[2017-09-17 11:44:57] GPU#3:result for 00000000 does not validate on CPU!
[2017-09-17 11:44:57] GPU#3:an illegal memory access was encountered
Cuda error in func 'quark_blake512_cpu_setBlock_80' at line 547 : an illegal memory access was encountered.
damNmad
Full Member
***
Offline Offline

Activity: 168



View Profile
September 17, 2017, 08:15:59 AM
 #3696

Greetings, i am in the process of setting up a 13 card rig to see what the world of mining is like. So i have run into an issue that seems odd. I have looked around and have not seen it. So here it is.

My miner keeps telling me it failed to connect to the host and i am not sure why. I am trying to use suprnova.cc pool

I set coin to ZEN
I then changed my worker name to my pool worker name
i have set the address to stratum+tcp://zen.suprnova.cc
i have set the port to 3618
and i have put my wallet address in.

So what am i missing? On my Windows rig i have to put worker name and password info in but i do not see any place to enter that. then when i start it up it just keeps failing to connect to host.

I've issue with connecting to stratum pool using EWBF;

try this:
Code:
ZEN_WORKER="yourSuprnovaWorkerName"
ZEN_ADDRESS="yourSuprNovaLoginName"
ZEN_POOL="zen.suprnova.cc"
ZEN_PORT="3618"

This should work; let me know if it doesn't.

▀     DeepOnion  |  TOR Integrated & Secured  [ Facebook  Telegram  Bitcointalk  Twitter  Youtube  Reddit ]     ▀
Your Anonymity Guaranteed  ★  Your Assets Secured by TOR  ★  Guard Your Privacy!   ❱❱❱ JOIN AIRDROP NOW!
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬  File Authenticity Guaranteed by DeepVault  ▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
damNmad
Full Member
***
Offline Offline

Activity: 168



View Profile
September 17, 2017, 08:21:10 AM
 #3697

Seems like there is a problem with Klaust and Neoscrypt in linux
There is an open ticket for that
https://github.com/KlausT/ccminer/issues/49


I can not install KTccminer on NVOCv019.

I looked at your post on their incident ticket page and I find that 4 days ago you were able to compile it correctly on your machine.
Unfortunately, I have not managed to do the same with my Biostar TB250-BTC PRO (Socket 1151) and my 2 x ASUS GTX1070 DUAL.

I use the script (s) of Scott ALlfter (alias Salfter) and I went on his page here: https://gitlab.com/salfter/mph_switch/tree/master. This page explains how to add the Cryptonight and Sia miners but I was unable to compile by following the command lines given by Salfter.

./autoreconf.sh does not exist in the KTccminer directory
and
./configure --with-cuda- / usr / local / cuda-8.0 also returns errors after executing the file: autogen.sh

here is what the configuration command gives me before the command make:

user @ hostname $ / KTccminer-cryptonight $ ./configure --with-cuda / usr / local / cuda
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type: / usr / local / cuda
checking build system type ... / usr / local / cuda
configure: error: invalid value of canonical build

It seems to me to have found by re-reading the bash-history that it tries to mine with the CPUminer which mine at the same time as ETH and the others algo.
is it possible to mining with CPUs and GPUs with two different software simultaneously without it posing bp?
That is, I use Scott's mining profit switching script and I have activated the plusCPU function of fullZERO in the 1bash

1 / How to install KTccminer correctly?
2 / Is it possible to mine monero with the CPUs in addition to the GPUs ?

@Scott Alfter

The use of your script delighted me, but I hesitated for a long time because of the lack of documentation. I did not know too much or I was going. and I still do not really know where all the files you are using.

Maybe you have some documentation about these scripts?

NB: I used google translation to write this message

If you just want KTccminer-cryptonight salfter has compiled one :

I finally got around to upgrading to v19 from v17.  I'd had some trouble with v18 and went back to v17, but v19's being much better behaved.  I put my config in (configured to use my MiningPoolHub switcher and Maxximus007's fan-control code) and let her rip.

There is one issue I ran across: no Cryptonight miner.  I noticed it when my mining rig's fans all slowed down.  To get things running again in a hurry, I copied the mining software from my v17 setup.  It's in this tarball:

https://alfter.us/wp/wp-content/uploads/2017/09/KTccminer-cryptonight.tar.xz

Unpack to ~m1. It'll unpack to a Git repo into which you can pull updates (I last updated it just a few days ago) that has already been configured and built.  I might've built it for Pascal (GeForce 10-series) GPUs only; I don't recall for sure if I did, so if you're using older GPUs and it doesn't work for you, you might need to rebuild it.

There was also an upstream change in this miner that requires a change in 3main.  The "-a cryptonight" option is no longer accepted, so load 3main into the editor of your choice, search for "KTccminer-cryptonight" (it's near the beginning of the heredoc that gets written to mph_conf.json), and delete "-a cryptonight" from that line.

Beyond that, the only other changes I made were to set the hostname equal to the worker name (changes in /etc/hostname and /etc/hosts), change the timezone from Eastern to Pacific, and to revise the speed and power figures in the mph_conf.json heredoc with my current configuration (up from 3 GPUs to 4).  As I write this, I'm imaging my v19 setup so I can copy it over to the (physically smaller) stick with v17.

I could compile KTccminer on nv0019, but not on my other ubuntu
gave me some errors
just download the source
and run the commands with no args
Code:
./autogen.sh
./configure.sh
./build.sh
it should be ok

Hello papampi; hope you are well Smiley

I believe we can compile it well but when we try to use it fails to mine with some weird errors!! or it has been fixed?

▀     DeepOnion  |  TOR Integrated & Secured  [ Facebook  Telegram  Bitcointalk  Twitter  Youtube  Reddit ]     ▀
Your Anonymity Guaranteed  ★  Your Assets Secured by TOR  ★  Guard Your Privacy!   ❱❱❱ JOIN AIRDROP NOW!
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬  File Authenticity Guaranteed by DeepVault  ▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
xingqiaoyin
Sr. Member
****
Offline Offline

Activity: 378


View Profile
September 17, 2017, 08:34:09 AM
 #3698

hi need help is there any way i can schedule miner to run like only from 6pm-11am ?


U have multiple solution, depend what u want exactly.

PC have to be turned off or only mining process ?

If u need to pc be turned off, you probably can buy a power timer.

If u let PC run and just turn off miner, u can do a crontab Wink

Code:
crontab -e 0 11 * * * miner1 pkill -e screen && pkill -f 3main
contrab -e 0 18 * * * miner1 bash /home/m1/3main &

First line will kill your process every day at 11am
Second line will launch miner process every day at 6pm (18)

thank you i am looking to do the crontab Smiley
papampi
Full Member
***
Offline Offline

Activity: 140


Linux FOREVER! Resistance is futile!!!


View Profile
September 17, 2017, 09:01:55 AM
 #3699

Seems like there is a problem with Klaust and Neoscrypt in linux
There is an open ticket for that
https://github.com/KlausT/ccminer/issues/49


I can not install KTccminer on NVOCv019.

I looked at your post on their incident ticket page and I find that 4 days ago you were able to compile it correctly on your machine.
Unfortunately, I have not managed to do the same with my Biostar TB250-BTC PRO (Socket 1151) and my 2 x ASUS GTX1070 DUAL.

I use the script (s) of Scott ALlfter (alias Salfter) and I went on his page here: https://gitlab.com/salfter/mph_switch/tree/master. This page explains how to add the Cryptonight and Sia miners but I was unable to compile by following the command lines given by Salfter.

./autoreconf.sh does not exist in the KTccminer directory
and
./configure --with-cuda- / usr / local / cuda-8.0 also returns errors after executing the file: autogen.sh

here is what the configuration command gives me before the command make:

user @ hostname $ / KTccminer-cryptonight $ ./configure --with-cuda / usr / local / cuda
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type: / usr / local / cuda
checking build system type ... / usr / local / cuda
configure: error: invalid value of canonical build

It seems to me to have found by re-reading the bash-history that it tries to mine with the CPUminer which mine at the same time as ETH and the others algo.
is it possible to mining with CPUs and GPUs with two different software simultaneously without it posing bp?
That is, I use Scott's mining profit switching script and I have activated the plusCPU function of fullZERO in the 1bash

1 / How to install KTccminer correctly?
2 / Is it possible to mine monero with the CPUs in addition to the GPUs ?

@Scott Alfter

The use of your script delighted me, but I hesitated for a long time because of the lack of documentation. I did not know too much or I was going. and I still do not really know where all the files you are using.

Maybe you have some documentation about these scripts?

NB: I used google translation to write this message

If you just want KTccminer-cryptonight salfter has compiled one :

I finally got around to upgrading to v19 from v17.  I'd had some trouble with v18 and went back to v17, but v19's being much better behaved.  I put my config in (configured to use my MiningPoolHub switcher and Maxximus007's fan-control code) and let her rip.

There is one issue I ran across: no Cryptonight miner.  I noticed it when my mining rig's fans all slowed down.  To get things running again in a hurry, I copied the mining software from my v17 setup.  It's in this tarball:

https://alfter.us/wp/wp-content/uploads/2017/09/KTccminer-cryptonight.tar.xz

Unpack to ~m1. It'll unpack to a Git repo into which you can pull updates (I last updated it just a few days ago) that has already been configured and built.  I might've built it for Pascal (GeForce 10-series) GPUs only; I don't recall for sure if I did, so if you're using older GPUs and it doesn't work for you, you might need to rebuild it.

There was also an upstream change in this miner that requires a change in 3main.  The "-a cryptonight" option is no longer accepted, so load 3main into the editor of your choice, search for "KTccminer-cryptonight" (it's near the beginning of the heredoc that gets written to mph_conf.json), and delete "-a cryptonight" from that line.

Beyond that, the only other changes I made were to set the hostname equal to the worker name (changes in /etc/hostname and /etc/hosts), change the timezone from Eastern to Pacific, and to revise the speed and power figures in the mph_conf.json heredoc with my current configuration (up from 3 GPUs to 4).  As I write this, I'm imaging my v19 setup so I can copy it over to the (physically smaller) stick with v17.

I could compile KTccminer on nv0019, but not on my other ubuntu
gave me some errors
just download the source
and run the commands with no args
Code:
./autogen.sh
./configure.sh
./build.sh
it should be ok

Hello papampi; hope you are well Smiley

I believe we can compile it well but when we try to use it fails to mine with some weird errors!! or it has been fixed?
Compiles ok, but Neoscrypt gives me this error

Code:
m1@m1-desktop-101:~/Downloads/ccminer-klaust/ccminer-klaust$  ./ccminer -a neoscrypt -o stratum+tcp://hub.miningpoolhub.com:20510 -u papampi.nv101 -p x
ccminer 8.13-KlausT (64bit) for nVidia GPUs
Compiled with GCC 5.4 using Nvidia CUDA Toolkit 8.0

Based on pooler cpuminer 2.3.2 and the tpruvot@github fork
CUDA support by Christian Buchner, Christian H. and DJM34
Includes optimizations implemented by sp-hash, klaust, tpruvot and tsiv.

[2017-09-13 14:15:46] Starting Stratum on stratum+tcp://hub.miningpoolhub.com:20510
[2017-09-13 14:15:46] NVML GPU monitoring enabled.
0
[2017-09-13 14:15:46] GPU #0: waiting for data
1
[2017-09-13 14:15:46] GPU #1: waiting for data
[2017-09-13 14:15:46] 6 miner threads started, using 'neoscrypt' algorithm.
[2017-09-13 14:15:46] GPU #2: waiting for data
[2017-09-13 14:15:46] GPU #3: waiting for data
[2017-09-13 14:15:46] GPU #4: waiting for data
[2017-09-13 14:15:46] GPU #5: waiting for data
[2017-09-13 14:15:47] Stratum difficulty set to 256
[2017-09-13 14:15:47] Stratum difficulty set to 64
[2017-09-13 14:15:47] hub.miningpoolhub.com:20510 neoscrypt block 1881811
Cuda error in func 'neoscrypt_cpu_init_2stream' at line 1439 : invalid device symbol.
Cuda error in func 'neoscrypt_cpu_init_2stream' at line 1434 : driver shutting down.
Cuda error in func 'neoscrypt_cpu_init_2stream' at line 1437 : driver shutting down.
Cuda error in func 'neoscrypt_cpu_init_2stream' at line 1436 : driver shutting down.
Cuda error in func 'scanhash_neoscrypt' at line 96 : driver shutting down.
Cuda error in func 'scanhash_neoscrypt' at line 96 : driver shutting down.


I just opened a new ticket
If any one else has same issue please follow this ticket and conform it.
may be some one try to solve it.
quasarix
Newbie
*
Offline Offline

Activity: 6


View Profile
September 17, 2017, 10:40:04 AM
 #3700

Guys what is SRR option?

also when i set minimum temp=25 or lower, it wont go lower than 30

(using v0019 with updating)
Why you wana set it to 25 or lower ?
Even a standby GPU temp is higher than that.
Dont kill your fans just to take temp down.


no i fu**** question Cheesy

I want to set fans to lower than 30, it wont do it...
Pages: « 1 ... 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 [185] 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 ... 284 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!