Bitcoin Forum
November 21, 2017, 08:13:39 PM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 ... 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 [168] 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 ... 287 »
  Print  
Author Topic: [OS] nvOC easy-to-use Linux Nvidia Mining v0019-1.4  (Read 327171 times)
papampi
Full Member
***
Offline Offline

Activity: 140


Linux FOREVER! Resistance is futile!!!


View Profile
September 06, 2017, 07:43:21 AM
 #3341

MPH_ETHASH Algo mining:

coin:
Code:
COIN="MPH_ETHASH"

1bash:

Code:
MPH_WORKER="$WORKERNAME"
MPH_ADDRESS="your_MPH_username"
MPH_ETHASH_POOL="us-east.ethash-hub.miningpoolhub.com:17020"


3main:
Code:
if [ $COIN == "MPH_ETHASH" ]
then
 
if [ $ETHMINER_or_GENOIL_or_CLAYMORE == "GENOIL" ]
then
HCD='/home/m1/eth/Genoil-U/ethminer'
 
MPH_ETHASH_ADDR="$MPH_ADDRESS.$MPH_WORKER"
 
screen -dmS miner $HCD -S $MPH_ETHASH_POOL -O $MPH_ETHASH_ADDR:x -U
 
if [ $LOCALorREMOTE == "LOCAL" ]
then
screen -r miner
fi
 
BITCOIN="theGROUND"
 
while [ $BITCOIN == "theGROUND" ]
do
sleep 60
done
fi
 
 
if [ $ETHMINER_or_GENOIL_or_CLAYMORE == "ETHMINER" ]
then
HCD='/home/m1/eth/ethminer_12dev2/ethminer'
 
MPH_ETHASH_ADDR="$MPH_ADDRESS.$MPH_WORKER"
 

screen -dmS miner $HCD -S $MPH_ETHASH_POOL -O $MPH_ETHASH_ADDR:x -U
 
if [ $LOCALorREMOTE == "LOCAL" ]
then
screen -r miner
fi
 
BITCOIN="theGROUND"
 
while [ $BITCOIN == "theGROUND" ]
do
sleep 60
done
fi
 
if [ $ETHMINER_or_GENOIL_or_CLAYMORE == "CLAYMORE" ]
then

if [ $CLAYMORE_VERSION == "10_0" ]
then
HCD='/home/m1/eth/10_0/ethdcrminer64'
fi

if [ $CLAYMORE_VERSION == "9_8" ]
then
HCD='/home/m1/eth/9_8/ethdcrminer64'
fi
 
if [ $CLAYMORE_VERSION == "9_7" ]
then
HCD='/home/m1/eth/9_7/ethdcrminer64'
fi
 
if [ $CLAYMORE_VERSION == "9_5" ]
then
HCD='/home/m1/eth/9_5/ethdcrminer64'
fi
 
if [ $CLAYMORE_VERSION == "9_4" ]
then
HCD='/home/m1/eth/9_4/ethdcrminer64'
fi
 
if [ $CLAYMORE_VERSION == "8_0" ]
then
HCD='/home/m1/eth/8_0/ethdcrminer64'
fi
 
MPH_ETHASH_ADDR="$MPH_ADDRESS.$MPH_WORKER"
 
screen -dmS miner $HCD -epool $MPH_ETHASH_POOL -ewal $MPH_ETHASH_ADDR -epsw x -mode 1 -allpools 1 -allcoins 1 -dbg -1 $MPH_ETHASH_EXTENSION_ARGUMENTS
 
if [ $LOCALorREMOTE == "LOCAL" ]
then
screen -r miner
fi
 
BITCOIN="theGROUND"
 
while [ $BITCOIN == "theGROUND" ]
do
sleep 60
done
fi
fi

@damNmad, trying to help to add more
1511295219
Hero Member
*
Offline Offline

Posts: 1511295219

View Profile Personal Message (Offline)

Ignore
1511295219
Reply with quote  #2

1511295219
Report to moderator
1511295219
Hero Member
*
Offline Offline

Posts: 1511295219

View Profile Personal Message (Offline)

Ignore
1511295219
Reply with quote  #2

1511295219
Report to moderator
1511295219
Hero Member
*
Offline Offline

Posts: 1511295219

View Profile Personal Message (Offline)

Ignore
1511295219
Reply with quote  #2

1511295219
Report to moderator
"Apparently, so I am told, there exist "people" who prefer to wipe sitting down. From the front. Initial research indicates it could be up to half the population." -- benjamindees
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1511295219
Hero Member
*
Offline Offline

Posts: 1511295219

View Profile Personal Message (Offline)

Ignore
1511295219
Reply with quote  #2

1511295219
Report to moderator
1511295219
Hero Member
*
Offline Offline

Posts: 1511295219

View Profile Personal Message (Offline)

Ignore
1511295219
Reply with quote  #2

1511295219
Report to moderator
1511295219
Hero Member
*
Offline Offline

Posts: 1511295219

View Profile Personal Message (Offline)

Ignore
1511295219
Reply with quote  #2

1511295219
Report to moderator
damNmad
Full Member
***
Offline Offline

Activity: 168



View Profile
September 06, 2017, 07:49:22 AM
 #3342

MPH_ETHASH Algo mining:

coin:
Code:
COIN="MPH_ETHASH"

1bash:

Code:
MPH_WORKER="$WORKERNAME"
MPH_ADDRESS="your_MPH_username"
MPH_ETHASH_POOL="us-east.ethash-hub.miningpoolhub.com:17020"


3main:
Code:
if [ $COIN == "MPH_ETHASH" ]
then
 
if [ $ETHMINER_or_GENOIL_or_CLAYMORE == "GENOIL" ]
then
HCD='/home/m1/eth/Genoil-U/ethminer'
 
MPH_ETHASH_ADDR="$MPH_ADDRESS.$MPH_WORKER"
 
screen -dmS miner $HCD -S $MPH_ETHASH_POOL -O $MPH_ETHASH_ADDR:x -U
 
if [ $LOCALorREMOTE == "LOCAL" ]
then
screen -r miner
fi
 
BITCOIN="theGROUND"
 
while [ $BITCOIN == "theGROUND" ]
do
sleep 60
done
fi
 
 
if [ $ETHMINER_or_GENOIL_or_CLAYMORE == "ETHMINER" ]
then
HCD='/home/m1/eth/ethminer_12dev2/ethminer'
 
MPH_ETHASH_ADDR="$MPH_ADDRESS.$MPH_WORKER"
 

screen -dmS miner $HCD -S $MPH_ETHASH_POOL -O $MPH_ETHASH_ADDR:x -U
 
if [ $LOCALorREMOTE == "LOCAL" ]
then
screen -r miner
fi
 
BITCOIN="theGROUND"
 
while [ $BITCOIN == "theGROUND" ]
do
sleep 60
done
fi
 
if [ $ETHMINER_or_GENOIL_or_CLAYMORE == "CLAYMORE" ]
then

if [ $CLAYMORE_VERSION == "10_0" ]
then
HCD='/home/m1/eth/10_0/ethdcrminer64'
fi

if [ $CLAYMORE_VERSION == "9_8" ]
then
HCD='/home/m1/eth/9_8/ethdcrminer64'
fi
 
if [ $CLAYMORE_VERSION == "9_7" ]
then
HCD='/home/m1/eth/9_7/ethdcrminer64'
fi
 
if [ $CLAYMORE_VERSION == "9_5" ]
then
HCD='/home/m1/eth/9_5/ethdcrminer64'
fi
 
if [ $CLAYMORE_VERSION == "9_4" ]
then
HCD='/home/m1/eth/9_4/ethdcrminer64'
fi
 
if [ $CLAYMORE_VERSION == "8_0" ]
then
HCD='/home/m1/eth/8_0/ethdcrminer64'
fi
 
MPH_ETHASH_ADDR="$MPH_ADDRESS.$MPH_WORKER"
 
screen -dmS miner $HCD -epool $MPH_ETHASH_POOL -ewal $MPH_ETHASH_ADDR -epsw x -mode 1 -allpools 1 -allcoins 1 -dbg -1 $MPH_ETHASH_EXTENSION_ARGUMENTS
 
if [ $LOCALorREMOTE == "LOCAL" ]
then
screen -r miner
fi
 
BITCOIN="theGROUND"
 
while [ $BITCOIN == "theGROUND" ]
do
sleep 60
done
fi
fi

@damNmad, trying to help to add more


Thanks mate, this one is already on my list of coins to add, will add both (ZPOOL_NEOSCRYPT) of these in my next version.

▀     DeepOnion  |  TOR Integrated & Secured  [ Facebook  Telegram  Bitcointalk  Twitter  Youtube  Reddit ]     ▀
Your Anonymity Guaranteed  ★  Your Assets Secured by TOR  ★  Guard Your Privacy!   ❱❱❱ JOIN AIRDROP NOW!
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬  File Authenticity Guaranteed by DeepVault  ▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
andreih
Newbie
*
Offline Offline

Activity: 7


View Profile
September 06, 2017, 07:51:41 AM
 #3343

how do I stop wdog in v0019? selecting no in 1bash doesn`t help.
damNmad
Full Member
***
Offline Offline

Activity: 168



View Profile
September 06, 2017, 08:01:01 AM
 #3344

how do I stop wdog in v0019? selecting no in 1bash doesn`t help.

If you can see it running on Guake?

kill it by using CTRL + c

▀     DeepOnion  |  TOR Integrated & Secured  [ Facebook  Telegram  Bitcointalk  Twitter  Youtube  Reddit ]     ▀
Your Anonymity Guaranteed  ★  Your Assets Secured by TOR  ★  Guard Your Privacy!   ❱❱❱ JOIN AIRDROP NOW!
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬  File Authenticity Guaranteed by DeepVault  ▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
papampi
Full Member
***
Offline Offline

Activity: 140


Linux FOREVER! Resistance is futile!!!


View Profile
September 06, 2017, 08:26:52 AM
 #3345

Random GPU drop to 0 when mining Neoscrypt
is it normal ?
Or my OC is high ?

1070 OC:

Code:
   POWERLIMIT_WATTS=140
__CORE_OVERCLOCK=125
MEMORY_OVERCLOCK=600


Rig-1:
Code:
==> 5_restartlog <==
      GPU_COUNT:  6
GPU UTILIZATION:  100 100 99 98 0 100

Wed Sep  6 12:54:45 IRDT 2017 - GPU under threshold found

Wed Sep  6 12:54:45 IRDT 2017 - Low Utilization Detected: 3main will reinit if there are 6 consecutive failures
                  35 Failures Before reinit

Rig-2:
Code:
      GPU_COUNT:  7
GPU UTILIZATION:  100 100 100 100 0 95 100

Wed Sep  6 13:01:25 IRDT 2017 - GPU under threshold found

Wed Sep  6 13:01:25 IRDT 2017 - Low Utilization Detected: 3main will reinit if there are 6 consecutive failures
                  41 Failures Before reinit
damNmad
Full Member
***
Offline Offline

Activity: 168



View Profile
September 06, 2017, 08:34:04 AM
 #3346

Random GPU drop to 0 when mining Neoscrypt
is it normal ?
Or my OC is high ?

1070 OC:

Code:
   POWERLIMIT_WATTS=140
__CORE_OVERCLOCK=125
MEMORY_OVERCLOCK=600



Code:
==> 5_restartlog <==
      GPU_COUNT:  6
GPU UTILIZATION:  100 100 99 98 0 100

Wed Sep  6 12:54:45 IRDT 2017 - GPU under threshold found

Wed Sep  6 12:54:45 IRDT 2017 - Low Utilization Detected: 3main will reinit if there are 6 consecutive failures
                  35 Failures Before reinit

I've noticed this too, sometimes all GPU's are not utilised completely; for eg sometime only 4 out of 8 are mining!!

That's where the WATCH_DOG comes into action and restarts mining, most of the times after restart it just mines normally (with full utilisation).

▀     DeepOnion  |  TOR Integrated & Secured  [ Facebook  Telegram  Bitcointalk  Twitter  Youtube  Reddit ]     ▀
Your Anonymity Guaranteed  ★  Your Assets Secured by TOR  ★  Guard Your Privacy!   ❱❱❱ JOIN AIRDROP NOW!
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬  File Authenticity Guaranteed by DeepVault  ▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
papampi
Full Member
***
Offline Offline

Activity: 140


Linux FOREVER! Resistance is futile!!!


View Profile
September 06, 2017, 09:03:34 AM
 #3347

Random GPU drop to 0 when mining Neoscrypt
is it normal ?
Or my OC is high ?

1070 OC:

Code:
   POWERLIMIT_WATTS=140
__CORE_OVERCLOCK=125
MEMORY_OVERCLOCK=600



Code:
==> 5_restartlog <==
      GPU_COUNT:  6
GPU UTILIZATION:  100 100 99 98 0 100

Wed Sep  6 12:54:45 IRDT 2017 - GPU under threshold found

Wed Sep  6 12:54:45 IRDT 2017 - Low Utilization Detected: 3main will reinit if there are 6 consecutive failures
                  35 Failures Before reinit

I've noticed this too, sometimes all GPU's are not utilised completely; for eg sometime only 4 out of 8 are mining!!

That's where the WATCH_DOG comes into action and restarts mining, most of the times after restart it just mines normally (with full utilisation).

Mine doesn't get to restart miner, just 1 drops and goes ok in next, then another in like 5 minutes , then another random drop... And goes on and on
vyt
Newbie
*
Offline Offline

Activity: 2


View Profile
September 06, 2017, 09:39:34 AM
 #3348

tell me when starting the terminal does not apply the overclocking attributes, just skips the lines

http://s019.radikal.ru/i619/1709/ec/71f068c776fa.jpg

http://s019.radikal.ru/i631/1709/be/097b5a81d5e0.jpg
jyakulis
Sr. Member
****
Online Online

Activity: 370


Resident Retard


View Profile
September 06, 2017, 10:41:19 AM
 #3349





A Sempron might have difficulty with additional GPUs and some ALGOs; I previously used all Sempron's with BTC / LTC gpu rigs:  they were solid for BTC, but had some issues with LTC with more than 4x GPUs.  I haven't used one in a long time, so I have no idea how they fair with current algos.



Hmm interesting you brought that up. I use the same board on my personal computer. But I upgraded it for gaming to a 6 core processor and doubled my ram. Anyway, I run 3 gpu no problems on Windows 10. But with the board with the Sempron I could never get it to install past 3 gpu on Windows. And I am also having some freezing problems in Ubuntu during mining. Thinking maybe I should upgrade...



As far as I know K10 Amds use AGP-Gart for their IOMMU. You might get problems on these system because you're running out of DMA-Space, try using 'iommu=memapper=4' (maybe 5) as your boot-parameter, you can look up more details in the kernel documentation.

I think you are probably right on the memory. That adjustment you made, I'm a little too new to this to really figure that out how to do that right now.

So, I've figured out a few things (maybe obvious to some). To mine on supernova, I did not need the tcp part just zen.suprnova.cc with the port it's own value and it worked swimmingly. I'm glad because that's my favorite pool.

Also, back to the memory thing. I have a lot of issues when I leave the miner running in unbuntu with the hashrates and shares displayed in real time. A lot of times mining will just stop or I'll freeze. However, if it goes to the quake window and I just close all that out then I have no issues. I woke up this morning and I went all night no problems. Sometimes I do like to watch the mining window to optimize a bit, but hey I'm not complaining. I could not get my rig to work in Windows 10.

Just out of curiosity, a question for anyone really. I have that older Asus M5A97 R2.0 motherboard with the Sempron processor. If you guys were going to upgrade your rig, would you get a better AM3+ processor or would you replace the whole board and processor? I'm thinking I'd like to eventually go to 6-8 GPU's on this rig (running 4 1070s currently).

And this Son of Man whom thou hast seen
Shall raise up the kings and the mighty from their seats,
And the strong from their thrones
woodl1
Newbie
*
Offline Offline

Activity: 15


View Profile
September 06, 2017, 10:47:21 AM
 #3350

Anone managed to start NVOC version 19 with built-in  VGA? I heared this version finally have a fix, for using on rigs built on GP106-100 GPUs

As I can see on the first page, it is still advised to start without monitor attached if you have only p106 in your rig.

I have tried to start full headless, with pure p106 mode enabled, but all I get are errors in logs, mining process doesn't start. Does anyone know why this could happen?

(I have asus z270-p with 8 p106-100, screen was attached only to modify bios settings as described for z270-a, usb stick was never attached with monitor at the same time)

Code:
Sep  5 15:13:51 m1-desktop systemd[1]: Started Detect the available GPUs and deal with any system changes.
Sep  5 15:13:51 m1-desktop systemd[1]: Starting Light Display Manager...
Sep  5 15:13:51 m1-desktop systemd[1]: Started Light Display Manager.
Sep  5 15:13:51 m1-desktop lightdm[5561]: /etc/modprobe.d is not a file
Sep  5 15:13:51 m1-desktop lightdm[5561]: message repeated 4 times: [ /etc/modprobe.d is not a file]
Sep  5 15:13:51 m1-desktop lightdm[5561]: update-alternatives: error: no alternatives for x86_64-linux-gnu_gfxcore_conf
Sep  5 15:13:52 m1-desktop lightdm[5561]: /etc/modprobe.d is not a file
Sep  5 15:13:52 m1-desktop lightdm[5561]: message repeated 4 times: [ /etc/modprobe.d is not a file]
Sep  5 15:13:52 m1-desktop lightdm[5561]: update-alternatives: error: no alternatives for x86_64-linux-gnu_gfxcore_conf
Sep  5 15:13:52 m1-desktop systemd[1]: lightdm.service: Main process exited, code=exited, status=1/FAILURE
Sep  5 15:13:52 m1-desktop systemd[1]: lightdm.service: Unit entered failed state.
Sep  5 15:13:52 m1-desktop systemd[1]: lightdm.service: Failed with result 'exit-code'.
Sep  5 15:13:52 m1-desktop systemd[1]: lightdm.service: Service hold-off time over, scheduling restart.
Sep  5 15:13:52 m1-desktop systemd[1]: Stopped Light Display Manager.
Sep  5 15:13:52 m1-desktop systemd[1]: Starting Detect the available GPUs and deal with any system changes...
Sep  5 15:13:54 m1-desktop gpu-manager[5613]: /etc/modprobe.d is not a file
Sep  5 15:13:54 m1-desktop gpu-manager[5613]: message repeated 4 times: [ /etc/modprobe.d is not a file]
Sep  5 15:13:54 m1-desktop gpu-manager[5613]: update-alternatives: error: no alternatives for x86_64-linux-gnu_gfxcore_conf
Sep  5 15:13:54 m1-desktop systemd[1]: Started Detect the available GPUs and deal with any system changes.
Sep  5 15:13:54 m1-desktop systemd[1]: Starting Light Display Manager...
Sep  5 15:13:54 m1-desktop systemd[1]: Started Light Display Manager.
Sep  5 15:13:54 m1-desktop lightdm[5640]: /etc/modprobe.d is not a file
Sep  5 15:13:54 m1-desktop lightdm[5640]: message repeated 4 times: [ /etc/modprobe.d is not a file]
Sep  5 15:13:54 m1-desktop lightdm[5640]: update-alternatives: error: no alternatives for x86_64-linux-gnu_gfxcore_conf
Sep  5 15:13:54 m1-desktop lightdm[5640]: /etc/modprobe.d is not a file
Sep  5 15:13:54 m1-desktop lightdm[5640]: message repeated 4 times: [ /etc/modprobe.d is not a file]
Sep  5 15:13:54 m1-desktop lightdm[5640]: update-alternatives: error: no alternatives for x86_64-linux-gnu_gfxcore_conf
Sep  5 15:13:54 m1-desktop systemd[1]: lightdm.service: Main process exited, code=exited, status=1/FAILURE
Sep  5 15:13:54 m1-desktop systemd[1]: lightdm.service: Unit entered failed state.
Sep  5 15:13:54 m1-desktop systemd[1]: lightdm.service: Failed with result 'exit-code'.
Sep  5 15:13:55 m1-desktop systemd[1]: lightdm.service: Service hold-off time over, scheduling restart.
Sep  5 15:13:55 m1-desktop systemd[1]: Stopped Light Display Manager.
Sep  5 15:13:55 m1-desktop systemd[1]: Starting Detect the available GPUs and deal with any system changes...
Sep  5 15:13:56 m1-desktop gpu-manager[5692]: /etc/modprobe.d is not a file
Sep  5 15:13:56 m1-desktop gpu-manager[5692]: message repeated 4 times: [ /etc/modprobe.d is not a file]
Sep  5 15:13:56 m1-desktop gpu-manager[5692]: update-alternatives: error: no alternatives for x86_64-linux-gnu_gfxcore_conf
Sep  5 15:13:56 m1-desktop systemd[1]: Started Detect the available GPUs and deal with any system changes.
Sep  5 15:13:56 m1-desktop systemd[1]: Starting Light Display Manager...
Sep  5 15:13:57 m1-desktop systemd[1]: Started Light Display Manager.

i also have following errors in syslog, in clean nvos019 install. I suppose it's kinda tails from previous usage of "SanDisk_Cruzer_Blade", because I've never used such device.

Code:
Sep  6 02:13:06 m1-desktop systemd[1]: dev-disk-by\x2did-usb\x2dSanDisk_Cruzer_Blade_4C530001260812105231\x2d0:0\x2dpart1.device: Job dev-disk-by\x2did-usb\x2dSanDisk_Cruzer_Blade_4C530001260812105231\x2d0:0\x2dpart1.device/start timed out.
Sep  6 02:13:06 m1-desktop systemd[1]: Timed out waiting for device dev-disk-by\x2did-usb\x2dSanDisk_Cruzer_Blade_4C530001260812105231\x2d0:0\x2dpart1.device.
Sep  6 02:13:06 m1-desktop systemd[1]: Dependency failed for /mnt/usb-SanDisk_Cruzer_Blade_4C530001260812105231-0:0-part1.
Sep  6 02:13:06 m1-desktop systemd[1]: mnt-usb\x2dSanDisk_Cruzer_Blade_4C530001260812105231\x2d0:0\x2dpart1.mount: Job mnt-usb\x2dSanDisk_Cruzer_Blade_4C530001260812105231\x2d0:0\x2dpart1.mount/start failed with result 'dependency'.
Sep  6 02:13:06 m1-desktop systemd[1]: dev-disk-by\x2did-usb\x2dSanDisk_Cruzer_Blade_4C530001260812105231\x2d0:0\x2dpart1.device: Job dev-disk-by\x2did-usb\x2dSanDisk_Cruzer_Blade_4C530001260812105231\x2d0:0\x2dpart1.device/start failed with result 'timeout'.
Sep  6 02:13:06 m1-desktop systemd[1]: dev-disk-by\x2duuid-55184403759586FB.device: Job dev-disk-by\x2duuid-55184403759586FB.device/start timed out.
Sep  6 02:13:06 m1-desktop systemd[1]: Timed out waiting for device dev-disk-by\x2duuid-55184403759586FB.device.
Sep  6 02:13:06 m1-desktop systemd[1]: Dependency failed for /mnt/55184403759586FB.
Sep  6 02:13:06 m1-desktop systemd[1]: mnt-55184403759586FB.mount: Job mnt-55184403759586FB.mount/start failed with result 'dependency'.
Sep  6 02:13:06 m1-desktop systemd[1]: Startup finished in 7.010s (kernel) + 1min 30.221s (userspace) = 1min 37.231s.
Sep  6 02:13:06 m1-desktop systemd[1]: dev-disk-by\x2duuid-55184403759586FB.device: Job dev-disk-by\x2duuid-55184403759586FB.device/start failed with result 'timeout'.

Can anybody guess what to do to make this thing work? Smiley thanks in advance!

ok i'm talking with myself but this becomes useful to solve the problem Smiley
After a little research i've finally launched mining full headless rig of asus z270-p with 7 gp106-100 onboard. Problem was in xorg configuration, nvidia utility helped to solve it:

Code:
sudo nvidia-xconfig -a --cool-bits=28 --allow-empty-initial-configuration
sudo reboot

Now all works fine including overclocking and powerlimits, just one trouble left - if I connect 8-th GPU, nvOS hangs on boot Sad
vyt
Newbie
*
Offline Offline

Activity: 2


View Profile
September 06, 2017, 11:35:13 AM
 #3351


Anone managed to start NVOC version 19 with built-in  VGA? I heared this version finally have a fix, for using on rigs built on GP106-100 GPUs

As I can see on the first page, it is still advised to start without monitor attached if you have only p106 in your rig.

I have tried to start full headless, with pure p106 mode enabled, but all I get are errors in logs, mining process doesn't start. Does anyone know why this could happen?

(I have asus z270-p with 8 p106-100, screen was attached only to modify bios settings as described for z270-a, usb stick was never attached with monitor at the same time)

Code:
Sep  5 15:13:51 m1-desktop systemd[1]: Started Detect the available GPUs and deal with any system changes.
Sep  5 15:13:51 m1-desktop systemd[1]: Starting Light Display Manager...
Sep  5 15:13:51 m1-desktop systemd[1]: Started Light Display Manager.
Sep  5 15:13:51 m1-desktop lightdm[5561]: /etc/modprobe.d is not a file
Sep  5 15:13:51 m1-desktop lightdm[5561]: message repeated 4 times: [ /etc/modprobe.d is not a file]
Sep  5 15:13:51 m1-desktop lightdm[5561]: update-alternatives: error: no alternatives for x86_64-linux-gnu_gfxcore_conf
Sep  5 15:13:52 m1-desktop lightdm[5561]: /etc/modprobe.d is not a file
Sep  5 15:13:52 m1-desktop lightdm[5561]: message repeated 4 times: [ /etc/modprobe.d is not a file]
Sep  5 15:13:52 m1-desktop lightdm[5561]: update-alternatives: error: no alternatives for x86_64-linux-gnu_gfxcore_conf
Sep  5 15:13:52 m1-desktop systemd[1]: lightdm.service: Main process exited, code=exited, status=1/FAILURE
Sep  5 15:13:52 m1-desktop systemd[1]: lightdm.service: Unit entered failed state.
Sep  5 15:13:52 m1-desktop systemd[1]: lightdm.service: Failed with result 'exit-code'.
Sep  5 15:13:52 m1-desktop systemd[1]: lightdm.service: Service hold-off time over, scheduling restart.
Sep  5 15:13:52 m1-desktop systemd[1]: Stopped Light Display Manager.
Sep  5 15:13:52 m1-desktop systemd[1]: Starting Detect the available GPUs and deal with any system changes...
Sep  5 15:13:54 m1-desktop gpu-manager[5613]: /etc/modprobe.d is not a file
Sep  5 15:13:54 m1-desktop gpu-manager[5613]: message repeated 4 times: [ /etc/modprobe.d is not a file]
Sep  5 15:13:54 m1-desktop gpu-manager[5613]: update-alternatives: error: no alternatives for x86_64-linux-gnu_gfxcore_conf
Sep  5 15:13:54 m1-desktop systemd[1]: Started Detect the available GPUs and deal with any system changes.
Sep  5 15:13:54 m1-desktop systemd[1]: Starting Light Display Manager...
Sep  5 15:13:54 m1-desktop systemd[1]: Started Light Display Manager.
Sep  5 15:13:54 m1-desktop lightdm[5640]: /etc/modprobe.d is not a file
Sep  5 15:13:54 m1-desktop lightdm[5640]: message repeated 4 times: [ /etc/modprobe.d is not a file]
Sep  5 15:13:54 m1-desktop lightdm[5640]: update-alternatives: error: no alternatives for x86_64-linux-gnu_gfxcore_conf
Sep  5 15:13:54 m1-desktop lightdm[5640]: /etc/modprobe.d is not a file
Sep  5 15:13:54 m1-desktop lightdm[5640]: message repeated 4 times: [ /etc/modprobe.d is not a file]
Sep  5 15:13:54 m1-desktop lightdm[5640]: update-alternatives: error: no alternatives for x86_64-linux-gnu_gfxcore_conf
Sep  5 15:13:54 m1-desktop systemd[1]: lightdm.service: Main process exited, code=exited, status=1/FAILURE
Sep  5 15:13:54 m1-desktop systemd[1]: lightdm.service: Unit entered failed state.
Sep  5 15:13:54 m1-desktop systemd[1]: lightdm.service: Failed with result 'exit-code'.
Sep  5 15:13:55 m1-desktop systemd[1]: lightdm.service: Service hold-off time over, scheduling restart.
Sep  5 15:13:55 m1-desktop systemd[1]: Stopped Light Display Manager.
Sep  5 15:13:55 m1-desktop systemd[1]: Starting Detect the available GPUs and deal with any system changes...
Sep  5 15:13:56 m1-desktop gpu-manager[5692]: /etc/modprobe.d is not a file
Sep  5 15:13:56 m1-desktop gpu-manager[5692]: message repeated 4 times: [ /etc/modprobe.d is not a file]
Sep  5 15:13:56 m1-desktop gpu-manager[5692]: update-alternatives: error: no alternatives for x86_64-linux-gnu_gfxcore_conf
Sep  5 15:13:56 m1-desktop systemd[1]: Started Detect the available GPUs and deal with any system changes.
Sep  5 15:13:56 m1-desktop systemd[1]: Starting Light Display Manager...
Sep  5 15:13:57 m1-desktop systemd[1]: Started Light Display Manager.

i also have following errors in syslog, in clean nvos019 install. I suppose it's kinda tails from previous usage of "SanDisk_Cruzer_Blade", because I've never used such device.

Code:
Sep  6 02:13:06 m1-desktop systemd[1]: dev-disk-by\x2did-usb\x2dSanDisk_Cruzer_Blade_4C530001260812105231\x2d0:0\x2dpart1.device: Job dev-disk-by\x2did-usb\x2dSanDisk_Cruzer_Blade_4C530001260812105231\x2d0:0\x2dpart1.device/start timed out.
Sep  6 02:13:06 m1-desktop systemd[1]: Timed out waiting for device dev-disk-by\x2did-usb\x2dSanDisk_Cruzer_Blade_4C530001260812105231\x2d0:0\x2dpart1.device.
Sep  6 02:13:06 m1-desktop systemd[1]: Dependency failed for /mnt/usb-SanDisk_Cruzer_Blade_4C530001260812105231-0:0-part1.
Sep  6 02:13:06 m1-desktop systemd[1]: mnt-usb\x2dSanDisk_Cruzer_Blade_4C530001260812105231\x2d0:0\x2dpart1.mount: Job mnt-usb\x2dSanDisk_Cruzer_Blade_4C530001260812105231\x2d0:0\x2dpart1.mount/start failed with result 'dependency'.
Sep  6 02:13:06 m1-desktop systemd[1]: dev-disk-by\x2did-usb\x2dSanDisk_Cruzer_Blade_4C530001260812105231\x2d0:0\x2dpart1.device: Job dev-disk-by\x2did-usb\x2dSanDisk_Cruzer_Blade_4C530001260812105231\x2d0:0\x2dpart1.device/start failed with result 'timeout'.
Sep  6 02:13:06 m1-desktop systemd[1]: dev-disk-by\x2duuid-55184403759586FB.device: Job dev-disk-by\x2duuid-55184403759586FB.device/start timed out.
Sep  6 02:13:06 m1-desktop systemd[1]: Timed out waiting for device dev-disk-by\x2duuid-55184403759586FB.device.
Sep  6 02:13:06 m1-desktop systemd[1]: Dependency failed for /mnt/55184403759586FB.
Sep  6 02:13:06 m1-desktop systemd[1]: mnt-55184403759586FB.mount: Job mnt-55184403759586FB.mount/start failed with result 'dependency'.
Sep  6 02:13:06 m1-desktop systemd[1]: Startup finished in 7.010s (kernel) + 1min 30.221s (userspace) = 1min 37.231s.
Sep  6 02:13:06 m1

Can anybody guess what to do to make this thing work? :) thanks in advance!
[/quote]

ok i'm talking with myself but this becomes useful to solve the problem :)
After a little research i've finally launched mining full headless rig of asus z270-p with 7 gp106-100 onboard. Problem was in xorg configuration, nvidia utility helped to solve it:

[code]
sudo nvidia-xconfig -a --cool-bits=28 --allow-empty-initial-configuration
sudo reboot

Now all works fine including overclocking and powerlimits, just one trouble left - if I connect 8-th GPU, nvOS hangs on boot Sad

Motherboard H110, 13pc p106, monitor connected on board
I have about the same problem, but for some reason your decision didn’t fit. I have one error
http://s018.radikal.ru/i515/1709/c8/3a5820fa09bdt.jpg[/code]
bobers
Member
**
Offline Offline

Activity: 64


View Profile
September 06, 2017, 11:44:07 AM
 #3352

Hi, i just upgraded from 0018 to 0019 and my 1060 3g with same settings (cc100, mc800, pl75, Dual ETH_SC, dcri 40) shows 3-2 Mh less in 0019 then 0018. What is wrong, may be some additional settings?



Sometimes a new claymore version will do worse with specific GPUs.  My guess is thats what is happening.  Try changing:

Code:
CLAYMORE_VERSION="9_8"   

to

Code:
CLAYMORE_VERSION="9_7"   

Thanks it helps. But only if i am mining ETH solo. When i switch to dual ETH_SC claymore 9_7 the hashrate ETH goes down, but SC goes up. I noticed if i change argument -dcri nothing happens, doesnt matter do i do -dcri 0, -dcri 40 or -dcri 100. Is it possible something wrong with 2unix or 3main setings becase -dcri argument doesn't Influence
woodl1
Newbie
*
Offline Offline

Activity: 15


View Profile
September 06, 2017, 12:43:46 PM
 #3353


Motherboard H110, 13pc p106, monitor connected on board
I have about the same problem, but for some reason your decision didn’t fit. I have one error
http://s018.radikal.ru/i515/1709/c8/3a5820fa09bdt.jpg

i get the same error if i have not enough permissions. Suppose "$sudo" at the beggining of the line in your case is wrong, you need to type just "sudo nvidia-xconfig ..."
ATCkit
Hero Member
*****
Offline Offline

Activity: 754


View Profile
September 06, 2017, 01:07:42 PM
 #3354





A Sempron might have difficulty with additional GPUs and some ALGOs; I previously used all Sempron's with BTC / LTC gpu rigs:  they were solid for BTC, but had some issues with LTC with more than 4x GPUs.  I haven't used one in a long time, so I have no idea how they fair with current algos.



Hmm interesting you brought that up. I use the same board on my personal computer. But I upgraded it for gaming to a 6 core processor and doubled my ram. Anyway, I run 3 gpu no problems on Windows 10. But with the board with the Sempron I could never get it to install past 3 gpu on Windows. And I am also having some freezing problems in Ubuntu during mining. Thinking maybe I should upgrade...



As far as I know K10 Amds use AGP-Gart for their IOMMU. You might get problems on these system because you're running out of DMA-Space, try using 'iommu=memapper=4' (maybe 5) as your boot-parameter, you can look up more details in the kernel documentation.

I think you are probably right on the memory. That adjustment you made, I'm a little too new to this to really figure that out how to do that right now.

So, I've figured out a few things (maybe obvious to some). To mine on supernova, I did not need the tcp part just zen.suprnova.cc with the port it's own value and it worked swimmingly. I'm glad because that's my favorite pool.

Also, back to the memory thing. I have a lot of issues when I leave the miner running in unbuntu with the hashrates and shares displayed in real time. A lot of times mining will just stop or I'll freeze. However, if it goes to the quake window and I just close all that out then I have no issues. I woke up this morning and I went all night no problems. Sometimes I do like to watch the mining window to optimize a bit, but hey I'm not complaining. I could not get my rig to work in Windows 10.

Just out of curiosity, a question for anyone really. I have that older Asus M5A97 R2.0 motherboard with the Sempron processor. If you guys were going to upgrade your rig, would you get a better AM3+ processor or would you replace the whole board and processor? I'm thinking I'd like to eventually go to 6-8 GPU's on this rig (running 4 1070s currently).

I used that MoBo and CPU since 2013 and until about April last year. I had a good run with it.

I have made varous builds since then with Asrock and MSI MOBOs and Pentium CPUs. Recently, I got a good deal on the Gigabyte GA 110 - D3A MOBO and a pentium G4400 CPU. This latest combo works as good as any. You can likely find them at NewEgg or Amazon etc. Shop around.

EDIT: Here's a review:

http://1stminingrig.com/gigabyte-ga-h110-d3a-review-the-new-best-motherboard-for-mining/
car1999
Full Member
***
Offline Offline

Activity: 168


View Profile
September 06, 2017, 01:13:52 PM
 #3355

in 3main
Code:
pkill -e miner
I know it is used to kill the miner process, but what does -e mean? Cannot find this argument in
Code:
man pkill
FailSaf3
Newbie
*
Offline Offline

Activity: 15


View Profile
September 06, 2017, 01:31:53 PM
 #3356

Quote
Mate, that is a very simple DIY stuff, for which you don't need to wait until next release.

Just follow this guide and try v10, you can simply switch back by renaming folder names.


Download the Linux version on rig from this link :

https://drive.google.com/drive/folders/0B69wv2iqszefdFZUV2toUG5HdlU

extract it (right click extract here)

Go to /home/m1/eth (can do it using GUI)

rename the 9_8 to 9_8_xx

copy the latest claymore folder from downloads and paste it in the above eth folder and rename it to 9_8.

It should work normally (this is the easiest work around, you don't need to edit any 1bash or 3main).

I've seen a little increase in dual mining lbc hashrates.


Hope it helps Smiley

Thank you! I was pretty sure the folder would have to be coded in, but never thought about using an existing folder as a temp solution!!    Is it only an increase for AMD lbc hr or also nvidia?
VoskCoin
Full Member
***
Offline Offline

Activity: 224


YouTube.com/VoskCoin


View Profile WWW
September 06, 2017, 01:34:49 PM
 #3357

Random GPU drop to 0 when mining Neoscrypt
is it normal ?
Or my OC is high ?

1070 OC:

Code:
   POWERLIMIT_WATTS=140
__CORE_OVERCLOCK=125
MEMORY_OVERCLOCK=600



Code:
==> 5_restartlog <==
      GPU_COUNT:  6
GPU UTILIZATION:  100 100 99 98 0 100

Wed Sep  6 12:54:45 IRDT 2017 - GPU under threshold found

Wed Sep  6 12:54:45 IRDT 2017 - Low Utilization Detected: 3main will reinit if there are 6 consecutive failures
                  35 Failures Before reinit

I've noticed this too, sometimes all GPU's are not utilised completely; for eg sometime only 4 out of 8 are mining!!

That's where the WATCH_DOG comes into action and restarts mining, most of the times after restart it just mines normally (with full utilisation).


Can you explain to me exactly how the watchdog works / is it auto enabled on nvOC_19?




Also added an
ALTERNATE nvOC_19 DOWNLOAD
http://www.mediafire.com/file/470ppz4amc4noo7/nvOC_v0019.zip
as well as nvOC_17
http://www.mediafire.com/file/oi84ue7e6z9epn9/nvOC_v0017.zip

I am just now experimenting with nvOC_19 and if its stable on my rigs will migrate all my rigs to it

SSH into these is better than teamviewer is my understanding, correct?

Check out my Crypto YouTube channel
https://www.youtube.com/VoskCoin
If you enjoy my content click Subscribe
FailSaf3
Newbie
*
Offline Offline

Activity: 15


View Profile
September 06, 2017, 01:41:10 PM
 #3358

Hi, i just upgraded from 0018 to 0019 and my 1060 3g with same settings (cc100, mc800, pl75, Dual ETH_SC, dcri 40) shows 3-2 Mh less in 0019 then 0018. What is wrong, may be some additional settings?
https://i.imgur.com/8nwXTh4.jpg
https://i.imgur.com/0kyevrx.jpg

Sometimes a new claymore version will do worse with specific GPUs.  My guess is thats what is happening.  Try changing:

Code:
CLAYMORE_VERSION="9_8"   

to

Code:
CLAYMORE_VERSION="9_7"   

Thanks it helps. But only if i am mining ETH solo. When i switch to dual ETH_SC claymore 9_7 the hashrate ETH goes down, but SC goes up. I noticed if i change argument -dcri nothing happens, doesnt matter do i do -dcri 0, -dcri 40 or -dcri 100. Is it possible something wrong with 2unix or 3main setings becase -dcri argument doesn't Influence


Try manually switching dual mining off on one of the cards after it has started by pressing a number 0-9 (ie.e GPU0, GPU1, GPU2).  Pressing a number once to turn the mining for that GPU off, press it again to go into ETH only, check numbers, and you can resume dual mining by pressing the same number once more (you will see text of what state you are in while your doing this in terminal).    If it is caused by the dual mining, try to manually lower the DCRI in the terminal by using the - key.  ( + key = increased hash rate of second coin, - key = lower hashrate of second coin)
damNmad
Full Member
***
Offline Offline

Activity: 168



View Profile
September 06, 2017, 01:50:28 PM
 #3359

Quote
Mate, that is a very simple DIY stuff, for which you don't need to wait until next release.

Just follow this guide and try v10, you can simply switch back by renaming folder names.


Download the Linux version on rig from this link :

https://drive.google.com/drive/folders/0B69wv2iqszefdFZUV2toUG5HdlU

extract it (right click extract here)

Go to /home/m1/eth (can do it using GUI)

rename the 9_8 to 9_8_xx

copy the latest claymore folder from downloads and paste it in the above eth folder and rename it to 9_8.

It should work normally (this is the easiest work around, you don't need to edit any 1bash or 3main).

I've seen a little increase in dual mining lbc hashrates.


Hope it helps Smiley

Thank you! I was pretty sure the folder would have to be coded in, but never thought about using an existing folder as a temp solution!!    Is it only an increase for AMD lbc hr or also nvidia?

I've tested on nvidia, seen a little increase for LBC

▀     DeepOnion  |  TOR Integrated & Secured  [ Facebook  Telegram  Bitcointalk  Twitter  Youtube  Reddit ]     ▀
Your Anonymity Guaranteed  ★  Your Assets Secured by TOR  ★  Guard Your Privacy!   ❱❱❱ JOIN AIRDROP NOW!
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬  File Authenticity Guaranteed by DeepVault  ▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
papampi
Full Member
***
Offline Offline

Activity: 140


Linux FOREVER! Resistance is futile!!!


View Profile
September 06, 2017, 02:09:29 PM
 #3360

Random GPU drop to 0 when mining Neoscrypt
is it normal ?
Or my OC is high ?

1070 OC:

Code:
   POWERLIMIT_WATTS=140
__CORE_OVERCLOCK=125
MEMORY_OVERCLOCK=600



Code:
==> 5_restartlog <==
      GPU_COUNT:  6
GPU UTILIZATION:  100 100 99 98 0 100

Wed Sep  6 12:54:45 IRDT 2017 - GPU under threshold found

Wed Sep  6 12:54:45 IRDT 2017 - Low Utilization Detected: 3main will reinit if there are 6 consecutive failures
                  35 Failures Before reinit

I've noticed this too, sometimes all GPU's are not utilised completely; for eg sometime only 4 out of 8 are mining!!

That's where the WATCH_DOG comes into action and restarts mining, most of the times after restart it just mines normally (with full utilisation).


Can you explain to me exactly how the watchdog works / is it auto enabled on nvOC_19?




Also added an
ALTERNATE nvOC_19 DOWNLOAD
http://www.mediafire.com/file/470ppz4amc4noo7/nvOC_v0019.zip
as well as nvOC_17
http://www.mediafire.com/file/oi84ue7e6z9epn9/nvOC_v0017.zip

I am just now experimenting with nvOC_19 and if its stable on my rigs will migrate all my rigs to it

SSH into these is better than teamviewer is my understanding, correct?

Watch Dog job is to watch for any thing you feed it
In nvoc IAmNotAJeep_and_Maxximus007_WATCHDOG job is to watch for mining failures
either if a gpu has utilization lower than 90% or miner stops or ....
it keeps watching for failures and restart miner or if needed restart system for example if gpu lost

and Maxximus007_AUTO_TEMPERATURE_CONTROL job is to control your temp and keep it below the limit, either higher the fan speed or lower power if fan is at 100%

You can enable or disable them in nvOC-0019

 
Code:
Maxximus007_AUTO_TEMPERATURE_CONTROL="YES"
 
IAmNotAJeep_and_Maxximus007_WATCHDOG="YES"

SSH is always the best way to control linux, forget about teamviewer
Pages: « 1 ... 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 [168] 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 ... 287 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!