Bitcoin Forum
July 17, 2018, 12:41:32 AM *
News: Latest stable version of Bitcoin Core: 0.16.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: « 1 ... 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 [217] 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 ... 847 »
  Print  
Author Topic: OFFICIAL CGMINER mining software thread for linux/win/osx/mips/arm/r-pi 4.10.0  (Read 5756843 times)
This is a self-moderated topic. If you do not want to be moderated by the person who started this topic, create a new topic.
sharky112065
Sr. Member
****
Offline Offline

Activity: 382
Merit: 250



View Profile
February 26, 2012, 02:22:54 AM
 #4321

Are there any windows 7 miners that can help me with the following problem?

I have APP SDK 2.5.732.1, AMD driver 11.12 installed.

One Nvidia GPU as my primary video card (not mining), One ATI Radeon HD 5870 (mining) with cgminer 2.3.1-2.

If I disconnect the dummy plug from the 5870 or disconnect it via AMD Vision Engine Control Center or via Windows (as in not extend the desktop to it), Cgminer cannot read/control GPU Clock, GPU Memory Speed, or GPU Fan.

If I leave the dummy plug on and extend the desktop to that GPU, occasionally I get display driver stopped responding and Cgminer craps out (keeps running but cannot hash).

Anyway to make it work either without the dummy plug or with out the desktop being extended to the 5870?

Donations welcome: 12KaKtrK52iQjPdtsJq7fJ7smC32tXWbWr
The World's Betting Exchange

Bet with play money. Win real Bitcoin. 5BTC Prize Fund for World Cup 2018.

Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
cuz0882
Sr. Member
****
Offline Offline

Activity: 392
Merit: 250


View Profile
February 26, 2012, 02:44:55 AM
 #4322

Is it possible to turn it on for a specific gpu?
I've been running one with autogpu because it has a non reference fan. The rest I just use fan auto
This parameter is global and enables ADL-related routines in cgminer, it is not enabled on a by-card basis as you'd surely know had you RTFM'd first.
Normally, since auto-gpu is a prerequisite for card speed throttling in case of fan failure(1) you want it enabled anyway.

Notes:
(1) or the house catching fire - "Whew! Suddenly getting hot in here, better drop those clocks"    (I really couldn't abstain from making a bad joke, sorry)
I read the manual. It's not very clear on the subject. I want to get as much of the settings in the config as possible. I don't want the other cards to down clock. If the fans stop the pc will crash in a few seconds anyway.
Vbs
Hero Member
*****
Offline Offline

Activity: 504
Merit: 500


View Profile
February 26, 2012, 03:35:24 AM
 #4323

I'll be taking an extended break from coding on cgminer shortly since most things are stable at the moment for my sanity.

A well deserved break! Grin

I'll keep tinkering with the phatk kernel when I have some free time. Meanwhile my best result for V2 (ignoring infinitesimally rare x==y==0), is:
Code:
#elif defined VECTORS2
uint result = !W[117].x ? W[3].x:0u;
result = !W[117].y ? W[3].y:result;
if (result)
output[FOUND] = output[NFLAG & result] = result;
(1357 ALUs, 67.65 min, 67.85 max, 67.75 avg)
DeathAndTaxes
Donator
Legendary
*
Offline Offline

Activity: 1218
Merit: 1005


Gerald Davis


View Profile
February 26, 2012, 03:37:29 AM
 #4324

Is it possible to turn it on for a specific gpu?
I've been running one with autogpu because it has a non reference fan. The rest I just use fan auto
This parameter is global and enables ADL-related routines in cgminer, it is not enabled on a by-card basis as you'd surely know had you RTFM'd first.
Normally, since auto-gpu is a prerequisite for card speed throttling in case of fan failure(1) you want it enabled anyway.

Notes:
(1) or the house catching fire - "Whew! Suddenly getting hot in here, better drop those clocks"    (I really couldn't abstain from making a bad joke, sorry)
I read the manual. It's not very clear on the subject. I want to get as much of the settings in the config as possible. I don't want the other cards to down clock. If the fans stop the pc will crash in a few seconds anyway.

Code:
"auto-gpu": true
"auto-fan" : true
gpu-engine : "600-800","800-800",800-800", etc
gpu-fan: "100-100", "60-85","60-85", etc

That should work.  It is saying turn auto gpu and auto fan ON.  range the first gpu but keep all others at 800.  keep first fan at 100 and range the others.

I recommend always using auto-gpu even if you want the clock static.  Having auto-gpu enabled allows cgminer to shutdown gpu if it overheats or put the fan into emergency (100% mode).
DeathAndTaxes
Donator
Legendary
*
Offline Offline

Activity: 1218
Merit: 1005


Gerald Davis


View Profile
February 26, 2012, 03:52:32 AM
 #4325

Code:
So I am trying to get 4x5970 working under Linux.

Aticonfig shows 8 GPUs but cgminer bombs out.
[code]
* 0. 17:00.0 ATI Radeon HD 5900 Series
  1. 16:00.0 ATI Radeon HD 5900 Series
  2. 13:00.0 ATI Radeon HD 5900 Series
  3. 12:00.0 ATI Radeon HD 5900 Series
  4. 0b:00.0 ATI Radeon HD 5900 Series
  5. 0a:00.0 ATI Radeon HD 5900 Series
  6. 07:00.0 ATI Radeon HD 5900 Series
  7. 06:00.0 ATI Radeon HD 5900 Series

* - Default adapter

cgminer -n
Code:

X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  140 (ATIFGLEXTENSION)
  Minor opcode of failed request:  67 ()
  Value in failed request:  0x17
  Serial number of failed request:  21
  Current serial number in output stream:  21

cgminer -D -T (w/ config file) has same error.

Unplugging PCIe power cables for one 5970 (6 active GPUs) works.[/code]
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2576
Merit: 1110


Ruu \o/


View Profile WWW
February 26, 2012, 05:46:09 AM
 #4326

Yes I've audited the code a million times and can't find the bug. For some reason some dual GPU cards the auto-fan control isn't doing anything and it's sitting at 85% at all times.
I think I figured it out:

ga->lasttemp seems to always contain the value for the temperature of the first GPU on the twin GPU card.  "temp" always contains the temperature of the GPU that is highest between the two.  Therefore, if the 2nd GPU on the card is hotter (and it almost always is on 5970s), it's never going to adjust.  ga->lasttemp needs to be modified to contain the value of the highest temp GPU between the two so that they're comparing "apples to apples".

The only reason my one rig is working and the other two aren't is because the 2nd GPU happens to stay a little cooler than the first.  The other two have hotter 2nd GPUs (as they should, since the hot air from the first GPU blows across it).

I'd make the change myself, but you really don't want to see my coding "skills".  I'm a good reverse-engineer, but I'm a shit coder (as far as keeping things clean goes).
If you're using linux + git, try the current git tree please to see if it fixes it.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org 1% Fee Solo mining at solo.ckpool.org
-ck
sharky112065
Sr. Member
****
Offline Offline

Activity: 382
Merit: 250



View Profile
February 26, 2012, 05:54:02 AM
 #4327

For the people that are having trouble compiling Cgminer on Windows from source, I have put together compile instructions. This is version 1.0 and will probably change over time.

http://pastebin.com/3pzivj32

Tested on both Windows 7 and Windows XP.

Donations welcome: 12KaKtrK52iQjPdtsJq7fJ7smC32tXWbWr
Proofer
Member
**
Offline Offline

Activity: 257
Merit: 10


View Profile
February 26, 2012, 06:22:28 AM
 #4328

If you're using linux + git, try the current git tree please to see if it fixes it.

Fixes it for me.  Thanks for delaying your extended break from coding!
cuz0882
Sr. Member
****
Offline Offline

Activity: 392
Merit: 250


View Profile
February 26, 2012, 06:43:12 AM
 #4329

Is it possible to turn it on for a specific gpu?
I've been running one with autogpu because it has a non reference fan. The rest I just use fan auto
This parameter is global and enables ADL-related routines in cgminer, it is not enabled on a by-card basis as you'd surely know had you RTFM'd first.
Normally, since auto-gpu is a prerequisite for card speed throttling in case of fan failure(1) you want it enabled anyway.

Notes:
(1) or the house catching fire - "Whew! Suddenly getting hot in here, better drop those clocks"    (I really couldn't abstain from making a bad joke, sorry)
I read the manual. It's not very clear on the subject. I want to get as much of the settings in the config as possible. I don't want the other cards to down clock. If the fans stop the pc will crash in a few seconds anyway.

Code:
"auto-gpu": true
"auto-fan" : true
gpu-engine : "600-800","800-800",800-800", etc
gpu-fan: "100-100", "60-85","60-85", etc

That should work.  It is saying turn auto gpu and auto fan ON.  range the first gpu but keep all others at 800.  keep first fan at 100 and range the others.

I recommend always using auto-gpu even if you want the clock static.  Having auto-gpu enabled allows cgminer to shutdown gpu if it overheats or put the fan into emergency (100% mode).



I tried this but the engine clock on the first gpu get stuck at 850. That's the stock speed for the card, the other clocks get changed correctly. If I change it from within cg miner it works.

"auto-gpu": true,
"auto-fan" : true,
"gpu-engine" : "600-850,800-800,800-800,800-800,800-800",
"gpu-fan" : "100-100,0-85,0-85,0-85,0-85",
"gpu-memclock" : "150,150,150,150,150",
"temp-target" : "80,70,70,75,75",
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2576
Merit: 1110


Ruu \o/


View Profile WWW
February 26, 2012, 07:15:52 AM
 #4330

I tried this but the engine clock on the first gpu get stuck at 850. That's the stock speed for the card, the other clocks get changed correctly. If I change it from within cg miner it works.

"auto-gpu": true,
"auto-fan" : true,
"gpu-engine" : "600-850,800-800,800-800,800-800,800-800",
"gpu-fan" : "100-100,0-85,0-85,0-85,0-85",
"gpu-memclock" : "150,150,150,150,150",
"temp-target" : "80,70,70,75,75",
You're telling it the upper limit for gpu engine is 850 or 800 depending on the card, so yeah it's listening to you.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org 1% Fee Solo mining at solo.ckpool.org
-ck
sveetsnelda
Hero Member
*****
Offline Offline

Activity: 637
Merit: 500


View Profile
February 26, 2012, 07:32:55 AM
 #4331

If you're using linux + git, try the current git tree please to see if it fixes it.

Worked like a champ.  Thanks very much!  Sent a couple coins your way.

14u2rp4AqFtN5jkwK944nn741FnfF714m7
cuz0882
Sr. Member
****
Offline Offline

Activity: 392
Merit: 250


View Profile
February 26, 2012, 07:40:44 AM
 #4332

I tried this but the engine clock on the first gpu get stuck at 850. That's the stock speed for the card, the other clocks get changed correctly. If I change it from within cg miner it works.

"auto-gpu": true,
"auto-fan" : true,
"gpu-engine" : "600-850,800-800,800-800,800-800,800-800",
"gpu-fan" : "100-100,0-85,0-85,0-85,0-85",
"gpu-memclock" : "150,150,150,150,150",
"temp-target" : "80,70,70,75,75",
You're telling it the upper limit for gpu engine is 850 or 800 depending on the card, so yeah it's listening to you.

gpu 0 should drop clock speed below 850 if the temp reaches over 80. How would you have written it?
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2576
Merit: 1110


Ruu \o/


View Profile WWW
February 26, 2012, 07:47:51 AM
 #4333

I tried this but the engine clock on the first gpu get stuck at 850. That's the stock speed for the card, the other clocks get changed correctly. If I change it from within cg miner it works.

"auto-gpu": true,
"auto-fan" : true,
"gpu-engine" : "600-850,800-800,800-800,800-800,800-800",
"gpu-fan" : "100-100,0-85,0-85,0-85,0-85",
"gpu-memclock" : "150,150,150,150,150",
"temp-target" : "80,70,70,75,75",
You're telling it the upper limit for gpu engine is 850 or 800 depending on the card, so yeah it's listening to you.

gpu 0 should drop clock speed below 850 if the temp reaches over 80. How would you have written it?
Your settings are fine for that. The threshold where clockspeed goes down is 3 degrees over the setting (see temp hysteresis) to prevent the clockspeed being changed too easily when it takes a few seconds for the fans to catch up.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org 1% Fee Solo mining at solo.ckpool.org
-ck
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2576
Merit: 1110


Ruu \o/


View Profile WWW
February 26, 2012, 07:49:58 AM
 #4334

If you're using linux + git, try the current git tree please to see if it fixes it.

Worked like a champ.  Thanks very much!  Sent a couple coins your way.
Thanks for testing. I'm considering wrapping up the few minor changes since 2.3.1 and releasing 2.3.2 before I take my break. Likely the only people who would notice a difference are those with twin GPUs going from 2.3.1-2 to 2.3.2. I'm not making any changes that might break something at this moment in time.

What do people think? Should I bother?

Primary developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org 1% Fee Solo mining at solo.ckpool.org
-ck
Diapolo
Hero Member
*****
Offline Offline

Activity: 769
Merit: 500



View Profile WWW
February 26, 2012, 09:41:59 AM
 #4335

If you're using linux + git, try the current git tree please to see if it fixes it.

Worked like a champ.  Thanks very much!  Sent a couple coins your way.
Thanks for testing. I'm considering wrapping up the few minor changes since 2.3.1 and releasing 2.3.2 before I take my break. Likely the only people who would notice a difference are those with twin GPUs going from 2.3.1-2 to 2.3.2. I'm not making any changes that might break something at this moment in time.

What do people think? Should I bother?

A fix that work is a fix no one cries for during your break Smiley. I hope you accept my last pull-request befor the break, anything wrong with it?

Dia

Liked my former work for Bitcoin Core? Drop me a donation via:
1PwnvixzVAKnAqp8LCV8iuv7ohzX2pbn5x
bitcoin:1PwnvixzVAKnAqp8LCV8iuv7ohzX2pbn5x?label=Diapolo
spiccioli
Legendary
*
Offline Offline

Activity: 1376
Merit: 1000

nec sine labore


View Profile
February 26, 2012, 01:31:00 PM
 #4336

Hi,

I don't know if this is the correct forum where ask my question, but since it is cgminer related I start from here Smiley

I've got a five 5870 rig I've just set up, it runs xubuntu 11.10 with catalyst 11.8 (the one that installs using xubuntu proprietary drivers applet) and I've installed AMD SDK 2.4.

If I don't use GPU_USE_SYNC_OBJECTS=1  CPU usage goes to 90%, If I use it, on the other hand, cgminer uses from 20 to 35% of CPU and CPU is a sempron 2.8 Ghz

Dud catalyst driver. Use 11.6 or 11.11+ on linux.

Sorry ckolivas,

but there is something else, I've just reinstalled everything using kano recipe, now I have xubuntu 11.04 64bit, catalyst 11.6 and AMD SDK 2.4

Code:
fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 5800 Series
OpenGL version string: 4.1.10834 Compatibility Profile Context



display: :0.0  screen: 1
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 5800 Series
OpenGL version string: 4.1.10834 Compatibility Profile Context



display: :0.0  screen: 2
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 5800 Series
OpenGL version string: 4.1.10834 Compatibility Profile Context



display: :0.0  screen: 3
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 5800 Series
OpenGL version string: 4.1.10834 Compatibility Profile Context



display: :0.0  screen: 4
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 5800 Series
OpenGL version string: 4.1.10834 Compatibility Profile Context

Code:
cgminer/cgminer -ndevs
[2012-02-26 14:25:56] CL Platform 0 vendor: Advanced Micro Devices, Inc.
[2012-02-26 14:25:56] CL Platform 0 name: AMD Accelerated Parallel Processing
[2012-02-26 14:25:56] CL Platform 0 version: OpenCL 1.1 AMD-APP-SDK-v2.4 (595.10)
[2012-02-26 14:25:56] Platform 0 devices: 5
[2012-02-26 14:25:56] GPU 0 ATI Radeon HD 5800 Series hardware monitoring enabled
[2012-02-26 14:25:56] Setting GPU 0 engine clock to 830
[2012-02-26 14:25:56] Setting GPU 0 memory clock to 160
[2012-02-26 14:25:56] Setting GPU 0 voltage to 1.050
[2012-02-26 14:25:56] GPU 1 ATI Radeon HD 5800 Series hardware monitoring enabled
[2012-02-26 14:25:56] Setting GPU 1 engine clock to 830
[2012-02-26 14:25:56] Setting GPU 1 memory clock to 160
[2012-02-26 14:25:56] Setting GPU 1 voltage to 1.050
[2012-02-26 14:25:56] GPU 2 ATI Radeon HD 5800 Series hardware monitoring enabled
[2012-02-26 14:25:56] Setting GPU 2 engine clock to 830
[2012-02-26 14:25:56] Setting GPU 2 memory clock to 160
[2012-02-26 14:25:56] Setting GPU 2 voltage to 1.050
[2012-02-26 14:25:56] GPU 3 ATI Radeon HD 5800 Series hardware monitoring enabled
[2012-02-26 14:25:56] Setting GPU 3 engine clock to 830
[2012-02-26 14:25:56] Setting GPU 3 memory clock to 160
[2012-02-26 14:25:56] Setting GPU 3 voltage to 1.050
[2012-02-26 14:25:56] GPU 4 ATI Radeon HD 5800 Series hardware monitoring enabled
[2012-02-26 14:25:56] Setting GPU 4 engine clock to 830
[2012-02-26 14:25:56] Setting GPU 4 memory clock to 160
[2012-02-26 14:25:56] Setting GPU 4 voltage to 1.050
[2012-02-26 14:25:56] 5 GPU devices max detected

without GPU_USE_SYNC_OBJECTS=1 either cgminer 2.1.2 or 2.3.1-2 use around 90% of CPU, with sync objects they're around 30-40% with 2.3.1-2 using around 5% more than 2.1.2

Code:
cgminer version 2.3.1 - Started: [2012-02-26 14:11:52]
--------------------------------------------------------------------------------
 (5s):1661.5 (avg):1696.8 Mh/s | Q:215  A:188  R:0  HW:0  E:87%  U:23.48/m
 TQ: 7  ST: 8  SS: 0  DW: 11  NB: 3  LW: 0  GF: 0  RF: 0
 Connected to http://pool.abcpool.co:8332 with LP as user spiccioli.m2
 Block: 0000065f11c15097cce668b2f037fbe7...  Started: [14:16:15]
--------------------------------------------------------------------------------
 [P]ool management [G]PU management [S]ettings [D]isplay options [Q]uit
 GPU 0:  73.0C  25%    | 336.6/346.5Mh/s | A:31 R:0 HW:0 U: 3.87/m I: 5
 GPU 1:  73.5C 1270RPM | 331.8/343.1Mh/s | A:34 R:0 HW:0 U: 4.25/m I: 5
 GPU 2:  71.5C 2012RPM | 329.9/341.4Mh/s | A:48 R:0 HW:0 U: 5.99/m I: 5
 GPU 3:  69.0C 1759RPM | 331.1/339.2Mh/s | A:46 R:0 HW:0 U: 5.74/m I: 5
 GPU 4:  75.5C 2214RPM | 327.1/335.2Mh/s | A:30 R:0 HW:0 U: 3.75/m I: 5
--------------------------------------------------------------------------------

and top

Code:
top - 14:21:44 up 17 min,  3 users,  load average: 0.05, 0.25, 0.38
Tasks: 145 total,   1 running, 144 sleeping,   0 stopped,   0 zombie
Cpu(s): 20.5%us, 32.0%sy,  0.0%ni, 47.3%id,  0.3%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   4055036k total,  1402804k used,  2652232k free,    20796k buffers
Swap:  4187132k total,        0k used,  4187132k free,   290544k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND             
 2423 user      20   0  570m 225m  52m S 32.2  5.7   3:18.96 cgminer             
 1177 root      20   0  675m 111m  75m S  9.9  2.8   1:12.56 Xorg               
 2636 user      20   0  772m 150m  39m S  6.1  3.8   0:45.95 firefox-bin         
    4 root      20   0     0    0    0 S  1.7  0.0   0:15.12 kworker/0:0         
 2875 root      20   0     0    0    0 S  1.7  0.0   0:05.71 kworker/0:2         
 1491 user      20   0  176m  14m 9472 S  0.3  0.4   0:02.14 xfwm4               
 1740 user      20   0  269m  17m  10m S  0.3  0.4   0:04.81 xfce4-terminal     
 1483 user      20   0 64112 2904 1968 S  0.1  0.1   0:00.96 xscreensaver       
    1 root      20   0 24008 2136 1292 S  0.0  0.1   0:01.15 init               

with sync objects to 0, same cgminer

Code:
top - 14:23:24 up 19 min,  3 users,  load average: 4.33, 1.33, 0.73
Tasks: 145 total,   2 running, 143 sleeping,   0 stopped,   0 zombie
Cpu(s):  6.3%us, 93.7%sy,  0.0%ni,  0.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   4055036k total,  1383356k used,  2671680k free,    20900k buffers
Swap:  4187132k total,        0k used,  4187132k free,   290640k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND             
 3329 user      20   0  558m 213m  39m S 61.2  5.4   0:35.00 cgminer             
 2875 root      20   0     0    0    0 S 12.0  0.0   0:11.21 kworker/0:2         
   56 root      20   0     0    0    0 R 11.1  0.0   0:09.72 kworker/0:1         
 2636 user      20   0  774m 153m  39m S  6.9  3.9   0:53.69 firefox-bin         
 1177 root      20   0  675m 111m  75m S  4.9  2.8   1:19.33 Xorg               
 1491 user      20   0  176m  14m 9472 S  1.7  0.4   0:03.14 xfwm4               
  310 root      20   0     0    0    0 S  0.5  0.0   0:00.68 usb-storage         
 1740 user      20   0  269m  17m  10m S  0.4  0.4   0:05.10 xfce4-terminal     

So either my CPU is too weak to handle 5 GPUs or cpu usage can be lower, but it does not depend on catalyst/amd sdk.

BTW I've tested catalyst 11.12 (11.11 gives problems installing) and 12.1 on xubuntu 11.10 64bit this morning with more or less same levels of CPU usage.

spiccioli
tenzor
Sr. Member
****
Offline Offline

Activity: 315
Merit: 250


View Profile
February 26, 2012, 01:41:58 PM
 #4337

I would love to see an expanded version of this that goes down to 100 (or lower) memclock using latest version of cgminer, latest drivers, and SDK 2.1.
Here is some tests
kano
Legendary
*
Offline Offline

Activity: 2506
Merit: 1043


Linux since 1997 RedHat 4


View Profile
February 26, 2012, 02:18:09 PM
 #4338

...
So either my CPU is too weak to handle 5 GPUs or cpu usage can be lower, but it does not depend on catalyst/amd sdk.

BTW I've tested catalyst 11.12 (11.11 gives problems installing) and 12.1 on xubuntu 11.10 64bit this morning with more or less same levels of CPU usage.

spiccioli
While it's running at 60% CPU ...
cat /proc/cpuinfo

Pool: https://kano.is Here on Bitcointalk: Forum BTC: 1KanoPb8cKYqNrswjaA8cRDk4FAS9eDMLU
FreeNode IRC: irc.freenode.net channel #kano.is Majority developer of the ckpool code
Help keep Bitcoin secure by mining on pools with full block verification on all blocks - and NO empty blocks!
Prayer
Member
**
Offline Offline

Activity: 69
Merit: 10


View Profile
February 26, 2012, 02:54:30 PM
 #4339

Not sure what's going on, but when I attempt to start cgminer, my display driver immediately crashes, and all I get from cgminer, is this:

Code:
[2012-02-26 09:29:29] LONGPOLL requested work restart, waiting on fresh work
[2012-02-26 09:29:29] Failed to tq_push in queue_request
[2012-02-26 09:29:39] LONGPOLL requested work restart, waiting on fresh work
[2012-02-26 09:29:39] Failed to tq_push in queue_request

A search on "tq_push in queue_request" turned up nothing useful.

When I exit cgminer, I get this:
Code:
[2012-02-26 09:45:59]
Summary of runtime statistics:

[2012-02-26 09:45:59] Started at [2012-02-26 09:12:24]
[2012-02-26 09:45:59] Pool: http://127.0.0.1:9332
[2012-02-26 09:45:59] Runtime: 0 hrs : 0 mins : 0 secs
[2012-02-26 09:45:59] Average hashrate: 672.8 Megahash/s
[2012-02-26 09:45:59] Solved blocks: 0
[2012-02-26 09:45:59] Queued work requests: 2254
[2012-02-26 09:45:59] Share submissions: 0
[2012-02-26 09:45:59] Accepted shares: 0
[2012-02-26 09:45:59] Rejected shares: 0
[2012-02-26 09:45:59] Hardware errors: 0
[2012-02-26 09:45:59] Efficiency (accepted / queued): 0%
[2012-02-26 09:45:59] Utility (accepted shares / min): 0.00/min

[2012-02-26 09:45:59] Discarded work due to new blocks: 204
[2012-02-26 09:45:59] Stale submissions discarded due to new blocks: 0
[2012-02-26 09:45:59] Unable to get work from server occasions: 95
[2012-02-26 09:45:59] Work items generated locally: 24762
[2012-02-26 09:45:59] Submitting work remotely delay occasions: 0
[2012-02-26 09:45:59] New blocks detected on network: 6

The things that concern me, is that the runtime at 0 hours, 0 mins, 0 secs, and the hashrate of 672.8.  If, after 33 minutes, the runtime is 0, how is there /any/ hashrate at all?  How is is 672, when pcolbm reports only 26.  Is cgminer really 25x faster?

Any suggestions on what to look at?

Asus M5A99X MB
AMD FX-4100
8GB RAM
Nvidia 8800GT, driver version 285.62
Windows 7 x64 SP1

I'm still using an old video card because it did what I needed it to do when I upgraded everything else.  I found Bitcoin just a couple weeks later.  I may upgrade to something else, I may not... haven't decided yet.

Thanks,

-Prayer

BTC/BEN:1PrayerRDDE2fohojZBQEwyjF2vsbz6eKw
jake262144
Full Member
***
Offline Offline

Activity: 210
Merit: 100


View Profile
February 26, 2012, 03:17:54 PM
 #4340

A search on "tq_push in queue_request" turned up nothing useful...
How about doing a search of queue_request inside cgminer source code?

Code:
static bool queue_request(struct thr_info *thr, bool needed)
{
(...)
applog(LOG_DEBUG, "Queueing getwork request to work thread");

/* send work request to workio thread */
if (unlikely(!tq_push(thr_info[work_thr_id].q, wc))) {
applog(LOG_ERR, "Failed to tq_push in queue_request");
workio_cmd_free(wc);
return false;
}
(...)
}

Some nVidia-specific bug? The hash rate is obviously bogus, it looks as if the kernel failed to perform some check and treated garbage as valid shares. Which kernel did you try?
Pages: « 1 ... 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 [217] 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 ... 847 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!