Bitcoin Forum
November 21, 2017, 08:12:54 PM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 ... 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 [246] 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 »
  Print  
Author Topic: [OS] nvOC easy-to-use Linux Nvidia Mining v0019-1.4  (Read 327141 times)
codereddew12
Jr. Member
*
Offline Offline

Activity: 33


View Profile
October 24, 2017, 11:38:58 AM
 #4901

So for those who are now reaching the login screen and cannot login even when you type in your password. SSH into your rig and run the following commands:

Code:
sudo apt-get purge nvidia*
sudo dpkg --configure -a
sudo shutdown -r now

Now everything's working back to normal. Not sure why it did that for me. Also, I don't know if the first commmand is necessary, it's just what I typed in initially so I included it.
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1511295174
Hero Member
*
Offline Offline

Posts: 1511295174

View Profile Personal Message (Offline)

Ignore
1511295174
Reply with quote  #2

1511295174
Report to moderator
1511295174
Hero Member
*
Offline Offline

Posts: 1511295174

View Profile Personal Message (Offline)

Ignore
1511295174
Reply with quote  #2

1511295174
Report to moderator
1511295174
Hero Member
*
Offline Offline

Posts: 1511295174

View Profile Personal Message (Offline)

Ignore
1511295174
Reply with quote  #2

1511295174
Report to moderator
Heguli97
Full Member
***
Offline Offline

Activity: 122


View Profile
October 24, 2017, 11:49:19 AM
 #4902

So for those who are now reaching the login screen and cannot login even when you type in your password. SSH into your rig and run the following commands:

Code:
sudo apt-get purge nvidia*
sudo dpkg --configure -a
sudo shutdown -r now

Now everything's working back to normal. Not sure why it did that for me. Also, I don't know if the first commmand is necessary, it's just what I typed in initially so I included it.

Too bad I don't have ssh configured/enabled.

Temporel
Full Member
***
Offline Offline

Activity: 154


View Profile
October 24, 2017, 11:55:48 AM
 #4903

I have the same issue. Both of my rigs running nvOC are down. It looks like some kind of update was done and drivers stopped working.

same here, that rig was up and running since August and it stopped an hour ago. I updated Nvidia drivers and its back online again.

That rig is still on v19 and is my last one on nvOC but after this event, Ill remove some cards and install Windows 10.

Temporel
Full Member
***
Offline Offline

Activity: 154


View Profile
October 24, 2017, 11:59:05 AM
 #4904

Nvidia driver updated today on one of my rigs
A reboot fixed my problem
The other one already had latest 384-90

run update / upgrade again

Code:
sudo apt update && sudo apt upgrade && sudo reboot

 I rebooted 3 times (v19) and still had the same problem. I had to update the Nvidia drivers to fix the issue.
FFI2013
Sr. Member
****
Offline Offline

Activity: 467


View Profile
October 24, 2017, 12:17:07 PM
 #4905

When I tried to unzip nvoc on win 7 I keep getting error that I don't have enough space when there 150gb empty but it unzips on my win 10 pro rigs without a issue

Nousplatform██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
|██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
██  ██  █
azsh07
Newbie
*
Offline Offline

Activity: 10


View Profile
October 24, 2017, 12:27:23 PM
 #4906

If possible, can we stop driver from auto update to prevent this event? For now, I just manage to get my rig working again by re-flashing image. But I believe this event will occur again since driver is auto update. I using P106 cards.


Doodkeen
Newbie
*
Offline Offline

Activity: 3


View Profile
October 24, 2017, 12:33:02 PM
 #4907

To prevent automatic updates in the future:

use your favorite editor, open /etc/apt/apt.conf.d/10periodic and change:

Code:
APT::Periodic::Update-Package-Lists "1";

To:

Code:
APT::Periodic::Update-Package-Lists "0";


and /etc/apt/apt.conf.d/20auto-upgrades
Code:
APT::Periodic::Update-Package-Lists "1";
APT::Periodic::Unattended-Upgrade "1";

to

Code:
APT::Periodic::Update-Package-Lists "0";
APT::Periodic::Unattended-Upgrade "0";


D

ps: Seriously, why was this ON?
azsh07
Newbie
*
Offline Offline

Activity: 10


View Profile
October 24, 2017, 12:45:00 PM
 #4908

To prevent automatic updates in the future:

use your favorite editor, open /etc/apt/apt.conf.d/10periodic and change:

Code:
APT::Periodic::Update-Package-Lists "1";

To:

Code:
APT::Periodic::Update-Package-Lists "0";


and /etc/apt/apt.conf.d/20auto-upgrades
Code:
APT::Periodic::Update-Package-Lists "1";
APT::Periodic::Unattended-Upgrade "1";

to

Code:
APT::Periodic::Update-Package-Lists "0";
APT::Periodic::Unattended-Upgrade "0";


D

ps: Seriously, why was this ON?

Thanks Doodkeen, but how to elevated access in nvoc? I using winscp but no luck. Not able to change using m1 credential.
Doodkeen
Newbie
*
Offline Offline

Activity: 3


View Profile
October 24, 2017, 12:53:38 PM
 #4909

Just use your editor with sudo after you are logged in by ssh. 

Code:
sudo vim.tiny /etc/apt/apt.conf.d/20auto-upgrades
Heguli97
Full Member
***
Offline Offline

Activity: 122


View Profile
October 24, 2017, 12:58:47 PM
 #4910

Nvidia driver updated today on one of my rigs
A reboot fixed my problem
The other one already had latest 384-90

run update / upgrade again

Code:
sudo apt update && sudo apt upgrade && sudo reboot

Thank you, this worked for me Cheesy. If you're using a keyboard press control + alt + f1 to get to terminal and first input login credentials(login: m1 password: miner1 by default)

das0212
Newbie
*
Offline Offline

Activity: 3


View Profile
October 24, 2017, 01:00:04 PM
 #4911

I managed to grab an image: https://i.imgur.com/3of2yT9.jpg

This is happening on both my rigs

Thats not a problem
Ubuntu is checking drive, wait and it will boot

Same thing happend for me...and I waited for 1 hour still same screen..what to do
Doodkeen
Newbie
*
Offline Offline

Activity: 3


View Profile
October 24, 2017, 01:03:06 PM
 #4912


Thanks Doodkeen, but how to elevated access in nvoc? I using winscp but no luck. Not able to change using m1 credential.

If you want to connect with winscp there is a good article about this situation but i would use ssh

https://blog.jamesbayley.com/2014/01/28/how-to-connect-as-root-using-winscp/
Temporel
Full Member
***
Offline Offline

Activity: 154


View Profile
October 24, 2017, 01:03:21 PM
 #4913



ps: Seriously, why was this ON?

Ill have to check my setup later but Im surprise it was ON.

Ill scan the distro for rootkit later too just to be sure.
azsh07
Newbie
*
Offline Offline

Activity: 10


View Profile
October 24, 2017, 01:03:54 PM
 #4914

Just use your editor with sudo after you are logged in by ssh. 

Code:
sudo vim.tiny /etc/apt/apt.conf.d/20auto-upgrades

Thanks Doodkeen, is done now.  Grin Grin
jmumich
Full Member
***
Offline Offline

Activity: 203


View Profile
October 24, 2017, 01:14:46 PM
 #4915

Wow that was an interesting morning. Thanks to everyone that identified the problem and posted a solution so quickly.

Oddly enough, a couple of rigs kept running - I can't think of anything about them that was different from the others. Though they also had the update and upgrade flags set to 1.

For me, just running 

sudo dpkg --configure -a

And then rebooting did the trick.
jmumich
Full Member
***
Offline Offline

Activity: 203


View Profile
October 24, 2017, 01:22:06 PM
 #4916

So for those who are now reaching the login screen and cannot login even when you type in your password. SSH into your rig and run the following commands:

Code:
sudo apt-get purge nvidia*
sudo dpkg --configure -a
sudo shutdown -r now

Now everything's working back to normal. Not sure why it did that for me. Also, I don't know if the first commmand is necessary, it's just what I typed in initially so I included it.

Thanks so much for this. I don't think the first command is necessary (edit: just to get your rigs running - see below, it may be for stability) - just the second got everything running for me. When I ran the first command, I then had to do:
Code:
sudo apt-get install nvidia-385

So to get my remote-rigs running again I just had to:

Code:
sudo dpkg --configure -a
sudo reboot
ComputerGenie
Sr. Member
****
Offline Offline

Activity: 462


Retired IRCX God


View Profile
October 24, 2017, 01:27:02 PM
 #4917

Not all best practices are "necessary" in terms of what is minimally required; that being said, that particular way (including purge) aids in ensuring stability.

If you have to ask why, you wouldn`t understand my answer.
jmumich
Full Member
***
Offline Offline

Activity: 203


View Profile
October 24, 2017, 01:32:31 PM
 #4918

Not all best practices are "necessary" in terms of what is minimally required; that being said, that particular way (including purge) aids in ensuring stability.

Thanks, and fair point - I just didn't have much time and needed to get things going. I also left most of my update/upgrade flags at 1 - something I have to fix later. So I guess skipping the purge part is for folks like me that had just a couple minutes to get their rigs back up.

I'll follow your advice and purge and reinstall later on when I have the time  Smiley
VoskCoin
Full Member
***
Offline Offline

Activity: 224


YouTube.com/VoskCoin


View Profile WWW
October 24, 2017, 01:53:41 PM
 #4919

This is so frustrating, nvOC17 was rock solid and nvOC19 has been a headache like 15 16 18 were

nvOC_17 DL
http://www.mediafire.com/file/oi84ue7e6z9epn9/nvOC_v0017.zip


Can anyone help me add a couple coins to 17 and implement the newer auto fan controller?

Check out my Crypto YouTube channel
https://www.youtube.com/VoskCoin
If you enjoy my content click Subscribe
DJ ACK
Newbie
*
Offline Offline

Activity: 11


View Profile
October 24, 2017, 02:05:13 PM
 #4920

Any idea why all rigs crashed last night.  v0018 and v0019 rigs all died and won't boot.  v0018 rigs hang trying to perform cleaning functions.  v0019 rigs ask for a password. v19-1.3 rigs are all running fine.  Rigs are in three completely different geographic locations.
Pages: « 1 ... 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 [246] 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!