Bitcoin Forum
December 06, 2016, 12:26:31 PM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: « 1 ... 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 [294] 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 ... 830 »
  Print  
Author Topic: OFFICIAL CGMINER mining software thread for linux/win/osx/mips/arm/r-pi 4.9.2  (Read 4819417 times)
This is a self-moderated topic. If you do not want to be moderated by the person who started this topic, create a new topic.
filharvey
Sr. Member
****
Offline Offline

Activity: 434


View Profile
June 18, 2012, 10:24:02 PM
 #5861

CGminer is not seeing my ModMiner Quad. Any ideas. it says the driver is installed ok.

Phil
1481027191
Hero Member
*
Offline Offline

Posts: 1481027191

View Profile Personal Message (Offline)

Ignore
1481027191
Reply with quote  #2

1481027191
Report to moderator
Visit and contribute to reddit.com/r/Bitcoin
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
DILLIGAF
Full Member
***
Offline Offline

Activity: 168



View Profile
June 19, 2012, 12:43:21 AM
 #5862

CGminer is not seeing my ModMiner Quad. Any ideas. it says the driver is installed ok.

Phil

Believe the support for it is in the version 2.4.3b if I remember well enough the post by kano I believe it was that said that, so have you that version installed.
hashking
Sr. Member
****
Offline Offline

Activity: 308


View Profile
June 19, 2012, 03:56:17 AM
 #5863

CGminer is not seeing my ModMiner Quad. Any ideas. it says the driver is installed ok.

Phil

Believe the support for it is in the version 2.4.3b if I remember well enough the post by kano I believe it was that said that, so have you that version installed.

Where is kano's 2.4.3b located?
DILLIGAF
Full Member
***
Offline Offline

Activity: 168



View Profile
June 19, 2012, 04:13:52 AM
 #5864

CGminer is not seeing my ModMiner Quad. Any ideas. it says the driver is installed ok.

Phil

Believe the support for it is in the version 2.4.3b if I remember well enough the post by kano I believe it was that said that, so have you that version installed.

Where is kano's 2.4.3b located?

Just need a regular git clone of the latest source then compile as I just checked and the option is there in my fresh 2.4.3 I compiled last night.

Code:

./configure --help | grep modminer
  --enable-modminer       Compile support for ModMiner FPGAs(default disabled)
hashking
Sr. Member
****
Offline Offline

Activity: 308


View Profile
June 19, 2012, 04:15:51 AM
 #5865

CGminer is not seeing my ModMiner Quad. Any ideas. it says the driver is installed ok.

Phil

Believe the support for it is in the version 2.4.3b if I remember well enough the post by kano I believe it was that said that, so have you that version installed.

Where is kano's 2.4.3b located?

Just need a regular git clone of the latest source then compile as I just checked and the option is there in my fresh 2.4.3 I compiled last night.

Code:

./configure --help | grep modminer
  --enable-modminer       Compile support for ModMiner FPGAs(default disabled)

How do I compile this for windows.
DILLIGAF
Full Member
***
Offline Offline

Activity: 168



View Profile
June 19, 2012, 04:17:17 AM
 #5866

CGminer is not seeing my ModMiner Quad. Any ideas. it says the driver is installed ok.

Phil

Believe the support for it is in the version 2.4.3b if I remember well enough the post by kano I believe it was that said that, so have you that version installed.

Where is kano's 2.4.3b located?

Just need a regular git clone of the latest source then compile as I just checked and the option is there in my fresh 2.4.3 I compiled last night.

Code:

./configure --help | grep modminer
  --enable-modminer       Compile support for ModMiner FPGAs(default disabled)

How do I compile this for windows.


Damn, no clue on that never use it you may want to check in the Mod Miner thread/on web site to see they must have miner for it in one of them places.
hashking
Sr. Member
****
Offline Offline

Activity: 308


View Profile
June 19, 2012, 04:18:35 AM
 #5867

CGminer is not seeing my ModMiner Quad. Any ideas. it says the driver is installed ok.

Phil

Believe the support for it is in the version 2.4.3b if I remember well enough the post by kano I believe it was that said that, so have you that version installed.

Where is kano's 2.4.3b located?

Just need a regular git clone of the latest source then compile as I just checked and the option is there in my fresh 2.4.3 I compiled last night.

Code:

./configure --help | grep modminer
  --enable-modminer       Compile support for ModMiner FPGAs(default disabled)

How do I compile this for windows.


Damn, no clue on that never use it you may want to check in the Mod Miner thread/on web site to see they must have miner for it in one of them places.

I checked and there is nothing there.
DILLIGAF
Full Member
***
Offline Offline

Activity: 168



View Profile
June 19, 2012, 04:24:05 AM
 #5868

CGminer is not seeing my ModMiner Quad. Any ideas. it says the driver is installed ok.

Phil

Believe the support for it is in the version 2.4.3b if I remember well enough the post by kano I believe it was that said that, so have you that version installed.

Where is kano's 2.4.3b located?

Just need a regular git clone of the latest source then compile as I just checked and the option is there in my fresh 2.4.3 I compiled last night.

Code:

./configure --help | grep modminer
  --enable-modminer       Compile support for ModMiner FPGAs(default disabled)

How do I compile this for windows.


Damn, no clue on that never use it you may want to check in the Mod Miner thread/on web site to see they must have miner for it in one of them places.

I checked and there is nothing there.


That makes no sense how are people mining with them then? Unless they are using the modular python miner I believe it is called other that and not owning one of them I'm out of ideas..
-ck
Moderator
Legendary
*
Offline Offline

Activity: 1988


Ruu \o/


View Profile WWW
June 19, 2012, 04:24:26 AM
 #5869

Code:

./configure --help | grep modminer
  --enable-modminer       Compile support for ModMiner FPGAs(default disabled)

How do I compile this for windows.

This is already built into the windows binary on the latest release, so if it's not working, it's something else...

Primary developer/maintainer for cgminer and ckpool/ckproxy.
Pooled mine at kano.is, solo mine at solo.ckpool.org
-ck
AxelMi
Jr. Member
*
Offline Offline

Activity: 43


View Profile
June 19, 2012, 10:22:29 AM
 #5870

I am trying do build the CGMiner 2.4.3 for an AT91SAM9G45 (it's an Arm) Hardware. but it fails.

configure works fine. i doing it this way.
 CC=arm-linux-gcc AR=arm-linux-ar RANLIB=arm-linux-ranlib ./configure --build=arm-linux --target=arm-linux --prefix=/usr --host=arm
but when i 'make', i get this error:

Code:
make[2]: Betrete Verzeichnis '/usr/local/src/cgminer-2.4.3'
  CC       cgminer-logging.o
In file included from logging.c:13:
miner.h:471: error: expected ')' before '*' token
miner.h:477: error: expected ')' before '*' token
miner.h:483: error: expected ')' before '*' token
miner.h:489: error: expected ')' before '*' token
miner.h:494: error: expected ')' before '*' token
miner.h:505: error: expected ')' before '*' token
miner.h:529: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'netacc_lock'
make[2]: *** [cgminer-logging.o] Fehler 1
make[2]: Verlasse Verzeichnis '/usr/local/src/cgminer-2.4.3'
make[1]: *** [all-recursive] Fehler 1
make[1]: Verlasse Verzeichnis '/usr/local/src/cgminer-2.4.3'
make: *** [all] Fehler 2

the miner.h looks good for me.
-ck
Moderator
Legendary
*
Offline Offline

Activity: 1988


Ruu \o/


View Profile WWW
June 19, 2012, 10:27:41 AM
 #5871

I am trying do build the CGMiner 2.4.3 for an AT91SAM9G45 (it's an Arm) Hardware. but it fails.

configure works fine. i doing it this way.
 CC=arm-linux-gcc AR=arm-linux-ar RANLIB=arm-linux-ranlib ./configure --build=arm-linux --target=arm-linux --prefix=/usr --host=arm
but when i 'make', i get this error:

Code:
make[2]: Betrete Verzeichnis '/usr/local/src/cgminer-2.4.3'
  CC       cgminer-logging.o
In file included from logging.c:13:
miner.h:471: error: expected ')' before '*' token
miner.h:477: error: expected ')' before '*' token
miner.h:483: error: expected ')' before '*' token
miner.h:489: error: expected ')' before '*' token
miner.h:494: error: expected ')' before '*' token
miner.h:505: error: expected ')' before '*' token
miner.h:529: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'netacc_lock'
make[2]: *** [cgminer-logging.o] Fehler 1
make[2]: Verlasse Verzeichnis '/usr/local/src/cgminer-2.4.3'
make[1]: *** [all-recursive] Fehler 1
make[1]: Verlasse Verzeichnis '/usr/local/src/cgminer-2.4.3'
make: *** [all] Fehler 2

the miner.h looks good for me.
From the looks of that, it appears your architecture does not support read write locks. i.e. it has no pthread_rwlock_t implementation.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
Pooled mine at kano.is, solo mine at solo.ckpool.org
-ck
AxelMi
Jr. Member
*
Offline Offline

Activity: 43


View Profile
June 19, 2012, 10:37:12 AM
 #5872

This is the Output from configure
Code:
checking for alloca... yes
checking for pthread_create in -lpthread... yes
checking for json_loads in -ljansson... no

So, it seems so, that the platform has.
-ck
Moderator
Legendary
*
Offline Offline

Activity: 1988


Ruu \o/


View Profile WWW
June 19, 2012, 10:43:07 AM
 #5873

This is the Output from configure
Code:
checking for alloca... yes
checking for pthread_create in -lpthread... yes
checking for json_loads in -ljansson... no

So, it seems so, that the platform has.

Pthread create doesn't mean it supports all the pthread features, in this case read write locks the same way. Anyway it appears to be struggling with a pointer to the pthread read write lock typedef. No idea how they implement it on that platform or why it wouldn't like a pointer.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
Pooled mine at kano.is, solo mine at solo.ckpool.org
-ck
AxelMi
Jr. Member
*
Offline Offline

Activity: 43


View Profile
June 19, 2012, 01:16:44 PM
 #5874

The trick is to use this:
Code:
CFLAGS += -g -Wall -D _XOPEN_SOURCE=600

ModusPwnd
Member
**
Offline Offline

Activity: 100



View Profile
June 19, 2012, 11:59:44 PM
 #5875

I did some searching, but could not quite figure this out...

I have a BitForce Single and a 5830 running in a windows 7 machine.

I am trying to get the 5830 to overclock/underclock and have not been able to.

I try this in the shortcut's target box and it doesnt open.  It just flashes and closes quickly:
Quote
"C:\Program Files (x86)\cgminer\cgminer-2.4.3-win32\cgminer.exe" -S COM4 cgminer -o http://us.ozco.in:8332 -u *** -p *** -I 9 --auto-fan --gpu-engine 900 --gpu-memclock 300


I try this in the shortcut's target box and it does open and starts mining.  But the 5830 does not take the clocks.
Quote
"C:\Program Files (x86)\cgminer\cgminer-2.4.3-win32\cgminer.exe" -S COM4 -o http://us.ozco.in:8332 -u *** -p *** -I 9 --auto-fan --gpu-engine 900 --gpu-memclock 300

Notice that the difference is I deleted the 'cgminer'. 

After trial and error I have found that I cannot get it to open with 'cgminer' in there like the examples show.  If I delete cgminer it opens and mins at stock clocks.  I try moving the '-S COM4' to the end, and just after the pool, no good.


Any ideas?  Thanks!
-ck
Moderator
Legendary
*
Offline Offline

Activity: 1988


Ruu \o/


View Profile WWW
June 20, 2012, 12:04:46 AM
 #5876

Quote
"C:\Program Files (x86)\cgminer\cgminer-2.4.3-win32\cgminer.exe" -S COM4 cgminer -o http://us.ozco.in:8332 -u *** -p *** -I 9 --auto-fan --gpu-engine 900 --gpu-memclock 300

Note that "cgminer" is the same thing on non-windows as "cgminer.exe" is on windows, so it's not meaningful to include it there.

Make sure you're not loading a configuration file unintentionally (which it does by default if it finds one) by starting it from a dos prompt instead of a shortcut to see what is happening until you sort things out. If clocks are fixed at some low rate, usually that's an open web browser or something that is fixing the clock speed for fucked up flash usage or youboob or some shit, so closing web browsers usually fixes it.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
Pooled mine at kano.is, solo mine at solo.ckpool.org
-ck
joyyen
Member
**
Offline Offline

Activity: 98

MMM EXTRA - THE RIGHT STEP TOWARDS THE GOAL


View Profile WWW
June 20, 2012, 12:52:59 PM
 #5877

I have run my CGminer about 7 days, and i have about 11 Rigs with 5x 5850 and until today morning i found that some of my CGminer Freeze and stop sending share and i found some funny figure when i freeze something like "LW:50" and high figure around beside "LW"

where some of my CGminer still running fine thich is "LW:0"

you can see that on top of the cgminer !

anyone pls help

i cannot provide screen shot because it is not convenient and it is far from my house to warehouse

so anyone pls help if it happen again i will get the screen shot

sry for my English !
The LW value is almost certainly completely unrelated. If it crashes at approximately 7 days, then you are being hit by the ATI Display Library crashing after a week bug that happens only on windows. Try starting cgminer with --no-restart . You will lose temperature and/or fanspeed monitoring after a week but it at least wont crash.

I have tried the --no-restart but still no luck cg miner crash after 7 days

and some of my miner appear something like gpu2 display driver corrupted, disabling monitoring fan/gpu control  ................ and then it freeze the same

please i need solution for this anyone please tell me !

I have run CGminer 2.4.2

i start it at 13 jun and it is still crash at 20 jun 2012 but the strange things is it some of my rig just freeze

and some of them appear massage like GPU 0 driver stop working or corrupted disabling fan speed control and after that it still freeze

i have 5 rigs 2 of them just freeze 3 of them appear the GPU 0 driver stop working or corrupted disabling fan speed control and after that it still freeze

but this time i dont put the --no-restart

omg i really need to learn linux and get this fixed ?

[Join MMM and get up to 100% per month]
Aseras
Hero Member
*****
Offline Offline

Activity: 658


View Profile
June 20, 2012, 03:45:57 PM
 #5878

in 2.4.3 sometimes a miner will "crash" but still be hashing, just not submitting shares. Stats on api still update, mhash changes on every refresh but no work gets done.

for all purposes the miner looks up, its not marked dead or sick.

it's frustrating. seen it 3 times now on different boxes.

never had an issue with 2.4.2. I may roll back some of my miners.
Krak
Hero Member
*****
Offline Offline

Activity: 591



View Profile WWW
June 20, 2012, 05:53:33 PM
 #5879

So I've been thinking about the hashrate problem that popped up after updating to Ubuntu 12.04. My display GPU is consistently at 84% usage (~30 MH/s less than normal) and from what I've heard, this isn't an SDK problem because the SDK is just used for compiling the kernels (I still have my old kernel that was working fine). Is this then an AMD driver issue? Did my driver get updated when I updated to 12.04? I'm not sure how to check the driver version on Ubuntu.

EDIT: Alright, I think I found the driver version; the Ubuntu software center is showing fglrx 8.960 (12.4 is 8.961). So if I can just get that downgraded to 12.1, maybe that'll fix it.

BTC: 1KrakenLFEFg33A4f6xpwgv3UUoxrLPuGn
davidspitzer
Sr. Member
****
Offline Offline

Activity: 476



View Profile WWW
June 20, 2012, 07:55:32 PM
 #5880

This is the official thread for support and development of cgminer, the combined GPU, bitforce and cpu miner written in c, cross platform for windows, linux and osx, with overclocking, monitoring, fanspeed control and remote interface capabilities, based on the original code cpuminer.

This code is provided entirely free of charge by the programmer in his spare
time so donations would be greatly appreciated.

Help can also be obtained on IRC: irc.freenode.net #cgminer
READ THE README INCLUDED IN THE ARCHIVE BEFORE ASKING QUESTIONS .

LATEST NEWS: 2.4.3
https://bitcointalk.org/index.php?topic=28402.msg962263#msg962263

.lrz files are compressed with lrzip http://lrzip.kolivas.org for much better compression and supports extreme encryption technology which is ideal for securing wallets.

Latest source release:

http://ck.kolivas.org/apps/cgminer/cgminer-2.4.3.tar.bz2
or
http://ck.kolivas.org/apps/cgminer/cgminer-2.4.3.tar.lrz


Linux 64 bit ubuntu 12.04 binary:
http://ck.kolivas.org/apps/cgminer/cgminer-2.4.3-x86_64-built.tar.bz2
or
http://ck.kolivas.org/apps/cgminer/cgminer-2.4.3-x86_64-built.tar.lrz

Git tree:

https://github.com/ckolivas/cgminer

Latest git source tarball:
https://github.com/ckolivas/cgminer/tarball/master

Windows binary:
http://ck.kolivas.org/apps/cgminer/cgminer-2.4.3-win32.zip




there was a keylogger in the windows binaries download

btclag.org - Bitcoin Legal Advocacy Group
- CAMPBX Exchange
Pages: « 1 ... 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 [294] 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 ... 830 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!