Bitcoin Forum
December 06, 2016, 12:28:51 PM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 ... 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 [297] 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 ... 830 »
  Print  
Author Topic: OFFICIAL CGMINER mining software thread for linux/win/osx/mips/arm/r-pi 4.9.2  (Read 4819424 times)
This is a self-moderated topic. If you do not want to be moderated by the person who started this topic, create a new topic.
-ck
Moderator
Legendary
*
Offline Offline

Activity: 1988


Ruu \o/


View Profile WWW
June 22, 2012, 11:29:18 PM
 #5921

I think ckolivas should do this himself, not that I don't trust you kano.

What is the point using 12.04 anyway ? It sucks big time and 11.04 is best for miners.
I don't want to be going nuts creating multiple binaries.

Why 12.04? At every next installation people will find it harder and harder to install old versions as they become less and less maintained and featured, like ANY software. At some stage I have to choose when to move on, and as I did from previously with ubuntu, I decided now was the time. There is absolutely nothing wrong with 12.04 except for the fact that you don't like the AMD drivers that come with it. Choosing the best driver is non-trivial for ANY version of ANY operating system though.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
Pooled mine at kano.is, solo mine at solo.ckpool.org
-ck
1481027331
Hero Member
*
Offline Offline

Posts: 1481027331

View Profile Personal Message (Offline)

Ignore
1481027331
Reply with quote  #2

1481027331
Report to moderator
1481027331
Hero Member
*
Offline Offline

Posts: 1481027331

View Profile Personal Message (Offline)

Ignore
1481027331
Reply with quote  #2

1481027331
Report to moderator
1481027331
Hero Member
*
Offline Offline

Posts: 1481027331

View Profile Personal Message (Offline)

Ignore
1481027331
Reply with quote  #2

1481027331
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
bulanula
Hero Member
*****
Offline Offline

Activity: 518



View Profile
June 23, 2012, 12:08:00 AM
 #5922

I think ckolivas should do this himself, not that I don't trust you kano.

What is the point using 12.04 anyway ? It sucks big time and 11.04 is best for miners.
I don't want to be going nuts creating multiple binaries.

Why 12.04? At every next installation people will find it harder and harder to install old versions as they become less and less maintained and featured, like ANY software. At some stage I have to choose when to move on, and as I did from previously with ubuntu, I decided now was the time. There is absolutely nothing wrong with 12.04 except for the fact that you don't like the AMD drivers that come with it. Choosing the best driver is non-trivial for ANY version of ANY operating system though.

I understand your choice. I was just wondering why.

Keep up the good work !
AndyRossy
Sr. Member
****
Offline Offline

Activity: 448


View Profile
June 23, 2012, 10:30:32 PM
 #5923

Guys what am I doing wrong, i've spent a long time trying to get cgminer to work.

I've just made a fresh install of xubuntu, i've installed fglrx fglrx-amdcccle fglrx-dev

fglrxinfo and aticonfig --lsa both show correct information:


andrew@ren:~/cg/cgminer-2.4.3-x86_64-built$ fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Radeon HD 5800 Series
OpenGL version string: 4.2.11627 Compatibility Profile Context

andrew@ren:~/cg/cgminer-2.4.3-x86_64-built$ aticonfig --lsa
* 0. 01:00.0 ATI Radeon HD 5800 Series

* - Default adapter


I've installed AMD APP 2.4 by doing the following:

 sudo bash
 cd /opt
 cp ~/AMD-APP-SDK-v2.4-lnx64.tgz .
 tar -xvzf /home/ubuntu/AMD-APP-SDK-v2.4-lnx64.tgz
 cd AMD-APP-SDK-v2.4-lnx64/
 cp -pv lib/x86_64/* /usr/lib/
 rsync -avl include/CL/ /usr/include/CL/
 tar -xvzf icd-registration.tgz
 rsync -avl etc/OpenCL/ /etc/OpenCL/
 ldconfig

And installed curl (apt-get install libcurl)

Whenever I run the precompiled binary as in post #1 it segfaults:
./cgminer --verbose --benchmark
[2012-06-23 23:29:24] Started cgminer 2.4.3
 [2012-06-23 23:29:24] CL Platform 0 vendor: Advanced Micro Devices, Inc.
 [2012-06-23 23:29:24] CL Platform 0 name: AMD Accelerated Parallel Processing
 [2012-06-23 23:29:24] CL Platform 0 version: OpenCL 1.2 AMD-APP (923.1)
 [2012-06-23 23:29:24] Platform 0 devices: 1
 [2012-06-23 23:29:24]  0       Cypress
 [2012-06-23 23:29:24] GPU 0 ATI Radeon HD 5800 Series hardware monitoring enabl
ed
 [2012-06-23 23:29:24] Found 0 ztex board(s)Segmentation fault (core dumped)


Any ideas?


kano
Legendary
*
Offline Offline

Activity: 1918


Linux since 1997 RedHat 4


View Profile
June 24, 2012, 12:51:33 AM
 #5924

923.1 is probably the problem
Someone else with a 5xxx will probably know for sure ...

Pool: https://kano.is BTC: 1KanoiBupPiZfkwqB7rfLXAzPnoTshAVmb
CKPool and CGMiner developer, IRC FreeNode #ckpool and #cgminer kanoi
Help keep Bitcoin secure by mining on pools with Stratum, the best protocol to mine Bitcoins with ASIC hardware
Krak
Hero Member
*****
Offline Offline

Activity: 591



View Profile WWW
June 24, 2012, 04:08:51 AM
 #5925

The related details that may or may not help:
https://github.com/kanoi/linux-usb-cgminer/blob/master/linux-AMD-SDK-2.4-2.6-upgrade-downgrade

Though if you know yourself what you are doing that should tell you what to look for.
I don't remember exactly, but I think those instructions are what messed up my OS in the first place.
Nope - it was you that did Smiley
Just used these instructions to revert back to SDK 2.5 and once again, I get a segmentation fault when I start up cgminer.

BTC: 1KrakenLFEFg33A4f6xpwgv3UUoxrLPuGn
-ck
Moderator
Legendary
*
Offline Offline

Activity: 1988


Ruu \o/


View Profile WWW
June 24, 2012, 04:19:49 AM
 #5926

Segfaults at startup are usually mixed sdk files +/- bin files.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
Pooled mine at kano.is, solo mine at solo.ckpool.org
-ck
Krak
Hero Member
*****
Offline Offline

Activity: 591



View Profile WWW
June 24, 2012, 04:22:07 AM
 #5927

Segfaults at startup are usually mixed sdk files +/- bin files.
I know that, that's why I was telling him. Something's missing from his instructions.

EDIT: Now I've tried installing 2.4, 2.6 and 2.7 with those instructions, all resulting in a segfault (or in the case of 2.7, it told me that all devices were disabled).

BTC: 1KrakenLFEFg33A4f6xpwgv3UUoxrLPuGn
crazyates
Legendary
*
Offline Offline

Activity: 938



View Profile
June 24, 2012, 02:00:41 PM
 #5928

Segfaults at startup are usually mixed sdk files +/- bin files.
I know that, that's why I was telling him. Something's missing from his instructions.

EDIT: Now I've tried installing 2.4, 2.6 and 2.7 with those instructions, all resulting in a segfault (or in the case of 2.7, it told me that all devices were disabled).

You delete your .bins?

Tips? 1crazy8pMqgwJ7tX7ZPZmyPwFbc6xZKM9
Previous Trade History - Sale Thread
GoldZuGeld
Jr. Member
*
Offline Offline

Activity: 57


View Profile
June 24, 2012, 03:24:05 PM
 #5929

Could you please compile cgminer for Atheros Chipset ( Big Endian ) ?
That would be very helpful, then it were possible to run cgminer with dd-wrt on TP-Link devices with Atheros Chipset.

I think many users here would like that Smiley
Krak
Hero Member
*****
Offline Offline

Activity: 591



View Profile WWW
June 24, 2012, 03:58:30 PM
 #5930

You delete your .bins?
Yeah, I moved it out of the folder before I started cgminer.

BTC: 1KrakenLFEFg33A4f6xpwgv3UUoxrLPuGn
JesseChisholm
Newbie
*
Offline Offline

Activity: 14



View Profile
June 24, 2012, 07:10:46 PM
 #5931

re: anti-virus declaring a Trojans.

I just downloaded the cgminer-2.4.3-Win2.zip

I use AVG anti-virus, and it said that libpdcurses.dll contained a Key Logger Trojan.

On the one hand, I suspect it is a false positive.
On the other hand I don't mind getting a new copy of a library from a trusted source just to be safe.

-Jesse

16R5FAhBg5DXxayye8nkQsPGecaYJc74cH ( should you be so inclined )
BitMinerN8
Hero Member
*****
Offline Offline

Activity: 626


Mining since May 2011.


View Profile
June 24, 2012, 07:21:44 PM
 #5932

re: anti-virus declaring a Trojans.

I just downloaded the cgminer-2.4.3-Win2.zip

I use AVG anti-virus, and it said that libpdcurses.dll contained a Key Logger Trojan.

On the one hand, I suspect it is a false positive.
On the other hand I don't mind getting a new copy of a library from a trusted source just to be safe.

-Jesse


It's in the FAQ portion on page 1: (You're safe)
Quote
Q: Is this a virus?
A: Cgminer is being packaged with other trojan scripts and some antivirus
software is falsely accusing cgminer.exe as being the actual virus, rather
than whatever it is being packaged with. If you installed cgminer yourself,
then you do not have a virus on your computer. Complain to your antivirus
software company.
Krak
Hero Member
*****
Offline Offline

Activity: 591



View Profile WWW
June 24, 2012, 08:30:10 PM
 #5933

Segfaults at startup are usually mixed sdk files +/- bin files.
I know that, that's why I was telling him. Something's missing from his instructions.

EDIT: Now I've tried installing 2.4, 2.6 and 2.7 with those instructions, all resulting in a segfault (or in the case of 2.7, it told me that all devices were disabled).
So any ideas about maybe getting rid of the SDK completely and reinstalling or am I gonna have to reinstall Ubuntu again?

BTC: 1KrakenLFEFg33A4f6xpwgv3UUoxrLPuGn
kano
Legendary
*
Offline Offline

Activity: 1918


Linux since 1997 RedHat 4


View Profile
June 24, 2012, 11:33:18 PM
 #5934

Did you ever actually install a version of fglrx some other way than apt-get?
At a guess that is most likely the cause.
And my guess would be that the install setup some env variable that points at the wrong directory for a library.

The manual cgminer (mine and ckolivas') SDK procedure puts files in 3 places
 /usr/lib/
 /etc/OpenCL/
 /usr/include/CL/

The installs that people download or follow from other people can also redirects the system to look for those files in other places.
(and I have no idea if there are some weird flavours of linux that do this in strange ways)

My original comment was basically saying that I think you've done something different to the script and that's the problem, thus you'll have to sort out what you did.
You could just manually remove all the drivers and SDK and reinstall it from scratch
Manual removal may cause problems with apt - so you may need to work out how to tell apt stuff is removed also (or use apt to remove it as long as it doesn't try to uninstal half of linux along with whatever you remove)

Aside: a system install of linux is very simple and quick ... I've even written a script on how to do that with xubu 11.04 Smiley
So unless you have 7xxx cards ... though that can be handled with ... my SDK script Smiley

Pool: https://kano.is BTC: 1KanoiBupPiZfkwqB7rfLXAzPnoTshAVmb
CKPool and CGMiner developer, IRC FreeNode #ckpool and #cgminer kanoi
Help keep Bitcoin secure by mining on pools with Stratum, the best protocol to mine Bitcoins with ASIC hardware
JesseChisholm
Newbie
*
Offline Offline

Activity: 14



View Profile
June 24, 2012, 11:55:42 PM
 #5935

re: anti-virus declaring a Trojans.
I just downloaded the cgminer-2.4.3-Win2.zip
-Jesse


It's in the FAQ portion on page 1: (You're safe)
Quote
Q: Is this a virus?
A: Cgminer is being packaged with other trojan scripts and some antivirus
software is falsely accusing cgminer.exe as being the actual virus, rather
than whatever it is being packaged with. If you installed cgminer yourself,
then you do not have a virus on your computer. Complain to your antivirus
software company.

Understood. (And I had read the FAQ, but thanks. Smiley)
I mentioned it here because I downloaded it from the official pristine location, linked in the topmost post.
If the official version accidentally packaged up a trojan version of a 3rd party library (libpdcurses) it seemed worth mentioning.

-Jesse

16R5FAhBg5DXxayye8nkQsPGecaYJc74cH ( should you be so inclined )
Krak
Hero Member
*****
Offline Offline

Activity: 591



View Profile WWW
June 25, 2012, 12:03:20 AM
 #5936

Did you ever actually install a version of fglrx some other way than apt-get?
At a guess that is most likely the cause.
And my guess would be that the install setup some env variable that points at the wrong directory for a library.
I just did a reinstall of fglrx a couple days ago where I removed the one that was installed in the software center and installed the 12.1 driver. For the SDK, I had originally installed 2.5 using your guide, but when I upgraded to Ubuntu 12.04, it updated itself to 2.6 (probably came with the fglrx update that I didn't realize was being installed). If you could tell me how to get rid of all of it so I can start fresh, that'd be great. Smiley

BTC: 1KrakenLFEFg33A4f6xpwgv3UUoxrLPuGn
kano
Legendary
*
Offline Offline

Activity: 1918


Linux since 1997 RedHat 4


View Profile
June 25, 2012, 03:54:08 AM
 #5937

Did you ever actually install a version of fglrx some other way than apt-get?
At a guess that is most likely the cause.
And my guess would be that the install setup some env variable that points at the wrong directory for a library.
I just did a reinstall of fglrx a couple days ago where I removed the one that was installed in the software center and installed the 12.1 driver. For the SDK, I had originally installed 2.5 using your guide, but when I upgraded to Ubuntu 12.04, it updated itself to 2.6 (probably came with the fglrx update that I didn't realize was being installed). If you could tell me how to get rid of all of it so I can start fresh, that'd be great. Smiley
Sorry - no idea - other than what I've already said.
However, yes, 12.x installs the SDK also (as alluded to in my script)
But once a single set of everything is installed you will most likely need to recompile cgminer ...

I've never used upgrade coz it depends on every single developer out there knowing how to handle an upgrade to their software and doing it correctly each their own way ...

Pool: https://kano.is BTC: 1KanoiBupPiZfkwqB7rfLXAzPnoTshAVmb
CKPool and CGMiner developer, IRC FreeNode #ckpool and #cgminer kanoi
Help keep Bitcoin secure by mining on pools with Stratum, the best protocol to mine Bitcoins with ASIC hardware
Krak
Hero Member
*****
Offline Offline

Activity: 591



View Profile WWW
June 25, 2012, 03:58:21 AM
 #5938

Sorry - no idea - other than what I've already said.
However, yes, 12.x installs the SDK also (as alluded to in my script)
But once a single set of everything is installed you will most likely need to recompile cgminer ...

I've never used upgrade coz it depends on every single developer out there knowing how to handle an upgrade to their software and doing it correctly each their own way ...
Damn, so I'll just have to reinstall Ubuntu then...again. So then does 12.1 install the 2.5 SDK also? Or what order should they be installed in?

BTC: 1KrakenLFEFg33A4f6xpwgv3UUoxrLPuGn
ummas
Sr. Member
****
Offline Offline

Activity: 274


View Profile
June 25, 2012, 04:58:17 PM
 #5939

Hi
sorry for tat, but i have to ask.

I just got my 3 singles, and trying to get it working with cgminer.
Downloaded 2.4.3 and compiled on my own, whitch is creazy Wink
Code:
CFLAGS="-O2 -Wall" ./configure --enable-bitforce
make
lsusb gives me
Code:
Bus 001 Device 014: ID 0403:6014 Future Technology Devices International, Ltd
Bus 001 Device 013: ID 0403:6014 Future Technology Devices International, Ltd
but cgminer gives me:
Code:
All devices disabled, cannot mine!

Am i missing somme sort of driver or what ? pliss help
kano
Legendary
*
Offline Offline

Activity: 1918


Linux since 1997 RedHat 4


View Profile
June 25, 2012, 05:17:13 PM
 #5940

Possibly:
sudo modprobe ftdi_sio vendor=0x0403 product=0x6014

Pool: https://kano.is BTC: 1KanoiBupPiZfkwqB7rfLXAzPnoTshAVmb
CKPool and CGMiner developer, IRC FreeNode #ckpool and #cgminer kanoi
Help keep Bitcoin secure by mining on pools with Stratum, the best protocol to mine Bitcoins with ASIC hardware
Pages: « 1 ... 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 [297] 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 ... 830 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!