Bitcoin Forum
June 22, 2017, 10:34:26 PM *
News: Latest stable version of Bitcoin Core: 0.14.2  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 ... 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 [317] 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 ... 834 »
  Print  
Author Topic: OFFICIAL CGMINER mining software thread for linux/win/osx/mips/arm/r-pi 4.10.0  (Read 5215138 times)
This is a self-moderated topic. If you do not want to be moderated by the person who started this topic, create a new topic.
P_Shep
Legendary
*
Offline Offline

Activity: 994


View Profile WWW
July 31, 2012, 03:29:27 PM
 #6321

Half an hour so far with no problems on either machine. Going to bed soon, so I'll just lettem do their thing and report in the morning.

Following up on this, everything seems to be great. Across 11 Singles nothing has hung over night, and all measurements seem to be up to par or better. Excellent work.

So, sabotage? Wink
1498170866
Hero Member
*
Offline Offline

Posts: 1498170866

View Profile Personal Message (Offline)

Ignore
1498170866
Reply with quote  #2

1498170866
Report to moderator
POLONIEX TRADING SIGNALS
+50% Profit and more via TELEGRAM
ALTCOINTRADER.CO
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1498170866
Hero Member
*
Offline Offline

Posts: 1498170866

View Profile Personal Message (Offline)

Ignore
1498170866
Reply with quote  #2

1498170866
Report to moderator
1498170866
Hero Member
*
Offline Offline

Posts: 1498170866

View Profile Personal Message (Offline)

Ignore
1498170866
Reply with quote  #2

1498170866
Report to moderator
1498170866
Hero Member
*
Offline Offline

Posts: 1498170866

View Profile Personal Message (Offline)

Ignore
1498170866
Reply with quote  #2

1498170866
Report to moderator
rav3n_pl
Legendary
*
Offline Offline

Activity: 1339


Don`t panic! Organize!


View Profile WWW
July 31, 2012, 03:31:41 PM
 #6322

When I run it, for some reason it duplicates the pools and shows 6 instead of 3 (each one twice). It also says BFL0 Hit thermal cutoff limit, disabling. Any idea why it is doing this in 2.6.1 but not 2.5?
It duplicates because you have config file saved, and cgminer is adding them to your command line options.
Delete config file if you are using full command line option.

1Rav3nkMayCijuhzcYemMiPYsvcaiwHni  Bitcoin stuff on my OneDrive
My RPC CoinControl for any coin https://bitcointalk.org/index.php?topic=929954
Some stuff on https://github.com/Rav3nPL/
Luke-Jr
Legendary
*
Offline Offline

Activity: 2198



View Profile
July 31, 2012, 03:31:58 PM
 #6323

Here are the results I've got for both miners running around 45k shares across 3 longpolls both:
Unfortunately, I've found even using the same device for even more shares does not produce comparable U results, even with the same exact software. Feel free to confirm this yourself by doing the same test over.

BlackPrapor
Hero Member
*****
Offline Offline

Activity: 589



View Profile
July 31, 2012, 03:37:00 PM
 #6324

Here are the results I've got for both miners running around 45k shares across 3 longpolls both:
Unfortunately, I've found even using the same device for even more shares does not produce comparable U results, even with the same exact software. Feel free to confirm this yourself by doing the same test over.

Well, I didn't comment the results, since I don't really know that much about the output data it gives. All I can say, is that U fluctuated in both miners from 716 to 722, but in general cgminer shows higher U, and bfgminer shows higher average Ghs speed.

There is no place like 127.0.0.1
In blockchain we trust
Luke-Jr
Legendary
*
Offline Offline

Activity: 2198



View Profile
July 31, 2012, 04:10:54 PM
 #6325

Here are the results I've got for both miners running around 45k shares across 3 longpolls both:
Unfortunately, I've found even using the same device for even more shares does not produce comparable U results, even with the same exact software. Feel free to confirm this yourself by doing the same test over.

Well, I didn't comment the results, since I don't really know that much about the output data it gives. All I can say, is that U fluctuated in both miners from 716 to 722, but in general cgminer shows higher U, and bfgminer shows higher average Ghs speed.
Human pattern analysis is always suspect Wink

Also, you're comparing cg2.6.1 with bfg2.5.1. At the very least, it'd be better to compare equivalent versions. But first, it'd be wise to try to find some way to reproduce consistent results with the same software - until then, there's really no good way to compare. Sad

Vbs
Hero Member
*****
Offline Offline

Activity: 504


View Profile
July 31, 2012, 04:21:21 PM
 #6326

(...)
Summary:
Jesusminer
(...)
Priceless! Cheesy
dave3
Sr. Member
****
Offline Offline

Activity: 316



View Profile
August 01, 2012, 06:47:50 AM
 #6327

I was just about to post how I've been running 2.6.1 with my BFL singles for 2 days straight without problem, and then I caught these errors.  I restarted cgminer and it's working again for now.

Code:
cgminer version 2.6.1 - Started: [2012-07-30 13:39:23]
--------------------------------------------------------------------------------
 (5s):676.7 (avg):1608.9 Mh/s | Q:4593  A:66056  R:459  HW:0  E:1438%  U:22.4/m
 TQ: 3  ST: 3  SS: 9  DW: 365  NB: 285  LW: 65155  GF: 291  RF: 14
 Connected to http://us2.eclipsemc.com:8337 with LP as user ---
 Block: 000002f8bafdadac36c5a7432645b005...  Started: [14:42:44]
--------------------------------------------------------------------------------
 [P]ool management [S]ettings [D]isplay options [Q]uit
 BFL 0:  56.7C         |   9.5/804.4Mh/s | A:32864 R:233 HW:0 U:11.16/m
 BFL 1:  58.2C         | 695.7/804.5Mh/s | A:33192 R:226 HW:0 U:11.28/m
--------------------------------------------------------------------------------

 [2012-08-01 14:41:46] Accepted e739af43.9733a4ee BFL 1 pool 0
 [2012-08-01 14:41:46] Accepted 1408b949.40bb64ba BFL 1 pool 0
 [2012-08-01 14:41:46] Accepted ba0677af.8ba676b3 BFL 1 pool 0
 [2012-08-01 14:41:46] Accepted 2af13e5f.ada5ec4d BFL 0 pool 0
 [2012-08-01 14:41:51] Accepted 83c05b44.9db665b3 BFL 1 pool 0
 [2012-08-01 14:41:51] Accepted c476a165.697a09cd BFL 1 pool 0
 [2012-08-01 14:41:56] Accepted f7ad3a83.c549c20f BFL 1 pool 0
 [2012-08-01 14:42:02] Accepted ff6bca72.427f2e0f BFL 1 pool 0
 [2012-08-01 14:42:02] Accepted adf8b4e8.8e00c928 BFL 0 pool 0
 [2012-08-01 14:42:07] Accepted a0cad834.a94bcf66 BFL 0 pool 0
 [2012-08-01 14:42:12] Accepted f2259814.f6f93b99 BFL 0 pool 0
 [2012-08-01 14:42:12] Accepted 82ada705.4552a4bd BFL 0 pool 0
 [2012-08-01 14:42:18] Accepted 749a8969.4d83e3b2 BFL 0 pool 0
 [2012-08-01 14:42:18] Accepted 3f0c4df2.106594de BFL 0 pool 0
 [2012-08-01 14:42:20] BFL0: Error: Get temp returned empty string/timed out
 [2012-08-01 14:42:23] BFL0: Error: Get result reports: Temperature (celcius): 57.9
 [2012-08-01 14:42:23] BFL0: Error: Send block data reports: ERR:UNKNOWN!!!
 [2012-08-01 14:42:23] Accepted 662b77a6.f98154b0 BFL 1 pool 0
 [2012-08-01 14:42:23] Accepted c2280535.ade77eb7 BFL 1 pool 0
 [2012-08-01 14:42:28] BFL0: Error: Send work reports: Temperature (celcius): 57.8
 [2012-08-01 14:42:33] BFL0: Error: Send work reports: ERR:INVALID DATA, i_read = 3
 [2012-08-01 14:42:39] BFL0: Error: Send work reports: ERR:UNKNOWN!!!
 [2012-08-01 14:42:44] LONGPOLL from pool 0 detected new block
 [2012-08-01 14:42:44] Pool 0 not providing work fast enough
 [2012-08-01 14:42:44] BFL0: Error: Send work reports: Temperature (celcius): 54.6
 [2012-08-01 14:42:49] BFL0: Error: Send work reports: ERR:INVALID DATA, i_read = 3
 [2012-08-01 14:42:49] Accepted 2a02dca0.a9f0ed3e BFL 1 pool 0
 [2012-08-01 14:42:54] BFL0: Error: Send work reports: ERR:INVALID DATA, i_read = 3
 [2012-08-01 14:42:54] Accepted f396c897.814b1228 BFL 1 pool 0

kano
Legendary
*
Offline Offline

Activity: 2128


Linux since 1997 RedHat 4


View Profile
August 01, 2012, 07:02:19 AM
 #6328

One direct cause of the above error is something else sending data on the serial line to the BFL (by accident?)
I've done exactly that and had exactly that error (in my case it never recovered I had to restart cgminer)
I have 2 cgminers running on my desktop, one that mines the BFL and the other mines my 2xIcarus
My Icarus miner does an ident test on all 3 serial port (by my choice) and once (when BFL was running) I got that problem.

The other possibility is that it did in fact timeout (took longer than 0.1s to reply) and thus the actual BFL/serial in now messed up (out of sync) with messages and replies

I'd guess the first one though.

Pool: https://kano.is Here on Bitcointalk: Forum BTC: 1KanoPb8cKYqNrswjaA8cRDk4FAS9eDMLU
FreeNode IRC: irc.freenode.net channel #kano.is
Help keep Bitcoin secure by mining on pools with full block verification on all blocks - and NO empty blocks!
Luke-Jr
Legendary
*
Offline Offline

Activity: 2198



View Profile
August 01, 2012, 07:03:38 AM
 #6329

I was just about to post how I've been running 2.6.1 with my BFL singles for 2 days straight without problem, and then I caught these errors.  I restarted cgminer and it's working again for now.
This is almost certainly caused by Kano's reduction of the timeout from 30 seconds to 0.1 second... I skimmed over this one and assumed it was 1 second (which is at least reasonable). Bet this is what was causing the other problems people reported too... thanks for the tip Smiley I'll fix it for the next BFGMiner.

dave3
Sr. Member
****
Offline Offline

Activity: 316



View Profile
August 01, 2012, 07:07:01 AM
 #6330

One direct cause of the above error is something else sending data on the serial line to the BFL (by accident?)
I've done exactly that and had exactly that error (in my case it never recovered I had to restart cgminer)
I have 2 cgminers running on my desktop, one that mines the BFL and the other mines my 2xIcarus
My Icarus miner does an ident test on all 3 serial port (by my choice) and once (when BFL was running) I got that problem.

The other possibility is that it did in fact timeout (took longer than 0.1s to reply) and thus the actual BFL/serial in now messed up (out of sync) with messages and replies

I'd guess the first one though.

I've only got the 2 BFL singles running on the system, both plugged into a usb hub (with nothing else using the hub).  The only other usb device I have on the system is a mouse.

DiabloD3
Legendary
*
Offline Offline

Activity: 1162


DiabloMiner author


View Profile WWW
August 01, 2012, 07:36:41 AM
 #6331

I've got mini rigs hanging after some time with cgminer 2.6.1 so I switched back to bfgminer 2.5.1. It does produce almost 1% more rejects (cgminer had almost none 0.07%), but at least it works  Roll Eyes.
No, CGMiner has them - it just hides them from you, along with other shares that would have been accepted...

Angry neighborhood bastard mod here.

Go FUD on some other forum, your kind isn't welcome here.

Luke-Jr
Legendary
*
Offline Offline

Activity: 2198



View Profile
August 01, 2012, 07:40:18 AM
 #6332

I've got mini rigs hanging after some time with cgminer 2.6.1 so I switched back to bfgminer 2.5.1. It does produce almost 1% more rejects (cgminer had almost none 0.07%), but at least it works  Roll Eyes.
No, CGMiner has them - it just hides them from you, along with other shares that would have been accepted...

Angry neighborhood bastard mod here.

Go FUD on some other forum, your kind isn't welcome here.
It's not FUD since it's true.

ShadesOfMarble
Donator
Hero Member
*
Offline Offline

Activity: 543



View Profile
August 01, 2012, 08:28:51 AM
 #6333

Is there a way to put this command line into a config file?

-S \\.\COM20 -S \\.\COM22

Because every combination that I tried either failed or only detected one of the two ports (like "scan-serial":"\\\\.\\COM20,\\\\.\\COM22", "scan-serial" on two lines with each port etc...)

Review of the Spondoolies-Tech SP10 „Dawson“ Bitcoin miner (1.4 TH/s)

[22:35] <Vinnie_win> Did anyone get paid yet? | [22:36] <Isokivi> pirate did!
Luke-Jr
Legendary
*
Offline Offline

Activity: 2198



View Profile
August 01, 2012, 08:32:47 AM
 #6334

Is there a way to put this command line into a config file?

-S \\.\COM20 -S \\.\COM22

Because every combination that I tried either failed or only detected one of the two ports (like "scan-serial":"\\\\.\\COM20,\\\\.\\COM22", "scan-serial" on two lines with each port etc...)
"scan-serial":["\\.\COM20", "\\.\COM22"]

ShadesOfMarble
Donator
Hero Member
*
Offline Offline

Activity: 543



View Profile
August 01, 2012, 08:58:42 AM
 #6335

Thanks - although I had to use escaped backslashes, probably because I'm on Windows.

Review of the Spondoolies-Tech SP10 „Dawson“ Bitcoin miner (1.4 TH/s)

[22:35] <Vinnie_win> Did anyone get paid yet? | [22:36] <Isokivi> pirate did!
kano
Legendary
*
Offline Offline

Activity: 2128


Linux since 1997 RedHat 4


View Profile
August 01, 2012, 09:35:38 AM
 #6336

I was just about to post how I've been running 2.6.1 with my BFL singles for 2 days straight without problem, and then I caught these errors.  I restarted cgminer and it's working again for now.
This is almost certainly caused by Kano's reduction of the timeout from 30 seconds to 0.1 second... I skimmed over this one and assumed it was 1 second (which is at least reasonable). Bet this is what was causing the other problems people reported too... thanks for the tip Smiley I'll fix it for the next BFGMiner.
If my change is the cause of all the problems then you only need to do a single one line change of driver_bitforce.c line 41
The value '1' - change it Tongue
So if that's the cause of it all as you are implying then you will have a fix ready in a few minutes ... Tongue

Anyway,
at least try to understand the old code Tongue

On windows it was 30 seconds

On linux is was either 0.1 seconds or never (HANG if BFL didn't reply)
(yeah a bug)

If you entered 'bitforce:' on the front in linux it wouldn't set a timeout (HANG on no reply)
If you didn't put 'bitforce:' on the front in linux, Icarus would set a 0.1s timeout
(bitforce still didn't set a timeout of course but the Icarus one affected the bitforce code)

I changed the code coz whenever it got a comms error, it would hang trying to flush the buffer coz I use 'bitforce:'
(my BFL device is crappy and thus I get to see what happens with a comms error sometimes)

Pool: https://kano.is Here on Bitcointalk: Forum BTC: 1KanoPb8cKYqNrswjaA8cRDk4FAS9eDMLU
FreeNode IRC: irc.freenode.net channel #kano.is
Help keep Bitcoin secure by mining on pools with full block verification on all blocks - and NO empty blocks!
kano
Legendary
*
Offline Offline

Activity: 2128


Linux since 1997 RedHat 4


View Profile
August 01, 2012, 09:39:20 AM
 #6337

I've got mini rigs hanging after some time with cgminer 2.6.1 so I switched back to bfgminer 2.5.1. It does produce almost 1% more rejects (cgminer had almost none 0.07%), but at least it works  Roll Eyes.
No, CGMiner has them - it just hides them from you, along with other shares that would have been accepted...

Angry neighborhood bastard mod here.

Go FUD on some other forum, your kind isn't welcome here.
It's not FUD since it's true.
Sigh - so because you don't even understand the code you call it FUD.
Ckolivas has already clearly explained why it's FUD and you reply with 'no'
Yeah about as intelligent as ... well nothing - no intelligence at all actually.
Please stop proving your a moron in this thread and do it elsewhere.

Pool: https://kano.is Here on Bitcointalk: Forum BTC: 1KanoPb8cKYqNrswjaA8cRDk4FAS9eDMLU
FreeNode IRC: irc.freenode.net channel #kano.is
Help keep Bitcoin secure by mining on pools with full block verification on all blocks - and NO empty blocks!
dave3
Sr. Member
****
Offline Offline

Activity: 316



View Profile
August 01, 2012, 09:49:21 AM
 #6338

I had those errors in 2.6.1 happen again, so I just down-graded to 2.5.0 for now.

-ck
Moderator
Legendary
*
Offline Offline

Activity: 2198


Ruu \o/


View Profile WWW
August 01, 2012, 09:53:44 AM
 #6339

I had those errors in 2.6.1 happen again, so I just down-graded to 2.5.0 for now.
Were you on windows 2.6.1 or the cgminer.exe from the test directory?

Primary developer/maintainer for cgminer and ckpool/ckproxy.
Pooled mine at ckpool.org Solo mine at solo.ckpool.org
-ck
dave3
Sr. Member
****
Offline Offline

Activity: 316



View Profile
August 01, 2012, 10:05:14 AM
 #6340

Were you on windows 2.6.1 or the cgminer.exe from the test directory?

It was 2.6.1 that I compiled myself for windows from source, with only bitforce support enabled (not the cgminer.exe from the test directory).

Pages: « 1 ... 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 [317] 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 ... 834 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!