Bitcoin Forum
July 22, 2018, 01:44:13 AM *
News: Latest stable version of Bitcoin Core: 0.16.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: « 1 ... 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 [336] 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 ... 847 »
  Print  
Author Topic: OFFICIAL CGMINER mining software thread for linux/win/osx/mips/arm/r-pi 4.10.0  (Read 5756982 times)
This is a self-moderated topic. If you do not want to be moderated by the person who started this topic, create a new topic.
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2590
Merit: 1113


Ruu \o/


View Profile WWW
August 21, 2012, 11:15:06 PM
 #6701

Hi,

Big problems with my miner. I have been mining 2-3 months, but I had to make fresh install of my backup computer. All steps and logs are here:

https://bitcointalk.org/index.php?topic=101758.0

Please, someone? RCP calls and job curls are missing... I have spotted the part in cgminer.c code, but so far I have not added own debugging messages while I hope someone knows what is wrong.


Absolutely no idea unless the 32 bit version of ubuntu you installed happened to have a broken curl library.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org 1% Fee Solo mining at solo.ckpool.org
-ck
1532223853
Hero Member
*
Offline Offline

Posts: 1532223853

View Profile Personal Message (Offline)

Ignore
1532223853
Reply with quote  #2

1532223853
Report to moderator
1532223853
Hero Member
*
Offline Offline

Posts: 1532223853

View Profile Personal Message (Offline)

Ignore
1532223853
Reply with quote  #2

1532223853
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
os2sam
Legendary
*
Offline Offline

Activity: 2464
Merit: 1001


Think for yourself


View Profile
August 21, 2012, 11:39:54 PM
 #6702

I am most certainly not going to give one more second's thought to scrypt.

Don't mean to make you think of it, but, what the heck is "scrypt" anyway?
Sam

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing on usenet and in e-mail?
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2590
Merit: 1113


Ruu \o/


View Profile WWW
August 21, 2012, 11:45:20 PM
 #6703

I am most certainly not going to give one more second's thought to scrypt.

Don't mean to make you think of it, but, what the heck is "scrypt" anyway?
Sam
Litecoin mining, which I hope dies and goes away.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org 1% Fee Solo mining at solo.ckpool.org
-ck
Morblias
Hero Member
*****
Offline Offline

Activity: 571
Merit: 500


View Profile
August 22, 2012, 02:47:25 AM
 #6704

I can confirm this. At first I thought it was because I manually added a pool while cgminer was running and that messed it up, but now he's posting a similar issue. Did you add a pool like me or did it switch and fail to switch back on its own Morblias?

It switched and failed to switch back.
Was bonuspool the common element?

I will check with Clipse tomorrow to see if he was having any problems with the pool. I noticed it is having communication problems a lot with 2.7.1 and I am not convinced yet it is the pools, but who knows, maybe it is.



I will keep you posted what I find tomorrow. Thanks again for all your hard work ckolivas.

Tips / Donations accepted: 1Morb18DsDHNEv6TeQXBdba872ZSpiK9fY
Beaflag VonRathburg
Sr. Member
****
Offline Offline

Activity: 443
Merit: 250



View Profile
August 22, 2012, 03:28:52 AM
 #6705

I can confirm this. At first I thought it was because I manually added a pool while cgminer was running and that messed it up, but now he's posting a similar issue. Did you add a pool like me or did it switch and fail to switch back on its own Morblias?

It switched and failed to switch back.
Was bonuspool the common element?

I will check with Clipse tomorrow to see if he was having any problems with the pool. I noticed it is having communication problems a lot with 2.7.1 and I am not convinced yet it is the pools, but who knows, maybe it is.



I will keep you posted what I find tomorrow. Thanks again for all your hard work ckolivas.

My bonuspool account went apeshit exactly like that for a little while a few hours ago. I switched a couple parts around in my rigs so I wasn't sure if it was a hardware issue, but it seems to have gone away.

farfie
Jr. Member
*
Offline Offline

Activity: 63
Merit: 0



View Profile
August 22, 2012, 03:53:39 AM
 #6706

My bonuspool account went apeshit exactly like that for a little while a few hours ago. I switched a couple parts around in my rigs so I wasn't sure if it was a hardware issue, but it seems to have gone away.

I don't think it's bonuspool. The common element was that we both had a pool go down. I use Eclipse and mtred, and when Eclipse went down this morning, I manually added mtred because it wasn't in the config at the time. Later on, I realized Eclipse had come up and was up for awhile, but the miner was doing -exactly- what Morblias was saying: except that I switched it myself, and it was failing to switch back. Actually, I didn't even switch it - I just added mtred manually while it was running, and it went over to mtred on it's own. Of course at first I expected the errors it was giving... because the pool was down. I even checked using ping.eu's port checker function and 8337 on eclipse was closed for all Eclipse servers. Later on when I knew the pool was up, the miner was doing exactly the same thing. Sitting on mtred, and saying Eclipse was down. I even checked again with ping.eu to make sure, and indeed Eclipse was up. So I just closed the miner, repoened it, and voila, connection to Eclipse.

I think this is pretty solid evidence Smiley
420
Hero Member
*****
Offline Offline

Activity: 756
Merit: 500



View Profile
August 22, 2012, 07:34:00 AM
 #6707

Failover only: does this override the default setting which is failover using backup pools when primary pool is lagging?

in other words if i use this parameter will it stay on one pool even if the pool is slow and not accepting shares at my full speed hashrate i could be sending them?

and default it would utilize another pool for some shares that the first pool isn't fast enough to select?

Donations: 1JVhKjUKSjBd7fPXQJsBs5P3Yphk38AqPr - TIPS
the hacks, the hacks, secure your bits!
Krak
Hero Member
*****
Offline Offline

Activity: 591
Merit: 500



View Profile WWW
August 22, 2012, 07:43:59 AM
 #6708

Failover only: does this override the default setting which is failover using backup pools when primary pool is lagging?

in other words if i use this parameter will it stay on one pool even if the pool is slow and not accepting shares at my full speed hashrate i could be sending them?

and default it would utilize another pool for some shares that the first pool isn't fast enough to select?
Yep, pretty much.

BTC: 1KrakenLFEFg33A4f6xpwgv3UUoxrLPuGn
nitrox
Member
**
Offline Offline

Activity: 135
Merit: 10


tester


View Profile
August 22, 2012, 08:22:48 AM
 #6709

winsows 7 x64
driver 12.8
SDK 2.7
cgminer 2.7.1

after few hours run appear error :

Code:
[2012-08-22 08:39:59] Accepted 43ccdc0e.9f4a0881 GPU 1 pool 0
 [2012-08-22 08:40:02] Accepted 56eb716f.b4d7f8c4 GPU 1 pool 0
 [2012-08-22 08:40:04] Accepted 9f5505de.e0a3aeb7 GPU 1 pool 0
 [2012-08-22 08:40:14] Pool 0 not providing work fast enough
 [2012-08-22 08:40:51] Pool 0 communication failure, caching submissions
 [2012-08-22 08:40:51] Share became stale while retrying submit, discarding
 [2012-08-22 08:40:56] Share became stale while retrying submit, discarding
 [2012-08-22 08:41:00] Share became stale while retrying submit, discarding
 [2012-08-22 08:41:14] Pool 0 http://pool.ABCPool.co:8332 not responding!
 [2012-08-22 08:41:14] Switching to http://mine3.btcguild.com:8332
 [2012-08-22 08:41:14] Long-polling activated for http://mine3.btcguild.com:8332/LP/
 [2012-08-22 08:41:14] Failed to create get_work_thread
 [2012-08-22 08:41:14]
Summary of runtime statistics:

 [2012-08-22 08:41:14] Started at [2012-08-21 21:21:42]
 [2012-08-22 08:41:14] Runtime: 11 hrs : 19 mins : 29 secs
 [2012-08-22 08:41:14] Average hashrate: 1146.9 Megahash/s
 [2012-08-22 08:41:14] Solved blocks: 0
 [2012-08-22 08:41:14] Queued work requests: 11182
 [2012-08-22 08:41:14] Share submissions: 10516
 [2012-08-22 08:41:14] Accepted shares: 10480
 [2012-08-22 08:41:14] Rejected shares: 36
 [2012-08-22 08:41:14] Reject ratio: 0.3%
 [2012-08-22 08:41:14] Hardware errors: 0
 [2012-08-22 08:41:14] Efficiency (accepted / queued): 94%
 [2012-08-22 08:41:14] Utility (accepted shares / min): 15.42/min
 [2012-08-22 08:41:14] Work Utility (diff1 shares solved / min): 15.48/min

 [2012-08-22 08:41:14] Discarded work due to new blocks: 156
 [2012-08-22 08:41:14] Stale submissions discarded due to new blocks: 3
 [2012-08-22 08:41:14] Unable to get work from server occasions: 78
 [2012-08-22 08:41:14] Work items generated locally: 0
 [2012-08-22 08:41:14] Submitting work remotely delay occasions: 1
 [2012-08-22 08:41:14] New blocks detected on network: 65

 [2012-08-22 08:41:14] Pool: http://pool.ABCPool.co:8332
 [2012-08-22 08:41:14]  Queued work requests: 11180
 [2012-08-22 08:41:14]  Share submissions: 10516
 [2012-08-22 08:41:14]  Accepted shares: 10480
 [2012-08-22 08:41:14]  Rejected shares: 36
 [2012-08-22 08:41:14]  Reject ratio: 0.3%
 [2012-08-22 08:41:14]  Efficiency (accepted / queued): 94%
 [2012-08-22 08:41:14]  Discarded work due to new blocks: 154
 [2012-08-22 08:41:14]  Stale submissions discarded due to new blocks: 3
 [2012-08-22 08:41:14]  Unable to get work from server occasions: 78
 [2012-08-22 08:41:14]  Submitting work remotely delay occasions: 1

 [2012-08-22 08:41:14] Pool: http://mine3.btcguild.com:8332
 [2012-08-22 08:41:14]  Queued work requests: 1
 [2012-08-22 08:41:14]  Share submissions: 0
 [2012-08-22 08:41:14]  Accepted shares: 0
 [2012-08-22 08:41:14]  Rejected shares: 0
 [2012-08-22 08:41:14]  Efficiency (accepted / queued): 0%
 [2012-08-22 08:41:14]  Discarded work due to new blocks: 1
 [2012-08-22 08:41:14]  Stale submissions discarded due to new blocks: 0
 [2012-08-22 08:41:14]  Unable to get work from server occasions: 0
 [2012-08-22 08:41:14]  Submitting work remotely delay occasions: 0

 [2012-08-22 08:41:14] Pool: http://pit.deepbit.net:8332
 [2012-08-22 08:41:14]  Queued work requests: 1
 [2012-08-22 08:41:14]  Share submissions: 0
 [2012-08-22 08:41:14]  Accepted shares: 0
 [2012-08-22 08:41:14]  Rejected shares: 0
 [2012-08-22 08:41:14]  Efficiency (accepted / queued): 0%
 [2012-08-22 08:41:14]  Discarded work due to new blocks: 1
 [2012-08-22 08:41:14]  Stale submissions discarded due to new blocks: 0
 [2012-08-22 08:41:14]  Unable to get work from server occasions: 0
 [2012-08-22 08:41:14]  Submitting work remotely delay occasions: 0

 [2012-08-22 08:41:14] Summary of per device statistics:

 [2012-08-22 08:41:14] GPU0                | (5s):551.9 (avg):547.8 Mh/s | A:5049 R:15 HW:0 U:7.4/m I:10
 [2012-08-22 08:41:14] GPU1                | (5s):602.9 (avg):599.1 Mh/s | A:5431 R:21 HW:0 U:8.0/m I:10
 [2012-08-22 08:41:14] Failed to tq_push in queue_request
 [2012-08-22 08:41:14] Failed to tq_push in queue_request
 [2012-08-22 08:41:14] Failed to tq_push in queue_request
 [2012-08-22 08:41:14] API failed (Socket Error: (10004) Interrupted system call) - API will not be available
 [2012-08-22 08:41:14] Failed to tq_push in queue_request
 [2012-08-22 08:41:14] Failed to tq_push in queue_request
 [2012-08-22 08:41:14] Failed to tq_push in queue_request
 [2012-08-22 08:41:14] Failed to tq_push in queue_request
 [2012-08-22 08:41:14] Failed to tq_push in queue_request
 [2012-08-22 08:41:14] Failed to tq_push in queue_request
 [2012-08-22 08:41:14] Failed to tq_push in queue_request
 [2012-08-22 08:41:14] Failed to tq_push in queue_request
 [2012-08-22 08:41:14] Failed to tq_push in queue_request
 [2012-08-22 08:41:14] Failed to tq_push in queue_request
 [2012-08-22 08:41:14] Failed to tq_push in queue_request
 [2012-08-22 08:41:14] Failed to tq_push in queue_request
 [2012-08-22 08:41:14] Failed to tq_push in queue_request
 [2012-08-22 08:41:14] Failed to tq_push in queue_request
 [2012-08-22 08:41:14] Failed to tq_push in queue_request

and cgminer crash.
i will go back to 2.7.0

-ck
Moderator
Legendary
*
Offline Offline

Activity: 2590
Merit: 1113


Ruu \o/


View Profile WWW
August 22, 2012, 09:49:53 AM
 #6710

winsows 7 x64
driver 12.8
SDK 2.7
cgminer 2.7.1

after few hours run appear error :

Code:
[2012-08-22 08:41:14] Failed to create get_work_thread
Most unusual. That is a fatal error because there are too many threads running or the system has run out of ram. This bug falls into the "I have no idea" category.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org 1% Fee Solo mining at solo.ckpool.org
-ck
nitrox
Member
**
Offline Offline

Activity: 135
Merit: 10


tester


View Profile
August 22, 2012, 10:08:50 AM
 #6711

2GB of system RAM, and is running flags " -g 1 -v 1 -w 256 -I 10 " i run two HD7950

stevegee58
Legendary
*
Offline Offline

Activity: 918
Merit: 1003



View Profile
August 22, 2012, 10:13:45 AM
 #6712

I'm having a problem with dynamic intensity with 2.7.1 on Windows XP:

When I start cgminer with dynamic intensity it generally operates around intensity 3 or 4 depending on what I'm doing on the PC.  Last night I changed the intensity from dynamic to 8 (by typing "g, i, 8" in cgminer) and found the PC almost unresponsive this morning with an intensity of 13.  I expected it to still be at 8.

You are in a maze of twisty little passages, all alike.
tnkflx
Sr. Member
****
Offline Offline

Activity: 347
Merit: 250


View Profile
August 22, 2012, 10:14:36 AM
 #6713

I am most certainly not going to give one more second's thought to scrypt.

Don't mean to make you think of it, but, what the heck is "scrypt" anyway?
Sam
Litecoin mining, which I hope dies and goes away.

Why is that?

| Operating electrum.be & us.electrum.be |
Nite69
Sr. Member
****
Offline Offline

Activity: 477
Merit: 500


View Profile
August 22, 2012, 10:28:04 AM
 #6714

New version - 2.7.1, 21st August 2012

Hopefully the gpu-map feature is working for more adl devices than opencl.

Seems to work now, thanks!

Sync: ShiSKnx4W6zrp69YEFQyWk5TkpnfKLA8wx
Bitcoin: 17gNvfoD2FDqTfESUxNEmTukGbGVAiJhXp
Litecoin: LhbDew4s9wbV8xeNkrdFcLK5u78APSGLrR
AuroraCoin: AXVoGgYtSVkPv96JLL7CiwcyVvPxXHXRK9
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2590
Merit: 1113


Ruu \o/


View Profile WWW
August 22, 2012, 10:32:48 AM
 #6715

I am most certainly not going to give one more second's thought to scrypt.

Don't mean to make you think of it, but, what the heck is "scrypt" anyway?
Sam
Litecoin mining, which I hope dies and goes away.

Why is that?
Because I don't care about LTC, the software to mine it is really awkward, newbies keep coming around expecting me to hold their hands and explain it to them when it is not remotely trivial, and it complicates cgminer code and support.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org 1% Fee Solo mining at solo.ckpool.org
-ck
tnkflx
Sr. Member
****
Offline Offline

Activity: 347
Merit: 250


View Profile
August 22, 2012, 11:19:30 AM
 #6716

I am most certainly not going to give one more second's thought to scrypt.

Don't mean to make you think of it, but, what the heck is "scrypt" anyway?
Sam
Litecoin mining, which I hope dies and goes away.

Why is that?
Because I don't care about LTC, the software to mine it is really awkward, newbies keep coming around expecting me to hold their hands and explain it to them when it is not remotely trivial, and it complicates cgminer code and support.

Ok, thanks for the answer Wink

| Operating electrum.be & us.electrum.be |
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2590
Merit: 1113


Ruu \o/


View Profile WWW
August 22, 2012, 11:51:16 AM
 #6717

I'm having a problem with dynamic intensity with 2.7.1 on Windows XP:

When I start cgminer with dynamic intensity it generally operates around intensity 3 or 4 depending on what I'm doing on the PC.  Last night I changed the intensity from dynamic to 8 (by typing "g, i, 8" in cgminer) and found the PC almost unresponsive this morning with an intensity of 13.  I expected it to still be at 8.
Not at all expected behaviour.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org 1% Fee Solo mining at solo.ckpool.org
-ck
The00Dustin
Hero Member
*****
Offline Offline

Activity: 807
Merit: 500


View Profile
August 22, 2012, 01:28:00 PM
 #6718

My bonuspool account went apeshit exactly like that for a little while a few hours ago. I switched a couple parts around in my rigs so I wasn't sure if it was a hardware issue, but it seems to have gone away.

I don't think it's bonuspool. The common element was that we both had a pool go down. I use Eclipse and mtred, and when Eclipse went down this morning, I manually added mtred because it wasn't in the config at the time. Later on, I realized Eclipse had come up and was up for awhile, but the miner was doing -exactly- what Morblias was saying: except that I switched it myself, and it was failing to switch back. Actually, I didn't even switch it - I just added mtred manually while it was running, and it went over to mtred on it's own. Of course at first I expected the errors it was giving... because the pool was down. I even checked using ping.eu's port checker function and 8337 on eclipse was closed for all Eclipse servers. Later on when I knew the pool was up, the miner was doing exactly the same thing. Sitting on mtred, and saying Eclipse was down. I even checked again with ping.eu to make sure, and indeed Eclipse was up. So I just closed the miner, repoened it, and voila, connection to Eclipse.

I think this is pretty solid evidence Smiley
I can confirm similar behavior as well in yet another scenario.  I added a 5th pool (I already had pools in positions 0 through 4) through the curses interface.  I then proceeded to switch to it.  Shortly thereafter, cgminer switched back to pool 0 (presumably due to a problem with pool 4), and then I started getting alive and down messages every few minutes but not submitting shares to pool 4 (I also started submitting shares to pools 1 and 2 álong with 0 in spite of --failover-only and 18 hours since launch of cgminer).  I deleted pool 4, added it again, switched to it again, and voila, cgminer is mining on it again.  Next time I may try disabling and re-enabling it instead of deleting it, however I can also report that it said disabled on the pool after I hit P before I deleted it.  I thought they were only supposed to go to disabled (vs dead) after a long string of rejects, and I didn't see any rejects.  I don't know if this additional information is helpful or not, but something is up...

ETA: I am using 2.7.1, I think the two quotes above are too, I just realized none of them indicate it in this post.
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2590
Merit: 1113


Ruu \o/


View Profile WWW
August 22, 2012, 01:33:16 PM
 #6719

Alas that was the bug I was trying to fix going from 2.7.0 to 2.7.1. If anyone's on git and want to give the latest git master a try there's one tiny change which might help, but it's a long shot.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org 1% Fee Solo mining at solo.ckpool.org
-ck
Luke-Jr
Legendary
*
Offline Offline

Activity: 2394
Merit: 1001



View Profile
August 22, 2012, 04:22:10 PM
 #6720

winsows 7 x64
driver 12.8
SDK 2.7
cgminer 2.7.1

after few hours run appear error :

Code:
[2012-08-22 08:41:14] Failed to create get_work_thread
Most unusual. That is a fatal error because there are too many threads running or the system has run out of ram. This bug falls into the "I have no idea" category.
Miners used to get this when there were a lot of weird network problems. I fixed it in BFGMiner, but it's back with the 2.7.0 changes. Perhaps my original fix might shed some light on the current problem.

Pages: « 1 ... 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 [336] 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 ... 847 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!