Bitcoin Forum
February 16, 2019, 11:01:05 PM *
News: Latest Bitcoin Core release: 0.17.1 [Torrent]
 
   Home   Help Search Login Register More  
Pages: « 1 ... 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 [346] 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 ... 844 »
  Print  
Author Topic: OFFICIAL CGMINER mining software thread for linux/win/osx/mips/arm/r-pi 4.11.1  (Read 5776288 times)
This is a self-moderated topic. If you do not want to be moderated by the person who started this topic, create a new topic. (2 posts by 2 users deleted.)
tnkflx
Sr. Member
****
Offline Offline

Activity: 347
Merit: 250


View Profile
September 04, 2012, 10:18:23 AM
 #6901

could that be a driver issue

The last stable release is 2.7.5. Maybe try an upgrade first? Wink

Don't be an asshat.  2.7.5 is the latest release.  It is not stable for everyone.  Just because it works for you, doesn't mean that everyone else should be using it.

Wow... rough night?

The last stable release in the 2.6 series was 2.6.6. The current last stable release is 2.7.5. Maybe help Kano and Con with debugging info if the versions you are using are stable and the latest ones don't work?

| Operating electrum.be & us.electrum.be |
1550358065
Hero Member
*
Offline Offline

Posts: 1550358065

View Profile Personal Message (Offline)

Ignore
1550358065
Reply with quote  #2

1550358065
Report to moderator
1550358065
Hero Member
*
Offline Offline

Posts: 1550358065

View Profile Personal Message (Offline)

Ignore
1550358065
Reply with quote  #2

1550358065
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1550358065
Hero Member
*
Offline Offline

Posts: 1550358065

View Profile Personal Message (Offline)

Ignore
1550358065
Reply with quote  #2

1550358065
Report to moderator
mdude77
Legendary
*
Offline Offline

Activity: 1540
Merit: 1001



View Profile
September 04, 2012, 11:28:23 AM
 #6902

Using 2.7.4.

The overheat function doesn't seem to be working right.  I have it set to 85.  Twice I've found it in the low 90s and not making any effort to shut down or cool down.

M
--temp-cutoff (default is 95)

This is in my cgminer.conf.  This isn't enough?

"temp-cutoff" : "90",
"temp-overheat" : "85",
"temp-target" : "75",

M

I mine at Kano's Pool because it pays the best and is completely transparent!  Come join me!
kano
Legendary
*
Offline Offline

Activity: 2730
Merit: 1103


Linux since 1997 RedHat 4


View Profile
September 04, 2012, 11:29:58 AM
Last edit: September 04, 2012, 11:53:31 AM by kano
 #6903

could that be a driver issue

The last stable release is 2.7.5. Maybe try an upgrade first? Wink

Don't be an asshat.  2.7.5 is the latest release.  It is not stable for everyone.  Just because it works for you, doesn't mean that everyone else should be using it.

Wow... rough night?

The last stable release in the 2.6 series was 2.6.6. The current last stable release is 2.7.5. Maybe help Kano and Con with debugging info if the versions you are using are stable and the latest ones don't work?
Or if anyone is interested in additions after 2.7.5 Smiley

The master branch in my git has a rather large number of commits I've worked on in the last 24 hours (and a couple before that)
The list is: debug control in the API, generic HW error handling for all devices except ztex, Diff1 information, BFL identify via a led flash, BFL throttle counter in 'notify' and a few other bit and pieces.

The pull request is here: https://github.com/ckolivas/cgminer/pull/310 that shows them all.
That is simply my master branch - and each change I've done I keep adding to that pull request.

Anyone interested in any of those additions feel free to compile my master and let me know if you have any problems.
I haven't changed the ztex code coz I don't have any ztex hardware and the original code does some weird shit dealing with HW errors - if someone has a ztex and has time to visit IRC I could add some changes in another branch and get them to test it also.

Thanks for anyone who can test this.

Edit: of course this is what I am running on my 2 rigs - BFL, and ICA+GPU

Pool: https://kano.is Here on Bitcointalk: Forum BTC: 1KanoPb8cKYqNrswjaA8cRDk4FAS9eDMLU
FreeNode IRC: irc.freenode.net channel #kano.is Majority developer of the ckpool code
Help keep Bitcoin secure by mining on pools with full block verification on all blocks - and NO empty blocks!
kano
Legendary
*
Offline Offline

Activity: 2730
Merit: 1103


Linux since 1997 RedHat 4


View Profile
September 04, 2012, 11:40:22 AM
 #6904

Using 2.7.4.

The overheat function doesn't seem to be working right.  I have it set to 85.  Twice I've found it in the low 90s and not making any effort to shut down or cool down.

M
--temp-cutoff (default is 95)

This is in my cgminer.conf.  This isn't enough?

"temp-cutoff" : "90",
"temp-overheat" : "85",
"temp-target" : "75",

M
The line of code related to that specifically says if the temp is above temp-cutoff it will change the device status to RECOVERING.
That's why I suggested that.
It will show the device status as 'REST' and give a message as below.
It also requires both --auto-gpu and --auto-fan
It also requires ADL working - which you will see via the GPU showing it's temperature.
Code:
       if (engine && ga->autoengine) {
                if (temp > cgpu->cutofftemp) {
                        applog(LOG_WARNING, "Hit thermal cutoff limit on GPU %d, disabling!", gpu);
                        *denable = DEV_RECOVER;
                        newengine = ga->minspeed;

                        cgpu->device_last_not_well = time(NULL);
                        cgpu->device_not_well_reason = REASON_DEV_THERMAL_CUTOFF;
                        cgpu->dev_thermal_cutoff_count++;

Edit: of course if there is a bug and it's not working as expected in the current 2.7.5 - yep we'll need to chase it down and fix it.

Pool: https://kano.is Here on Bitcointalk: Forum BTC: 1KanoPb8cKYqNrswjaA8cRDk4FAS9eDMLU
FreeNode IRC: irc.freenode.net channel #kano.is Majority developer of the ckpool code
Help keep Bitcoin secure by mining on pools with full block verification on all blocks - and NO empty blocks!
Roland68
Member
**
Offline Offline

Activity: 103
Merit: 10



View Profile
September 04, 2012, 12:12:16 PM
 #6905

it's working nicely in 2.7.4 ... don't know in 2.7.5
mdude77
Legendary
*
Offline Offline

Activity: 1540
Merit: 1001



View Profile
September 04, 2012, 04:17:05 PM
 #6906

Using 2.7.4.

The overheat function doesn't seem to be working right.  I have it set to 85.  Twice I've found it in the low 90s and not making any effort to shut down or cool down.

M
--temp-cutoff (default is 95)

This is in my cgminer.conf.  This isn't enough?

"temp-cutoff" : "90",
"temp-overheat" : "85",
"temp-target" : "75",

M

Is the fan working? How many mining threads do you have running?  What is the status and the temperature displayed in the main cgminer window?

Fan's working.

Two threads.

cgminer is happily mining away, listing it at 92C when I find it.  No indication it found anything wrong.  Fan no higher than the 60% I left it at.

M

I mine at Kano's Pool because it pays the best and is completely transparent!  Come join me!
crazyates
Legendary
*
Offline Offline

Activity: 952
Merit: 1000



View Profile
September 04, 2012, 04:20:53 PM
 #6907

Fan no higher than the 60% I left it at.

M

Why only 60% fan? You might need to bump that a little higher.

Tips? 1crazy8pMqgwJ7tX7ZPZmyPwFbc6xZKM9
Previous Trade History - Sale Thread
ralree
Hero Member
*****
Offline Offline

Activity: 518
Merit: 500


Manateeeeeeees


View Profile
September 04, 2012, 05:01:39 PM
 #6908

My reject rates have gone to almost 2% according to cgminer after going from 2.7.0 -> 2.7.5.  The weird part is my pool (bitminter) has them at 0, so that's a plus.  How can I figure out what's happening here?

cgminer seems to be reporting lots of Duplicates (many more than usual).

1MANaTeEZoH4YkgMYz61E5y4s9BYhAuUjG
mdude77
Legendary
*
Offline Offline

Activity: 1540
Merit: 1001



View Profile
September 04, 2012, 05:29:36 PM
 #6909

Fan no higher than the 60% I left it at.

M

Why only 60% fan? You might need to bump that a little higher.

I don't run any of my GPUs above 60%.  All but this one do just fine between 50 and 60%.  Most run in a very cooled environment (air conditioning blowing right on them), "free" from any chasis with a box fan blowing on them.  They usually run high 60s, low 70s.  This one is in my main workstation, which has cooling issues.  Usually 60% is fine, sometimes I can do 50-55% w/o a problem.  However, twice recently I found it in the low 90s, and cgminer seemed oblivious to it, even though it clearly showed the temp on the screen in cgminer.

M


I mine at Kano's Pool because it pays the best and is completely transparent!  Come join me!
crazyates
Legendary
*
Offline Offline

Activity: 952
Merit: 1000



View Profile
September 04, 2012, 06:02:15 PM
 #6910

Fan no higher than the 60% I left it at.

M

Why only 60% fan? You might need to bump that a little higher.

I don't run any of my GPUs above 60%.  All but this one do just fine between 50 and 60%.  Most run in a very cooled environment (air conditioning blowing right on them), "free" from any chasis with a box fan blowing on them.  They usually run high 60s, low 70s.  This one is in my main workstation, which has cooling issues.  Usually 60% is fine, sometimes I can do 50-55% w/o a problem.  However, twice recently I found it in the low 90s, and cgminer seemed oblivious to it, even though it clearly showed the temp on the screen in cgminer.

M


Well there you go. You just answered your own question. If all your caseless, air conditioned GPUs do fine with 60% fan, but your workstation GPU (which has cooling issues) isn't fine with 60%, then I say again, bump up the fan speed! "--auto-fan --gpu-fan 25-75".

Tips? 1crazy8pMqgwJ7tX7ZPZmyPwFbc6xZKM9
Previous Trade History - Sale Thread
mdude77
Legendary
*
Offline Offline

Activity: 1540
Merit: 1001



View Profile
September 04, 2012, 07:48:45 PM
 #6911

Quote
I don't run any of my GPUs above 60%.  All but this one do just fine between 50 and 60%.  Most run in a very cooled environment (air conditioning blowing right on them), "free" from any chasis with a box fan blowing on them.  They usually run high 60s, low 70s.  This one is in my main workstation, which has cooling issues.  Usually 60% is fine, sometimes I can do 50-55% w/o a problem.  However, twice recently I found it in the low 90s, and cgminer seemed oblivious to it, even though it clearly showed the temp on the screen in cgminer.

M

Well there you go. You just answered your own question. If all your caseless, air conditioned GPUs do fine with 60% fan, but your workstation GPU (which has cooling issues) isn't fine with 60%, then I say again, bump up the fan speed! "--auto-fan --gpu-fan 25-75".

My question wasn't why it's overheating, my question was why didn't cgminer shut down when it exceeded my threshold?  Obviously I can speed the fan up, and obviously I don't want to otherwise I would!!

M

I mine at Kano's Pool because it pays the best and is completely transparent!  Come join me!
TheHarbinger
Sr. Member
****
Offline Offline

Activity: 378
Merit: 250


Why is it so damn hot in here?


View Profile
September 04, 2012, 07:58:16 PM
 #6912

Quote
I don't run any of my GPUs above 60%.  All but this one do just fine between 50 and 60%.  Most run in a very cooled environment (air conditioning blowing right on them), "free" from any chasis with a box fan blowing on them.  They usually run high 60s, low 70s.  This one is in my main workstation, which has cooling issues.  Usually 60% is fine, sometimes I can do 50-55% w/o a problem.  However, twice recently I found it in the low 90s, and cgminer seemed oblivious to it, even though it clearly showed the temp on the screen in cgminer.

M

Well there you go. You just answered your own question. If all your caseless, air conditioned GPUs do fine with 60% fan, but your workstation GPU (which has cooling issues) isn't fine with 60%, then I say again, bump up the fan speed! "--auto-fan --gpu-fan 25-75".

My question wasn't why it's overheating, my question was why didn't cgminer shut down when it exceeded my threshold?  Obviously I can speed the fan up, and obviously I don't want to otherwise I would!!

M

It's overheating because you don't have auto-fan and auto-gpu turned on.  You have told cgminer to run your GPU at a set clock speed, with a set fan speed, and that's exactly what it's doing.  It will happily continue to do so until you GPU bursts into flame. The temp settings don't mean anything if you aren't allowing cgminer to control the temperature.

Just another case of operator error.

12Um6jfDE7q6crm1s6tSksMvda8s1hZ3Vj
The00Dustin
Hero Member
*****
Offline Offline

Activity: 807
Merit: 500


View Profile
September 04, 2012, 08:03:40 PM
 #6913

It's overheating because you don't have auto-fan and auto-gpu turned on.  You have told cgminer to run your GPU at a set clock speed, with a set fan speed, and that's exactly what it's doing.  It will happily continue to do so until you GPU bursts into flame. The temp settings don't mean anything if you aren't allowing cgminer to control the temperature.

Just another case of operator error.
To clarify, you need something like this:
--auto-gpu --temp-cutoff <temp> --gpu-engine <MHz> --gpu-memclock <MHz> --gpu-fan <%>

Note that all of the values in <>'s are chosen by you and can be set or ranges, so in this case, --gpu-fan could be 60 or 50-60.  I don't remember exactly what --temp-cutoff does, so you might want to set it a few degrees cooler than you think you should, but it sounds like you have plenty of room to experiment without damaging your card.
Roland68
Member
**
Offline Offline

Activity: 103
Merit: 10



View Profile
September 04, 2012, 08:05:25 PM
 #6914

using the provided example.cfg file would help ...just cut/paste auto settings into your cfg file ...
kano
Legendary
*
Offline Offline

Activity: 2730
Merit: 1103


Linux since 1997 RedHat 4


View Profile
September 04, 2012, 09:29:04 PM
 #6915

...
It's overheating because you don't have auto-fan and auto-gpu turned on.  You have told cgminer to run your GPU at a set clock speed, with a set fan speed, and that's exactly what it's doing.  It will happily continue to do so until you GPU bursts into flame. The temp settings don't mean anything if you aren't allowing cgminer to control the temperature.

Just another case of operator error.
Made me laugh Smiley
Yes that is correct of course Smiley

Pool: https://kano.is Here on Bitcointalk: Forum BTC: 1KanoPb8cKYqNrswjaA8cRDk4FAS9eDMLU
FreeNode IRC: irc.freenode.net channel #kano.is Majority developer of the ckpool code
Help keep Bitcoin secure by mining on pools with full block verification on all blocks - and NO empty blocks!
mdude77
Legendary
*
Offline Offline

Activity: 1540
Merit: 1001



View Profile
September 04, 2012, 10:40:07 PM
 #6916

Quote
It's overheating because you don't have auto-fan and auto-gpu turned on.  You have told cgminer to run your GPU at a set clock speed, with a set fan speed, and that's exactly what it's doing.  It will happily continue to do so until you GPU bursts into flame. The temp settings don't mean anything if you aren't allowing cgminer to control the temperature.

Just another case of operator error.


Okay, let's start over again.

My cgminer.cfg clearly states, as I said a few posts back:

Code:
"gpu-engine" : "0-1125",
"gpu-fan" : "0-55",
"gpu-memdiff" : "0",
"gpu-powertune" : "0",
"gpu-vddc" : "0.870",
"temp-cutoff" : "90",
"temp-overheat" : "85",
"temp-target" : "75",

Where is the problem?  Is the config file missing something, or do I need to add more parms to the command line?  Note that I didn't put any of these lines in here, cgminer wrote them when I told it to create a .cfg.  All I did was change some parms.  It's a bit misleading for these parms to be here and do nothing.  Specifically the temp-cutoff part, I would think that means, well, when it reaches that temperature, it stops dead in the water.

And, I would hope the internal shutdown on the GPU would prevent it from bursting into flame.

BTW, thanks for the sarcastic help.  Much appreciated.

M

I mine at Kano's Pool because it pays the best and is completely transparent!  Come join me!
crazyates
Legendary
*
Offline Offline

Activity: 952
Merit: 1000



View Profile
September 04, 2012, 10:46:30 PM
 #6917

Quote
It's overheating because you don't have auto-fan and auto-gpu turned on.  You have told cgminer to run your GPU at a set clock speed, with a set fan speed, and that's exactly what it's doing.  It will happily continue to do so until you GPU bursts into flame. The temp settings don't mean anything if you aren't allowing cgminer to control the temperature.

Just another case of operator error.


Okay, let's start over again.

My cgminer.cfg clearly states, as I said a few posts back:

Code:
"gpu-engine" : "0-1125",
"gpu-fan" : "0-55",
"gpu-memdiff" : "0",
"gpu-powertune" : "0",
"gpu-vddc" : "0.870",
"temp-cutoff" : "90",
"temp-overheat" : "85",
"temp-target" : "75",

Where is the problem?  Is the config file missing something, or do I need to add more parms to the command line?  Note that I didn't put any of these lines in here, cgminer wrote them when I told it to create a .cfg.  All I did was change some parms.  It's a bit misleading for these parms to be here and do nothing.  Specifically the temp-cutoff part, I would think that means, well, when it reaches that temperature, it stops dead in the water.

And, I would hope the internal shutdown on the GPU would prevent it from bursting into flame.

BTW, thanks for the sarcastic help.  Much appreciated.

M

We're not being sarcastic. You need the --auto-gpu and --auto-fan options, and you've been told this many times! In the config, it would look like this:

Code:
"auto-gpu" : true,
"auto-fan" : true,

My grandfather has a saying: When 3 people tell you you're drunk, you better sit down.

Tips? 1crazy8pMqgwJ7tX7ZPZmyPwFbc6xZKM9
Previous Trade History - Sale Thread
kano
Legendary
*
Offline Offline

Activity: 2730
Merit: 1103


Linux since 1997 RedHat 4


View Profile
September 04, 2012, 10:52:29 PM
 #6918

Yeah I mentioned that at the start also
https://bitcointalk.org/index.php?topic=28402.msg1158935#msg1158935

Though I did add the edit back then saying if there was a bug it would need following up just in case I was wrong.

I guess that comment about --auto-gpu --auto-fan has been missed each time?

Pool: https://kano.is Here on Bitcointalk: Forum BTC: 1KanoPb8cKYqNrswjaA8cRDk4FAS9eDMLU
FreeNode IRC: irc.freenode.net channel #kano.is Majority developer of the ckpool code
Help keep Bitcoin secure by mining on pools with full block verification on all blocks - and NO empty blocks!
mdude77
Legendary
*
Offline Offline

Activity: 1540
Merit: 1001



View Profile
September 04, 2012, 11:28:27 PM
 #6919

We're not being sarcastic. You need the --auto-gpu and --auto-fan options, and you've been told this many times! In the config, it would look like this:

Code:
"auto-gpu" : true,
"auto-fan" : true,

Alright, twice someone has said to use parms, this is the first time someone said to add it to the config file.  I'll adjust it now.

What this means is the lines in the config file, written by cgminer, are misleading, as they don't do a thing unless you tweak it.  Which is fine..

Quote
My grandfather has a saying: When 3 people tell you you're drunk, you better sit down.

If this isn't sarcasm, and "another case of operator error", what is?

M

I mine at Kano's Pool because it pays the best and is completely transparent!  Come join me!
mdude77
Legendary
*
Offline Offline

Activity: 1540
Merit: 1001



View Profile
September 04, 2012, 11:31:55 PM
Last edit: September 05, 2012, 12:00:31 AM by mdude77
 #6920

Yeah I mentioned that at the start also
https://bitcointalk.org/index.php?topic=28402.msg1158935#msg1158935

Though I did add the edit back then saying if there was a bug it would need following up just in case I was wrong.

I guess that comment about --auto-gpu --auto-fan has been missed each time?

No, I saw it, and I already changed my command line to include it.  Someone else, might have been you, to add the cutoff, which was already in the config.

What was tripping me up was the lines in the config that I didn't put there, and someone telling me to add the temp cutoff line.

Thanks for the assistance.

M

EDIT: It occurred to me after I wrote this that the auto-gpu and auto-fan lines might have been in the config file to begin with, and I might have removed them.  That of course would lead to this situation.  I don't recall doing so, but that doesn't mean it didn't happen.

I mine at Kano's Pool because it pays the best and is completely transparent!  Come join me!
Pages: « 1 ... 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 [346] 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 ... 844 »
  Print  
 
Jump to:  

Bitcointalk.org is not available or authorized for sale. Do not believe any fake listings.
Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!