Bitcoin Forum
December 03, 2016, 03:57:34 PM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: « 1 ... 591 592 593 594 595 596 597 598 599 600 601 602 603 604 605 606 607 608 609 610 611 612 613 614 615 616 617 618 619 620 621 622 623 624 625 626 627 628 629 630 631 632 633 634 635 636 637 638 639 640 [641] 642 643 644 645 646 647 648 649 650 651 652 653 654 655 656 657 658 659 660 661 662 663 664 665 666 667 668 669 670 671 672 673 674 675 676 677 678 679 680 681 682 683 684 685 686 687 688 689 690 691 ... 830 »
  Print  
Author Topic: OFFICIAL CGMINER mining software thread for linux/win/osx/mips/arm/r-pi 4.9.2  (Read 4815265 times)
This is a self-moderated topic. If you do not want to be moderated by the person who started this topic, create a new topic.
ksenter
Member
**
Offline Offline

Activity: 90


View Profile
October 15, 2013, 01:49:44 AM
 #12801

In case it helps you.  I just got a LOT of this on the newest version after running for a few hours:

[2013-10-14 20:55:37] BAL 0 usb write err:(-11) LIBUSB_ERROR_NO_MEM
 [2013-10-14 20:55:37] BAL0: RequestQueJob failed (err=-11 amt=0)
 [2013-10-14 20:55:37] BAL 0 usb write err:(-11) LIBUSB_ERROR_NO_MEM
 [2013-10-14 20:55:37] BAL0: RequestResults failed (err=-11 amt=0)
 [2013-10-14 20:55:37] BAL 0 usb write err:(-11) LIBUSB_ERROR_NO_MEM
 [2013-10-14 20:55:37] BAL0: RequestResults failed (err=-11 amt=0)
 [2013-10-14 20:55:37] BAL 0 usb write err:(-11) LIBUSB_ERROR_NO_MEM
 [2013-10-14 20:55:37] BAL0: RequestResults failed (err=-11 amt=0)
 [2013-10-14 20:55:37] BAL 0 usb write err:(-11) LIBUSB_ERROR_NO_MEM
 [2013-10-14 20:55:37] BAL0: RequestQueJob failed (err=-11 amt=0)
 [2013-10-14 20:55:37] BAL 0 usb write err:(-11) LIBUSB_ERROR_NO_MEM
 [2013-10-14 20:55:37] BAL0: RequestResults failed (err=-11 amt=0)
 [2013-10-14 20:55:37] BAL 0 usb write err:(-11) LIBUSB_ERROR_NO_MEM
 [2013-10-14 20:55:37] BAL0: RequestResults failed (err=-11 amt=0)
 [2013-10-14 20:55:38] BAL 0 usb write err:(-11) LIBUSB_ERROR_NO_MEM
 [2013-10-14 20:55:38] BAL0: Error: Request temp invalid/timed out (0:-11)
 [2013-10-14 20:55:38] BAL 0 usb write err:(-11) LIBUSB_ERROR_NO_MEM
 [2013-10-14 20:55:38] BAL0: RequestResults failed (err=-11 amt=0)
 [2013-10-14 20:55:38] BAL 0 usb write err:(-11) LIBUSB_ERROR_NO_MEM
 [2013-10-14 20:55:38] BAL0: RequestQueJob failed (err=-11 amt=0)
 [2013-10-14 20:55:38] BAL 0 usb write err:(-11) LIBUSB_ERROR_NO_MEM
 [2013-10-14 20:55:38] BAL0: RequestResults failed (err=-11 amt=0)
 [2013-10-14 20:55:38] BAL 0 usb write err:(-11) LIBUSB_ERROR_NO_MEM
 [2013-10-14 20:55:38] BAL0: RequestResults failed (err=-11 amt=0)
 [2013-10-14 20:55:38] BAL 0 usb write err:(-11) LIBUSB_ERROR_NO_MEM
 [2013-10-14 20:55:38] BAL0: RequestQueJob failed (err=-11 amt=0)
 [2013-10-14 20:55:38] BAL 0 usb write err:(-11) LIBUSB_ERROR_NO_MEM
1480780654
Hero Member
*
Offline Offline

Posts: 1480780654

View Profile Personal Message (Offline)

Ignore
1480780654
Reply with quote  #2

1480780654
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480780654
Hero Member
*
Offline Offline

Posts: 1480780654

View Profile Personal Message (Offline)

Ignore
1480780654
Reply with quote  #2

1480780654
Report to moderator
1480780654
Hero Member
*
Offline Offline

Posts: 1480780654

View Profile Personal Message (Offline)

Ignore
1480780654
Reply with quote  #2

1480780654
Report to moderator
1480780654
Hero Member
*
Offline Offline

Posts: 1480780654

View Profile Personal Message (Offline)

Ignore
1480780654
Reply with quote  #2

1480780654
Report to moderator
mdude77
Legendary
*
Offline Offline

Activity: 1358


View Profile
October 15, 2013, 01:50:23 AM
 #12802

In case it helps you.  I just got a LOT of this on the newest version after running for a few hours:

[2013-10-14 20:55:37] BAL 0 usb write err:(-11) LIBUSB_ERROR_NO_MEM
 [2013-10-14 20:55:37] BAL0: RequestQueJob failed (err=-11 amt=0)
 [2013-10-14 20:55:37] BAL 0 usb write err:(-11) LIBUSB_ERROR_NO_MEM
 [2013-10-14 20:55:37] BAL0: RequestResults failed (err=-11 amt=0)

That's the one I got too.

M

MMinerMonitor author, monitor/auto/schedule reboots/alerts/remote/MobileMiner for Ants and Spondoolies! Latest (5.2). MPoolMonitor author, monitor stats/workers for most pools, global BTC stats (current/nxt diff/USD val/hashrate/calc)! Latest (v4.2) 
Buyer beware of Bitmain hardware and services.
-ck
Moderator
Legendary
*
Offline Offline

Activity: 1988


Ruu \o/


View Profile WWW
October 15, 2013, 01:52:50 AM
 #12803

In case it helps you.  I just got a LOT of this on the newest version after running for a few hours:

[2013-10-14 20:55:37] BAL 0 usb write err:(-11) LIBUSB_ERROR_NO_MEM
 [2013-10-14 20:55:37] BAL0: RequestQueJob failed (err=-11 amt=0)
 [2013-10-14 20:55:37] BAL 0 usb write err:(-11) LIBUSB_ERROR_NO_MEM
 [2013-10-14 20:55:37] BAL0: RequestResults failed (err=-11 amt=0)

That's the one I got too.

M
Did either of you try the experimental binaries I listed above?

This suggests a memory leak within the windows specific part of the libusb code. Anyway now that timeouts are managed differently it means we can try libusbx instead of libusb, so I'm putting up some testing binaries that use it. Please try them, but I'm not holding much to hope.

http://ck.kolivas.org/apps/cgminer/temp/

Primary developer/maintainer for cgminer and ckpool/ckproxy.
Pooled mine at kano.is, solo mine at solo.ckpool.org
-ck
ksenter
Member
**
Offline Offline

Activity: 90


View Profile
October 15, 2013, 01:57:58 AM
 #12804

Trying it now.  I'll let you know if it crashes.  Unless I'm asleep by then. Smiley

Edit: BTW, I just downloaded cgminer-nogpu.exe and libusb-1.0.dll and dropped them in the 3.6.1 folder.  Is that good enough, or do I need all the files?
ksenter
Member
**
Offline Offline

Activity: 90


View Profile
October 15, 2013, 01:08:13 PM
 #12805

Btw, it ran all night.  So far so good.
btc6000
Member
**
Offline Offline

Activity: 115


View Profile
October 15, 2013, 01:38:36 PM
 #12806

Hi,

I'm currently mining with a BFL Jalapeno and CGMiner, and am also waiting for some BlueFury USBs to arrive. Will I be able to run both sets of hardware on the same box with one instance of CGMiner?

Cheers

We have come to be one of the worst ruled, one of the most completely controlled and dominated, governments in the civilized world—no longer a government by free opinion, no longer a government by conviction and the vote of the majority, but a government by the opinion and the duress of small groups of dominant men.
wolfskill
Jr. Member
*
Offline Offline

Activity: 36


View Profile
October 15, 2013, 02:22:33 PM
 #12807

I updated those files from last night and my BFL 30gh miner has been running without the error.


WolfSkill
SpaceCadet
Full Member
***
Offline Offline

Activity: 164


Just mining my own business...


View Profile
October 15, 2013, 02:33:03 PM
 #12808

I had a different issue with 3.6.1 that I haven't seen before.  I'm running win7-x64 with 9 BEs (no GPU) and when I got up this morning, cgminer was locked up (no errors showing in the window, and I forgot to note the run duration before windows reported the app had crashed).  I went back to 3.5.1 for now, and will try the test code when I get a chance. 

I'm also running a cpu miner in one window for SRC, and cgminer 3.3.1 to drive the GPU on a script coin (it ignores the BEs), so there may be some conflicts there (even though 3.5.1 runs without issue - well, the timeout errors, but those done seem to affect performance too much).  Also, another box running 3 BEs on 3.6.1 (win7-32) did not have the same issue.

Just an info report...

ineedit
Sr. Member
****
Offline Offline

Activity: 252


View Profile
October 15, 2013, 02:56:11 PM
 #12809


Hi Guys,

I am re-compiling on Windows to get ready for some Bitfury's that should appear soon but I have run into problems with make. I can successfully compile and run cgminer versions up to 3.3.3 but after that all versions to 3.5.1 consistently fail with

"ws2tcpip.h is not compatible with winsock.h. Include winsock2.h instead."

There are a number of fixes around the Interweb but I would rather use the same fix that you guys must be using to build the exe's. I am using the same versions of mingw, gtk, etc as per the windows build doc and follow the guide without problems for versions to 3.3.3, all builds are clean onto a fresh Win 7 VM.




As an aside I am also noticing differences in the dll's included in the exe distro against those required from the windows build doc, not a biggie but something that needs to be added to a tidy up list at some point.

If I have been help then please show your thanks         BTC: 127PRogAVZiV3fEmpJERh9KemK3a3Ffh6G         LTC: LXghFL8mZffpTFkm2nRTesuDrV5DJQP3Js
os2sam
Legendary
*
Offline Offline

Activity: 1918


Think for yourself


View Profile
October 15, 2013, 02:58:16 PM
 #12810

I am re-compiling on Windows to get ready for some Bitfury's

The precompiled Windoze binaries don't work?

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing on usenet and in e-mail?
ineedit
Sr. Member
****
Offline Offline

Activity: 252


View Profile
October 15, 2013, 03:11:48 PM
 #12811

I am re-compiling on Windows to get ready for some Bitfury's

The precompiled Windoze binaries don't work?

The pre-compiled exe's work fine, but it is open source and I like to compile my own for a number of various reasons.

If I have been help then please show your thanks         BTC: 127PRogAVZiV3fEmpJERh9KemK3a3Ffh6G         LTC: LXghFL8mZffpTFkm2nRTesuDrV5DJQP3Js
os2sam
Legendary
*
Offline Offline

Activity: 1918


Think for yourself


View Profile
October 15, 2013, 03:20:33 PM
 #12812

I am re-compiling on Windows to get ready for some Bitfury's

The precompiled Windoze binaries don't work?

The pre-compiled exe's work fine, but it is open source and I like to compile my own for a number of various reasons.

OK, that's cool.

I'm guessing you already looked in the windows-build file?

I'll just shut up now. Smiley
Good Luck,
Sam

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing on usenet and in e-mail?
Aurum
Sr. Member
****
Offline Offline

Activity: 441


Ego auri metalla, ergo sum


View Profile WWW
October 15, 2013, 03:30:29 PM
 #12813

3.6.1 isn't working for me.  (win7x64 - 33 usb block erupters).   I let it run for a while, then it stopped mining, repeatedly saying something like USB write error_no_mem.

I tried to copy/paste the error but lost it.  I can get it again if need be.
And FFS LOL windows. Always with the new and exciting modes of failure. This suggests a memory leak within the windows specific part of the libusb code. Anyway now that timeouts are managed differently it means we can try libusbx instead of libusb, so I'm putting up some testing binaries that use it. Please try them, but I'm not holding much to hope.

http://ck.kolivas.org/apps/cgminer/temp/
I replaced cgminer-nogpu.exe with the one in the above temp folder. I get ever increasing lines of:
AMU 0 usb write err:(-7) LIBUSB_ERROR_TIMEOUT

techman05
Hero Member
*****
Offline Offline

Activity: 546


View Profile WWW
October 15, 2013, 04:02:59 PM
 #12814

Should 3.6.1 be working? I've had it on for maybe 1 Minute with no errors showing on windows 7.

I'm using block eroupters if that makes any difference.

Like the info address for potential tips Wink
BTC 1CL5BnNhdL2wDVmSDwMbW1cNhZew87CAPV
* http://www.miningrigrentals.com/register?ref=563
ineedit
Sr. Member
****
Offline Offline

Activity: 252


View Profile
October 15, 2013, 04:51:29 PM
 #12815

I am re-compiling on Windows to get ready for some Bitfury's

The precompiled Windoze binaries don't work?

The pre-compiled exe's work fine, but it is open source and I like to compile my own for a number of various reasons.

OK, that's cool.

I'm guessing you already looked in the windows-build file?

I'll just shut up now. Smiley
Good Luck,
Sam

NP Sam  Smiley

The problem been around a while and I have not found the answer in this thread or any of the build docs, etc. I was trying to stay out of the dev's way until I really started to need it as they have been very busy doing all this fantastic work on ASIC support.

If I have been help then please show your thanks         BTC: 127PRogAVZiV3fEmpJERh9KemK3a3Ffh6G         LTC: LXghFL8mZffpTFkm2nRTesuDrV5DJQP3Js
techman05
Hero Member
*****
Offline Offline

Activity: 546


View Profile WWW
October 15, 2013, 05:20:32 PM
 #12816

wouldn't see so bad to report if git hub had report bugs option for cgminer on. then all the things you find wouldn't get buried over. This post is at least 600 pages deep Grin Grin Shocked .

Like the info address for potential tips Wink
BTC 1CL5BnNhdL2wDVmSDwMbW1cNhZew87CAPV
* http://www.miningrigrentals.com/register?ref=563
-ck
Moderator
Legendary
*
Offline Offline

Activity: 1988


Ruu \o/


View Profile WWW
October 15, 2013, 07:38:09 PM
 #12817

wouldn't see so bad to report if git hub had report bugs option for cgminer on. then all the things you find wouldn't get buried over. This post is at least 600 pages deep Grin Grin Shocked .
People were using it for support instead of bug reporting.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
Pooled mine at kano.is, solo mine at solo.ckpool.org
-ck
-ck
Moderator
Legendary
*
Offline Offline

Activity: 1988


Ruu \o/


View Profile WWW
October 15, 2013, 07:39:14 PM
 #12818

Should 3.6.1 be working? I've had it on for maybe 1 Minute with no errors showing on windows 7.

I'm using block eroupters if that makes any difference.
Current one runs out of memory eventually on windows. The binaries in temp/ are currently the best 3.6.1 working ones for windows.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
Pooled mine at kano.is, solo mine at solo.ckpool.org
-ck
-ck
Moderator
Legendary
*
Offline Offline

Activity: 1988


Ruu \o/


View Profile WWW
October 15, 2013, 07:41:48 PM
 #12819

Btw, it ran all night.  So far so good.
In that case it's definitely better. We may have to finally move libusb to libusbx then.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
Pooled mine at kano.is, solo mine at solo.ckpool.org
-ck
-ck
Moderator
Legendary
*
Offline Offline

Activity: 1988


Ruu \o/


View Profile WWW
October 15, 2013, 07:42:37 PM
 #12820

I replaced cgminer-nogpu.exe with the one in the above temp folder. I get ever increasing lines of:
AMU 0 usb write err:(-7) LIBUSB_ERROR_TIMEOUT
Odd. What hardware are you using?

Primary developer/maintainer for cgminer and ckpool/ckproxy.
Pooled mine at kano.is, solo mine at solo.ckpool.org
-ck
Pages: « 1 ... 591 592 593 594 595 596 597 598 599 600 601 602 603 604 605 606 607 608 609 610 611 612 613 614 615 616 617 618 619 620 621 622 623 624 625 626 627 628 629 630 631 632 633 634 635 636 637 638 639 640 [641] 642 643 644 645 646 647 648 649 650 651 652 653 654 655 656 657 658 659 660 661 662 663 664 665 666 667 668 669 670 671 672 673 674 675 676 677 678 679 680 681 682 683 684 685 686 687 688 689 690 691 ... 830 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!