Bitcoin Forum
January 20, 2019, 02:27:16 PM *
News: Latest Bitcoin Core release: 0.17.1 [Torrent]
 
   Home   Help Search Login Register More  
Pages: « 1 ... 598 599 600 601 602 603 604 605 606 607 608 609 610 611 612 613 614 615 616 617 618 619 620 621 622 623 624 625 626 627 628 629 630 631 632 633 634 635 636 637 638 639 640 641 642 643 644 645 646 647 [648] 649 650 651 652 653 654 655 656 657 658 659 660 661 662 663 664 665 666 667 668 669 670 671 672 673 674 675 676 677 678 679 680 681 682 683 684 685 686 687 688 689 690 691 692 693 694 695 696 697 698 ... 844 »
  Print  
Author Topic: OFFICIAL CGMINER mining software thread for linux/win/osx/mips/arm/r-pi 4.11.1  (Read 5771426 times)
This is a self-moderated topic. If you do not want to be moderated by the person who started this topic, create a new topic.
Krak
Hero Member
*****
Offline Offline

Activity: 591
Merit: 500



View Profile WWW
October 25, 2013, 06:03:37 PM
 #12941

腹切り
切腹


I put this in Google translate, and it said:

Belly cut ri
Seppuku

Are you threatening suicide here?

:O
Dealing with Windows can make anyone feel suicidal. He's obviously joking though. Tongue

BTC: 1KrakenLFEFg33A4f6xpwgv3UUoxrLPuGn
1547994436
Hero Member
*
Offline Offline

Posts: 1547994436

View Profile Personal Message (Offline)

Ignore
1547994436
Reply with quote  #2

1547994436
Report to moderator
1547994436
Hero Member
*
Offline Offline

Posts: 1547994436

View Profile Personal Message (Offline)

Ignore
1547994436
Reply with quote  #2

1547994436
Report to moderator
PLAY NOW
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1547994436
Hero Member
*
Offline Offline

Posts: 1547994436

View Profile Personal Message (Offline)

Ignore
1547994436
Reply with quote  #2

1547994436
Report to moderator
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2758
Merit: 1149


Ruu \o/


View Profile WWW
October 25, 2013, 08:46:22 PM
 #12942

Edit: 3 minutes later, first zombie just appeared. Sorry.
Run it in full debug mode storing the log somewhere until the zombies appear to see what it might be that provokes them.

i.e. start it with the extra commands: -D 2>log.txt
and send me the log.txt file.

Note that if, despite all the absurd extra code I put in, you are still having problems, it may not be code at all, so check connections, power cables, adequate power, OS etc.
Latest binaries are ok for last 4 hours for me. Still logging just in case.
By the way is that only me using --text-only to get proper debug.log?
That -D 2 > log.txt does not work in windows for me. Is there a way to log and keep console updating in windows?
PS. That was great to know about quotas Smiley
Note that "-D 2>log.txt" works in windows as well, and does not need to be in text only mode. Note also there is no space after the 2. However the windows log file might not flush until cgminer shuts down due to the way windows writes to files so it may look zero sized indefinitely.

Developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org, 1% Fee Solo mining at solo.ckpool.org
-ck
Trongersoll
Hero Member
*****
Offline Offline

Activity: 490
Merit: 500



View Profile
October 25, 2013, 09:04:36 PM
 #12943

can we manually edit the config file and have it still work? V3.3.1
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2758
Merit: 1149


Ruu \o/


View Profile WWW
October 25, 2013, 09:06:59 PM
 #12944

can we manually edit the config file and have it still work? V3.3.1
Of course. If you're lucky you can also hit restart and it will pick up the config changes and restart... though restart hasn't been entirely reliable for some versions (hopefully that will be fixed in the next version due out later today).

Developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org, 1% Fee Solo mining at solo.ckpool.org
-ck
Trongersoll
Hero Member
*****
Offline Offline

Activity: 490
Merit: 500



View Profile
October 25, 2013, 09:16:05 PM
 #12945

can we manually edit the config file and have it still work? V3.3.1
Of course. If you're lucky you can also hit restart and it will pick up the config changes and restart... though restart hasn't been entirely reliable for some versions (hopefully that will be fixed in the next version due out later today).

ok,thanks. can't hit restart. both my main and fallback pools are coming up unavailable. so i can either let it try every 15 sec.s or quit. Since i'm running ubuntu 12.4 i can't seem to upgrade to the newer versions. This was a case of "if it ain't broke..." Today it feels like everything i have is broke. Tongue
Karin
Member
**
Offline Offline

Activity: 109
Merit: 10



View Profile WWW
October 25, 2013, 09:20:22 PM
 #12946

Some Mac users are reporting to me that the latest Mac OS X update, codenamed Mavericks (10.9), sees their BFL Jalapeño devices no longer working with cgminer 3.6.4 and 3.3.4 (the last release of cgminer in my GUI named Asteroid).  This is the only relevant error message, and it repeats every 5 seconds or so:

Code:
BitForceSC detect (253:2) failed to initialise (incorrect device?)

I'm still gathering info and trying workarounds, but if you have any ideas on what to investigate further I'd be all ears.  I heard rumour that the code that Apple uses to interface with FTDI-based chipsets has been rewritten for Mavericks from the previous OS version, but I'm not entirely sure I even know what that means or implies.

Will keep looking...

Easiest to use bitcoin/litecoin miner for Mac: AsteroidApp.com | @AsteroidApp | Bitcointalk forum thread
Unofficial cgminer for Mac OS X | sgminer for Mac OS X
techman05
Hero Member
*****
Offline Offline

Activity: 546
Merit: 500


View Profile WWW
October 25, 2013, 09:31:01 PM
 #12947

腹切り
切腹

WOW   Shocked Shocked Shocked

Breath what ever he's got I don't want. I got 3.6.4 going for at least 2 days with no faults.

Have they at least restarted their computer in a while. I just recently cycled all my eroupters(cooled and pulled and re put in hub) and haven't seen this since last version.

Like the info address for potential tips Wink
BTC 1CL5BnNhdL2wDVmSDwMbW1cNhZew87CAPV
* http://www.miningrigrentals.com/register?ref=563
mdude77
Legendary
*
Offline Offline

Activity: 1540
Merit: 1001



View Profile
October 25, 2013, 09:53:31 PM
 #12948

TeckNet USB3.0 hub, BFL Jala 7.5GH, 8 BEs, Win7 x64, got zombied BEs few times. Was ok with 3.5.1.
Did you try experimental .exes in the temp directory? Some fixes there.
Tried, zombies with them too. All 3.6.x has this issue.
* ckolivas laughs hysterically as he completely loses his marbles

I can't believe it. I spend ages fixing a billion problems with windows for some people, and somehow the solution presents a problem in windows for someone else...

Try newer exes just uploaded in temp directory please.

I think it's very hardware relative.  3.6.4 works fine for me on one machine, gives zombies and errors on another one.  The 2nd one is significantly newer and more powerful.

M

I mine at Kano's Pool because it pays the best and is completely transparent!  Come join me!
aigeezer
Legendary
*
Online Online

Activity: 1439
Merit: 1010


Cryptanalyst castrated by his government, 1952


View Profile
October 25, 2013, 10:17:08 PM
 #12949

Edit: 3 minutes later, first zombie just appeared. Sorry.
Run it in full debug mode storing the log somewhere until the zombies appear to see what it might be that provokes them.

i.e. start it with the extra commands: -D 2>log.txt
and send me the log.txt file.

Note that if, despite all the absurd extra code I put in, you are still having problems, it may not be code at all, so check connections, power cables, adequate power, OS etc.
Latest binaries are ok for last 4 hours for me. Still logging just in case.
By the way is that only me using --text-only to get proper debug.log?
That -D 2 > log.txt does not work in windows for me. Is there a way to log and keep console updating in windows?
PS. That was great to know about quotas Smiley
Note that "-D 2>log.txt" works in windows as well, and does not need to be in text only mode. Note also there is no space after the 2. However the windows log file might not flush until cgminer shuts down due to the way windows writes to files so it may look zero sized indefinitely.

It's getting interesting.

I took one machine back to 3.1.1 and it has had no zombies for three hours. It probably would have had at least one by now when running 3.5 or 3.6.

I rebooted and started logging on the other machine, still using 3.6.4. with your new exe temporary fixes. It has had no zombies since. It almost certainly would have had a couple by now without the log running!

Speculation: Of course a zombie might show up at any moment but for now this feels like it might be a timing issue. Might the old (relatively inefficient?) 3.1.1 and the overhead of logging each slow some component enough to keep it from timing out?

I'll post if the log catches a zombie, but no news is good news for now.

Issue that is probably unrelated, but perhaps worth mentioning - Slush's pool has been having issues today. Whenever I've been getting zombies I've been connected to that pool but these new zombie-free runs happen to be using BTCGuild. Probably coincidence, but one more variable, I'm afraid.

techman05
Hero Member
*****
Offline Offline

Activity: 546
Merit: 500


View Profile WWW
October 25, 2013, 10:22:01 PM
 #12950

Thats been my side assumtion that were getting funky shares cgminer isn't built to handle. I switched to bitminter from btcGuild and that's where my fun was for a while.

Did you specify which os your using? At least for the record.

Like the info address for potential tips Wink
BTC 1CL5BnNhdL2wDVmSDwMbW1cNhZew87CAPV
* http://www.miningrigrentals.com/register?ref=563
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2758
Merit: 1149


Ruu \o/


View Profile WWW
October 25, 2013, 10:23:47 PM
 #12951

3.1.1 doesn't talk usb but serial to those devices, so absolutely none of the rules apply comparing that version with the current cgminer. A zombie implies the usb effectively got disconnected at some stage. I'm just trying to find the mode of failure, looking for the last usb error that cgminer reports before it zombifies it.

Developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org, 1% Fee Solo mining at solo.ckpool.org
-ck
aigeezer
Legendary
*
Online Online

Activity: 1439
Merit: 1010


Cryptanalyst castrated by his government, 1952


View Profile
October 25, 2013, 10:37:42 PM
Last edit: October 26, 2013, 11:54:10 AM by aigeezer
 #12952

3.1.1 doesn't talk usb but serial to those devices, so absolutely none of the rules apply comparing that version with the current cgminer. A zombie implies the usb effectively got disconnected at some stage. I'm just trying to find the mode of failure, looking for the last usb error that cgminer reports before it zombifies it.

OK, I get it now - my 3.1.1 test won't help you at all. As a user though, my temporary fix for zombies is to go back to a stable 3.1.1 when I need to, for example if I'm leaving a machine unattended for a long time.

What do you make of the "no zombies while logging" phenomenon? It could of course be just coincidence but it's still going on. I guess it won't prove anything if I turn logging off and quickly get a zombie as it might have happened anyway. I'll watch and wait some more. I wish I could be more helpful.

Edit: update after 14.5 hours running 3.6.4 with logging - no zombies, no anomalies, ran without incident. I think the act of logging serendipitously fixed whatever timing issues had been causing zombies. A debugger's nightmare, if true. The log file is now 747 meg, so I'll stop the run and get rid of it shortly. Time to try 3.6.6 in any case. Thanks!

-ck
Moderator
Legendary
*
Offline Offline

Activity: 2758
Merit: 1149


Ruu \o/


View Profile WWW
October 26, 2013, 04:31:11 AM
Last edit: October 26, 2013, 09:34:28 AM by ckolivas
 #12953

New release: Version 3.6.6 - 26th October 2013

A new stable release building on top of 3.6.4 that should be a safe upgrade path after the earlier unstable 3.6 releases. Please pay attention for the options have changed.


Human readable changelog:

3.6.6:
- Fix for avalon type hardware hanging

3.6.5:
- OpenCL now needs to be explicitly built into binaries with --enable-opencl; it is no longer built in by default (binaries built by me still include it).
- Updated the build to not install opencl kernels when cgminer is built without opencl.
- Added an option to build with the system libusb for when it's difficult to get all the dependencies built (like udev on MIPS) by using the --with-system-libusb option. NOTE: It is recommended to not use this option unless you cannot build udev on linux as the included libusb is the most stable  version.
- Updated klondike driver, now built into linux binary.
- Improvements to support for BitBurner boards.
- Lots of fixes for failures to shutdown and restart, including knowing about all USB transfers in flight and waiting till they're complete.
- Updated the read mechanism on slower USB devices: instead of polling regularly, cgminer can now wait the full length of time to get results (which can be as slow as 15 seconds on some icarus devices), but it can cancel these transfers immediately once a block change is detected. The advantage of this is much less wasted CPU time, and much faster response to block change - i.e. lower CPU when there are many devices, and lower rejects. Currently this feature has been added to bitfury sticks and icarus devices. The stabilising of async transfers in cgminer made this change possible.
- Timer updates on windows now using the native clocks and timers for higher accuracy timing and tighter control.
- Fixed a minor timer bug.
- Made one off I/O errors non fatal for devices now, so only if a device has repeated I/O errors will it consider the device dead.
- Buffering extra bytes message no longer shows up in verbose mode since it's a routine operation now.
- More information is now shown when a usb error occurs.
- miner.php updates
- api updates
- Lots of low level features added in preparation for newer drivers in development for upcoming hardware.


Full changelog:

3.6.6:
- Remove inappropriate extra locking in _usb_transfer_read

3.6.5:
- klondike - fix uninitialised dev bug
- Adjust the binary ntime data in submit_noffset_nonce even when there is no hex
ntime string for eg. gbt.
- Put an entry into the work struct telling drivers how much they can roll the
ntime themselves.
- Only set libusb cancellable status if the transfer succeeds.
- Remove the applog on miner threads dying to prevent deadlocks on exit.
- Do one extra guaranteed libusb event handling before testing if there are any
pending async usb transfers.
- Use a linked list for all usb transfers instead of just cancellable ones.
- Provide a mechanism for informing drivers of updated work templates for
stratum and gbt mining.
- Add cancellable transfers correctly to the ct_list
- Check for presence of thr in icarus get nonce for startup nonce testing to
work.
- Use cancellable usb transfers in the icarus driver to avoid having to loop and
poll when waiting for a response and to speed up work restart response time.
- Add a usb_read_ii_timeout_cancellable wrapper
- Add usb transfer cancellation on shutdown and documentation regarding where
cancellable transfers are suitable.
- Use cancellable transfers on bitfury device.
- Cancel cancellable usb transfers on work restart messages.
- Don't bother having a separate cancellable transfer struct for usb transfers,
simply include the list in the usb_transfer struct.
- Add wrappers for usb_read_cancellable and usb_read_timeout_cancellable
- Specifically set the cancellable state for it to not be uninitialised in the
usb transfer struct.
- Alter the usb cancellable list only under cgusb_fd_lock write lock.
- Pass the cancellable option to _usb_read options to decide on whether to add
usb transfers to the list of cancellable transfers.
- Create a linked list of potentially cancellable usb transfers.
- Don't attempt to disable curses or print a summary during an app restart to
prevent deadlocks.
- Keep the libusb event handle polling thread active until there are no async
usb transfers in progress.
- Keep a global counter of how many async usb transfers are in place.
- Perform libusb_submit_transfer under the write variant of cgusb_fd_lock
- klondike - error condition handling
- Avoid entering static libusb directory if --with-system-libusb is enabled.
- Minor opencl build corrections.
- Enable dynamic linking against system libusb --with-system-libusb
- Modify Makefile to only include opencl related code when configured in.
- Convert opencl to need to be explicitly enabled during build with
--enable-opencl
- Implement a cglock_destroy function.
- Implement a rwlock_destroy function.
- Implement a mutex_destroy function.
- Add usb command name to critical libusb error reporting.
- Use windows' own higher resolution time and handlers allowing us to have
higher precision absolute timeouts.
- Fix lldiv error in windows cgminer_t calculation.
- miner.php correct sort gen field names largest to smallest
- api ... the code related to device elapsed
- api add device elapsed since hotplug devices Elapsed is less than cgminer
Elapsed
- Drop usb buffering message to debug logging level.
- Do the ntime binary modification to the work struct when submitting an ntime
offset nonce within submit_noffset_nonce
- Code cleanup and improved documentation
- Improvements to support for BitBurner boards
- Convert libusb transfer errors to regular libusb error messages to allow for
accurate message reporting.

Developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org, 1% Fee Solo mining at solo.ckpool.org
-ck
ThinkFast
Member
**
Offline Offline

Activity: 69
Merit: 10


View Profile
October 26, 2013, 04:48:17 AM
 #12954

cgminer 3.6.5 in Windows XP SP3 using 7z pre-built downloaded from your site.

cgminer -o http://mint.bitminter.com:8332 -u xxxxxxx_xxx@xxx.com_RHD4850 -p xxxxxxxx -d 0 --auto-fan --auto-gpu -Q 2
Error opening terminal: xterm.

Env vars:
TERM=xterm

Not sure why Windows version would be trying to invoke 'xterm'. But I'm still new to Linux.
Miner-TE
Hero Member
*****
Offline Offline

Activity: 513
Merit: 500



View Profile
October 26, 2013, 04:57:41 AM
 #12955

cgminer 3.6.5 in Windows XP SP3 using 7z pre-built downloaded from your site.

cgminer -o http://mint.bitminter.com:8332 -u xxxxxxx_xxx@xxx.com_RHD4850 -p xxxxxxxx -d 0 --auto-fan --auto-gpu -Q 2
Error opening terminal: xterm.

Env vars:
TERM=xterm

Not sure why Windows version would be trying to invoke 'xterm'. But I'm still new to Linux.

Try the following command before running CGminer in a CMD window.

'Set TERM='

BTC - 1PeMMYGn7xbZjUYeaWe9ct1VV6szLS1vkD - LTC - LbtcJRJJQQBjZuHr6Wm7vtB9RnnWtRNYpq
ThinkFast
Member
**
Offline Offline

Activity: 69
Merit: 10


View Profile
October 26, 2013, 05:09:03 AM
 #12956

That fixed it. Thanks! Grin
Pontius
Full Member
***
Offline Offline

Activity: 225
Merit: 100


View Profile
October 26, 2013, 07:42:38 AM
 #12957

New v3.6.5 doesn't work for me, after start it hangs "forever" here:
Code:
[2013-10-26 09:36:34] Started cgminer 3.6.5

When starting with "-D" it will get me the same result - cgminer hangs just printing the above line. When shutting down with "Ctrl-C" it prints this:
Code:
[2013-10-26 09:37:54] BF1 looking for BF1 03eb:204b but found 1d6b:0001 instead
 [2013-10-26 09:37:54] USB scan devices: checking for AVA devices
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 152d:2336 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 152d:2336 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 152d:2336 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for and found BTB 0403:6001
 [2013-10-26 09:37:55] USB lock avalon 4-32
 [2013-10-26 09:37:55] RES: avalon (4:32) lock=1
 [2013-10-26 09:37:55] USB res lock avalon 4-32
 [2013-10-26 09:37:55] RES: avalon (4:32) lock ok=1
 [2013-10-26 09:37:55] USB init - BTB device 4:32 usbver=0200 prod='BitBurner' manuf='Burnin Electronics' serial='855'
 [2013-10-26 09:37:55] BTB0: reset got err 0
 [2013-10-26 09:37:55] BTB0: latency got err 0
 [2013-10-26 09:37:55] BTB0: data got err 0
 [2013-10-26 09:37:55] BTB0: setbaud got err 0
 [2013-10-26 09:37:55] BTB0: setmodemctrl got err 0
 [2013-10-26 09:37:55] BTB0: setflowctrl got err 0
 [2013-10-26 09:37:55] BTB0: setmodemctrl 2 got err 0
 [2013-10-26 09:37:55] BTB0: setflowctrl 2 got err 0
 [2013-10-26 09:38:34] Shutdown signal received.

With v3.4.3 or v3.6.4 I don't have this issue.
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2758
Merit: 1149


Ruu \o/


View Profile WWW
October 26, 2013, 07:44:30 AM
 #12958

New v3.6.5 doesn't work for me, after start it hangs "forever" here:
Code:
[2013-10-26 09:36:34] Started cgminer 3.6.5

When starting with "-D" it will get me the same result - cgminer hangs just printing the above line. When shutting down with "Ctrl-C" it prints this:
Code:
[2013-10-26 09:37:54] BF1 looking for BF1 03eb:204b but found 1d6b:0001 instead
 [2013-10-26 09:37:54] USB scan devices: checking for AVA devices
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 152d:2336 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 152d:2336 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 152d:2336 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for and found BTB 0403:6001
 [2013-10-26 09:37:55] USB lock avalon 4-32
 [2013-10-26 09:37:55] RES: avalon (4:32) lock=1
 [2013-10-26 09:37:55] USB res lock avalon 4-32
 [2013-10-26 09:37:55] RES: avalon (4:32) lock ok=1
 [2013-10-26 09:37:55] USB init - BTB device 4:32 usbver=0200 prod='BitBurner' manuf='Burnin Electronics' serial='855'
 [2013-10-26 09:37:55] BTB0: reset got err 0
 [2013-10-26 09:37:55] BTB0: latency got err 0
 [2013-10-26 09:37:55] BTB0: data got err 0
 [2013-10-26 09:37:55] BTB0: setbaud got err 0
 [2013-10-26 09:37:55] BTB0: setmodemctrl got err 0
 [2013-10-26 09:37:55] BTB0: setflowctrl got err 0
 [2013-10-26 09:37:55] BTB0: setmodemctrl 2 got err 0
 [2013-10-26 09:37:55] BTB0: setflowctrl 2 got err 0
 [2013-10-26 09:38:34] Shutdown signal received.

With v3.4.3 or v3.6.4 I don't have this issue.

Yep all those bitburner changes broke avalon builds. That will teach me to trust other people's code without testing it. Will have to fix it soon.

Developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org, 1% Fee Solo mining at solo.ckpool.org
-ck
Roy Badami
Hero Member
*****
Offline Offline

Activity: 564
Merit: 500


View Profile
October 26, 2013, 08:52:27 AM
 #12959

New v3.6.5 doesn't work for me, after start it hangs "forever" here:
Code:
[2013-10-26 09:36:34] Started cgminer 3.6.5

When starting with "-D" it will get me the same result - cgminer hangs just printing the above line. When shutting down with "Ctrl-C" it prints this:
Code:
[2013-10-26 09:37:54] BF1 looking for BF1 03eb:204b but found 1d6b:0001 instead
 [2013-10-26 09:37:54] USB scan devices: checking for AVA devices
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 152d:2336 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 152d:2336 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 152d:2336 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for and found BTB 0403:6001
 [2013-10-26 09:37:55] USB lock avalon 4-32
 [2013-10-26 09:37:55] RES: avalon (4:32) lock=1
 [2013-10-26 09:37:55] USB res lock avalon 4-32
 [2013-10-26 09:37:55] RES: avalon (4:32) lock ok=1
 [2013-10-26 09:37:55] USB init - BTB device 4:32 usbver=0200 prod='BitBurner' manuf='Burnin Electronics' serial='855'
 [2013-10-26 09:37:55] BTB0: reset got err 0
 [2013-10-26 09:37:55] BTB0: latency got err 0
 [2013-10-26 09:37:55] BTB0: data got err 0
 [2013-10-26 09:37:55] BTB0: setbaud got err 0
 [2013-10-26 09:37:55] BTB0: setmodemctrl got err 0
 [2013-10-26 09:37:55] BTB0: setflowctrl got err 0
 [2013-10-26 09:37:55] BTB0: setmodemctrl 2 got err 0
 [2013-10-26 09:37:55] BTB0: setflowctrl 2 got err 0
 [2013-10-26 09:38:34] Shutdown signal received.

With v3.4.3 or v3.6.4 I don't have this issue.


Pontius - what Avalon/Bitburner devices are you mining with?  What command line arguments are you using?
Pontius
Full Member
***
Offline Offline

Activity: 225
Merit: 100


View Profile
October 26, 2013, 09:15:13 AM
 #12960

Pontius - what Avalon/Bitburner devices are you mining with?  What command line arguments are you using?

Bitburner XX

Code:
cgminer -n
 [2013-10-26 11:06:02] USB all: found 9 devices - listing known devices
.USB dev 0: Bus 4 Device 32 ID: 0403:6001
  Manufacturer: 'Burnin Electronics'
  Product: 'BitBurner'                   
 [2013-10-26 11:06:02] 1 known USB devices

No command line options, everything is inside the ~/.cgminer/cgminer.conf:
Code:
{
    "api-listen"        :   true,
    "api-allow"         :   "W:127.0.0.1,172.16.8.0/23",
   
    "avalon-options"    :   "115200:4:10:d:372",
    "avalon-temp"       :   "40",
    "bitburner-voltage" :   "1170",
    "queue"             :   "4",
    "usb"               :   ":1",

    "load-balance"      :   true,
    "pools"             : [
        [...]
    ]
}
Pages: « 1 ... 598 599 600 601 602 603 604 605 606 607 608 609 610 611 612 613 614 615 616 617 618 619 620 621 622 623 624 625 626 627 628 629 630 631 632 633 634 635 636 637 638 639 640 641 642 643 644 645 646 647 [648] 649 650 651 652 653 654 655 656 657 658 659 660 661 662 663 664 665 666 667 668 669 670 671 672 673 674 675 676 677 678 679 680 681 682 683 684 685 686 687 688 689 690 691 692 693 694 695 696 697 698 ... 844 »
  Print  
 
Jump to:  

Bitcointalk.org is not available or authorized for sale. Do not believe any fake listings.
Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!