Bitcoin Forum
December 10, 2018, 09:14:59 PM *
News: Latest Bitcoin Core release: 0.17.0 [Torrent].
 
   Home   Help Search Login Register More  
Pages: « 1 ... 601 602 603 604 605 606 607 608 609 610 611 612 613 614 615 616 617 618 619 620 621 622 623 624 625 626 627 628 629 630 631 632 633 634 635 636 637 638 639 640 641 642 643 644 645 646 647 648 649 650 [651] 652 653 654 655 656 657 658 659 660 661 662 663 664 665 666 667 668 669 670 671 672 673 674 675 676 677 678 679 680 681 682 683 684 685 686 687 688 689 690 691 692 693 694 695 696 697 698 699 700 701 ... 846 »
  Print  
Author Topic: OFFICIAL CGMINER mining software thread for linux/win/osx/mips/arm/r-pi 4.11.1  (Read 5766699 times)
This is a self-moderated topic. If you do not want to be moderated by the person who started this topic, create a new topic.
techman05
Hero Member
*****
Offline Offline

Activity: 546
Merit: 500


View Profile WWW
October 25, 2013, 10:22:01 PM
 #13001

Thats been my side assumtion that were getting funky shares cgminer isn't built to handle. I switched to bitminter from btcGuild and that's where my fun was for a while.

Did you specify which os your using? At least for the record.

Like the info address for potential tips Wink
BTC 1CL5BnNhdL2wDVmSDwMbW1cNhZew87CAPV
* http://www.miningrigrentals.com/register?ref=563
1544476499
Hero Member
*
Offline Offline

Posts: 1544476499

View Profile Personal Message (Offline)

Ignore
1544476499
Reply with quote  #2

1544476499
Report to moderator
1544476499
Hero Member
*
Offline Offline

Posts: 1544476499

View Profile Personal Message (Offline)

Ignore
1544476499
Reply with quote  #2

1544476499
Report to moderator
PLAY NOW
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1544476499
Hero Member
*
Offline Offline

Posts: 1544476499

View Profile Personal Message (Offline)

Ignore
1544476499
Reply with quote  #2

1544476499
Report to moderator
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2730
Merit: 1148


Ruu \o/


View Profile WWW
October 25, 2013, 10:23:47 PM
 #13002

3.1.1 doesn't talk usb but serial to those devices, so absolutely none of the rules apply comparing that version with the current cgminer. A zombie implies the usb effectively got disconnected at some stage. I'm just trying to find the mode of failure, looking for the last usb error that cgminer reports before it zombifies it.

Developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org, 1% Fee Solo mining at solo.ckpool.org
-ck
aigeezer
Legendary
*
Offline Offline

Activity: 1438
Merit: 1010


Cryptanalyst castrated by his government, 1952


View Profile
October 25, 2013, 10:37:42 PM
 #13003

3.1.1 doesn't talk usb but serial to those devices, so absolutely none of the rules apply comparing that version with the current cgminer. A zombie implies the usb effectively got disconnected at some stage. I'm just trying to find the mode of failure, looking for the last usb error that cgminer reports before it zombifies it.

OK, I get it now - my 3.1.1 test won't help you at all. As a user though, my temporary fix for zombies is to go back to a stable 3.1.1 when I need to, for example if I'm leaving a machine unattended for a long time.

What do you make of the "no zombies while logging" phenomenon? It could of course be just coincidence but it's still going on. I guess it won't prove anything if I turn logging off and quickly get a zombie as it might have happened anyway. I'll watch and wait some more. I wish I could be more helpful.

Edit: update after 14.5 hours running 3.6.4 with logging - no zombies, no anomalies, ran without incident. I think the act of logging serendipitously fixed whatever timing issues had been causing zombies. A debugger's nightmare, if true. The log file is now 747 meg, so I'll stop the run and get rid of it shortly. Time to try 3.6.6 in any case. Thanks!

-ck
Moderator
Legendary
*
Offline Offline

Activity: 2730
Merit: 1148


Ruu \o/


View Profile WWW
October 26, 2013, 04:31:11 AM
 #13004

New release: Version 3.6.6 - 26th October 2013

A new stable release building on top of 3.6.4 that should be a safe upgrade path after the earlier unstable 3.6 releases. Please pay attention for the options have changed.


Human readable changelog:

3.6.6:
- Fix for avalon type hardware hanging

3.6.5:
- OpenCL now needs to be explicitly built into binaries with --enable-opencl; it is no longer built in by default (binaries built by me still include it).
- Updated the build to not install opencl kernels when cgminer is built without opencl.
- Added an option to build with the system libusb for when it's difficult to get all the dependencies built (like udev on MIPS) by using the --with-system-libusb option. NOTE: It is recommended to not use this option unless you cannot build udev on linux as the included libusb is the most stable  version.
- Updated klondike driver, now built into linux binary.
- Improvements to support for BitBurner boards.
- Lots of fixes for failures to shutdown and restart, including knowing about all USB transfers in flight and waiting till they're complete.
- Updated the read mechanism on slower USB devices: instead of polling regularly, cgminer can now wait the full length of time to get results (which can be as slow as 15 seconds on some icarus devices), but it can cancel these transfers immediately once a block change is detected. The advantage of this is much less wasted CPU time, and much faster response to block change - i.e. lower CPU when there are many devices, and lower rejects. Currently this feature has been added to bitfury sticks and icarus devices. The stabilising of async transfers in cgminer made this change possible.
- Timer updates on windows now using the native clocks and timers for higher accuracy timing and tighter control.
- Fixed a minor timer bug.
- Made one off I/O errors non fatal for devices now, so only if a device has repeated I/O errors will it consider the device dead.
- Buffering extra bytes message no longer shows up in verbose mode since it's a routine operation now.
- More information is now shown when a usb error occurs.
- miner.php updates
- api updates
- Lots of low level features added in preparation for newer drivers in development for upcoming hardware.


Full changelog:

3.6.6:
- Remove inappropriate extra locking in _usb_transfer_read

3.6.5:
- klondike - fix uninitialised dev bug
- Adjust the binary ntime data in submit_noffset_nonce even when there is no hex
ntime string for eg. gbt.
- Put an entry into the work struct telling drivers how much they can roll the
ntime themselves.
- Only set libusb cancellable status if the transfer succeeds.
- Remove the applog on miner threads dying to prevent deadlocks on exit.
- Do one extra guaranteed libusb event handling before testing if there are any
pending async usb transfers.
- Use a linked list for all usb transfers instead of just cancellable ones.
- Provide a mechanism for informing drivers of updated work templates for
stratum and gbt mining.
- Add cancellable transfers correctly to the ct_list
- Check for presence of thr in icarus get nonce for startup nonce testing to
work.
- Use cancellable usb transfers in the icarus driver to avoid having to loop and
poll when waiting for a response and to speed up work restart response time.
- Add a usb_read_ii_timeout_cancellable wrapper
- Add usb transfer cancellation on shutdown and documentation regarding where
cancellable transfers are suitable.
- Use cancellable transfers on bitfury device.
- Cancel cancellable usb transfers on work restart messages.
- Don't bother having a separate cancellable transfer struct for usb transfers,
simply include the list in the usb_transfer struct.
- Add wrappers for usb_read_cancellable and usb_read_timeout_cancellable
- Specifically set the cancellable state for it to not be uninitialised in the
usb transfer struct.
- Alter the usb cancellable list only under cgusb_fd_lock write lock.
- Pass the cancellable option to _usb_read options to decide on whether to add
usb transfers to the list of cancellable transfers.
- Create a linked list of potentially cancellable usb transfers.
- Don't attempt to disable curses or print a summary during an app restart to
prevent deadlocks.
- Keep the libusb event handle polling thread active until there are no async
usb transfers in progress.
- Keep a global counter of how many async usb transfers are in place.
- Perform libusb_submit_transfer under the write variant of cgusb_fd_lock
- klondike - error condition handling
- Avoid entering static libusb directory if --with-system-libusb is enabled.
- Minor opencl build corrections.
- Enable dynamic linking against system libusb --with-system-libusb
- Modify Makefile to only include opencl related code when configured in.
- Convert opencl to need to be explicitly enabled during build with
--enable-opencl
- Implement a cglock_destroy function.
- Implement a rwlock_destroy function.
- Implement a mutex_destroy function.
- Add usb command name to critical libusb error reporting.
- Use windows' own higher resolution time and handlers allowing us to have
higher precision absolute timeouts.
- Fix lldiv error in windows cgminer_t calculation.
- miner.php correct sort gen field names largest to smallest
- api ... the code related to device elapsed
- api add device elapsed since hotplug devices Elapsed is less than cgminer
Elapsed
- Drop usb buffering message to debug logging level.
- Do the ntime binary modification to the work struct when submitting an ntime
offset nonce within submit_noffset_nonce
- Code cleanup and improved documentation
- Improvements to support for BitBurner boards
- Convert libusb transfer errors to regular libusb error messages to allow for
accurate message reporting.

Developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org, 1% Fee Solo mining at solo.ckpool.org
-ck
ThinkFast
Member
**
Offline Offline

Activity: 69
Merit: 10


View Profile
October 26, 2013, 04:48:17 AM
 #13005

cgminer 3.6.5 in Windows XP SP3 using 7z pre-built downloaded from your site.

cgminer -o http://mint.bitminter.com:8332 -u xxxxxxx_xxx@xxx.com_RHD4850 -p xxxxxxxx -d 0 --auto-fan --auto-gpu -Q 2
Error opening terminal: xterm.

Env vars:
TERM=xterm

Not sure why Windows version would be trying to invoke 'xterm'. But I'm still new to Linux.
Miner-TE
Hero Member
*****
Offline Offline

Activity: 513
Merit: 500



View Profile
October 26, 2013, 04:57:41 AM
 #13006

cgminer 3.6.5 in Windows XP SP3 using 7z pre-built downloaded from your site.

cgminer -o http://mint.bitminter.com:8332 -u xxxxxxx_xxx@xxx.com_RHD4850 -p xxxxxxxx -d 0 --auto-fan --auto-gpu -Q 2
Error opening terminal: xterm.

Env vars:
TERM=xterm

Not sure why Windows version would be trying to invoke 'xterm'. But I'm still new to Linux.

Try the following command before running CGminer in a CMD window.

'Set TERM='

BTC - 1PeMMYGn7xbZjUYeaWe9ct1VV6szLS1vkD - LTC - LbtcJRJJQQBjZuHr6Wm7vtB9RnnWtRNYpq
ThinkFast
Member
**
Offline Offline

Activity: 69
Merit: 10


View Profile
October 26, 2013, 05:09:03 AM
 #13007

That fixed it. Thanks! Grin
Pontius
Full Member
***
Offline Offline

Activity: 225
Merit: 100


View Profile
October 26, 2013, 07:42:38 AM
 #13008

New v3.6.5 doesn't work for me, after start it hangs "forever" here:
Code:
[2013-10-26 09:36:34] Started cgminer 3.6.5

When starting with "-D" it will get me the same result - cgminer hangs just printing the above line. When shutting down with "Ctrl-C" it prints this:
Code:
[2013-10-26 09:37:54] BF1 looking for BF1 03eb:204b but found 1d6b:0001 instead
 [2013-10-26 09:37:54] USB scan devices: checking for AVA devices
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 152d:2336 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 152d:2336 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 152d:2336 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for and found BTB 0403:6001
 [2013-10-26 09:37:55] USB lock avalon 4-32
 [2013-10-26 09:37:55] RES: avalon (4:32) lock=1
 [2013-10-26 09:37:55] USB res lock avalon 4-32
 [2013-10-26 09:37:55] RES: avalon (4:32) lock ok=1
 [2013-10-26 09:37:55] USB init - BTB device 4:32 usbver=0200 prod='BitBurner' manuf='Burnin Electronics' serial='855'
 [2013-10-26 09:37:55] BTB0: reset got err 0
 [2013-10-26 09:37:55] BTB0: latency got err 0
 [2013-10-26 09:37:55] BTB0: data got err 0
 [2013-10-26 09:37:55] BTB0: setbaud got err 0
 [2013-10-26 09:37:55] BTB0: setmodemctrl got err 0
 [2013-10-26 09:37:55] BTB0: setflowctrl got err 0
 [2013-10-26 09:37:55] BTB0: setmodemctrl 2 got err 0
 [2013-10-26 09:37:55] BTB0: setflowctrl 2 got err 0
 [2013-10-26 09:38:34] Shutdown signal received.

With v3.4.3 or v3.6.4 I don't have this issue.
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2730
Merit: 1148


Ruu \o/


View Profile WWW
October 26, 2013, 07:44:30 AM
 #13009

New v3.6.5 doesn't work for me, after start it hangs "forever" here:
Code:
[2013-10-26 09:36:34] Started cgminer 3.6.5

When starting with "-D" it will get me the same result - cgminer hangs just printing the above line. When shutting down with "Ctrl-C" it prints this:
Code:
[2013-10-26 09:37:54] BF1 looking for BF1 03eb:204b but found 1d6b:0001 instead
 [2013-10-26 09:37:54] USB scan devices: checking for AVA devices
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 152d:2336 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 152d:2336 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 152d:2336 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for and found BTB 0403:6001
 [2013-10-26 09:37:55] USB lock avalon 4-32
 [2013-10-26 09:37:55] RES: avalon (4:32) lock=1
 [2013-10-26 09:37:55] USB res lock avalon 4-32
 [2013-10-26 09:37:55] RES: avalon (4:32) lock ok=1
 [2013-10-26 09:37:55] USB init - BTB device 4:32 usbver=0200 prod='BitBurner' manuf='Burnin Electronics' serial='855'
 [2013-10-26 09:37:55] BTB0: reset got err 0
 [2013-10-26 09:37:55] BTB0: latency got err 0
 [2013-10-26 09:37:55] BTB0: data got err 0
 [2013-10-26 09:37:55] BTB0: setbaud got err 0
 [2013-10-26 09:37:55] BTB0: setmodemctrl got err 0
 [2013-10-26 09:37:55] BTB0: setflowctrl got err 0
 [2013-10-26 09:37:55] BTB0: setmodemctrl 2 got err 0
 [2013-10-26 09:37:55] BTB0: setflowctrl 2 got err 0
 [2013-10-26 09:38:34] Shutdown signal received.

With v3.4.3 or v3.6.4 I don't have this issue.

Yep all those bitburner changes broke avalon builds. That will teach me to trust other people's code without testing it. Will have to fix it soon.

Developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org, 1% Fee Solo mining at solo.ckpool.org
-ck
Roy Badami
Hero Member
*****
Offline Offline

Activity: 564
Merit: 500


View Profile
October 26, 2013, 08:52:27 AM
 #13010

New v3.6.5 doesn't work for me, after start it hangs "forever" here:
Code:
[2013-10-26 09:36:34] Started cgminer 3.6.5

When starting with "-D" it will get me the same result - cgminer hangs just printing the above line. When shutting down with "Ctrl-C" it prints this:
Code:
[2013-10-26 09:37:54] BF1 looking for BF1 03eb:204b but found 1d6b:0001 instead
 [2013-10-26 09:37:54] USB scan devices: checking for AVA devices
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0001 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 152d:2336 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 152d:2336 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 152d:2336 instead
 [2013-10-26 09:37:55] AVA looking for BTB 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for BBF 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for AVA 0403:6001 but found 1d6b:0002 instead
 [2013-10-26 09:37:55] AVA looking for and found BTB 0403:6001
 [2013-10-26 09:37:55] USB lock avalon 4-32
 [2013-10-26 09:37:55] RES: avalon (4:32) lock=1
 [2013-10-26 09:37:55] USB res lock avalon 4-32
 [2013-10-26 09:37:55] RES: avalon (4:32) lock ok=1
 [2013-10-26 09:37:55] USB init - BTB device 4:32 usbver=0200 prod='BitBurner' manuf='Burnin Electronics' serial='855'
 [2013-10-26 09:37:55] BTB0: reset got err 0
 [2013-10-26 09:37:55] BTB0: latency got err 0
 [2013-10-26 09:37:55] BTB0: data got err 0
 [2013-10-26 09:37:55] BTB0: setbaud got err 0
 [2013-10-26 09:37:55] BTB0: setmodemctrl got err 0
 [2013-10-26 09:37:55] BTB0: setflowctrl got err 0
 [2013-10-26 09:37:55] BTB0: setmodemctrl 2 got err 0
 [2013-10-26 09:37:55] BTB0: setflowctrl 2 got err 0
 [2013-10-26 09:38:34] Shutdown signal received.

With v3.4.3 or v3.6.4 I don't have this issue.


Pontius - what Avalon/Bitburner devices are you mining with?  What command line arguments are you using?
Pontius
Full Member
***
Offline Offline

Activity: 225
Merit: 100


View Profile
October 26, 2013, 09:15:13 AM
 #13011

Pontius - what Avalon/Bitburner devices are you mining with?  What command line arguments are you using?

Bitburner XX

Code:
cgminer -n
 [2013-10-26 11:06:02] USB all: found 9 devices - listing known devices
.USB dev 0: Bus 4 Device 32 ID: 0403:6001
  Manufacturer: 'Burnin Electronics'
  Product: 'BitBurner'                   
 [2013-10-26 11:06:02] 1 known USB devices

No command line options, everything is inside the ~/.cgminer/cgminer.conf:
Code:
{
    "api-listen"        :   true,
    "api-allow"         :   "W:127.0.0.1,172.16.8.0/23",
   
    "avalon-options"    :   "115200:4:10:d:372",
    "avalon-temp"       :   "40",
    "bitburner-voltage" :   "1170",
    "queue"             :   "4",
    "usb"               :   ":1",

    "load-balance"      :   true,
    "pools"             : [
        [...]
    ]
}
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2730
Merit: 1148


Ruu \o/


View Profile WWW
October 26, 2013, 09:29:24 AM
 #13012

My bad, it wasn't Roy's fault at all, it was mine. Quick update to 3.6.6 shortly.

EDIT: Updated to 3.6.6, uploaded, git pushed etc.

Developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org, 1% Fee Solo mining at solo.ckpool.org
-ck
kano
Legendary
*
Offline Offline

Activity: 2660
Merit: 1059


Linux since 1997 RedHat 4


View Profile
October 26, 2013, 11:50:27 AM
 #13013

Been a while Smiley

3.6.6a 3.6.6 recompiled on:
Fedora 18
64 bit xubuntu 11.04 (should also work on Fedora 16 and 17)
RPi 32bit Arch
RPi 32bit Raspbian

e.g. to get the 64 bit xubuntu 11.04 binary:
wget https://github.com/kanoi/cgminer-binaries/raw/master/Ubuntu_11.04_x86_64/cgminer-3.6.6a
chmod +x cgminer-3.6.6a


The 3 others are:
https://github.com/kanoi/cgminer-binaries/raw/master/Fedora18_x86_64/cgminer-3.6.6a
https://github.com/kanoi/cgminer-binaries/raw/master/RPi_Arch/cgminer-3.6.6a
https://github.com/kanoi/cgminer-binaries/raw/master/RPi_Raspbian/cgminer-3.6.6a

The Xubuntu configure option (with GPU and scrypt):
CFLAGS="-g -W -Wall" ./autogen.sh --enable-bflsc --enable-icarus --enable-bitforce --enable-modminer --enable-avalon --enable-opencl --enable-scrypt --enable-bitfury --enable-klondike

The rest are USB only (no GPU):
CFLAGS="-g -W -Wall" ./autogen.sh --enable-bflsc --enable-icarus --enable-bitforce --enable-modminer --enable-avalon --enable-bitfury --enable-klondike

The -g (instead of -O2) means it's a debug build so if anyone finds a problem and has core dumps enabled, it will dump a much more useful debug core.

Note I have binary folders of ckolivas official release files in my binaries git also, for if you can't get to his downloads
To get them you select the folder (e.g. 3.6.6) then click on the file you want then right-click save-as the "View Raw" link.

Important: Read README, ASIC-README or FPGA-README about USB configuration on linux and windows

Pool: https://kano.is Here on Bitcointalk: Forum BTC: 1KanoPb8cKYqNrswjaA8cRDk4FAS9eDMLU
FreeNode IRC: irc.freenode.net channel #kano.is Majority developer of the ckpool code
Help keep Bitcoin secure by mining on pools with full block verification on all blocks - and NO empty blocks!
kano
Legendary
*
Offline Offline

Activity: 2660
Merit: 1059


Linux since 1997 RedHat 4


View Profile
October 26, 2013, 11:54:14 AM
 #13014

3.1.1 doesn't talk usb but serial to those devices, so absolutely none of the rules apply comparing that version with the current cgminer. A zombie implies the usb effectively got disconnected at some stage. I'm just trying to find the mode of failure, looking for the last usb error that cgminer reports before it zombifies it.

OK, I get it now - my 3.1.1 test won't help you at all. As a user though, my temporary fix for zombies is to go back to a stable 3.1.1 when I need to, for example if I'm leaving a machine unattended for a long time.

What do you make of the "no zombies while logging" phenomenon? It could of course be just coincidence but it's still going on. I guess it won't prove anything if I turn logging off and quickly get a zombie as it might have happened anyway. I'll watch and wait some more. I wish I could be more helpful.

Just an aside ... 3.1.1 can't have a zombie AMU coz AMUs were not usbutils in 3.1.1, they were serial - and it's only usbutils that can flag a device as zombie

Pool: https://kano.is Here on Bitcointalk: Forum BTC: 1KanoPb8cKYqNrswjaA8cRDk4FAS9eDMLU
FreeNode IRC: irc.freenode.net channel #kano.is Majority developer of the ckpool code
Help keep Bitcoin secure by mining on pools with full block verification on all blocks - and NO empty blocks!
aigeezer
Legendary
*
Offline Offline

Activity: 1438
Merit: 1010


Cryptanalyst castrated by his government, 1952


View Profile
October 26, 2013, 12:28:33 PM
 #13015

3.1.1 doesn't talk usb but serial to those devices, so absolutely none of the rules apply comparing that version with the current cgminer. A zombie implies the usb effectively got disconnected at some stage. I'm just trying to find the mode of failure, looking for the last usb error that cgminer reports before it zombifies it.

OK, I get it now - my 3.1.1 test won't help you at all. As a user though, my temporary fix for zombies is to go back to a stable 3.1.1 when I need to, for example if I'm leaving a machine unattended for a long time.

What do you make of the "no zombies while logging" phenomenon? It could of course be just coincidence but it's still going on. I guess it won't prove anything if I turn logging off and quickly get a zombie as it might have happened anyway. I'll watch and wait some more. I wish I could be more helpful.

Just an aside ... 3.1.1 can't have a zombie AMU coz AMUs were not usbutils in 3.1.1, they were serial - and it's only usbutils that can flag a device as zombie

I've been over-using the word zombie in my posts. It became a shorthand for "non-working Erupter". Usually it was literally flagged as a zombie by cgminer (versions after 3.1.1) but sometimes it was not mining for other reasons. The effect was always LED on solid and mining stopped. The cure varied. Sometime restarting cgminer worked, sometimes hot replug of the Erupter worked, sometimes hot replug of the hub's USB connection worked, very occasionally a whole hub needed to be powered down and restarted, and once in a rare while it took a system reboot to make things right.

I'll mention again though that 3.6.4 ran (still running) for 15+ hours with logging turned on. With logging off it has never lasted that long without a literal zombie or some other solid-light Erupter failure. It sounds like 3.6.6 has the right kinds of changes for my problems.

Magic.    Smiley
techman05
Hero Member
*****
Offline Offline

Activity: 546
Merit: 500


View Profile WWW
October 26, 2013, 12:37:39 PM
 #13016

New release: Version 3.6.6 - 26th October 2013

A new stable release building on top of 3.6.4 that should be a safe upgrade path after the earlier unstable 3.6 releases. Please pay attention for the options have changed.



CKolivias, could next update have an error pop up if it doesn't find a file its looking for like the config file. When it doesn't find the file it just flashes and closes without any error. Maybe say "missing startup item "cgminer.conf" and a generic press any key to exit message?

Using windows 7 (though I'd think somthing like this would be same in linux versions).

Thanks, I've just been going up in versions so fast I'm forgetting to move my config file.

Like the info address for potential tips Wink
BTC 1CL5BnNhdL2wDVmSDwMbW1cNhZew87CAPV
* http://www.miningrigrentals.com/register?ref=563
aigeezer
Legendary
*
Offline Offline

Activity: 1438
Merit: 1010


Cryptanalyst castrated by his government, 1952


View Profile
October 26, 2013, 12:55:47 PM
 #13017

3.6.6 reports two zombies (literally) after about 20 minutes. I'll restart it shortly with logging on.
techman05
Hero Member
*****
Offline Offline

Activity: 546
Merit: 500


View Profile WWW
October 26, 2013, 01:11:30 PM
 #13018

So far so good for me. Mines been running for about 40 minutes with load balancing.

Like the info address for potential tips Wink
BTC 1CL5BnNhdL2wDVmSDwMbW1cNhZew87CAPV
* http://www.miningrigrentals.com/register?ref=563
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2730
Merit: 1148


Ruu \o/


View Profile WWW
October 26, 2013, 01:17:54 PM
 #13019

3.6.6 reports two zombies (literally) after about 20 minutes. I'll restart it shortly with logging on.

3.6.6 is almost identical to the experimental .exe you last downloaded.

Developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org, 1% Fee Solo mining at solo.ckpool.org
-ck
aigeezer
Legendary
*
Offline Offline

Activity: 1438
Merit: 1010


Cryptanalyst castrated by his government, 1952


View Profile
October 26, 2013, 01:34:15 PM
 #13020

3.6.6 reports two zombies (literally) after about 20 minutes. I'll restart it shortly with logging on.

3.6.6 is almost identical to the experimental .exe you last downloaded.

OK, thanks for the info. Behavior seems about the same. Working fine with logging, only running with log for about half an hour so far though.
Pages: « 1 ... 601 602 603 604 605 606 607 608 609 610 611 612 613 614 615 616 617 618 619 620 621 622 623 624 625 626 627 628 629 630 631 632 633 634 635 636 637 638 639 640 641 642 643 644 645 646 647 648 649 650 [651] 652 653 654 655 656 657 658 659 660 661 662 663 664 665 666 667 668 669 670 671 672 673 674 675 676 677 678 679 680 681 682 683 684 685 686 687 688 689 690 691 692 693 694 695 696 697 698 699 700 701 ... 846 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!