Bitcoin Forum
July 26, 2021, 02:55:38 AM *
News: Latest Bitcoin Core release: 0.21.1 [Torrent]
 
   Home   Help Search Login Register More  
Pages: « 1 ... 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 [104] 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 ... 1431 »
  Print  
Author Topic: Claymore's Dual Ethereum AMD+NVIDIA GPU Miner v15.0 (Windows/Linux)  (Read 6583152 times)
Andy777s
Full Member
***
Offline Offline

Activity: 147
Merit: 100

RevolverCoin Team


View Profile WWW
May 19, 2016, 08:05:30 PM
 #2061

Really nice software, thanks Claymore! A lot more stable than stock miner.  Watchdog is also awesome - helps a lot with driver crashes.

▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬   RevolverCoin   ▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
⎩  NO ICO  ♦  NO PREMINE  ♦  X11EVO ALGO  ♦  ASIC RESISTANT  ⎭
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬ XRE ▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1627268138
Hero Member
*
Offline Offline

Posts: 1627268138

View Profile Personal Message (Offline)

Ignore
1627268138
Reply with quote  #2

1627268138
Report to moderator
1627268138
Hero Member
*
Offline Offline

Posts: 1627268138

View Profile Personal Message (Offline)

Ignore
1627268138
Reply with quote  #2

1627268138
Report to moderator
1627268138
Hero Member
*
Offline Offline

Posts: 1627268138

View Profile Personal Message (Offline)

Ignore
1627268138
Reply with quote  #2

1627268138
Report to moderator
Claymore
Donator
Legendary
*
Offline Offline

Activity: 1610
Merit: 1325

Miners developer


View Profile
May 19, 2016, 08:15:45 PM
 #2062

Thanks to Claymore for new version!
I have some feature request if it possible.
It will be good to doesn't exit miner if -tstop is exceeded, but switch off specific GPU with overheat from mining like sgminer does.

Ok, I will do it.

Claymore, Why does your miner produces a low hash rate of Ethereum in single mode, compared to dual mining?

The reason is memory accessing/caching. When all GPU threads are accessing memory by random addresses at the same time it causes some overload. When some threads are busy with Decred and don't access memory, overload is less and other threads can get required data a bit faster. Because there is no way to freeze some threads I cannot use this behaviour to improve mining speed in Ethereum-only mode.

Please read Readme and FAQ in the first post of this thread before asking any questions, probably the answer is already there.
List of my miners: https://bitcointalk.org/index.php?topic=3019607
jstefanop
Legendary
*
Offline Offline

Activity: 1867
Merit: 1305


View Profile
May 19, 2016, 08:16:19 PM
 #2063

Claymore can you format your json output with key value pairs? Current output is very hard to parse and get individual values.

{"id": 0, "result": ["4.3", "8", "93479;11;0", "18352;18914;18191;18809;19210", "0;0;0", "0;0;0;0;0", "67;53;66;50;66;48;56;61;60;56", "us1.ethpool.org:3333"], "error": null}

something like result.eth_mh would be great to get just the hashrate value for example.


Also someone that know curl explain why
telnet localhost 3333
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
{"id":0,"jsonrpc":"2.0","method":"miner_getstat1"}

works to get a response, but

curl -i -X POST --data '{"id":0,"jsonrpc":"2.0","method":"miner_getstat1"}' http://localhost:3333

does not work? Im not that great with curl so not sure if I formatted that request right.

Project Apollo: A Pod Miner Designed for the Home https://bitcointalk.org/index.php?topic=4974036
FutureBit Moonlander 2 USB Scrypt Stick Miner: https://bitcointalk.org/index.php?topic=2125643.0
LTC:LX5vpxrQE4eLRLPobKwZhw2comkKFCh3p4 - BTC:14w9Lea6kdVzspJk8TQRe7qSYu9LhzJJsh
zyzzyva
Member
**
Offline Offline

Activity: 82
Merit: 10


View Profile
May 19, 2016, 08:21:03 PM
 #2064

Also someone that know curl explain why
telnet localhost 3333
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
{"id":0,"jsonrpc":"2.0","method":"miner_getstat1"}

works to get a response, but

curl -i -X POST --data '{"id":0,"jsonrpc":"2.0","method":"miner_getstat1"}' http://localhost:3333

does not work? Im not that great with curl so not sure if I formatted that request right.

My guess is that CDM doesn't like the HTTP headers that curl sends. I'd recommend using nc (https://en.wikipedia.org/wiki/Netcat) instead.
Claymore
Donator
Legendary
*
Offline Offline

Activity: 1610
Merit: 1325

Miners developer


View Profile
May 19, 2016, 08:22:40 PM
 #2065

Claymore can you format your json output with key value pairs? Current output is very hard to parse and get individual values.

{"id": 0, "result": ["4.3", "8", "93479;11;0", "18352;18914;18191;18809;19210", "0;0;0", "0;0;0;0;0", "67;53;66;50;66;48;56;61;60;56", "us1.ethpool.org:3333"], "error": null}

something like result.eth_mh would be great to get just the hashrate value for example.

I won't change format without a serious reason. If you want to get hashrate and cannot use any json lib (which would be the best solution) you can just find 9th " character and then first ; character and take the number between them. Looks like not a big deal.

Please read Readme and FAQ in the first post of this thread before asking any questions, probably the answer is already there.
List of my miners: https://bitcointalk.org/index.php?topic=3019607
drr0ss
Member
**
Offline Offline

Activity: 98
Merit: 10


View Profile
May 19, 2016, 08:34:48 PM
 #2066

Claymore, Why does your miner produces a low hash rate of Ethereum in single mode, compared to dual mining?

The reason is memory accessing/caching. When all GPU threads are accessing memory by random addresses at the same time it causes some overload. When some threads are busy with Decred and don't access memory, overload is less and other threads can get required data a bit faster. Because there is no way to freeze some threads I cannot use this behaviour to improve mining speed in Ethereum-only mode.
[/quote]

Thanks for the answer, is this mean that lowering number of threads will increase the eth speed?
Claymore
Donator
Legendary
*
Offline Offline

Activity: 1610
Merit: 1325

Miners developer


View Profile
May 19, 2016, 08:42:14 PM
 #2067

Thanks for the answer, is this mean that lowering number of threads will increase the eth speed?

Yes, a bit, on some cards. But there is no way to reduce number of active GPU threads, all are always active. May be you can disable some compute units via bios, but I'm not sure if it helps because in dual mode all compute units are active but some of threads are busy with decred.

Please read Readme and FAQ in the first post of this thread before asking any questions, probably the answer is already there.
List of my miners: https://bitcointalk.org/index.php?topic=3019607
jstefanop
Legendary
*
Offline Offline

Activity: 1867
Merit: 1305


View Profile
May 19, 2016, 08:56:12 PM
 #2068

Also someone that know curl explain why
telnet localhost 3333
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
{"id":0,"jsonrpc":"2.0","method":"miner_getstat1"}

works to get a response, but

curl -i -X POST --data '{"id":0,"jsonrpc":"2.0","method":"miner_getstat1"}' http://localhost:3333

does not work? Im not that great with curl so not sure if I formatted that request right.

My guess is that CDM doesn't like the HTTP headers that curl sends. I'd recommend using nc (https://en.wikipedia.org/wiki/Netcat) instead.

Nice, this works:

echo '{"id":0,"jsonrpc":"2.0","method":"miner_getstat1"}' | nc localhost 3333

this dumps the raw json output so it can easily be used in a bash script in linux to do fun things Smiley

Project Apollo: A Pod Miner Designed for the Home https://bitcointalk.org/index.php?topic=4974036
FutureBit Moonlander 2 USB Scrypt Stick Miner: https://bitcointalk.org/index.php?topic=2125643.0
LTC:LX5vpxrQE4eLRLPobKwZhw2comkKFCh3p4 - BTC:14w9Lea6kdVzspJk8TQRe7qSYu9LhzJJsh
Foss
Full Member
***
Offline Offline

Activity: 125
Merit: 100


View Profile
May 19, 2016, 09:02:19 PM
 #2069

Claymore. Strange behavior: the window of the program actively about 10 seconds, then inactively, and so proceeds minutes 7 or more. During it process of dllhost.exe appears and disappears. In version 4.2 a beta such isn't present. win7x64, catalyst 15.7.1
Code:
setx GPU_FORCE_64BIT_PTR 0
setx GPU_MAX_HEAP_SIZE 100
setx GPU_USE_SYNC_OBJECTS 1
setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_SINGLE_ALLOC_PERCENT 100
EthDcrMiner64.exe -epool eth-ru.dwarfpool.com:8008 -ewal 0xe4b10dff72b58a363a3c8b70e21cfb236e2697c9/asus -epsw x -di 1 -erate 0 -mport 0 -esm 0 -mode 1 -r 0 -etha 0 -ethi 10


BTC: 147kwy3LndX6jkwGC3mU9j6rZMWU8g1Amd
DASH: XhR4V6ChnQp7LDWhpArwBMXARxU5LGiq8a
ETH: 0xe4b10dff72b58a363a3c8b70e21cfb236e2697c9
PPOC
Hero Member
*****
Offline Offline

Activity: 575
Merit: 500



View Profile
May 19, 2016, 09:48:00 PM
 #2070

Claymore - Your miner works great on pools, a week with no issues or crashes. I am trying to setup solo mining. Have Geth running on a local LAN machine and tried to point miner from same machine as well as another LAN machine.

Used
EthDcrMiner64.exe -epool http://localhost:8545

Connects, looks like it starts mining and Geth console shows the connection. But not seeing any shares? only temps and new jobs. On pool, i'm seeing accepted shares almost instantly. Doing something wrong here?

Also, when I point another rig to my local Geth using LAN IP and same port, can't connect. Port is open, no FW running and its local LAN.


ETH: 05/19/16-17:43:38 - New job (target 0x000000000006f68d) from localhost:8545
ETH - Total Speed: 122.037 Mh/s, Total Shares: 0, Rejected: 0, Time: 00:06
ETH: GPU0 30.444 Mh/s, GPU1 30.541 Mh/s, GPU2 30.526 Mh/s, GPU3 30.527 Mh/s
ETH: 05/19/16-17:43:43 - New job (target 0x000000000006f5af) from localhost:8545
ETH - Total Speed: 122.052 Mh/s, Total Shares: 0, Rejected: 0, Time: 00:06
ETH: GPU0 30.473 Mh/s, GPU1 30.543 Mh/s, GPU2 30.528 Mh/s, GPU3 30.508 Mh/s
GPU0 t=63C fan=0%, GPU1 t=62C fan=0%, GPU2 t=62C fan=0%
ETH: 05/19/16-17:44:09 - New job (target 0x000000000006f68d) from localhost:8545
ETH - Total Speed: 122.006 Mh/s, Total Shares: 0, Rejected: 0, Time: 00:06
ETH: GPU0 30.431 Mh/s, GPU1 30.532 Mh/s, GPU2 30.521 Mh/s, GPU3 30.523 Mh/s
ETH: 05/19/16-17:44:10 - New job (target 0x000000000006f5af) from localhost:8545
ETH - Total Speed: 121.798 Mh/s, Total Shares: 0, Rejected: 0, Time: 00:06
ETH: GPU0 30.477 Mh/s, GPU1 30.533 Mh/s, GPU2 30.280 Mh/s, GPU3 30.508 Mh/s
ETH: 05/19/16-17:44:12 - New job (target 0x000000000006f4d0) from localhost:8545
ETH - Total Speed: 122.068 Mh/s, Total Shares: 0, Rejected: 0, Time: 00:06
ETH: GPU0 30.477 Mh/s, GPU1 30.537 Mh/s, GPU2 30.539 Mh/s, GPU3 30.515 Mh/s
ETH: 05/19/16-17:44:16 - New job (target 0x000000000006f3f2) from localhost:8545
ETH - Total Speed: 122.117 Mh/s, Total Shares: 0, Rejected: 0, Time: 00:06
ETH: GPU0 30.530 Mh/s, GPU1 30.527 Mh/s, GPU2 30.539 Mh/s, GPU3 30.521 Mh/s
GPU0 t=64C fan=0%, GPU1 t=62C fan=0%, GPU2 t=63C fan=0%
ETH: 05/19/16-17:44:43 - New job (target 0x000000000006f4d0) from localhost:8545
ETH - Total Speed: 122.040 Mh/s, Total Shares: 0, Rejected: 0, Time: 00:07
ETH: GPU0 30.482 Mh/s, GPU1 30.519 Mh/s, GPU2 30.523 Mh/s, GPU3 30.517 Mh/s

BTC: 1Bo6YsPeHCrVRygHLJg9BwHeaLSQpppcJi
"Lost coins only make everyone else’s coins worth slightly more. Think of it as a donation to everyone."
osnwt
Sr. Member
****
Offline Offline

Activity: 353
Merit: 251


View Profile
May 19, 2016, 09:57:42 PM
 #2071

Connects, looks like it starts mining and Geth console shows the connection. But not seeing any shares? only temps and new jobs. On pool, i'm seeing accepted shares almost instantly. Doing something wrong here?

ETH: 05/19/16-17:44:09 - New job (target 0x000000000006f68d) from localhost:8545
I didn't try solo mining. But I guess that with solo mode your "share" means to be a block solution. With such difficulty difference (compare yours and pool ones) and your hashrate you should mine few days, maybe a week on average, to find a block. I think so, but might be wrong.
malandante
Full Member
***
Offline Offline

Activity: 142
Merit: 100


View Profile
May 19, 2016, 10:14:29 PM
 #2072

Claymore - Your miner works great on pools, a week with no issues or crashes. I am trying to setup solo mining. Have Geth running on a local LAN machine and tried to point miner from same machine as well as another LAN machine.

Used
EthDcrMiner64.exe -epool http://localhost:8545

Connects, looks like it starts mining and Geth console shows the connection. But not seeing any shares? only temps and new jobs. On pool, i'm seeing accepted shares almost instantly. Doing something wrong here?

Also, when I point another rig to my local Geth using LAN IP and same port, can't connect. Port is open, no FW running and its local LAN.


ETH: 05/19/16-17:43:38 - New job (target 0x000000000006f68d) from localhost:8545
ETH - Total Speed: 122.037 Mh/s, Total Shares: 0, Rejected: 0, Time: 00:06
ETH: GPU0 30.444 Mh/s, GPU1 30.541 Mh/s, GPU2 30.526 Mh/s, GPU3 30.527 Mh/s
ETH: 05/19/16-17:43:43 - New job (target 0x000000000006f5af) from localhost:8545
ETH - Total Speed: 122.052 Mh/s, Total Shares: 0, Rejected: 0, Time: 00:06
ETH: GPU0 30.473 Mh/s, GPU1 30.543 Mh/s, GPU2 30.528 Mh/s, GPU3 30.508 Mh/s
GPU0 t=63C fan=0%, GPU1 t=62C fan=0%, GPU2 t=62C fan=0%
ETH: 05/19/16-17:44:09 - New job (target 0x000000000006f68d) from localhost:8545
ETH - Total Speed: 122.006 Mh/s, Total Shares: 0, Rejected: 0, Time: 00:06
ETH: GPU0 30.431 Mh/s, GPU1 30.532 Mh/s, GPU2 30.521 Mh/s, GPU3 30.523 Mh/s
ETH: 05/19/16-17:44:10 - New job (target 0x000000000006f5af) from localhost:8545
ETH - Total Speed: 121.798 Mh/s, Total Shares: 0, Rejected: 0, Time: 00:06
ETH: GPU0 30.477 Mh/s, GPU1 30.533 Mh/s, GPU2 30.280 Mh/s, GPU3 30.508 Mh/s
ETH: 05/19/16-17:44:12 - New job (target 0x000000000006f4d0) from localhost:8545
ETH - Total Speed: 122.068 Mh/s, Total Shares: 0, Rejected: 0, Time: 00:06
ETH: GPU0 30.477 Mh/s, GPU1 30.537 Mh/s, GPU2 30.539 Mh/s, GPU3 30.515 Mh/s
ETH: 05/19/16-17:44:16 - New job (target 0x000000000006f3f2) from localhost:8545
ETH - Total Speed: 122.117 Mh/s, Total Shares: 0, Rejected: 0, Time: 00:06
ETH: GPU0 30.530 Mh/s, GPU1 30.527 Mh/s, GPU2 30.539 Mh/s, GPU3 30.521 Mh/s
GPU0 t=64C fan=0%, GPU1 t=62C fan=0%, GPU2 t=63C fan=0%
ETH: 05/19/16-17:44:43 - New job (target 0x000000000006f4d0) from localhost:8545
ETH - Total Speed: 122.040 Mh/s, Total Shares: 0, Rejected: 0, Time: 00:07
ETH: GPU0 30.482 Mh/s, GPU1 30.519 Mh/s, GPU2 30.523 Mh/s, GPU3 30.517 Mh/s

Shares are your contributions in pool mining, so no shares in solo mining, you mine the whole thing alone. Try launching geth with --rpc --rpcaddr 192.168.x.x --farm 192.168.x.x where 192.168.x.x is the lan address of the machine running geth. For me it does work like that. With 127.0.0.1 machines in the lan can't connect.
PPOC
Hero Member
*****
Offline Offline

Activity: 575
Merit: 500



View Profile
May 19, 2016, 10:15:06 PM
 #2073

Connects, looks like it starts mining and Geth console shows the connection. But not seeing any shares? only temps and new jobs. On pool, i'm seeing accepted shares almost instantly. Doing something wrong here?

ETH: 05/19/16-17:44:09 - New job (target 0x000000000006f68d) from localhost:8545
I didn't try solo mining. But I guess that with solo mode your "share" means to be a block solution. With such difficulty difference (compare yours and pool ones) and your hashrate you should mine few days, maybe a week on average, to find a block. I think so, but might be wrong.

I actually have 600mh of miners that I want to solo mine, but so far only the local box running Geth is connecting my GPU's and that's the 120mh you see here. Tried pointing my other rigs to this Geth box and getting failure to connect messages. I would think I should still see accepted shares as rarely are they blocks on a pool. I avg 450 accepted shares per hour on a pool like Nano, so I was expecting to see similar results solo mining.

BTC: 1Bo6YsPeHCrVRygHLJg9BwHeaLSQpppcJi
"Lost coins only make everyone else’s coins worth slightly more. Think of it as a donation to everyone."
adaseb
Legendary
*
Offline Offline

Activity: 2730
Merit: 1331



View Profile
May 19, 2016, 10:16:50 PM
 #2074

So does the miner stop mining when a new block is found or only when its submitting a share?





.
.




░██████████████████░
████████████████████
█████████▀░░░███████
█████████░░▄████████
███████▀▀░░▀▀███████
███████▄▄░░▄▄███████
█████████░░█████████

█████████░░█████████

█████████▄▄█████████

████████████████████

░██████████████████░
░██████████████████░
████████████████████
████████████▀▀▀█▀███
███░▀█████▀░░░░░▀███
███▌░░░▀▀▀░░░░░░████
████▄░░░░░░░░░░░████
█████▀░░░░░░░░░█████

██████▄░░░░░▄▄██████

█████▄▄▄▄███████████

████████████████████

░██████████████████░
░██████████████████░
████████████████████
████████████████████
███████████▀▀░░▐████
███████▀▀░░░░░█████
████▀░░░▄█▀░░░▐█████
█████▄▄█▀░░░░░██████

███████▌▄▄▄▐██████

████████████████████

████████████████████

░██████████████████░
malandante
Full Member
***
Offline Offline

Activity: 142
Merit: 100


View Profile
May 19, 2016, 10:30:26 PM
 #2075

Connects, looks like it starts mining and Geth console shows the connection. But not seeing any shares? only temps and new jobs. On pool, i'm seeing accepted shares almost instantly. Doing something wrong here?

ETH: 05/19/16-17:44:09 - New job (target 0x000000000006f68d) from localhost:8545
I didn't try solo mining. But I guess that with solo mode your "share" means to be a block solution. With such difficulty difference (compare yours and pool ones) and your hashrate you should mine few days, maybe a week on average, to find a block. I think so, but might be wrong.

I actually have 600mh of miners that I want to solo mine, but so far only the local box running Geth is connecting my GPU's and that's the 120mh you see here. Tried pointing my other rigs to this Geth box and getting failure to connect messages. I would think I should still see accepted shares as rarely are they blocks on a pool. I avg 450 accepted shares per hour on a pool like Nano, so I was expecting to see similar results solo mining.

The not connecting is most likely because you set rpc to 127.0.0.1 and then geth only accepts connections from the same machine. Use the local ip instead.

And by the way, I wouldn't use CDM to solo mine. When you solo mine, you don't want 36 or 72 seconds per hour not mining for yourself because in this time it can be when you're gonna hit a block. If you are pool mining then it is ok because shares you will be hitting a lot anyway. I'll give you an example: a few months ago when I was still solo mining, I was gonna stop one of my rigs and in the time between hitting CTRL and C this rig found one block.
osnwt
Sr. Member
****
Offline Offline

Activity: 353
Merit: 251


View Profile
May 19, 2016, 10:36:07 PM
 #2076

I would think I should still see accepted shares as rarely are they blocks on a pool. I avg 450 accepted shares per hour on a pool like Nano, so I was expecting to see similar results solo mining.
You should read the theory of pool operation to understand the whole thing.

A miner calculates a "checksum" of data in the block using some hashing algorithm. The result is a very long number. To solve a block this number must be lesser than some value called target. Target depends on the speed of finding blocks by the whole network and adapts so the average rate of new blocks is constant regardless of number of miners in the network. That is, more miners - more hashpower - lesser target - harder to find a block solution.

When you mine with a pool, pool sets target for miners much higher than actual target for the block solution. So miners with low hash rates can find at least something in reasonable time frame. Those solutions are called "shares" because they do NOT solve a block. But pool can estimate miner hashrate by the rate of submitted shares. Finally some share from some miner will be smaller than a block solution. This share will solve the block, but usually miner does not know that it was its share (some pools like suprnova and pool.mn report block founders, though, for stats).

Now compare the typical target from a pool: 0x0000000112e0be82 (4611686018) with your target 0x000000000006f3f2 (455666).  4611686018/455666 ~= 10120. This means that in solo mode only 1 of 10120 such pool shares will solve a block. If your miner finds 100 shares per hour, you need 101 hour to find a solution in solo mode. Until that you will not see any shares in solo mode. You see only block solution.
hitchpool
Newbie
*
Offline Offline

Activity: 2
Merit: 0


View Profile
May 19, 2016, 10:45:46 PM
 #2077

Hi it seems that eth_submitHashrate in eth-proxy mode is lacking the worker parameter:
Code:
{"id":6,"jsonrpc":"2.0","method":"eth_submitHashrate","params":["0x7b64145", "0x000000000000000000000000000000000000000000000000000000009ff1e5fb"]}

While a request from eth proxy for eth_submitHahrate looks like this (when worker ids are enabled):
Code:
{"id":6,"worker": "rig1","jsonrpc":"2.0","method":"eth_submitHashrate","params":["0x7b64145", "0x000000000000000000000000000000000000000000000000000000009ff1e5fb"]}

Maybe you could add the worker param to the request if it is set.
majky80
Newbie
*
Offline Offline

Activity: 28
Merit: 0


View Profile
May 19, 2016, 11:16:25 PM
 #2078

Hi i have problem. I have GPU R9 280X and R9 290X in one motherboard with Windows 8, CPU 4core, 8gb ram. Here i have driver 15.12. One GPU R9 280X hashrate is ok. Is 20-21 MH/s. And problem i have with two GPU card R9 290X. Before i have in this card 46-47 MH/s. But now is very critical low....20-21 MH/s. I send photo screenshot and settings my miner. I test previous version and too problem....I test another software and too...Before this time all ok....

EthDcrMiner64.exe -mode 1 -esm 1 -epool eu1.ethpool.org:3333 -ewal 0x7efa35203ded3af8394854022541a2cbfa73cc05.marian2 -epsw x -estale 0

http://s32.postimg.org/6q7dtz879/r290x.jpg

Please help me friend....where is the problem?
markus124
Hero Member
*****
Offline Offline

Activity: 574
Merit: 500



View Profile
May 19, 2016, 11:57:54 PM
 #2079

"dwarfpool (and Stratum for Decred):
EthDcrMiner64.exe -epool eth-eu.dwarfpool.com:8008 -ewal 0xD69af2A796A737A103F12d2f0BCC563a13900E6F/YourWorkerName -epsw x -dpool stratum+tcp://dcr.suprnova.cc:2252 -dwal Redhex.my -dpsw x"

I dont want to sound like an idiot but in the part where it says "-dwal"? Do i need to add my decred payment address too or leave it blank? I see that the miner is accepting shares from decred but im not sure if i have to put my address or not (Is blank in the original post)

Sorry if is a dumb question first time trying this. Thanks for the help.







PPOC
Hero Member
*****
Offline Offline

Activity: 575
Merit: 500



View Profile
May 20, 2016, 12:01:34 AM
 #2080

Connects, looks like it starts mining and Geth console shows the connection. But not seeing any shares? only temps and new jobs. On pool, i'm seeing accepted shares almost instantly. Doing something wrong here?

ETH: 05/19/16-17:44:09 - New job (target 0x000000000006f68d) from localhost:8545
I didn't try solo mining. But I guess that with solo mode your "share" means to be a block solution. With such difficulty difference (compare yours and pool ones) and your hashrate you should mine few days, maybe a week on average, to find a block. I think so, but might be wrong.

I actually have 600mh of miners that I want to solo mine, but so far only the local box running Geth is connecting my GPU's and that's the 120mh you see here. Tried pointing my other rigs to this Geth box and getting failure to connect messages. I would think I should still see accepted shares as rarely are they blocks on a pool. I avg 450 accepted shares per hour on a pool like Nano, so I was expecting to see similar results solo mining.

The not connecting is most likely because you set rpc to 127.0.0.1 and then geth only accepts connections from the same machine. Use the local ip instead.

And by the way, I wouldn't use CDM to solo mine. When you solo mine, you don't want 36 or 72 seconds per hour not mining for yourself because in this time it can be when you're gonna hit a block. If you are pool mining then it is ok because shares you will be hitting a lot anyway. I'll give you an example: a few months ago when I was still solo mining, I was gonna stop one of my rigs and in the time between hitting CTRL and C this rig found one block.

Thanks for the info, very helpful. So in your opinion, I should use ethminer doing solo on my Geth? Even though CMD give me a higher hash rate? With either I get 103mh on 1 rig, with CMD I get 120mh. With all my hw, using Ethminer its 460mh, with CMD its 550Mh. Considerable difference.

Thanks,

BTC: 1Bo6YsPeHCrVRygHLJg9BwHeaLSQpppcJi
"Lost coins only make everyone else’s coins worth slightly more. Think of it as a donation to everyone."
Pages: « 1 ... 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 [104] 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 ... 1431 »
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!