Bitcoin Forum
February 05, 2023, 02:21:09 AM *
News: Latest Bitcoin Core release: 24.0.1 [Torrent]
 
   Home   Help Search Login Register More  
Pages: « 1 ... 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 [179] 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 ... 364 »
  Print  
Author Topic: SRBMiner Cryptonight AMD GPU Miner V1.9.3 - native algo switching  (Read 236661 times)
chafer99
Member
**
Offline Offline

Activity: 96
Merit: 10


View Profile
July 24, 2018, 11:31:26 AM
 #3561

SRB is best for my 4xR380 (CN7 - 740H/s per card - 1050/1600Mhz) but very unstable: "application has been blocked from accessing graphics hardware".
The same problems as default settings (1000/1500Mhz). Driver 18.5.1 whql, Win10 (1803). Claymore 11.3 is OK.

What settings for RX580 8Gb? I got only 820H/s in CN7 (intensity 60/8/2, 1430/2200Mhz).

Application blocked text = driver crash
Try with 1 thread, i had better results with 1 thread when testing on 380 4g.

56/8/2 is ok for 580 8g.
Are you using a custom strap? Memory brand?

Thanks, now intensity 56, thread 1 - 700H/s (R380 2g, samsung) looks stable. (previous 31/8/2 - 740H/s)

RX580 in default (no custom straps/mem). But not bad in Heavy algo - 1000H/s
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction.
1675563669
Hero Member
*
Offline Offline

Posts: 1675563669

View Profile Personal Message (Offline)

Ignore
1675563669
Reply with quote  #2

1675563669
Report to moderator
JuanHungLo
Hero Member
*****
Offline Offline

Activity: 935
Merit: 1001


I don't always drink...


View Profile
July 24, 2018, 11:32:35 AM
 #3562

Hi! Are there plans to support the purk algorithm?

Nope, it's not cryptonight algo.


From Purk's page:
Quote
Based on Boolberry & CryptoNote technology,...

If you read the ANN thread, algo is wild keccak...
https://bitcointalk.org/index.php?topic=3213127.0


I read, and plenty.

https://cryptonote.org/cns/cns008.txt

http://cpucoinlist.com/cryptocurrency-algorithms/wild-keccack/

The original question from UAGet was not inordinate.  It was a reasonable question.

Bull markets are born on pessimism, grow on skepticism, mature on optimism, and die on euphoria. - John Templeton
doktor83 (OP)
Hero Member
*****
Offline Offline

Activity: 2184
Merit: 625


View Profile WWW
July 24, 2018, 11:36:30 AM
 #3563

SRB is best for my 4xR380 (CN7 - 740H/s per card - 1050/1600Mhz) but very unstable: "application has been blocked from accessing graphics hardware".
The same problems as default settings (1000/1500Mhz). Driver 18.5.1 whql, Win10 (1803). Claymore 11.3 is OK.

What settings for RX580 8Gb? I got only 820H/s in CN7 (intensity 60/8/2, 1430/2200Mhz).

Application blocked text = driver crash
Try with 1 thread, i had better results with 1 thread when testing on 380 4g.

56/8/2 is ok for 580 8g.
Are you using a custom strap? Memory brand?

Thanks, now intensity 56, thread 1 - 700H/s (R380 2g, samsung) looks stable. (previous 31/8/2 - 740H/s)

RX580 in default (no custom straps/mem). But not bad in Heavy algo - 1000H/s

When i was testing r9 380 with double threads i could not go beyond intensity 28-29, it simply always crashed the driver.

SRBMiner-MULTI thread - HERE
http://www.srbminer.com
doktor83 (OP)
Hero Member
*****
Offline Offline

Activity: 2184
Merit: 625


View Profile WWW
July 24, 2018, 11:37:54 AM
 #3564

Hi! Are there plans to support the purk algorithm?

Nope, it's not cryptonight algo.


From Purk's page:
Quote
Based on Boolberry & CryptoNote technology,...

If you read the ANN thread, algo is wild keccak...
https://bitcointalk.org/index.php?topic=3213127.0


I read, and plenty.

https://cryptonote.org/cns/cns008.txt

http://cpucoinlist.com/cryptocurrency-algorithms/wild-keccack/

The original question from UAGet was not inordinate.  It was a reasonable question.

so i checked out the opencl kernel of purk and it has nothing to do with cryptonight algo.
That's why there are wildkeccak miners for purk, not cryptonight miners.

SRBMiner-MULTI thread - HERE
http://www.srbminer.com
chafer99
Member
**
Offline Offline

Activity: 96
Merit: 10


View Profile
July 24, 2018, 12:18:30 PM
Last edit: July 24, 2018, 12:47:18 PM by chafer99
 #3565

SRB is best for my 4xR380 (CN7 - 740H/s per card - 1050/1600Mhz) but very unstable: "application has been blocked from accessing graphics hardware".
The same problems as default settings (1000/1500Mhz). Driver 18.5.1 whql, Win10 (1803). Claymore 11.3 is OK.

What settings for RX580 8Gb? I got only 820H/s in CN7 (intensity 60/8/2, 1430/2200Mhz).

Application blocked text = driver crash
Try with 1 thread, i had better results with 1 thread when testing on 380 4g.

56/8/2 is ok for 580 8g.
Are you using a custom strap? Memory brand?

Thanks, now intensity 56, thread 1 - 700H/s (R380 2g, samsung) looks stable. (previous 31/8/2 - 740H/s)

RX580 in default (no custom straps/mem). But not bad in Heavy algo - 1000H/s

When i was testing r9 380 with double threads i could not go beyond intensity 28-29, it simply always crashed the driver.

at 31 intensity works, but after 4-5 hours driver crashed, (the same as 28-30 intensity).
https://imgur.com/oTgtb0p
hesido
Jr. Member
*
Offline Offline

Activity: 157
Merit: 5


View Profile
July 24, 2018, 09:42:20 PM
 #3566

SRB is best for my 4xR380 (CN7 - 740H/s per card - 1050/1600Mhz) but very unstable: "application has been blocked from accessing graphics hardware".
The same problems as default settings (1000/1500Mhz). Driver 18.5.1 whql, Win10 (1803). Claymore 11.3 is OK.

What settings for RX580 8Gb? I got only 820H/s in CN7 (intensity 60/8/2, 1430/2200Mhz).

Application blocked text = driver crash
Try with 1 thread, i had better results with 1 thread when testing on 380 4g.

56/8/2 is ok for 580 8g.
Are you using a custom strap? Memory brand?

Thanks, now intensity 56, thread 1 - 700H/s (R380 2g, samsung) looks stable. (previous 31/8/2 - 740H/s)

RX580 in default (no custom straps/mem). But not bad in Heavy algo - 1000H/s

When i was testing r9 380 with double threads i could not go beyond intensity 28-29, it simply always crashed the driver.

at 31 intensity works, but after 4-5 hours driver crashed, (the same as 28-30 intensity).
https://imgur.com/oTgtb0p


Try to adjust your OC, most instabilities I've had could be solved by throwing more voltage at the cards or reducing the frequencies.
chafer99
Member
**
Offline Offline

Activity: 96
Merit: 10


View Profile
July 25, 2018, 04:35:47 AM
 #3567

SRB is best for my 4xR380 (CN7 - 740H/s per card - 1050/1600Mhz) but very unstable: "application has been blocked from accessing graphics hardware".
The same problems as default settings (1000/1500Mhz). Driver 18.5.1 whql, Win10 (1803). Claymore 11.3 is OK.

What settings for RX580 8Gb? I got only 820H/s in CN7 (intensity 60/8/2, 1430/2200Mhz).

Application blocked text = driver crash
Try with 1 thread, i had better results with 1 thread when testing on 380 4g.

56/8/2 is ok for 580 8g.
Are you using a custom strap? Memory brand?

Thanks, now intensity 56, thread 1 - 700H/s (R380 2g, samsung) looks stable. (previous 31/8/2 - 740H/s)

RX580 in default (no custom straps/mem). But not bad in Heavy algo - 1000H/s

When i was testing r9 380 with double threads i could not go beyond intensity 28-29, it simply always crashed the driver.

at 31 intensity works, but after 4-5 hours driver crashed, (the same as 28-30 intensity).
https://imgur.com/oTgtb0p


Try to adjust your OC, most instabilities I've had could be solved by throwing more voltage at the cards or reducing the frequencies.

Yes, i tried OC, other miners, algos, etc.(claymore pow7, zcash, ethash is OK). This problem (crash driver) they only cards conected to splitter-PCIe:
https://ae01.alicdn.com/kf/HTB167XXaBUSMeJjSszeq6AKgpXae/CY-PCI-e-Express-1x-to-4-Port-1x-Switch-Multiplier-Splitter-Hub-Riser-Card-with.jpg_640x640.jpg
puntodecontrol
Newbie
*
Offline Offline

Activity: 18
Merit: 0


View Profile
July 25, 2018, 09:44:50 AM
 #3568

how do you uses this miner with undervolting? With Afterburner? Because it does not support cvddc in config.
abg00
Jr. Member
*
Offline Offline

Activity: 288
Merit: 1


View Profile
July 25, 2018, 01:06:33 PM
 #3569

how do you uses this miner with undervolting? With Afterburner? Because it does not support cvddc in config.
via bios editing
hesido
Jr. Member
*
Offline Offline

Activity: 157
Merit: 5


View Profile
July 25, 2018, 01:26:28 PM
 #3570

how do you uses this miner with undervolting? With Afterburner? Because it does not support cvddc in config.
via bios editing

Or overdriventool. bios editing is a bit too invasive.
MoX-Project
Copper Member
Newbie
*
Offline Offline

Activity: 7
Merit: 0


View Profile
July 25, 2018, 02:45:17 PM
 #3571

Hello,

We launched MoX few days ago with a new variant of CryptoNightV7 which consists of CryptoNight Lite and a tweak variant.
I'd really like to see the support added into SRBMiner as well

Please contact me about that !

Have a good day

Our github : https://github.com/mox-project/MoX
and here is the tweak in question :

#define VARIANT1_1(p) \
  do if (variant > 0) \
  { \
    const uint8_t tmp = ((const uint8_t*)(p))[11]; \
    static const uint32_t table = 0x75310; \
    const uint8_t index = (((tmp >> 8 ) & 6) | (tmp & 1)) << 1; \
    ((uint8_t*)(p))[11] = tmp ^ ((table >> index) & 0x30); \
} while(0)
abg00
Jr. Member
*
Offline Offline

Activity: 288
Merit: 1


View Profile
July 26, 2018, 06:17:25 AM
 #3572

solve trouble with variable rate rx 560 4 gb card on heavy

12 gpu rig work with 4 gb ram and 60 gb swap. rig work but with variable rate
change swap to 90 gb and rate stable high
doktor83 (OP)
Hero Member
*****
Offline Offline

Activity: 2184
Merit: 625


View Profile WWW
July 26, 2018, 08:46:42 AM
 #3573

solve trouble with variable rate rx 560 4 gb card on heavy

12 gpu rig work with 4 gb ram and 60 gb swap. rig work but with variable rate
change swap to 90 gb and rate stable high

thanks for this info, i will put it on first page in tips. 90gb insane for 12x4gb Smiley

SRBMiner-MULTI thread - HERE
http://www.srbminer.com
ripcurrent
Member
**
Offline Offline

Activity: 160
Merit: 10


View Profile
July 26, 2018, 01:41:08 PM
 #3574

Vega FEs are allergic to 18.3.4 and I'll get less hash-rate on Alloy/Heavy and CN7, on Alloy there is alot of STALE shares too, so the only viable driver is 18.6.1.

Results for a rig having 5 Vega FEs SRB Miner 1.6.4:
driver 18.6.1
CN7  = 11060 H/s
Alloy = 5670 H/s
note: Mining Alloy, on DevFee we get miner crash or error

driver 18.3.4
CN7  = 10900 H/s
Alloy = 5580 H/s
note: Mining Alloy, there is a lot of STALE shares.

Results for a rig having 5 Vega FEs SRB Miner 1.6.1:
driver 18.6.1
CN7  = 10910 H/s
Alloy = 5630 H/s

driver Blockchain Aug 23








Hello,

I was wondering if you could share how you setup your FE, I have one in which I cant seem to get working. I am trying to mine bittube with no success and if I do get it running it draws too much power.

CN7  = 10910 H/s
Alloy = 5630 H/s

=========================================
So in conclusion:
18.3.4 won't work for Vega FEs. For Alloy we have to use 1.6.1 and we get similar hashrates as blockchain driver.

Edited: The said crash/error occurs not on DevFee but right after when resuming!

Stales are not a problem if they are accepted,i guess the difficulty on the pool you use is low, and the pool sends jobs quickly, so that is why you get a lot of stales, but if they are accepted then you have no problem.
Also could you turn on logging (use --logfile log.txt in bat added) maybe i can get more info on the crash ?
If i understand you correctly only on 18.6.1 is the miner crashing, on 18.3.4 it isnt ?

Yes, I'll do this and see what we get. Regarding the drivers, I think 18.3.4 is just not working for me, even on CN7 I get lower hash-rate simiar to what I used to get on Blockchain driver about 150 H/s less or 50 H/s less on heavy/Alloy, but 18.6.1 has been very stable for me. So I avoid 18.3.4 totally. As for heavy/Alloy algo while using the SRB 1.6.4, I get GPU crash right after DevFee sometimes recovers after resetting the miner but other times I have to close the miner and restart it manually. I noticed this happened on 1.6.1 too but apparently less often. I don't have a clue what the cause could be, but I guess it might be something to do with change of algo from Alloy to DevFee and back. Unfortunately I have not had the chance to try any other heavy algo yet. I'll set the log and see what happens and come back. Thanks

popow_sergei
Newbie
*
Offline Offline

Activity: 26
Merit: 0


View Profile
July 27, 2018, 08:46:54 AM
 #3575

[2018-07-27 10:58:39] miner_result: Pool accepted result 0x00003BA4
[2018-07-27 10:58:40] json_receive: {"jsonrpc":"2.0","method":"job","params":{"blob":"07078fa3ebda05903742c8ff9e934d51d9e0fad1a9cc44e701c85362b36216ae09f59c31718c7a0 00000009bd2c15bf0563ac49bc262c4255e598dea935a0e7e6d420d5dd52501b26d1f0804","job_id":"ywbhbuO5AltTJEyfnaXOIVlIjQsP","target":"2ceb0000","id":"3131a1a8-9f70-4414-8ebf-e0befd833500","algo":"cn","variant":1}}
[2018-07-27 10:58:40] pool_have_job: Pool sent a new job (ID: ywbhbuO5AltTJEyfnaXOIVlIjQsP)
[2018-07-27 10:58:58] hashrate: GPU0: 0 H/s [BUS:19]
[2018-07-27 10:58:58] hashrate: GPU1: 0 H/s [BUS:10]
[2018-07-27 10:58:58] hashrate: GPU2: 0 H/s [BUS:13]
[2018-07-27 10:58:58] hashrate: GPU3: 0 H/s [BUS:7]
[2018-07-27 10:58:58] hashrate: GPU4: 0 H/s [BUS:16]
[2018-07-27 10:58:58] hashrate: GPU5: 0 H/s [BUS:3]
[2018-07-27 10:58:58] hashrate: Total: 0 H/s
[2018-07-27 10:59:16] watchdog: GPU0 [BUS: 19] hashing speed is 0 H/S
[2018-07-27 10:59:16] watchdog: GPU1 [BUS: 10] hashing speed is 0 H/S
[2018-07-27 10:59:16] watchdog: GPU2 [BUS: 13] hashing speed is 0 H/S
[2018-07-27 10:59:16] watchdog: GPU3 [BUS: 7] hashing speed is 0 H/S
[2018-07-27 10:59:16] watchdog: GPU4 [BUS: 16] hashing speed is 0 H/S
[2018-07-27 10:59:16] watchdog: GPU5 [BUS: 3] hashing speed is 0 H/S
[2018-07-27 11:00:16] watchdog: GPU0 [BUS: 19] hashing speed is 0 H/S
[2018-07-27 11:00:16] watchdog: GPU1 [BUS: 10] hashing speed is 0 H/S
[2018-07-27 11:00:16] watchdog: GPU2 [BUS: 13] hashing speed is 0 H/S
[2018-07-27 11:00:16] watchdog: GPU3 [BUS: 7] hashing speed is 0 H/S
[2018-07-27 11:00:16] watchdog: GPU4 [BUS: 16] hashing speed is 0 H/S
[2018-07-27 11:00:16] watchdog: GPU5 [BUS: 3] hashing speed is 0 H/S
[2018-07-27 11:00:59] hashrate: GPU0: 0 H/s [BUS:19]
[2018-07-27 11:00:59] hashrate: GPU1: 0 H/s [BUS:10]
[2018-07-27 11:00:59] hashrate: GPU2: 0 H/s [BUS:13]
[2018-07-27 11:00:59] hashrate: GPU3: 0 H/s [BUS:7]
[2018-07-27 11:00:59] hashrate: GPU4: 0 H/s [BUS:16]
[2018-07-27 11:00:59] hashrate: GPU5: 0 H/s [BUS:3]
[2018-07-27 11:00:59] hashrate: Total: 0 H/s
[2018-07-27 11:01:15] watchdog: GPU0 [BUS: 19] hashing speed is 0 H/S
[2018-07-27 11:01:15] watchdog: GPU1 [BUS: 10] hashing speed is 0 H/S
[2018-07-27 11:01:15] watchdog: GPU2 [BUS: 13] hashing speed is 0 H/S
[2018-07-27 11:01:15] watchdog: GPU3 [BUS: 7] hashing speed is 0 H/S
[2018-07-27 11:01:15] watchdog: GPU4 [BUS: 16] hashing speed is 0 H/S
[2018-07-27 11:01:15] watchdog: GPU5 [BUS: 3] hashing speed is 0 H/S
[2018-07-27 11:02:14] Stopping miner process

Huh


[2018-07-27 11:03:53] Miner version: 1.6.1
[2018-07-27 11:03:54] AMD Platform ID: 1
[2018-07-27 11:03:54] AMD platform FOUND
[2018-07-27 11:03:54] Found 6 AMD devices
[2018-07-27 11:03:54] GPU0: 687F:C3 [gfx901] [8176 MB][Intensity 112.0][W: 16][T: 2][K: 1][BUS: 19]
[2018-07-27 11:03:54] GPU1: 687F:C3 [gfx901] [8176 MB][Intensity 112.0][W: 16][T: 2][K: 1][BUS: 10]
[2018-07-27 11:03:54] GPU2: 687F:C3 [gfx901] [8176 MB][Intensity 112.0][W: 16][T: 2][K: 1][BUS: 13]
[2018-07-27 11:03:54] GPU3: 687F:C3 [gfx901] [8176 MB][Intensity 112.0][W: 16][T: 2][K: 1][BUS: 7]
[2018-07-27 11:03:54] GPU4: 687F:C3 [gfx901] [8176 MB][Intensity 112.0][W: 16][T: 2][K: 1][BUS: 16]
[2018-07-27 11:03:54] GPU5: 687F:C3 [gfx901] [8176 MB][Intensity 112.0][W: 16][T: 2][K: 1][BUS: 3]
[2018-0
cristian13
Newbie
*
Offline Offline

Activity: 18
Merit: 1


View Profile
July 27, 2018, 06:31:16 PM
 #3576

Hi,
Rig :  4 x Vega 64 / 2 x Vega 56 / 2 x RX 580 8gb
Amd Drivers : 18.6.1

I tried with low intensity, high intensity, even auto intensity and after few minutes of mining i am getting this :

https://imgur.com/a/tPFgcQv

Mining works with CastXMR.
Can anyone help ?
doktor83 (OP)
Hero Member
*****
Offline Offline

Activity: 2184
Merit: 625


View Profile WWW
July 27, 2018, 06:34:17 PM
 #3577

Hi,
Rig :  4 x Vega 64 / 2 x Vega 56 / 2 x RX 580 8gb
Amd Drivers : 18.6.1

I tried with low intensity, high intensity, even auto intensity and after few minutes of mining i am getting this :



Mining works with CastXMR.
Can anyone help ?

use latest version

SRBMiner-MULTI thread - HERE
http://www.srbminer.com
cristian13
Newbie
*
Offline Offline

Activity: 18
Merit: 1


View Profile
July 27, 2018, 06:39:53 PM
 #3578

Hi,
Rig :  4 x Vega 64 / 2 x Vega 56 / 2 x RX 580 8gb
Amd Drivers : 18.6.1

I tried with low intensity, high intensity, even auto intensity and after few minutes of mining i am getting this :

https://imgur.com/a/tPFgcQv

Mining works with CastXMR.
Can anyone help ?

use latest version

But on miner's thread, the dev says : "Don't use Adrenaline 18.7.1 drivers"
doktor83 (OP)
Hero Member
*****
Offline Offline

Activity: 2184
Merit: 625


View Profile WWW
July 27, 2018, 06:43:01 PM
 #3579

Hi,
Rig :  4 x Vega 64 / 2 x Vega 56 / 2 x RX 580 8gb
Amd Drivers : 18.6.1

I tried with low intensity, high intensity, even auto intensity and after few minutes of mining i am getting this :



Mining works with CastXMR.
Can anyone help ?

use latest version

But on miner's thread, the dev says : "Don't use Adrenaline 18.7.1 drivers"

yes, dont use it its buggy. but you wrote 18.6.1 not 18.7.1

SRBMiner-MULTI thread - HERE
http://www.srbminer.com
cristian13
Newbie
*
Offline Offline

Activity: 18
Merit: 1


View Profile
July 27, 2018, 06:56:35 PM
 #3580

Hi,
Rig :  4 x Vega 64 / 2 x Vega 56 / 2 x RX 580 8gb
Amd Drivers : 18.6.1

I tried with low intensity, high intensity, even auto intensity and after few minutes of mining i am getting this :

https://imgur.com/a/tPFgcQv

Mining works with CastXMR.
Can anyone help ?

use latest version

But on miner's thread, the dev says : "Don't use Adrenaline 18.7.1 drivers"

yes, dont use it its buggy. but you wrote 18.6.1 not 18.7.1

Yes, i am using 18.6.1
How can i get SRB Miner work ?
Thanks
Pages: « 1 ... 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 [179] 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 ... 364 »
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!