Bitcoin Forum
February 18, 2019, 11:51:16 PM *
News: Latest Bitcoin Core release: 0.17.1 [Torrent]
 
   Home   Help Search Login Register More  
Pages: « 1 ... 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541 542 543 544 545 546 547 548 549 550 551 552 553 554 555 [556] 557 558 559 560 561 562 563 564 565 566 567 568 569 570 571 572 573 574 575 576 577 578 579 580 581 582 583 584 585 586 587 588 589 590 591 592 593 594 595 596 597 598 599 600 601 602 603 604 605 606 ... 844 »
  Print  
Author Topic: OFFICIAL CGMINER mining software thread for linux/win/osx/mips/arm/r-pi 4.11.1  (Read 5776472 times)
This is a self-moderated topic. If you do not want to be moderated by the person who started this topic, create a new topic. (2 posts by 2 users deleted.)
JordanL
Donator
Sr. Member
*
Offline Offline

Activity: 294
Merit: 250



View Profile
June 21, 2013, 02:09:55 PM
 #11101

Okay so am I supposed to be running it using the exact command I did with just the ASICMINER UBSs? Which was something like this:

--icarus-options 115200:1:1 --icarus-timing 3.0=100 -S COM3 -S COM4 -S COM5 -S COM6 -S COM7 -S COM8 -S COM9

When I try that, the ASICMINERs run fine but then I also get this error:

"BitForceSC detect <2:27> get details return invalid/timed out <0:-7>"

I just noticed that at first when I had used the wrong driver (the one from the BFL page) I could see the BLFSC in the ports section of device manager, but now that I have used zadig to install the WinUSB driver (v6.1.7600.16385), it's not showing up there.

Is it supposed to be?

Again any help will be greatly appreciated!


Thanks again


Update: I left this machine mining for about an hour, with that error continuing (as the ASICMINERs where running), and it seems to have corrected itself. So far it looks like it is hashing at almost exactly 5GH/s, hopefully the error won't persist.

I've very grateful everyone who read my post and/or offered help!

0.075 tip sent with thanks to each -Redacted- and kano, spend it in good health.   Smiley
Thanks Smiley

There's been quite a few changes since 3.1.1 so if you are having trouble with 3.1.1 and the Jalapeno then you can easily get around it by running 2 cgminers as follows:

Run the 3.1.1 one above like you already are but add --usb BAS:0 so it will ignore the BFL SC's - the Jalapeno

Run a second one but 3.2.2 with a different usb setting --usb ICA:0 so it will ignore all Icarus devices (the Asicminer USB is an Icarus device)

The two wont attempt to touch the other's devices.


Wow great advice thanks again, I've bookmarked this in case I run in to any problems in the future.
1550533876
Hero Member
*
Offline Offline

Posts: 1550533876

View Profile Personal Message (Offline)

Ignore
1550533876
Reply with quote  #2

1550533876
Report to moderator
1550533876
Hero Member
*
Offline Offline

Posts: 1550533876

View Profile Personal Message (Offline)

Ignore
1550533876
Reply with quote  #2

1550533876
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
kano
Legendary
*
Offline Offline

Activity: 2730
Merit: 1103


Linux since 1997 RedHat 4


View Profile
June 21, 2013, 02:26:42 PM
 #11102

win7 64 with cgminer 3.1.1 and usb stick miners.
i cannot use more than 9 usbs since cgminer cannot work with Com10 and above. it seems it has an issue with 2 digit coms?
cgminer above 3.1.1 cannot detect any usb miner and also cannot accept the -Scomx switch!!!!

cgminer 3.1.1 absolutely works with higher # com ports - I _start_ my numbering at Com10.

If you go to 3.2.2 you need to switch to the WinUSB driver - this depreciates the com ports (and thus the -S switch).
Yeah with 3.1.1 you need to use \\.\COM10 etc for COM numbers > 9
... it's in the readme Smiley

Pool: https://kano.is Here on Bitcointalk: Forum BTC: 1KanoPb8cKYqNrswjaA8cRDk4FAS9eDMLU
FreeNode IRC: irc.freenode.net channel #kano.is Majority developer of the ckpool code
Help keep Bitcoin secure by mining on pools with full block verification on all blocks - and NO empty blocks!
xjack
Hero Member
*****
Offline Offline

Activity: 540
Merit: 500



View Profile
June 21, 2013, 04:46:12 PM
 #11103

win7 64 with cgminer 3.1.1 and usb stick miners.
i cannot use more than 9 usbs since cgminer cannot work with Com10 and above. it seems it has an issue with 2 digit coms?
cgminer above 3.1.1 cannot detect any usb miner and also cannot accept the -Scomx switch!!!!

cgminer 3.1.1 absolutely works with higher # com ports - I _start_ my numbering at Com10.

If you go to 3.2.2 you need to switch to the WinUSB driver - this depreciates the com ports (and thus the -S switch).
Yeah with 3.1.1 you need to use \\.\COM10 etc for COM numbers > 9
... it's in the readme Smiley

That's where I found it, just trying to help someone who didn't RTFM.   Wink

xjack - 1xjackDMgJCLn1LDtbgh51DYw6uRgeHVb
Reputation thread - https://bitcointalk.org/index.php?topic=482124.0
ChipGeek
Full Member
***
Offline Offline

Activity: 198
Merit: 100


View Profile
June 21, 2013, 06:48:27 PM
 #11104

Run the 3.1.1 one above like you already are but add --usb BAS:0 so it will ignore the BFL SC's - the Jalapeno
Just curious, should that be "BAJ:0" instead of "BAS:0" or does "BA<any letter>" disable all BFL ASICs?

Edit: Of course, where I said <any letter> I really meant the valid choices for BFL ASICs: [J | L | S | M ].  (Is it "M" for minirig?)

Tip jar: 1ChipGeeK7PDxaAWG4VgsTi31SfJ6peKHw
Trongersoll
Hero Member
*****
Offline Offline

Activity: 490
Merit: 500



View Profile
June 21, 2013, 07:27:59 PM
Last edit: June 21, 2013, 08:04:23 PM by Trongersoll
 #11105

ok, cgminer -n gets the following:

./cgminer -n
 [2013-06-21 15:10:01] CL Platform 0 vendor: Advanced Micro Devices, Inc.                    
 [2013-06-21 15:10:01] CL Platform 0 name: AMD Accelerated Parallel Processing                    
 [2013-06-21 15:10:01] CL Platform 0 version: OpenCL 1.2 AMD-APP (1113.2)                    
 [2013-06-21 15:10:01] Platform 0 devices: 1                    
 [2013-06-21 15:10:01]    0   Tahiti                    
 [2013-06-21 15:10:01] Failed to ADL_Adapter_ID_Get. Error -10                    
 [2013-06-21 15:10:01] This error says the device is not enabled                    
 [2013-06-21 15:10:01] Failed to ADL_Adapter_ID_Get. Error -10                    
 [2013-06-21 15:10:01] This error says the device is not enabled                    
 [2013-06-21 15:10:01] GPU 0 AMD Radeon HD 7900 Series  hardware monitoring enabled                    
 [2013-06-21 15:10:01] 1 GPU devices max detected                    
 [2013-06-21 15:10:01] USB all: found 7 devices - listing known devices                    
 [2013-06-21 15:10:01] No known USB devices

aticonfig --lsa
* 0. 01:00.0 AMD Radeon HD 7900 Series
  1. 04:00.0 AMD Radeon HD 7900 Series


There is a Sapphire 7970 in the PCIe X16  slot and a GigaByte  7950 on a PCIe X16 PCIe X16 extender which is plugged into a PCIe X16 connector on the MB which is actually X4. any ideas why I'm only seeing one card? this is running on 64 bit ubuntu 12.whatever LTS i didn't see anything specific to this in README or GPU-README
bronan
Hero Member
*****
Offline Offline

Activity: 776
Merit: 500


Lazy Lurker Reads Alot


View Profile WWW
June 21, 2013, 08:46:32 PM
 #11106

I am experiencing similer problems with the bfl asic jalapeno device
Posted on the bfgminer thread as well, this thing baffles me.

Now to make it even more interresting i do have 5 pc's in the house and all are somewhat different machines
The weirdest of all is on some of them do work without messing with winusb driver crap
Well as long as i use easyminer or bitminter client they run.

Ofcourse this would be good if i really wanted to mine on these pools.

Now if i want to run cgminer or bfgminer from command line they fail, giving messages device not found or timed out messages.
To be precise i use the same pools to test to see if it actually wants to run.

My main intel pc which i want to run the miner on simply does not work, i tried installing the winusb v6 driver which caused me numerous problems with attached usb devices as well.
I also tried another similar usb driver which gave me the same problems and not finding usb devices for mining problem
Do not get me wrong windows even with its own driver finds the device and reports it connected.

Just cgminer does not find it or times out for some reason. I get the same with bfgminer
I do however not want the programs to use any of my gpu's simply because they eat too much juice.
Krak
Hero Member
*****
Offline Offline

Activity: 591
Merit: 500



View Profile WWW
June 21, 2013, 08:51:27 PM
 #11107

Run the 3.1.1 one above like you already are but add --usb BAS:0 so it will ignore the BFL SC's - the Jalapeno
Just curious, should that be "BAJ:0" instead of "BAS:0" or does "BA<any letter>" disable all BFL ASICs?

Edit: Of course, where I said <any letter> I really meant the valid choices for BFL ASICs: [J | L | S | M ].  (Is it "M" for minirig?)
It's BAS because you're disabling that whole brand of ASICs. Also, I believe the minirig is recognized as several (8?) singles; so that's still BAS. Not sure what the L would stand for.

BTC: 1KrakenLFEFg33A4f6xpwgv3UUoxrLPuGn
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2786
Merit: 1154


Ruu \o/


View Profile WWW
June 21, 2013, 09:50:25 PM
 #11108

ok, cgminer -n gets the following:

./cgminer -n
 [2013-06-21 15:10:01] CL Platform 0 vendor: Advanced Micro Devices, Inc.                    
 [2013-06-21 15:10:01] CL Platform 0 name: AMD Accelerated Parallel Processing                    
 [2013-06-21 15:10:01] CL Platform 0 version: OpenCL 1.2 AMD-APP (1113.2)                    
 [2013-06-21 15:10:01] Platform 0 devices: 1                    
 [2013-06-21 15:10:01]    0   Tahiti                    
 [2013-06-21 15:10:01] Failed to ADL_Adapter_ID_Get. Error -10                    
 [2013-06-21 15:10:01] This error says the device is not enabled                    
 [2013-06-21 15:10:01] Failed to ADL_Adapter_ID_Get. Error -10                    
 [2013-06-21 15:10:01] This error says the device is not enabled                    
 [2013-06-21 15:10:01] GPU 0 AMD Radeon HD 7900 Series  hardware monitoring enabled                    
 [2013-06-21 15:10:01] 1 GPU devices max detected                    
 [2013-06-21 15:10:01] USB all: found 7 devices - listing known devices                    
 [2013-06-21 15:10:01] No known USB devices

aticonfig --lsa
* 0. 01:00.0 AMD Radeon HD 7900 Series
  1. 04:00.0 AMD Radeon HD 7900 Series


There is a Sapphire 7970 in the PCIe X16  slot and a GigaByte  7950 on a PCIe X16 PCIe X16 extender which is plugged into a PCIe X16 connector on the MB which is actually X4. any ideas why I'm only seeing one card? this is running on 64 bit ubuntu 12.whatever LTS i didn't see anything specific to this in README or GPU-README
SDK 2.8

Developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org, 1% Fee Solo mining at solo.ckpool.org
-ck
Trongersoll
Hero Member
*****
Offline Offline

Activity: 490
Merit: 500



View Profile
June 21, 2013, 10:58:20 PM
Last edit: June 22, 2013, 04:31:26 AM by Trongersoll
 #11109

ok, cgminer -n gets the following:

./cgminer -n
 [2013-06-21 15:10:01] CL Platform 0 vendor: Advanced Micro Devices, Inc.                    
 [2013-06-21 15:10:01] CL Platform 0 name: AMD Accelerated Parallel Processing                    
 [2013-06-21 15:10:01] CL Platform 0 version: OpenCL 1.2 AMD-APP (1113.2)                    
 [2013-06-21 15:10:01] Platform 0 devices: 1                    
 [2013-06-21 15:10:01]    0   Tahiti                    
 [2013-06-21 15:10:01] Failed to ADL_Adapter_ID_Get. Error -10                    
 [2013-06-21 15:10:01] This error says the device is not enabled                    
 [2013-06-21 15:10:01] Failed to ADL_Adapter_ID_Get. Error -10                    
 [2013-06-21 15:10:01] This error says the device is not enabled                    
 [2013-06-21 15:10:01] GPU 0 AMD Radeon HD 7900 Series  hardware monitoring enabled                    
 [2013-06-21 15:10:01] 1 GPU devices max detected                    
 [2013-06-21 15:10:01] USB all: found 7 devices - listing known devices                    
 [2013-06-21 15:10:01] No known USB devices

aticonfig --lsa
* 0. 01:00.0 AMD Radeon HD 7900 Series
  1. 04:00.0 AMD Radeon HD 7900 Series


There is a Sapphire 7970 in the PCIe X16  slot and a GigaByte  7950 on a PCIe X16 PCIe X16 extender which is plugged into a PCIe X16 connector on the MB which is actually X4. any ideas why I'm only seeing one card? this is running on 64 bit ubuntu 12.whatever LTS i didn't see anything specific to this in README or GPU-README
SDK 2.8

I was using that one:

1 )Starting Installation of AMD APPSDK v2.8 ....
2 )64-bit Operating System Found..
3 )Version Information Available in VersionInfo.txt
4 )Untar command executed succesfully, The SDK package available
5 )Untar command executed succesfully, The ICD package available
6 )SDK Binaries/Source/Samples/Other files copying to  = /opt/AMDAPP
7 )SDK files copied successfully at /opt/AMDAPP/
8 )Copying the OpenCL runtime files to System...  
9 )Updating Environment vairables...
10 )Updating LD_LIBRARY_PATH in /etc/profile
11 )Environment vairables updated successfully
12 )Initialize global environment vairables...
13 )Global environment vairables Initialized
14 )AMD APP installation Completed
15 )Reboot required to reflect the changes

is there a command line setting that i need to make? I'm just using: ./cgminer

or do i need to set something with aticonfig?

or do i need a dummy plug to enable the board?
pirate1
Member
**
Offline Offline

Activity: 75
Merit: 10



View Profile
June 22, 2013, 12:06:32 AM
 #11110

Can someone break down for me exactly how you do a configuration file?  Is that all you need to do to compile and enable a BFL ASIC?  I know about changing the driver and have zadig.  I have been mining with my fpga and a couple of video cards with the newest version of cgminer.  cgminer-3.2.2  I just can't get it working with the ASIC.  I know I have to enable bflsc but need to know exactly how to do that.  I realize it is probably something simple but I am at a loss and have gone through all the read me files.  Do I just take the example conf file and change it to a conf file and input my info along with the line "--enable-bflsc" : "enabled"  Huh  As you can tell I need some help.

As long as I wake up breathing it's all a bonus.  Sometimes not much of a bonus but still a bonus.
Krak
Hero Member
*****
Offline Offline

Activity: 591
Merit: 500



View Profile WWW
June 22, 2013, 01:32:34 AM
 #11111

Can someone break down for me exactly how you do a configuration file?  Is that all you need to do to compile and enable a BFL ASIC?  I know about changing the driver and have zadig.  I have been mining with my fpga and a couple of video cards with the newest version of cgminer.  cgminer-3.2.2  I just can't get it working with the ASIC.  I know I have to enable bflsc but need to know exactly how to do that.  I realize it is probably something simple but I am at a loss and have gone through all the read me files.  Do I just take the example conf file and change it to a conf file and input my info along with the line "--enable-bflsc" : "enabled"  Huh  As you can tell I need some help.
That's a compile option that's already enabled in ckolivas' binaries. You don't need that unless you compile it yourself. With 3.2.2 and the right drivers installed, it should instantly recognize it when you plug it in.

BTC: 1KrakenLFEFg33A4f6xpwgv3UUoxrLPuGn
pirate1
Member
**
Offline Offline

Activity: 75
Merit: 10



View Profile
June 22, 2013, 01:38:30 AM
 #11112

It is giving me the message--  BitForceSc detect (2:1) Warning unknown firmware 'FIRMWARE: 1.2:40x00'     
I did use zadig and changed the driver.

As long as I wake up breathing it's all a bonus.  Sometimes not much of a bonus but still a bonus.
Polyatomic
Sr. Member
****
Offline Offline

Activity: 256
Merit: 250


View Profile
June 22, 2013, 02:14:39 AM
Last edit: June 22, 2013, 10:49:57 PM by Polyatomic
 #11113




Using difficulty 128 is HW value too high . Any feedback would be helpful.
kano
Legendary
*
Offline Offline

Activity: 2730
Merit: 1103


Linux since 1997 RedHat 4


View Profile
June 22, 2013, 04:40:20 AM
 #11114

It is giving me the message--  BitForceSc detect (2:1) Warning unknown firmware 'FIRMWARE: 1.2:40x00'    
I did use zadig and changed the driver.
Coz you are using 3.2.2

We only got to access hardware with the new firmware after 3.2.2 was released

Current git for 1.2.x firmware.

Pool: https://kano.is Here on Bitcointalk: Forum BTC: 1KanoPb8cKYqNrswjaA8cRDk4FAS9eDMLU
FreeNode IRC: irc.freenode.net channel #kano.is Majority developer of the ckpool code
Help keep Bitcoin secure by mining on pools with full block verification on all blocks - and NO empty blocks!
kano
Legendary
*
Offline Offline

Activity: 2730
Merit: 1103


Linux since 1997 RedHat 4


View Profile
June 22, 2013, 04:47:57 AM
 #11115

Run the 3.1.1 one above like you already are but add --usb BAS:0 so it will ignore the BFL SC's - the Jalapeno
Just curious, should that be "BAJ:0" instead of "BAS:0" or does "BA<any letter>" disable all BFL ASICs?

Edit: Of course, where I said <any letter> I really meant the valid choices for BFL ASICs: [J | L | S | M ].  (Is it "M" for minirig?)

The usbutils drivers are BAS, BFL, MMQ, AVA, ICA
The name you use there is the driver abbreviation, not the device abbreviation shown on the screen.
Thus when you say BAS:0 it refers to the BFL SC driver and disables trying to mine on all BAX (X = J, L, S and M)
There were 4 SC ASIC products, Jalapeno, LIttle Single, Single and Minirig - so that answers what the letters stand for.

There are other ways to select with --usb as per the README ...

... where it also says "... with BAS:n you can limit how many BFL ASIC devices will
be checked, but you cannot limit the number of each type of BFL ASIC"

Pool: https://kano.is Here on Bitcointalk: Forum BTC: 1KanoPb8cKYqNrswjaA8cRDk4FAS9eDMLU
FreeNode IRC: irc.freenode.net channel #kano.is Majority developer of the ckpool code
Help keep Bitcoin secure by mining on pools with full block verification on all blocks - and NO empty blocks!
pirate1
Member
**
Offline Offline

Activity: 75
Merit: 10



View Profile
June 22, 2013, 11:08:02 AM
 #11116

Thanks for the answer kano but I am not sure I understand.  I found the "driver-bflsc.c" under your git hub.  Is this what I need?  If not, where do I find the current git for 1.2.x firmware?  Do I need to install git and learn how to use it?  Can I just copy and paste the driver somewhere? 

As long as I wake up breathing it's all a bonus.  Sometimes not much of a bonus but still a bonus.
rsbriggs
Full Member
***
Offline Offline

Activity: 369
Merit: 100



View Profile
June 22, 2013, 05:17:47 PM
 #11117

@Polyatomic

Difficulty being much too high for hash rate.  At 800 Mh/s you should be doing difficulty 2 or 4 only.  

But if determined running at difficulty 128, must remembering only about 1 share in every 128 shares calculating being sent.  At 2% error rate, will be averaging  2.5 HW errors for each share submitting.  Suggesting to lower difficulty much.


rsbriggs
Full Member
***
Offline Offline

Activity: 369
Merit: 100



View Profile
June 22, 2013, 05:19:47 PM
 #11118

Thanks for the answer kano but I am not sure I understand.  I found the "driver-bflsc.c" under your git hub.  Is this what I need?  If not, where do I find the current git for 1.2.x firmware?  Do I need to install git and learn how to use it?  Can I just copy and paste the driver somewhere? 

That being source code file, not driver.  You are wanting compiled version of cgminer using that version unless planning to compile software your own self.

FiatKiller
Sr. Member
****
Offline Offline

Activity: 378
Merit: 250


View Profile
June 22, 2013, 06:07:41 PM
 #11119

Wow, what an ordeal... just got my first Jale and I was caught in a catch-22 because cg 3.2.2 has issues with ASIC Block Eruptors(which I already had). If I ran 3.1.1, it would crash from the Jale. If I ran 3.2.2, it could not start the BEs. After two hours of screwing around with different ideas, I finally came up with calling out the specific devices for each version of cg with --usb 1:31 (in my case) for the Jale with cg 3.2.2 and --usb 1:4,1:6,1:7 etc. for the BEs with 3.1.1

3.1.1 does seem to have issues either randomly or with more than a dozen or so devices with the vcp driver. Certain ones won't initialize randomly. I may move a few to a different system since I have 18 total. I did try the usb driver with 3.2.2 and no go. Went back to vcp driver and only 16 of them show-up. Did not try a reboot yet. Just happy to be hashing with double digits for now.  :-D   Also, noticed on reboot previously that the com port numbers can change(which sucks). Not a biggie since I can just leave the PC on for a week straight between reboots.

LTC: LdxgJQLUdr8hZ79BV5AYbxkBUdaXctXAPi
MoonCoin Gambling: https://coin-horse.com/MON/
Subo1977
Sr. Member
****
Offline Offline

Activity: 344
Merit: 250


Flixxo - Watch, Share, Earn!


View Profile
June 22, 2013, 08:54:44 PM
 #11120

are there somewhere nightly builds of cgminer for win?

X       ▄▄█████████▄▄
    ▄██▀▀         ▀▀██▄
  ▄██▀              ▀██▄
 ▄██     ██▄▄          ██▄
▄██      █████▄▄        ██▄
██       ████████▄▄      ██
██       ███████████▄    ██
██       ██████████▀     ██
▀██      ███████▀       ██▀
 ▀██     ████▀         ██▀
  ▀██▄   █▀          ▄██▀
    ▀██▄▄         ▄▄██▀
       ▀▀█████████▀▀
.flixxo    X▄████████████████████▄
██████████████████████
██████████████████████
████████████▀▀███████
█████▀████░░░░░░▄████
█████░░░░░░░░░░▄█████
█████▄░░░░░░░░░░██████
██████░░░░░░░░░███████
███████░░░░░░▄████████
████▄▄░░░░▄▄██████████
██████████████████████
██████████████████████
▀████████████████████▀
▄████████████████████▄
██████████████████████
█████████▀█▀██████████
██████▀▀▀▀▀████████
██████▄▄░░▄▄▄░░███████
████████░░███░░███████
████████░░░░░░▀███████
████████░░███▄░░██████
██████▀▀░░▀▀▀░░░██████
██████▄▄▄▄▄▄███████
█████████▄█▄██████████
██████████████████████
▀████████████████████▀
X[[]]X
Pages: « 1 ... 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541 542 543 544 545 546 547 548 549 550 551 552 553 554 555 [556] 557 558 559 560 561 562 563 564 565 566 567 568 569 570 571 572 573 574 575 576 577 578 579 580 581 582 583 584 585 586 587 588 589 590 591 592 593 594 595 596 597 598 599 600 601 602 603 604 605 606 ... 844 »
  Print  
 
Jump to:  

Bitcointalk.org is not available or authorized for sale. Do not believe any fake listings.
Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!